7. QGIS GUI

QGIS GUI(Graphical User Interface)는 다음 그림에서 보이는 대로입니다. (노란색 원 안의 1부터 5까지의 숫자는 QGIS GUI의 주요 구성 요소를 나타냅니다. 차례대로 설명하겠습니다.)

../../../_images/startup.png

그림 7.1 알래스카 예시 데이터를 불러온 QGIS GUI

참고

사용자의 운영체제 및 창 관리자에 따라 창 양식(제목 바 등등)이 다르게 나타날 수도 있습니다.

The main QGIS GUI (그림 7.1) consists of five components / component types:

  1. 메뉴 바

  2. 툴바

  3. 패널

  4. 맵 뷰

  5. 상태 바

이들에 대한 자세한 설명을 보려면 아래로 스크롤하세요.

7.2. 패널 및 툴바

View 메뉴에서 (또는 kde Settings 에서) QGIS 위젯(Panels ‣)과 툴바(Toolbars ‣)를 켜고 끌 수 있습니다. 사용자가 메뉴 바 또는 툴바를 오른쪽 클릭해서 어떤 항목이라도 선택해서 활성화/비활성화시킬 수 있습니다. QGIS 인터페이스 안이라면, 각 패널 또는 툴바를 사용자가 편리하게 사용할 수 있는 어떤 위치로든 이동시킬 수 있습니다. 또한 핵심 또는 외부 플러그인 을 활성화하면 목록이 늘어날 수도 있습니다.

7.2.1. 툴바

메뉴와 동일한 기능들을 대부분 툴바를 통해서 접근할 수 있으며, 또한 맵과 상호 작용할 수 있는 추가적인 도구들도 제공합니다. 툴바의 각 항목은 팝업 도움말을 표시할 수 있습니다. 항목 위에 마우스를 가져 가면 해당 도구의 목적을 설명하는 짧은 텍스트를 표시합니다.

사용자의 필요에 따라 모든 툴바를 이동할 수 있습니다. 또는, 오른쪽 클릭하면 나오는 컨텍스트 메뉴를 통해, 아니면 툴바 위에 마우스를 가져 가서 툴바를 꺼버릴 수도 있습니다.

../../../_images/toolbars1.png

그림 7.2 툴바 메뉴

툴바를 복구하기

사용자가 실수로 툴바를 꺼버렸을 경우, View ‣ Toolbars ‣ 메뉴 옵션을 (또는 kde Settings ‣ Toolbars ‣ 를) 선택해서 다시 켤 수 있습니다. 어떤 이유로 인터페이스에서 툴바가 (또는 다른 위젯이) 완전히 사라졌을 경우, 초기 GUI 복구 를 보면 복구에 필요한 팁을 얻을 수 있습니다.

7.2.2. 패널

QGIS는 수많은 패널을 제공하고 있습니다. 패널이란 좀 더 복잡한 작업을 수행하기 위해 사용자와 상호작용(옵션 선택, 체크박스 체크, 값 입력 등등)할 수 있는 특별한 위젯입니다.

../../../_images/panels.png

그림 7.3 패널 메뉴

다음은 QGIS가 제공하는 기본 패널 목록입니다:

7.3. 맵 뷰

7.3.1. 맵 뷰 탐구

맵 캔버스 라고도 불리는 맵 뷰는 QGIS의 《총화》입니다. 이 영역에 맵을 표시하기 때문이죠. 이 창에 표시되는 맵은 사용자가 불러온 레이어에 적용한 (심볼, 라벨, 가시화 여부 등등) 렌더링을 반영할 것입니다. 또한 레이어 및 해당 프로젝트의 좌표계(Coordinate Reference System)에 따라 달라집니다.

사용자가 아무것도 없는 QGIS 프로젝트에 레이어를 추가하면 (데이터 열기 참조) QGIS는 자동적으로 레이어의 좌표계를 찾습니다. 만약 프로젝트에 기본적으로 설정된 좌표계가 (프로젝트 좌표계 참조) 레이어 좌표계와 다를 경우, 프로젝트 좌표계로 레이어 범위를 《실시간(on-the-fly)》 으로 변환한 다음 레이어 범위로 맵 뷰를 확대하거나 축소합니다. 프로젝트에 이미 레이어가 존재하는 경우라면 맵 캔버스 크기 조정은 일어나지 않으므로 현재 맵 캔버스의 범위 안에 들어오는 피처들만 표시될 것입니다.

맵 뷰 창이 활성화된 상태라면:

  • pan Pan Map 도구, 화살표 키, 또는 Space 키나 마우스의 가운데 버튼 또는 마우스 휠을 누른 채 마우스를 움직이면 디스플레이 영역을 맵의 다른 지역으로 옮기며 이동할 수 있습니다.

  • zoomIn Zoom InzoomOut Zoom Out 전용 도구를 사용해서 맵을 확대/축소할 수 있습니다. 또 마우스 휠을 앞쪽으로 돌리면 확대, 뒤쪽으로 돌리면 축소됩니다. 확대/축소는 마우스 커서 위치를 중심으로 이루어집니다.

    Settings ‣ Options ‣ Map tools 메뉴에서 Zoom factor 를 사용자 지정할 수 있습니다.

  • 불러온 레이어들의 전체 영역으로 (zoomFullExtent Zoom Full) 확대/축소할 수 있고, 어느 레이어 영역으로 (zoomToLayer Zoom to Layer) 확대/축소할 수도 있으며, 선택한 피처들의 영역으로 (zoomToSelected Zoom to Selection) 확대/축소할 수도 있습니다.

  • zoomLastZoom LastzoomNextZoom Next 버튼이나 마우스의 전/후 버튼을 이용하면 캔버스 뷰 이력을 통해 전/후를 찾아갈 수 있습니다.

QGIS는 기본적으로 Layers 패널에 단단히 연결된 (《메인 맵》이라고도 하는) 단일 맵 뷰를 엽니다. 메인 맵은 사용자가 Layers 패널 영역에서 작업한 변경 사항을 자동적으로 반영합니다. 그러나 사용자 데이터셋을 다르게 렌더링해서 미리보기할 수 있게 해주는 추가적인 맵 뷰를 메인 맵과 나란히 놓고 볼 수도 있습니다. 이 추가 맵 뷰는 메인 맵과 마찬가지로 Layers 패널에서 설정한 레이어 속성을 따르지만, 각 맵 뷰는 각각 다른 축척과 영역에서 각각 다른 레이어 모음을 표시할 수 있습니다.

7.3.2. 추가 맵 뷰 설정

새 맵 뷰를 추가하려면 View ‣ newMap New Map View 메뉴 항목을 선택하십시오. QGIS에 레이어 렌더링을 표시하는 새 플로팅 위젯(floating widget)이 추가될 것입니다. 사용자가 필요한 개수만큼 맵 뷰를 추가할 수 있습니다. 이 추가 맵 뷰들을 나란히 배열하거나 아래 위로 쌓아놓는 방식으로 계속 부유(float)하는 상태로 유지할 수 있습니다.

../../../_images/map_views.png

그림 7.4 서로 다른 설정을 가진 다중 맵 뷰들

추가된 맵 캔버스의 상단에는 다음 기능을 가진 툴바가 존재합니다:

  • zoomFullExtent Zoom Full, zoomToSelected Zoom to SelectionzoomToLayer Zoom to Layer : 뷰 내부를 이동할 수 있습니다.

  • showMapTheme Set View Theme : 맵 뷰 안에 표시되는 맵 테마 를 선택할 수 있습니다. 테마를 (none) 으로 설정하면, 뷰가 Layers 패널의 변경 사항을 반영할 것입니다.

  • options View settings : 맵 뷰를 설정합니다.

    • radioButtonOn Synchronize view center with main map: 축척을 변경하지 않으면서 맵 뷰들의 중앙을 동기화합니다. 이 옵션을 활성화하면 메인 맵의 중앙을 따르는 오버뷰 형식 또는 확대 맵을 사용할 수 있습니다.

    • radioButtonOff Synchronize view to selection: 선택한 피처로 확대/축소 기능과 동일합니다.

    • Scale : 축척을 설정합니다.

    • Rotation : 맵의 기울기를 설정합니다.

    • Magnification : 맵의 확대 비율을 설정합니다.

    • unchecked Synchronize scale : 메인 맵 축척과 동기화합니다. 이 옵션을 활성화하면 Scale factor 를 적용할 수 있습니다. 이를 테면 언제나 메인 맵 축척의 2배 축척인 뷰를 설정할 수 있게 됩니다.

    • checkbox Show annotations : 주석을 표시합니다.

    • checkbox Show cursor position : 커서 위치를 보여줍니다.

    • unchecked Show main canvas extent : 메인 캔버스의 범위를 표시합니다.

    • checkbox Show labels: 이 옵션을 해제하면 표시된 레이어의 속성에 라벨이 설정되어 있더라도 라벨을 보이지 않게 할 수 있습니다.

    • Change map CRS… : 좌표계를 변경합니다.

    • Rename view… : 뷰의 명칭을 다시 설정합니다.

7.3.3. 맵 뷰 내보내기

인쇄 조판기 또는 보고서 의 고급 기능을 이용하면 사용자가 만든 맵을 조판해서 여러 포맷으로 내보낼 수 있습니다. 물론 현재 렌더링을 조판하지 않은 채로 그대로 내보낼 수도 있습니다. 이런 맵의 즉석 《스크린샷》 에는 몇 가지 편리한 장점이 있습니다.

맵 캔버스를 현재 렌더링 그대로 내보내려면:

  1. Project ‣ Import/Export 메뉴 항목을 선택하십시오.

  2. 사용자의 산출물 포맷에 따라, 다음 중 하나를 선택하십시오:

    • saveMapAsImage Export Map to Image…

    • or saveAsPDF Export Map to PDF…

이 2개의 도구는 일반적인 옵션 모음을 제공합니다. 다음 대화창이 열리면:

../../../_images/saveMapAsImage.png

그림 7.5 맵을 이미지로 저장 대화창

  1. Extent : 내보낼 범위를 선택합니다. 현재 뷰의 범위(기본값)일 수도 있고, 레이어의 범위 또는 맵 캔버스 위에 그린 사용자 지정 범위일 수도 있습니다. 선택한 영역의 좌표가 표시되며, 직접 편집할 수 있습니다.

  2. Scale : 맵의 축척을 입력하거나 사전에 정의된 축척 가운데 선택할 수 있습니다. 축척을 변경하면 내보낼 범위의 크기를 (중앙을 기준으로) 다시 조정할 것입니다.

  3. Resolution : 산출물의 해상도를 설정합니다.

  4. Output widthOutput height : 이미지의 너비와 높이를 픽셀 단위로 조정합니다. 기본적으로 현재 해상도와 범위를 기준으로 하지만, 이들을 사용자 지정하면 맵 범위의 크기를 (중앙을 기준으로) 다시 조정할 것입니다. 크기 비율을 고정시킬 수 있는데, 캔버스 위에 사용자 지정 범위를 그릴 경우 매우 편리할 수도 있습니다.

  5. checkbox Draw active decorations: 이 옵션을 활성화하면 지도 장식 (축척 막대, 제목, 그리드, 방위표 등등)을 맵과 함께 내보낼 수 있습니다.

  6. checkbox Draw annotations : 이 옵션을 활성화하면 어떤 주석 도 내보낼 수 있습니다.

  7. checkbox Append georeference information (embedded or via world file): 산출물 포맷에 따라, 사용자 이미지가 저장되는 폴더에 이미지와 동일한 명칭의 월드 파일(PNG 이미지의 경우 확장자 PNGW, JPG 이미지의 경우 확장자 JPGW, …)을 저장합니다. PDF 포맷의 경우 PDF 파일에 정보를 내장합니다.

  8. PDF로 내보낼 경우, Save map as PDF… 대화창에서 더 많은 옵션을 설정할 수 있습니다:

    ../../../_images/saveMapAsPDF.png

    그림 7.6 맵을 PDF로 저장 대화창

    • checkbox Export RDF metadata : 문서의 제목, 저자, 날짜, 설명 등등을 RDF 메타데이터로 내보냅니다.

    • unchecked Create Geospatial PDF (GeoPDF): 이 옵션을 활성화하면 지리참조 PDF 파일 을 생성합니다. (GDAL 버전 3 이상이 필요합니다.) 다음과 같은 옵션을 설정할 수 있습니다:

      • Format : GeoPDF 포맷을 선택합니다.

      • checkbox Include vector feature information : 산출물 GeoPDF 파일에 있는 맵 안에 가시화된 피처들의 모든 도형 및 속성 정보를 GeoPDF 파일에 내장시킬 것입니다.

      참고

      QGIS 3.10 버전부터, GDAL 3를 설치한 경우 GeoPDF 파일을 데이터소스로 이용할 수도 있습니다. QGIS의 GeoPDF 지원에 대해 더 자세한 정보를 알고 싶다면 https://north-road.com/2019/09/03/qgis-3-10-loves-geopdf/ 페이지를 참조하세요.

    • Rasterize map : 맵을 래스터화합니다.

    • checkbox Simplify geometries to reduce output file size: 맵을 내보내는 도중, 내보내기 해상도에서 눈에 띄지 않는 불필요한 꼭짓점들을 제거해서 도형을 단순화시킬 것입니다. (예를 들어 내보내기 해상도가 300 dpi 인 경우 서로의 거리가 1/600 inch 미만인 꼭짓점을 제거할 것입니다.) 이렇게 하면 내보내기 파일의 용량 및 복잡도를 줄일 수 있습니다. (다른 응용 프로그램에서 대용량 파일을 불러올 수 없을 수도 있기 때문입니다.)

    • Text export: 텍스트 라벨을 제대로 된 텍스트 오브젝트로 내보낼지(Always export texts as text objects) 경로로만 내보낼지(Always export texts as paths) 설정합니다. 텍스트 라벨을 텍스트 객체로 내보낼 경우 (잉크스케이프 같은) 외부 응용 프로그램에서 일반 텍스트처럼 편집할 수 있습니다. 하지만 렌더링의 질이 하락하는 부작용이 있습니다. 게다가 버퍼 같은 특정 텍스트 설정이 적용된 경우 렌더링 오류가 생길 수도 있습니다. 경로로 내보내기를 추천하는 이유입니다.

  9. Save : 파일의 위치, 명칭, 포맷을 선택합니다.

    이미지로 내보내는 경우, Copy to clipboard 버튼을 클릭해서 대화창에서 설정한 대로의 예상 산출물을 클립보드로 복사한 다음 리브레오피스GIMP 등 다른 응용 프로그램에 맵을 붙여넣기할 수도 있습니다.

7.4. 3D 맵 뷰

3D 맵 뷰를 통해 3D 가시화를 지원합니다. View ‣ new3DMap New 3D Map View 메뉴를 선택하면 3D 맵 뷰를 생성해서 열 수 있습니다. 해당 메뉴를 클릭하면 QGIS의 플로팅 패널이 나타날 것입니다. 이 패널을 다른 창에 도킹시킬 수 있습니다.

먼저, 3D 맵 뷰는 2D 메인 맵 캔버스와 동일한 범위와 뷰를 표시합니다. 이 뷰를 3D로 변환시키는 데 사용할 수 있는 탐색(navigation) 도구 모음이 있습니다.

../../../_images/3dmapview.png

그림 7.7 3D 맵 뷰 대화창

3D 맵 뷰 최상단에 다음과 같은 도구들이 있습니다:

  • pan Camera control: 카메라의 각도와 방향을 동일하게 유지하면서 뷰를 이동합니다.

  • zoomFullExtent Zoom Full: 뷰의 크기를 전체 레이어 범위로 다시 조정합니다.

  • 3dNavigation Toggle on-screen notification: (맵 뷰를 더 쉽게 조정하기 위한) 탐색 위젯을 켜고 끕니다.

  • identify Identify: 지형에서 클릭한 포인트 또는 클릭한 3D 피처(들)에 대한 정보를 반환합니다. 더 자세한 정보는 피처 식별 를 참조하세요.

  • measure Measurement line: 두 포인트 사이의 수평 거리를 측정합니다.

  • play Animations: 애니메이션 플레이어 위젯을 켜고 끕니다.

  • saveMapAsImage Save as image…: 현재 뷰를 이미지 파일 포맷으로 내보냅니다.

  • options Configure: 맵 뷰를 설정 합니다.

7.4.2. 애니메이션 생성하기

애니메이션은 특정 시간대 카메라 위치의 키프레임 모음을 기반으로 합니다. 애니메이션을 생성하려면:

  1. play Animations 도구를 켜면 애니메이션 플레이어 위젯이 나타납니다.

  2. signPlus Add keyframe 버튼을 클릭하고 Keyframe time 을 초 단위로 입력하면, Keyframe 콤보박스가 타임셋(time set)을 표시합니다.

  3. 탐색 도구를 이용해서 현재 키프레임 시간과 관련된 위치로 카메라를 이동합니다.

  4. 이전 단계를 반복해서 필요한 만큼 많은 (시간과 위치를 가진) 키프레임을 추가합니다.

  5. 애니메이션을 미리보기하려면 play 버튼을 클릭하십시오. QGIS가 타임셋에 맞춰 카메라 위치/회전을 사용해 이를 각 키프레임 사이에 삽입해서 신(scene)을 생성할 것입니다. 애니메이션을 위한 다양한 Interpolation 모드를 사용할 수 있습니다. (linear, inQuad, outQuad, inCirc 등등… 더 자세한 내용은 https://doc.qt.io/qt-5/qeasingcurve.html#EasingFunction-typedef 를 참조하세요.)

    타임 슬라이드 막대를 움직여서도 애니메이션을 미리보기할 수 있습니다. refresh Repeat 버튼을 켜면 애니메이션을 반복해서 실행할 것입니다. 이때 애니메이션을 멈추려면 play 버튼을 클릭하십시오.

Keyframe 목록을 이용해서 카메라의 서로 다른 뷰들을 탐색할 수 있습니다. 타임셋이 활성화된 상태에서 맵 뷰를 변경하면 자동적으로 관련된 위치를 업데이트할 것입니다. symbologyEdit Edit keyframe 버튼으로 키프레임의 시간을 편집하거나 signMinus Remove keyframe 버튼으로 키프레임을 삭제할 수도 있습니다.

fileSave Export animation frames 버튼을 클릭하면 신을 나타내는 이미지 모음을 생성합니다. Template 에서 파일명을, Output directory 에서 저장할 디렉터리를 지정할 수 있을 뿐만 아니라, Frames per second 에서 초당 프레임 개수를, Output widthOutput height 에서 산출 이미지의 너비와 높이도 설정할 수 있습니다.

7.4.3. 신(scene) 설정

3D 맵 뷰는 기본 설정값으로 열리지만, 이를 사용자 지정할 수 있습니다. 3D 캔버스 패널 최상단의 options Configure… 버튼을 클릭하면 3D configuration 창이 열립니다.

../../../_images/3dmapconfiguration.png

그림 7.8 3D 맵 설정 대화창

3D 설정 대화창에는 3D 신을 미세 조정할 수 있는 다양한 옵션들이 있습니다:

  • 카메라의 Field of view: 파노라마 신을 생성할 수 있습니다. 기본값은 45°입니다.

  • Terrain: 자세한 내용으로 들어가기 전에, 3D 뷰에서의 지형은 지형 타일들의 위계로 표현되기 때문에 카메라가 지형에 가까이 갈수록 세부 사항이 충분하지 않은 기존 타일은 더 자세한 정보를 가진 더 작은 타일로 대체된다는 사실을 기억해야 합니다. 각 타일은 표고 래스터 레이어에서 추출한 메시 도형과 2D 맵 레이어에서 추출한 텍스처로 이루어져 있습니다.

    • 표고 지형의 Type 으로 다음 가운데 하나를 선택할 수 있습니다:

    • Elevation: 래스터 레이어를 사용해서 지형을 생성합니다. 해당 레이어는 표고를 나타내는 밴드를 담고 있어야 합니다.

    • Vertical scale: 수직축 용 축척 인자를 설정합니다. 축척을 증가시키면 지형의 높이를 과장하게 될 것입니다.

    • Tile resolution: 각 타일에 사용하기 위해 지형 래스터 레이어에서 얼마나 많은 샘플을 추출할지 설정합니다. 16px이란 값은 각 타일의 도형이 16x16 픽셀의 표고 샘플로 이루어질 것이라는 의미입니다. 해상도 값이 높을수록 더 자세한 지형 타일을 생성하지만, 그에 비례해서 렌더링 복잡도도 더 높아집니다.

    • Skirt height: 가끔 지형 타일들 사이에서 작은 틈이 보일 수도 있습니다. 이 값을 높이면 지형 타일 주위로 수직 장벽(《스커트》)을 추가해서 틈을 숨길 것입니다.

    • Map theme: 미리 정의된 맵 테마 에서 맵 뷰에 표시될 레이어 모음을 선택할 수 있도록 해줍니다.

  • unchecked Terrain shading: 사용자가 지형 렌더링 방법을 선택할 수 있습니다.

    • 셰이딩(shading) 비활성화 - 맵 텍스처만을 기준으로 지형 색상을 결정합니다.

    • 셰이딩 활성화 - 퐁 셰이딩 모델(Phong’s shading model)을 이용, 맵 텍스처, 지형 법선 벡터(normal vector), 신 조명(들) 및 지형 소재(terrain material)의 AmbientSpecular 색상과 Shininess 를 계산해서 지형 색상을 결정합니다.

  • Lights: 8개의 점조명(point light)을 추가할 수 있습니다. 각 조명의 위치(X, Y and Z), 색상(Color), 광도(Intensity) 및 감쇠율(Attenuation)을 설정할 수 있습니다.

    ../../../_images/3dmapconfiguration_lights.png

    그림 7.9 3D 맵 조명 설정 대화창

  • Map tile resolution: 2D 맵 이미지의 너비와 높이를 지형 타일의 텍스처로 이용합니다. 256px이란 각 타일을 256x256 픽셀 크기의 이미지로 렌더링할 것이라는 의미입니다. 픽셀값이 높을수록 더 자세한 지형 타일을 생성하지만, 그에 비례해서 렌더링 복잡도도 더 높아집니다.

  • Max. screen error: 지형 타일을 더 자세한 타일로 (그리고 그 반대로) 교체하는 역치(threshold)를 결정합니다. 즉 3D 뷰가 얼마나 빨리 더 상세한 타일을 사용할 것인가를 결정하는 것이죠. 이 값이 낮을수록 신의 세부 사항이 더 자세해지지만, 그에 반비례해서 렌더링 복잡도는 더 높아집니다.

  • Max. ground error: 지형 타일이 더 상세한 타일로 더이상 나눠지지 않는 해상도를 결정합니다. (타일을 나눠봤자 더 자세한 사항이 나오지도 않겠지요.) 이 값은 타일 위계의 심도(depth)를 제한합니다. 이 값이 낮을수록 위계가 늘어나지만, 그에 반비례해서 렌더링 복잡도는 더 높아집니다.

  • Zoom labels: 확대/축소 단계의 개수를 보여줍니다. (Map tile resolutionMax. ground error 값에 따라 달라집니다.)

  • unchecked Show labels: 맵 라벨을 켜고 끕니다.

  • unchecked Show map tile info: 지형 타일에 대한 경계(border) 및 타일 개수를 포함하는 정보를 켜고 끕니다. (지형에 문제가 있을 때 파악하고 해결하는 데 유용합니다.)

  • unchecked Show bounding boxes: 지형 타일의 3D 경계 상자(bounding box)를 켜고 끕니다. (지형에 문제가 있을 때 파악하고 해결하는 데 유용합니다.)

  • unchecked Show camera’s view center : 카메라 뷰의 중앙 표시를 켜고 끕니다.

7.4.4. 3D 벡터 레이어

벡터 레이어 속성 패널의 3D View 부분에 있는 Enable 3D Renderer 를 활성화하면 3D 맵 뷰에 표고값을 가진 벡터 레이어를 표시할 수 있습니다. 3D 벡터 레이어의 렌더링을 조정할 수 있는 몇 가지 옵션이 존재합니다.

7.5. 상태 바

상태 바는 맵 뷰 및 처리 중이거나 처리할 수 있는 동작에 대한 일반적인 정보를 제공하며, 맵 뷰를 관리할 수 있는 도구들도 들어 있습니다.

상태 바의 좌측에 있는 위치 탐색란(locator bar)은 즉각적인 검색 위젯으로 사용자가 QGIS에서 어느 기능이나 옵션을 찾아 실행할 수 있게 해줍니다. 사용자가 찾고 있는 항목과 관련된 (명칭, 태그, 키워드 등등) 텍스트를 입력하기만 하면, 입력 중에 실시간으로 업데이트되는 목록을 볼 수 있습니다. 위치 탐색 필터 를 사용해서 검색 범위를 제한할 수도 있습니다. search 버튼을 클릭해서 필터 가운데 하나를 선택한 다음, Configure 항목을 클릭하면 일반 설정 창이 열립니다.

위치 탐색란 옆의 영역에는 필요한 경우 (예를 들어 레이어에 있는 피처를 선택했다거나, 레이어를 제거했다거나 하는) 사용자가 수행한 작업의 요약이 표시되거나, 사용자가 마우스를 가져다 댄 도구에 대한 자세한 설명이 표시될 것입니다. (모든 도구가 자세한 설명을 지원하지는 않습니다.)

래스터 레이어에서 통계를 수집하거나, 공간 처리 알고리즘을 실행하거나, 맵 뷰에서 레이어 몇 개를 렌더링하는 등 시간이 걸리는 작업의 경우, 상태 바에 진행 막대를 표시해서 해당 작업의 현재 진행 상태를 보여줍니다.

tracking Coordinate 옵션은 맵 뷰 상에서 마우스의 움직임을 따라가며 커서의 현재 위치를 표시합니다. Project ‣ Properties… ‣ General 탭에서 이 기능에 사용할 단위(와 정확도)를 설정할 수 있습니다. 텍스트 란 왼쪽에 있는 작은 버튼을 클릭하면 이 Coordinate 옵션과, 사용자가 맵을 이동하거나 확대/축소할 때 맵 뷰의 현재 좌하단 및 우상단 포인트의 좌표를 맵 단위로 표시하는 extents Extents 옵션을 서로 바꿔가며 켜고 끌 수 있습니다.

좌표 표시 옆에 Scale 표시가 보입니다. 이 표시는 맵 뷰의 축척을 보여줍니다. 사용자가 맵 뷰에 적용할 사전 정의된/사용자 지정 축척 을 선택할 수 있는 축척 선택기(scale selector)가 있습니다.

축척 표시 오른쪽에 있는 lockedGray 버튼을 클릭하면 확대경으로 확대/축소할 수 있도록 축척을 고정시킵니다. 맵 축척을 변경하지 않고 맵을 확대할 수 있어, 라벨 및 심볼의 위치를 정밀하게 조정하는 데 편리합니다. 확대 수준은 백분율로 표시됩니다. 만약 Magnifier 가 100% 수준이라면 현재 맵은 확대되지 않은 상태입니다. 또한 Settings ‣ Options ‣ Rendering ‣ Rendering behavior 메뉴에서 확대 기본값을 정의할 수 있습니다. 이 옵션은 고해상도 모니터에서 심볼이 너무 작아지지 않게 하는 데 매우 유용합니다.

확대경(Magnifier) 오른쪽에서 맵 뷰의 시계 방향 회전량(rotation)을 도(˚) 단위로 정의할 수 있습니다.

상태 바의 우측에 레이어가 맵 뷰에 렌더링되는 것을 일시적으로 막는 데 쓰이는 작은 체크박스가 있습니다. (렌더링 작업 을 참조하십시오.)

렌더링 기능 오른쪽에 현재 투영 좌표계를 보여주는 projectionEnabled EPSG:code 버튼이 있습니다. 이 아이콘을 클릭하면 Project Properties 대화창이 열려, 맵 뷰에 또다른 좌표계를 적용할 수 있습니다.

그 옆의 messageLog Messages 버튼을 클릭하면 기저 프로세스(QGIS 실행, 플러그인 불러오기, 공간 처리 도구 등등)에 대한 정보를 알려주는 Log Messages Panel 을 엽니다.

플러그인 관리자 설정 에 따라, 상태 바 우측에 pluginNew 새로 설치할 수 있는 플러그인 또는 pluginUpgrade 업데이트할 수 있는 플러그인을 알려주는 아이콘이 나타날 때가 있습니다. 해당 아이콘을 클릭하면 플러그인 관리자 대화창이 열립니다.

사용자 맵 캔버스의 정확한 축척을 계산하기

QGIS 실행 시, 기본 좌표계는 WGS 84 (EPSG 4326) 이고 단위는 도(˚)입니다. 즉 QGIS는 사용자 레이어의 모든 좌표를 도 단위로 해석할 것이란 뜻입니다. 정확한 축척값을 얻으려면 이 설정을, 예를 들어 Project ‣ Properties… 메뉴의 General 탭에서 미터 단위로 직접 변경하거나, 또는 앞에서 설명한 projectionEnabled EPSG:code 아이콘을 통해 변경할 수도 있습니다. 후자의 경우, 프로젝트의 투영체가 지정하는 대로 (예를 들어 +units=us-ft 처럼) 단위를 설정하게 됩니다.

Settings ‣ Options ‣ CRS 메뉴 옵션에서 실행 시 기본적으로 적용할 좌표계를 설정할 수 있다는 사실을 알아두십시오.