11. 일반 도구

11.1. 컨텍스트 도움말

특정 문제에 대해 도움말이 필요한 경우, 대부분의 대화창에 있는 Help 버튼을 통해 최신 사용자 지침서에서 대응하는 페이지를 볼 수 있습니다. 이때 외부 플러그인의 경우 전용 웹페이지로 이동할 수도 있다는 사실을 기억하십시오.

11.2. 패널

QGIS는 작업할 수 있는 패널 여러 개를 기본적으로 제공합니다. 이 패널들 가운데 일부는 이 절에서 설명하고 있으며, 이 문서의 다른 부분들에서 다른 패널들의 정보를 찾아볼 수도 있습니다. View ‣ Panels ‣ 메뉴에서 QGIS가 제공하는 기본 패널들의 전체 목록을 볼 수 있으며, 패널 에서 이를 언급하고 있습니다.

11.2.1. 레이어 패널

Layers 패널(통칭 《맵 범례》)에서 프로젝트가 보유한 모든 레이어 목록을 볼 수 있으며, 레이어의 가시성을 관리할 수 있습니다. Ctrl+1 키 조합을 눌러 레이어를 보이게 하거나 숨길 수 있습니다. Z 순서를 변경하기 위해 범례 안에서 레이어를 선택해, 위아래로 드래그할 수 있습니다. Z 순서란 범례 목록 상위에 위치한 레이어가 범례 목록 하위에 있는 레이어를 덮는다는 뜻입니다.

참고

레이어 정렬 패널을 통해 범례의 Z 순서를 무시하게 할 수 있습니다.

레이어 패널 상단에 있는 툴바의 기능은 다음과 같습니다:

  • symbology Open the layer styling dock (F7): 레이어 스타일 작업 패널을 켜고 끕니다.

  • addGroup Add new group: 새 레이어 그룹을 만듭니다.

  • showMapTheme Manage Map Themes: 레이어의 가시성을 제어하고 서로 다른 맵 테마에 레이어를 배치합니다.

  • filterMap Filter Legend by Map Content: 맵에 표시되며 피처가 현재 맵 캔버스 안에 들어오는 레이어만, 레이어 패널에 레이어 스타일을 렌더링합니다. 해당 사항이 없을 경우, 일반적인 NULL 심볼로 표시합니다. 레이어 심볼을 바탕으로 하는 이 방식으로 어떤 레이어의 어떤 피처 유형이 사용자의 관심 지역에 들어오는지 손쉽게 알아볼 수 있습니다.

  • expressionFilter Filter Legend by Expression: 선택한 레이어 트리에서, 조건을 만족시키는 피처가 없는 레이어의 스타일을 제거하는 표현식을 적용하도록 해줍니다. 예를 들어 기준으로 설정한 다른 레이어의 영역/피처 내부에 있는 피처만 강조하도록 할 수도 있습니다. 드롭다운 목록에서 현재 적용된 표현식을 편집하고 삭제할 수 있습니다.

  • expandTree Expand All 또는 collapseTree Collapse All: 레이어 패널에 있는 모든 레이어 및 그룹을 펼치거나 접을 수 있습니다.

  • removeLayer Remove Layer/Group: 현재 선택한 레이어나 그룹을 제거합니다.

../../../_images/layer_toolbar.png

그림 11.1 레이어 패널의 레이어 툴바

참고

레이어 패널을 관리하는 도구들은 인쇄 조판기의 맵과 범례 항목을 배치하는 데에도 쓸 수 있습니다.

11.2.1.1. 맵 테마 환경 설정하기

showMapTheme Manage Map Themes 드롭다운 버튼은 Layers 패널에 있는 레이어들의 가시성을 조작할 수 있는 편리한 도구들을 제공합니다.

  • showAllLayers Show All Layers

  • hideAllLayers Hide All Layers

  • showSelectedLayers Show Selected Layers

  • hideSelectedLayers Hide Selected Layers

  • hideDeselectedLayers Hide Deselected Layers

레이어 가시성을 간단하게 조작할 수 있을 뿐만 아니라, showMapTheme Manage Map Themes 메뉴는 범례에서 맵 테마 를 환경 설정할 수 있으며 맵 테마를 변경할 수도 있습니다. 맵 테마는 다음과 같은 정보를 기록하는 현재 맵의 스냅샷 입니다:

  • Layers 패널에서 보이도록 설정된 레이어들

  • 그리고 각 가시 레이어의:

    • 레이어에 적용된 스타일 관련 사항

    • Layers 패널에서 노드 항목이 체크된 레이어 같은, 스타일의 가시 범주. 이는 단일 심볼 렌더링이 아니라 심볼 에 적용됩니다.

    • 레이어 노드(들) 및 레이어가 위치한 그룹(들)의 펼쳐진/접힌 상태

맵 테마를 생성하려면:

  1. 표시하고자 하는 레이어를 체크하십시오.

  2. 평소대로 레이어 속성(심볼, 다이어그램, 라벨 등등)을 환경 설정하십시오.

  3. 하단에 있는 Style ‣ 메뉴를 펼친 다음 Add… 를 클릭해서 설정을 프로젝트에 내장된 새 스타일 로 저장하십시오.

    참고

    맵 테마는 현재 속성의 상세 사항을 기억하지 않습니다. 스타일 명칭 참조 정보만 저장하기 때문에, 이 스타일이 활성화된 상태에서 (예를 들어 심볼 렌더링을 변경하는 것과 같이) 레이어에 수정 사항을 적용할 때마다 맵 테마는 새 정보로 업데이트됩니다.

  4. 다른 레이어에 대해서도 필요한 만큼 이전 단계를 반복합니다.

  5. 적용할 수 있다면, Layers 패널에서 그룹 또는 가시 레이어 노드를 펼치거나 접습니다.

  6. 패널 상단에 있는 showMapTheme Manage Map Themes 버튼을 클릭한 다음, Add Theme… 를 클릭해서 테마를 추가합니다.

  7. 맵 테마의 명칭을 입력한 다음 OK 를 클릭합니다.

새 테마가 showMapTheme 드롭다운 메뉴의 목록 하단에 추가됩니다.

사용자가 필요한 만큼 제한없이 맵 테마를 생성할 수 있습니다. 위와 같이 정의한 기존 맵 테마 내용 가운데 맵 범례에 있는 현재 조합(가시 레이어, 활성 스타일, 맵 범례 노드)과 일치하지 않는 것이 하나라도 있다면, Add Theme… 를 클릭해서 새 맵 테마를 생성하거나, Replace Theme ‣ 메뉴를 사용해서 맵 테마를 업데이트하십시오. Remove Current Theme 버튼을 클릭하면 활성 테마를 삭제합니다.

맵 테마는 미리 환경 설정해놓은 서로 다른 조합들을 빠르게 바꾸는 데 유용합니다. 목록에서 맵 테마를 선택하면 해당 테마의 조합을 복구합니다. 인쇄 조판기에서도 환경 설정해놓은 테마에 접근할 수 있기 때문에, 특정 테마에 기반하면서도 현재 주 캔버스의 렌더링에 독립적인 서로 다른 맵 항목들을 생성할 수 있습니다. (맵 항목 레이어 참조)

11.2.1.2. 레이어 패널의 컨텍스트 메뉴 개요

툴바 아래 있는 레이어 패널의 주 요소는 프로젝트에 추가된 벡터 또는 래스터 레이어 목록을 담은 프레임으로, 이 레이어들을 그룹화할 수도 있습니다. 패널에서 어떤 항목을 선택하느냐에 따라 오른쪽 클릭으로 나타나는 컨텍스트 메뉴의 내용이 달라집니다. 컨텍스트 메뉴의 옵션들은 다음과 같습니다.

옵션

벡터 레이어

래스터 레이어

Group

zoomToLayer Zoom to Layer/Group

checkbox

checkbox

checkbox

zoomToLayer Zoom to Selection

checkbox

inOverview Show in Overview

checkbox

checkbox

Show Feature Count

checkbox

Copy Layer/Group

checkbox

checkbox

checkbox

Rename Layer/Group

checkbox

checkbox

checkbox

zoomActual Zoom to Native Resolution (100%)

checkbox

Stretch Using Current Extent

checkbox

dbManager Update SQL Layer…

checkbox

addGroup Add Group

checkbox

duplicateLayer Duplicate Layer

checkbox

checkbox

removeLayer Remove Layer/Group…

checkbox

checkbox

checkbox

Move Out of Group

checkbox

checkbox

Move to Top

checkbox

checkbox

checkbox

Check and all its Parents

checkbox

checkbox

Group Selected

checkbox

checkbox

openTable Open Attribute Table

checkbox

toggleEditing Toggle Editing

checkbox

allEdits Current Edits ‣

checkbox

Filter…

checkbox

Set Layer Scale Visibility…

checkbox

checkbox

Zoom to Visible Scale

checkbox

checkbox

Set CRS ‣

checkbox

checkbox

‣ Set Layer/Group CRS…

checkbox

checkbox

checkbox

‣ Set Project CRS from Layer

checkbox

checkbox

Set Group WMS Data…

checkbox

unchecked Mutually Exclusive Group

checkbox

Check and all its children (Ctrl-click)

checkbox

Uncheck and all its children (Ctrl-click)

checkbox

Make Permanent

checkbox

Export ‣

checkbox

checkbox

checkbox

‣ Save As…

checkbox

‣ Save Features As…

checkbox

‣ Save Selected Features As…

checkbox

‣ Save As Layer Definition File…

checkbox

checkbox

checkbox

‣ Save As QGIS Layer Style File…

checkbox

checkbox

Styles ‣

checkbox

checkbox

‣ Copy Style

checkbox

checkbox

‣ Paste Style

checkbox

checkbox

checkbox

‣ Add…

checkbox

checkbox

‣ Rename Current…

checkbox

checkbox

‣ Edit symbol…

checkbox

‣ Copy Symbol

checkbox

‣ Paste Symbol

checkbox

Properties…

checkbox

checkbox

표: 레이어 패널의 컨텍스트 메뉴 항목

GRASS 벡터 레이어의 경우, toggleEditing Toggle editing 을 사용할 수 없습니다. GRASS 벡터 레이어 편집에 대한 정보는 GRASS 벡터 레이어 디지타이즈 및 편집하기 를 참조하십시오.

11.2.1.3. 그룹 및 레이어와 대화형 작업

범례 창에 있는 레이어들을 그룹화할 수 있습니다. 그룹화하는 데에는 다음 두 가지 방법이 있습니다:

  1. folder 아이콘을 클릭해서 새 그룹을 추가합니다. 그룹의 명칭을 입력한 다음 Enter 를 누르십시오. 이제 기존 레이어를 클릭한 채로 그룹으로 드래그하십시오.

  2. 레이어 몇 개를 선택하고, 범례 창을 오른쪽 클릭한 다음 Group Selected 를 선택하십시오. 새 그룹이 만들어지고 선택한 레이어들이 이 그룹으로 자동 이동될 것입니다.

레이어를 그룹에서 꺼내려면, 레이어를 밖으로 드래그하거나 또는 오른쪽 클릭한 다음 Move Out of Group 을 선택하면 됩니다. 레이어가 원래 있던 그룹과 동일한 수준으로 이동합니다. 또, 그룹을 다른 그룹 안에 넣을 수도 있습니다. 레이어가 그룹 안의 그룹에 있는 경우, Move Out of Group 메뉴는 레이어를 모든 그룹에서 꺼낼 것입니다.

레이어 패널 최상단으로 그룹 또는 레이어를 이동시키려면, 최상단으로 드래그하거나 Move to Top 메뉴를 선택하십시오. 그룹 안에 들어 있는 레이어에 이 메뉴 옵션을 사용하면, 해당 레이어가 들어 있는 현재 그룹 안에서 최상단으로 이동합니다.

그룹의 체크박스를 클릭하면 그룹에서 체크된 레이어를 표시하거나 숨길 것입니다. Ctrl 키를 누른 채 체크박스를 클릭하면 그룹 및 하위그룹에 있는 모든 레이어를 켜거나 끕니다.

체크된/체크 해제된 레이어를 Ctrl 키를 누른 채 클릭하면 해당 레이어와 모든 부모 레이어를 체크 해제/체크합니다.

Mutually Exclusive Group 옵션을 활성화하면 한 번에 한 레이어만 보이는 그룹을 생성할 수 있습니다. 그룹 내부의 어떤 레이어를 보이도록 설정할 때마다 다른 레이어들은 보이지 않도록 꺼질 것입니다.

왼쪽 마우스 버튼으로 레이어를 선택할 때 Ctrl 키를 누르고 있으면 하나 이상의 레이어 또는 그룹을 동시에 선택할 수 있습니다. 그 다음 선택한 모든 레이어를 동시에 새 그룹으로 이동시킬 수 있습니다.

Ctrl 키로 항목 몇 개를 선택한 다음 Ctrl+D 를 누르면 하나 이상의 레이어 또는 그룹을 한 번에 삭제할 수도 있습니다. 이렇게 하면, 선택한 모든 레이어 또는 그룹이 레이어 목록에서 한꺼번에 제거될 것입니다.

11.2.1.3.1. 표시자(indicator) 아이콘을 통한 레이어 및 그룹에 대한 상세 정보

레이어/그룹에 대한 상세 정보를 제공하기 위한 아이콘이 Layers 패널에 있는 레이어 또는 그룹 옆에 나타나는 경우가 종종 있습니다. 다음과 같은 심볼로 나타납니다:

  • toggleEditing : 레이어가 편집 상태여서 사용자가 데이터를 수정할 수 있다는 것을 나타냅니다.

  • editableEdits : 편집 중인 레이어에 일부 저장되지 않은 변경 사항이 있다는 것을 나타냅니다.

  • indicatorFilter : 레이어에 필터 가 적용됐다는 것을 나타냅니다. 이 아이콘 위에 마우스를 가져가면 필터 표현식을 볼 수 있고, 더블클릭하면 설정을 업데이트할 수 있습니다.

  • indicatorEmbedded: 내장된 그룹 또는 레이어 및 원래 프로젝트 파일의 경로를 식별합니다.

  • indicatorBadLayer : 프로젝트 파일을 열 때 데이터소스를 사용할 수 없는 레이어를 식별합니다. 아이콘을 클릭하면 소스 경로를 업데이트할 수 있습니다.

  • indicatorMemory : 레이어가 임시 스크래치 레이어 이며 현재 프로젝트를 닫으면 레이어의 내용이 사라질 것이라는 사실을 알려줍니다. 데이터 손실을 피하고 레이어를 항구적으로 만들려면, 아이콘을 클릭해서 레이어를 QGIS가 지원하는 OGR 벡터 유형 가운데 하나로 저장하십시오.

  • indicatorNoCRS : 좌표계가 없거나, 알려지지 않은 좌표계를 가진 레이어를 식별합니다.

11.2.1.4. 벡터 레이어 스타일 편집 작업

레이어 패널에서 레이어 렌더링을 쉽고 빠르게 변경할 수 있는 빠른 방법이 있습니다. 벡터 레이어를 오른쪽 클릭한 다음 목록에서 Styles ‣ 를 선택하면 다음과 같은 작업을 할 수 있습니다:

  • 레이어에 현재 적용된 스타일 을 확인합니다. 해당 레이어에 여러 스타일을 정의했을 경우, 한 스타일에서 다른 스타일로 바꿔가면 맵 캔버스에서 해당 레이어의 렌더링이 자동적으로 업데이트되는 걸 볼 수 있습니다.

  • 현재 스타일의 일부분 또는 전부를 복사해서, 이 스타일을 적용할 수 있는 다른 레이어에 붙여넣을 수 있습니다.

    손쉽게 레이어 스타일 공유

    컨텍스트 메뉴에서, 레이어의 스타일을 복사해 그룹 또는 레이어 집합에 붙여 넣을 수 있습니다. 원본 레이어와 동일한 유형(벡터 또는 래스터)인 모든 레이어에, 그리고 벡터 레이어의 경우 동일한 도형 유형(포인트, 라인, 폴리곤)을 가진 모든 레이어에 스타일을 적용합니다.

  • 현재 스타일의 명칭을 변경하거나, (사실 현재 스타일의 복사본인) 새 스타일을 추가하거나, 또는 (다중 스타일을 사용할 수 있는 경우) 현재 스타일을 삭제할 수 있습니다.

참고

이 작업들은 래스터 또는 메시 레이어에 대해서도 똑같이 쓸 수 있습니다.

  • update the symbol color using a Color Wheel. For convenience, the recently used colors are also available at the bottom of the color wheel.

  • Edit symbol…: 심볼 선택기 대화창을 열고 피처 심볼을 변경합니다. (심볼, 크기, 색상 등등)

(범주, 등급 또는 규칙 기반 을 기반으로 하는) 범주 심볼 유형을 사용하는 경우, 범주 단계 항목의 컨텍스트 메뉴에서 앞에서 언급한 심볼 수준 옵션을 사용할 수 있습니다. 또 toggleAllLayers Toggle Items, showAllLayers Show All ItemshideAllLayers Hide All Items 항목을 통해 피처의 모든 범주의 가시성을 전환할 수도 있습니다. 이렇게 하면 항목들을 하나하나 체크 또는 체크 해제하지 않아도 됩니다.

범주의 잎(leaf) 항목을 더블 클릭하면 Symbol Selector 대화창을 엽니다.

11.2.2. 레이어 스타일 작업 패널

Layer Styling 패널은 (Ctrl+3 키 조합으로 활성화할 수 있으며) Layer Properties 대화창의 기능 가운데 일부를 실행하는 단축키입니다. 이 패널은 레이어 속성 대화창을 열지 않고도 레이어의 렌더링 방식과 습성을 정의해서 그에 따라 시각화할 수 있는 빠르고 손쉬운 방법을 제공합니다.

레이어 스타일 작업 패널은 《모달(modal)》 대화상자가 레이어 속성 대화창을 가리는 일을 방지할 뿐만 아니라, 이미 대부분의 스타일 기능(색상 선택기, 효과 속성, 규칙 편집, 라벨 대체 등등)을 내장하고 있기 때문에 대화창들이 화면을 덮어버리는 일도 방지해줍니다. 예를 들어, 레이어 스타일 작업 패널 내부의 색상 버튼을 클릭하면 색상 선택기가 개별 대화창이 아니라 레이어 스타일 패널 안에서 열립니다.

레이어 패널에 있는 현재 레이어들의 드롭다운 목록에서 항목을 선택한 다음:

  • 래스터 레이어의 경우 레이어의 symbology Symbology, transparency Transparency, rasterHistogram Histogram 을 설정합니다. 이 옵션들은 래스터 속성 대화창 과 동일합니다.

  • 벡터 레이어의 경우 레이어의 symbology Symbology, 3d 3D View, labeling Labels 를 설정합니다. 이 옵션들은 벡터 속성 대화창 과 동일합니다.

  • stylePreset Style Manager 에서 관련 스타일(들)을 관리합니다. (자세한 내용은 사용자 지정 스타일 관리하기 를 참조하세요.)

  • 사용자가 현재 프로젝트의 레이어 스타일에 적용한 변경 history History 전체를 추적합니다. 따라서 이력 목록에 있는 어떤 상태든 선택하고 Apply 버튼을 클릭하면 해당 상태 이후의 변경 사항을 취소하고 해당 상태를 복구할 수 있습니다.

이 패널의 또다른 강력한 기능은 checkbox Live update 체크박스입니다. 이 옵션을 활성화하면 사용자가 변경 사항을 만드는 대로 맵 캔버스에 해당 변경 사항을 즉시 렌더링하기 때문에, 더 이상 Apply 버튼을 클릭할 필요가 없습니다.

../../../_images/layer_styling.png

그림 11.2 레이어 스타일 작업 패털에서 레이어 심볼 정의하기

레이어 스타일 작업 패널에 사용자 지정 탭 추가하기

PyQGIS 를 사용하면, 레이어 스타일 작업 패널에 레이어 속성 정보 관리를 위한 새로운 탭을 설정할 수 있습니다. 다음의 예를 참고하세요: https://nathanw.net/2016/06/29/qgis-style-dock-part-2-plugin-panels/

11.2.3. 레이어 순서 패널

QGIS 맵 캔버스에 보여지는 레이어는 기본적으로 Layers 패널에 있는 레이어 순서를 따라 렌더링됩니다. 패널에서 레이어가 위에 있을수록 맵 뷰에서도 위에 렌더링됩니다. (따라서 더 잘 보입니다.)

View ‣ Panels ‣ 메뉴에서 또는 Ctrl+9 키 조합으로 활성화할 수 있는 Layer Order 패널을 통해 레이어 패널에 있는 순서에 독립적으로 레이어를 렌더링하는 순서를 정의할 수 있습니다. 레이어 목록 아래 있는 checkbox Control rendering order 옵션을 체크하고 사용자가 원하는 대로 패널에 있는 레이어들을 재정렬하십시오. 예를 들어 범례에 독립적인 레이어 순서 정의하기 그림을 보십시오. 레이어 패널에 있는 레이어 위치에도 불구하고 airports 피처가 alaska 폴리곤 위에 표시되고 있습니다.

checkbox Control rendering order 옵션을 해제하면 기본 동작대로 레이어 페널의 순서를 따르게 됩니다.

../../../_images/layer_order.png

그림 11.3 범례에 독립적인 레이어 순서 정의하기

11.2.4. 오버뷰 패널

Overview 패널(Ctrl+8)은 일부 레이어들의 전체 범위를 보여주는 맵입니다. 오버뷰 맵은 Layer 메뉴 또는 레이어 컨텍스트 메뉴에서 Show in Overview 옵션을 켠 레이어들로 채워집니다. 이 뷰 안에는현재 맵 범위를 나타내는 빨간 사각형이 있습니다. 이 사각형을 통해 사용자가 현재 맵의 어느 영역을 보고 있는지 한 눈에 알 수 있습니다. 오버뷰에서 현재 범위를 보여주는 빨간색 사각형을 클릭&드래그하면, 그에 따라 주 맵 뷰도 자동적으로 업데이트됩니다.

맵 오버뷰가 표시하는 레이어에 라벨이 적용돼 있더라도 맵 오버뷰에는 라벨이 렌더링되지 않는다는 사실을 기억하십시오.

11.2.5. 로그 메시지 패널

몇몇 작업을 불러오거나 공간 처리할 때, messageLog Log Messages Panel 을 통해 서로 다른 탭에 나타나는 메시지를 추적하고 지켜볼 수 있습니다. 하단 상태 바의 가장 오른쪽에 있는 아이콘을 클릭하면 이 패널을 활성화할수 있습니다.

11.2.6. 실행 취소/재실행 패널

Undo/Redo 패널(Ctrl+5)은 편집 중인 각 레이어에 대해 실행된 모든 작업 목록을 표시해서, 위쪽에 있는 작업을 선택하는것만으로도 작업 모음을 빠르게 실행 취소시킬 수 있습니다. 더 자세한 내용은 실행 취소 및 재실행 편집 을 참조하세요.

11.2.7. 통계 요약 패널

Statistics 패널(Ctrl+6)은 모든 벡터 레이어에 대한 요약된 정보를 표시할 수 있습니다. 이 패널에서 선택할 수있는 것은 다음과 같습니다:

  • 통계를 계산할 벡터 레이어

  • 사용할 열(column) 또는 expression 표현식

  • 대화창 우하단의 드롭다운 버튼을 통해 반환할 통계 정보. 레이어 필드 유형에 따라 (또는 표현식의 값 유형에 따라) 사용할 수 있는 통계 정보는 다음과 같습니다:

통계 정보

문자열

정수

실수

날짜

개수

checkbox

checkbox

checkbox

checkbox

고유 값(Distinct Value) 개수

checkbox

checkbox

누락 값(Missing value) 개수

checkbox

checkbox

합계

checkbox

checkbox

평균

checkbox

checkbox

checkbox

표준 편차

checkbox

checkbox

표본 표준 편차

checkbox

checkbox

최소값

checkbox

checkbox

checkbox

checkbox

최대값

checkbox

checkbox

checkbox

checkbox

범위

checkbox

checkbox

checkbox

소수 기준(Minority)

checkbox

checkbox

다수 기준(Majority)

checkbox

checkbox

다양도(Variety)

checkbox

checkbox

제1사분위수(First Quartile)

checkbox

checkbox

제3사분위수(Third Quartile)

checkbox

checkbox

사분위간 범위(Inter Quartile Range)

checkbox

checkbox

최소 길이

checkbox

최대 길이

checkbox

표: 필드 유형에 따라 사용할 수 있는 통계

통계 요약 정보는:

  • 전체 레이어의 통계를 반환하거나, checkbox selected features only 옵션으로 선택한 피처에 대한 통계만 반환할 수도 있습니다.

  • 기저 데이터소스가 바뀔 경우 (예를 들어 피처/필드를 새로 추가하거나, 피처/필드를 제거하거나, 속성을 수정하는 경우) refresh 버튼을 통해 통계를 다시 계산할 수 있습니다.

  • editCopy 클립보드로 복사한 다음 다른 응용 프로그램에 테이블로 붙여넣을 수 있습니다.

../../../_images/statistical_summary.png

그림 11.4 필드에 대한 통계 정보 종류 표시

11.3. 프로젝트 내포 작업

서로 다른 프로젝트들에 있는 여러 레이어들을 동일한 스타일로 유지하고자 할 경우가 있습니다. 이 레이어들을 위한 기본 스타일 을 생성할 수도 있고, 또는 다른 프로젝트로부터 레이어들을 내포시켜 수고를 줄일 수도 있습니다.

기존 프로젝트로부터 레이어 및 그룹을 내포시키면 스타일과 관련해 몇몇 장점이 생깁니다:

  • 모든 유형의 (벡터 또는 래스터, 로컬 또는 온라인 등등) 레이어를 추가할 수 있습니다.

  • 그룹 및 레이어를 불러오면, 서로 다른 사용자 프로젝트에 있는 《배경》 레이어들의 트리 구조를 동일하게 유지할 수 있습니다.

  • 내포한 레이어를 편집할 수 있지만, 심볼, 라벨, 양식, 기본값, 동작 등과 같은 레이어 속성을 변경할 수는 없습니다. 이 습성은 프로젝트 전체에서 일관성을 보장합니다.

  • 원본 프로젝트에 있는 항목을 수정하면, 변경 사항이 다른 모든 프로젝트로 전파됩니다.

사용자 프로젝트에 다른 프로젝트 파일의 내용을 삽입하고자 할 경우, Layer ‣ Embed Layers and Groups 메뉴를 선택한 다음:

  1. 버튼을 클릭해서 프로젝트를 찾으십시오. 프로젝트의 내용을 (삽입할 레이어 및 그룹 선택 그림 참조) 볼 수 있습니다.

  2. Ctrl (또는 osx Cmd) 키를 누른 채 사용자가 가져오려 하는 레이어 및 그룹을 클릭하십시오.

  3. OK 를 클릭합니다.

Layers 패널에 선택한 레이어 및 그룹을 삽입하고 맵 캔버스에 가시화할 것입니다. 내포된 항목의 명칭 옆에 indicatorEmbedded 아이콘이 추가되고, 그 위에 마우스를 가져가면 원본 프로젝트 파일 경로를 보여주는 툴팁을 표시합니다.

../../../_images/embed_dialog.png

그림 11.5 삽입할 레이어 및 그룹 선택

다른 모든 레이어와 마찬가지로, 내포 레이어를 오른쪽 클릭하고 removeLayer Remove 를 선택하면 프로젝트에서 제거할 수 있습니다.

내포 레이어의 렌더링 변경

원본 프로젝트 파일을 변경하지 않는 이상, 내포 레이어의 렌더링을 변경할 수는 없습니다. 하지만, 내포 레이어를 오른쪽 클릭하고 Duplicate 를 선택하면 완전히 동일하며 원본 프로젝트에 독립적인 레이어를 생성합니다. 그 다음 링크된 레이어를 안전하게 제거할 수 있습니다.

11.4. 맵 캔버스 작업

11.4.1. 렌더링 작업

기본적으로 QGIS는 맵 캔버스를 업데이트할 때마다 모든 가시 레이어를 렌더링합니다. 다음과 같은 이벤트가 맵 캔버스 업데이트를 유발합니다:

  • 레이어 추가

  • 맵 이동 또는 확대/축소

  • QGIS 창 크기 변경

  • 레이어(들)의 가시성 변경

사용자는 QGIS 상에서 다양한 방법으로 렌더링 과정을 제어할 수 있습니다.

11.4.1.1. 축척에 따른 렌더링

축척에 의존적인 렌더링을 통해 어떤 (래스터 또는 벡터) 레이어를 가시화하는 최소 및 최대 축척을 설정할 수 있습니다. 축척 의존 렌더링을 설정하려면, 범례에 있는 레이어를 더블 클릭해서 Properties 대화창을 여십시오. Rendering 탭에서 checkbox Scale dependent visibility 를 체크한 다음, Minimum (exclusive)Maximum (inclusive) 축척값을 입력합니다.

레이어 패널에서 레이어에 대한 축척 의존 가시성을 활성화시킬 수도 있습니다. 레이어를 오른쪽 클릭한다음 컨텍스트 메뉴에서 Set Layer Scale Visibility 를 선택하십시오.

mapIdentification Set to current canvas scale 버튼을 클릭하면 가시성 범위의 한계값으로 현재 맵 캔버스의 축척을 쓸 수 있습니다.

참고

맵 축척이 가시성 축척 범위를 벗어나서 맵 캔버스에 레이어를 렌더링하지 않는 경우, 레이어 패널에서 해당 레이어를 회색조로 표시하며 해당 레이어의 컨텍스트 메뉴에 새로운 옵션 Zoom to Visible Scale 이 추가됩니다. 이 옵션을 선택하면 해당 레이어가 가시화될 가장 가까운 축척값으로 맵을 확대/축소할 것입니다.

11.4.1.2. 맵 렌더링 제어

다음에서 설명하는 대로, 다양한 방법으로 맵 렌더링을 제어할 수 있습니다.

11.4.1.2.1. 렌더링 보류

렌더링 작업을 보류하려면, 상태 바 우하단에 있는 checkbox Render 체크박스를 클릭하십시오. checkbox Render 체크박스를 해제하면, QGIS 는 렌더링 작업 에서 설명하는 어떤 이벤트에도 대응하지 않고 캔버스를 다시 그리지 않습니다. 사용자가 렌더링을 보류하길 원할 수도 있는 경우는 다음과 같습니다:

  • 많은 레이어를 추가하고 렌더링 전에 심볼 작업을 하고자 하는 경우

  • 하나 이상의 대용량 레이어를 추가하고 렌더링 전에 축척 의존성을 설정하고자 하는 경우

  • 하나 이상의 대용량 레이어를 추가하고 렌더링 전에 특정한 뷰로 확대/축소하고자 하는 경우

  • 이런 경우들의 조합

checkbox Render 체크박스를 체크하면 렌더링을 활성화해서 즉시 맵 캔버스를 업데이트하게 됩니다.

11.4.1.2.2. 레이어 추가 옵션 설정

새 레이어를 불러올 때 항상 그리지 않도록 하는 옵션을 설정할 수 있습니다. 즉 맵에 레이어가 추가되어도,기본적으로 범례의 가시성 체크박스는 해제된 상태일 것이라는 뜻입니다. 이 옵션을 설정하려면, Settings ‣ Options 메뉴 옵션을 선택한 다음 Rendering 탭을 클릭하십시오. checkbox By default new layers added to the map should be displayed 체크박스를 해제하십시오. 이후 맵에 추가되는 모든 레이어가 기본적으로 꺼져 있게 (보이지 않게) 될 것입니다.

11.4.1.2.3. 렌더링 중단

맵 렌더링을 중단하려면 Esc 키를 누르십시오. 맵 캔버스 업데이트를 중단하고 맵 일부만 렌더링된 상태로 남겨둘 겁니다. Esc 키를 눌렀을 때 실제로 맵 렌더링이 중단될 때까지 시간이 조금 걸릴 수도 있습니다.

11.4.1.2.4. 렌더링 질 변경

QGIS는 맵의 렌더링 질을 변경할 수 있는 옵션을 보유하고 있습니다. Settings ‣ Options 메뉴 옵션을 선택하고, Rendering 탭을 클릭한 다음 checkbox Make lines appear less jagged at the expense of some drawing performance 체크박스를 체크하거나 해제해보십시오.

11.4.1.2.5. 렌더링 속도 향상

몇 가지 설정으로 렌더링 속도를 향상시킬 수 있습니다. Settings ‣ Options 메뉴 옵션으로 QGIS 설정 대화창을 열고, Rendering 탭으로 이동해서 다음 체크박스들을 체크하거나 해제해보십시오:

  • checkbox Use render caching where possible to speed up redraws 를 체크

  • checkbox Render layers in parallel using many CPU cores 를 체크한 다음 checkbox Max cores to use 를 설정

  • 백그라운드에서 맵을 별개의 이미지로 렌더링해서 각 checkbox Map Update interval 시간마다 이 (오프스크린) 이미지의 내용을 가져다가 맵 캔버스를 업데이트하게 됩니다. 하지만 렌더링 작업이 이 간격보다 빨리 끝나는 경우, 그 즉시 화면에 업데이트됩니다.

  • checkbox Enable Feature simplification by default for newly added layers 를 체크하면, 피처의 도형을 단순화(노드 감소)해서 그 결과 피처를 더 빨리 표시합니다. 이때 렌더링 일관성을 해치게 될 수도 있다는 점을 주의하십시오.

11.4.2. 확대/축소 및 이동

QGIS는 사용자의 관심 지역으로 확대/축소하거나 이동할 수 있는 도구를 제공합니다.

마우스로 툴바에 있는 pan pan 이동 및 zoomIn zoom-in/zoomOut zoom-out 확대/축소 아이콘을 이용하는 것 이외에, 마우스 휠, 스페이스 바 그리고 방향 키로도 맵을 탐색할 수 있습니다. Settings ‣ options Options ‣ Map tools 메뉴를 통해 Zoom factor 를 설정해서 확대/축소 중의 축척 습성을 정의할 수 있습니다.

11.4.2.1. 마우스 휠 사용법

메인 창 안에서 마우스 휠을 누르면 (맥OS에서는 cmd 키를 함께 눌러야 할 수도 있습니다) 맵을 이동할수 있습니다. 마우스 휠을 돌려서 맵을 확대하거나 축소할 수 있습니다. 관심 지역을 확대/축소할 때 마우스커서의 위치가 중심점이 될 것입니다. Ctrl 키를 누른 상태에서 마우스 휠을 돌리면 더 정밀하게 확대/축소할 수 있습니다.

11.4.2.2. 방향 키 사용법

방향 키를 이용해서 맵을 이동할 수 있습니다. 맵 영역 안쪽에 마우스 커서를 가져간 다음 방향 키를 누르면 위쪽, 아래쪽, 왼쪽, 오른쪽으로 이동합니다.

스페이스 바를 누르면 일시적으로 마우스 움직임에 따라 맵을 이동시킬 수 있습니다. 사용자 키보드의 PgUpPgDown 키를 누르면 설정한 확대/축소 인자(zoom factor)에 따라 맵을 확대하거나 축소할 수 있습니다. 맵 캔버스 상에서 Ctrl++ 또는 Ctrl+- 키 조합을 누르면 즉각적으로 맵을 확대/축소합니다.

특정한 맵 도구(식별, 측정 등등)를 활성화한 상태라면, Shift 키를 누른 상태로 맵 상에 사각형을 드래그해서 해당 지역으로 확대할 수 있습니다. 선택 도구(선택 도구는 추가 선택에 Shift 키를 이용합니다)나 편집 도구가 아닌 맵 도구에 한해 이 기능이 활성화됩니다.

11.4.3. 공간 북마크

공간 북마크를 통해 지리적 위치에 《책갈피》 를 끼워 나중에 다시 해당 위치로 돌아올 수 있습니다. 기본적으로 북마크는 사용자 프로파일에 (User Bookmarks 로) 저장되는데, 사용자가 연 어떤 프로젝트에서도 사용할 수 있다는 뜻입니다. 북마크를 단일 프로젝트 용으로 (Project Bookmarks 라는 명칭으로) 저장할 수도 있습니다. 프로젝트 북마크는 프로젝트 파일 안에 저장되는데, 다른 사용자와 공유해야 하는 프로젝트인 경우 유용할 것입니다.

11.4.3.1. 북마크 생성

북마크를 생성하려면:

  1. 관심 지역으로 확대/축소 또는 이동하십시오.

  2. View ‣ newBookmark New Spatial Bookmark… 메뉴 옵션을 선택하고, Ctrl+B 키 조합을 누르거나 Browser 패널에 있는 Spatial Bookmarks 항목을 오른쪽 클릭한 다음 New Spatial Bookmark 를 선택하십시오. Bookmark Editor 대화창이 열립니다.

    ../../../_images/bookmark_editor.png

    그림 11.6 북마크 편집기 대화창

  3. 북마크를 잘 설명하는 명칭을 입력하십시오.

  4. 관련 북마크를 저장할 그룹명을 입력하거나 선택하십시오.

  5. 범위 선택기를 사용해서 저장하고자 하는 영역의 범위를 선택하십시오. 불러온 레이어의 범위, 현재 맵 캔버스의 범위, 또는 현재 맵 캔버스 위에 마우스로 드래그한 사각형을 통해 범위를 계산할 수 있습니다.

  6. 선택한 범위에 사용할 CRS 를 지정하십시오.

  7. Saved in 옵션에서 북마크를 User Bookmarks 로 또는 Project Bookmarks 로 저장할지 선택하십시오.

  8. Save 를 클릭하면 북마크가 목록에 추가됩니다.

북마크 여러 개를 동일한 명칭으로 만들 수 있다는 사실을 기억하십시오.

11.4.3.2. 북마크 관련 작업

북마크를 사용하거나 관리하려면, Spatial Bookmarks 패널이나 Browser 를 사용하면 됩니다.

Spatial Bookmarks Manager 패널을 열려면 View ‣ showBookmarks Show Spatial Bookmark Manager 메뉴 옵션을 선택하거나 Ctrl+7 키 조합을 누르십시오. Browser 패널에 있는 showBookmarks Spatial Bookmarks 항목을 보려면 View ‣ showBookmarks Show Bookmarks 메뉴를 선택하거나 Ctrl+Shift+B 키 조합을 누르십시오.

다음과 같은 작업들을 수행할 수 있습니다:

작업

공간 북마크 관리자

탐색기

북마크로 확대/축소

북마크를 더블 클릭하거나, 북마크를 선택한 다음 zoomToBookmark Zoom to bookmark 버튼을 누르십시오.

북마크를 더블 클릭하거나, 북마크를 맵 캔버스로 드래그&드롭하거나, 북마크를 오른쪽 클릭한 다음 Zoom to Bookmark 를 선택하십시오.

북마크 삭제

북마크를 선택하고 deleteSelected Delete bookmark 버튼을 클릭한 다음, 확인을 누르십시오.

북마크를 오른쪽 클릭하고 Delete Spatial Bookmark 를 선택한 다음, 확인을 누르십시오.

북마크를 XML로 내보내기

sharing Import/Export Bookmarks 버튼을 클릭한 다음 sharingExport Export 를 선택하십시오. 모든 (사용자 또는 프로젝트) 북마크를 xml 파일로 저장합니다.

하나 이상의 폴더(사용자 또는 프로젝트) 또는 하위 폴더(그룹)를 선택한 다음, 오른쪽 클릭하고 Export Spatial Bookmarks… 를 선택하십시오. 선택한 북마크 부분 집합(subset)을 저장합니다.

XML에서 북마크 가져오기

sharing Import/Export Bookmarks 버튼을 클릭한 다음 sharingImport Import 를 선택하십시오. xml 파일에 있는 모든 북마크를 사용자 북마크로 가져옵니다.

Spatial Bookmarks 항목이나, 북마크를 가져올 하나 이상의 북마크 폴더(사용자 또는 프로젝트) 또는 하위 폴더(그룹)를 오른쪽 클릭한 다음, sharingImport Import Spatial Bookmarks 를 선택하십시오. Spatial Bookmarks 항목을 오른쪽 클릭했을 경우, User Bookmarks 로 북마크를 추가합니다.

북마크 편집

테이블에 있는 값을 변경해서 북마크를 수정할 수 있습니다. 사용자가 명칭, 그룹, 범위 및 프로젝트에 저장됐는지 여부를 편집할 수 있습니다.

원하는 북마크를 오른쪽 클릭하고 Edit Spatial Bookmark… 를 선택합니다. Bookmark Editor 가 열려, 마치 사용자가 북마크를 처음으로 생성하는 것처럼 해당 북마크의 모든 속성을 재정의할 수 있습니다.

폴더(사용자 또는 프로젝트) 또는 하위 폴더(그룹)로 북마크를 드래그&드롭할 수도 있습니다.

위치 탐색란 에 북마크 명칭을 입력해서 북마크로 확대/축소할 수도 있습니다.

11.4.4. 지도 장식

지도 장식은 그리드, 제목 라벨, 저작권 라벨, 이미지, 방위표, 축척 막대 및 조판 범위를 포함하며, 지도 제작 요소를 추가해 맵을 〈장식〉 하는 데 쓰입니다.

11.4.4.1. 그리드

addGrid Grid 를 통해 맵 캔버스에 좌표 격자 및 좌표 주석을 추가할 수 있습니다.

  1. View ‣ Decorations ‣ Grid… 메뉴 옵션을 선택해서 대화창을 여십시오.

    ../../../_images/grid_dialog.png

    그림 11.7 그리드 대화창

  2. checkbox Enable grid 체크박스를 체크해서 활성화한 다음 맵 캔버스에 불러온 레이어에 맞춰 그리드 정의를 설정하십시오.

    • Grid type: Line 또는 Marker 가운데 하나로 설정할 수 있습니다.

    • 그리드를 표시하는 데 관련 라인 심볼 또는 마커 심볼 을 사용합니다.

    • Interval XInterval Y : 그리드 표시 사이의 X 방향 간격과 Y 방향 간격을 맵 단위로 설정합니다.

    • Offset XOffset Y : 맵 캔버스의 좌하단에서 그리드 표시까지의 X방향, Y 방향 거리를 맵 단위로 설정합니다.

    • 다음에 기반해서 간격 및 오프셋 파라미터를 설정할 수 있습니다:

      • Canvas Extents: 캔버스 범위의 약 1/5 간격으로 그리드를 생성합니다.

      • Active Raster Layer : 가시 래스터 레이어의 해상도를 기반으로 그리드를 생성합니다.

  3. checkbox Draw annotations 옵션을 체크하면 그리드 표시의 좌표를 보이게 하고 다음을 설정할 수 있습니다:

    • Annotation direction : 주석의 방향, 즉 그리드 선을 기준으로 라벨을 어떻게 배치할지 다음 가운데 하나를 선택합니다.

      • Horizontal 또는 Vertical : 모든 라벨을 그리드 선에 대해 수평 또는 수직으로 배치합니다.

      • Horizontal and Vertical : 각 라벨을 각 라벨이 참조하는 그리드 표시에 평행하게 배치합니다.

      • Boundary direction : 각 라벨을 캔버스 경계(boundary)를 따라, 각 라벨이 참조하는 그리드 표시에 수직으로 배치합니다.

    • Annotation font: OS의 글꼴 선택기 위젯 을 통해 주석의 글꼴을 선택합니다.

    • Distance to map frame : 주석과 맵 캔버스 경계 사이의 여백을 설정합니다. 맵 캔버스를 예를 들어 이미지 포맷이나 PDF로 내보내면서 주석이 《용지》 한계에 걸리지 않도록 하는 데 유용합니다.

    • Coordinate precision : 좌표 수치의 정밀도를 설정합니다.

  4. 기대한대로 모양이 나오는지 확인하려면 Apply 를, 또는 사용자가 만족한다면 OK 를 클릭하십시오.

11.4.4.2. 제목 라벨

titleLabel Title Label 도구는 사용자 맵에 제목 을 장식할 수 있습니다.

제목 라벨 장식을 추가하려면:

  1. View ‣ Decorations ‣ Title Label… 메뉴 옵션을 선택해서 대화창을 여십시오.

    ../../../_images/titleLabel.png

    그림 11.8 제목 장식 대화창

  2. checkbox Enable Title Label 체크박스가 체크돼 있는지 확인하십시오.

  3. 맵 상에 배치하려 하는 제목 텍스트를 입력하십시오. Insert an Expression 버튼을 사용하면 동적 텍스트를 만들 수 있습니다.

  4. Font 에서 QGIS의 텍스트 서식 설정 전체 옵션을 사용할 수 있는 글꼴 선택기 위젯 을 통해 라벨 용 글꼴을 선택하십시오. 글꼴 콤보박스 오른쪽에 있는 검은 화살표를 클릭하면 글꼴 색상 및 투명도를 빠르게 설정할 수 있습니다.

  5. Background bar color 에서 제목의 배경 막대에 적용할 색상 을 선택하십시오.

  6. Placement 에서 캔버스에 라벨을 어떻게 배치할지 선택하십시오. Top left, Top Center (기본값), Top Right, Bottom left, Bottom CenterBottom Right 가운데 하나를 선택할 수 있습니다.

  7. Margin from Edge 에서 수평 그리고/또는 수직 경계 여백을 설정해서 항목의 배치를 미세 조정하십시오. 밀리미터 또는 픽셀 값으로 설정할 수도 있고, 맵 캔버스의 너비 또는 높이의 백분율 값으로 설정할 수도 있습니다.

  8. 기대한대로 모양이 나오는지 확인하려면 Apply 를, 또는 사용자가 만족한다면 OK 를 클릭하십시오.

11.4.4.4. 이미지 장식

addImage Image 를 통해 맵 캔버스 위에 이미지(로고, 범례 등등)를 추가할 수 있습니다.

이미지를 추가하려면:

  1. View ‣ Decorations ‣ Image… 메뉴 옵션을 선택해서 대화창을 여십시오.

    ../../../_images/image_decoration.png

    그림 11.10 이미지 장식 대화창

  2. checkbox Enable Image 체크박스가 체크돼 있는지 확인하십시오.

  3. Browse 버튼을 사용해서 (png 또는 jpg 같은) 비트맵 이미지 또는 SVG 이미지를 선택하십시오.

  4. SVG를 활성화시키는 파라미터를 선택했다면 Fill 또는 Stroke (외곽선) 색상도 설정할 수 있습니다. 비트맵 이미지의 경우 색상 설정은 비활성화됩니다.

  5. Size 에서 이미지의 크기를 밀리미터 단위로 설정하십시오. 선택한 이미지의 너비를 설정한 Size 로 맞춰 크기를 재조정합니다.

  6. Placement 콤보박스를 통해 맵 상에 이미지를 어떻게 배치할지 선택하십시오. 기본 위치는 Top Left 입니다.

  7. Margin from (Canvas) Edge 에서 HorizontalVertical 경계 여백을 설정하십시오. 밀리미터 또는 픽셀 값으로 설정할 수도 있고, 맵 캔버스의 너비 또는 높이의 백분율 값으로 설정할 수도 있습니다.

  8. 기대한대로 모양이 나오는지 확인하려면 Apply 를, 사용자가 만족한다면 OK 를 클릭하십시오.

11.4.4.5. 방위표

addImage North Arrow 를 통해 맵 캔버스 위에 방위표를 추가할 수 있습니다.

방위표를 추가하려면:

  1. View ‣ Decorations ‣ North Arrow… 메뉴 옵션을 선택해서 대화창을 여십시오.

    ../../../_images/north_arrow_dialog.png

    그림 11.11 방위표 대화창

  2. checkbox Enable North Arrow 체크박스가 체크돼 있는지 확인하십시오.

  3. 색상 및 크기 옵션을 변경하거나, 사용자 지정 SVG를 선택하십시오.

  4. 각도 옵션을 변경하거나, 자동 선택(Automatic) 을 선택해서 QGIS가 방향을 결정하도록 하십시오.

  5. Placement 콤보박스에서 방위표의 배치를 선택할 수도 있습니다.

  6. Margin from (Canvas) Edge 에서 수평 그리고/또는 수직 경계 여백을 설정해서 항목의 배치를 미세 조정하십시오. 밀리미터 또는 픽셀 값으로 설정할 수도 있고, 맵 캔버스의 너비 또는 높이의 백분율 값으로 설정할 수도 있습니다.

  7. 기대한대로 모양이 나오는지 확인하려면 Apply 를, 사용자가 만족한다면 OK 를 클릭하십시오.

11.4.4.6. 축척 막대

scaleBar Scale Bar 도구는 맵 캔버스에 단순한 축척 막대를 추가합니다. 사용자가 스타일과 위치는 물론 막대의 라벨도 제어할 수 있습니다.

QGIS에서는 축척을 사용자 맵 프레임과 동일한 단위로만 표시할 수 있습니다. 따라서 사용자 프로젝트의 좌표계가 미터 단위라면, 축척 막대를 피트 단위로 생성할 수 없습니다. 마찬가지로, 사용자가 십진수도(decimal degrees)를 사용하고 있다면, 미터 단위로 거리를 표시하는 축척 막대를 생성할 수 없습니다.

축척 막대를 추가하려면:

  1. View ‣ Decorations ‣ Scale Bar… 메뉴 옵션을 선택해서 대화창을 여십시오.

    ../../../_images/scale_bar_dialog.png

    그림 11.12 축척 막대 대화창

  2. checkbox Enable Scale Bar 체크박스가 체크돼 있는지 확인하십시오.

  3. Scale bar style selectString 콤보박스를 이용해서 축척 막대의 스타일을 선택하십시오.

  4. Color of bar selectColor 에서 채우기 색상(기본값: 검정색) 및 외곽선 색상(기본값: 흰색)을 선택하십시오. 색상 입력 오른쪽에 있는 아래쪽 화살표를 클릭하면 축척 막대의 채우기 및 외곽선을 불투명하게 만들 수 있습니다.

  5. Font of bar selectString 콤보박스에서 축척 막대 용 글꼴을 선택하십시오.

  6. Size of bar selectNumber 에서 축척 막대의 크기를 설정하십시오.

  7. checkbox Automatically snap to round number on resize 옵션을 체크하면 읽기 쉬운 값을 표시하도록 할 수 있습니다.

  8. Placement selectString 콤보박스에서 축척 막대의 배치를 선택하십시오.

  9. Margin from (Canvas) Edge 에서 수평 그리고/또는 수직 경계 여백을 설정해서 항목의 배치를 미세 조정하십시오. 밀리미터 또는 픽셀 값으로 설정할 수도 있고, 맵 캔버스의 너비 또는 높이의 백분율 값으로 설정할 수도 있습니다.

  10. 기대한대로 모양이 나오는지 확인하려면 Apply 를, 또는 사용자가 만족한다면 OK 를 클릭하십시오.

11.4.4.7. 조판 범위

addMap Layout Extents 도구는 캔버스에 인쇄 조판기(들)에 있는 맵 항목(들) 의 범위를 추가합니다. 이 도구를 활성화하면 모든 인쇄 조판기에 있는 모든 맵 항목의 범위를 인쇄 조판기 및 맵 항목의 명칭 라벨이 붙은 점선으로 된 경계선으로 표시합니다. 표시된 조판 범위의 스타일과 라벨을 제어할 수 있습니다. 사용자가 라벨 같은 맵 요소의 위치를 조정하는 도중 인쇄 조판기의 실제 가시화 영역을 알아야 하는 경우 이 장식이 유용합니다.

../../../_images/decoration_layoutextents_example.png

그림 11.13 QGIS 프로젝트에 인쇄 조판기 2개의 조판 범위가 표시돼 있는 예시. 〈Sights〉 라는 인쇄 조판기는 맵 항목 2개를 담고 있는 반면, 다른 인쇄 조판기는 맵 항목 1개를 담고 있다.

조판 범위(들)를 추가하려면:

  1. View ‣ Decorations ‣ Layout Extents 메뉴 옵션을 선택해서 대화창을 여십시오.

    ../../../_images/decoration_layoutextents.png

    그림 11.14 조판 범위 대화창

  2. checkbox Show layout extents 체크박스가 체크돼 있는지 확인하십시오.

  3. 범위의 심볼 및 라벨을 변경할 수 있는 옵션이 있습니다.

  4. 기대한대로 모양이 나오는지 확인하려면 Apply 를, 사용자가 만족한다면 OK 를 클릭하십시오.

장식 설정

사용자가 QGIS 프로젝트 파일을 저장할 때, 프로젝트에 그리드, 방위표, 축척 막대, 저작권 및 조판 범위의 모든 변경 사항이 저장되어 다음에 프로젝트를 불러올 때 복원될 것입니다.

11.4.5. 주석 도구

주석이란 맵 캔버스에 추가된 정보로 말풍선 안에 표시됩니다. 서로 다른 유형의 정보를 표시할 수 있으며, Attributes Toolbar 에 있는 서로 다른 유형에 대응하는 도구를 사용하면 해당 유형의 주석을 추가합니다:

../../../_images/custom_annotation.png

그림 11.15 사용자 지정 QT 디자이너 주석 양식

주석을 추가하려면, 대응하는 도구를 선택한 다음 맵 캔버스를 클릭하십시오. 비어 있는 말풍선이 추가됩니다. 이 말풍선을 더블 클릭하면 여러 옵션을 담은 대화창이 열립니다. 모든 주석 유형에 대해 이 대화창은 거의 동일합니다:

  • 주석 유형에 따라 html, svg 또는 ui 파일을 가리키는 경로를 입력하는 파일 선택기가 맨 위에 있습니다. 텍스트 주석의 경우, 사용자가 텍스트 란에 직접 메시지를 입력하고 일반 글꼴 도구로 텍스트의 렌더링 방법을 설정할 수 있습니다.

  • checkbox Fixed map position: 이 옵션을 체크 해제하면, 말풍선을 (맵 위치 대신) 스크린 위치를 기반으로 배치합니다. 즉 맵 캔버스 범위와 상관없이 언제나 말풍선을 표시합니다.

  • Linked layer: 주석을 맵 레이어와 연결해서 해당 레이어가 가시화될 때만 주석을 가시화합니다.

  • Map marker: QGIS 심볼 을 사용해서 말풍선 고정 위치(anchor position)에 표시될 심볼을 설정합니다. (Fixed map position 옵션을 체크한 경우에만 심볼을 표시합니다.)

  • Frame style: QGIS 심볼을 통해 주석 프레임의 배경색, 투명도, 획 색상 또는 말풍선의 너비를 설정합니다.

  • Contents margins: 주석 프레임의 내부 여백을 설정합니다.

../../../_images/annotation.png

그림 11.16 주석 텍스트 대화창

주석 도구를 활성화하면 주석을 선택할 수 있습니다. 선택한 주석의 맵 위치를 (맵 마커를 드래그해서) 옮기거나, 말풍선만 이동시킬 수도 있습니다. annotation Move Annotation 도구를 사용해서도 맵 캔버스 상에서 말풍선을 이동할 수 있습니다.

주석을 삭제하려면, 주석을 선택한 다음 Del 또는 Backspace 키를 누르거나 또는 주석을 더블 클릭한 다음 속성 대화창에 있는 Delete 버튼을 클릭하십시오.

참고

Annotation 도구가 활성화됐을 때 (주석 이동, 텍스트 주석, 양식 주석 등) Ctrl+T 를 누르면 말풍선의 가시성 상태가 반전됩니다.

주석으로 맵을 조판하기

다음 도구를 사용해서 사용자 맵을 주석과 함께 인쇄하거나 여러 포맷으로 내보낼 수 있습니다:

  • Project 메뉴에서 사용할 수 있는 맵 캔버스 내보내기 도구들

  • 인쇄 조판기 를 이용하는 경우, 내보내고자 하는 맵 항목 속성에서 Draw map canvas items 옵션을 활성화해야 합니다.

11.4.6. 측정

11.4.6.1. 일반 정보

QGIS는 도형을 측정하는 네 가지 방법을 제공하고 있습니다:

  • 쌍방향 측정 도구인 measure 과,

  • calculateField Field Calculator 에서 측정하는 방법,

  • 피처 식별 도구에서 파생된 측정 방법,

  • 그리고 Vector ‣ Geometry Tools ‣ Export/Add Geometry Columns 메뉴의 벡터 분석 도구가 있습니다.

측정 작업은 (UTM 같은) 투영좌표계 및 투영체가 정의되지 않은 데이터 안에서 이루어집니다. 처음 세 가지 측정 도구의 습성은 일반 투영 설정과 동일합니다:

  • 다른 대부분의 GIS 와는 달리, 기본 측정법은 Project ‣ Properties… ‣ General 에서 정의한 타원체를 이용합니다. 프로젝트 용으로 지리 좌표계를 정의한 경우, 투영 좌표계를 정의한 경우 둘 다 타원체 상에서 측정합니다.

  • 데카르트 수학을 이용해서 투영/평면 면적 또는 거리를 계산하려면, Project ‣ Properties… ‣ General 메뉴에서 측정 타원체를 《None/Planimetric》으로 설정해야 합니다. 하지만 데이터 및 프로젝트 용으로 지리(=비투영) 좌표계를 정의했다면, 타원체 상에서 면적 및 거리를 측정할 것입니다.

그러나 식별 도구 또는 필드 계산기 둘 다 측정 작업 전에 사용자 데이터를 프로젝트 좌표계로 변환하지 않을 겁니다. 측정 전에 좌표계를 변환하도록 하고 싶다면, Vector ‣ Geometry Tools ‣ Add Geometry Attributes… 메뉴의 벡터 분석 도구를 이용해야 합니다. 이때 사용자가 타원체 측정법을 선택한 경우를 제외하면 기본적으로 평면 상에서 측정하게 됩니다.

11.4.6.2. 대화형 길이, 면적 및 각도 측정

측정을 시작하려면 Attributes toolbar 에 있는 measure 아이콘을 클릭하십시오. 아이콘 옆에 있는 아래쪽 화살표를 누르면 measure 길이, measureArea 면적, 또는 measureAngle 각도 측정 도구로 번갈아 변경합니다. 측정 대화창은 Project ‣ Properties… ‣ General 메뉴에서 설정한 기본 단위를 사용합니다.

참고

측정 도구 환경 설정

길이 또는 면적 측정 시, 위젯 하단에 있는 Configuration 버튼을 클릭하면 Settings ‣ Options ‣ Map Tools 메뉴와 동일하게 고무줄 색상, 측정 정밀도 및 단위 습성을 정의할 수 있습니다. 사용자가 선호하는 측정 단위 또는 각도 단위를 선택할 수도 있지만, Project ‣ Properties… ‣ General 메뉴 그리고 측정 위젯에서 선택한 옵션이 현재 프로젝트에서 사용자가 선택한 단위를 대체한다는 사실을 유념해야 합니다.

모든 측정 모듈은 디지타이즈 작업 모듈의 스냅 설정(스냅 허용 오차 및 검색 반경 설정 참조)을 이용합니다. 따라서 라인 피처를 따라서든 폴리곤 피처를 돌아서든, 정확히 측정하려면 먼저 레이어 스냅 허용 오차를 설정해야 합니다. 그러면 측정 도구 사용 시 (허용 오차 설정 범위 내의) 각 마우스 클릭이 해당 레이어에 스냅할 것입니다.

기본값인 measure Measure Line 은 지정한 포인트들 사이의 실제 거리를 정의한 타원체에 따라 측정합니다. 이 도구를 선택하면 사용자가 맵 상에 포인트를 클릭할 수 있습니다. 각 선분 길이는 물론 총합 길이도 측정 창에 표시됩니다. 측정을 중단하려면 오른쪽 클릭하십시오.

측정 도구 사용 중에 총합 길이 옆에 있는 드롭다운 목록에서 대화형으로 측정 단위를 (〈미터〉, 〈킬로미터〉, 〈피트〉, 〈야드〉, 〈마일〉, 〈해리〉, 〈센티미터〉, 〈밀리미터〉, 〈도〉, 〈맵 단위〉) 변경할 수 있다는 사실을 기억하십시오. 위젯은 새로운 또는 다른 프로젝트를 열 때까지 이렇게 선택한 단위를 유지합니다.

대화창의 Info 부분은 사용할 수 있는 좌표계 설정에 따라 어떻게 계산하는지 설명합니다.

../../../_images/measure_line.png

그림 11.17 거리 측정

measureArea Measure Area 도구로 면적도 측정할 수 있습니다. 측정 창에 누적 면적 크기를 표시합니다. 오른쪽 클릭으로 그리기를 중단합니다. 서로 다른 면적 단위로 (〈제곱미터〉, 〈제곱킬로미터〉, 〈제곱피트〉, 〈제곱야드〉, 〈제곱마일〉, 〈헥타르〉, 〈에이커〉, 〈제곱센티미터〉, 〈제곱밀리미터〉, 〈제곱해리〉, 〈제곱도〉, 〈맵 단위〉) 변경할 수 있는 것은 물론 Info 부분도 볼 수 있습니다.

../../../_images/measure_area.png

그림 11.18 면적 측정

measureAngle Measure Angle 도구로 각도도 측정할 수 있습니다. 커서가 십자가 형태로 바뀝니다. 사용자가 측정하려는각도의 첫 번째 선분을 그린 다음, 커서를 움직여서 원하는 각도를 그리십시오. 측정값이 팝업 대화창에 표시됩니다.

../../../_images/measure_angle.png

그림 11.19 각도 측정

11.5. 대화형 피처 작업

11.5.1. 피처 선택

QGIS는 맵 캔버스에서 피처를 선택할 수 있는 여러 도구를 제공하고 있습니다. Edit ‣ Select 메뉴 또는:guilabel:Attributes toolbar 에서 선택 도구를 쓸 수 있습니다.

참고

선택 도구는 현재 활성화된 레이어 상에서 동작합니다.

11.5.1.1. 맵 캔버스에서 직접 선택하기

하나 이상의 피처를 마우스로 선택하려면, 다음 도구들 가운데 하나를 쓸 수 있습니다:

  • selectRectangle Select Features by area or single click

  • selectPolygon Select Features by Polygon

  • selectFreehand Select Features by Freehand

  • selectRadius Select Features by Radius

참고

selectPolygon Select Features by Polygon 도구를 제외하면, 이 수동 선택 도구들을 통해 맵 캔버스에서 피처(들)를 클릭 한 번으로 선택할 수 있습니다.

참고

중첩된 피처를 선택하기 위해 기존 폴리곤을 쓰려면 selectPolygon Select Features by Polygon 도구를 사용하십시오. 폴리곤을 오른쪽 클릭하면 클릭한 포인트를 담고 있는 모든 폴리곤들의 목록을 보여주는 컨텍스트 메뉴가 나타납니다. 이 목록에서 원하는 폴리곤을 선택하십시오. 활성화된 레이어에 있는 모든 중첩 피처들이 선택될 것입니다.

사용자가 가장 마지막으로 선택했던 피처를 다시 선택하려면 Edit ‣ Select ‣ Reselect Features 메뉴를 사용하십시오. 사용자가 고생해서 선택해 놓은 것들을 실수로 다른 곳을 클릭해버리는 바람에 선택 해제됐을 경우 매우 유용합니다.

selectRectangle Select Feature(s) 도구 사용 시, Shift 또는 Ctrl 키를 누르면 피처를 선택할지 말지를 (예를 들면 현재 선택 집합에 추가할지 아니면 제거할지) 토글할 수 있습니다.

다른 도구들의 경우, 다음 키를 누르면 서로 다른 습성이 발현됩니다:

  • Shift: 현재 선택 집합에 피처를 추가

  • Ctrl: 현재 선택 집합에서 피처를 제거

  • Ctrl+Shift: 현재 선택 집합과 교차, 예를 들어 현재 선택 집합에서 중첩하는 피처들만 유지

  • Alt: 선택 형태에 완전히 들어가는 피처들만 선택. Shift 또는 Ctrl 키와 조합하면, 현재 선택 집합에 피처를 추가하거나 제거할 수 있습니다.

11.5.1.2. 자동 선택

속성 테이블 에서도 대부분 쓸 수 있는 다음 선택 도구들은 피처의 속성 또는 선택 상태를 바탕으로 선택 작업을 수행합니다(속성 테이블과 맵 캔버스는 동일한 정보를 표시하기 때문에, 속성 테이블에서 피처 1개를 선택하면 맵 캔버스에서도 선택될 것이라는 점을 기억하십시오):

  • expressionSelect Select By Expression… 도구로 표현식 대화창을 이용해서 피처를 선택할 수 있습니다.

  • formSelect Select Features By Value… 도구 또는 F3

  • deselectAll Deselect Features from All Layers 도구 또는 Ctrl+Shift+A 조합 키로 모든 레이어에서 선택한 모든 피처들을 선택 해제할 수 있습니다.

  • selectAll Select All Features 도구 또는 Ctrl+A 조합 키로 현재 레이어에 있는 모든 피처를 선택할 수 있습니다.

  • invertSelection Invert Feature Selection 도구로 현재 레이어의 선택 집합을 반전시킬 수 있습니다.

예를 들어 QGIS 예시 데이터의 regions.shp 파일에서 구(borough)인 지역을 찾고자 하는 경우:

  1. expressionSelect Select features using an Expression 아이콘을 클릭하고

  2. Fields and Values 그룹을 펼친 다음

  3. 쿼리하려는 필드를 (《TYPE_2》) 더블 클릭하고

  4. 오른쪽에 나타나는 패널에 있는 All Unique 버튼을 클릭하면

  5. 나타나는 목록에서 〈Borough〉 를 더블 클릭하고 Expression 편집기 필드에 다음 쿼리를 입력하십시오:

    "TYPE_2"  =  'Borough'
    
  6. Select Features 를 클릭합니다.

표현식 작성기 대화창에서, Function list ‣ Recent (Selection) 메뉴를 이용해서 이전에 사용했던 표현식을 선택할 수도 있습니다. 이 대화창은 최근 사용한 표현식을 20개까지 저장하고 있습니다. 더 자세한 정보 및 몇몇 예시를 살펴보려면 표현식 을 참조하세요.

사용자 선택 집합을 새 파일로 저장

Edit ‣ Copy FeaturesEdit ‣ Paste Features as 메뉴를 통해 선택한 피처를 각각 원하는 유형의 New Temporary Scratch Layer 또는 New Vector Layer 로 저장할 수 있습니다.

11.5.1.3. 값으로 피처 선택

이 선택 도구는 레이어의 피처 양식을 열어 사용자가 각 필드에 대해 어떤 값을 검색할지, 대소문자를 구분해서 검색할지, 어떤 연산을 사용할지 선택할 수 있게 해줍니다. 이 도구는 자동적으로 검색란을 기존 값으로 채워주는 자동 완성 기능도 제공합니다.

../../../_images/select_by_value.png

그림 11.20 양식 대화창을 이용해 피처 필터링/선택

각 필드 옆에, 검색 습성을 제어할 수 있는 옵션을 나열한 드롭다운 목록이 있습니다:

필드 검색 옵션

문자열

수치

날짜

Exclude Field 검색에서 제외할 필드

checkbox

checkbox

checkbox

Equal to (=)

checkbox

checkbox

checkbox

Not equal to (≠)

checkbox

checkbox

checkbox

Greater than (>)

checkbox

checkbox

Less than (<)

checkbox

checkbox

Greater than or equal to (≥)

checkbox

checkbox

Less than or equal to (≤)

checkbox

checkbox

Between (inclusive)

checkbox

checkbox

Not between (inclusive)

checkbox

checkbox

Contains

checkbox

Does not contain

checkbox

Is missing (null)

checkbox

checkbox

checkbox

Is not missing (not null)

checkbox

checkbox

checkbox

Starts with

checkbox

Ends with

checkbox

문자열 비교의 경우, 대소문자를 구분하는 checkbox Case sensitive 옵션도 사용할 수 있습니다.

모든 검색 옵션을 설정한 다음, Select features 버튼을 눌러 일치하는 피처들을 선택할 수 있습니다. 드롭다운 옵션은 다음과 같습니다:

  • Select features

  • Add to current selection

  • Remove from current selection

  • Filter current selection

Reset form 버튼을 눌러 모든 검색 옵션을 초기화할 수도 있습니다.

조건을 설정하고 나면, 다음 가운데 하나를 할 수 있습니다:

  • Zoom to features: 피처를 미리 선택하지 않고도 맵 캔버스에서 조건과 일치하는 피처로 확대/축소할 수 있습니다.

  • Flash features: 조건과 일치하는 피처를 강조합니다. 선택 또는 식별 도구를 사용하지 않고도 피처를 식별할 수 있는 간편한 방법입니다. 강조 효과는 맵 캔버스 범위를 변경하지 않으며, 피처가 현재 맵 캔버스 경계 안에 있는 경우에만 강조가 가시화될 것이라는 점을 기억하십시오.

11.5.2. 피처 식별

식별 도구를 통해 맵 캔버스와 상호작용해서 팝업창으로 피처에 대한 정보를 얻을 수 있습니다. 피처를 식별하려면, 다음 도구를 이용하십시오:

  • View ‣ Identify Features 메뉴

  • Ctrl+Shift+I (또는 osx Cmd+Shift+I) 키 조합

  • 속성 툴바에 있는 identify Identify Features 아이콘

11.5.2.1. 피처 식별 도구 이용하기

QGIS는 identify Identify Features 도구로 피처를 식별할 수 있는 몇 가지 방법을 제공합니다:

  • 왼쪽 클릭 하면 Identify Results 패널에서 설정한 선택 모드선택 마스크 에 따라 피처를 식별합니다.

  • Identify Results 패널에서 설정한 선택 모드 를 따르는 Identify Feature(s)오른쪽 클릭 하면 모든 가시화된 레이어에서 모든 스냅된 피처를 가져옵니다. 이 방법은 컨텍스트 메뉴를 열어, 사용자가 식별할 피처를 또는 피처에 실행할 작업을 더 정밀하게 선택할 수 있도록 해줍니다.

  • Identify Results 패널 에서 설정한 선택 모드 를 따르는 Identify Features by Polygon 으로 오른쪽 클릭 하면 선택한 기존 폴리곤과 중첩하는 피처를, Identify Results 패널에서 설정한 선택 마스크 에 따라 식별합니다.

쿼리할 레이어를 피처 식별 도구로 필터링하기

Project ‣ Properties… ‣ Data Sources 메뉴의 Layer Capabilities 에서 레이어 옆에 있는 Identifiable 열을 체크 해제하면, Current Layer 가 아닌 모드로 identify Identify Features 도구를 사용할 경우 해당 레이어를 쿼리 대상에서 제외합니다. 사용자가 관심을 가진 레이어에서만 피처를 반환받을 수 있는 간편한 방법입니다.

피처(들)를 클릭하면, 클릭한 피처(들)에 대한 정보 목록을 담은 Identify Results 대화창이 열립니다. 기본 뷰는 첫 번째 항목이 레이어명이고 그 하위 항목이 식별된 피처(들)인 트리 뷰입니다. 각 피처는 필드명을 그 값과 함께 표시합니다. Layer Properties ‣ Display 메뉴에서 이 필드를 설정합니다. 그 다음 해당 피처에 대한 다른 모든 정보를 나열합니다.

11.5.2.2. 피처 정보

사용자 지정 필드를 표출시키기 위해 식별 결과 대화창을 사용자 지정할 수도 있지만, 기본적으로 다음과 같은 유형의 정보를 표시할 것입니다:

  • 피처의 표시 명칭

  • Actions: 피처 식별 창에 액션을 추가할 수 있습니다. 액션 라벨을 클릭해서 액션을 수행합니다. 기본적으로, 편집 작업을 위한 View feature form 이라는 액션 하나만 추가돼 있습니다. 레이어의 속성 대화창에서 더 많은 액션을 정의할 수 있습니다. (액션 속성 참조)

  • Derived: 다른 정보로부터 계산된 또는 파생된 정보로, 다음을 포함합니다:

    • 피처의 도형과 관련된 일반 정보:

      • 도형 유형에 따라, 데카르트 평면에서 레이어 좌표계의 단위로 측정된 피처의 길이, 둘레 또는 면적

      • 프로젝트 속성 대화창에서 Measurements 용으로 설정된 타원체가 있는 경우, 도형 유형에 따라 타원체 상에서 지정한 단위로 측정된 피처의 길이, 둘레 또는 면적

      • 피처가 보유한 도형 부분의 개수와 클릭한 부분의 개수

      • 피처가 보유한 꼭짓점의 개수

    • 프로젝트 속성의 Coordinates display 설정을 사용한 좌표 정보:

      • 클릭한 포인트의 XY 좌표값

      • 클릭한 포인트에 가장 가까운 꼭짓점의 번호

      • 가장 가까운 꼭짓점의 XY 좌표값 (가능한 경우 Z/M 좌표값)

      • 곡선을 클릭한 경우, 해당 구간의 반경도 표시합니다.

  • Data attributes: 사용자가 클릭한 피처의 속성 필드 및 값들의 목록입니다.

참고

Identify Results 패널에서 피처 속성 내부에 있는 링크를 클릭할 수 있으며, 사용자 기본 웹브라우저로 열릴 것입니다.

../../../_images/identify_features.png

그림 11.21 식별 결과 대화창

11.5.2.3. 식별 결과 대화창

창 상단에 여러 도구가 있습니다:

  • formView Open Form: 현재 피처의 양식을 엽니다.

  • expandTree Expand tree: 트리를 펼칩니다.

  • collapseTree Collapse tree: 트리를 접습니다.

  • expandNewTree Expand New Results by Default: 다음 식별할 피처의 정보를 접을지 펼칠지 여부를 정의합니다.

  • deselectAll Clear Results: 결과를 초기화합니다.

  • editCopy Copy selected feature to clipboard

  • filePrint Print selected HTML response

  • 식별할 피처를 가져오기 위해 사용할 선택 모드:

    • identifyByRectangle Identify Features by area or single click

    • identifyByPolygon Identify Features by Polygon

    • identifyByFreehand Identify Features by Freehand

    • identifyByRadius Identify Features by Radius

    참고

    identifyByPolygon Identify Features by Polygon 도구 사용 시, 모든 기존 폴리곤을 오른쪽 클릭하면 또다른 레이어의 중첩하는 피처를 식별하는 데 사용할 수 있습니다.

창 하단에는 ModeView 콤보박스가 있습니다. Mode 콤보박스를 통해 어떤 레이어에 있는 피처를 식별해야 하는지 정의할 수 있습니다:

  • Current layer: 선택한 레이어에 있는 피처만 식별합니다. 레이어가 맵 캔버스에 보이지 않아도 됩니다.

  • Top down, stop at first: 가시화된 레이어 가운데 가장 위에 있는 레이어의 피처만 식별합니다.

  • Top down: 가시화된 레이어들의 모든 피처를 식별합니다. 식별 결과가 패널에 표시됩니다.

  • Layer selection: 컨텍스트 메뉴를 열어서 사용자가 피처를 식별할 레이어를 선택할 수 있습니다. 오른쪽 클릭과 동일하게 동작합니다. 선택한 피처만 식별 결과 패널에 표시될 것입니다.

View트리, 테이블 또는 그래프 로 설정할 수 있습니다. 래스터 레이어에 대해서만 〈테이블〉 과 〈그래프〉 를 설정할 수 있습니다.

The identify tool allows you to checkbox Auto open form for single feature results, found under options Identify Settings. If checked, each time a single feature is identified, a form opens showing its attributes. This is a handy way to quickly edit a feature’s attributes.

식별된 항목의 컨텍스트 메뉴에서 다른 기능도 찾아볼 수 있습니다. 예를 들면, 컨텍스트 메뉴를 통해 다음 작업을 할 수 있습니다:

  • 피처 양식 보기

  • 피처로 확대/축소

  • 피처 복사: 모든 피처 도형 및 속성 복사

  • 피처 집합 켜고끄기: 식별한 피처를 선택 집합에 추가

  • 속성값 복사: 사용자가 클릭한 속성값만 복사

  • 피처 속성 복사: 피처의 속성을 복사

  • 결과 삭제: 창에서 식별 결과를 제거

  • 강조 삭제: 맵 상에서 강조된 피처를 제거

  • 모든 피처 강조

  • 레이어 강조

  • 레이어 활성화: 활성화할 레이어를 선택

  • 레이어 속성: 레이어 속성 창 열기

  • 모두 확장

  • 모두 접기

11.6. 레이어 속성 저장 및 공유

11.6.1. 사용자 지정 스타일 관리하기

맵 캔버스에 벡터 레이어를 추가하면, QGIS는 레이어 피처를 렌더링하는 데 기본값으로 랜덤한 심볼/색상을 이용합니다. 하지만 Project ‣ Properties… ‣ Default styles 에서 기본 심볼을 설정해서, 새로 추가되는 레이어마다 그 도형 유형에 따라 적용시킬 수 있습니다.

그러나 대부분의 경우, 레이어에 자동적으로 또는 수동으로 (수고를 덜 들이고) 적용할 수 있는, 사용자가 지정한 좀 더 복잡한 스타일을 선호할 겁니다. 레이어 속성 대화창 하단에 있는 Style 메뉴를 통해 이런 스타일을 정의할 수 있습니다. 이 메뉴는 스타일을 생성하고, 불러오고, 관리할 수 있는 기능을 제공합니다.

스타일은 벡터 레이어의 경우 피처(심볼, 라벨, 필드 및 양식 정의, 액션, 다이어그램 등등의 설정), 래스터 레이어의 경우 픽셀(밴드 또는 색상 렌더링, 투명도, 피라미드, 히스토그램 등등)을 렌더링하거나 상호작용하기 위해 레이어 속성 대화창에서 설정한 모든 정보를 저장합니다.

../../../_images/style_combobox.png

그림 11.22 벡터 레이어 스타일 콤보박스 옵션들

불러온 레이어에 적용되는 스타일의 기본 명칭은 default 입니다. 사용자 레이어에 대해 이상적이고 적절한 렌더링 옵션을 설정하고 나면, selectString Style 콤보박스를 클릭해서 다음 저장 옵션 가운데 하나를 선택할 수 있습니다:

  • Rename Current: 활성화된 스타일을 재명명하고 현재 옵션으로 업데이트합니다.

  • Add: 현재 옵션으로 새 스타일을 생성합니다. 기본적으로 QGIS 프로젝트 파일 안에 저장될 겁니다. 스타일을 다른 파일로 또는 데이터베이스에 저장하는 방법은 다음 항을 참조하세요.

  • Remove: 해당 레이어에 하나 이상의 스타일이 정의돼 있는 경우, 원하지 않는 스타일을 삭제합니다.

스타일 드롭다운 목록 하단에 레이어에 대한 스타일 집합이 있는데, 활성화된 스타일은 체크 표시가 돼 있습니다.

사용자가 레이어 속성 대화창을 승인할 때마다, 활성화된 스타일이 사용자가 변경한 사항으로 업데이트된다는 점을 기억하십시오.

레이어 하나에 대해 원하는 만큼 많은 스타일을 생성할 수 있지만, 한 번에 스타일 하나만 활성화할 수있습니다. 맵 테마 와 결합하면, 맵 범례에서 어떤 레이어도 복사할 필요가 없이 복잡한 프로젝트를 관리할 수 있는 빠르고 강력한 방법을 얻게 됩니다.

참고

사용자가 레이어 속성을 수정할 때마다 활성화된 스타일에 변경 사항을 저장한다는 사실은, 사용자가 맵 테마 에서 사용되는 스타일을 실수로 변경하는 일 없이 언제나 올바른 스타일을 편집하고 있다는 점을 보장합니다.

레이어 컨텍스트 메뉴에서 스타일 관리하기

Layers 패널에 있는 레이어를 오른쪽 클릭하면 레이어 스타일을 복사, 붙여넣기, 추가 또는 재명명할 수 있습니다.

11.6.2. 스타일을 파일 또는 데이터베이스로 저장하기

기본적으로 프로젝트 파일에 Style 콤보박스에서 생성한 스타일을 저장하고, 프로젝트에 있는 레이어에서 레이어로 복사하고 붙여넣을 수 있지만, 다른 프로젝트에서 불러올 수 있도록 프로젝트 외부에 저장할 수도 있습니다.

11.6.2.1. 텍스트 파일로 저장

selectString Style ‣ Save Style 메뉴를 클릭하면, 스타일을 다음 텍스트 파일로 저장할 수 있습니다:

  • QGIS 레이어 스타일 파일 (.qml)

  • 벡터 레이어만 지원하는 SLD 파일 (.sld)

파일 기반 유형 레이어(.shp, .tab 등등)의 경우, Save as Default 메뉴가 레이어와 함께 (동일한 명칭으로) .qml 파일을 생성합니다. 모든 렌더링 작업자 유형 – 단일 심볼, 범주, 등급 또는 규칙 기반 – 이 SLD 파일을 내보낼 수 있습니다. 그러나 SLD를 가져오는 경우, 단일 심볼 또는 규칙 기반 렌더링 작업자 가운데 하나를 생성합니다. 즉 범주 또는 등급 스타일이 규칙 기반으로 변환된다는 뜻입니다. 범주 또는 등급 렌더링 작업자를 그대로 가져오려면 QML 포맷을 이용해야 합니다. 그런 반면, 스타일을 손쉽게 규칙 기반으로 변환하는 이런 방법이 매우 유용한 경우도 있습니다.

11.6.2.2. 데이터베이스에 저장

레이어 데이터소스가 데이터베이스 제공자인 경우 벡터 레이어 스타일도 데이터베이스에 저장할 수 있습니다. PostGIS, GeoPackage, SpatiaLite, MS SQL 및 Oracle 포맷을 지원합니다. 데이터베이스의 (테이블명 layer_styles) 테이블에 레이어 스타일을 저장합니다. Save Style… ‣ Save in database 메뉴를 클릭한 다음 대화창에서 스타일 명칭을 정의하고, 설명을 추가하고, 가능한 경우 .ui 파일을 추가하고 해당 스타일을 기본 스타일로 설정할지 체크하십시오.

데이터베이스의 단일 테이블에 여러 스타일을 저장할 수 있습니다. 하지만 각 테이블은 오직 하나의 기본 스타일만 보유할 수 있습니다. 레이어 데이터베이스 또는 ~/.qgis2/ 디렉터리에 있는 QGIS 로컬 데이터베이스 ─ (QGIS가 로컬 설정을 저장하는) SQLite 데이터베이스 ─ 에 기본 스타일을 저장할 수 있습니다.

../../../_images/save_style_database.png

그림 11.23 데이터베이스 대화창에서 스타일 저장

데이터베이스들 사이에서 스타일 파일 공유하기

레이어가 데이터베이스 기반일 경우에만 해당 데이터베이스에 사용자 스타일을 저장할 수 있습니다. 데이터베이스 사이에서 (예를 들어 Oracle 레이어 스타일과 MS SQL 스타일은) 호환되지 않습니다. 데이터베이스들 사이에서 스타일을 공유하려면 암호화되지 않은 텍스트 파일을 대신 이용하십시오.

참고

PostgreSQL 데이터베이스 백업에서 layer_styles 테이블을 복구하는 데 문제가 있을 수도 있습니다. 이런 문제를 해결하려면 QGIS layer_style 테이블 및 데이터베이스 백업 을 참조하세요.

11.6.2.3. 스타일 불러오기

QGIS에 레이어를 불러올 때, 해당 레이어의 기본 스타일이 이미 존재하는 경우, QGIS는 해당 레이어를 레이어 기본 스타일로 불러옵니다. 또 Style ‣ Restore Default 메뉴 옵션을 클릭하면 기본 스타일 파일을 찾아 불러와서 해당 레이어의 현재 스타일을 교체합니다.

Style ‣ Load Style 메뉴를 사용하면 레이어에 저장된 모든 스타일을 적용할 수 있습니다. 텍스트 파일 스타일(.sld 또는 .qml)은 레이어 유형에 상관없이 적용할 수 있는 반면, 데이터베이스에 저장된 스타일은 레이어가 동일 데이터베이스 기반이거나, QGIS 로컬 데이터베이스에 저장된 스타일인 경우에만 불러올 수 있습니다.

Database Styles Manager 대화창은 데이터베이스에 있는 레이어 관련 스타일은 물론 저장돼 있는 다른 모든 스타일의 목록을 명칭 및 설명과 함께 표시합니다.

프로젝트 내부에서 손쉽게 레이어 스타일 공유

프로젝트 내부에서 파일 또는 데이터베이스 스타일을 가져오지 않고서도 레이어 스타일을 공유할 수 있습니다. Layers Panel 에 있는 레이어를 오른쪽 클릭한 다음 Styles 콤보박스에서 레이어의 스타일을 복사해서 그룹 또는 레이어 집합으로 붙여 넣을 수 있습니다. 이렇게 하면 원본 레이어와 동일한 (벡터 또는 래스터) 유형인 모든 레이어에, 그리고 벡터 레이어인 경우 모든 동일한 도형 유형(포인트, 라인, 폴리곤)에 스타일을 적용합니다.

11.6.3. 레이어 정의 파일

활성화된 레이어의 컨텍스트 메뉴에서 Export ‣ Save As Layer Definition File… 을 선택하면 레이어 정의를 Layer Definition File (.qlr)로 저장할 수 있습니다. 레이어 정의 파일(.qlr)은 레이어의 데이터소스를 가리키는 참조 정보와 레이어 스타일을 담고 있습니다. .qlr 파일은 탐색기 패널에 표시되며, 레이어 패널에 레이어를 (저장된 스타일과 함께) 추가하는 데 사용할 수 있습니다. 시스템 파일 관리자에서 맵 캔버스로 .qlr 파일을 드래그&드롭할 수도 있습니다.

11.7. 값을 변수로 저장

QGIS는 표현식에 쓰일 수 있는 자주 사용되는 유용한 값들(예를 들어 프로젝트 제목 또는 사용자의 이름)을 변수를 이용해서 저장할 수 있습니다. 응용 프로그램 전체 수준, 프로젝트 수준, 레이어 수준, 조판 수준그리고 조판기 항목 수준에서 변수를 정의할 수 있습니다. CSS의 순차적(cascading) 규칙처럼, 변수도 덮어쓸 수 있습니다. 예를 들어, 프로젝트 수준의 변수는 동일한 명칭을 가진 모든 응용 프로그램 수준의 변수를 덮어쓸 것입니다. 변수명 앞에 @ 문자를 붙여서 텍스트 문자열 또는 다른 사용자 지정 표현식을 작성하는 데 쓸 수 있습니다. 다음은 인쇄 조판기에서 라벨을 생성하는 예시입니다:

This map was made using QGIS [% @qgis_version %]. The project file for this
map is: [% @project_path %]

다음과 같은 라벨로 렌더링됩니다:

This map was made using QGIS 3.4.4-Madeira. The project file for this map is:
/gis/qgis-user-conference-2019.qgs

사전 설정된 읽기 전용 변수 이외에도, 앞에서 언급한 모든 수준에서 사용자 지정 변수를 정의할 수 있습니다. 다음 변수들을 관리할 수 있습니다:

  • Settings ‣ Options 메뉴에서 전체 수준 변수

  • Project Properties 대화창에서 프로젝트 수준 변수 (프로젝트 속성 참조)

  • Layer Properties 대화창에서 벡터 레이어 수준 변수 (벡터 속성 대화창 참조)

  • 인쇄 조판기의 Layout 패널에서 조판기 수준 변수 (조판 패널 참조)

  • 인쇄 조판기의 Item Properties 패널에서 조판 항목 수준 변수 (조판기 항목 공통 옵션 참조)

편집 가능한 변수와 구별하기 위해, 읽기 전용 변수의 명칭 및 값을 이탤릭체로 표시합니다. 다른 한편으로, 하위 수준 변수가 덮어쓰는 상위 수준 변수엔 취소선이 그어집니다.

../../../_images/options_variables.png

그림 11.24 프로젝트 수준 변수 편집기

참고

나이얼 도슨(Nyall Dawson)의 블로그 게시글, QGIS 2.12에서의 변수 탐구 1편, 2편 그리고 3편 에서 더 자세한 정보와 예시들을 찾아볼 수 있습니다.

11.8. 인증

QGIS에는 안전한 방식으로 인증서(authentication credentials)를 저장/검색할 수 있는 기능이 있습니다.사용자는 인증 환경 설정 안에 인증서를 안전하게 저장할 수 있는데, 인증 환경 설정은 자체 데이터베이스에 저장되어 서버 또는 데이터베이스 연결에 적용할 수 있으며 프로젝트 또는 설정 파일에서 ID 토큰으로 안전하게 참조할 수 있습니다. 더 자세한 정보를 원한다면 인증 시스템 을 참조하세요.

인증 시스템 및 그 자체 데이터베이스를 처음 실행할 때 마스터 비밀번호를 설정해줘야 합니다.

11.9. 일반 위젯

사용자가 QGIS에서 자주 사용해야 할 옵션이 몇 개 있습니다. QGIS는 사용자 편의를 위해 다음에 소개하는 특별 위젯들을 제공합니다.

11.9.1. 색상 선택기

11.9.1.1. 색상 대화창

사용자가 색상을 선택하기 위해 selectColor 아이콘을 클릭할 때마다 Select Color 대화창이 열립니다. Settings ‣ Options… ‣ General 메뉴에 있는 Use native color chooser dialogs 파라미터 체크박스의 상태에 따라 이 대화창의 기능이 달라집니다. 체크된 상태라면, QGIS가 실행 중인 OS의 색상 대화창이 열립니다. 해제된 경우엔 QGIS 전용 색상 선택기가 열립니다.

전용 색상 선택기 대화창은 사용자가 색상을 선택할 수 있도록 colorBox Color ramp 색상표, colorWheel Color wheel 색상환, colorSwatches Color swatches 색상 견본표 또는 colorPicker Color picker 색상 추출기 탭 4개를 보유하고 있습니다. 앞의 두 탭을 통해 가능한 모든 색상 조합을 탐색하고 항목에 사용자 선택 사항을 적용할 수 있습니다.

../../../_images/color_selector_ramp.png

그림 11.25 색상 선택기의 색상표 탭

colorSwatches Color swatches 탭에 있는 색상표 목록에서 색상을 선택할 수 있습니다. (자세한 내용은 색상 설정 을 참조하세요.) 프레임 하단에 있는 signPlus Add current colorsignMinus Remove selected color 버튼으로 Recent colors 색상표를 제외한 모든 색상표를 수정할 수 있습니다.

색상표 콤보박스 옆에있는 버튼을 클릭하면 다음 옵션들을 선택할 수 있습니다:

  • 색상을 복사, 붙여넣기, 불러오기 또는 내보내기

  • 색상표를 생성, 불러오기 또는 제거하기

  • Show in Color Buttons 옵션을 활성화시키면 색상 선택기 위젯(빠른 색상 선택기 메뉴 그림 참조)에 사용자 지정 색상표를 추가합니다.

../../../_images/color_selector_recent_colors.png

그림 11.26 색상 선택기의 색상 견본표 탭

사용자가 QGIS UI의 어디에서라도 또는 다른 응용 프로그램에서라도 마우스 커서 아래에 있는 색상 표본을 추출할 수 있는 colorPicker Color picker 색상 추출기를 이용하는 옵션도 있습니다. 탭이 활성화된 상태에서 스페이스 바를 누르고, 원하는 색상 위로 마우스를 가져가서 클릭하거나 스페이스 바를 다시 누르십시오. Sample Color 버튼을 눌러도 색상 추출기가 활성화됩니다.

어떤 방법을 이용하든, 항상 HSV (색상 hue, 채도 saturation, 명도 value)와 RGB (적 red, 녹 green, 청 blue) 값에 대한 색상 슬라이드 바를 통해 선택한 색상을 설명합니다. HTML notation 으로도 색상을 식별할 수 있습니다.

색상환(color wheel)이나 색상표(color ramp) 또는 모든 색상 파라미터 슬라이드 바를 클릭하는 것만으로도 쉽게 색상을 조정할 수 있습니다. 색상 파라미터들 옆에 있는 스핀박스를 통해 또는 해당 슬라이드 바에 커서를 가져가서 마우스 휠을 돌리면 이런 파라미터들을 변경할 수 있습니다. HTML notation 에 색상을 입력할 수도 있습니다. 마지막으로, 투명도 수준을 설정하기 위한 Opacity 슬라이드 바가 있습니다.

이 대화창에서 (오브젝트에 적용된) Old 색상과 (선택한) Current 색상을 시각적으로 비교해볼 수도 있습니다. 이렇게 선택한 색상을 손쉽게 쓸 수 있도록 슬롯에 드래그&드롭해서 또는 atlasNext Add color to swatch 버튼을 클릭해서 저장할 수 있습니다.

빠른 색상 조정

색상 선택기 위젯을 다른 색상 선택기 위젯으로 드래그&드롭하면 해당 위젯의 색상을 적용합니다.

11.9.1.2. 색상 드롭다운 단축키

selectColor 색상 버튼 오른쪽에 있는 드롭다운 화살표를 클릭하면 빠른 색상 선택을 위한 위젯을 표시합니다. 이 단축키로 다음 기능에 접근할 수 있습니다:

  • 색상을 선택하기 위한 색상환

  • 색상 투명도를 변경하기 위한 알파값 슬라이드 바

  • 이전에 Show in Color Buttons 에 설정된 색상표

  • 현재 색상을 복사해서 다른 위젯으로 붙여넣기

  • 사용자의 컴퓨터 스크린 어느 곳에서든 색상 선택

  • 색상 선택기 대화창에서 색상 선택

  • 빠른 색상 조정을 위해 한 위젯에서 다른 위젯으로 색상을 드래그&드롭

참고

데이터 정의 무시 속성을 통해 색상 위젯이 프로젝트 색상 으로 설정돼 있는 경우, 앞에서 설명한 색상 변경 기능들을 사용할 수 없습니다. 색상을 변경하려면 먼저 Unlink color 로 색상을 해제하거나 Clear 로 색상 정의를 초기화해야 합니다.

../../../_images/quick_color_selector.png

그림 11.27 빠른 색상 선택기 메뉴

11.9.1.3. 색상표 드롭다운 단축키

색상표는 하나 이상의 피처에 색상 집합을 적용할 수 있는 실용적인 방법입니다. 색상표 설정 절에서 색상표를 생성하는 방법을 설명하고 있습니다. 색상의 경우, selectColorRamp 색상표 버튼을 클릭하면 그에 대응하는 유형의 색상표 대화창이 열려 그 속성을 변경할 수 있습니다.

../../../_images/color_ramp_brewer.png

그림 11.28 컬러브루어(colorbrewer) 색상표 사용자 지정하기

옵션 오른쪽에 있는 드롭다운 메뉴를 통해 다음과 같은 더 다양한 색상 모음 및 옵션에 빠르게 접근할 수 있습니다:

  • Invert Color Ramp: 반전 색상표

  • Style Manager 대화창에서 Favorites 로 표시된 gradient 또는 catalog: cpt-city 색상표의 미리보기

  • 호환 가능한 색상표 데이터베이스에 접근할 수 있는 All Color Ramps

  • 현재 위젯에서 사용할 수 있는 모든 지원 색상표 유형을 생성하는 Create New Color Ramp… (이 색상표를 라이브러리에 저장하지 않으면 현재 위젯에서밖에 사용할 수 없다는 사실을 기억하십시오.)

  • Edit Color Ramp…: 전체 색상표 버튼을 클릭하는 것과 동일

  • Save Color Ramp…: 스타일 라이브러리에 현재 색상표를 사용자 지정 사항과 함께 저장

../../../_images/quick_colorramp_selector.png

그림 11.29 빠른 색상표 선택 위젯

11.9.2. 심볼 위젯

Symbol 선택기 위젯은 피처의 심볼 속성을 설정하고자 할 때 편리한 단축키입니다. 드롭다운 화살표를 클릭하면 색상 드롭다운 위젯 의 기능과 함께, 다음과 같은 심볼 옵션이 표시됩니다:

  • Configure Symbol…: 심볼 선택기 위젯 버튼을 클릭하는 것과 동일합니다. 이 메뉴는 심볼 파라미터 를 설정하는 대화창을 엽니다.

  • Copy Symbol: 현재 항목의 심볼을 복사합니다.

  • Paste Symbol: 현재 항목에 클립보드의 심볼을 붙여넣습니다. 심볼을 빠르게 환경 설정할 수 있습니다.

11.9.3. 글꼴 선택기

Font 선택기 위젯은 텍스트 정보(피처 라벨, 장식 라벨, 맵 범례 텍스트 등등)의 글꼴 속성을 설정하고자 할 때 편리한 단축키입니다. 드롭다운 화살표를 클릭하면 다음과 같은 옵션이 표시됩니다:

../../../_images/fontselector_widget.png

그림 11.30 글꼴 선택기 드롭다운 메뉴

  • Font Size: 관련 단위로 된 글꼴 크기

  • Recent Fonts ‣: (맨 위에) 활성화 글꼴이 체크되어 있는 최근 사용 글꼴 목록

  • Configure Format…: 글꼴 선택기 위젯 버튼을 클릭하는 것과 동일합니다. 텍스트 서식 파라미터를 설정하는 대화창을 엽니다. 맥락에 따라, OS의 기본 Text format 대화창이 될 수도 있고 또는 라벨 텍스트 서식 설정 절에서 설명하는 고급 서식 작업 옵션(투명도, 기울기, 버퍼, 배경, 그림자 등등)을 가진 QGIS의 사용자 지정 대화창이 될 수도 있습니다.

  • Copy Format: 텍스트의 서식을 복사합니다.

  • Paste Format: 텍스트에 클립보드의 서식을 붙여넣습니다. 텍스트 서식을 빠르게 환경 설정할 수 있습니다.

11.9.4. 단위 선택기

QGIS의 항목(라벨, 심볼, 조판기 요소 등등)들의 크기 속성이 꼭 프로젝트 단위 또는 특정 레이어의 단위일 필요는 없습니다. 광범위한 속성 집합의 경우, Unit 선택기 드롭다운 메뉴를 통해 사용자가 원하는 (스크린 해상도, 용지 크기, 또는 지형에 기반한) 렌더링에 따라 단위 값을 조정할 수 있습니다. 다음과 같은 단위를 사용할 수 있습니다:

  • Millimeters

  • Points

  • Pixels

  • Inches

  • Meters at Scale: 이 옵션을 선택하면 기저 맵 단위가 (인치, 피트, 지리도(geographic degree) 등등) 무엇이든, 항상 크기를 미터 단위로 설정할 수 있습니다. 현재 프로젝트 타원체 설정을 기반으로 크기를 미터 단위로 계산하며, 현재 맵 범위의 중심에서 거리의 투영을 미터 단위로 계산합니다.

  • Map Units: 맵 뷰 축척에 따라 크기를 조정합니다. 이렇게 하면 너무 크거나 너무 작은 값이 될 수 있기 때문에, 입력란 옆에 있는 options 버튼을 사용해서 크기를 다음과 같은 기준을 기반으로 하는 값의 범위로 제한하십시오:

    • Minimum scaleMaximum scale: 두 축척 제한값 가운데 어느 한쪽에 도달할 때까지 맵 뷰 축척을 기반으로 값을 조정합니다. 축척이 제한 범위를 넘어서면, 가장 가까운 축척 제한에서의 값을 유지합니다.

    • 그리고/또는 mm 단위로 된 Minimum sizeMaximum size: 두 축척 제한값 가운데 어느 한쪽에 도달할 때까지 맵 뷰 축척을 기반으로 값을 조정합니다. 축척이 제한 범위를 넘어서면 제한에서의 크기를 유지합니다.

    ../../../_images/adjust_scaling.png

    그림 11.31 축척 범위 조정 대화창

11.9.5. 혼합 모드

QGIS는 사용자가 이전에 그래픽 프로그램으로밖에 몰랐을 특별한 렌더링 효과를 위한 여러 옵션과 함께 이 도구를 제공합니다. 레이어나 피처에 적용할 수 있지만, 인쇄 조판기 항목에도 다음 혼합 모드를 적용할 수 있습니다:

  • Normal: 표준 혼합 모드로, 위에 있는 픽셀의 알파 채널을 이용해서 밑에 있는 픽셀과 혼합합니다. 색상은 섞이지 않습니다.

  • Lighten: 위에 있는 픽셀과 밑에 있는 픽셀로부터 각 요소의 최대값을 선택합니다. 이 모드의 산출물은 경계가 도드라져 보기 안 좋은 경향이 있다는 사실을 주의하십시오.

  • Screen: 원본의 밝은 픽셀은 산출물에 렌더링되는 반면, 어두운 픽셀은 렌더링되지 않습니다. 이 모드는 한 항목의 질감을 다른 항목과 섞는 데 가장 유용합니다. (예를 들어 어떤 레이어에 질감을 부여하는 데 음영기복도를 사용할 수 있습니다.)

  • Dodge: 위에 있는 픽셀의 밝기를 바탕으로 밑에 있는 픽셀의 명도와 채도를 올립니다. 따라서 위에 있는 픽셀이 밝을수록 밑에 있는 픽셀의 채도와 명도가 증가합니다. 위에 있는 픽셀이 너무 밝지 않을 때 가장 유용합니다. 너무 밝을 경우 그 효과가 극단적일 것입니다.

  • Addition: 이 혼합 모드는 한 항목의 픽셀값을 다른 항목의 픽셀값에 더합니다. (RGB 값이) 최대값을 초과하는 경우 하얀색으로 표시합니다. 피처를 강조하려 할 때 적당한 모드입니다.

  • Darken: 위에 있는 픽셀과 밑에 있는 픽셀 요소 가운데 최저값을 유지합니다. Lighten 모드와 마찬가지로 보기에 안 좋은 경향이 있습니다.

  • Multiply: 위에 있는 항목의 각 픽셀의 값을 밑에 있는 항목의 픽셀의 대응 값과 곱합니다. 산출물이 어둡게 보이게 됩니다.

  • Burn: 위에 있는 항목의 색상이 어두울수록 밑에 있는 항목도 어두워집니다. 밑에 있는 레이어에 색상을 부여하고 조정하는 데 이 모드를 쓸 수 있습니다.

  • Overlay: 이 모드는 Multiply와 Screen 혼합 모드를 조합합니다. 밝은 부분은 더 밝고 어두운 부분은 더 어두운 산출물을 생성합니다.

  • Soft light: Overlay 모드와 매우 비슷하지만, Multiply/Screen 을 이용하는 대신 Burn/Dodge 모드의 색상을 이용합니다. 이미지 위에 부드러운 빛을 비추는 것 같은 효과를 낸다고 합니다.

  • Hard light: 이 모드도 Overlay 모드와 매우 비슷합니다. 이미지 위에 아주 강렬한 빛을 비추는 것 같은 효과를 낸다고 합니다.

  • Difference: 이 모드는 밑에 있는 픽셀값에서 위에 있는 픽셀값을 빼거나 그 반대로 계산해서 항상 양의 값을 남깁니다. 검정색은 혼합해도 아무 변화가 없습니다. 모든 색상과의 차가 0이기 때문입니다.

  • Subtract: 이 혼합 모드는 한 항목의 픽셀값에서 다른 항목의 픽셀값을 뺍니다. 음의 값이 나올 경우 검정색으로 표시합니다.

11.9.6. 데이터 정의 무시 설정

벡터 레이어 속성 대화창 또는 인쇄 조판기의 설정에는 많은 옵션들이 있지만, 그 중에서도 dataDefined Data defined override 아이콘이 있습니다. 레이어 속성 또는 항목 설정에 기반한 표현식, 미리 작성한 또는 사용자 지정한 함수, 그리고 변수 를 사용하면 이 도구로 파라미터에 대한 동적인 값을 설정할 수 있습니다. 이 옵션을 활성화하면, 일반적인 값(체크박스, 텍스트 상자, 슬라이드 바 등등)에 상관없이 파라미터에 이 위젯이 반환하는 값을 적용합니다.

11.9.6.1. 데이터 정의 무시 위젯

dataDefined Data defined override 아이콘을 클릭하면 다음과 같은 항목들을 표시합니다:

  • Description… 은 해당 옵션 활성화 여부, 입력해야 할 값, 유효한 입력 유형 그리고 현재 정의를 설명합니다. 위젯에 마우스를 가져가도 이 정보들을 팝업으로 표시합니다.

  • Store data in the project: 보조 저장소 속성 메커니즘을 사용해서 속성을 저장할 수 있는 버튼입니다.

  • Field type: 유효한 입력 유형과 일치하는 레이어의 필드로부터 선택하는 항목입니다.

  • Color: 위젯이 색상 속성과 링크되어 있는 경우, 이 메뉴를 사용하면 정의된 색상을 현재 프로젝트 색상 스키마의 일부로서 접근할 수 있습니다.

  • Variable: 사용할 수 있는 사용자 정의 변수 에 접근할 수 있는 메뉴입니다.

  • Edit…: Expression String Builder 대화창을 열어 표현식을 생성하거나 편집해서 적용할 수 있는 버튼입니다. 표현식을 정확히 작성할 수 있도록, 대화창에 기대되는 산출물의 서식을 알려주는 메시지를 표시합니다.

  • PasteCopy 버튼

  • Clear 버튼은 설정을 초기화합니다.

  • 수치 및 색상 속성의 경우, Assistant… 메뉴를 사용해서 속성에 피처 데이터를 어떻게 적용시킬지 재조정할 수 있습니다. (자세한 내용은 다음 절 을 참조하세요.)

오른쪽 클릭으로 데이터 정의 무시를 (비)활성화하기

데이터 정의 무시 옵션을 정확하게 설정했다면 노란색 dataDefineOn 또는 dataDefineExpressionOn 아이콘이 표시됩니다. 옵션이 정확하지 않다면 빨간색 dataDefineError 또는 dataDefineExpressionError 아이콘이 표시됩니다.

위젯을 오른쪽 클릭하는 것만으로도 환경 설정된 dataDefined data-defined override 버튼을 활성화시키거나 비활성화시킬 수 있습니다.

11.9.6.2. 데이터 정의 어시스턴트 인터페이스 사용하기

dataDefined Data-defined override 버튼이 수치 또는 색상 파라미터와 연결되어 있는 경우, Assistant… 옵션을 사용해서 각 피처의 파라미터에 데이터를 어떻게 적용할지를 변경할 수 있습니다. 어시스턴트는 다음과 같은 작업을 할 수 있습니다:

  • Input 데이터를 정의할 수 있습니다. 예를 들어:

    • 필드 목록 상자 또는 expression Set column expression 기능을 사용해서 표현할 속성 (표현식 참조)

    • 표현할 값의 범위: 사용자가 직접 입력하거나 refresh Fetch value range from layer 버튼을 눌러 선택한 속성 또는 사용자 데이터에 적용된 표현식이 반환한 최소최대값으로 필드를 자동적으로 채울 수 있습니다.

  • unchecked Apply transform curve: 기본적으로 산출값은 선형 척도를 따라 입력 피처에 적용되지만, 이 로직을 다음과 같이 무시할 수 있습니다: 변환 옵션을 활성화하고, 그래픽을 클릭해서 중단점(break point)(들)을 추가한 다음 해당 중단점(들)을 드래그해서 사용자 지정 분포를 적용하십시오.

  • Output 값을 정의할 수 있습니다: 이 옵션은 정의할 파라미터에 따라 달라집니다. 다음 전체 수준 값을 설정할 수 있습니다:

    • 선택한 속성에 적용할 최소최대값 (색상 설정 작업 시 색상표 를 제공해야 합니다.)

    • Scale method: 표현에 사용할 척도 방법을 Flannery, Exponential, Surface 또는 Radius 가운데 선택할 수 있습니다.

    • Exponent: 데이터 척도에 사용할 지수를 정의할 수 있습니다.

    • NULL 값을 가진 피처를 표현할 산출값 또는 색상 을 정의할 수 있습니다.

적용이 가능한 속성인 경우, 대화창 오른쪽에 실시간으로 업데이트되는 미리보기를 표시해서 사용자가 값 조정 작업을 제어할 수 있도록 해줍니다.

../../../_images/varying_size_assistant.png

그림 11.32 데이터 정의 크기 어시스턴트

위의 변화하는 크기 어시스턴트에 나온 값들은 다음 표현식으로 〈데이터 정의 무시〉 크기를 설정할 것입니다:

coalesce(scale_exp(Importance, 1, 20, 2, 10, 0.57), 1)