17.1. 인쇄 조판기 개요

인쇄 조판기가 제공하는 조판 및 인쇄 기능은 점차 증가하고 있습니다. QGIS 맵 캔버스, 텍스트 라벨, 이미지, 범례, 축척 막대, 기본 도형, 화살표, 속성 테이블 및 HTML 프레임과 같은 항목들을 추가할 수 있습니다. 각 항목의 크기를 조정하고 그룹화하고 정렬하고 배치하고 기울이며, 그 속성을 수정해서 사용자의 조판을 생성할 수 있습니다. 이 조판을 인쇄하거나 또는 이미지 포맷, PostScript, PDF 또는 SVG 파일로 내보낼 수 있습니다. 사용자가 만든 조판을 템플릿으로 저장해서 다른 세션에서 다시 불러올 수도 있습니다. 마지막으로, 지도책 생성기를 통해 템플릿 하나에 기반한 여러 맵을 생성할 수 있습니다.

17.1.1. 초보자를 위한 예시 세션

인쇄 조판기 작업을 시작하기 전에, QGIS 맵 캔버스에 래스터 또는 벡터 레이어를 몇 개 불러온 다음 레이어 속성을 사용자 편의에 맞춰 조정해야 합니다. 모든 것이 사용자 마음에 들도록 렌더링되고 심볼도 적용된 후에야, 툴바에 있는 newLayout New Print Layout 아이콘을 클릭하거나 File ‣ New Print Layout 메뉴 옵션을 선택하십시오. 새 조판기의 제목을 설정하라는 메시지가 뜰 것입니다.

맵을 어떻게 생성하는지 보고 싶다면 다음 지침을 따라주십시오.

  1. 대화창 좌측에서, addMap Add new map 툴바 버튼을 클릭하고 왼쪽 마우스 버튼을 누른 채 조판기 캔버스 위에 직사각형을 드래그하십시오. 이 직사각형 안쪽에 QGIS 맵 뷰가 추가됩니다.

  2. scaleBar Add new scalebar 툴바 버튼을 클릭하고 인쇄 조판기 캔버스를 왼쪽 클릭하십시오. 캔버스에 축척 막대가 추가됩니다.

  3. addLegend Add new legend 툴바 버튼을 클릭하고 왼쪽 마우스 버튼을 누른 채 캔버스 위에 직사각형을 드래그하십시오. 이 직사각형 안쪽에 범례를 렌더링할 것입니다.

  4. select Select/Move item 아이콘을 클릭해서 캔버스 상에 있는 지도를 선택한 다음 조금 움직여보십시오.

  5. 지도 항목이 선택 상태인 동안 그 크기를 변경할 수도 있습니다. 지도 항목의 모서리에 있는 하얀색 정사각형을 클릭하고 왼쪽 마우스 버튼을 누른 채 새 위치로 드래그하면 지도의 크기를 변경합니다.

  6. 좌하단에 있는 Item Properties 패널을 선택한 다음 방향 관련 옵션을 찾아, Map orientation 의 설정값을 〈15.00°〉로 변경하십시오. 지도 항목의 방향이 바뀐 것을 볼 수 있을 겁니다.

  7. 이제 사용자가 만든 인쇄 조판을 인쇄하거나 또는 Layout 메뉴에 있는 내보내기 도구를 통해 이미지 포맷, PDF 또는 SVG 파일로 내보낼 수 있습니다.

  8. 마지막으로, fileSave Save Project 버튼을 클릭하면 프로젝트 파일 안에 사용자의 인쇄 조판을 저장할 수 있습니다.

조판기에 여러 요소들을 추가할 수 있습니다. 인쇄 조판기 캔버스에 하나 이상의 맵 뷰, 범례 또는 축척 막대를 놓을 수도 있고, 지도를 한 장 이상 조판할 수도 있습니다. 각 요소는 고유 속성을 보유하고 있으며, 지도의 경우 고유 범위를 보유하고 있습니다. 조판기 캔버스에서 어떤 항목을 제거하고 싶다면, Delete 또는 Backspace 키를 눌러 삭제할 수 있습니다.

17.1.2. 조판 관리자

Layout Manager 란 프로젝트의 인쇄 조판을 관리할 수 있는 주 대화창입니다. 기존 인쇄 조판의 오버뷰 및 프로젝트의 보고서를 볼 수 있고, 다음과 같은 도구를 제공합니다:

  • 새 인쇄 조판을 추가하고, 기초부터 보고서를 추가하고, 템플릿을 추가하거나 기존 템플릿을 복제할 수 있습니다.

  • 인쇄 조판, 보고서, 템플릿을 재명명하거나 삭제할 수 있습니다.

  • 프로젝트에서 인쇄 조판, 보고서, 템플릿을 열 수 있습니다.

조판 관리자 대화창을 열려면:

  • QGIS 주 대화창에서 Project ‣ Layout Manager… 메뉴를 선택하거나 Project Toolbar 에 있는 layoutManager Layout Manager 버튼을 클릭하십시오.

  • 인쇄 조판기 또는 보고서 대화창에서 Layout ‣ Layout Manager… 메뉴를 선택하거나 Layout Toolbar 에 있는 layoutManager Layout Manager 버튼을 클릭하십시오.

../../../_images/print_composer_manager.png

그림 17.1 인쇄 조판 관리자

조판 관리자 상단에 있는 목록은 프로젝트에서 사용할 수 있는 모든 인쇄 조판 또는 보고서를 담고 있습니다. 다음과 같은 도구들이 있습니다:

  • Show: 여러 보고서 그리고/또는 인쇄 조판(들)을 클릭 한 번으로 선택하고 열 수 있습니다. 명칭을 더블클릭해서 열 수도 있습니다.

  • duplicate the selected print layout or report (available only if one item is selected): it creates a new dialog using the selected one as template. You’ll be prompted to choose a new title for the new layout;

  • rename the report or layout (available only if one item is selected): you’ll be prompted to choose a new title for the layout;

  • Remove…: 조판을 제거합니다. 프로젝트에서 선택한 인쇄 조판(들)을 삭제할 것입니다.

조판 관리자 하단에서 새 인쇄 조판을 생성하고, 기초부터 보고서를 생성하거나 템플릿을 생성할 수 있습니다. 기본적으로, QGIS는 사용자 프로파일과 응용 프로그램 템플릿 디렉터리(프레임 하단에 있는 두 버튼으로 접근할 수 있습니다)는 물론, Settings ‣ Options ‣ Layouts 메뉴에서 Path(s) to search for extra print templates 로 선언된 모든 폴더에서도 템플릿을 찾을 것입니다. 찾아낸 모든 템플릿은 콤보박스 목록에 표시됩니다. 항목을 하나 선택한 다음 Create 버튼을 클릭하면 새 보고서 또는 인쇄 조판을 생성합니다.

물론 사용자가 사용자 지정 폴더에 있는 조판 템플릿을 사용할 수도 있습니다. 이 경우 템플릿 드롭다운 목록에서 specific 을 선택한 다음, 템플릿을 탐색해서 Create 버튼을 클릭하십시오.

탐색기 패널에서 템블릿 기반 인쇄 조판을 생성하기

어느 파일 탐색기에서든 인쇄 조판 템플릿 .qpt 파일을 맵 캔버스로 드래그&드롭하거나, 또는 탐색기 패널 에서 해당 파일을 더블클릭하면 템플릿으로부터 새 인쇄 조판을 생성합니다.