13.1. 데이터 열기

오픈소스 소프트웨어 생태계의 일원으로서, QGIS는 서로 다른 라이브러리들을 기반으로 빌드되어, 자체 제공자와 결합해 다음과 같은 여러 포맷들을 읽고, 많은 경우 작성할 수도 있는 능력을 갖추고 있습니다:

  • GeoPackage, GML, GeoJSON, GPX, KML, 쉼표 구분 값, ESRI 포맷(shapefile, Geodatabase 등등), MapInfo 및 MicroStation 파일 포맷, AutoCAD DWG/DXF, GRASS, 그 외에도 많은 포맷들을 포함하는 벡터 데이터 유형을 지원합니다. 지원 벡터 유형 의 전체 목록을 읽어보세요.

  • GeoTIFF, JPEG, ASCII Gridded XYZ, MBTiles, R 또는 Idrisi 래스터, GDAL Virtual, SRTM, Sentinel Data, ERDAS IMAGINE, ArcInfo Binary Grid, ArcInfo ASCII Grid, 그 외에도 많은 포맷들을 포함하는 래스터 데이터 유형을 지원합니다. 지원 래스터 유형 의 전체 목록을 읽어보세요.

  • PostgreSQL/PostGIS, SQLite/SpatiaLite, Oracle, DB2 또는 MSSQL Spatial, MySQL, 그 외에도 많은 데이터베이스를 포함하는 데이터베이스 유형을 지원합니다.

  • QGIS 제공자는 WM(T)S, WFS, WCS, CSW, XYZ 타일, ArcGIS 서비스 등의 웹 맵 및 데이터 서비스 지원도 처리하고 있습니다. 자세한 정보를 알고 싶다면 OGC 데이터 클라이언트로서의 QGIS 를 참조하세요.

  • 보존된(archived) 폴더에서 지원하는 파일을 읽어올 수 있고, QML 파일(QML ─ QGIS 스타일 파일 포맷), 가상(virtual) 및 메모리 레이어 같은 QGIS 자체 포맷도 사용할 수 있습니다.

GDAL 과 QGIS 자체 제공자는 벡터 포맷 80개 이상, 래스터 포맷 140개 이상을 지원하고 있습니다.

참고

목록에 있는 포맷 가운데 여러 가지 이유로 인해 QGIS에서 작동하지 않는 포맷이 있을 수도 있습니다. 예를 들어 일부 포맷은 외부 상표등록 라이브러리가 필요할 수도 있고, 사용자 OS에 GDAL/OGR을 설치했을 때 사용자가 원하는 유형을 지원하도록 빌드되지 않았을 수도 있습니다. 사용할 수 있는 포맷 목록을 얻으려면, QGIS에서 (벡터의 경우) ogrinfo --formats 명령어를 실행하거나 (래스터의 경우) Settings ‣ Options ‣ GDAL 메뉴를 확인하십시오.

QGIS는 데이터 유형에 따라 서로 다른 도구로 데이터셋을 열 수 있습니다. 주로 Layer ‣ Add Layer ‣ 메뉴나 (View ‣ Toolbars 메뉴에서 활성화할 수 있는) Manage Layers 툴바를 사용합니다. 하지만 이 모든 도구들은 결국 Data Source Manager Toolbar 에 있는 dataSourceManager Open Data Source Manager 버튼이나 Ctrl+L 조합키로 열 수 있는 단일한 Data Source Manager 대화창으로 연결됩니다. 이 Data Source Manager 대화창은 벡터 또는 래스터 파일 기반 데이터는 물론 QGIS가 지원하는 데이터베이스나 웹 서비스도 열 수 있는 통합 인터페이스를 제공합니다. Settings ‣ Options ‣ General 메뉴의 checkbox Modeless data source manager dialog 옵션을 켜면 모달리스 대화창으로, 끄면 모달 대화창으로 설정할 수 있습니다.

../../../_images/datasource_manager.png

그림 13.1 QGIS 데이터소스 관리자 대화창

이런 주 진입점(entry point) 외에, 연결된 데이터베이스를 분석하고 처리할 수 있는 고급 성능을 제공하는 dbManager DB Manager 플러그인도 있습니다. DB 관리자 성능에 대한 자세한 정보는 데이터베이스 관리자 플러그인 에서 찾아볼 수 있습니다.

사용자가 다양한 데이터 유형들을 열 수 있도록 해주는 다른 도구들, 자체 또는 제3자 플러그인들도 다수 존재합니다.

이 장에서는 QGIS가 데이터를 불러올 때 기본적으로 제공하는 도구들에 대해서만 설명할 것입니다. 주로 Data Source Manager 대화창에 집중하겠지만, 각 탭을 설명하는 데 그치지 않고 데이터 제공자 또는 포맷 사양에 기반한 도구들에 대해서도 알아볼 것입니다.

13.1.1. 탐색기 패널

Browser 는 프로젝트에 사용자 데이터를 쉽고 빠르게 추가할 수 있는 주된 방법 가운데 하나입니다. 다음 방법으로 사용할 수 있습니다:

  • dataSourceManager Open Data Source Manager 버튼을 누르면 (Ctrl+L 조합키를 누르면) Data Source Manager 탭이 활성화됩니다.

  • QGIS의 패널이므로, View ‣ Panels (또는 kde Settings ‣ Panels) 메뉴를 통해 또는 Ctrl+2 조합키를 눌러 열 수 있습니다.

어떻게 열든, Browser 를 통해 사용자 파일 시스템을 둘러보고 레이어 유형 (래스터, 벡터, 테이블) 또는 데이터소스 유형(일반 또는 압축 파일, 데이터베이스, 웹 서비스)에 상관없이 지리 데이터(geodata)를 관리할 수 있습니다.

13.1.1.1. 인터페이스 탐구

탐색기 패널 상단에 있는 아이콘의 기능은 다음과 같습니다:

  • addLayer Add Selected Layers: 레이어의 컨텍스트 메뉴에서 Add selected layer(s) 를 선택해도 맵 캔버스에 데이터를 추가할 수 있습니다.

  • refresh Refresh: 탐색 트리를 새로고칩니다.

  • filterMap Filter Browser: 특정 데이터를 검색합니다. 검색어 또는 임의 문자 기호(wildcard)를 입력하면 탐색기가 트리를 필터링해서 입력 문자열과 일치하는 데이터베이스 테이블, 파일명 또는 폴더를 가리키는 경로만 표시합니다. 일치하지 않는 다른 데이터 또는 폴더는 숨깁니다. 나란히 있는 QGIS 탐색기 패널 그림의 Browser Panel(2) 예시를 참조하십시오. 필터링 작업은 대소문자를 구분할 수도 있고 안 할 수도 있습니다. 다음 옵션으로 필터링을 설정할 수도 있습니다:

    • Normal: 검색어를 포함하는 모든 항목을 반환합니다.

    • Wildcard(s): 검색 문자열에서 위치를 지정하는 ? 그리고/또는 * 문자를 이용해서 검색을 세밀하게 조정합니다.

    • Regular expression: 정규 표현식을 이용합니다.

  • collapseTree Collapse All: 탐색 트리 전체를 접습니다.

  • metadata Enable/disable properties widget: 속성 위젯을 켜고 끕니다. 활성화하면, 패널 하단에 선택한 항목의 (메타데이터가 있는 경우) 메타데이터를 표시하는 새 위젯을 추가합니다.

Browser 패널의 항목들은 위계에 따라 구성돼 있으며, 여러 최상위 수준 항목들이 있습니다:

  1. Favorites: 자주 사용하는 위치를 가리키는 단축키를 배치할 수 있는 곳입니다.

  2. Spatial Bookmarks: 자주 사용하는 맵 범위를 저장할 수 있는 곳입니다. (공간 북마크 참조)

  3. Project Home: 사용자 프로젝트와 관련된 (대부분의) 데이터가 저장돼 있는 폴더에 빠르게 접근할 수 있습니다. 기본값은 사용자의 프로젝트 파일이 위치한 디렉터리입니다.

  4. Home: 파일 시스템의 홈 디렉터리 및 파일 시스템 루트 디렉터리

  5. 연결된 로컬 또는 네트워크 드라이브

  6. 그 다음 사용자 플랫폼과 기저 라이브러리에 따라 여러 컨테이너/데이터베이스 유형과 서비스 프로토콜이 나열됩니다:

    • geoPackage GeoPackage

    • spatialite SpatiaLite

    • postgis PostGIS

    • mssql MSSQL

    • oracle Oracle

    • db2 DB2

    • wms WMS/WMTS

    • wms XYZ Tiles

    • wcs WCS

    • wfs WFS

    • ows OWS

    • ams ArcGISMapServer

    • afs ArcGISFeatureServer

    • geonode GeoNode

13.1.1.2. 탐색기 항목과 대화형 작업

탐색기는 드래그&드롭을 지원합니다. 탐색기 내부에서, 탐색기에서 캔버스 및 Layers 패널로, 그리고 Layers 패널에서 탐색기에 있는 (GeoPackage 같은) 레이어 컨테이너로 드래그&드롭할 수 있습니다.

탐색기에 있는 프로젝트 파일 항목을 해당 프로젝트가 담고 있는 (그룹 포함) 전체 레이어 트리를 표시하도록 펼칠 수 있습니다. 프로젝트 항목을 브라우저의 다른 모든 항목과 마찬가지로 취급하기 때문에, 탐색기 안에서 드래그&드롭하거나 (예를 들어 레이어 항목을 GeoPackage 파일로 복사하거나) 현재 프로젝트에 드래그&드롭 또는 더블 클릭을 통해 추가할 수도 있습니다.

Browser 패널에 있는 요소를 오른쪽 클릭하면 컨텍스트 메뉴가 열립니다.

파일 시스템 디렉터리 항목의 경우, 컨텍스트 메뉴에서 다음 옵션을 선택할 수 있습니다:

  • New –>

    • Directory…

    • GeoPackage…

    • ShapeFile…

  • Add as a Favorite

  • Hide from Browser

  • Fast Scan this Directory

  • Open Directory

  • Open in Terminal

  • Properties…

  • Directory Properties…

Favourites, can also be removed and renamed:

  • Rename favourite…

  • Remove favourite

프로젝트에서 레이어로 동작할 수 있는 리프(leaf; 맨 마지막 끝 노드) 항목의 경우, 컨텍스트 메뉴에 지원하는 옵션을 표시할 것입니다. 예를 들어 데이터베이스나 서비스 기반이 아닌 벡터, 래스터 및 메시 데이터소스의 경우:

  • Delete File 《<name of file>》…

  • Export Layer –> To File…

  • Add Layer to Project

  • Layer Properties

  • File Properties

Layer properties 항목의 컨텍스트 메뉴는 (프로젝트에 레이어를 추가한 다음 벡터래스터 레이어 속성에서 찾을 수 있는 것과 비슷한) 다음 옵션을 표시할 것입니다:

  • 레이어 용 Metadata: 메타데이터 그룹은 Information from provider (가능한 경우, Path 가 소스를 가리키는 하이퍼링크일 것입니다), Identification, Extent, Access, Fields (벡터 레이어 용), Bands (래스터 레이어 용), Contacts, Links (벡터 레이어 용), References (래스터 레이어 용), History 입니다.

  • Preview 패널

  • (Attributes 패널에 있는) 벡터 소스 용 속성 테이블

Browser 를 사용해서 프로젝트에 레이어를 추가하려면:

  1. 앞에서 설명한대로 Browser 를 활성화하십시오. 사용자 파일 시스템, 데이터베이스 및 웹 서비스의 탐색 트리가 표시될 것입니다. 데이터베이스나 웹 서비스를 표시하려면 먼저 연결해야 할 수도 있습니다. (데이터베이스 또는 웹 서비스 절을 참조하세요.)

  2. 목록에서 레이어를 찾으십시오.

  3. 컨텍스트 메뉴를 사용해서 레이어 명칭을 더블 클릭하거나 맵 캔버스 로 레이어를 드래그&드롭하십시오. 레이어 패널 에 사용자 레이어를 추가하고 맵 캔버스 상에 표시할 것입니다.

    탐색기에서 QGIS 프로젝트를 직접 열기

    프로젝트 명칭을 더블 클릭하거나 맵 캔버스로 드래그&드롭하면 탐색기 패널에서 QGIS 프로젝트도 직접 열 수 있습니다.

파일을 불러왔다면, 맵 탐색 도구를 사용해서 레이어 주변을 확대/축소 및 이동할 수 있습니다. 레이어 스타일을 변경하려면 레이어 명칭을 더블 클릭하거나, 범례에서 레이어 명칭을 오른쪽 클릭하고 컨텍스트 메뉴에서 Properties 를 선택해서 Layer Properties 대화창을 여십시오. 벡터 레이어의 심볼을 설정하는 데 대한 자세한 내용을 알고 싶다면 심볼 속성 절을 참조하세요.

탐색 트리에 있는 항목을 오른쪽 클릭하면 다음 작업을 할 수 있습니다:

  • 파일 또는 테이블인 경우, 해당 항목의 메타데이터를 표시하거나 사용자의 프로젝트에 항목을 열 수 있습니다. 테이블의 경우 재명명하거나, 삭제하거나, 추출할 수도(truncate) 있습니다.

  • 폴더인 경우, 사용자의 즐겨찾기에 북마크해두고 탐색 트리에서 숨길 수 있습니다. Settings ‣ Options ‣ Data Sources 탭에서 이렇게 숨긴 풀더들을 관리할 수 있습니다.

  • 사용자의 공간 북마크 관리: 북마크를 생성하거나, XML 파일로 내보내거나 가져올 수 있습니다.

  • 데이터베이스 또는 웹 서비스로의 연결을 생성할 수 있습니다.

  • 스키마를 새로고침하거나, 재명명하거나 삭제할 수 있습니다.

단순히 드래그&드롭하는 것만으로도 데이터베이스로 파일을 불러들이거나 어떤 스키마/데이터베이스에서 다른 스키마/데이터베이스로 테이블을 복사할 수 있습니다. 드래그하는 동안 오래 스크롤을 해야 하는 일을 피하기 위해 두 번째 탐색 패널을 사용할 수 있습니다. 그냥 파일을 선택한 다음 한쪽 패널에서 다른 패널로 드래그&드롭하십시오.

../../../_images/browser_panels.png

그림 13.2 나란히 있는 QGIS 탐색기 패널

사용자 OS의 파일 탐색기에서 단순히 드래그&드롭하는 것만으로 QGIS에 레이어 추가

사용자의 운영체제 파일 탐색기에서 Layers Panel 또는 맵 캔버스로 파일(들)을 드래그&드롭해서 프로젝트에 추가할 수도 있습니다.

13.1.2. 데이터베이스 관리자

DB Manager 플러그인은 QGIS가 지원하는 공간 데이터베이스 유형(PostGIS, SpatiaLite, GeoPackage, Oracle Spatial, MSSQL, DB2, 가상 레이어)을 통합하고 관리하기 위한 또다른 도구입니다. Plugins ‣ Manage and Install Plugins… 메뉴에서 이 플러그인을 활성화시킬 수 있습니다.

dbManager DB Manager 플러그인은 다음 여러 기능들을 제공합니다:

  • 데이터베이스에 연결해서 그 구조 및 내용을 표시합니다.

  • 데이터베이스의 테이블을 미리보기합니다.

  • 맵 캔버스에 레이어를 더블 클릭 또는 드래그&드롭으로 추가합니다.

  • QGIS 탐색기에서 또는 다른 데이터베이스로부터 데이터베이스에 레이어를 추가합니다.

  • SQL 쿼리를 생성하고 맵 캔버스에 그 산출물을 추가합니다.

  • 가상 레이어 를 생성합니다.

데이터베이스 관리자 플러그인 에서 데이터베이스 관리자 성능에 관한 더 자세한 정보를 설명하고 있습니다.

../../../_images/db_manager.png

그림 13.3 데이터베이스 관리자 대화창

13.1.3. 제공자 기반 불러오기 도구

QGIS가 레이어를 추가하기 위해 제공하는 주 도구인 탐색기 패널 및 데이터베이스 관리자 이외에도, 데이터 제공자에 특화된 도구들이 존재합니다.

참고

일부 외부 플러그인 도 QGIS에서 특정 파일 포맷을 열기 위한 도구를 제공합니다.

13.1.3.1. 파일에서 레이어 불러오기

파일에서 레이어를 불러오려면:

  1. Data Source Manager 대화창에 있는 레이어 유형 탭을 선택하십시오. 예를 들면 dataSourceManager Open Data Source Manager 버튼을 클릭하고 (또는 Ctrl+L 조합키를 누르고) 레이어 유형 탭을 선택하거나:

    • 벡터 데이터(GML, ESRI Shapefile, Mapinfo 및 DXF 레이어 등)의 경우: Ctrl+Shift+V 조합키를 누르거나, Layer ‣ Add Layer ‣ addOgrLayer Add Vector Layer 메뉴 옵션을 선택하거나, addOgrLayer Add Vector Layer 툴바 버튼을 클릭하십시오.

      ../../../_images/addvectorlayerdialog.png

      그림 13.4 벡터 레이어 추가 대화창

    • 래스터 데이터(GeoTiff, MBTiles, GRIdded Binary 및 DWG 레이어 등)의 경우: Ctrl+Shift+R 조합키를 누르거나, Layer ‣ Add Layer ‣ addRasterLayer Add Raster Layer 메뉴 옵션을 선택하거나, addRasterLayer Add Raster Layer 툴바 버튼을 클릭하십시오.

      ../../../_images/addrasterlayerdialog.png

      그림 13.5 래스터 레이어 추가 대화창

  2. radioButtonOn File 소스 유형을 확인하십시오.

  3. Browse 버튼을 클릭하십시오.

  4. 파일 시스템을 탐색해서 지원 데이터소스를 불러오십시오. 대화창에서 Ctrl 키를 누른 채 여러 항목을 클릭하거나, Shift 키를 누른 채 선택 범위의 첫 번째 항목과 마지막 항목을 클릭하면 한 번에 하나 이상의 레이어를 불러올 수 있습니다. 잘 검증된 포맷들만 포맷 필터에 표시됩니다. (풀다운 메뉴에서 맨 위에 있는) All files 를 선택하면 다른 포맷들도 불러올 수 있습니다.

  5. Open 을 클릭하면 Data Source Manager 대화창으로 선택한 파일을 불러들입니다.

  6. 필요한 경우 벡터 파일용 인코딩을 지정할 수 있습니다.

  7. Add 를 클릭하면 QGIS로 파일을 불러와서 맵 뷰에 표시합니다. 알래스카 shapefile을 불러들인 QGIS 그림은 QGIS가 alaska.shp 파일을 불러들인 모습입니다.

    ../../../_images/shapefileloaded.png

    그림 13.6 알래스카 shapefile을 불러들인 QGIS

참고

MapInfo(예를 들면 .tab) 또는 Autocad(.dxf) 같은 일부 포맷은 파일 하나 안에 서로 다른 도형 유형을 함께 담을 수 있기 때문에 QGIS에 이런 포맷을 불러올 경우 레이어 하나 당 도형 유형 하나만 보유할 수 있도록, 사용할 도형을 선택할 수 있는 대화창이 열립니다.

addOgrLayer Add Vector LayeraddRasterLayer Add Raster Layer 탭에서는 File 이 아닌 소스 유형으로부터도 레이어를 불러올 수 있습니다:

  • ArcInfo Binary Coverage, UK. National Transfer Format 과 같은 특정 벡터 포맷 뿐만 아니라 US Census Bureau 또는 OpenfileGDB 의 raw TIGER 포맷도 불러올 수 있습니다. 이를 위해서는 Source type 으로 radioButtonOn Directory 를 선택해야합니다. 이때 Browse 를 누르면 대화창에서 디렉토리를 선택할 수 있습니다.

  • radioButtonOn Database 소스 유형로는 기존 데이터베이스 연결을 선택하거나 또는 선택한 데이터베이스 유형의 연결을 생성할 수 있습니다. ODBC, Esri Personal Geodatabase, MSSQL 은 물론 PostgreSQL 또는 MySQL 등 많은 데이터베이스 유형을 선택할 수 있습니다.

    New 버튼을 누르면 Create a New OGR Database Connection 대화창이 열립니다. 저장된 연결 생성하기 에서 이 대화창의 파라미터에 대한 내용을 찾아 볼 수 있습니다. Open 을 클릭하면, 예를 들어 PostGIS 활성 데이터베이스에서 사용 가능한 데이터베이스 테이블을 고를 수 있습니다.

  • radioButtonOn Protocol: HTTP(S), cloud, etc. 소스 유형은 로컬에 저장된 또는 네트워크 상에 있는 데이터를 엽니다. 이때 네트워크를 공개적으로 접속할 수도 있고, 상용 클라우드 저장소 서비스의 비공개 버킷(private bucket)을 사용할 수도 있습니다. 다음과 같은 프로토콜 유형을 지원합니다:

    • HTTP/HTTPS/FTP: URI 와 함께 필요한 경우 인증 정보 를 입력해야 합니다.

    • AWS S3, Google Cloud Storage, Microsoft Azure Blob, Alibaba OSS Cloud, Open Stack Swift Storage 와 같은 클라우드 저장소: Bucket or containerObject key 를 입력해야 합니다.

    • GeoJSON 또는 GEOJSON - Newline Delimited 포맷을 사용하거나 CouchDB 데이터베이스 기반의 (아직 실험 단계인) OGC WFS 3 를 지원하는 서비스: URI 와 함께 필요한 경우 인증 정보 를 입력해야 합니다.

13.1.3.2. 메시 레이어 불러오기

메시(mesh)란 일반적으로 시계열 및 기타 요소들을 가지고 있는 비구조적 그리드를 말합니다. 공간 요소는 2차원 또는 3차원 공간에 있는 꼭짓점, 경계(edge) 및 면(face)의 집합을 담고 있습니다. 메시 레이어에 대한 더 자세한 내용은 메시 데이터 작업 을 참조하세요.

QGIS에 메시 레이어를 추가하려면:

  1. Layer ‣ 메뉴에서 선택하거나 dataSourceManager Open Data Source Manager 버튼을 클릭해서 Data Source Manager 대화창을 여십시오.

  2. 왼쪽 패널에 있는 addMeshLayer Mesh 탭을 선택하십시오.

  3. Browse 버튼을 눌러 파일을 선택하십시오. 여러 유형 을 지원합니다.

  4. 레이어를 선택한 다음 Add 를 클릭하십시오. 자체 메시 렌더링을 사용해서 레이어를 추가할 것입니다.

../../../_images/mesh_datasource_manager.png

그림 13.7 데이터소스 관리자의 메시 탭

13.1.3.3. 구분 텍스트 파일 가져오기

앞에서 설명한 도구들을 이용해서 QGIS에 구분 텍스트 파일(예: .txt, .csv, .dat, .wkt)을 불러올 수 있습니다. 이렇게 불러오면, 단순 테이블처럼 표시될 겁니다. 그런데 구분 텍스트 파일이 사용자가 가시화하려는 좌표/도형 데이터를 담고 있는 경우도 있습니다. 이것이 addDelimitedTextLayerAdd Delimited Text Layer 를 개발한 이유입니다.

  1. dataSourceManager Open Data Source Manager 아이콘을 클릭해서 Data Source Manager 대화창을 여십시오.

  2. addDelimitedTextLayer Delimited Text 탭을 선택하십시오.

  3. Browse 버튼을 클릭해서 가져올 구분 텍스트 파일을 (예를 들어 qgis_sample_data/csv/elevp.csv 파일을) 선택하십시오.

  4. Layer name 필드에 프로젝트에서 레이어용으로 사용할 명칭을 (예를 들어 Elevation 을) 입력하십시오.

  5. 다음에 설명하는 내용처럼 사용자 데이터셋 및 필요를 만족시키는 환경을 설정하십시오.

../../../_images/delimited_text_dialog.png

그림 13.8 구분 텍스트 대화창

13.1.3.3.1. 파일 포맷

파일을 선택하면, QGIS가 가장 최근에 사용한 구분자로 필드와 행을 식별해서 파일을 파싱하려 할 겁니다. QGIS가 파일을 제대로 파싱하게 하려면, 정확한 구분자를 선택하는 것이 중요합니다. 다음 옵션 가운데 하나를 선택해서 구분자를 지정할 수 있습니다:

  • radioButtonOnCSV (comma separated values): 쉼표 문자를 구분자로 사용합니다.

  • radioButtonOffRegular expression delimiter: Expression 란에 구분자로 이용할 텍스트를 입력합니다. 예를 들어 구분자를 탭으로 변경하려면, (정규 표현식에서 탭 문자를 나타내는) \t 를 입력하세요.

  • radioButtonOffCustom delimiters: comma, space, tab, semicolon 등등 사전 정의된 여러 구분자들 가운데 선택합니다.

13.1.3.3.2. 레코드와 필드

데이터 식별을 위한 몇몇 다른 편리한 옵션을 사용할 수 있습니다:

  • Number of header lines to discard: 가져온 파일의 첫 줄이 빈 줄이거나 다른 서식으로 돼 있기 때문에 첫 줄을 파싱하지 않고자 하는 경우 편리합니다.

  • checkboxFirst record has field names: 첫 줄에 있는 값들을 필드명으로 사용합니다. 이 옵션을 선택하지 않는다면 QGIS는 필드명으로 field_1, field_2, …를 사용할 것입니다.

  • checkboxDetect field types: 필드 유형을 자동으로 식별합니다. 이 옵션을 선택하지 않는다면 모든 속성을 텍스트 필드로 취급합니다.

  • checkboxDecimal separator is comma: 소수 구분 기호를 쉼표로 강제할 수 있습니다.

  • checkboxTrim fields: 필드에서 처음 및 마지막 부분의 공백을 잘라낼 수 있습니다.

  • checkboxDiscard empty fields: 비어 있는 필드를 무시할 수도 있습니다.

파싱 작업자 속성을 설정하는 대로, 대화창 하단에 예시 데이터 미리보기가 업데이트됩니다.

13.1.3.3.3. 도형 정의

파일 파싱 작업이 끝나면 Geometry definition 을 다음 가운데 하나로 설정하십시오.

  • radioButtonOnPoint coordinates: 레이어가 포인트 도형 유형이며 해당 필드를 가지고 있다면 X field, Y field, (3차원 데이터의 경우) Z field 를 입력하고, (측정 치수용) M field 도 지정하십시오. 좌표가 도/분/초로 정의된 경우, checkboxDMS coordinates 체크박스를 체크하십시오. setProjection Select CRS 위젯을 이용해서 적절한 Geometry CRS 를 지정하십시오.

  • radioButtonOnWell known text (WKT): WKT로 공간 정보를 표현하는 경우 이 옵션을 선택하십시오. WKT 도형을 담고 있는 Geometry field 를 선택하고 적절한 Geometry field 를 선택하거나 QGIS가 자동으로 식별하게 하십시오. setProjection Select CRS 위젯을 이용해서 적절한 Geometry CRS 를 지정하십시오.

  • 파일이 비공간 데이터를 담고 있는 경우, No geometry (attribute only table) 옵션을 활성화하면 파일을 서수(序數) 테이블로 불러들일 것입니다.

13.1.3.3.4. 레이어 설정

여기에 더해, 다음 옵션을 활성화시킬 수 있습니다:

  • checkboxUse spatial index: 피처를 공간적으로 선택하고 화면에 표시하는 성능을 향상시킵니다.

  • checkboxUse subset index: (레이어 속성에 하위 집합을 정의한 경우) 하위 집합 필터 의 성능을 향상시킵니다.

  • checkboxWatch file: QGIS 실행 중에 다른 응용 프로그램이 파일을 변경하지는 않는지 감시합니다.

마지막으로 Add 를 클릭하면 맵에 레이어를 추가합니다. 이 예시에서는 프로젝트에 Elevation 이라는 명칭의 포인트 레이어를 추가하며, 이 레이어는 QGIS에서 다른 모든 맵 레이어와 마찬가지로 동작합니다. 이 레이어는 .csv 소스 파일을 쿼리한 결과물로 (즉 해당 파일과 연결돼 있기 때문에) 디스크 상에 공간 레이어를 만들려면 저장 해야만 합니다.

13.1.3.4. DXF 또는 DWG 파일 가져오기

탐색기 패널에서 DXFDWG 파일을 드래그&드롭하기만 하면 QGIS에 추가할 수 있습니다. 프로젝트에 추가하고 싶은 하위 레이어를 선택할 수 있는 창이 뜰 겁니다. 레이어 추가 시 스타일 속성은 랜덤하게 적용됩니다.

참고

포인트, 라인 그리고/또는 폴리곤 등 여러 도형 유형을 담고 있는 DXF 파일의 경우, <filename.dxf> entities <geometry type> 형식으로 레이어를 명명합니다.

QGIS에서 DXF/DWG 파일 구조 및 그 심볼을 유지하려면, 전용 Project ‣ Import/Export ‣ Import Layers from DWG/DXF… 도구를 사용해야 할 수도 있습니다. 이 도구를 사용하면:

  1. 그리기 파일(drawing file)에서 GeoPackage 데이터베이스로 요소들을 가져올 수 있습니다.

  2. 프로젝트에 가져온 요소들을 추가할 수 있습니다.

DWG/DXF Import 대화창에서 그리기 파일의 내용을 가져오려면:

  1. 데이터를 저장할 새 GeoPackage 파일 같은, Target package 의 위치를 입력하십시오. 기존 파일을 입력하면 해당 파일을 덮어 쓸 것입니다.

  2. 그리기 파일에 있는 데이터의 좌표계를 지정하십시오.

  3. 그리기 파일의 블록(block)을 일반적인 요소로 가져오려면 checkbox Expand block references 를 체크하십시오.

  4. 가져온 레이어를 curved 만곡 도형 유형으로 승격시키려면 checkbox Use curves 를 체크하십시오.

  5. Import 버튼을 클릭해서 사용할 DWG/DXF 파일을 (GeoPackage 당 하나씩) 선택하십시오. 그리기 파일 내용이 GeoPackage 데이터베이스를 자동으로 채울 것입니다. 파일 용량에 따라 시간이 걸릴 수도 있습니다.

.dwg 또는 .dxf 데이터를 GeoPackage 데이터베이스로 가져왔다면, 가져온 파일에 있는 레이어의 목록이 대화창 프레임의 하단을 채울 것입니다. 이 목록에서 QGIS 프로젝트에 추가할 레이어를 선택할 수 있습니다:

  1. 맨 위 Group name 에서, 프로젝트에 그리기 파일을 그룹화할 그룹명을 설정하십시오.

  2. 가시화할 레이어를 체크하십시오: 그리기 레이어의 포인트, 라인, 라벨 및 영역 피처를 위한 벡터 레이어들을 담고 있는 즉석 그룹에 선택한 각 레이어를 추가합니다. 선택한 레이어의 스타일은 *CAD에서 원래 가지고 있던 모양을 닮게 될 것입니다.

  3. 레이어를 열 때 가시화할 것인지 여부를 선택하십시오.

  4. 모든 레이어를 단일 그룹으로 배치하려면 checkbox Merge layers 를 체크하십시오.

  5. OK 를 클릭하면 QGIS에서 레이어가 열립니다.

../../../_images/dwg_dxf_import_dialog.png

그림 13.9 DWG/DXF 파일 가져오기 대화창

13.1.3.5. OpenStreetMap 벡터 가져오기

The OpenStreetMap project is popular because in many countries no free geodata such as digital road maps are available. The objective of the OSM project is to create a free editable map of the world from GPS data, aerial photography and local knowledge. To support this objective, QGIS provides support for OSM data.

Browser Panel 을 통해 맵 캔버스에 .osm 파일을 불러올 수 있는데, 이때 도형 유형을 바탕으로 하위 레이어를 선택할 수 있는 대화창이 열립니다. 불러온 레이어는 .osm 파일에 있는 모든 도형 유형의 데이터를 담고 있으며 .osm 파일 데이터 구조를 유지할 것입니다.

13.1.3.6. SpatiaLite 레이어

addSpatiaLiteLayer 처음으로 SpatiaLite 데이터베이스에서 데이터를 불러오는 경우, 다음 가운데 한 방법으로 시작하십시오:

  • addSpatiaLiteLayer Add SpatiaLite Layer 툴바 버튼을 클릭합니다.

  • Layer ‣ Add Layer 메뉴에서 addSpatiaLiteLayer Add SpatiaLite Layer… 옵션을 선택합니다.

  • Ctrl+Shift+L 조합키를 누릅니다.

드롭다운 메뉴에서 QGIS가 이미 알고 있는 SpatiaLite 데이터베이스를 선택해서 연결할 수 있거나 또는 새 데이터베이스로의 새 연결을 정의할 수 있는 대화창이 열립니다. 새 연결을 정의하려면, New 를 클릭한 다음 파일 탐색기에서 사용자 SpatiaLite 데이터베이스를 지정하십시오. SpatiaLite 데이터베이스는 .sqlite 확장자를 가진 파일입니다.

QGIS는 SpatiaLite에서 편집할 수 있는 뷰도 지원합니다.

13.1.3.7. GPS

핵심 플러그인인 GPS Tools 를 이용하면 QGIS에 GPS 데이터를 불러올 수 있습니다. GPS 플러그인 에서 해당 지침을 설명하고 있습니다.

13.1.3.8. GRASS

GRASS GIS 통합 에서 GRASS 벡터 데이터 작업을 설명하고 있습니다.

13.1.4. QGIS 사용자 지정 포맷

QGIS는 2개의 사용자 지정 포맷을 제안합니다:

13.1.5. QLR - QGIS 레이어 정의 파일

레이어 컨텍스트 메뉴의 Export ‣ Save As Layer Definition File… 메뉴를 통해 레이어 정의를 레이어 정의 파일 (QLR - .qlr)로 저장할 수 있습니다.

QLR 포맷은 《완전한》 QGIS 레이어를 다른 QGIS 사용자들과 공유할 수 있게 해줍니다. QLR 파일은 데이터소스를 가리키는 링크 및 레이어 스타일 작업에 필요한 모든 QGIS 스타일 정보를 담고 있습니다.

QLR 파일은 탐색기 패널에 표시되며, 레이어 패널에 레이어를 (저장된 레이어 스타일과 함께) 추가하는 데 사용할 수 있습니다. 시스템 파일 관리자에서 맵 캔버스로 QLR 파일을 드래그&드롭할 수도 있습니다.

13.1.6. 웹 서비스 연결

QGIS를 통해 서로 다른 OGC 웹 서비스 유형(WM(T)S, WFS(-T), WCS, CSW 등등)에 접근할 수 있습니다. QGIS 서버 덕분에, 이 서비스들을 웹 상에 공개할 수도 있습니다. OGC 데이터 작업 에서 이런 성능에 대해 설명하고 있습니다.

13.1.6.1. XYZ 타일 서비스 사용하기

BrowserXYZ Tiles 최상위 수준 항목에서 XYZ 타일 서비스를 찾을 수 있습니다. OpenStreetMap XYZ 타일 서비스가 기본적으로 환경 설정돼 있습니다. XYZ 타일의 (오른쪽 클릭으로 열리는) 컨텍스트 메뉴에서 New Connection 을 선택하면 XYZ 타일 프로토콜을 사용하는 다른 서비스를 추가할 수 있습니다. XYZ 타일 - OpenStreetMap 환경 설정 그림은 OpenStreetMap XYZ 타일 서비스 환경 설정을 담고 있는 대화창입니다.

../../../_images/xyz_tiles_dialog_osm.png

그림 13.12 XYZ 타일 - OpenStreetMap 환경 설정

이 환경 설정을 XML로 (Save Connections) 저장할 수 있고, 이를 컨텍스트 메뉴를 통해 (Load Connections) 불러올 수 있습니다. 인증 환경 설정도 지원합니다. OpenStreetMap 용 XML 파일은 다음과 비슷한 내용을 담고 있습니다:

<!DOCTYPE connections>
<qgsXYZTilesConnections version="1.0">
  <xyztiles url="https://tile.openstreetmap.org/{z}/{x}/{y}.png"
   zmin="0" zmax="19" password="" name="OpenStreetMap" username=""
   authcfg="" referer=""/>
</qgsXYZTilesConnections>

XYZ 타일 서비스 연결을 설정한 다음, 해당 항목을 오른쪽 클릭하면:

  • Edit…: XYZ 연결 설정을 편집합니다.

  • Delete: 연결을 삭제합니다.

  • Export layer… ‣ To File: XYZ 타일 레이어를 래스터로 저장 합니다.

  • Add layer to project: 이 메뉴는 물론 더블 클릭으로도 레이어를 추가할 수 있습니다.

  • Layer Properties…: 레이어 속성을 표시해서 서비스가 제공하는 데이터의 메타데이터 및 미리보기에 접근할 수 있습니다. 프로젝트에 레이어를 불러온 후라면 더 많은 설정을 사용할 수 있습니다.

XYZ 타일 서비스 예시:

  • 흑백 오픈스트리트맵: URL: http://tiles.wmflabs.org/bw-mapnik/{z}/{x}/{y}.png, Min. Zoom Level: 0, Max. Zoom Level: 19

  • 구글 지도: URL: https://mt1.google.com/vt/lyrs=m&x={x}&y={y}&z={z}, Min. Zoom Level: 0, Max. Zoom Level: 19

  • 오픈웨더맵 기온 지도: URL: http://tile.openweathermap.org/map/temp_new/{z}/{x}/{y}.png?appid={api_key} Min. Zoom Level: 0, Max. Zoom Level: 19

13.1.7. 망가진 파일 경로 처리

데이터소스를 가리키는 경로가 잘못되었을 경우, QGIS는 Handle Unavailable Layers 대화창을 엽니다. Datasource 필드를 더블 클릭하거나 Browse 를 클릭하면 경로를 고칠 수 있습니다. Keep Unavailable Layers 를 클릭하면 망가진 경로와 함께 사용자 프로젝트를 계속 작업할 수도 있습니다. 사용자의 레이어가 Layers 패널에 표시되지만, 사용자가 Layers 패널에서 사용자 레이어 옆에 있는 indicatorBadLayer Unavailable layer! 아이콘 또는 레이어 컨텍스트 메뉴의 Change Data Source… 항목을 사용해서 경로를 고치기 전에는 어떤 데이터도 없습니다. 또다른 방법으로는 deleteSelected Remove Unavailable Layers 를 사용해서 레이어를 제거하는 것입니다. 마지막 단계로 Apply changes 를 클릭하십시오.

레이어 경로를 고치고 나면, QGIS는 다른 모든 망가진 경로를 스캔해서 동일한 망가진 파일 경로를 가진 레이어를 자동으로 고치려 시도합니다.