편집 작업

QGIS는 OGR, SpatiaLite, PostGIS, MSSQL Spatial 및 Oracle Spatial 벡터 레이어와 테이블을 편집할 수 있는 다양한 능력을 지원합니다.

참고

GRASS 레이어 편집 과정은 조금 다릅니다. 자세한 내용은 GRASS 벡터 레이어 디지타이즈 및 편집하기 을 참조하세요.

병행 편집

QGIS 이번 버전은 사용자가 피처를 편집하는 도중에 다른 사용자가 동일한 피처를 편집하고 있지는 않은지 추적하지 않습니다. 마지막에 저장하는 변경 사항이 적용될 것입니다.

스냅 허용 오차 및 검색 반경 설정

벡터 레이어 도형을 정확하게, 최적으로 편집하기 위해 피처 꼭짓점에 대한 스냅 허용 오차 및 검색 반경을 적절한 값으로 설정해야 합니다.

스냅 허용 오차

When you add a new vertex or move an existing one, snapping tolerance is the distance QGIS uses to search for the closest vertex or segment you are trying to connect to. If you aren’t within the snapping tolerance, QGIS will leave the vertex where you release the mouse button, instead of snapping it to an existing vertex or segment.

The snapping tolerance setting affects all tools that work with tolerance.

You can enable or disable snapping by using the snapping Enable snapping button on the Snapping Toolbar or pressing S at any time while you’re on the map view. This toolbar is also very convenient to quickly configure the snapping mode, tolerance value, and units. The snapping configuration can also be set in Project ‣ Snapping Options….

There are three options to select the layer(s) to snap to:

  • All layers: quick setting for all visible layers in the project so that the pointer snaps to all vertices and/or segments. In most cases, it is sufficient to use this snapping mode, but beware when using it on projects with many vector layers, as it may cause slowness.

  • Current layer: only the active layer is used, a convenient way to ensure topology within the layer being edited.

  • Advanced Configuration: allows you to enable and adjust snapping mode and tolerance on a layer basis (see figure_edit_snapping). If you need to edit a layer and snap its vertices to another, ensure the target layer is checked and increase the snapping tolerance to a higher value. Snapping will not occur to a layer that is not checked in the snapping options dialog.

As for snapping mode, you can select between To vertex, To segment, and To vertex and segment.

The tolerance values can be set either in the project’s map units or in pixels. The advantage of choosing pixels is that it keeps the snapping constant at different map scales. 10 to 12 pixels is normally a good value, but it depends on the DPI of your screen. Using map units allows the tolerance to be related to real ground distances. For example, if you have a minimum distance between elements, this option can be useful to ensure that you don’t add vertexes too close to each other.

../../../_images/editProjectSnapping.png

Snapping options (Advanced Configuration mode)

참고

By default, only visible features (the features whose style is displayed, except for layers where the symbology is 《No symbols》) can be snapped. You can enable the snapping on invisible features by checking unchecked Enable snapping on invisible features under the Settings ‣ Options ‣ Digitizing tab.

Enable snapping by default

You can set snapping to be enabled by default on all new projects in the Settings ‣ Options ‣ Digitizing tab. You can also set the default snapping mode, tolerance value, and units, which will populate the Snapping Options dialog.

교차점에 스냅 활성화하기

Another available option is to use snappingIntersection snapping on intersection, which allows you to snap to geometry intersections of snapping enabled layers, even if there are no vertices at the intersections.

검색 반경

Search radius is the distance QGIS uses to search for the closest vertex you are trying to select when you click on the map. If you aren’t within the search radius, QGIS won’t find and select any vertex for editing. The search radius for vertex edits can be defined under the Settings ‣ options Options ‣ Digitizing tab. This is the same place where you define the snapping default values.

Snap tolerance and search radius are set in map units or pixels, so you may find you need to experiment to get them set right. If you specify too big of a tolerance, QGIS may snap to the wrong vertex, especially if you are dealing with a large number of vertices in close proximity. Set the search radius too small, and it won’t find anything to move.

위상 편집

Apart from snapping options, the Snapping options…` dialog (Project ‣ Snapping options) and the Snapping toolbar allow you to enable and disable some topological functionalities.

위상 편집 활성화하기

The topopologicalEditing Topological editing button helps when editing and maintaining features with common boundaries. With this option enabled, QGIS 〈detects〉 boundaries that are shared by the features; When you move common vertices/segments, QGIS will also move them in the geometries of the neighboring features.

Topological editing works with features from different layers, as long as the layers are visible and in editing mode.

새 폴리곤의 교차를 피하기

When the snapping mode is set to Advanced configuration, for polygon layers, there’s an option called checkbox Avoid intersections. This option prevents you from drawing new features that overlap existing ones in the selected layer, speeding up digitizing of adjacent polygons.

With avoid intersections enabled, if you already have one polygon, you can digitize a second one such that both intersect. QGIS will cut the second polygon to the boundary of the existing one. The advantage is that you don’t have to digitize all vertices of the common boundary.

참고

If the new geometry is totally covered by existing ones, it gets cleared, and QGIS will show an error message.

경고

Use cautiously the Avoid overlap option

Since this option will cut new overlapping geometries of any polygon layer, you can get unexpected geometries if you forget to uncheck it when no longer needed.

도형 확인기

이 핵심 플러그인으로 도형의 유효성을 확인할 수 있습니다. Geometry Checker Plugin 에서 이 플러그인에 관한 자세한 정보를 찾아볼 수 있습니다.

자동 투사하기

Usually, when using capturing map tools (add feature, add part, add ring, reshape and split), you need to click each vertex of the feature. With the automatic tracing mode, you can speed up the digitization process as you no longer need to manually place all the vertices during digitization:

  1. Enable the tracing Tracing tool by pushing the icon or pressing T key.

  2. Snap to a vertex or segment of a feature you want to trace along.

  3. Move the mouse over another vertex or segment you’d like to snap and, instead of the usual straight line, the digitizing rubber band represents a path from the last point you snapped to the current position.

    QGIS actually uses the underlying features topology to build the shortest path between the two points. Tracing requires snapping to be activated in traceable layers to build the path. You should also snap to an existing vertex or segment while digitizing and ensure that the two nodes are topologically connectable through existing features edges, otherwise QGIS is unable to connect them and thus traces a single straight line.

  4. Click and QGIS places the intermediate vertices following the displayed path.

Unfold the tracing Enable Tracing icon and set the Offset option to digitize a path parallel to the features instead of tracing along them; a positive value shifts the new drawing to the left side of the tracing direction and a negative value does the opposite.

참고

최적의 투사를 위해 맵 축척 또는 스냅 설정을 조정하기

맵 캔버스에 너무 많은 피처들이 있는 경우, 잠재적으로 너무 긴 투사 구조 준비 및 대용량 메모리 부담을 피하기 위해 투사를 비활성화시킵니다. 맵을 확대하거나 일부 레이어를 비활성화하면 다시 투사를 활성화시킵니다.

참고

Does not add topological points

This tool does not add points to existing polygon geometries even if Topological editing is enabled. If geometry precision is activated on the edited layer, the resulting geometry might not exactly follow an existing geometry.

Quickly enable or disable automatic tracing by pressing the T key

By pressing the T key, tracing can be enabled/disabled anytime even while digitizing one feature, so it is possible to digitize some parts of the feature with tracing enabled and other parts with tracing disabled. Tools behave as usual when tracing is disabled.

기존 레이어 디지타이즈 작업

기본적으로, QGIS는 레이어를 읽기 전용으로 불러옵니다. 이 습성은 혹시라도 마우스가 미끄러져 레이어를 실수로 편집하는 일을 피하기 위한 예방책입니다. 하지만, 편집을 지원하는 데이터 제공자이며 (데이터 포맷 및 필드 탐구 참조) 기저 데이터소스가 쓰기 가능인 경우 (예: 파일이 읽기 전용이 아닌 경우) 모든 레이어를 편집할 수 있습니다.

프로젝트 내부에서 레이어 편집 권한 제한

From the Project ‣ Properties… ‣ Data Sources ‣ Layers Capabilities table, You can choose to set any layer read-only regardless the provider permission. This can be a handy way, in a multi-users environment to avoid unauthorized users to mistakenly edit layers (e.g., Shapefile), hence potentially corrupt data. Note that this setting only applies inside the current project.

일반적으로, 벡터 레이어를 편집하기 위한 도구는 고급 디지타이즈 작업 절에서 설명하는 대로 디지타이즈 작업과 고급 디지타이즈 작업 툴바로 나뉘어져 있습니다. View ‣ Toolbars ‣ 메뉴에서 둘 다 선택하고 선택 해제할 수 있습니다. 기본 디지타이즈 작업 도구를 선택하면, 다음 기능들을 수행할 수 있습니다:

아이콘

목적

아이콘

목적

allEdits

현재 편집 내용

toggleEditing

편집 켜고끄기

saveEdits

레이어 편집 내용 저장

newTableRow

Add new record

capturePoint

피처 추가: 포인트 캡처

captureLine

피처 추가: 라인 캡처

capturePolygon

피처 추가: 폴리곤 캡처

vertexTool

Vertex Tool (All Layers)

vertexToolActiveLayer

Vertex Tool (Current Layer)

multiEdit

Modify the attributes of all selected features simultaneously

deleteSelected

선택 항목 삭제

editCut

피처 잘라내기

editCopy

피처 복사하기

editPaste

피처 붙여넣기

undo

실행 취소

redo

재실행

표: 편집 작업 - 벡터 레이어 기본 편집 툴바

이 모든 디지타이즈 작업 도구를 쓰는 도중에 도구를 비활성화시키지 않고서도 맵 캔버스에서 zoom_pan 할 수 있다는 사실을 기억하십시오.

모든 편집 세션은 선택한 레이어의 컨텍스트 메뉴, 속성 테이블 대화창, 디지타이즈 작업 툴바, 또는 Edit 메뉴에 있는 toggleEditing Toggle editing 옵션을 선택해서 시작됩니다.

레이어를 편집 모드로 전환하면, 편집 작업 툴바에 있는 부가 도구 아이콘들이 활성화되며, Settings ‣ Options… ‣ Digitizing 탭에 있는 checkbox Show markers only for selected features 옵션을 체크하지 않은 경우 모든 피처의 꼭짓점에 마커가 나타날 것입니다.

정기적으로 저장하세요

saveEdits Save Layer Edits 아이콘으로 주기적으로 편집 내용을 저장하는 것을 잊지 마십시오. 이 아이콘을 클릭하면 사용자의 데이터소스가 모든 수정 사항을 받아들일 수 있는지도 확인할 것입니다.

피처 추가하기

Depending on the layer type, you can use the newTableRow Add Record, capturePoint Add Point Feature, captureLine Add Line Feature or capturePolygon Add Polygon Feature icons on the toolbar to add new features into the current layer.

To add a geometryless feature, click on the newTableRow Add Record button and you can enter attributes in the feature form that opens. To create features with the spatially enabled tools, you first digitize the geometry then enter its attributes. To digitize the geometry:

  1. Left-click on the map area to create the first point of your new feature. For point features, this should be enough and trigger, if required, the feature form to fill in their attributes. Having set the geometry precision in the layer properties you can use snap to grid here to create features based on a regular distance.

  2. For line or polygon geometries, keep on left-clicking for each additional point you wish to capture or use automatic tracing capability to accelerate the digitization. This will create consecutive straight lines between the vertices you place.

    참고

    Pressing Delete or Backspace key reverts the last node you add.

  3. When you have finished adding points, right-click anywhere on the map area to confirm you have finished entering the geometry of that feature.

    참고

    While digitizing line or polygon geometries, you can switch back and forth between the linear Add feature tools and circular string tools to create compound curved geometries.

    디지타이즈 작업 고무줄을 사용자 지정하기

    폴리곤을 캡처하는 도중에 기본값인 빨강색 고무줄이 아래에 있는 – 사용자가 포인트를 캡처하고자 하는 – 피처 또는 장소를 가릴 수가 있습니다. Settings ‣ Options ‣ Digitizing 대화창에서 고무줄의 Fill Color 에 대한 투명도(또는 알파 채널)를 높이면 이 문제를 해결할 수 있습니다. 또는 Don’t update rubber band during node editing 옵션을 체크해서 고무줄을 사용하지 않을 수도 있습니다.

  4. 디지타이즈 작업을 완료하면 새 피처를 위한 정보를 입력할 수 있는 속성 대화창이 열립니다. 새 벡터 피처를 디지타이즈한 후의 속성 입력 양식 대화창 그림은 알래스카에 있는 가상의 새 강을 위한 속성을 설정하는 예시입니다. 하지만, Settings ‣ Options 메뉴의 Digitizing 대화창에서 다음 옵션들을 활성화시킬 수도 있습니다:

    • checkbox Suppress attributes pop-up windows after each created feature to avoid the form opening;

    • checkbox Reuse last entered attribute values: 속성 입력 양식 대화창이 열릴 때 가장 최근에 입력한 속성값으로 자동 입력해서 변경할 값만 입력하면 되도록 합니다.

../../../_images/editDigitizing.png

새 벡터 피처를 디지타이즈한 후의 속성 입력 양식 대화창

Vertex tool

참고

QGIS 3 major changes

In QGIS 3, the node tool has been fully redesigned and renamed to Vertex Tool. It was previously working with 《click and drag》 ergonomy, and now uses a 《click - click》 workflow. This allows major improvements like taking profit of the advanced digitizing panel with the vertex tool while digitizing or editing objects of multiple layers at the same time.

For any editable vector layer, the vertexToolActiveLayer Vertex tool (Current Layer) provides manipulation capabilities of feature vertices similar to CAD programs. It is possible to simply select multiple vertices at once and to move, add or delete them altogether. The vertex tool also works with 〈on the fly〉 projection turned on and supports the topological editing feature. This tool is selection persistent, so when some operation is done, selection stays active for this feature and tool.

Settings ‣ options Options ‣ Digitizing ‣ Search Radius: selectNumber 검색 반경 속성을 0보다 큰 숫자로 설정하는 것이 중요합니다. 그러지 않을 경우, QGIS가 현재 어떤 꼭짓점을 편집 중인지 구분하지 못 하고 경고 메시지를 표시할 것입니다.

꼭짓점 마커

QGIS 이번 버전은 〈Semi-transparent circle〉, 〈Cross〉 및 〈None〉 세 종류의 꼭짓점 마커를 지원하고 있습니다. 마커 스타일을 변경하려면, Settings 메뉴에서 options Options 를 선택한 다음, Digitizing 탭에서 적절한 항목을 선택하십시오.

기본 작업

Start by activating the vertexToolActiveLayer Vertex Tool (Current Layer). Red circles will appear when hovering vertices.

  • Selecting vertices: You can select vertices by clicking on them one at a time holding Shift key pressed, or by clicking and dragging a rectangle around some vertices. When a vertex is selected, its color changes to blue. To add more vertices to the current selection, hold down the Shift key while clicking. To remove vertices from the selection, hold down Ctrl.

  • Batch vertex selection mode: The batch selection mode can be activated by pressing Shift+R. Select a first node with one single click, and then hover without clicking another vertex. This will dynamically select all the nodes in between using the shortest path (for polygons).

    ../../../_images/vertex_batch_selection_mode.png

    Batch vertex selection using Shift+R

    Press Ctrl will invert the selection, selecting the longest path along the feature boundary. Ending your node selection with a second click, or pressing Esc will escape the batch mode.

  • Adding vertices: To add a vertex, a virtual new node appears on the segment center. Simply grab it to add a new vertex. Double click on any location of the boundary also creates a new node. For lines, a virtual node is also proposed at both extremities of a line to extend it.

    ../../../_images/vertex_add_node.png

    Virtual nodes for adding vertices

  • 꼭짓점 삭제하기: 꼭짓점을 선택한 다음 Delete 키를 누르십시오. 피처의 모든 꼭짓점을 삭제하면 – 데이터소스가 지원하는 경우 – 도형이 없는 피처를 생성합니다. 피처를 완전히 삭제하는 것이 아니라 도형만 삭제한다는 점을 기억하십시오. 피처를 완전히 삭제하려면 deleteSelected Delete Selected 도구를 사용해야 합니다.

  • Moving vertices: Select all the vertices you want to move, click on a selected vertex or edge, and click again on the desired new location. All the selected vertices will move together. If snapping is enabled, the whole selection can jump to the nearest vertex or line. You can use Advanced Digitizing Panel constraints for distance, angles, exact X Y location before the second click.

    Here you can use the snap-to-grid feature. Having set a value for the geometry precision in the layer properties, a grid appears on a zoom level according to the Geometry precision.

    ../../../_images/vertex_snap_to_grid.png

    Selecting a vertex and moving the vertices to grid

Each change made with the vertex is stored as a separate entry in the Undo dialog. Remember that all operations support topological editing when this is turned on. On-the-fly projection is also supported, and the node tool provides tooltips to identify a vertex by hovering the pointer over it.

The Vertex Editor Panel

When using the Vertex tool on a feature, it is possible to right click to open the Vertex Editor panel listing all the vertices of the feature with their x, y (z, m if applicable) coordinates and r (for the radius, in case of circular geometry). Simply select a row in the table does select the corresponding vertex in the map canvas, and vice versa. Simply change a coordinate in the table and your vertex position is updated. You can also select multiple rows and delete them altogether.

참고

Changed behavior in QGIS 3.4

Right click on a feature will immediately show the vertex editor and lock this feature, thus disabling the editing of any other features. While being locked, a feature is exclusive for editing: Selecting and moving of vertices and segments by clicking or dragging is only possible for this feature. New vertices can only be added to the locked feature. Also, the vertex editor panel now opens itself automatically upon activating the vertex tool, and its position/docked state remembered across uses.

../../../_images/vertex_editor_panel.png

선택한 노드를 보여주는 꼭짓점 편집기 패널

피처 잘라내기, 복사 및 붙여넣기

먼저 toggleEditing Toggle editing 을 통해 대상 레이어를 편집 모드로 설정해놓았다면, 동일한 QGIS 프로젝트의 레이어들 사이에서 선택한 피처를 자르고, 복사하고 붙여넣을 수 있습니다.

복사/붙여넣기를 이용해서 폴리곤을 라인으로, 라인을 폴리곤으로 변형하기

라인 피처를 복사해서 폴리곤 레이어에 붙여넣는 경우, QGIS가 대상 레이어에 그 경계가 라인 피처의 닫힌 도형에 대응하는 폴리곤으로 붙여넣습니다. 이는 동일한 데이터를 가진 서로 다른 도형 유형을 빠르게 생성하는 방법입니다.

외부 응용 프로그램에 피처를 텍스트로 붙여넣을 수도 있습니다. 피처가 도형 데이터를 OGC WKT(Well-Known Text) 서식으로 표현한 CSV 포맷인 경우에 말이죠. QGIS 외부의 WKT 및 GeoJSON 객체를 QGIS 내부의 레이어로 붙여넣는 것도 가능합니다.

복사/붙여넣기 기능이 유용한 경우란 어떤 경우일까요? 바로 한 번에 하나 이상의 레이어를 편집하는 중에 레이어들 간에 피처를 복사/붙여넣기하는 경우입니다. 어째서 이런 작업이 필요한 걸까요? QGIS 예시 데이터의 big_lakes 레이어에 있는 호수 5,000개 전부가 아니라 한두 개만 있는 레이어에서 몇몇 작업을 해야 한다고 가정해봅시다. 새 레이어를 생성한 다음 해당 레이어에 필요한 호수만 복사/붙여넣기를 이용해서 넣을 수 있습니다.

새 레이어에 몇몇 호수를 복사해 넣는 다음 예제를 해보겠습니다:

  1. 복사해오려는 레이어(원본 레이어)를 불러옵니다.

  2. 복사해 넣으려는 레이어(대상 레이어)를 불러오거나 생성합니다.

  3. 대상 레이어를 편집 모드로 설정합니다.

  4. 범례에서 원본 레이어를 클릭해서 활성화시킵니다.

  5. selectRectangle Select Features by area or single click 도구를 이용해서 원본 레이어에서 피처(들)을 선택합니다.

  6. editCopy Copy Features 도구를 클릭합니다.

  7. 범례에서 대상 레이어를 클릭해서 활성화시킵니다.

  8. editPaste Paste Features 도구를 클릭합니다.

  9. 편집 모드를 해제하고 변경 사항을 저장합니다.

원본과 대상 레이어가 서로 다른 스키마를 가지고 있다면 (필드명과 유형이 동일하지 않다면) 어떻게 될까요? QGIS는 일치하는 데이터를 붙여넣고 나머지는 무시합니다. 대상 레이어에 속성을 복사해 넣을 필요가 없는 경우, 필드 및 데이터 유형을 어떻게 구성하든 상관없습니다. 하지만 전체를 – 피처와 그 속성까지 – 복사하고자 하는 경우, 원본과 대상 레이어의 스키마가 일치하는지 확인해야 합니다.

참고

붙여넣은 피처의 합치성

원본과 대상 레이어가 동일한 투영체를 사용하고 있는 경우, 붙여넣은 피처가 원본 레이어와 동일한 도형을 가지게 될 것입니다. 하지만, 대상 레이어의 투영체가 다른 경우, QGIS는 도형이 동일한지 보장할 수 없게 됩니다. 왜냐하면 서로 다른 투영체 간에 변환할 때 자잘한 반올림 오류가 발생하기 때문입니다.

문자열 속성을 또다른 속성으로 복사하기

사용자의 속성 테이블에 문자열 유형의 새 열을 생성했는데, 더 긴 길이를 가진 다른 속성 열로 그 값을 붙여넣으려는 경우, 열의 길이가 대상 열의 길이로 늘어날 것입니다. GDAL/OGR 1.10과 함께 구동되는 GDAL shapefile 드라이버가 삽입될 데이터의 길이를 동적으로 수용하기 위해 문자열 및 정수형 필드를 자동 확장하기 때문입니다.

선택한 피처 삭제하기

어떤 피처 전체(속성 및 도형)를 삭제하려는 경우, 먼저 표준적인 selectRectangle Select Features by area or single click 도구를 사용해서 도형을 선택할 수 있습니다. 속성 테이블에서 선택할 수도 있습니다. 선택을 마치고 나면, Delete 또는 Backspace 키를 누르거나 deleteSelected Delete Selected 도구를 클릭해서 피처를 삭제하십시오. 선택한 피처 여러 개를 한 번에 삭제할 수 있습니다.

피처를 삭제하는 데 디지타이즈 작업 툴바에 있는 editCut Cut Features 도구를 이용할 수도 있습니다. 이 도구는 피처를 사실상 삭제하지만 《공간 클립보드》에 옮겨 놓기도 합니다. 즉, 삭제할 피처를 잘라내는 겁니다. 이후에 editPaste Paste Features 도구를 통해 되돌려 놓을 수 있습니다. 기초 수준의 실행 취소 능력이죠. 잘라내기, 복사 및 붙여넣기는 현재 선택한 피처를 대상으로 작동합니다. 즉 한 번에 하나 이상을 대상으로 작업할 수 있다는 뜻입니다.

실행 취소 및 재실행

undo Undoredo Redo 도구는 벡터 편집 작업을 실행 취소하거나 재실행할 수 있습니다. 실행 취소/재실행 이력에 있는 모든 작업을 보여주는 고정 가능한(dockable) 위젯도 있습니다. (실행 취소/재실행 디지타이즈 작업 이력 그림을 참조하세요.) 이 위젯은 기본적으로 표시되지 않습니다. 이 위젯을 표시하려면 툴바를 오른쪽 클릭한 다음 checkbox Undo/Redo Panel 을 활성화해야 합니다. 하지만 이 위젯이 표시되지 않은 경우에도 실행 취소/재실행 능력은 켜져 있습니다.

../../../_images/redo_undo.png

실행 취소/재실행 디지타이즈 작업 이력

[Undo] 버튼을 클릭하거나 Ctrl+Z (또는 |osx| Cmd+Z) 조합키를 누르면, 모든 피처와 속성의 상태가 되돌린 작업 이전의 상태로 돌아갑니다. 일반적인 벡터 편집 작업이 아닌 변경 사항(예: 플러그인을 통한 변경 사항)은 해당 변경 사항이 어떻게 수행됐는지에 따라 되돌릴 수도 있고 되돌리지 못 할 수도 있습니다.

실행 취소/재실행 이력 위젯을 이용하려면, 그냥 이력 목록에 있는 작업을 하나 선택하십시오. 모든 피처가 선택한 작업 직후의 상태로 돌아갈 것입니다.

편집한 레이어 저장하기

레이어가 편집 모드 상태인 경우, 모든 변경 사항이 QGIS의 메모리에 남아 있습니다. 즉 변경 사항이 즉시 데이터소스 또는 디스크에 커밋 또는 저장되는 것이 아닙니다. 현재 레이어에 편집 사항을 저장하고 싶지만 편집 모드를 해제하지 않고 계속 편집 작업을 하고 싶은 경우, saveEdits Save Layer Edits 아이콘을 클릭하면 됩니다. toggleEditing Toggle editing 아이콘으로 편집 모드를 끄는 경우 (또는 QGIS를 종료하는 경우) 사용자의 변경 사항을 저장할 거냐 또는 무시할 거냐를 묻는 대화창이 열립니다.

변경 사항을 저장할 수 없는 경우 (예: 디스크에 남은 공간이 없거나, 범위를 벗어난 속성값이 있는 경우) QGIS의 내부 메모리 상태가 보존됩니다. 사용자가 편집 사항을 조정해서 다시 저장할 수 있게 하기 위해서입니다.

데이터 무결성

편집 작업을 시작하기 전에 항상 사용자 데이터소스를 백업하도록 권장합니다. QGIS 개발자들이 사용자 데이터의 무결성을 보존하기 위해 모든 노력을 다 하고 있지만, 어떤 보장도 해드릴 수 없기 때문입니다.

여러 레이어를 한 번에 저장하기

이 기능은 여러 레이어를 디지타이즈할 수 있게 해줍니다. 사용자가 여러 레이어에서 만든 모든 변경 사항을 저장하려면 fileSaveAs Save for Selected Layers 를 선택하십시오. rollbackEdits Rollback for Selected Layers 를 클릭하면, 선택한 모든 레이어에 대한 디지타이즈 작업을 되돌릴 수도 있습니다. 선택한 레이어에 대한 편집 작업을 종료하려면, cancelEdits Cancel for Selected Layer(s) 를 통해 쉽게 끝낼 수 있습니다.

프로젝트의 모든 레이어 편집 작업에서 동일한 기능들을 사용할 수 있습니다.

여러 레이어 변경 사항을 한 번에 편집, 저장 또는 되돌리는 데 트랜잭션 그룹 이용하기

When working with layers from the same PostGreSQL database, activate the Automatically create transaction groups where possible option in Project ‣ Properties… ‣ Data Sources to sync their behavior (enter or exit the edit mode, save or rollback changes at the same time).

고급 디지타이즈 작업

아이콘

목적

아이콘

목적

cad

고급 디지타이즈 작업 도구 활성화

tracing

투사 활성화

moveFeature moveFeatureLine moveFeaturePoint

Move Feature(s)

moveFeatureCopy moveFeatureCopyLine moveFeatureCopyPoint

Copy and Move Feature(s)

rotateFeature

피처(들) 기울이기

simplifyFeatures

피처 단순화

addRing

고리 추가

addPart

부분 추가

fillRing

고리 채우기

deleteRing

고리 삭제

deletePart

부분 삭제

offsetCurve

오프셋 곡선

reshape

피처 재형성

splitParts

부분 분할

splitFeatures

피처 분할

mergeFeatAttributes

선택한 피처의 속성 병합

mergeFeatures

선택한 피처 병합

rotatePointSymbols

포인트 심볼 기울이기

offsetPointSymbols

오프셋 포인트 심볼

표: 고급 편집 작업 - 벡터 레이어 고급 편집 작업 툴바

Move Feature(s)

The moveFeature Move Feature(s) tool allows you to move existing features:

  1. Select the feature(s) to move.

  2. Click on the map canvas to indicate the origin point of the displacement; you can rely on snapping capabilities to select an accurate point.

    You can also take advantages of the advanced digitizing constraints to accurately set the origin point coordinates. In that case:

    1. First click on the cad button to enable the panel.

    2. Type x and enter the corresponding value for the origin point you’d like to use. Then press the locked button next to the option to lock the value.

    3. Do the same for the y coordinate.

    4. Click on the map canvas and your origin point is placed at the indicated coordinates.

  3. Move over the map canvas to indicate the destination point of the displacement, still using snapping mode or, as above, use the advanced digitizing panel which would provide complementary distance and angle placement constraints to place the end point of the translation.

  4. Click on the map canvas: the whole features are moved to new location.

Likewise, you can create a translated copy of the feature(s) using the moveFeatureCopy Copy and Move Feature(s) tool.

참고

If no feature is selected when you first click on the map canvas with any of the Move Feature(s) or Copy and Move Feature(s) tools, then only the feature under the mouse is affected by the action. So, if you want to move several features, they should be selected first.

피처(들) 기울이기

Use the rotateFeature Rotate Feature(s) tool to rotate one or multiple features in the map canvas:

  1. Press the rotateFeature Rotate Feature(s) icon

  2. Then click on the feature to rotate. The feature’s centroid is referenced as rotation center, a preview of the rotated feature is displayed and a widget opens showing the current Rotation angle.

  3. Click on the map canvas when you are satisfied with the new placement or manually enter the rotation angle in the text box. You can also use the Snap to ° box to constrain the rotation values.

  4. If you want to rotate several features at once, they shall be selected first, and the rotation is by default around the centroid of their combined geometries.

You can also use an anchor point different from the default feature centroid: press the Ctrl button, click on the map canvas and that point will be used as the new rotation center.

맵을 클릭하기 전에 Shift 키를 누른 상태인 경우, 45도씩 기울어질 것입니다. 이후 사용자 입력 위젯에서 각도를 수정할 수 있습니다.

To abort feature rotation, press the ESC button or click on the rotateFeature Rotate Feature(s) icon.

피처 단순화

The simplifyFeatures Simplify Feature tool allows you to interactively reshape a line or polygon geometry by reducing or densifying the number of vertices, as long as the geometry remains valid:

  1. Select the simplifyFeatures Simplify Feature tool.

  2. Click on the feature or drag a rectangle over the features.

  3. A dialog pops up allowing you to define the Method to apply, ie whether you would like to:

    • simplify the geometry, meaning less vertices than the original. Available methods are Simplify by distance, Simplify by snapping to grid or simplify by area (Visvalingam). You’d then need to indicate the value of Tolerance in Layer units, Pixels or map units to use for simplification. The higher the tolerance is the more vertices can be deleted.

    • or densify the geometries with new vertices thanks to the Smooth option: for each existing vertex, two vertices are placed on each of the segments originated from it, at an Offset distance representing the percentage of the segment length. You can also set the number of Iterations the placement would be processed: the more iterations, the more vertices and smoother is the feature.

    Settings that you used will be saved when leaving a project or an edit session. So you can go back to the same parameters the next time you simplify a feature.

  4. A summary of the modifications that would apply is shown at the bottom of the dialog, listing number of features and number of vertices (before and after the operation and the ratio the change represents). Also, in the map canvas, the expected geometry is displayed over the existing one, using the rubberband color.

  5. When the expected geometry fits your needs, click OK to apply the modification. Otherwise, to abort the operation, you can either press Cancel or right-click in the map canvas.

참고

렌더링만을 위해 도형을 단순화하는 Settings ‣ Options ‣ Rendering 메뉴의 피처 단순화 옵션과는 달리, simplifyFeatures Simplify Feature 도구는 데이터소스에 있는 피처의 도형을 영구히 변경합니다.

부분 추가

addPart Add Part 도구로 선택한 피처에 부분을 추가해서 멀티포인트, 멀티라인 또는 멀티폴리곤 피처를 생성할 수 있습니다. 기존 피처 외부에서 이 새 부분을 디지타이즈해야만 하는데, 이 기존 피처는 먼저 선택돼 있어야 합니다.

도형이 없는 피처에 도형을 추가하는 경우에도 addPart Add Part 도구를 사용할 수 있습니다. 먼저, 속성 테이블에서 피처를 선택한 다음 addPart Add Part 도구로 새 도형을 디지타이즈하십시오.

부분 삭제

deletePart Delete Part 도구는 다중 피처에서 부분을 삭제할 수 있습니다. (예를 들면 멀티폴리곤 피처에서 폴리곤을 삭제할 수 있습니다.) 이 도구는 포인트, 라인 및 폴리곤 모든 다중 부분 도형에 대해 작동합니다. 더우기, 피처의 도형 요소를 완전히 제거할 수도 있습니다. 부분을 삭제하려면, 그냥 대상 피처 안에 있는 부분을 클릭하면 됩니다.

고리 추가

툴바에 있는 addRing Add Ring 아이콘을 클릭하면 고리 폴리곤을 생성할 수 있습니다. 기존 폴리곤 영역 내부에 〈구멍’으로 간주되는 내곽 폴리곤을 디지타이즈할 수 있다는 뜻으로, 이 경우 외곽 및 내곽 폴리곤 경계선 사이의 영역만 고리 폴리곤으로 남게 됩니다.

고리 채우기

The fillRing Fill Ring tool helps you create polygon feature that totally falls within another one without any overlapping area; that is the new feature covers a hole within the existing one. To create such a feature:

  1. Select the fillRing Fill Ring tool.

  2. Draw a new polygon over the existing feature: QGIS adds a ring to its geometry (like if you used the addRing Add Ring tool) and creates a new feature whose geometry matches the ring (like if you traced over the interior boundaries with the capturePolygon Add polygon feature tool).

  3. Or alternatively, if the ring already exists on the feature, place the mouse over the ring and left-click while pressing Shift: a new feature filling the hole is drawn at that place.

    The Feature Attributes form of the new feature opens, pre-filled with values of the 《parent》 feature and/or fields constraints.

고리 삭제

deleteRing Delete Ring 도구는 구멍 안쪽을 클릭해서 기존 폴리곤 내부의 고리를 삭제할 수 있습니다. 이 도구는 폴리곤 및 멀티폴리곤 피처에 대해서만 작동합니다. 폴리곤의 외곽 고리에 이 도구를 사용해도 아무것도 변경되지 않습니다.

피처 재형성

툴바에 있는 reshape Reshape Features 도구를 사용해서 라인 및 폴리곤 피처를 재형성할 수 있습니다. 라인의 경우, 원본 라인을 첫 번째 교차점에서 마지막 교차점까지의 라인 부분으로 대체합니다.

../../../_images/reshape_lines.png

라인 재형성하기

재형성 도구로 라인스트링 도형을 연장시키기

reshape Reshape Features 도구를 이용해서 기존 라인의 첫 번째 또는 마지막 꼭짓점에 스냅한 다음 새 라인을 그리면 기존 라인스트링 도형을 늘릴 수 있습니다. 새 라인을 승인하면 피처 도형이 두 라인의 결합체로 변합니다.

폴리곤의 경우, 이 도구는 폴리곤의 경계선을 재형성합니다. 제대로 동작하려면, 재형성 도구의 라인이 폴리곤 경계선과 최소한 두 번 교차해야만 합니다. 라인을 그리려면, 맵 캔버스를 클릭해서 꼭짓점을 추가하십시오. 그리기를 마치려면, 오른쪽 클릭만 하면 됩니다. 라인의 경우와 마찬가지로, 첫 번째와 마지막 교차점 사이에 있는 선분만 처리됩니다. 폴리곤 내부에 있는 재형성 라인의 선분은 폴리곤을 잘라내고, 외부에 있는 선분은 폴리곤을 확장시킬 것입니다.

../../../_images/reshape_polygon.png

폴리곤 재형성하기

폴리곤의 경우, 재형성 작업이 때로 의도하지 않은 결과를 낼 수도 있습니다. 이 도구는 폴리곤의 자잘한 부분을 수정하는 데 유용하지, 본체를 수정하기는 힘듭니다. 또 재형성 라인이 여러 폴리곤 고리와 교차해서도 안 됩니다. 그런 경우 유효하지 않은 폴리곤이 생성되기 때문입니다.

참고

재형성 도구는 폴리곤 고리 또는 닫힌 라인의 시작점을 변경시킬 수도 있습니다. 즉, 〈두 번〉 나타나던 포인트가 더 이상 그러지 않을 수도 있다는 뜻입니다. 대부분의 응용 프로그램에서 문제가 없을 수도 있지만, 고려해야 할 사항임에는 틀림없습니다.

오프셋 곡선

offsetCurve Offset Curve 도구는 라인 레이어를 평행하게 이동시킨 객체를 생성합니다. 이 도구를 편집 중인 레이어에 적용하면 도형을 수정하며, 배경 레이어에 적용하면 라인/고리를 복사해서 편집 중인 레이어에 추가합니다. 따라서 이 도구는 거리 라인 레이어를 생성하는 데 적합합니다. 이 도구는 변위 거리를 보여주는 User Input 대화창을 엽니다.

라인 레이어를 이동시킨 객체를 생성하려면, 먼저 편집 모드를 켠 다음 offsetCurve Offset Curve 도구를 활성화시켜야 합니다. 그 다음 피처를 클릭해서 이동시킵니다. 마우스를 움직여 원하는 곳을 클릭하거나 또는 사용자 입력 위젯에 원하는 거리를 입력하십시오. 이동 후에 saveEdits Save Layer Edits 도구로 사용자 변경 사항을 저장할 수도 있습니다.

QGIS 옵션 대화창(의 디지타이즈 탭에서 Curve offset tools 부분)에서 Join style, Quadrant segments, Miter limit 과 같은 몇몇 파라미터를 환경 설정할 수 있습니다.

피처 분할

Use the splitFeatures Split Features tool to split a feature into two or more new and independent features, ie. each geometry corresponding to a new row in the attribute table.

To split line or polygon features:

  1. Select the splitFeatures Split Features tool.

  2. Draw a line across the feature(s) you want to split. If a selection is active, only selected features are split. When set, default values or clauses are applied to corresponding fields and other attributes of the parent feature are by default copied to the new features.

  3. You can then as usually modify any of the attributes of any resulting feature.

Split a polyline into new features in one-click

Using the splitFeatures Split Features tool, snap and click on an existing vertex of a polyline feature to split that feature into two new features.

부분 분할

QGIS는 다중 부분 피처의 부분을 분할해서 부분의 개수를 늘릴 수 있습니다. splitParts Split Parts 도구를 사용해서 분할하고 싶은 부분을 가로지르는 라인을 그리기만 하면 됩니다.

Split a polyline into new parts in one-click

Using the splitParts Split Parts tool, snap and click on an existing vertex of a polyline feature to split the feature into two new polylines belonging to the same feature.

선택한 피처 병합

mergeFeatures Merge Selected Features 도구는 기존 피처들을 합쳐서 새 피처를 생성할 수 있습니다. 기존 피처의 도형들을 병합해서 새 피처를 생성합니다. 기존 피처들에 공통 경계가 없는 경우, 멀티폴리곤/멀티폴리라인/멀티포인트 피처를 생성합니다.

  1. First, select the features you’d like to combine.

  2. Then press the mergeFeatures Merge Selected Features button.

  3. In the new dialog, the Merge line at the bottom of the table shows the attributes of the resulting feature. You can alter any of these values either by:

    • manually replacing the value in the corresponding cell;

    • selecting a row in the table and pressing Take attributes from selected feature to use the values of this initial feature;

    • pressing Skip all fields to use empty attributes;

    • or, expanding the drop down menu at the top of the table, select any of the above options to apply to the corresponding field only. There, you can also choose to aggregate the initial features attributes (Minimum, Maximum, Median, Sum, Count, Concatenation… depending on the type of the field. see 통계 요약 패널 for the full list of functions).

    참고

    If the layer has default values or clauses present on fields, these are used as the initial value for the merged feature.

  4. Press OK to apply the modifications. A single (multi)feature is created in the layer, replacing the previously selected ones.

선택한 피처의 속성 병합

mergeFeatAttributes Merge Attributes of Selected Features 도구는 피처들의 경계를 병합하지 않고서도 피처에 동일한 속성을 적용할 수 있게 해줍니다. 이 도구의 대화창은 Merge Selected Features 도구의 대화창과 동일합니다. 다만 선택한 개체들의 속성은 동일하게 변하지만, 개체 도형은 그대로 유지된다는 점이 다릅니다.

포인트 심볼 기울이기

The rotatePointSymbols Rotate Point Symbols allows you to change the rotation of point symbols in the map canvas.

  1. First of all, apply to the symbol a data-defined rotation:

    1. In the Layer Properties ‣ Symbology dialog, browse to the symbol editor dialog.

    2. Click the dataDefined Data-defined override widget near the Rotation option of the top Marker level (preferably) of the symbol layers.

    3. Choose a field in the Field Type combobox. Values of this field are hence used to rotate each feature’s symbol accordingly.

    참고

    Make sure that the same field is assigned to all the symbol layers

    Setting the data-defined rotation field at the topmost level of the symbol tree automatically propagates it to all the symbol layers, a prerequisite to perform graphical symbol rotation with the Rotate Point Symbols tool. Indeed, if a symbol layer does not have the same field attached to its rotation property, the tool will not work.

    ../../../_images/rotatepointsymbol.png

    Rotating a point symbol

  2. Then click on a point feature in the map canvas with the rotatePointSymbols Rotate Point Symbols and move the mouse around, holding the left button pressed. A red arrow with the rotation value will be visualized (see Figure_rotate_point).

  3. Release the left mouse button again, the symbol is defined with this new rotation and the rotation field is updated in the layer’s attribute table.

Ctrl 키를 누르고 있을 경우, 15도씩 기울어질 것입니다.

오프셋 포인트 심볼

offsetPointSymbols Offset Point Symbols 도구는 포인트 심볼이 맵 캔버스에 렌더링된 위치를 대화형으로 변경할 수 있습니다. 이 도구는 rotatePointSymbols Rotate Point Symbols 도구와 비슷하게 동작합니다만, 심볼의 데이터로 정의된 Offset (X,Y) 속성에 연결해야 한다는 점이 다릅니다. 이 오프셋 필드에 연결하면, 포인트 심볼의 좌표가 오프셋 좌표로 변경돼 맵 캔버스에 있는 심볼도 이동합니다.

참고

The offsetPointSymbols Offset Point Symbols tool doesn’t move the point feature itself; you should use the vertexToolActiveLayer Vertex Tool (Current Layer) or moveFeaturePoint Move Feature tool for this purpose.

Shape digitizing

The Shape Digitizing toolbar offers a set of tools to draw regular shapes and curved geometries.

Add Circular string

The circularStringCurvePoint Add circular string or circularStringRadius Add circular string by radius buttons allow users to add line or polygon features with a circular geometry.

Creating features with these tools follow the same rule as of other digitizing tools: left-click to place vertices and right-click to finish the geometry. While drawing the geometry, you can switch from one tool to the other as well as to the linear geometry tools, creating some coumpound geometries.

참고

만곡 도형은 호환되는 데이터 제공자에서만 만곡 도형으로 저장됩니다

Although QGIS allows to digitize curved geometries within any editable data format, you need to be using a data provider (e.g. PostGIS, memory layer, GML or WFS) that supports curves to have features stored as curved, otherwise QGIS segmentizes the circular arcs.

Draw Circles

There is a set of tools for drawing circles. The tools are described below.

Circles are converted into circular strings, therefore, as explained in ref:add_circular_string, if allowed by the data provider, it will be saved as a curved geometry, if not, QGIS will segmentize the circular arcs.

  • circle2Points Add circle from 2 points: The two points define the diameter and the orientation of the circle. (Left-click, right-click)

  • circle3Points Add circle from 3 points: Draws a circle from three known points on the circle. (Left-click, left-click, right-click)

  • circleCenterPoint Add circle from center and a point: Draws a circle with a given center and a point on the circle. (Left-click, right-click) When used with the 고급 디지타이즈 작업 패널 this tool can become a 《Add circle from center and radius》 tool by setting and locking the distance value after first click.

  • circle3Tangents :sup`Add circle from 3 tangents`: Draws a circle that is tangential to three segments. Note that you must activate snapping to segments (See 스냅 허용 오차 및 검색 반경 설정). Click on a segment to add a tangent. If two tangents are parallel, an error message appears and the input is cleared. (Left-click, left-click, right-click)

  • circle2TangentsPoint Add circle from 2 tangents and a point: Similar to circle from 3 tangents, except that you have to select two tangents, enter a radius and select the desired center.

고급 디지타이즈 작업 패널

새로운 또는 기존 도형을 캡처, 재형성, 분할하는 경우 고급 디지타이즈 작업 패널을 이용할 수도 있습니다. 라인을 정확히 평행으로 또는 특정 각도에 직각으로 디지타이즈할 수도 있고, 라인을 지정 각도로 고정시킬 수도 있습니다. 게다가, 좌표를 직접 입력해서 사용자의 새 도형을 정밀하게 정의할 수도 있습니다.

../../../_images/advanced_digitizing.png

고급 디지타이즈 작업 패널

The Advanced Digitizing panel can be open either with a right-click on the toolbar, from View ‣ Panels ‣ menu or pressing Ctrl+4. Once the panel is visible, click the cad Enable advanced digitizing tools button to activate the set of tools.

참고

맵 뷰가 지리 좌표인 경우 이 도구들을 활성화할 수 없습니다.

개념

고급 다지타이즈 작업 도구의 목적은 맵 캔버스에서 디지타이즈 작업 도중 마우스를 이동시킬 때 좌표, 길이 그리고 각도를 고정하는 것입니다.

또한 상대 또는 절대 참조로 제약 조건을 생성할 수도 있습니다. 상대 참조란 이전 꼭짓점 또는 선분에 따라 다음 꼭짓점 제약 조건의 값이 변한다는 뜻입니다.

스냅 설정

고급 디지타이즈 작업 도구의 스냅 환경을 설정하려면 settings 아이콘을 클릭하십시오. 이 도구가 공통 각도로 스냅하도록 할 수 있습니다. 옵션은 다음과 같습니다:

  • Do not snap to common angles

  • Snap to 30º angles

  • Snap to 45º angles

  • Snap to 90º angles

피처에 어떻게 스냅할지도 설정할 수 있습니다. 옵션은 다음과 같습니다:

  • Do not snap to vertices or segments

  • Snap according to project configuration

  • Snap to all layers

키보드 단축키

To speed up the use of Advanced Digitizing Panel, there are a couple of keyboard shortcuts available:

간단한 설명

Ctrl+ or Alt+

Shift+

D

거리 설정

거리 고정

A

각도 설정

각도 고정

마지막 선분에 상대적인 각도 켜고끄기

X

Set X coordinate

Lock X coordinate

Toggle relative X to last vertex

Y

Set Y coordinate

Lock Y coordinate

Toggle relative Y to last vertex

C

작성 모드 켜고끄기

P

수직 및 평행 모드 켜고끄기

절대 참조 디지타이즈 작업

아무것도 없는 상태에서 새 도형을 그리는 경우, 지정한 좌표에서 꼭짓점 디지타이즈를 시작할 수 있다면 매우 편리합니다.

예를 들면 폴리곤 레이어에 새 피처를 추가하려면, capturePolygon 아이콘을 클릭하십시오. 피처 편집을 시작하길 바라는 X 및 Y 좌표를 다음과 같이 선택할 수 있습니다:

  • Click the x text box (or use the X keyboard shortcut).

  • 원하는 X 좌표를 입력한 다음 Enter 키를 누르거나 오른쪽에 있는 locked 아이콘을 클릭하면 맵 캔버스 상의 X 좌표의 축에 마우스가 고정됩니다.

  • Click the y text box (or use the Y keyboard shortcut).

  • 원하는 Y 좌표를 입력한 다음 Enter 키를 누르거나 오른쪽에 있는 locked 아이콘을 클릭하면 맵 캔버스 상의 Y 좌표의 축에 마우스가 고정됩니다.

파랑색 점선 2개와 초록색 가위표가 사용자가 입력한 좌표를 정확히 가리키고 있습니다. 마우스 위치는 초록색 가위표에 고정돼 있습니다. 맵 캔버스를 클릭해서 디지타이즈 작업을 시작하십시오.

../../../_images/advanced_digitizing_coordinates.png

지정 좌표에서 그리기 시작

사용자의 손으로 직접 디지타이즈를 계속해서 좌표 몇 쌍을 추가할 수도 있고, 또는 선분의 길이 (거리) 및 각도 를 입력할 수도 있습니다.

If you want to draw a segment of a given length, click the d (distance) text box (keyboard shortcut D), type the distance value (in map units) and press Enter or click the locked button on the right to lock the mouse in the map canvas to the length of the segment. In the map canvas, the clicked point is surrounded by a circle whose radius is the value entered in the distance text box.

../../../_images/advanced_digitizing_distance.png

고정 길이 선분

Finally, you can also choose the angle of the segment. As described before , click the a (angle) text box (keyboard shortcut A), type the angle value (in degrees), and press Enter or click the locked buttons on the right to lock it. In this way the segment will follow the desired angle:

../../../_images/advanced_digitizing_angle.png

고정 각도 선분

상대 참조 디지타이즈 작업

각도 또는 좌표의 절대값을 사용하는 대신, 직전에 디지타이즈한 꼭짓점 또는 선분에 상대적인 값을 사용할 수도 있습니다.

For angles, you can click the delta button on the left of the a text box (or press Shift+A) to toggle relative angles to the previous segment. With that option on, angles are measured between the last segment and the mouse pointer.

For coordinates, click the delta buttons to the left of the x or y text boxes (or press Shift+X or Shift+Y) to toggle relative coordinates to the previous vertex. With these options on, coordinates measurement will consider the last vertex to be the X and Y axes origin.

지속 고정

Both in absolute or relative reference digitizing, angle, distance, X and Y constraints can be locked continuously by clicking the lockedRepeat Continuous lock buttons. Using continuous lock allows you to digitize several points or vertexes using the same constraints.

Parallel and perpendicular lines

앞에서 설명한 모든 도구들은 cadPerpendicular PerpendicularcadParallel Parallel 도구와 결합해서 사용할 수 있습니다. 이 두 도구는 선분을 또다른 선분에 완벽히 직각으로 또는 평행하게 그릴 수 있습니다.

To draw a perpendicular segment, during the editing click the cadPerpendicular Perpendicular icon (keyboard shortcut P) to activate it. Before drawing the perpendicular line, click on the segment of an existing feature that you want to be perpendicular to (the line of the existing feature will be colored in light orange); you should see a blue dotted line where your feature will be snapped:

../../../_images/advanced_digitizing_perpendicular.png

수직 디지타이즈 작업

To draw a parallel feature, the steps are the same: click on the cadParallel Parallel icon (keyboard shortcut P twice), click on the segment you want to use as reference and start drawing your feature:

../../../_images/advanced_digitizing_parallel.png

평행 디지타이즈 작업

이 두 도구는 수직 및 평행 각도에 딱 맞는 각도를 찾아서 편집 작업 중에 해당 파라미터를 고정시킵니다.

작성 모드

You can enable and disable construction mode by clicking on the cadConstruction Construction icon or with the C keyboard shortcut. While in construction mode, clicking the map canvas won’t add new vertexes, but will capture the clicks〉 positions so that you can use them as reference points to then lock distance, angle or X and Y relative values.

예를 들어, 기존 포인트에서 정확이 동일 거리에 있는 포인트를 몇 개 그리는 데 작성 모드를 사용할 수 있습니다.

With an existing point in the map canvas and the snapping mode correctly activated, you can easily draw other points at given distances and angles from it. In addition to the cad button, you have to activate also the construction mode by clicking the cadConstruction Construction icon or with the C keyboard shortcut.

Click next to the point from which you want to calculate the distance and click on the d box (D shortcut) type the desired distance and press Enter to lock the mouse position in the map canvas:

../../../_images/advanced_digitizing_distance_point.png

포인트로부터의 거리

Before adding the new point, press C to exit the construction mode. Now, you can click on the map canvas, and the point will be placed at the distance entered.

You can also use the angle constraint to, for example, create another point at the same distance of the original one, but at a particular angle from the newly added point. Click the cadConstruction Construction icon or with the C keyboard shortcut to enter construction mode. Click the recently added point, and then the other one to set a direction segment. Then, click on the d text box (D shortcut) type the desired distance and press Enter. Click the a text box (A shortcut) type the angle you want and press Enter. The mouse position will be locked both in distance and angle.

../../../_images/advanced_digitizing_distance_angle_point.png

포인트들로부터의 거리 및 각도

Before adding the new point, press C to exit the construction mode. Now, you can click on the map canvas, and the point will be placed at the distance and angle entered. Repeating the process, several points can be added.

../../../_images/advanced_digitizing_distance_point_final.png

지정 거리 및 각도에 있는 포인트들

The Processing in-place layer modifier

The Processing menu provides access to a large set of tools to analyze and create new features based on the properties of the input features or their relations with other features (within the same layer or not). While the common behavior is to create new layers as outputs, some algorithms also allow modifications to the input layer. This is a handy way to automate multiple features modification using advanced and complex operations.

To edit features in-place:

  1. Select the layer to edit in the Layers panel.

  2. Select the concerned features. You can skip this step, in which case the modification will apply to the whole layer.

  3. Press the processSelected Edit Features In-Place button at the top of the Processing toolbox. The list of algorithms is filtered, showing only those compatible with in-place modifications, i.e.:

    • They work at the feature source and not at the layer level.

    • They do not change the layer structure, e.g. adding or removing fields.

    • They do not change the geometry type, e.g. from line to point layer.

    ../../../_images/edit_inplace_algorithms.png

    Processing algorithms: all (left) vs polygon in-place editors (right)

  4. Find the algorithm you’d like to run and double-click it.

    참고

    If the algorithm does not need any additional user-set parameters (excluding the usual input and output layer parameters), then the algorithm is run immediately without any dialog popup.

    1. If parameters other than the usual input or output layers are needed, the algorithm dialog pops up. Fill in the required information.

    2. Click Modify Selected Features or Modify All Features depending on whether there’s an active selection.

    Changes are applied to the layer and placed in the edit buffer: the layer is indeed toggled to editing mode with unsaved modification as indicated by the editableEdits icon next to the layer name.

  5. As usual, press saveEdits Save layer edits to commit the changes in the layer. You can also press undo Undo to rollback the whole modification.