編集

QGISはOGR、SpatiaLite、PostGISに、MSSQL SpatialおよびOracle Spatialのベクターレイヤーとテーブルを編集するためのさまざまな機能をサポートしています。

注釈

GRASSレイヤーを編集する手順は異なります - 詳細は GRASSベクターレイヤーをデジタル化して編集する のセクションを参照。

ちなみに

同時編集

他の誰かが同じ時間に同じ地物を編集しているかどうかをQGISのこのバージョンでは追跡しません。その編集内容を保存するには、最後の人が勝ち。

スナップ許容誤差と検索半径の設定

ベクターレイヤーの形状の最適かつ正確な編集のために、地物の頂点のスナップの誤差と検索半径の適切な値を設定する必要があります。

スナップ許容誤差

When you add a new vertex or move an existing one, snapping tolerance is the distance QGIS uses to search for the closest vertex or segment you are trying to connect to. If you aren't within the snapping tolerance, QGIS will leave the vertex where you release the mouse button, instead of snapping it to an existing vertex or segment.

The snapping tolerance setting affects all tools that work with tolerance.

You can enable or disable snapping by using the snapping Enable snapping button on the Snapping Toolbar or pressing S at any time while you're on the map view. This toolbar is also very convenient to quickly configure the snapping mode, tolerance value, and units. The snapping configuration can also be set in Project ‣ Snapping Options....

There are three options to select the layer(s) to snap to:

  • All layers: quick setting for all visible layers in the project so that the pointer snaps to all vertices and/or segments. In most cases, it is sufficient to use this snapping mode, but beware when using it on projects with many vector layers, as it may cause slowness.

  • Current layer: only the active layer is used, a convenient way to ensure topology within the layer being edited.

  • Advanced Configuration: allows you to enable and adjust snapping mode and tolerance on a layer basis (see figure_edit_snapping). If you need to edit a layer and snap its vertices to another, ensure the target layer is checked and increase the snapping tolerance to a higher value. Snapping will not occur to a layer that is not checked in the snapping options dialog.

As for snapping mode, you can select between To vertex, To segment, and To vertex and segment.

The tolerance values can be set either in the project's map units or in pixels. The advantage of choosing pixels is that it keeps the snapping constant at different map scales. 10 to 12 pixels is normally a good value, but it depends on the DPI of your screen. Using map units allows the tolerance to be related to real ground distances. For example, if you have a minimum distance between elements, this option can be useful to ensure that you don’t add vertexes too close to each other.

../../../_images/editProjectSnapping.png

Snapping options (Advanced Configuration mode)

注釈

By default, only visible features (the features whose style is displayed, except for layers where the symbology is "No symbols") can be snapped. You can enable the snapping on invisible features by checking unchecked Enable snapping on invisible features under the Settings ‣ Options ‣ Digitizing tab.

ちなみに

Enable snapping by default

You can set snapping to be enabled by default on all new projects in the Settings ‣ Options ‣ Digitizing tab. You can also set the default snapping mode, tolerance value, and units, which will populate the Snapping Options dialog.

交差に対するスナッピングを有効にする

Another available option is to use snappingIntersection snapping on intersection, which allows you to snap to geometry intersections of snapping enabled layers, even if there are no vertices at the intersections.

検索半径

Search radius is the distance QGIS uses to search for the closest vertex you are trying to select when you click on the map. If you aren't within the search radius, QGIS won't find and select any vertex for editing. The search radius for vertex edits can be defined under the Settings ‣ options Options ‣ Digitizing tab. This is the same place where you define the snapping default values.

Snap tolerance and search radius are set in map units or pixels, so you may find you need to experiment to get them set right. If you specify too big of a tolerance, QGIS may snap to the wrong vertex, especially if you are dealing with a large number of vertices in close proximity. Set the search radius too small, and it won't find anything to move.

トポロジ編集

Apart from snapping options, the Snapping options...` dialog (Project ‣ Snapping options) and the Snapping toolbar allow you to enable and disable some topological functionalities.

トポロジ編集を有効にする

The topopologicalEditing Topological editing button helps when editing and maintaining features with common boundaries. With this option enabled, QGIS 'detects' boundaries that are shared by the features; When you move common vertices/segments, QGIS will also move them in the geometries of the neighboring features.

Topological editing works with features from different layers, as long as the layers are visible and in editing mode.

新規ポリゴンの重なりの禁止

When the snapping mode is set to Advanced configuration, for polygon layers, there's an option called checkbox Avoid intersections. This option prevents you from drawing new features that overlap existing ones in the selected layer, speeding up digitizing of adjacent polygons.

With avoid intersections enabled, if you already have one polygon, you can digitize a second one such that both intersect. QGIS will cut the second polygon to the boundary of the existing one. The advantage is that you don't have to digitize all vertices of the common boundary.

注釈

If the new geometry is totally covered by existing ones, it gets cleared, and QGIS will show an error message.

警告

Use cautiously the Avoid overlap option

Since this option will cut new overlapping geometries of any polygon layer, you can get unexpected geometries if you forget to uncheck it when no longer needed.

ジオメトリチェッカー

コアプラグインはジオメトリ無効を見つけるためにユーザーを助けることができます。このプラグインの詳細情報は ジオメトリチェッカープラグイン に見つかります。

自動トレース

Usually, when using capturing map tools (add feature, add part, add ring, reshape and split), you need to click each vertex of the feature. With the automatic tracing mode, you can speed up the digitization process as you no longer need to manually place all the vertices during digitization:

  1. Enable the tracing Tracing tool by pushing the icon or pressing T key.

  2. Snap to a vertex or segment of a feature you want to trace along.

  3. Move the mouse over another vertex or segment you'd like to snap and, instead of the usual straight line, the digitizing rubber band represents a path from the last point you snapped to the current position.

    QGIS actually uses the underlying features topology to build the shortest path between the two points. Tracing requires snapping to be activated in traceable layers to build the path. You should also snap to an existing vertex or segment while digitizing and ensure that the two nodes are topologically connectable through existing features edges, otherwise QGIS is unable to connect them and thus traces a single straight line.

  4. Click and QGIS places the intermediate vertices following the displayed path.

Unfold the tracing Enable Tracing icon and set the Offset option to digitize a path parallel to the features instead of tracing along them; a positive value shifts the new drawing to the left side of the tracing direction and a negative value does the opposite.

注釈

最適なトレースのための地図の縮尺やスナップ設定を調整します

地図表示中にあまりにも多くの地物がある場合、トレースは、長いトレース構造の準備と大容量メモリのオーバーヘッドの可能性を回避するために、無効になります。いくつかのレイヤーをズームインまたは無効にした後、トレースは再び有効になります。

注釈

Does not add topological points

This tool does not add points to existing polygon geometries even if Topological editing is enabled. If geometry precision is activated on the edited layer, the resulting geometry might not exactly follow an existing geometry.

ちなみに

Quickly enable or disable automatic tracing by pressing the T key

By pressing the T key, tracing can be enabled/disabled anytime even while digitizing one feature, so it is possible to digitize some parts of the feature with tracing enabled and other parts with tracing disabled. Tools behave as usual when tracing is disabled.

既存レイヤーのデジタイズ

デフォルトでは、QGISはレイヤーを読み取り専用でロードします。これは、マウスが滑ってしまった場合に誤ってレイヤーを編集することを避けるための安全装置です。しかし、どんなレイヤーでも、データプロバイダーがサポートしていて( データフォーマットとフィールドを書き出す 参照)かつ基礎となるデータソースが書き込み可能である(すなわち、そのファイルが読み取り専用でない)限り、編集を選択できます。

ちなみに

プロジェクト内のレイヤーに対する編集権限を制限する

From the Project ‣ Properties... ‣ Data Sources ‣ Layers Capabilities table, You can choose to set any layer read-only regardless the provider permission. This can be a handy way, in a multi-users environment to avoid unauthorized users to mistakenly edit layers (e.g., Shapefile), hence potentially corrupt data. Note that this setting only applies inside the current project.

ベクターレイヤーを編集するツールは、デジタイズと高度なデジタイズという二つのツールバーにわけてまとめられています。高度なデジタイズについては 高度なデジタイジング によって解説されています。 このツールの選択/非選択は ビュー ‣ ツールバー ‣ によって行います。基本的なデジタイズのツールでは次のような機能を使用できます。

アイコン

目的

アイコン

目的

allEdits

現在の編集

toggleEditing

編集切り替え

saveEdits

レイヤー編集の保存

newTableRow

Add new record

capturePoint

地物を追加:ポイントをキャプチャ

captureLine

地物を追加:ラインをキャプチャ

capturePolygon

地物を追加:ポリゴンをキャプチャ

vertexTool

Vertex Tool (All Layers)

vertexToolActiveLayer

Vertex Tool (Current Layer)

multiEdit

Modify the attributes of all selected features simultaneously

deleteSelected

選択したものの削除

editCut

地物の切り取り

editCopy

地物のコピー

editPaste

地物の貼り付け

undo

元に戻す

redo

やり直し

テーブル編集:ベクターレイヤー基本編集ツールバー

デジタル化のツールを何か使用している間も、ツールにフォーカスを失うことなく地図キャンバス内で ズームやパン ができることに注意してください。

すべての編集セッションは所定のレイヤーのコンテキストメニューにある toggleEditing 編集切替 オプション選択することによって開始、属性テーブル]ダイアログ、デジタル化のツールバー、または 編集 メニューボックスから。

レイヤーが編集モードになると、編集ツールバー上に追加のツールボタンが利用可能になり、マーカーは 設定 ‣ オプション... ‣ デジタル化 メニュー下 選択した地物だけにマーカー表示 オプションがチェックされない限り、すべての地物の頂点に表示されます。

ちなみに

定期的に保存する

定期的に saveEdits レイヤー編集を保存 することを忘れないでください。また、これはデータソースがすべての変更を受け入れることができることを確認します。

地物を追加する

Depending on the layer type, you can use the newTableRow Add Record, capturePoint Add Point Feature, captureLine Add Line Feature or capturePolygon Add Polygon Feature icons on the toolbar to add new features into the current layer.

To add a geometryless feature, click on the newTableRow Add Record button and you can enter attributes in the feature form that opens. To create features with the spatially enabled tools, you first digitize the geometry then enter its attributes. To digitize the geometry:

  1. Left-click on the map area to create the first point of your new feature. For point features, this should be enough and trigger, if required, the feature form to fill in their attributes. Having set the geometry precision in the layer properties you can use snap to grid here to create features based on a regular distance.

  2. For line or polygon geometries, keep on left-clicking for each additional point you wish to capture or use automatic tracing capability to accelerate the digitization. This will create consecutive straight lines between the vertices you place.

    注釈

    Pressing Delete or Backspace key reverts the last node you add.

  3. When you have finished adding points, right-click anywhere on the map area to confirm you have finished entering the geometry of that feature.

    注釈

    While digitizing line or polygon geometries, you can switch back and forth between the linear Add feature tools and circular string tools to create compound curved geometries.

    ちなみに

    デジタル化ゴムバンドをカスタマイズ

    ポリゴンをキャプチャしながら、デフォルトの赤いゴムバンドを使用すると、ポイントをキャプチャしたいのですが、基礎となる地物や場所を非表示にできます。 設定 ‣ オプション ‣ デジタル化 メニュー内の 塗りつぶし色 このゴムバンドの下に不透明度(またはアルファチャンネル)を設定することによって固定できます。 ノード編集中にゴムバンドを更新しない をチェックすることにより、ゴムバンドの使用を避けることもできます。

  4. 属性ウィンドウが表示され、新しい地物のための情報を入力できます。 Figure_edit_values は、アラスカの架空の新しい川の属性を設定することを示しています。しかし、 設定 ‣ オプション メニュー下の デジタル化 メニューの中で、以下もアクティブにできます。

    • checkbox Suppress attributes pop-up windows after each created feature to avoid the form opening;

    • または checkbox 最後に入力された属性値を再利用 で、フォームが開いたときにフィールドが自動的に満たされ変化する値を入力する必要があるだけにします。

../../../_images/editDigitizing.png

属性を入力すると、新しいベクター地物をデジタル化した後、ダイアログ値

Vertex tool

注釈

QGIS 3 major changes

In QGIS 3, the node tool has been fully redesigned and renamed to Vertex Tool. It was previously working with "click and drag" ergonomy, and now uses a "click - click" workflow. This allows major improvements like taking profit of the advanced digitizing panel with the vertex tool while digitizing or editing objects of multiple layers at the same time.

For any editable vector layer, the vertexToolActiveLayer Vertex tool (Current Layer) provides manipulation capabilities of feature vertices similar to CAD programs. It is possible to simply select multiple vertices at once and to move, add or delete them altogether. The vertex tool also works with 'on the fly' projection turned on and supports the topological editing feature. This tool is selection persistent, so when some operation is done, selection stays active for this feature and tool.

プロパティ 設定 ‣ options オプション ‣ デジタル化 ‣ 検索半径: selectNumber をゼロより大きい数に設定することが重要です。そうでない場合は、QGISではどの頂点が編集されているか伝えることができなくなり、警告が表示されます。

ちなみに

頂点マーカー

「半透明の円」、「十字架」と「なし」:QGISの現在のバージョンは、頂点マーカーの3種類をサポートしています。マーカーのスタイルを変更するには 設定 メニューから options オプション 選択し、 デジタル化 タブをクリックして、適切なエントリを選択します。

基本操作

Start by activating the vertexToolActiveLayer Vertex Tool (Current Layer). Red circles will appear when hovering vertices.

  • Selecting vertices: You can select vertices by clicking on them one at a time holding Shift key pressed, or by clicking and dragging a rectangle around some vertices. When a vertex is selected, its color changes to blue. To add more vertices to the current selection, hold down the Shift key while clicking. To remove vertices from the selection, hold down Ctrl.

  • Batch vertex selection mode: The batch selection mode can be activated by pressing Shift+R. Select a first node with one single click, and then hover without clicking another vertex. This will dynamically select all the nodes in between using the shortest path (for polygons).

    ../../../_images/vertex_batch_selection_mode.png

    Batch vertex selection using Shift+R

    Press Ctrl will invert the selection, selecting the longest path along the feature boundary. Ending your node selection with a second click, or pressing Esc will escape the batch mode.

  • Adding vertices: To add a vertex, a virtual new node appears on the segment center. Simply grab it to add a new vertex. Double click on any location of the boundary also creates a new node. For lines, a virtual node is also proposed at both extremities of a line to extend it.

    ../../../_images/vertex_add_node.png

    Virtual nodes for adding vertices

  • 頂点を削除する:頂点を選択し、クリックしてください DELETE キーを。地物のすべての頂点を削除すると、データソースと互換性がある場合は、ジオメトリなし地物が作成されます。これは、完全に地物を削除せず、ジオメトリ部分だけを削除することに注意してください。完全に地物を削除するには、 deleteSelected 選択を削除 ツールを使用します。

  • Moving vertices: Select all the vertices you want to move, click on a selected vertex or edge, and click again on the desired new location. All the selected vertices will move together. If snapping is enabled, the whole selection can jump to the nearest vertex or line. You can use Advanced Digitizing Panel constraints for distance, angles, exact X Y location before the second click.

    Here you can use the snap-to-grid feature. Having set a value for the geometry precision in the layer properties, a grid appears on a zoom level according to the Geometry precision.

    ../../../_images/vertex_snap_to_grid.png

    Selecting a vertex and moving the vertices to grid

Each change made with the vertex is stored as a separate entry in the Undo dialog. Remember that all operations support topological editing when this is turned on. On-the-fly projection is also supported, and the node tool provides tooltips to identify a vertex by hovering the pointer over it.

The Vertex Editor Panel

When using the Vertex tool on a feature, it is possible to right click to open the Vertex Editor panel listing all the vertices of the feature with their x, y (z, m if applicable) coordinates and r (for the radius, in case of circular geometry). Simply select a row in the table does select the corresponding vertex in the map canvas, and vice versa. Simply change a coordinate in the table and your vertex position is updated. You can also select multiple rows and delete them altogether.

注釈

Changed behavior in QGIS 3.4

Right click on a feature will immediately show the vertex editor and lock this feature, thus disabling the editing of any other features. While being locked, a feature is exclusive for editing: Selecting and moving of vertices and segments by clicking or dragging is only possible for this feature. New vertices can only be added to the locked feature. Also, the vertex editor panel now opens itself automatically upon activating the vertex tool, and its position/docked state remembered across uses.

../../../_images/vertex_editor_panel.png

選択したノードを示す頂点エディタパネル

地物の切り取り、コピーと貼り付け

選択した地物が、同じQGISプロジェクトのレイヤーの間に、カット、コピー&ペーストできる限り、先のレイヤーが設定されているように事前に toggleEditing 編集切り替え

ちなみに

コピー/ペーストを使用して行およびその逆にポリゴンを変換

ポリゴンレイヤーにライン地物をコピーして貼り付け:QGISでは貼り付け先レイヤーにその境界、ライン地物の閉じた形状に対応したポリゴンを貼り付けます。これは、同じデータの異なる形状を生成する簡単な方法です。

地物はテキストなどの外部アプリケーションに貼り付けできます。これは、地物はジオメトリデータはOGC well-knownテキスト(WKT)形式に登場すると、CSV形式で表現されています。外部QGISからのWKTおよびGeoJSON地物もQGIS内のレイヤーに貼り付けできます。

どんなときであればコピー&ペースト機能が便利になるのでしょうか?まあ、それはあなたがレイヤーの間の一度にコピー/貼り付け機能で複数のレイヤーを編集できることが判明しました。なぜ我々はこれをしたいのでしょうか?私たちは big_lakes レイヤーの上に5000、ない新しいレイヤーの上にいくつかの作業を行う必要があるが、1つのまたは2つの湖を必要とします。新しいレイヤーを作成し、コピー/貼り付けを使用して必要な湖をそこにポトンと落とすことができます。

例として新しいレイヤーにいくつかの湖沼をコピーします:

  1. コピーしたいレイヤーをロードします (元レイヤー)

  2. コピー先にしたいレイヤーをロードまたは作成します(先レイヤー)

  3. 先レイヤーの編集を開始します

  4. 凡例をクリックして元レイヤーをアクティブにします

  5. selectRectangle 領域またはシングルクリックで地物を選択 ツールを使用して、ソースレイヤー上の地物(複数可)を選択します

  6. editCopy 地物をコピー ツールをクリックして

  7. 凡例をクリックしてコピー先レイヤーをアクティブにします

  8. editPaste 地物を貼り付け ツールをクリックして

  9. 編集モードを終了して変更内容を保存して下さい

コピー元とコピー先レイヤーでスキーマが異なる(フィールド名とタイプが同じではない)場合はどうなりますか?QGISは一致するものを投入し、残りは無視します。コピー先レイヤーにコピーされる属性は気にしないのであれば、フィールドとデータ型を設計する方法は重要ではありません。すべて、つまり地物とその属性、が必ずコピーされるようにしたい場合は、スキーマが一致していることを確認してください。

注釈

貼り付け地物の一致

コピー元とコピー先のレイヤーが同じ投影を使用する場合は、貼り付けられた地物はソースレイヤーと同一の形状になるでしょう。しかし、コピー先のレイヤーの投影が異なる場合、QGISでは形状が同一であることを保証できません。これは単に、投影間で変換する時に小さな丸め誤差が入ってくるためです。

ちなみに

文字列属性を他にコピー

タイプ「文字列」を使用して属性テーブルに新しい列を作成し、より大きな長さを持つ別の属性列から値を貼り付けたい場合、列のサイズの長さは同じ量に拡張されるでしょう。GDAL / OGR 1.10始まるGDALシェープファイルドライバが動的に挿入されるデータの長さに適応するように、文字列と整数フィールドを自動的に拡張することを知っているからです。

選択地物の削除

地物全体(属性とジオメトリ)を削除したい場合は、正規 selectRectangle エリアやシングルクリックで地物を選択 ツールを使用して最初にジオメトリを選択することによって行うことができます。選択は属性テーブルからも行うことができます。選択セットを得たら、 DELETEBackspace キーを押すか、または deleteSelected 選択を削除 ツールを使用して地物を削除します。選択した複数の地物を一度に削除できます。

デジタル化ツールバーの editCut 地物を切り取り ツールは、地物を削除するために使用できます。これは効果的に地物が削除されますが、それらをまた「空間クリップボード」上に置きます。そこで、削除する地物をカット。その後、 editPaste 地物を貼り付け ツールを使用できます、1レベルの取り消し機能を与え、それを戻すために。一度に複数の上で動作させることができることを意味し、現在選択されている地物の切り取り、コピー、貼り付け作業。

元に戻すとやり直し

undo 元に戻すredo やり直し ツールを使用すると、ベクタ-の編集操作を元に戻すか、やり直すことができます( Figure_edit_undo を参照)。元に戻す/やり直しの履歴の中ですべての操作を示しドッキング可能なウィジェットもあります。このウィジェットは、デフォルトでは表示されません。それはツールバーを右クリックすると、 元に戻す/やり直しパネル チェックボックスをアクティブにして表示できます。しかしながら[元に戻す/やり直し]は、ウィジェットが表示されていない場合でもアクティブです。

../../../_images/redo_undo.png

デジタル化のステップを元に戻すかやり直しします

「元に戻す」が押されるか Ctrlキー+Z (または Cmd+Z )が押された場合、すべての地物および属性の状態が、戻される操作が起こった前の状態に戻ります。通常のベクターの編集操作以外の変更(例えば、プラグインによって行われた変更)は、どのように変更が行われたかに応じて、戻ることも戻らないこともあります。

元に戻す/やり直し 履歴ウィジェットを利用する場合単純に操作の履歴リストをクリックして下さい。すべての操作は選択操作のあとであった状態に戻されます。

編集レイヤーの保存

レイヤーが編集モードである場合、すべての変更は、QGISのメモリに残ります。したがって、それらはすぐにデータソースまたはディスクにコミット/保存されるわけではありません。現在のレイヤーに編集内容を保存したいが、編集モードを離れることなく、編集を続けたい場合は、クリックできます saveEdits レイヤー編集を保存 ボタン。 toggleEditing 編集を切り替え で編集モードを無効にする(またはそのことについてQGISを終了する)と、変更を保存するか破棄するか尋ねられます。

変更が保存できない場合(例えば、ディスクがいっぱい、または属性が範囲外の値を持つ)、QGISメモリ内の状態は保持されます。これにより、編集を調整して、やり直しできます。

ちなみに

データの整合性

編集を開始する前には常に、データソースをバックアップすることをお勧めします。QGISの著者はデータの整合性を維持するためにあらゆる努力をしていますが、我々はこの点において保証を提供しません。

一度に複数のレイヤーを保存する

この機能は、複数のレイヤーのデジタル化できます。複数のレイヤーで作られたすべての変更を保存するためには、 fileSaveAs 選択したレイヤーについて保存 を選択してください。また rollbackEdits 選択レイヤーについてロールバック の機会を持っている、選択されたすべてのレイヤーについてデジタル化が撤回できるようになっています。選択したレイヤーを編集を中止したい場合 cancelEdits 選択されたレイヤー(複数可)についてキャンセル が簡単な方法です。

同じ機能がプロジェクトの全レイヤーの編集で可能です.

ちなみに

複数のレイヤーの変更を一度に編集、保存、またはロールバックするためにトランザクショングループを使用する

When working with layers from the same PostGreSQL database, activate the Automatically create transaction groups where possible option in Project ‣ Properties... ‣ Data Sources to sync their behavior (enter or exit the edit mode, save or rollback changes at the same time).

高度なデジタイジング

アイコン

目的

アイコン

目的

cad

高度なデジタル化ツールを有効にします

tracing

トレースを有効にします

moveFeature moveFeatureLine moveFeaturePoint

Move Feature(s)

moveFeatureCopy moveFeatureCopyLine moveFeatureCopyPoint

Copy and Move Feature(s)

rotateFeature

地物(群)の回転

simplifyFeatures

地物の簡素化

addRing

リングの追加

addPart

パートの追加

fillRing

リングの塗りつぶし

deleteRing

リングの削除

deletePart

パートの削除

offsetCurve

オフセットカーブ

reshape

地物の変形

splitParts

部分の分割

splitFeatures

地物の分割

mergeFeatAttributes

選択地物の属性の結合

mergeFeatures

選択地物の結合

rotatePointSymbols

ポイントシンボルの回転

offsetPointSymbols

ポイントシンボルのオフセット

高度なテーブル編集: ベクターレイヤーの高度な編集ツールバー

Move Feature(s)

The moveFeature Move Feature(s) tool allows you to move existing features:

  1. Select the feature(s) to move.

  2. Click on the map canvas to indicate the origin point of the displacement; you can rely on snapping capabilities to select an accurate point.

    You can also take advantages of the advanced digitizing constraints to accurately set the origin point coordinates. In that case:

    1. First click on the cad button to enable the panel.

    2. Type x and enter the corresponding value for the origin point you'd like to use. Then press the locked button next to the option to lock the value.

    3. Do the same for the y coordinate.

    4. Click on the map canvas and your origin point is placed at the indicated coordinates.

  3. Move over the map canvas to indicate the destination point of the displacement, still using snapping mode or, as above, use the advanced digitizing panel which would provide complementary distance and angle placement constraints to place the end point of the translation.

  4. Click on the map canvas: the whole features are moved to new location.

Likewise, you can create a translated copy of the feature(s) using the moveFeatureCopy Copy and Move Feature(s) tool.

注釈

If no feature is selected when you first click on the map canvas with any of the Move Feature(s) or Copy and Move Feature(s) tools, then only the feature under the mouse is affected by the action. So, if you want to move several features, they should be selected first.

地物(群)の回転

Use the rotateFeature Rotate Feature(s) tool to rotate one or multiple features in the map canvas:

  1. Press the rotateFeature Rotate Feature(s) icon

  2. Then click on the feature to rotate. The feature's centroid is referenced as rotation center, a preview of the rotated feature is displayed and a widget opens showing the current Rotation angle.

  3. Click on the map canvas when you are satisfied with the new placement or manually enter the rotation angle in the text box. You can also use the Snap to ° box to constrain the rotation values.

  4. If you want to rotate several features at once, they shall be selected first, and the rotation is by default around the centroid of their combined geometries.

You can also use an anchor point different from the default feature centroid: press the Ctrl button, click on the map canvas and that point will be used as the new rotation center.

地図上をクリックする前に Shift を保持している場合、回転が45度の段階で行われます、ユーザー入力ウィジェットの中で後で変更できます。

To abort feature rotation, press the ESC button or click on the rotateFeature Rotate Feature(s) icon.

地物の簡素化

The simplifyFeatures Simplify Feature tool allows you to interactively reshape a line or polygon geometry by reducing or densifying the number of vertices, as long as the geometry remains valid:

  1. Select the simplifyFeatures Simplify Feature tool.

  2. Click on the feature or drag a rectangle over the features.

  3. A dialog pops up allowing you to define the Method to apply, ie whether you would like to:

    • simplify the geometry, meaning less vertices than the original. Available methods are Simplify by distance, Simplify by snapping to grid or simplify by area (Visvalingam). You'd then need to indicate the value of Tolerance in Layer units, Pixels or map units to use for simplification. The higher the tolerance is the more vertices can be deleted.

    • or densify the geometries with new vertices thanks to the Smooth option: for each existing vertex, two vertices are placed on each of the segments originated from it, at an Offset distance representing the percentage of the segment length. You can also set the number of Iterations the placement would be processed: the more iterations, the more vertices and smoother is the feature.

    Settings that you used will be saved when leaving a project or an edit session. So you can go back to the same parameters the next time you simplify a feature.

  4. A summary of the modifications that would apply is shown at the bottom of the dialog, listing number of features and number of vertices (before and after the operation and the ratio the change represents). Also, in the map canvas, the expected geometry is displayed over the existing one, using the rubberband color.

  5. When the expected geometry fits your needs, click OK to apply the modification. Otherwise, to abort the operation, you can either press Cancel or right-click in the map canvas.

注釈

レンダリングするためだけにジオメトリを簡素化する 設定 ‣ オプション ‣ レンダリング メニュー中の地物の簡素化オプションとは異なり、 simplifyFeatures 地物を簡素化 ツールでは、永遠にデータソース内の地物のジオメトリを変更します。

パートの追加

選択された地物に addPart 部分を追加 して、マルチポイント、マルチラインまたはマルチポリゴン地物を生成します。新しい部分は、事前に選択する必要のある既存のものの外にデジタル化する必要があります。

addPart 部分を追加 は、ジオメトリのない地物にジオメトリを追加するためにも使用できます。まず、属性テーブルで地物を選択し、 addPart 部分を追加 ツールで新しいジオメトリを数値化します。

パートの削除

deletePart 部分を削除 ツールは、複数部分地物から部分を削除できます(例えば、マルチポリゴン地物からポリゴンを削除する)。ポイント、ラインとポリゴン:このツールは、すべての複数部分ジオメトリで動作します。さらに、完全な地物の幾何的構成要素を除去するために使用できます。一部を削除するには、単に対象の部分内をクリックします。

リングの追加

ツールバーの addRing リングを追加 アイコンを使用してリングポリゴンを作成できます。これは、既存の領域の内部、外側と内側の多角形の境界の間の領域のみがリングポリゴンとして残るように、「穴」として発生する更なるポリゴンをデジタル化することが可能であることを意味します。

リングの塗りつぶし

The fillRing Fill Ring tool helps you create polygon feature that totally falls within another one without any overlapping area; that is the new feature covers a hole within the existing one. To create such a feature:

  1. Select the fillRing Fill Ring tool.

  2. Draw a new polygon over the existing feature: QGIS adds a ring to its geometry (like if you used the addRing Add Ring tool) and creates a new feature whose geometry matches the ring (like if you traced over the interior boundaries with the capturePolygon Add polygon feature tool).

  3. Or alternatively, if the ring already exists on the feature, place the mouse over the ring and left-click while pressing Shift: a new feature filling the hole is drawn at that place.

    The Feature Attributes form of the new feature opens, pre-filled with values of the "parent" feature and/or fields constraints.

リングの削除

deleteRing リングを削除 ツールでは、穴の内側をクリックすることで、既存のポリゴン内のリングを削除できます。このツールは、ポリゴンとマルチポリゴンの地物に対応しています。それはポリゴンの外側のリング上で使用されているとき、それは何も変わりません。

地物の変形

ツールバーの reshape 地物を変形 ツールを使用するとラインやポリゴンの形状を変更できます。ラインの場合は、最初のラインからのライン部分を元のラインとの最後の交差まで置き換えます。

../../../_images/reshape_lines.png

ラインを変形

ちなみに

変形ツールでラインストリングジオメトリを延長

reshape 地物を変形 を使用する、ツール既存のラインストリングジオメトリを拡張する:ラインの最初または最後の頂点にスナップして、新しいラインを描画します。検証すると、地物のジオメトリは2つのラインの組み合わせになります。

ポリゴンの場合は、ポリゴンの境界を再形成します。それが動作するためには、変形ツールの線はポリゴンの境界を少なくとも2回横切る必要があります。ラインを描画するには、地図キャンバスをクリックして頂点を追加します。終了するには、右クリックしてください。ラインと同様に、最初の交差点と最後の交差点の間のセグメントのみが考慮されます。ポリゴンの内側にあるリシェイプラインのセグメントは、ポリゴンの外側にあるものがポリゴンの外側にある部分を切り取るようになります。

../../../_images/reshape_polygon.png

ポリゴンを変形

ポリゴンでは、変形によって意図しない結果が生じることがあります。これは、ポリゴンの小さな部分を置換することが主なオーバーホールではなく、主に有効です。また、変形ラインは、無効なポリゴンを生成するので、いくつかのポリゴンリングを横切ることはできません。

注釈

変形ツールは、ポリゴンのリングまたは閉じた線の開始位置を変更することができます。だから、「二回」表されるポイントはこれ以上同じにはなりません。これは、ほとんどのアプリケーションでは問題ではないかもしれないが、考慮すべきものです。

オフセットカーブ

offsetCurve オフセット曲線 ツールは、ラインレイヤーの平行移動を作成します。ツールは、編集されたレイヤー(ジオメトリが変更された)に適用し、あるいはまた(それはライン/リングのコピーを作成し、編集したレイヤーに追加した場合)、背景レイヤーにできます。したがって、距離線レイヤーの作成に最適です。 ユーザー入力 ダイアログポップアップ、変位距離を示します。

ラインレイヤーのシフトを作成するには、まず編集モードに入るとアクティブにする必要があります offsetCurve オフセット曲線 ツール。そして、それをシフトする地物をクリックしてください。マウスを移動し、望んでいたか、ユーザー入力ウィジェットに所望の距離を入力する場所をクリックします。変更は、その後一緒に保存できます saveEdits レイヤー編集を保存 ツール。

QGISのオプション]ダイアログボックス([デジタル化]タブの後 曲線ツールをオフセット セクション) 結合スタイルクアドラントセグメントマイターリミット のようないくつかのパラメーターを設定できます。

地物の分割

Use the splitFeatures Split Features tool to split a feature into two or more new and independent features, ie. each geometry corresponding to a new row in the attribute table.

To split line or polygon features:

  1. Select the splitFeatures Split Features tool.

  2. Draw a line across the feature(s) you want to split. If a selection is active, only selected features are split. When set, default values or clauses are applied to corresponding fields and other attributes of the parent feature are by default copied to the new features.

  3. You can then as usually modify any of the attributes of any resulting feature.

ちなみに

Split a polyline into new features in one-click

Using the splitFeatures Split Features tool, snap and click on an existing vertex of a polyline feature to split that feature into two new features.

部分の分割

QGISでは、部分数が増加するように複数部分地物の部分を分割することが可能です。ちょうど使用して分割したい部分全体に線を引きます splitParts 部分を分割 アイコン。

ちなみに

Split a polyline into new parts in one-click

Using the splitParts Split Parts tool, snap and click on an existing vertex of a polyline feature to split the feature into two new polylines belonging to the same feature.

選択地物のマージ

mergeFeatures 選択された地物をマージ ツールは、既存の地物をマージして新しい地物を作成することを可能にします。それらのジオメトリをマージして新しい地物を生成します。地物に共通の境界がない場合、マルチポリゴン/マルチライン/マルチポイント地物が作成されます。

  1. First, select the features you'd like to combine.

  2. Then press the mergeFeatures Merge Selected Features button.

  3. In the new dialog, the Merge line at the bottom of the table shows the attributes of the resulting feature. You can alter any of these values either by:

    • manually replacing the value in the corresponding cell;

    • selecting a row in the table and pressing Take attributes from selected feature to use the values of this initial feature;

    • pressing Skip all fields to use empty attributes;

    • or, expanding the drop down menu at the top of the table, select any of the above options to apply to the corresponding field only. There, you can also choose to aggregate the initial features attributes (Minimum, Maximum, Median, Sum, Count, Concatenation... depending on the type of the field. see 統計の概要パネル for the full list of functions).

    注釈

    If the layer has default values or clauses present on fields, these are used as the initial value for the merged feature.

  4. Press OK to apply the modifications. A single (multi)feature is created in the layer, replacing the previously selected ones.

選択地物の属性マージ

mergeFeatAttributes 選択した地物の属性をマージする ツールを使用すると、地物に境界をマージせずに同じ属性を適用できます。このダイアログは、「選択された地物のマージ」ツールとは異なり、そのツールと異なり、選択されたオブジェクトは、その属性の一部は同一になりますが、ジオメトリは保持されます。

ポイントシンボルの回転

The rotatePointSymbols Rotate Point Symbols allows you to change the rotation of point symbols in the map canvas.

  1. First of all, apply to the symbol a data-defined rotation:

    1. In the Layer Properties ‣ Symbology dialog, browse to the symbol editor dialog.

    2. Click the dataDefined Data-defined override widget near the Rotation option of the top Marker level (preferably) of the symbol layers.

    3. Choose a field in the Field Type combobox. Values of this field are hence used to rotate each feature's symbol accordingly.

    注釈

    Make sure that the same field is assigned to all the symbol layers

    Setting the data-defined rotation field at the topmost level of the symbol tree automatically propagates it to all the symbol layers, a prerequisite to perform graphical symbol rotation with the Rotate Point Symbols tool. Indeed, if a symbol layer does not have the same field attached to its rotation property, the tool will not work.

    ../../../_images/rotatepointsymbol.png

    Rotating a point symbol

  2. Then click on a point feature in the map canvas with the rotatePointSymbols Rotate Point Symbols and move the mouse around, holding the left button pressed. A red arrow with the rotation value will be visualized (see Figure_rotate_point).

  3. Release the left mouse button again, the symbol is defined with this new rotation and the rotation field is updated in the layer's attribute table.

ちなみに

Ctrl キーを押し続けると回転は15度単位で実行されます。

ポイントシンボルのオフセット

offsetPointSymbols ポイントシンボルをオフセット は、地図キャンバス内のポイントシンボルのレンダリングされた位置を対話的に変更することを可能にします。このツールは、rotatePointSymbols のように動作します。 ポイントシンボルを回転 ツールは、フィールドをシンボルのデータ定義の Offset(X,Y) プロパティに接続する必要がある点を除いて、オフセット座標で設定されます。地図キャンバスでシンボルを移動します。

注釈

The offsetPointSymbols Offset Point Symbols tool doesn't move the point feature itself; you should use the vertexToolActiveLayer Vertex Tool (Current Layer) or moveFeaturePoint Move Feature tool for this purpose.

Shape digitizing

The Shape Digitizing toolbar offers a set of tools to draw regular shapes and curved geometries.

Add Circular string

The circularStringCurvePoint Add circular string or circularStringRadius Add circular string by radius buttons allow users to add line or polygon features with a circular geometry.

Creating features with these tools follow the same rule as of other digitizing tools: left-click to place vertices and right-click to finish the geometry. While drawing the geometry, you can switch from one tool to the other as well as to the linear geometry tools, creating some coumpound geometries.

注釈

湾曲形状は互換性のあるデータプロバイダーにおいてだけそのようなものとして記憶

Although QGIS allows to digitize curved geometries within any editable data format, you need to be using a data provider (e.g. PostGIS, memory layer, GML or WFS) that supports curves to have features stored as curved, otherwise QGIS segmentizes the circular arcs.

Draw Circles

There is a set of tools for drawing circles. The tools are described below.

Circles are converted into circular strings, therefore, as explained in ref:add_circular_string, if allowed by the data provider, it will be saved as a curved geometry, if not, QGIS will segmentize the circular arcs.

  • circle2Points Add circle from 2 points: The two points define the diameter and the orientation of the circle. (Left-click, right-click)

  • circle3Points Add circle from 3 points: Draws a circle from three known points on the circle. (Left-click, left-click, right-click)

  • circleCenterPoint Add circle from center and a point: Draws a circle with a given center and a point on the circle. (Left-click, right-click) When used with the 高度なデジタル化パネル this tool can become a "Add circle from center and radius" tool by setting and locking the distance value after first click.

  • circle3Tangents :sup`Add circle from 3 tangents`: Draws a circle that is tangential to three segments. Note that you must activate snapping to segments (See スナップ許容誤差と検索半径の設定). Click on a segment to add a tangent. If two tangents are parallel, an error message appears and the input is cleared. (Left-click, left-click, right-click)

  • circle2TangentsPoint Add circle from 2 tangents and a point: Similar to circle from 3 tangents, except that you have to select two tangents, enter a radius and select the desired center.

高度なデジタル化パネル

新規または既存のジオメトリをキャプチャ、再シェーピング、分割するときには、高度なデジタル化パネルを使用できます。特定の角度に対して線を正確に平行または垂直にデジタイズするか、線を特定の角度にロックできます。さらに、新しいジオメトリを正確に定義できるように、座標を直接入力することもできます。

../../../_images/advanced_digitizing.png

高度なデジタル化パネル

The Advanced Digitizing panel can be open either with a right-click on the toolbar, from View ‣ Panels ‣ menu or pressing Ctrl+4. Once the panel is visible, click the cad Enable advanced digitizing tools button to activate the set of tools.

注釈

地図ビューは、地理座標系である場合のツールが有効になっていません。

概念

高度なデジタル化ツールの目的は、地図キャンバスのデジタル化中にマウスを動かすときの座標、長さ、および角度をロックすることです。

相対参照または絶対参照を使用して、制約を作成することもできます。相対参照とは、次の頂点制約の値が前の頂点またはセグメントを基準とすることを意味します。

スナップ設定

settings ボタンを押して、高度なデジタル化ツールのスナップ設定を設定します。ツールを共通の角度にスナップできます。オプションは次のとおりです。

  • 共通角にスナップしない

  • 30º度にスナップ

  • 45º度にスナップ

  • 90º度にスナップ

地物のスナップを制御することもできます。オプションは次のとおりです。

  • 頂点または線分にスナップしない

  • プロジェクト設定に応じてスナップする

  • すべてのレイヤーにスナップ

キーボードショートカット

To speed up the use of Advanced Digitizing Panel, there are a couple of keyboard shortcuts available:

キー

シンプル

Ctrl+ or Alt+

Shift+

D

距離を設定

距離をロック

A

角度を設定

角度をロック

最後のセグメントに対する相対的な角度に切り替え

X

Set X coordinate

Lock X coordinate

Toggle relative X to last vertex

Y

Set Y coordinate

Lock Y coordinate

Toggle relative Y to last vertex

C

作図モードを切り替え

P

垂直と水平モードを切り替え

絶対参照デジタイジング

新しいジオメトリを最初から描画するときは、与えられた座標で頂点をデジタル化することが可能です。

たとえば、ポリゴンレイヤーに新しい地物を追加するには、 capturePolygon ボタンをクリックします。地物の編集を開始するX座標とY座標を選択してから、次の操作を実行できます。

  • Click the x text box (or use the X keyboard shortcut).

  • 必要なX座標値を入力し、 Enter を押すか、 locked ボタンを右に移動して、地図キャンバス上でマウスをX軸にロックします。

  • Click the y text box (or use the Y keyboard shortcut).

  • 必要なY座標値を入力し、 Enter を押すか、 locked ボタンを右に移動して、地図キャンバス上でマウスをY軸にロックします。

2つの青い点線と緑の十字は、入力した正確な座標を示します。地図キャンバスをクリックしてデジタイズを開始します。マウスの位置は緑の十字でロックされます。

../../../_images/advanced_digitizing_coordinates.png

与えられた座標で描画を開始

フリーハンドでデジタル化を続行したり、新しい座標ペアを追加したり、セグメントの 長さ (距離)と 角度 を入力できます。

If you want to draw a segment of a given length, click the d (distance) text box (keyboard shortcut D), type the distance value (in map units) and press Enter or click the locked button on the right to lock the mouse in the map canvas to the length of the segment. In the map canvas, the clicked point is surrounded by a circle whose radius is the value entered in the distance text box.

../../../_images/advanced_digitizing_distance.png

固定長セグメント

Finally, you can also choose the angle of the segment. As described before , click the a (angle) text box (keyboard shortcut A), type the angle value (in degrees), and press Enter or click the locked buttons on the right to lock it. In this way the segment will follow the desired angle:

../../../_images/advanced_digitizing_angle.png

固定角セグメント

相対参照デジタイジング

角度または座標の絶対値を使用する代わりに、最後のデジタル化された頂点またはセグメントを基準にした値を使用することもできます。

For angles, you can click the delta button on the left of the a text box (or press Shift+A) to toggle relative angles to the previous segment. With that option on, angles are measured between the last segment and the mouse pointer.

For coordinates, click the delta buttons to the left of the x or y text boxes (or press Shift+X or Shift+Y) to toggle relative coordinates to the previous vertex. With these options on, coordinates measurement will consider the last vertex to be the X and Y axes origin.

連続的ロック

Both in absolute or relative reference digitizing, angle, distance, X and Y constraints can be locked continuously by clicking the lockedRepeat Continuous lock buttons. Using continuous lock allows you to digitize several points or vertexes using the same constraints.

Parallel and perpendicular lines

上記のすべてのツールは、 cadPerpendicular 垂直 および cadParallel 平行 ツールと組み合わせできます。これらの2つのツールでは、描画セグメントを別のセグメントと完全に垂直または平行にできます。

To draw a perpendicular segment, during the editing click the cadPerpendicular Perpendicular icon (keyboard shortcut P) to activate it. Before drawing the perpendicular line, click on the segment of an existing feature that you want to be perpendicular to (the line of the existing feature will be colored in light orange); you should see a blue dotted line where your feature will be snapped:

../../../_images/advanced_digitizing_perpendicular.png

垂直デジタイズ

To draw a parallel feature, the steps are the same: click on the cadParallel Parallel icon (keyboard shortcut P twice), click on the segment you want to use as reference and start drawing your feature:

../../../_images/advanced_digitizing_parallel.png

平行デジタイジング

これらの2つのツールは、直角と平行な角度の直角を見つけて、編集中にこのパラメーターをロックします。

作図モード

You can enable and disable construction mode by clicking on the cadConstruction Construction icon or with the C keyboard shortcut. While in construction mode, clicking the map canvas won't add new vertexes, but will capture the clicks' positions so that you can use them as reference points to then lock distance, angle or X and Y relative values.

一例として、構築モードを使用して、ある点を既存の点から正確な距離に描画できます。

With an existing point in the map canvas and the snapping mode correctly activated, you can easily draw other points at given distances and angles from it. In addition to the cad button, you have to activate also the construction mode by clicking the cadConstruction Construction icon or with the C keyboard shortcut.

Click next to the point from which you want to calculate the distance and click on the d box (D shortcut) type the desired distance and press Enter to lock the mouse position in the map canvas:

../../../_images/advanced_digitizing_distance_point.png

点からの距離

Before adding the new point, press C to exit the construction mode. Now, you can click on the map canvas, and the point will be placed at the distance entered.

You can also use the angle constraint to, for example, create another point at the same distance of the original one, but at a particular angle from the newly added point. Click the cadConstruction Construction icon or with the C keyboard shortcut to enter construction mode. Click the recently added point, and then the other one to set a direction segment. Then, click on the d text box (D shortcut) type the desired distance and press Enter. Click the a text box (A shortcut) type the angle you want and press Enter. The mouse position will be locked both in distance and angle.

../../../_images/advanced_digitizing_distance_angle_point.png

点からの距離と角度

Before adding the new point, press C to exit the construction mode. Now, you can click on the map canvas, and the point will be placed at the distance and angle entered. Repeating the process, several points can be added.

../../../_images/advanced_digitizing_distance_point_final.png

所与の距離と角度の点

The Processing in-place layer modifier

The Processing menu provides access to a large set of tools to analyze and create new features based on the properties of the input features or their relations with other features (within the same layer or not). While the common behavior is to create new layers as outputs, some algorithms also allow modifications to the input layer. This is a handy way to automate multiple features modification using advanced and complex operations.

To edit features in-place:

  1. Select the layer to edit in the Layers panel.

  2. Select the concerned features. You can skip this step, in which case the modification will apply to the whole layer.

  3. Press the processSelected Edit Features In-Place button at the top of the Processing toolbox. The list of algorithms is filtered, showing only those compatible with in-place modifications, i.e.:

    • They work at the feature source and not at the layer level.

    • They do not change the layer structure, e.g. adding or removing fields.

    • They do not change the geometry type, e.g. from line to point layer.

    ../../../_images/edit_inplace_algorithms.png

    Processing algorithms: all (left) vs polygon in-place editors (right)

  4. Find the algorithm you'd like to run and double-click it.

    注釈

    If the algorithm does not need any additional user-set parameters (excluding the usual input and output layer parameters), then the algorithm is run immediately without any dialog popup.

    1. If parameters other than the usual input or output layers are needed, the algorithm dialog pops up. Fill in the required information.

    2. Click Modify Selected Features or Modify All Features depending on whether there's an active selection.

    Changes are applied to the layer and placed in the edit buffer: the layer is indeed toggled to editing mode with unsaved modification as indicated by the editableEdits icon next to the layer name.

  5. As usual, press saveEdits Save layer edits to commit the changes in the layer. You can also press undo Undo to rollback the whole modification.