11.1. 2D Map View

The 2D map view (also called Map canvas) is the central place where maps are displayed. QGIS opens by default with a single map view (called main map), showing layers in 2D, and tightly bound to the Layers panel. That window reflects the rendering (symbology, labeling, visibilities…) you applied to the loaded layers.

../../../_images/startup.png

Fig. 11.1 Interface de QGIS

11.1.1. Exploration de la vue cartographique

Lorsque vous ajoutez une couche (voir par exemple Ouvrir des données), QGIS recherche automatiquement son Système de Coordonnées de Référence (SCR). Si un SCR différent est définit par défaut pour le projet (voir Systèmes de Coordonnées de Référence d’un projet), la couche est reprojetée « à la volée » dans ce SCR et la vue cartographique zoome sur l’emprise de la couche s’il s’agit d’un projet vide. S’il y a déjà des couches dans le projet, il n’y a pas de recentrage de la vue, seules les entités comprises dans l’emprise courante de la vue seront visibles.

Click on the map view and you should be able to interact with it, panning or zooming to different areas of the map. Dedicated tools are provided in the Navigation Toolbar and in the View menu, with handful shortcuts from the keyboard or the mouse buttons.

Tableau 11.1 Map canvas navigation tools

Outil

Usage

pan Pan Map

  • Single left click: the map is centered on the clicked point, at the same scale

  • Hold down the left mouse button and drag the map canvas.

zoomIn Zoom In

  • Single left click: the map is centered on the clicked point, while the scale gets doubled

  • Drag a rectangle on the map canvas with the left mouse button to zoom in to an area.

  • Hold the Alt key to switch to the zoomOut Zoom Out tool.

zoomOut Zoom Out

  • Single left click: the map is centered on the clicked point, while the scale gets halved

  • Drag a rectangle on the map canvas with the left mouse button to zoom out from an area.

  • Hold the Alt key to switch to the zoomIn Zoom In tool.

panToSelected Pan Map to Selection

Pan the map to the selected features of all the selected layers in the Layers panel.

zoomToSelected Zoom To Selection

Zoom to the selected features of all the selected layers in the Layers panel.

Also available in the layer contextual menu

zoomToLayer Zoom To Layer(s)

Zoom to the extent of all the selected layers in the Layers panel.

Also available in the layer contextual menu

zoomFullExtent Zoom Full

Zoom to the extent of all the layers in the project or to the project full extent.

zoomLast Zoom Last

Zoomer la carte à l’emprise précédente dans l’historique.

zoomNext Zoom Next

Zoomer la carte à l’emprise suivante dans l’historique.

zoomActual Zoom to Native Resolution

Zoomer sur la carte à un niveau où un pixel de la couche raster active couvre un pixel d’écran.

Also available in the layer contextual menu

Mouse wheel

  • Pan map: Hold and drag the mouse wheel.

  • Zoom: Roll the mouse wheel to zoom in or zoom out. With Ctrl key pressed while rolling the mouse wheel results in a finer zoom.

  • Press the back or forward button to browse the map canvas zoom history.

Keyboard

  • Pan map: Hold down the Space key and move the mouse. Press the arrow keys to pan up, down, left and right.

  • Zoom in: Press PgUp or Ctrl++

  • Zoom out: Press PgDown or Ctrl+-

  • Zoom to area: When certain map tools are active (Identify, Measure…), hold down Shift and drag a rectangle on the map to zoom to that area. Not compatible with active selection or edit tools.

Faites un clic-droit sur la carte et vous pourrez editCopy Copier les coordonnées du point cliqué dans le SCR de la carte, en WGS84 ou dans le SCR de votre choix. L’information copiée peut être collée dans une expression, un script, un éditeur de texte ou un tableur…

11.1.2. Controlling map rendering

Par défaut, QGIS effectue le rendu de toutes les couches visibles à chaque fois que l’affichage de la carte est mis à jour. Les évènements qui déclenchent ce rafraîchissement incluent :

  • changing the visibility of a layer

  • modifying symbology of a visible layer

  • l’ajout de couche

  • le déplacement ou le zoom

  • le redimensionnement de la fenêtre de QGIS

QGIS vous laisse contrôler le processus de rendu de plusieurs manières.

To stop the map drawing, press the Esc key. This will halt the refresh of the map canvas and leave the map partially drawn. It may however take a bit of time after pressing Esc for the map drawing to halt.

To suspend rendering, click the checkbox Render checkbox in the bottom-right corner of the status bar. When checkbox Render is unchecked, QGIS does not redraw the canvas in response to any of the usual triggers mentioned earlier. Examples of when you might want to suspend rendering include:

  • Ajouter plusieurs couches et réaliser leur symbologie avant de les afficher

  • Ajouter une ou plusieurs couches et définir leur dépendance d’échelle avant de les afficher

  • Ajouter une ou plusieurs couches et zoomer à une vue spécifique avant de les afficher

  • N’importe quelle combinaison des éléments précédents

Cocher la case checkbox Rendu activera de nouveau le rendu et provoquera un rafraîchissement immédiat de la carte.

11.1.3. Time-based control on the map canvas

QGIS can handle temporal control on loaded layers, i.e. modify the map canvas rendering based on a time variation. To achieve this, you need:

  1. Layers that have dynamic temporal properties set. QGIS supports temporal control for different data providers, with custom settings. It’s mainly about setting the time range in which the layer would display:

    • raster layers: controls whether to display or not the layer.

    • WMTS layers: controls whether the data should be rendered based on a static time range or following a dynamic temporal range

    • vector layers: features are filtered based on time values associated to their attributes

    • mesh layers: displays dynamically the active dataset groups values

    When dynamic temporal options are enabled for a layer, an indicatorTemporal icon is displayed next to the layer in the Layers panel to remind you that the layer is temporally controlled. Click the icon to update the temporal settings.

  2. Enable the temporal navigation of the map canvas using the Temporal controller panel. The panel is activated:

    • using the temporal Temporal controller panel icon located in the Map Navigation toolbar

    • or from the View ► Panels ► Temporal controller panel menu

11.1.3.1. The temporal controller panel

The Temporal controller panel has the following modes:

../../../_images/temporal_controller_panel.png

Fig. 11.2 Temporal Controller Panel in navigation mode

  • temporalNavigationOff Turn off temporal navigation: all the temporal settings are disabled and visible layers are rendered as usual

  • temporalNavigationFixedRange Fixed range temporal navigation: a time range is set and only layers (or features) whose temporal range overlaps with this range are displayed on the map.

  • temporalNavigationAnimated Animated temporal navigation: a time range is set, split into steps, and only layers (or features) whose temporal range overlaps with each frame are displayed on the map

  • settings Settings for general control of the animation

    • Frames rate: number of steps that are shown per second

    • unchecked Cumulative range: all animation frames will have the same start date-time but different end dates and times. This is useful if you wish to accumulate data in your temporal visualization instead of showing a ‘moving time window’ across your data.

11.1.3.2. Animating a temporal navigation

An animation is based on a varying set of visible layers at particular times within a time range. To create a temporal animation:

  1. Toggle on the temporalNavigationAnimated Animated temporal navigation, displaying the animation player widget

  2. Enter the Time range to consider. Using the refresh button, this can be defined as:

    • Set to full range of all the time enabled layers

    • Set to preset project range as defined in the project properties

    • Set to single layer’s range taken from a time-enabled layer

  3. Fill in the time Step to split the time range. Different units are supported, from seconds to centuries. A source timestamps option is also available as step: when selected, this causes the temporal navigation to step between all available time ranges from layers in the project. It’s useful when a project contains layers with non-contiguous available times, such as a WMS-T service which provides images that are available at irregular dates. This option will allow you to only step between time ranges where the next available image is shown.

  4. Click the play button to preview the animation. QGIS will generate scenes using the layers rendering at the set times. Layers display depends on whether they overlap any individual time frame.

    ../../../_images/map_navigation.gif

    Fig. 11.3 Temporal navigation through a layer

    The animation can also be previewed by moving the time slider. Checking the unchecked Loop checkbox will repeatedly run the animation while clicking play stops a running animation. A full set of video player buttons is available.

    Horizontal scrolling using the mouse wheel (where supported) with the cursor on the map canvas will also allow you to navigate, or “scrub”, the temporal navigation slider backwards and forwards.

  5. Click the fileSave Export animation button if you want to generate a series of images representing the scene. They can be later combined in a video editor software:

    ../../../_images/saveTimeAnimation.png

    Fig. 11.4 Exporting map canvas animation scenes to images

    • The filename Template: the #### are replaced with frame sequence number

    • The Output directory

    • Under Map settings, you can:

      • redefine the spatial extent to use

      • control the Resolution of the image (Output width and Output height)

      • Draw active decorations: whether active decorations should be kept in the output

    • Under Temporal settings, you can redefine:

      • the time Range for the animation

      • the Step (frame length) in the unit of your choice

11.1.4. Bookmarking extents on the map

Les signets spatiaux vous permettent de créer un « marque-page » d’un emplacement géographique et permettent d’y retourner plus tard. Par défaut, les signets sont sauvegardés dans le profil de l’utilisateur (comme Signets utilisateurs), signifiant qu’ils sont disponibles pour chaque project que l’utilisateur ouvre. Ils peuvent également être enregistrés pour un seul projet (nommés Signets du projet) et sont enregistrés dans le fichier du projet, ce qui peut être utile si le projet doit être partagé avec d’autres utilisateurs.

11.1.4.1. Créer un signet

Pour créer un signet :

  1. Zoomer et se déplacer jusqu’à la zone d’intérêt.

  2. Sélectionner le menu Vue ► newBookmark Nouveau signet spatial…., appuyer sur Ctrl+B ou faire un clic droit sur la catégorie showBookmarks Signets spatiaux dans le panneau Explorateur et sélectionner Nouveau signet spatial. L”Éditeur de signets apparaît.

    ../../../_images/bookmark_editor.png

    Fig. 11.5 L’éditeur de signets

  3. Saisir un nom descriptif pour le signet

  4. Saisir ou sélectionner un nom de groupe dans lequel enregistrer les signets apparentés

  5. Select the extent of the area you wish to save, using the extent selector widget

  6. Indiquer le SCR à utiliser pour l’emprise.

  7. Select whether the bookmark will be Saved in User Bookmarks or Project Bookmarks (by default, this drop-down list is set to User Bookmarks)

  8. Appuyer sur Enregistrer pour ajouter le signet à la liste

Notez que vous pouvez avoir plusieurs signets portant le même nom.

11.1.4.2. Travailler avec les signets

Pour utiliser et gérer les signets, vous pouvez utiliser soit le panneau Gestionnaire de signets spatiaux ou l”Explorateur.

Sélectionner Vue ► showBookmarks Afficher le Gestionnaire de Signets Spatiaux ou appuyer sur Ctrl+7 pour ouvrir le panneau Gestionnaire de signets spatiaux. Sélectionner Vue ► showBookmarks Afficher les signets spatiaux ou Ctrl+Shift+B pour afficher la catégorie showBookmarks Signets spatiaux dans le panneau Explorateur.

Vous pouvez effectuer les tâches suivantes :

Tableau 11.2 Managing bookmark actions

Tâche

Gestionnaire de signets spatiaux

Explorateur

Zoomer jusqu’au signet

Double-cliquer dessus, ou sélectionner le signet et appuyer sur le bouton zoomToBookmark Zoomer jusqu’au signet.

Double-cliquer dessus, le glisser déposer sur le canevas, ou cliquer avec le bouton droit sur le signet et sélectionner Zoomer jusqu’au signet.

Effacer un signet

Sélectionner le signet et cliquer sur le bouton deleteSelected Effacer le signet. Confirmez votre choix.

Clic droit sur le signet et sélectionner Supprimer signet spatial. Confirmez votre choix.

Exporter des signets au format XML

Cliquer sur le bouton sharing Importer ou exporter des signets et sélectionner sharingExport Exporter. Tous les signets (utilisateurs ou projets) sont enregistrés dans un fichier XML.

Sélectionner un ou plusieurs dossiers (utilisateurs ou projet) ou sous-dossiers (groupes), puis faire un clic droit et sélectionner sharingExport Exporter les signets spatiaux…. Le sous-ensemble de signets sélectionné est enregistré.

Importer des signets depuis un fichier XML

Cliquer sur le bouton sharing Importer ou exporter des signets et sélectionner sharingImport Importer. Tous les signets du fichier XML sont importés en tant que signets utilisateur.

Clic-droit sur la catégorie Signets spatiaux ou un de ses dossiers (utilisateurs ou projet) ou sous-dossiers (groupes) pour déterminer où importer les signets, puis sélectionner sharingImport Importer des signets spatiaux. Si l’import est effectué sur la catégorie Signets spatiaux, les signets sont ajoutés aux Signets utilisateurs.

Éditer un signet

Vous pouvez modifier un signet en modifiant les valeurs dans le tableau. Vous pouvez éditer le nom, le groupe, l’emprise et s’il est ou non enregistré dans le projet.

Clic droit sur le signet voulu et sélectionner Modifier le signet spatial……. L”Éditeur de signets s’ouvrira, vous permettant de redéfinir chaque aspect du signet comme si vous le créez pour la première fois.

Vous pouvez aussi glisser déposer le signet entre les dossiers (utilisateurs et projets) et sous-dossiers (groupes).

Vous pouvez aussi zoomer sur des signets en tapant le nom du signet dans le Localisateur.

11.1.5. Decorating the map

Décorations comprends Grille, Étiquette de titre, Étiquette de Copyright, Flèche Nord, Échelle Graphique et étendue de mise en page. Elles sont utilisées pour “décorer” la carte en ajoutant des éléments cartographiques.

11.1.5.1. Grille

addGrid Grille vous permet d’ajouter un graticule et des coordonnées à la carte.

  1. Sélectionnez Vue ► Décorations ► Grille… pour ouvrir la fenêtre.

    ../../../_images/grid_dialog.png

    Fig. 11.6 La fenêtre Grille

  2. Cocher checkbox Activer la grille et réglez les paramètres de la grille en fonction des couches chargées dans le canevas :

    • Le Type de grille: il peut être Ligne ou Symbole

    • Le Symbole de ligne ou le Symbole de marqueur sont utilisés pour représenter les marqueurs de la grille.

    • L”Intervalle X et l”Intervalle Y entre les marqueurs de la grille, en unités cartographiques

    • Une distance de Décalage X et de Décalage Y des marqueurs de grille à partir du coin en bas à gauche du canevas, en unités cartographiques

    • Les paramètres d’intervalle et de décalage peuvent être mis à jour depuis :

      • Emprise du canevas: génère une grille avec un intervalle d’approximativement 1/5 de la largeur du canevas

      • Résolution de la Couche raster active

  3. Cocher checkbox Afficher les annotations pour afficher les coordonnées de la grille et définir :

    • La Direction, c’est à dire comment les étiquettes seraient placées par rapport à leur ligne de grille. Elle peut être :

      • Horizontal ou Vertical pour toutes les étiquettes

      • Horizontal et Vertical, c’est à dire que chaque étiquette est parallèle au marqueur de grille auquel il fait référence

      • Suivant le contour, c’est à dire que chaque étiquette suit le contour du canevas, et est perpendiculaire au marqueur de grille auquel il fait référence

    • La police d’annotation (mise en forme du texte, tampon, ombre…) en utilisant le selector widget.

    • La Distance au cadre de la carte, marge entre les annotations et les limites du canevas de la carte. Pratique pour exporting the map canvas, par exemple vers un format d’image ou un PDF, et éviter que les annotations soient sur les limites du « papier ».

    • La Précision des coordonnées

  4. Cliquez sur Appliquer pour vérifier si le rendu souhaité est obtenu ou OK si vous êtes satisfait.

11.1.5.2. Étiquette de Titre

titleLabel Etiquette de titre vous permet de décorer votre carte avec un titre.

Pour ajouter une décoration d’étiquette de titre:

  1. Sélectionner Vue ► Décorations ► Étiquette de titre… pour ouvrir la fenêtre.

    ../../../_images/titleLabel.png

    Fig. 11.7 La fenêtre de Titre

  2. Assurez-vous que checkbox Activer l’étiquette de titre est cochée

  3. Saisissez le texte du titre que vous souhaitez placer sur la carte. Vous pouvez le rendre dynamique en utilisant le bouton Insérer ou modifier une expression….

  4. Choisissez la police pour l’étiquette via l”outil de sélection de police qui donne accès à toutes les options de formatage de texte de QGIS. Réglez la couleur de la police de caractère et son opacité en cliquant sur la flèche noir à droite de la liste des polices.

  5. Sélectionnez une couleur pour l’appliquer à l”arrière plan du titre.

  6. Choisissez la Position de l’étiquette sur le canevas : les possibilités sont Coin supérieur gauche, Au milieu en haut (par défaut), Coin supérieur droit, Coin inférieur gauche, Au milieu en bas et Coin inférieur droit.

  7. Affinez le placement de l’élément en définissant une valeur horizontale et/ou verticale Marge du bord. Ces valeurs peuvent être en Milimètres ou Pixels ou définis en Pourcentage de la largeur ou hauteur du canevas de la carte.

  8. Cliquez sur Appliquer pour vérifier si le rendu souhaité est obtenu ou OK si vous êtes satisfait.

11.1.5.4. Décoration d’image

addImage Image vous permet d’ajouter une image (logo, légende, ..) sur le canevas de la carte.

Pour ajouter une image:

  1. Sélectionnez l’option de menu Vue ► Décorations ► Image… pour ouvrir la boîte de dialogue.

    ../../../_images/image_decoration.png

    Fig. 11.9 La boîte de dialogue de décoration d’image

  2. Assurez-vous que checkbox activer l’image est coché

  3. Sélectionnez une image bitmap (par exemple png ou jpg) ou SVG à l’aide du bouton Navigateur

  4. Si vous avez choisi un paramètre SVG activé, vous pouvez également définir une couleur remplissage ou contour (contour). Pour les images bitmap, les paramètres de couleur sont désactivés.

  5. Définissez Taille de l’image en mm. La largeur de l’image sélectionnée est utilisée pour la redimensionner à la taille saisit.

  6. Choisissez l’endroit où vous souhaitez placer l’image sur le canevas de carte avec la zone de liste déroulante Placement. La position par défaut est En haut à gauche.

  7. Définissez Horizontal et Marge verticale à partir du bord (du canevas ). Ces valeurs peuvent être définies en Millimètres, Pixels ou en Pourcentage de la largeur ou de la hauteur du canevas de carte.

  8. Cliquez sur Appliquer pour vérifier si le rendu souhaité est obtenu ou OK si vous êtes satisfait.

11.1.5.5. Flèche du nord

northArrow Flèche nord vous permet d’ajouter une flèche nord sur le canevas de la carte.

Pour ajouter une flèche nord:

  1. Sélectionnez Vue ► Décorations ► Flèche Nord… pour ouvrir la fenêtre.

    ../../../_images/north_arrow_dialog.png

    Fig. 11.10 La fenêtre de flèche du nord

  2. Assurez-vous que checkbox Activer la Flèche Nord est coché

  3. Modifiez éventuellement la couleur et la taille, ou choisissez un SVG personnalisé

  4. Modifiez éventuellement l’angle ou choisissez Automatique pour laisser QGIS déterminer la direction.

  5. Modifiez éventuellement le placement depuis la combox box Position

  6. Vous pouvez affiner le placement de l’élément en définissant une marge horizontale et/ou verticale à partir du bord (du Canevas). Ces valeurs peuvent être en Millimètre ou en Pixels ou un Pourcentage de la largeur ou de la hauteur du canevas de carte.

  7. Cliquez sur Appliquer pour vérifier si le rendu souhaité est obtenu ou OK si vous êtes satisfait.

11.1.5.6. Échelle graphique

scaleBar Échelle graphique ajoute une simple barre d’échelle sur la carte. Vous choisissez le style, l’emplacement ainsi que les étiquettes de la barre.

QGIS permet uniquement d’afficher l’échelle dans la même unité que celle de la carte. Donc, si l’unité du SCR du projet est le mètre, vous ne pouvez créer une échelle en pieds. De la même manière, si vous utilisez les degrés décimaux, vous ne pouvez afficher une échelle en mètres.

Pour ajouter une échelle graphique :

  1. Sélectionnez Vue ► Decorations ► Échelle graphique… pour ouvrir la fenêtre.

    ../../../_images/scale_bar_dialog.png

    Fig. 11.11 La fenêtre de barre d’échelle

  2. Assurez-vous que la case checkbox Activer l’échelle graphique est cochée

  3. Choisissez le style dans la liste déroulante Style de la barre d’échelle selectString.

  4. Sélectionnez une couleur de remplissage Couleur de la barre selectColor (par défaut: noir) et une couleur de contour (par défaut: blanc). Le remplissage et le contour de la barre d’échelle peuvent être rendus opaques en cliquant sur la flèche à droite de l’entrée de couleur

  5. Choisissez la police pour la barre d’échelle depuis le menu Police de la barre selectString

  6. Définissez la Taille de la barre selectNumber.

  7. Éventuellement cochez checkbox Arrondir automatiquement lors du changement de zoom pour afficher des valeurs faciles à lire

  8. Choisissez l’emplacement dans la liste déroulante Position selectString.

  9. Vous pouvez affiner le placement de l’élément en définissant une marge horizontale et/ou verticale à partir du bord (du Canevas). Ces valeurs peuvent être en Millimètre ou en Pixels ou un Pourcentage de la largeur ou de la hauteur du canevas de carte.

  10. Cliquez sur Appliquer pour vérifier si le rendu souhaité est obtenu ou OK si vous êtes satisfait.

11.1.5.7. Étendue de mise en page

addMap Étendue de mise en page ajoute l’étendue des éléments de carte de la mise en page dans le canevas de la carte. Lorsque cette option est activée, les étendues de tous les objets carte de toutes les mises en page sont affichées à l’aide d’une bordure légèrement en pointillés et étiquetées avec le nom de la mise en page. Cette décoration est utile lorsque vous ajustez le positionnement des objets carte comme des étiquettes et que vous avez besoin de connaître la véritable zone visible sur les mises en page.

../../../_images/decoration_layoutextents_example.png

Fig. 11.12 Exemple d’étendue de mise en page affichée dans un projet QGIS avec deux mises en page d’impression. La mise en page d’impression nommée « Sights » contient deux éléments de carte, tandis que l’autre mise en page contient un élément de carte.

Pour ajouter une étendue de mise en page

  1. Sélectionnez Vue ► Decorations ► Étendu de mise en page pour ouvrir la boîte de dialogue.

    ../../../_images/decoration_layoutextents.png

    Fig. 11.13 La boîte de dialogue Étendu de mise en page

  2. Assurez-vous que checkbox Montrez l’étendue de la mise en page est coché.

  3. Éventuellement changez le symbole et l’étendue de l’étiquette.

  4. Cliquez sur Appliquer pour vérifier si le rendu souhaité est obtenu ou OK si vous êtes satisfait.

Astuce

Paramètres de Décoration

Lorsque vous sauvegardez un projet QGIS, toute modification faites sur la grille, la flèche nord, l’échelle graphique, etiquette de copyright et l’étendue de mise en page sera sauvegardée dans le projet et restaurée la prochaine fois qu’il sera chargé.

11.1.6. Outils d’annotation

Annotations are another type of elements added onto the map canvas to provide additional information that can not be depicted by the rendered layers. Unlike labels that rely on attribute values stored in vector layers, annotations are independent details, stored within the project file itself.

Two families of annotations are available in QGIS:

  • Feature annotations: they are actual georeferenced features of text, marker, line or polygon type stored within a special layer type called « annotation layer ». They are tied to a particular geographic location, meaning that moving your map, changing the scale or changing projection won’t cause your annotations to jump around the map. Rather, they’ll be locked in place to the location you’ve drawn them.

  • Balloon annotations: these are individuals annotations of text, form or image type placed inside a bubble. They can be associated to any layer for their visibility, are drawn on top of the map canvas. The size is dependent from the map canvas scale, and its position can be anchored.

Astuce

Mettre en page une carte avec des annotations

Vous pouvez imprimer ou exporter des annotations avec votre carte dans divers formats via :

  • les outils d’export du canevas de la carte disponibles dans le menu Projet

  • les mises en pages, dans ce cas, vous devez cocher Dessiner les objets du canevas de la carte dans les propriétés de l’élément carte correspondant.

The Annotations Toolbar provides a set of tools to create and interact with both families of annotations.

Tableau 11.3 The Annotations Toolbar actions

Outil

Usage

Scope

createAnnotationLayer New Annotation Layer

Create a new layer to store annotations

Feature annotations

Main Annotation Layer Properties

Control settings of the Main Annotation Layer

select Modify Annotations

Select, move, resize and modify symbology properties of annotations

addPolygon Create Polygon Annotation

Create an annotation as a polygon feature

addPolyline Create Line Annotation

Create an annotation as a polyline feature

addMarker Create Marker Annotation

Create an annotation as a point feature

actionText Create Text Annotation at Point

Create an annotation as a text label

textAnnotation Text Annotation

Select and create a text formatted annotation

Balloon annotations

htmlAnnotation HTML Annotation

Select and create annotation with an HTML file’s content

svgAnnotation SVG Annotation

Select and create annotation showing an SVG file

formAnnotation Form Annotation

Select and create annotation showing attributes of a vector layer in a custom form file

annotation Move Annotation

Adjust size and position of annotation element

11.1.6.1. Feature Annotations

Feature annotations are stored in annotation layers. Unlike conventional layers, an annotation layer is available only in the current project and can contain features of different types (text, marker, line, polygon). The layer has no attributes and no symbology associated, but instead each feature can be symbolized on an item-by-item basis, through Layer Styling panel.

Two types of annotation layer are available in QGIS:

  • A common Annotation Layer: you can create one using the createAnnotationLayer New Annotation Layer tool. It is listed in the Layers panel, allowing you to control its features” visibility, move it to show above or below particular layers in your map, like any common layer. Double-click the layer and you can access its properties.

  • The Main Annotation Layer: By default, this is where annotations are stored when no annotation layer is available in the project or is selected at creation time. This layer is always drawn on the very top of your map and you won’t see it listed in the Layers panel alongside the other layers in your project, meaning that its features are always visible. The Main Annotation Layer Properties entry on the Annotations toolbar helps you open its properties dialog.

Interaction

The Feature annotations have dedicated tools for creation depending on their type:

  • addPolygon Create Polygon Annotation

  • addPolyline Create Line Annotation

  • addMarker Create Marker Annotation

  • actionText Create Text Annotation at Point

All the usual QGIS shortcuts for creating features apply when creating annotation items. A line or polygon annotation is drawn by left-clicking once for each vertex, with a final right mouse click to complete the shape. Snapping can be enabled while you draw, you can use the Advanced Digitizing Tools to precisely place vertices, and even switch the drawing tools to the streaming mode for completely free-form shapes.

Unlike common layers, an annotation layer does not need to be active before you select its features. Simply grab the select Modify Annotations tool and you will be able to interact with any feature annotation:

  • Selection: simply left-click on the annotation

  • Moving: Left click on a selected annotation item to start moving it. A right-click or pressing Esc key cancels the move, while a second left click will confirm the move. The displacement can also be controlled pressing the cursor keys:

    • Shift+key for big movement

    • Alt+key for 1 px movement

  • Geometry modification: for line or polygon annotations, left-click on a vertex of the geometry, move and click again. Double-click a segment to add a new vertex.

  • Delete: Pressing the Del or Backspace key while an annotation is selected will delete that annotation

  • Change feature symbology

Feature symbology

A selected annotation will display its Symbology properties in the Layer styling panel. You can:

  • modify the appearance using full capabilities of the symbol or the text format (including the text itself), depending on the type.

  • configure a Reference scale

  • set a Z index

  • modify some of the Layer rendering settings

Propriétés des couches

The properties dialog of an annotation layer provides the following tabs:

  • Information: a read-only dialog representing an interesting place to quickly grab summarized information and metadata on the current layer.

  • Source: defines general settings for the annotation layer. You can:

  • Rendering:

    • Vous pouvez définir une échelle Maximum (inclusive) et Minimum (exclusive), correspondant à une plage d’échelles pour lesquelles les entités sont visibles. En dehors de cette plage, elles sont cachées. Le bouton mapIdentification Mettre à l’échelle actuelle du canevas permet d’utiliser l’échelle actuelle pour l’une ou l’autre des limites de la plage de visibilité. Voir Visibility Scale Selector pour plus d’informations.

    • Opacity: You can make the underlying layer in the map canvas visible with this tool. Use the slider to adapt the visibility of your vector layer to your needs. You can also make a precise definition of the percentage of visibility in the menu beside the slider.

    • Blending mode at the Layer level: You can achieve special rendering effects with these tools that you may previously only know from graphics programs. The pixels of your overlaying and underlying layers are mixed through the settings described in Modes de fusion.

    • Appliquer les effets sur les entités de la couche avec le bouton Effets.

    Some of these options are accessible from the feature annotation Symbology properties.

11.1.6.2. Balloon annotations

You can add balloon annotations through Edit ► Add Annotation ► menu or from the Annotations Toolbar:

  • textAnnotation Annotation de texte pour du texte au format personnalisé

  • htmlAnnotation Annotation HTML pour placer le contenu d’un fichier html

  • svgAnnotation Annotation SVG pour ajouter un symbole SVG

  • formAnnotation Formulaire d’annotation : utile pour afficher les attributs d’une couche vecteur via un fichier ui personnalisé (voir Fig. 11.14). Ceci est similaire au formulaire d’attributs personnalisé mais affiché dans une annotation. Voir aussi la vidéo de Tim Sutton pour plus d’informations : https://www.youtube.com/watch?v=0pDBuSbQ02o&feature=youtu.be&t=2m25s

  • annotation Move Annotation to adjust annotation element size or position (using click and drag)

../../../_images/custom_annotation.png

Fig. 11.14 Examples of balloon annotations

To add a balloon annotation, select the corresponding tool and click on the map canvas. An empty balloon is added. Double-click on it and a dialog opens with various options. This dialog is almost the same for all the annotation types:

  • Selon le type d’annotation, en haut de la fenêtre, un sélecteur demande le chemin vers un fichier de type html, svg ou ui. Pour une annotation de texte, vous pouvez entrer votre message dans la zone de texte et définir son rendu avec les outils classiques de police.

  • checkbox Figer la position sur la carte : lorsqu’elle est décochée, la position de la bulle se base sur une position à l’écran (au lieu de la carte), c’est-à-dire qu’elle sera toujours visible, quelle que soit l’emprise de la carte.

  • Couche liée : permet d’associer l’annotation à une couche et qui ne sera visible que lorsque la couche est visible.

  • Symbole de carte : utilise les symboles QGIS, définit le symbole à utiliser pour afficher l’ancrage de la bulle (affiché uniquement si la case Figer la position sur la carte est cochée).

  • Style de cadre : définit la couleur du fond, la transparence, la couleur et l’épaisseur du contour de la bulle en utilisant les symboles QGIS.

  • Marges du contenu : définit les marges intérieures entre le cadre et le contenu de l’annotation.

../../../_images/annotation.png

Fig. 11.15 A ballon annotation text dialog

Les annotations peuvent être sélectionnées lorsque l’outil d’annotation est activé. Elles peuvent être déplacées sur la carte (en faisant glisser le symbole sur la carte) ou en déplaçant uniquement la bulle. L’outil annotation Déplacer une annotation vous permet également de déplacer la bulle sur le canevas de la carte.

Pour supprimer une annotation, sélectionnez la et appuyez soit sur la touche Suppr soit sur Retour arrière, ou double-cliquez dessus et cliquez sur le bouton Supprimer dans la fenêtre des propriétés.

Note

If you press Ctrl+T while a balloon Annotation tool (move annotation, text annotation, form annotation) is active, the visibility states of the items are inverted.

11.1.7. Mesurer

11.1.7.1. Information générale

QGIS propose quatre moyens de mesurer des géométries :

  • les outils de mesure interactifs measure

  • les mesures via la calculateField Calculatrice de champ

  • les mesures dérivées de l’outil Identifier les entités

  • les outils d’analyse sur les couches vecteur : Vecteur ► Outils de géométrie ► Ajouter les attributs de géométrie

Les mesures fonctionnent pour les systèmes de coordonnées projetés (par ex. UTM) et non projetés. Les trois premiers outils de mesure utilisent les mêmes options globales au projet :

  • Contrairement à la plupart des logiciels SIG, les mesures se basent par défaut sur l’ellipsoïde définie dans Projet ► Propriétés… ► Général. Cela s’applique dans tous les cas, que le système de coordonnées du projet soit de type géographique ou projeté.

  • Si vous voulez calculer une superficie projetée/planimétrique ou une distance en utilisant les mathématiques cartésiennes, l’ellipsoïde de mesure doit être paramétré à « Aucun / Planimétrique » (Projet ► Propriétés… ► Général). Cependant, si un SCR géographique (c’est-à-dire non projeté) est défini pour le projet et les données, les mesures de distance et d’aire se feront sur l’ellipsoïde.

Cependant, ni l’outil d’identification ni le calculateur de champ n’effectue une transformation dans le SCR du projet avant la mesure. Si vous voulez atteindre cet objectif, vous devez utiliser l’outil d’analyse vecteur: Vecteur ► Outils de géométrie ► Ajouter les attributs de géométrie…. Dans ce cas, la mesure est planimétrique sauf si vous choisissez la mesure ellipsoïdale.

11.1.7.2. Measure length, areas, bearings and angles interactively

Click the measure icon in the Attribute toolbar to begin measurements. The down arrow near the icon switches between measure length, measureArea area, measureBearing bearing or measureAngle angle. The default unit used in the dialog is the one set in Project ► Properties… ► General menu.

For the Measure Line and the Measure Area the measurements can be done in radioButtonOn Cartesian or radioButtonOn Ellipsoidal measure.

Note

Configurer l’outil de mesure

En mesurant des longueurs et des aires, cliquer sur le bouton Configuration en bas de la fenêtre ouvre l’onglet Préférences ► Options ► Outils cartographiques où vous pouvez paramétrer la couleur du trait de mesure, la précision des mesures et le comportement des unités. Vous pouvez également choisir les unités préférentielles pour les mesures et les angles. Mais gardez à l’esprit que ces paramètres sont écrasés par ceux définis dans le menu Projet ► Propriétés… ► Général pour le projet en cours et les choix effectués dans la fenêtre de mesure.

Tous les outils de mesure utilisent les options d’accrochage des outils de numérisation (voir Configuration de la tolérance de l’accrochage et du rayon de recherche). Donc si vous voulez mesurer avec exactitude une ligne ou le contour d’un polygone, spécifiez d’abord la tolérance d’accrochage de la couche. Ensuite, avec l’outil de mesure, chaque clic de souris se situant sous ce seuil s’accrochera à cette couche.

The measure Measure Line measures distances between given points. The tool then allows you to click points on the map. Each segment length, as well as the total, shows up in the measure window. To stop measuring, click the right mouse button. Now it is possible to copy all your line measurements at once to the clipboard using the Copy All button.

Notez que vous pouvez utiliser la liste déroulante située à côté du total pour changer les unités de mesure interactivement tout en utilisant l’outil de mesure (“Mètres”, “Kilomètres”, “Pieds”, “Yards”, “Miles”, “Milles nautiques”, “Centimètres”, “Millimètres”, “Degrés”, “Unités de la carte”). Cette unité sera gardée en mémoire jusqu’à la création ou l’ouverture d’un projet.

La partie Info de la fenêtre explique comment les calculs sont effectués, en fonction des paramètres de SCR choisis.

../../../_images/measure_line.png

Fig. 11.16 Mesure de distance

measureArea Mesurer une aire : des aires peuvent également être mesurées. Dans la fenêtre de mesure, l’aire cumulée s’affiche. Faites un clic-droit pour arrêter la mesure. La partie Info est également disponible ainsi que la possibilité de changer d’unité (“Mètres carrés”, “Kilomètres carrés”, “Pieds carrés”, “Yards carrés”, “Miles carrés”, “Hectares”, “Acres”, “Centimètres carrés”, “Millimètres carrés”, “Milles nautiques carrés”, “Degrés carrés” ou “Unités de carte” ).

../../../_images/measure_area.png

Fig. 11.17 Mesure d’une aire

measureBearing Measure Bearing: You can also measure bearings. The cursor becomes cross-shaped. Click to draw the first point of the bearing, then move the cursor to draw the second point. The measurement is displayed in a pop-up dialog.

../../../_images/measure_bearing.png

Fig. 11.18 Measure Bearing

measureAngle Mesurer un angle : Vous pouvez également mesurer des angles. Le curseur de la souris prend l’aspect d’une croix. Cliquez pour dessiner le premier segment puis déplacez le curseur pour dessiner l’angle désiré. La mesure s’affiche dans une fenêtre qui s’ouvre.

../../../_images/measure_angle.png

Fig. 11.19 Mesure d’un angle

11.1.8. Définition de vues de carte supplémentaires

It is also possible to open additional map views whose content could diverge from the Layers panel current state. To add a new map view, go to View ► newMap New Map View. A new floating widget, mimicking the main map view’s rendering, is added to QGIS. You can add as many map views as you need. They can be kept floating, placed side by side or stacked on top of each other.

../../../_images/map_views.png

Fig. 11.20 Plusieurs vues de carte avec différents paramètres

En haut de toute vue cartographique supplémentaire, une barre d’outils offre les possibilités suivantes :

  • zoomFullExtent Zoom Full, zoomToSelected Zoom to Selection and zoomToLayer Zoom to Layer(s) to navigate within the view

  • showPresets Définir le thème pour sélectionner le thème de carte à afficher dans la vue de la carte. Si elle est définie sur (aucun), la vue suivra les modifications du panneau Couches.

  • options Paramètres de la vue pour configurer la vue de la carte:

    • radioButtonOn Synchroniser le centre de la vue avec la carte principale: synchronise le centre des vues de la carte sans changer l’échelle. Cela vous permet d’avoir un style de vue d’ensemble ou une carte agrandie qui suit le centre du canevas principal.

    • radioButtonOff Synchroniser la vue avec la sélection: identique au zoom avec la sélection

    • Échelle

    • Rotation

    • Grossissement

    • unchecked Synchroniser l’échelle avec l’échelle de la carte principale. Un facteur echelle peut ensuite être appliqué, vous permettant d’avoir une vue qui est par exemple toujours 2x l’échelle du canevas principal.

    • checkbox Afficher les annotations

    • checkbox Afficher la position du curseur

    • unchecked Afficher l’étendue du canevas principal

    • checkbox Afficher les étiquettes: autorise à masquer les étiquettes telles qu’elles sont définies dans les propriétés des couches affichées

    • Changer le CRS carte …

    • Renommer la vue…

11.1.9. Exporter la vue cartographique

Les cartes que vous réalisez peuvent être mises en page et exportées dans divers formats via les capacites avancées de la mise en page ou des rapports. Il est également possible d’exporter directement la carte en cours, sans mise en page. Cette « capture d’écran » rapide de la vue cartographique propose quelques fonctionnalités intéressantes.

Pour exporter le canevas de la carte tel quel :

  1. Allez dans Projet ► Importer/Exporter

  2. Selon le format de sortie, sélectionnez

    • saveMapAsImage Exporter la carte au format image…

    • ou saveAsPDF Exporter la carte au format PDF…

Les deux outils proposent les mêmes options. Dans la fenêtre qui s’ouvre :

../../../_images/saveMapAsImage.png

Fig. 11.21 La fenêtre d’export de la carte au format image

  1. Choisissez l” Emprise à exporter : elle peut correspondre à l’emprise actuelle de la vue (par défaut), à l’emprise d’une couche ou à une emprise personnalisée via un rectangle dessiné sur le canevas de la carte. Les coordonnées de la zone sélectionnée sont affichées et éditables.

  2. Entrez l” Échelle de la carte ou sélectionnez la depuis les échelles prédéfinies : changer l’échelle redimensionnera l’emprise à exporter (depuis le centre).

  3. Choisissez une Résolution pour l’export

  4. Contrôlez la Largeur de l’image en sortie et la Hauteur de l’image en sortie en pixels : basées par défaut sur la résolution et l’emprise, elles peuvent être modifiées ce qui changera l’emprise de la carte (depuis le centre). Le ratio de taille peut être verrouillé ce qui peut être particulièrement utile lorsque l’on dessine une emprise sur le canevas de la carte.

  5. checkbox Afficher les décorations actives : les décorations utilisées (barre d’échelle, titre, carroyage, flèche du Nord…) sont exportées avec la carte.

  6. checkbox Afficher les annotations pour exporter toutes les annotations.

  7. checkbox Ajouter les informations de géoréférencement (encapsulées ou via un fichier world) : selon le format de sortie, un fichier world portant le même nom (avec l’extension PNGW pour PNG, JPGW pour JPG…) est sauvegardé dans le même répertoire que l’image. Le format PDF encapsule l’information dans le fichier PDF.

  8. Lorsque vous exportez en PDF, d’autres options sont proposées dans la fenêtre Enregistrer la carte en PDF :

    ../../../_images/saveMapAsPDF.png

    Fig. 11.22 La fenêtre d’export de la carte au format PDF

    • checkbox Exporter les métadonnées RDF du document telles que le titre, l’auteur, la date, la description…

    • unchecked Create Geospatial PDF (GeoPDF): Generate a georeferenced PDF file. You can:

      • Choisir le Format du GeoPDF

      • checkbox Inclure les informations des entités vecteur dans le fichier GeoPDF : inclura toutes les informations de géométrie et des attributs des entités visibles dans la carte exportée dans le fichier GeoPDF.

      Note

      A GeoPDF file can also be used as a data source. For more on GeoPDF support in QGIS, see https://north-road.com/2019/09/03/qgis-3-10-loves-geopdf/.

    • Transformer la carte en raster

    • checkbox Simplify geometries to reduce output file size: Geometries will be simplified while exporting the map by removing vertices that are not discernibly different at the export resolution (e.g. if the export resolution is 300 dpi, vertices that are less than 1/600 inch apart will be removed). This can reduce the size and complexity of the export file (very large files can fail to load in other applications).

    • Définir l”Export de texte : contrôle si les textes sont exportés en tant que textes (Toujours exporter le texte sous forme d’objets texte) ou en tant que chemins uniquement (Toujours exporter le texte comme des chemins). S’ils sont exportés comme des objets texte, ils seront éditables comme des textes par des applications externes (par ex. Inkscape). MAIS la qualité du rendu est diminuée ET il peut y avoir des problèmes avec certains rendus comme les tampons autour des textes. C’est pour cela que l’export en chemins est recommandé.

  9. Cliquez sur Enregistrer pour choisir l’emplacement, le nom et le format du fichier.

    Quand vous exportez en image, il est également possible de Copier vers le presse-papiers le résultat des paramétrages précédents et de coller la carte dans une autre application telle que LibreOffice, GIMP…