15.1. Ouvrir des données

Comme faisant partie d’un écosystème de logiciel Open Source, QGIS est construit à partir de différentes bibliothèques qui, combinées avec ses propres fournisseurs, offre la possibilité de lire et souvent d’écrire dans de nombreux formats :

  • Les formats de données vecteur incluent GeoPackage, GML, GeoJSON, GPX, KML, Valeurs séparées par des virgules, les formats ESRI (Shapefile, Geodatabase …), les formats de fichier MapInfo et MicroStation, AutoCAD DWG / DXF, GRASS et bien d’autres encore … Lire la liste des formats vecteur pris en charge.

  • Les formats de données raster incluent GeoTIFF, JPEG, ASCII Gridded XYZ, MBTiles, R ou Idrisi rasters, GDAL Virtual, SRTM, Sentinel Data, ERDAS IMAGINE, ArcInfo Binary Grid, ArcInfo ASCII Grid, et bien d’autres … Lisez la liste complète des formats raster pris en charge.

  • Database formats include PostgreSQL/PostGIS, SQLite/SpatiaLite, Oracle, MS SQL Server, SAP HANA, MySQL…

  • Les services de cartes et de données Web (WM (T) S, WFS, WCS, CSW, tuiles XYZ, services ArcGIS, …) sont également gérés par les fournisseurs QGIS. Voir Travailler avec les protocoles OGC / ISO pour plus d’informations sur certains d’entre eux.

  • Vous pouvez lire les fichiers pris en charge à partir de dossiers archivés et utiliser des formats natifs QGIS tels que des fichiers QML (QML - Le format de fichier de style QGIS), des couches virtuelles et de mémoire.

Plus de 80 formats vecteur et 140 raster sont pris en charge par les fournisseurs natifs GDAL et QGIS.

Note

Tous les formats répertoriés peuvent ne pas fonctionner dans QGIS pour diverses raisons. Par exemple, certains nécessitent des bibliothèques propriétaires externes, ou l’installation GDAL / OGR de votre système d’exploitation peut ne pas avoir été conçue pour prendre en charge le format que vous souhaitez utiliser. Pour voir la liste des formats disponibles, exécutez la ligne de commande ogrinfo --formats (pour les données vecteur) et gdalinfo --formats (pour les données raster), ou vérifiez Préférences ► Options ► GDAL dans QGIS.

Dans QGIS, selon le format de données, il existe différents outils pour ouvrir un jeu de données, principalement disponibles dans le menu Couche ► Ajouter une couche ► ou à partir de la barre d’outils Gestionnaire de couches (activé via Vue ► Barres d’outils). Cependant, tous ces outils pointent vers une boîte de dialogue unique, la boîte de dialogue Gestionnaire de source de données, que vous pouvez ouvrir avec le bouton dataSourceManager Ouvrir le gestionnaire de source données, disponible depuis la barre d’outils Gestionnaire de source de données (Fig. 15.1), ou en appuyant sur Ctrl+L. La boîte de dialogue Gestionnaire de source de données offre une interface unifiée pour ouvrir des données fichier, ainsi que des bases de données ou des services Web pris en charge par QGIS.

../../../_images/datasource_manager.png

Fig. 15.1 Gestionnaire de sources de données QGIS

A côté de ce point d’entrée principal, vous avez également le plugin dbManager DB Manager qui offre des capacités avancées pour analyser et manipuler les bases de données connectées. Plus d’informations sur les capacités de DB Manager peuvent être trouvées dans Extension DB Manager.

Il existe de nombreux autres outils, plugins natifs ou tiers, qui vous aident à ouvrir différents formats de données.

Ce chapitre décrira uniquement les outils fournis par défaut dans QGIS pour le chargement des données. Il se concentrera principalement sur la boîte de dialogue Gestionnaire de source de données mais plus que la description de chaque onglet, il explorera également les outils en fonction du fournisseur de données ou des spécificités de format.

15.1.1. Le panneau Explorateur

L”Explorateur est l’un des principaux moyens d’ajouter rapidement et facilement vos données à des projets. Il est disponible en tant que:

  • Un onglet Gestionnaire de sources de données, activé en appuyant sur le bouton dataSourceManager Ouvrir gestionnaire de sources de données ( Ctrl + L) ;

  • en tant que panneau QGIS, vous pouvez l’ouvrir à partir du menu Vue ► Panneaux (ou kde Préférences ► Panneaux) ou en appuyant sur Ctrl + 2.

Dans les deux cas, l”Explorateur vous aide à naviguer dans votre système de fichiers et à gérer les données géographiques, quel que soit le type de couche (raster, vecteur, table) ou le format de la source de données (fichiers simples ou compressés, bases de données, services Web) .

15.1.1.1. Explorer l’interface

En haut du panneau Explorateur, vous trouverez des boutons qui vous aident à :

  • addLayer Ajouter les couches sélectionnées: vous pouvez également ajouter des données au canevas de carte en sélectionnant Ajouter la ou les couches sélectionnées dans le menu contextuel de la couche;

  • refresh Rafraîchir le navigateur ;

  • filterMap Filtrer l’explorateur pour rechercher des données spécifiques. Entrez un mot de recherche ou un caractère générique et l’explorateur filtrera l’arborescence pour n’afficher que les chemins d’accès aux tables, noms de fichiers ou tables de bases de données correspondants - les autres données ou dossiers ne seront pas affichés. Voir l’exemple du Panneau Explorateur (2) dans Fig. 15.2. La comparaison peut être sensible à la casse ou non. Elle peut également être définie sur :

    • Normal: affiche les éléments contenant le texte de recherche

    • Wildcard (s): affinez la recherche en utilisant les caractères ? et / ou * pour spécifier la position du texte de recherche

    • Expression régulière

  • collapseTree Réduire tout;

  • metadata Activer / désactiver le widget des propriétés: lorsqu’il est activé, un nouveau widget est ajouté en bas du panneau affichant, le cas échéant, les métadonnées de l’élément sélectionné.

Les entrées dans le panneau Navigateur sont organisées hiérarchiquement, et il y a plusieurs entrées :

  1. Favoris où vous pouvez placer des raccourcis vers des endroits souvent utilisés

  2. Signets spatiaux où vous pouvez stocker des étendues de cartes souvent utilisées (voir Bookmarking extents on the map)

  3. Dossier du projet : pour un accès rapide au dossier dans lequel (la plupart des) données relatives à votre projet sont stockées. La valeur par défaut est le répertoire dans lequel se trouve votre fichier de projet.

  4. Home dans le système de fichiers et le répertoire racine du système de fichiers.

  5. Lecteurs locaux ou en réseau connectés

  6. Viennent ensuite un certain nombre de types de conteneurs / bases de données et de protocoles de services, en fonction de votre plate-forme et des bibliothèques sous-jacentes :

    • geoPackage GeoPackage

    • spatialite SpatiaLite

    • postgis PostGIS

    • mssql MS SQL Server

    • oracle Oracle

    • hana SAP HANA

    • wms WMS/WMTS

    • vectorTileLayer Tuiles vectorielles

    • xyz Tuiles XYZ

    • wcs WCS

    • wfs WFS/OGC API-Features

    • ows OWS

    • ams Service de cartes ArcGIS

    • afs Service d’entités ArcGIS

    • geonode GeoNode

15.1.1.2. Interaction avec les éléments de l’Explorateur

L’explorateur prend en charge le glisser-déposer dans l’explorateur, de l’explorateur vers le canevas et le panneau couches, et du panneau Couches aux conteneurs de couches (par exemple GeoPackage) dans l’explorateur.

Les éléments du fichier de projet à l’intérieur de l’Explorateur peuvent être développés, montrant l’arborescence complète des couches (y compris les groupes) contenue dans ce projet. Les éléments de projet sont traités de la même manière que tout autre élément de l’explorateur, de sorte qu’ils peuvent être glissés et déposés dans l’explorateur (par exemple pour copier une couche dans un fichier geopackage) ou ajoutés au projet en cours par un glisser-déposer ou un double-clic

Le menu contextuel d’un élément du panneau Explorateur s’ouvre en cliquant dessus avec le bouton droit.

Pour les entrées du répertoire du système de fichiers, le menu contextuel propose les éléments suivants:

  • Nouveau ► dans créer dans le répertoire sélectionné :

    • Répertoire …

    • GeoPackage…

    • ShapeFile…

  • Ajouter aux marque-pages : les répertoires favoris peuvent être renommés (Renommer le marque-page…) ou supprimés (Supprimer le marque-page) à tous moments.

  • Masquer dans l’Explorateur : les répertoires masqués peuvent être affichés à nouveau depuis le menu Préférences ► Options ► Sources de données ► Chemins masqués.

  • Scanner rapidement ce répertoire

  • Ouvrir Dossier

  • Ouvrir dans le terminal

  • Propriétés…

  • Propriétés du répertoire …

Pour les entrées de type fichier qui peuvent agir comme des couches dans le projet, le menu contextuel aura des entrées spécifiques. Par exemple, pour des données qui ne sont pas stockées en base de données, pour les services non basés sur des données vecteur, raster et source de données maillées :

  • Export Layer ► To File…

  • Ajouter une couche au projet

  • Propriétés couche

  • Manage ► Rename « <name of file> »… or Delete « <name of file> »…

  • Show in Files

  • Propriétés du fichier

Dans l’entrée Propriétés de la couche, vous trouverez (similaire à ce que vous trouverez dans les propriétés des couches vecteur et raster une fois les couches ajoutées au projet) :

  • Métadonnées pour la couche. Groupes de métadonnées: Informations du fournisseur (si possible, Chemin sera un lien hypertexte vers la source), Identification, Étendue, Accès, Attributs (pour les données vecteur), Bandes (pour raster), Contacts, Liens (pour les données vecteur), Références (pour raster), Historique.

  • Un panneau Aperçu

  • La table des attributs pour les sources vecteur (dans le panneau Attributs).

Pour ajouter une couche au projet en utilisant l”Explorateur :

  1. Activez l”Explorateur comme décrit ci-dessus. Une arborescence d’explorateur avec votre système de fichiers, vos bases de données et vos services Web s’affiche. Vous devrez peut-être connecter des bases de données et des services Web avant qu’ils n’apparaissent (voir les sections dédiées).

  2. Recherchez la couche dans la liste.

  3. Utilisez le menu contextuel, double-cliquez sur son nom ou glissez-déposez la dans le canevas de la carte. Votre couche est maintenant ajoutée au Panneau couches et peut être visualisée sur le canevas de la carte.

    Astuce

    Ouvrez un projet QGIS directement depuis l’explorateur

    Vous pouvez également ouvrir un projet QGIS directement à partir du panneau Explorateur en double-cliquant sur son nom ou par glisser-déposer dans le canevas de la carte.

Une fois un fichier chargé, vous pouvez zoomer à l’aide des outils de navigation sur la carte. Pour changer le style d’une couche, ouvrez la boîte de dialogue Propriétés couche en double-cliquant sur le nom de la couche ou en cliquant avec le bouton droit sur le nom dans la légende et en choisissant Propriétés dans le menu contextuel. Voir la section Onglet Symbologie pour plus d’informations sur la définition de la symbologie pour les couches vecteur.

Un clic droit sur un élément dans l’arborescence de l’explorateur vous aide à :

  • pour un fichier ou une table, affichez ses métadonnées ou l” ouvrir dans votre projet. Les tables peuvent même être renommées, supprimées ou tronquées.

  • pour un dossier, ajoutez-le à vos marques-pages ou masquez-le dans l’arborescence de l’explorateur. Les dossiers cachés peuvent être gérés à partir de l’onglet Paramètres ► Options ► Sources de données.

  • gérer vos marque-pages spatiaux: les marque-pages peuvent être créés, exportés et importés sous forme de fichiers XML.

  • créer une connexion à une base de données ou à un service Web.

  • actualisez, renommez ou supprimez un schéma.

Vous pouvez également importer des fichiers dans des bases de données ou copier des tables d’un schéma / base de données à un autre avec un simple glisser-déposer. Un deuxième panneau de navigation est disponible pour éviter un long défilement lors du glissement. Sélectionnez simplement le fichier et glissez-déposez d’un panneau à l’autre.

../../../_images/browser_panels.png

Fig. 15.2 Les deux panneaux de l’Explorateur QGIS côte à côte

Astuce

Ajoutez des couches à QGIS par simple glisser-déposer depuis votre explorateur de fichiers

Vous pouvez également ajouter des fichiers au projet en les faisant glisser depuis l’explorateur de fichiers de votre système d’exploitation vers Panneau Couches ou le canevas de la carte.

15.1.2. Le Gestionnaire de Base de Données

Le Gestionnaire de Base de Données fait parti des outils permettant l’intégration et la gestion de bases de données spatiales par QGIS (PostGIS, SpatiaLite, GeoPackage, Oracle Spatial, MS SQL Server, Virtual layers). Il s’active via le menu Extensions ► Installer / gérer les extensions….

Le dbManager Gestionnaire BD offre plusieurs fonctionnalités :

  • se connecter aux bases de données et afficher leur structure et leur contenu

  • aperçu des tables des bases de données

  • ajoutez des couches au canevas de la carte, soit en double-cliquant, soit en faisant glisser-déposer.

  • ajouter des couches à une base de données à partir de l’explorateur QGIS ou d’une autre base de données

  • créer des requêtes SQL et ajouter leur sortie au canevas de carte

  • créer des couches virtuelles

Plus d’informations sur les capacités de Gestionnaire BD dans Extension DB Manager.

../../../_images/db_manager.png

Fig. 15.3 Fenêtre Gestionnaire BD

15.1.3. Outils de chargement basé sur les fournisseurs

Outre le panneau Explorateur et le Gestionnaire de bases de données, les principaux outils fournis par QGIS pour ajouter des couches, vous trouverez également des outils spécifiques aux fournisseurs de données.

Note

Certaines extensions externes fournissent également des outils pour ouvrir des fichiers aux formats spécifiques dans QGIS.

15.1.3.1. Charger une couche à partir d’un fichier

Pour charger une couche à partir d’un fichier:

  1. Ouvrez l’onglet type de couche dans la boîte de dialogue Gestionnaire de sources de données, c’est-à-dire cliquez sur le bouton dataSourceManager ouvrir le gestionnaire de source de donnees (ou appuyez sur Ctrl + L) et activez l’onglet cible ou:

    • pour les données vecteur (comme les couches GML, ESRI Shapefile, Mapinfo et DXF): appuyez sur Ctrl + Shift + V, sélectionnez Couche ► Ajouter couche ► addOgrLayer Ajouter une couche vecteur ou cliquez sur le bouton addOgrLayer Ajouter une couche vecteur.

      ../../../_images/addvectorlayerdialog.png

      Fig. 15.4 Fenêtre d’ajout d’une couche vecteur

    • pour les données raster (comme GeoTiff, MBTiles, GRIdded Binary et DWG): appuyez sur Ctrl + Shift + R, sélectionnez Couche ► ajouter couche ► addRasterLayer Ajouter une couche raster ou cliquez sur le bouton addRasterLayer Ajouter une couche raster.

      ../../../_images/addrasterlayerdialog.png

      Fig. 15.5 Boîte de dialogue ajouter une couche raster

  2. Vérifiez radioButtonOn type de source de fichier File

  3. Cliquez sur le bouton :guilabel: Parcourir

  4. Naviguez dans le système de fichiers et chargez une source de données prise en charge. Plusieurs couches peuvent être chargées en même temps en maintenant enfoncée la touche Ctrl et en cliquant sur plusieurs éléments dans la boîte de dialogue ou en maintenant enfoncée la touche Shift pour sélectionner une plage d’éléments en cliquant sur les premiers et dernier fichers affichés . Seuls les formats qui ont été bien testés apparaissent dans le filtre des formats. D’autres formats peuvent être chargés en sélectionnant Tous les fichiers (l’élément supérieur du menu déroulant).

  5. Appuyez sur Ouvrir pour charger le fichier sélectionné dans la boîte de dialogue Gestionnaire de source de données

    ../../../_images/openoptionsvectorlayer.png

    Fig. 15.6 Charger un Shapefile avec des options

  6. Appuyez sur Ajouter pour charger le fichier dans QGIS et l’afficher dans la vue de la carte. Fig. 15.7 montre QGIS après le chargement du fichier alaska.shp.

    ../../../_images/shapefileloaded.png

    Fig. 15.7 QGIS après avoir chargé le Shapefile de l’Alaska

Note

For loading vector and raster files the GDAL driver offers to define open actions. These will be shown when a file is selected. Options are described in detail on https://gdal.org/drivers/vector/, https://gdal.org/drivers/raster and if a file is selected in QGIS, a text with hyperlink will directly lead to the documentation of the selected file type.

Note

Étant donné que certains formats comme MapInfo (par exemple .tab) ou Autocad (.dxf) permettent de mélanger différents types de géométrie dans un seul fichier, le chargement de ces ensembles de données ouvre une boîte de dialogue pour sélectionner les géométries à utiliser dans afin d’avoir une géométrie par couche.

Onglets addOgrLayer Ajouter une couche vecteur et addRasterLayer Ajouter une couche raster permettent de charger des couches à partir de types de sources autres que Fichier:

  • Vous pouvez charger des formats vecteur spécifiques tels que Couverture binaire ArcInfo, Royaume-Uni. National Transfer Format, ainsi que le format TIGER brut du US Census Bureau ou OpenfileGDB. Pour ce faire, vous sélectionnez radioButtonOn Répertoire comme Type de source. Dans ce cas, un répertoire peut être sélectionné dans la boîte de dialogue après avoir appuyé sur Parcourir.

  • With the radioButtonOn Database source type you can select an existing database connection or create one to the selected database type. Some possible database types are ODBC, Esri Personal Geodatabase, MS SQL Server as well as PostgreSQL or MySQL .

    Appuyer sur le bouton Nouveau ouvre la boîte de dialogue Créer une nouvelle connexion à la base de données OGR dont les paramètres sont parmi ceux que vous pouvez trouver dans Créer une connexion à enregistrer. En appuyant sur ouvrir cela vous permet de sélectionner parmi les tables disponibles, par exemple des bases de données compatibles PostGIS.

  • Le type de source radioButtonOn Protocole: HTTP (S), cloud, etc. ouvre les données stockées localement ou sur le réseau, accessibles au public ou dans des compartiments privés de services de stockage cloud commerciaux. Les types de protocoles pris en charge sont:

    • HTTP/HTTPS/FTP, avec une URI et, si nécessaire, une authentification.

    • Stockage cloud tel que AWS S3, Google Cloud Storage, Microsoft Azure Blob, Alibaba OSS Cloud, Open Stack Swift Storage. Vous devez remplir Bucket or container et Object key.

    • service supportant OGC WFS 3 (encore expérimental), utilisant le format GeoJSON ou GEOJSON - Newline Delimited ou basé sur la base de données CouchDB. Une :guilabel:URI est requise, avec en option une authentification.

    • Pour tous les types de sources vectorielles, il est possible de définir le paramètre Encodage ou d’utiliser le paramètre Automatique ►.

15.1.3.2. Chargement d’une couche de maillage

Un maillage est une grille non structurée généralement avec des composants temporels et autres. La composante spatiale contient une collection de sommets, d’arêtes et de faces dans un espace 2D ou 3D. Plus d’informations sur les couches de mailles sur Travailler avec des données maillées (mesh).

Pour ajouter une couche de maillage à QGIS:

  1. Ouvrez la boîte de dialogue Gestionnaire de sources de données, soit en la sélectionnant dans le menu Couche ► , soit en cliquant sur le bouton dataSourceManager Ouvrir le gestionnaire de sources de données.

  2. Activez l’onglet addMeshLayer maillage sur le panneau de gauche

  3. Appuyez sur le bouton Parcourir pour sélectionner le fichier. De nombreux formats sont supportés.

  4. Select the file and press Add. The layer will be added using the native mesh rendering.

  5. If the selected file contains many mesh layers, then you’ll be prompted with a dialog to choose the sublayers to load. Do your selection and press OK and the layers are loaded with the native mesh rendering. It’s also possible to load them within a group.

../../../_images/mesh_datasource_manager.png

Fig. 15.8 Onglet Maillage dans gestionnaire de source de donnees

15.1.3.3. Importation d’un fichier texte délimité

Les fichiers texte délimités (par exemple .txt, .csv, .dat, .wkt) peuvent être chargés à l’aide des outils décrits ci-dessus. De cette façon, ils apparaîtront comme de simples tables. Parfois, les fichiers texte délimités peuvent contenir des coordonnées / géométries que vous pourriez souhaiter visualiser. C’est pour cela que addDelimitedTextLayer Ajouter une couche de texte délimité est conçu.

  1. Cliquez sur l’icône dataSourceManager Ouvrir le gestionnaire des sources de données pour ouvrir la boîte de dialogue Gestionnaire des source de données

  2. Activez l’onglet addDelimitedTextLayer Texte délimité

  3. Sélectionnez le fichier texte délimité à importer (par exemple qgis_sample_data/csv/elevp.csv) en cliquant sur le bouton Parcourir.

  4. Dans le champ Nom de la couche, indiquez le nom à utiliser pour la couche dans le projet (par exemple Élévation).

  5. Configurez les paramètres pour répondre à votre ensemble de données et à vos besoins, comme expliqué ci-dessous.

../../../_images/delimited_text_dialog.png

Fig. 15.9 Fenêtre d’ajout de couche depuis un fichier texte délimité

Format fichier

Une fois le fichier sélectionné, QGIS tente d’analyser le fichier avec le délimiteur le plus récemment utilisé, en identifiant les champs et les lignes. Pour permettre à QGIS d’analyser correctement le fichier, il est important de sélectionner le bon délimiteur. Vous pouvez spécifier un délimiteur en choisissant entre:

  • radioButtonOn CSV (valeurs séparées par des virgules) pour utiliser le caractère virgule.

  • radioButtonOff Délimiteur d’expressions régulières et entrez du texte dans le champ Expression. Par exemple, pour changer le délimiteur en tab, utilisez \t (utilisé dans les expressions régulières pour le caractère de tabulation).

  • radioButtonOff Délimiteurs personnalisés, en choisissant parmi certains délimiteurs prédéfinis comme virgule, espace, tabulation, point-virgule, ….

Enregistrements et champs

D’autres options pratiques peuvent être utilisées pour la reconnaissance des données:

  • Nombre de lignes d’en-tête à supprimer: pratique lorsque vous souhaitez éviter les premières lignes du fichier lors de l’importation, soit parce que ce sont des lignes vides, soit avec un autre formatage.

  • checkbox Le premier enregistrement a des noms de champs: les valeurs de la première ligne sont utilisées comme noms de champs, sinon QGIS utilise les noms de champs field_1, field_2

  • checkbox Detecter les types de champ: reconnaît automatiquement le type de champ. Si cette case n’est pas cochée, tous les attributs sont traités comme des champs de texte.

  • checkbox Le séparateur décimal est une virgule: vous pouvez forcer le séparateur décimal à être une virgule.

  • checkbox Trim fields: permet de couper les espaces de début et de fin des champs.

  • checkbox Supprimer les champs vides.

  • Custom boolean literals: allows you to add a custom couple of string that will be detected as boolean values.

Field type detection

QGIS tries to detect the field types automatically (unless checkboxDetect field types is not checked) by examining the content of an optional sidecar CSVT file (see: GeoCSV specification) and by scanning the whole file to make sure that all values can actually be converted without errors, the fall-back field type is text.

The detected field type appears under the field name in sample data preview table and can be manually changed if necessary.

The following field types are supported:

  • Boolean case-insensitive literal couples that are interpreted as boolean values are 1/0, true/false, t/f, yes/no

  • Whole Number (integer)

  • Whole Number (integer - 64 bit)

  • Decimal Number: double precision floating point number

  • Date

  • Time

  • Date and Time

  • Text

Définition de la géométrie

Une fois le fichier analysé, définissez Definition de la géométrie sur

  • radioButtonOn Coordonnées du point et fournissez Champ X, Champ Y, Champ Z (pour les données tridimensionnelles) et Champ M`(pour la dimension de mesure) si la couche est de type géométrie ponctuelle et contient de tels champs. Si les coordonnées sont définies en degrés/minutes/secondes, cochez la case |checkbox| :guilabel:`Coordonnées DMS. Fournissez le Geometry CRS à l’aide de setProjection Select CRS.

  • radioButtonOn Option Well Known Text (WKT) si les informations spatiales sont représentées sous la forme WKT: sélectionnez Champ de géométrie contenant la géométrie WKT et choisissez la version appropriée Champ de géométrie ou laissez QGIS le détecter automatiquement. Fournissez le Geometry CRS à l’aide de setProjection Select CRS.

  • Si le fichier contient des données non spatiales, activez radioButtonOn Pas de géométrie (seulement attributs de la table) et il sera chargé comme une table ordinaire.

Paramétrages de la couche

En complément, vous pouvez activer :

  • checkbox Utiliser l’index spatial pour améliorer les performances d’affichage et de sélection spatiale des entités.

  • checkbox Utiliser l’index de sous-ensemble pour améliorer les performances de Use subset index (lorsqu’il est défini dans les propriétés de la couche).

  • checkbox Regarder le fichier pour surveiller les modifications du fichier par d’autres applications pendant que QGIS est en cours d’exécution.

À la fin, cliquez sur Ajouter pour ajouter la couche à la carte. Dans notre exemple, une couche de points nommée Altitude est ajoutée au projet et se comporte comme n’importe quelle autre couche de la carte dans QGIS. Cette couche est le résultat d’une requête sur le fichier source .csv (donc liée à lui) et nécessiterait d’être sauvegardée afin d’obtenir une couche spatiale sur le disque.

Sample Data

As you set the parser properties, the sample data preview updates regarding to the applied settings.

Also in the Sample Data Table it is possible to override the automatically determined column types.

15.1.3.4. Importation d’un fichier DXF ou DWG

Les fichiers DXF et DWG peuvent être ajoutés à QGIS par simple glisser-déposer depuis le panneau de l’Explorateur. Vous serez invité à sélectionner les sous-couches que vous souhaitez ajouter au projet. Les couches sont ajoutées avec des propriétés de style aléatoires.

Note

Pour les fichiers DXF contenant plusieurs types de géométrie (point, ligne et / ou polygone), le nom des couches sera généré en tant qu’entités <filename.dxf> <geometry type>.

Pour conserver la structure du fichier dxf / dwg et sa symbologie dans QGIS, vous pouvez utiliser l’outil dédié Projet ► Import / Export ► Importer couches depuis DWG / DXF… qui vous permet de :

  1. importer des éléments du fichier de dessin dans une base de données GeoPackage.

  2. ajouter des éléments importés au projet.

Dans la boîte de dialogue Importation DWG / DXF, pour importer le contenu du fichier de dessin:

  1. Saisissez l’emplacement du package sortie, c’est-à-dire le nouveau fichier GeoPackage qui stockera les données. Si un fichier existant est fourni, il sera écrasé.

  2. Spécifiez le système de coordonnées de référence des données dans le fichier de dessin.

  3. checkbox Détacher les blocs de référence pour importer les blocs dans le fichier de dessin en tant qu’éléments normaux.

  4. checkbox Utiliser les courbes pour promouvoir les couches importées en un type de géométrie courbe.

  5. Utilisez le bouton Importer pour sélectionner le fichier DWG / DXF à utiliser (un par géopackage). La base de données GeoPackage sera automatiquement remplie avec le contenu du fichier de dessin. Selon la taille du fichier, cela peut prendre un certain temps.

Une fois les données .dwg ou .dxf importées dans la base de données GeoPackage, le cadre dans la moitié inférieure de la boîte de dialogue est rempli avec la liste des couches du fichier importé. Vous pouvez y sélectionner les couches à ajouter au projet QGIS:

  1. En haut, définissez un nom de groupe pour regrouper les fichiers de dessin dans le projet.

  2. Vérifier les couches à afficher: chaque couche sélectionnée est ajoutée à un groupe ad hoc qui contient des couches vecteur pour les entités ponctuelles, linéaires, d’étiquettes et de surface de la couche de dessin. Le style des couches ressemblera à l’aspect qu’ils avaient à l’origine dans *CAD.

  3. Choisissez si la couche doit être visible à l’ouverture.

  4. checkbox Fusionner les calques place tous les calques dans un seul groupe.

  5. Appuyez sur OK pour ouvrir les couches dans QGIS.

../../../_images/dwg_dxf_import_dialog.png

Fig. 15.10 Boîte de dialogue d’importation pour les fichiers DWG / DXF

15.1.3.5. Importer des données vecteur OpenStreetMap

Le projet OpenStreetMap est populaire car dans de nombreux pays, aucune géodonnée gratuite telle que des cartes routières numériques n’est disponible. L’objectif du projet OSM est de créer une carte du monde éditable gratuite à partir des données GPS, de la photographie aérienne et des connaissances locales. Pour soutenir cet objectif, QGIS prend en charge les données OSM.

En utilisant le panneau Explorateur, vous pouvez charger un fichier .osm dans le canevas de carte, auquel cas vous obtiendrez une boîte de dialogue pour sélectionner des sous-couches en fonction du type de géométrie. Les couches chargées contiendront toutes les données de ce type de géométrie dans le fichier .osm, et conserveront la structure de données du fichier .osm.

15.1.3.6. Couches SpatiaLite

addSpatiaLiteLayer La première fois que vous chargez des données à partir d’une base de données SpatiaLite, commencez par:

  • en cliquant sur le bouton addSpatiaLiteLayer Ajouter une couche SpatiaLite

  • sélection de addSpatiaLiteLayer Ajouter une couche SpatiaLite… du menu Coucher ► Ajouter couche

  • ou en tapant Ctrl + Maj + L

Cela fera apparaître une fenêtre qui vous permettra soit de vous connecter à une base de données SpatiaLite déjà connue de QGIS (que vous choisissez dans le menu déroulant) soit de définir une nouvelle connexion à une nouvelle base de données. Pour définir une nouvelle connexion, cliquez sur Nouveau et utilisez l’explorateur de fichiers pour pointer vers votre base de données SpatiaLite, qui est un fichier avec une extension .sqlite.

QGIS gère les vues SpatiaLite éditables.

15.1.3.7. GPS

Il y a des dizaines de formats de fichier différent pour stocker des données GPS. Le format que QGIS utilise est appelé GPX (GPS eXchange format), qui est un format d’échange standard qui peut contenir n’importe quel nombre de waypoints, itinéraires et tracks dans un même fichier.

Use the Browse button to select the GPX file, then use the check boxes to select the feature types you want to load from that GPX file. Each feature type will be loaded in a separate layer.

More on GPS data manipulation at Les données GPS.

../../../_images/gps_datasource.png

Fig. 15.11 Loading GPS Data dialog

15.1.3.8. GRASS

Le travail avec les données vecteur GRASS est décrit dans la section Intégration du SIG GRASS.

15.1.4. The Layer Metadata Search Panel

The layer metadata search panel allows to browse layers metadata from registered metadata providers and add them to the project.

The list can be filtered by text, by current project and by map canvas extent.

The sources of metadata are implemented through a layer metadata provider system that can be extended by plugins.

QGIS provides out of the box the layer metadata providers that retrieve the metadata from the connections that allow for metadata storage (for more details save metadata to the database).

../../../_images/layer_metadata_search_panel.png

Fig. 15.15 Layer Metadata Search Panel

15.1.5. Formats personnalisés QGIS

QGIS propose deux formats personnalisés :

15.1.6. QLR - Fichier de définition de couche QGIS

Les définitions de couche peuvent être enregistrées sous la forme de Fichier de définition de couche ( au format .qlr) en utilisant Exporter ► Enregistrer en tant que fichier de définition de couche… dans le menu contextuel de la couche.

Le format QLR permet de partager des couches QGIS « complètes » avec d’autres utilisateurs QGIS. Les fichiers QLR contiennent des liens vers les sources de données et toutes les informations de style QGIS nécessaires pour styliser la couche.

Les fichiers QLR sont affichés dans le panneau Explorateur et peuvent être utilisés pour ajouter des couches (avec leurs styles enregistrés) au panneau Couches. Vous pouvez également faire glisser et déposer des fichiers QLR du gestionnaire de fichiers système dans le canevas de la carte.

15.1.7. Connexion aux services Web

Avec QGIS, vous pouvez accéder à différents types de services Web OGC (WM(T)S, WFS(-T), WCS, CSW, …). Grâce à QGIS Server, vous pouvez également publier de tels services. Guide/manuel de QGIS Serveur contient les descriptions de ces capacités.

15.1.7.1. Utiliser les services de tuiles vectorielles

Vector Tile services can be added via the addVectorTileLayer Vector Tiles tab of the Data Source Manager dialog or the contextual menu of the Vector Tiles entry in the Browser panel. Services can be either a New Generic Connection… or a New ArcGIS Vector Tile Service Connection….

You set up a service by adding:

  • un Nom.

  • the URL: of the type http://example.com/{z}/{x}/{y}.pbf for generic services and http://example.com/arcgis/rest/services/Layer/VectorTileServer for ArcGIS based services. The service must provide tiles in .pbf format.

  • the checkboxMin. Zoom Level and the checkboxMax. Zoom Level. Vector Tiles have a pyramid structure. By using these options you have the opportunity to individually generate layers from the tile pyramid. These layers will then be used to render the Vector Tile in QGIS.

    For Mercator projection (used by OpenStreetMap Vector Tiles) Zoom Level 0 represents the whole world at a scale of 1:500.000.000. Zoom Level 14 represents the scale 1:35.000.

  • a Style URL: a URL to a MapBox GL JSON style configuration. If provided, then that style will be applied whenever the layers from the connection are added to QGIS. In the case of Arcgis vector tile service connections, the URL overrides the default style configuration specified in the server configuration.

  • the authentication configuration if necessary

  • a Referer

Fig. 15.16 shows the dialog with the MapTiler planet Vector Tiles service configuration.

../../../_images/vector_tiles_maptilerplanet.png

Fig. 15.16 Tuiles vectorielles - Configuration de Maptiler Planet

Configurations can be saved to .XML file (Save Connections) through the Vector Tiles entry in Data Source Manager dialog or its context menu in the Browser panel. Likewise, they can be added from a file (Load Connections).

Once a connection to a vector tile service is set, it’s possible to:

  • Edit the vector tile connection settings

  • Remove the connection

  • From the Browser panel, right-click over the entry and you can also:

    • Ajouter la couche au projet : un double-clic ajoute également la couche

    • Affichez les Propriétés de la couche… et accédez aux métadonnées et à un aperçu des données fournies par le service. D’autres paramètres sont disponibles lorsque la couche a été chargée dans le projet.

15.1.7.2. Utilisation des services de tuiles XYZ

XYZ Tile services can be added via the addXyzLayer XYZ tab of the Data Source Manager dialog or the contextual menu of the XYZ Tiles entry in the Browser panel. Press New (respectively New Connection) and provide:

  • un Nom.

  • l”URL

  • the authentication configuration if necessary

  • the Min. Zoom level and Max. Zoom level

  • a Referer

  • the Tile Resolution: possible values are Unknown (not scaled), Standard (256x256 / 96DPI) and High (512x512 / 192DPI)

  • Interpretation: converts WMTS/XYZ raster datasets to a raster layer of single band float type following a predefined encoding scheme. Supported schemes are Default (no conversion is done), MapTiler Terrain RGB and Terrarium Terrain RGB. The selected converter will translate the RGB source values to float values for each pixel. Once loaded, the layer will be presented as a single band floating point raster layer, ready for styling using QGIS usual raster renderers.

By default, QGIS provides some default and ready-to-use XYZ Tiles services:

  • xyz Mapzen Global Terrain, allowing an immediate access to global DEM source for the projects. More details and resources at https://registry.opendata.aws/terrain-tiles/

  • xyz OpenStreetMap to access the world 2D map. Fig. 15.17 shows the dialog with the OpenStreetMap XYZ Tile service configuration.

    ../../../_images/xyz_tiles_dialog_osm.png

    Fig. 15.17 Tuiles XYZ - Configuration OpenStreetMap

Configurations can be saved to .XML file (Save Connections) through the XYZ Tiles entry in Data Source Manager dialog or its context menu in the Browser panel. Likewise, they can be added from a file (Load Connections).

The XML file for OpenStreetMap looks like this:

<!DOCTYPE connections>
<qgsXYZTilesConnections version="1.0">
  <xyztiles url="https://tile.openstreetmap.org/{z}/{x}/{y}.png"
   zmin="0" zmax="19" tilePixelRatio="0" password="" name="OpenStreetMap"
   username="" authcfg="" referer=""/>
</qgsXYZTilesConnections>

Once a connection to a XYZ tile service is set, it’s possible to:

  • Edit the XYZ connection settings

  • Remove the connection

  • From the Browser panel, right-click over the entry and you can also:

    • Exporter la couche… ► Vers un fichier…, en l’enregistrant comme un raster

    • Ajouter la couche au projet : un double-clic ajoute également la couche

    • Affichez les Propriétés de la couche… et accédez aux métadonnées et à un aperçu des données fournies par le service. D’autres paramètres sont disponibles lorsque la couche a été chargée dans le projet.

Exemples de services de tuiles XYZ :

  • OpenStreetMap Monochrome : URL: http://tiles.wmflabs.org/bw-mapnik/{z}/{x}/{y}.png, Niveau de zoom min.: 0, Niveau de zoom max.: 19.

  • Google Maps : URL: https://mt1.google.com/vt/lyrs=m&x={x}&y={y}&z={z}, Niveau de zoom min.: 0, Niveau de zoom max.: 19.

  • Open Weather Map Temperature : URL: http://tile.openweathermap.org/map/temp_new/{z}/{x}/{y}.png?appid={api_key} Niveau de zoom min.: 0, Niveau de zoom max.: 19.

15.1.7.3. Using ArcGIS REST Servers

ArcGIS REST Servers can be added via the addAfsLayer ArcGIS REST Server tab of the Data Source Manager dialog or the contextual menu of the ArcGIS REST Servers entry in the Browser panel. Press New (respectively New Connection) and provide:

  • un Nom.

  • l”URL

  • a Community endpoint URL

  • a Content endpoint URL

  • the authentication configuration if necessary

  • a Referer

Note

ArcGIS Feature Service connections which have their corresponding Portal endpoint URLS set can be explored by content groups in the browser panel.

If a connection has the Portal endpoints set, then expanding out the connection in the browser will show a “Groups” and “Services” folder, instead of the full list of services usually shown. Expanding out the groups folder will show a list of all content groups that the user is a member of, each of which can be expanded to show the service items belonging to that group.

Configurations can be saved to .XML file (Save Connections) through the ArcGIS REST Server entry in Data Source Manager dialog. Likewise, they can be added from a file (Load Connections).

Once a connection to an ArcGIS REST Server is set, it’s possible to:

  • Edit the ArcGIS REST Server connection settings

  • Remove the connection

  • Refresh the connection

  • use a filter for the available layers

  • choose from a list of available layers with the option to checkboxOnly request features overlapping the current view extent

  • From the Browser panel, right-click over the connection entry and you can:

    • Rafraîchir

    • Éditer la connexion…

    • Remove connection…

    • View Service Info which will open the default web browser and display the Service Info.

  • Right-click over the layer entry and you can also:

    • View Service Info which will open the default web browser and display the Service Info.

    • Exporter couche… ► Vers fichier

    • Ajouter la couche au projet : un double-clic ajoute également la couche

    • Affichez les Propriétés de la couche… et accédez aux métadonnées et à un aperçu des données fournies par le service. D’autres paramètres sont disponibles lorsque la couche a été chargée dans le projet.