Wichtig

Translation is a community effort you can join. This page is currently translated at 20.45%.

11.1. 2D Map View

The 2D map view (also called Map canvas) is the central place where maps are displayed. QGIS opens by default with a single map view (called main map), showing layers in 2D, and tightly bound to the Layers panel. That window reflects the rendering (symbology, labeling, visibilities…) you applied to the loaded layers.

../../../_images/startup.png

Abb. 11.1 QGIS GUI

11.1.1. Funktionen des Kartenfensters

Wenn Sie einen Layer hinzufügen (siehe z.B. Öffnen von Daten), sucht QGIS automatisch nach dem KBS des Layers. Wenn für das Projekt ein anderes KBS eingestellt ist, dann wird die Ausdehnung des Layers „on-the-fly“ in dieses KBS übersetzt (siehe Project Coordinate Reference Systems). Wenn Sie mit einem leeren QGIS-Projekt beginnenund wird die Kartenansicht auf die Ausdehnung des/der zuerst hinzugefügten Layer gezoomt. Wenn bereits Layer im Projekt vorhanden sind, wird keine Größenänderung der Kartenansicht durchgeführt, so dass nur Features sichtbar sind, die innerhalb der aktuellen Kartenansicht liegen.

Click on the map view and you should be able to interact with it, panning or zooming to different areas of the map. Dedicated tools are provided in the Navigation Toolbar and in the View menu, with handful shortcuts from the keyboard or the mouse buttons.

Tab. 11.1 Map canvas navigation tools

Werkzeug

Anwendung

pan Pan Map

  • Single left click: the map is centered on the clicked point, at the same scale

  • Hold down the left mouse button and drag the map canvas.

zoomIn Zoom In

  • Single left click: the map is centered on the clicked point, while the scale gets doubled

  • Drag a rectangle on the map canvas with the left mouse button to zoom in to an area.

  • Hold the Alt key to switch to the zoomOut Zoom Out tool.

zoomOut Zoom Out

  • Single left click: the map is centered on the clicked point, while the scale gets halved

  • Drag a rectangle on the map canvas with the left mouse button to zoom out from an area.

  • Hold the Alt key to switch to the zoomIn Zoom In tool.

panToSelected Pan Map to Selection

Pan the map to the selected features of all the selected layers in the Layers panel.

zoomToSelected Zoom To Selection

Zoom to the selected features of all the selected layers in the Layers panel.

Also available in the layer contextual menu

zoomToLayer Zoom To Layer(s)

Zoom to the extent of all the selected layers in the Layers panel.

Also available in the layer contextual menu

zoomFullExtent Zoom Full

Zoom to the extent of all the layers in the project or to the project full extent.

zoomLast Zoom Last

Zoom the map to the previous extent in history.

zoomNext Zoom Next

Zoom the map to the next extent in history.

zoomActual Zoom to Native Resolution

Zoom the map to a level where one pixel of the active raster layer covers one screen pixel.

Also available in the layer contextual menu

Mouse wheel

  • Pan map: Hold and drag the mouse wheel.

  • Zoom: Roll the mouse wheel to zoom in or zoom out. With Ctrl key pressed while rolling the mouse wheel results in a finer zoom.

  • Press the back or forward button to browse the map canvas zoom history.

Keyboard

  • Pan map: Hold down the Space key and move the mouse. Press the arrow keys to pan up, down, left and right.

  • Zoom in: Press PgUp or Ctrl++

  • Zoom out: Press PgDown or Ctrl+-

  • Zoom to area: When certain map tools are active (Identify, Measure…), hold down Shift and drag a rectangle on the map to zoom to that area. Not compatible with active selection or edit tools.

Mit einem rechten Maustaste in die Karte können Sie die Koordinaten des angeklickten Punktes kopieren, entwieder im KBS der Karte, in WGS84-Koordinaten oder in einem benutzerdefiniertes KBS (editCopy Koordinaten kopieren). Die kopierten Informationen stehen dann in der Zwischenablage des Betriebssystems zur Verfügung und können über „Einfügen“ oder entprechende Tastenkombiantionen in einen Texteditor, einer Tabellenkalkulation, einem Skript, etc eingefügt werden.

11.1.2. Controlling map rendering

QGIS rendert standardmäßig alle sichtbaren Layer wenn das Kartenfenster aktualisirt werden muss. Die Abläufe, die eine ‚Erneuerung‘ der Wiedergabe verursachen sind:

  • changing the visibility of a layer

  • modifying symbology of a visible layer

  • adding a layer

  • panning or zooming

  • resizing the QGIS window

QGIS ermöglicht es, den Wiedergabeprozess auf verschiedene Arten zu kontrollieren.

To stop the map drawing, press the Esc key. This will halt the refresh of the map canvas and leave the map partially drawn. It may however take a bit of time after pressing Esc for the map drawing to halt.

To suspend rendering, click the checkbox Render checkbox in the bottom-right corner of the status bar. When checkbox Render is unchecked, QGIS does not redraw the canvas in response to any of the usual triggers mentioned earlier. Examples of when you might want to suspend rendering include:

  • adding many layers and symbolizing them prior to drawing

  • adding one or more large layers and setting scale dependency before drawing

  • adding one or more large layers and zooming to a specific view before drawing

  • any combination of the above

Wenn Sie die checkbox Zeichnen aktivieren, findet automatisch eine Erneuerung der Wiedergabe des Kartenfensters statt.

11.1.3. Zeitabhängige Darstellung in der Kartenansicht

In QGIS können Layer zeitlich gesteuert dargestellt werden, d.h. die Kartenansicht wird zeitabhängig verändert. Um dies durchführen zu können, benötigen Sie:

  1. Einen oder mehrere Layer, für den zeitlich-dynamische Eigenschaften festgelegt wurden. QGIS unterstützt die zeitliche Steuerung für verschiedene Layer-Typen mit unterschiedlichen Einstellungen. Diese unterscheiden sich in erster Linie bei der Einstellung des Zeitintervalls, in dem der Layer angezeigt werden soll:

    • Raster Layer: es wird festgelegt, ob der Layer angezeigt werden soll oder nicht

    • WMTS Layer: es wird festgelegt, ob die Daten auf der Grundlage eines statischen Zeitbereichs oder nach einem dynamischen Zeitbereich dargestellt werden sollen

    • ref:Vektor-Layer <vectortemporalmenu>: Objekte können auch über Zeitwerte gesteuert werden, die in der Attributtabelle enthalten sind

    • mesh layers: zeigt dynamisch die Werte der aktiven Datensatzgruppen an

    Wenn zeitlich-dynamische Eigenschaften für einen Layer aktiviert sind, ist neben dem Layer im Layer Bedienfeld ein Symbol indicatorTemporal sichtbar, um anzuzeigen, dass der Layer zeitgesteuert ist. Klicken Sie auf das Symbol, um die zeitlichen Einstellungen zu ändern.

  2. Aktivierung der zeitlichen Steuerung der Kartenansicht mit dem Zeitsteuerung Bedienfeld. Das Bedienfeld selber kann angezeigt werden über

    • das Symbol temporal Zeitsteuerungsfenster in der Kartennavigationswerkzeugleiste

    • oder über das Menü Ansicht ► Bedienfelder ► Zeitsteuerung

11.1.3.1. Das Zeitsteuerung-Bedienfeld

Das Zeitsteuerung Bedienfeld bietet die folgenden Möglichkeiten:

../../../_images/temporal_controller_panel.png

Abb. 11.2 Zeitsteuerung-Bedienfeld im Navigationsmodus

  • temporalNavigationOff Zeitliche Navigation abschalten: alle zeitlichen Einstellungen sind deaktiviert und die aktiven Layer werden wie gewohnt angezeigt

  • temporalNavigationFixedRange Zeit-Navigation in festem Bereich: ein Zeitbereich wird festgelegt und nur Layer (oder Objekte), deren Zeitbereich sich mit diesem überschneidet, werden auf der Karte angezeigt

  • temporalNavigationAnimated Animierte Zeitnavigation: ein Zeitbereich und eine Schrittlänge innerhalb dieses Zeitbereichs werden festgelegt und es werden nur Layer (oder Objekte) angezeigt, die sich innerhalb des jeweiligen Schrittes befinden

  • settings Einstellungen für die allgemeine Steuerung der Animation:

    • Bildrate: Anzahl der Bilder, die pro Sekunde angezeigt werden

    • unchecked Kumulativer Bereich: alle Animationsbilder haben die gleiche Startzeit, aber unterschiedliche Enddaten und -zeiten. Dies ist nützlich, wenn Sie Daten in Ihrer zeitlichen Visualisierung akkumulieren möchten, anstatt ein „bewegliches Zeitfenster“ über die Daten laufen zu lassen.

11.1.3.2. Animation über einen Zeitverlauf

Eine zeitliche Animation besteht aus einer Reihe von Bildern aller zeitlich aktiven Layer zu einem bestimmten Zeitpunkten innerhalb eines Zeitraums. So erstellen Sie eine zeitliche Animation:

  1. Schalten Sie auf temporalNavigationAnimated Animierte Zeitnavigation um, so das die Bedienelemente des Players anzeigt werden

  2. Geben Sie den Animationsbereich ein, der berücksichtigt werden soll . Mit der refresh Schaltfläche kann dieser wie folgt automatisch definiert werden:

    • Auf ganzen Bereich setzen legt den Animationsbereich so fest, dass die Zeiträume aller zeitlich aktivierten Layer berücksichtigt werden

    • Auf Projektbereich voreinstellen legt den Animationsbereich so fest, wie er in den Projekteigenschaften definiert ist

    • Bereich eines einzelnen Layers setzen legt den Bereich auf die Spanne der Werte eines einzelnen Layers fest

  3. Mit dem Zeit- Schritt, wird die Zeitspanne in einzelne Intervalle unterteilt. Es werden verschiedene Einheiten unterstützt z. B. Sekunden oder Jahrhunderte . Als Schritt ist auch die Option Quellzeitstempel verfügbar: Wenn sie ausgewählt ist, bewirkt sie, dass die zeitliche Navigation zwischen allen verfügbaren Zeitbereichen der Layer im Projekt wechselt. Dies ist nützlich, wenn in einem Projekt verschiedene Layer enthalten sind, welche nicht in einem zusammenhängenden Zeitraum liegen. Dies kann z. B. bei einem WMS-T-Dienst der Falls sein, wenn Bilder bereitstellt werden, die unregelmäßige Zeitpunkten wiedergeben. Diese Option ermöglicht es ihnen, mit einem Schritt einfach in den Zeitbereich zu wechseln, in dem das nächste Bild verfügbar ist.

  4. Klicken Sie auf die Schaltfläche play, um eine Vorschau der Animation zu erhalten. QGIS erzeugt eine Serie von Bildern mit den Layern oder Objekten, die zu den eingestellten Zeiten dargestellt werden. Die Anzeige der Layer oder Objekte hängt davon ab, ob deren Zeitstempel innerhalb des jeweiligen Zeitintervalls liegen.

    ../../../_images/map_navigation.gif

    Abb. 11.3 Zeitliche Navigation durch einen Layer

    The animation can also be previewed by moving the time slider. Checking the unchecked Loop checkbox will repeatedly run the animation while clicking play stops a running animation. A full set of video player buttons is available.

    Durch horizontales Scrollen mit dem Mausrad (sofern von Ihrer Maus unterstützt) und dem Cursor auf der Kartenansicht können Sie auch den Schieberegler für die zeitliche Navigation vorwärts und rückwärts verschieben ( “scrubben”).

  5. Klicken Sie auf die Schaltfläche fileSave Animation exportieren, wenn Sie die Serie von Bildern exportieren wollen. Diese können später in einem Videoeditor zusammengefügt werden:

    ../../../_images/saveTimeAnimation.png

    Abb. 11.4 Fenster zum Exportieren von Bildern einer Animation

    • In der Vorlage für den Dateinamen werden die Platzhalter #### durch fortlaufende Bildnummern ersetzt

    • Das Ausgabeverzeichnis

    • Unter Karteneinstellungen können Sie:

      • Die räumliche Ausdehnung neu festlegen

      • Die Auflösung der Bilder festlegen (Ausgabebreite und Ausgabehöhe)

      • Aktive Dekorationen anzeigen legt fest, ob aktive Dekorationen in den Ausgabe-Bildern dargestellt sein sollen

    • Unter Zeiteinstellungen können Sie folgende Parameter neu festlegen:

      • den Zeit-Bereich für die Animation

      • die Schrittweite (Einzelbildlänge) in der gewünschten Einheit

11.1.4. Bookmarking extents on the map

Spatial Bookmarks allow you to „bookmark“ a geographic location and return to it later. By default, bookmarks are saved in the user’s profile (as User Bookmarks), meaning that they are available from any project the user opens. They can also be saved for a single project (named Project Bookmarks) and stored within the project file, which can be helpful if the project is to be shared with other users.

11.1.4.1. Ein Lesezeichen erstellen

Um ein Lesezeichen zu erstellen:

  1. Zoom and pan to the area of interest.

  2. Select the menu option View ► newBookmark New Spatial Bookmark…, press Ctrl+B or right-click the showBookmarks Spatial Bookmarks entry in the Browser panel and select New Spatial Bookmark. The Bookmark Editor dialog opens.

    ../../../_images/bookmark_editor.png

    Abb. 11.5 The Bookmark Editor Dialog

  3. Enter a descriptive name for the bookmark

  4. Enter or select a group name in which to store related bookmarks

  5. Select the extent of the area you wish to save, using the extent selector widget

  6. Change the map Rotation

  7. Indicate the CRS to use for the extent

  8. Select whether the bookmark will be Saved in User Bookmarks or Project Bookmarks (by default, this drop-down list is set to User Bookmarks)

  9. Press Save to add the bookmark to the list

Sie können mehrere Lesezeichen mit demselben Namen erstellen.

11.1.4.2. Arbeiten mit Lesezeichen

To use and manage bookmarks, you can either use the Spatial Bookmarks panel or Browser.

Select View ► showBookmarks Show Spatial Bookmark Manager or press Ctrl+7 to open the Spatial Bookmarks Manager panel. Select View ► showBookmarks Show Bookmarks or Ctrl+Shift+B to show the showBookmarks Spatial Bookmarks entry in the Browser panel.

You can perform the following tasks:

Tab. 11.2 Managing bookmark actions

Task

Spatial Bookmark Manager

Browser

Zoom to a Bookmark

Double-click on it, or select the bookmark and press the zoomToBookmark Zoom to bookmark button.

Double-click on it, drag and drop it to the map canvas, or right-click the bookmark and select Zoom to Bookmark.

Delete a bookmark

Select the bookmark and click the deleteSelected Delete bookmark button. Confirm your choice.

Right-click the bookmark and select Delete Spatial Bookmark. Confirm your choice.

Export bookmarks to XML

Click the sharing Import/Export Bookmarks button and select sharingExport Export. All the bookmarks (user or project) are saved in an xml file.

Select one or more folders (user or project) or subfolders (groups), then right-click and select sharingExport Export Spatial Bookmarks…. The selected bookmark subset is saved.

Import bookmarks from XML

Click the sharing Import/Export Bookmarks button and select sharingImport Import. All bookmarks in the XML file are imported as user bookmarks.

Right-click the Spatial Bookmarks entry or one of its folders (user or project) or subfolders (groups) to determine where to import the bookmarks, then select sharingImport Import Spatial Bookmarks. If performed on the Spatial Bookmarks entry, the bookmarks are added to User Bookmarks.

Edit bookmark

You can change a bookmark by changing the values in the table. You can edit the name, the group, the extent and if it is stored in the project or not.

Right-click the desired bookmark and select Edit Spatial Bookmark…. The Bookmark Editor will open, allowing you to redefine every aspect of the bookmark as if you were creating it for the first time.

You can also drag and drop the bookmark between folders (user and project) and subfolders (groups).

You can manage bookmark actions by right-click on the desired bookmark in the Spatial Bookmarks Manager. You can also zoom to bookmarks by typing the bookmark name in the locator.

11.1.5. Decorating the map

Decorations include Grid, Title Label, Copyright Label, Image, North Arrow, Scale Bar and Layout Extents. They are used to ‚decorate‘ the map by adding cartographic elements.

11.1.5.1. Gitter

addGrid Grid allows you to add a coordinate grid and coordinate annotations to the map canvas.

  1. Select menu option View ► Decorations ► Grid… to open the dialog.

    ../../../_images/grid_dialog.png

    Abb. 11.6 Der Gitter Dialog

  2. Tick checkbox Enable grid and set grid definitions according to the layers loaded in the map canvas:

    • The Grid type: it can be Line or Marker

    • The associated Line symbol or marker symbol used to represent the grid marks

    • The Interval X and Interval Y between the grid marks, in map units

    • An Offset X and Offset Y distance of the grid marks from the bottom left corner of the map canvas, in map units

    • The interval and offset parameters can be set based on the:

      • Canvas Extents: generates a grid with an interval that is approximatively 1/5 of the canvas width

      • Active Raster Layer resolution

  3. Tick checkbox Draw annotations to display the coordinates of the grid marks and set:

    • The Annotation direction, ie how the labels would be placed relative to their grid line. It can be:

      • Horizontal or Vertical for all the labels

      • Horizontal and Vertical, ie each label is parallel to the grid mark it refers to

      • Boundary direction, ie each label follows the canvas boundary, and is perpendicular to the grid mark it refers to

    • The Annotation font (text formatting, buffer, shadow…) using the font selector widget

    • The Distance to map frame, margin between annotations and map canvas limits. Convenient when exporting the map canvas eg to an image format or PDF, and avoid annotations to be on the „paper“ limits.

    • The Coordinate precision

  4. Click Apply to verify that it looks as expected or OK if you’re satisfied.

11.1.5.2. Title Label

titleLabel Title Label allows you to decorate your map with a Title.

To add a Title Label decoration:

  1. Select menu option View ► Decorations ► Title Label… to open the dialog.

    ../../../_images/titleLabel.png

    Abb. 11.7 The Title Decoration Dialog

  2. Make sure checkbox Enable Title Label is checked

  3. Enter the title text you want to place on the map. You can make it dynamic using the Insert or Edit an Expression… button.

  4. Choose the Font for the label using the font selector widget with full access to QGIS text formatting options. Quickly set the font color and opacity by clicking the black arrow to the right of the font combo box.

  5. Select the color to apply to the title’s Background bar color.

  6. Choose the Placement of the label in the canvas: options are Top left, Top Center (default), Top Right, Bottom left, Bottom Center and Bottom Right.

  7. Refine the placement of the item by setting a horizontal and/or vertical Margin from Edge. These values can be in Millimeters or Pixels or set as a Percentage of the width or height of the map canvas.

  8. Click Apply to verify that it looks as expected or OK if you’re satisfied.

11.1.5.4. Image Decoration

addImage Image allows you to add an image (logo, legend, ..) on the map canvas.

To add an image:

  1. Select menu option View ► Decorations ► Image… to open the dialog.

    ../../../_images/image_decoration.png

    Abb. 11.9 The Image Decoration Dialog

  2. Make sure checkbox Enable Image is checked

  3. Select a bitmap (e.g. png or jpg) or SVG image using the Browse button

  4. If you have chosen a parameter enabled SVG then you can also set a Fill or Stroke (outline) color. For bitmap images, the color settings are disabled.

  5. Set a Size of the image in mm. The width of selected image is used to resize it to given Size.

  6. Choose where you want to place the image on the map canvas with the Placement combo box. The default position is Top Left.

  7. Set the Horizontal and Vertical Margin from (Canvas) Edge. These values can be set in Millimeters, Pixels or as a Percentage of the width or height of the map canvas.

  8. Click Apply to verify that it looks as expected and OK if you’re satisfied.

11.1.5.5. Nordpfeil

northArrow North Arrow allows you to add a north arrow on the map canvas.

To add a north arrow:

  1. Select menu option View ► Decorations ► North Arrow… to open the dialog.

    ../../../_images/north_arrow_dialog.png

    Abb. 11.10 Der Nordpfeil Dialog

  2. Make sure checkbox Enable north arrow is checked

  3. Optionally change the color and size, or choose a custom SVG

  4. Optionally change the angle or choose Automatic to let QGIS determine the direction

  5. Optionally choose the placement from the Placement combo box

  6. Optionally refine the placement of the arrow by setting a horizontal and/or vertical Margin from (Canvas) Edge. These values can be in Millimeters or Pixels or set as a Percentage of the width or height of the map canvas.

  7. Click Apply to verify that it looks as expected and OK if you’re satisfied.

11.1.5.6. Maßstab

scaleBar Scale Bar adds a simple scale bar to the map canvas. You can control the style and placement, as well as the labelling of the bar. The scale bar respects the active project’s distance unit as defined in Project properties ► General ► Units for distance measurement.

Das Hinzufügen eines Maßstabbalkens geht folgendermaßen:

  1. Select menu option View ► Decorations ► Scale Bar… to open the dialog

    ../../../_images/scale_bar_dialog.png

    Abb. 11.11 Der Maßstab Dialog

  2. Make sure checkbox Enable scale bar is checked

  3. Choose a style from the Scale bar style selectString combo box

  4. Select the Color of bar selectColor by choosing a fill color (default: black) and an outline color (default: white). The scale bar fill and outline can be made opaque by clicking on the down arrow to the right of the color input.

  5. Select the font for the scale bar from the Font of bar selectString combo box

  6. Set the Size of bar in the active unit

  7. Optionally check checkbox Automatically snap to round number on resize to display easy-to-read values

  8. Choose the placement from the Placement selectString combo box

  9. You can refine the placement of the item by setting a horizontal and/or vertical Margin from (Canvas) Edge. These values can be in Millimeters or Pixels or set as a Percentage of the width or height of the map canvas.

  10. Click Apply to verify that it looks as expected or OK if you’re satisfied.

11.1.5.7. Layout Extents

addMap Layout Extents adds the extents of map item(s) in print layout(s) to the canvas. When enabled, the extents of all map items within all print layouts are shown using a lightly dotted border labeled with the name of the print layout and map item. You can control the style and labeling of the displayed layout extents. This decoration is useful when you are tweaking the positioning of map elements such as labels, and need to know the actual visible region of print layouts.

../../../_images/decoration_layoutextents_example.png

Abb. 11.12 Example of layout extents displayed in a QGIS project with two print layouts. The print layout named ‚Sights‘ contains two map items, while the other print layout contains one map item.

To add layout extent(s):

  1. Select View ► Decorations ► Layout Extents to open the dialog

    ../../../_images/decoration_layoutextents.png

    Abb. 11.13 The Layout Extents Dialog

  2. Make sure checkbox Show layout extents is checked.

  3. Optionally change the symbol and labeling of the extents.

  4. Click Apply to verify that it looks as expected and OK if you’re satisfied.

Tipp

Decorations Settings

When you save a QGIS project file, any changes you have made to Grid, North Arrow, Scale Bar, Copyright and Layout Extents will be saved in the project and restored the next time you load the project.

11.1.6. Beschriftungstools

Annotations are another type of elements added onto the map canvas to provide additional information that can not be depicted by the rendered layers. Unlike labels that rely on attribute values stored in vector layers, annotations are independent details, stored within the project file itself.

Two families of annotations are available in QGIS:

  • Feature annotations: they are actual georeferenced features of text, marker, line or polygon type stored within a special layer type called „annotation layer“. They are tied to a particular geographic location, meaning that moving your map, changing the scale or changing projection won’t cause your annotations to jump around the map. Rather, they’ll be locked in place to the location you’ve drawn them.

  • Balloon annotations: these are individuals annotations of text, form or image type placed inside a bubble. They can be associated to any layer for their visibility, are drawn on top of the map canvas. The size is dependent from the map canvas scale, and its position can be anchored.

Tipp

Layout the map with annotations

You can print or export annotations with your map to various formats using:

  • map canvas export tools available in the Project menu

  • print layout, in which case you need to check Draw map canvas items in the corresponding map item properties

The Annotations Toolbar provides a set of tools to create and interact with both families of annotations.

Tab. 11.3 The Annotations Toolbar actions

Werkzeug

Anwendung

Scope

createAnnotationLayer New Annotation Layer

Create a new layer to store annotations

Feature annotations

Main Annotation Layer Properties

Control settings of the Main Annotation Layer

select Modify Annotations

Select, move, resize and modify symbology properties of annotations

addPolygon Create Polygon Annotation

Create an annotation as a polygon feature

addPolyline Create Line Annotation

Create an annotation as a polyline feature

addMarker Create Marker Annotation

Create an annotation as a point feature

actionText Create Text Annotation at Point

Create an annotation as a text label

textAlongLine Create Text Annotation along Line

Create an annotation as a curved text along a linestring

textAnnotation Text Annotation

Select and create a text formatted annotation

Balloon annotations

htmlAnnotation HTML Annotation

Select and create annotation with an HTML file’s content

svgAnnotation SVG Annotation

Select and create annotation showing an SVG file

formAnnotation Form Annotation

Select and create annotation showing attributes of a vector layer in a custom form file

11.1.6.1. Feature Annotations

Feature annotations are stored in annotation layers. Unlike conventional layers, an annotation layer is available only in the current project and can contain features of different types (text, marker, line, polygon). The layer has no attributes and no symbology associated, but instead each feature can be symbolized on an item-by-item basis, through Layer Styling panel.

Two types of annotation layer are available in QGIS:

  • A common Annotation Layer: you can create one using the createAnnotationLayer New Annotation Layer tool. It is listed in the Layers panel, allowing you to control its features‘ visibility, move it to show above or below particular layers in your map, like any common layer. Double-click the layer and you can access its properties.

  • The Main Annotation Layer: By default, this is where annotations are stored when no annotation layer is available in the project or is selected at creation time. This layer is always drawn on the very top of your map and you won’t see it listed in the Layers panel alongside the other layers in your project, meaning that its features are always visible. The Main Annotation Layer Properties entry on the Annotations toolbar helps you open its properties dialog.

Layer-Eigenschaften

The properties dialog of an annotation layer provides the following tabs:

  • Information: a read-only dialog representing an interesting place to quickly grab summarized information and metadata on the current layer. This may include the layer extent, count of items per annotation type and total count, CRS details, …

  • Source: defines general settings for the annotation layer. You can:

    • Set a Layer name that will be used to identify the layer in the project (in the Layers Panel, with expressions, …)

    • Display the layer’s Assigned Coordinate Reference System (CRS): you can change the layer’s CRS, selecting a recently used one in the drop-down list or clicking on setProjection Select CRS button (see Coordinate Reference System Selector). Use this process only if the CRS applied to the layer is a wrong one or if none was applied.

  • Rendering:

    • You can set the Maximum (inclusive) and Minimum (exclusive) scale, defining a range of scale in which features will be visible. Out of this range, they are hidden. The mapIdentification Set to current canvas scale button helps you use the current map canvas scale as boundary of the range visibility. See Visibility Scale Selector for more information.

    • Opacity: You can make the underlying layer in the map canvas visible with this tool. Use the slider to adapt the visibility of your vector layer to your needs. You can also make a precise definition of the percentage of visibility in the menu beside the slider.

    • Blending mode at the Layer level: You can achieve special rendering effects with these tools that you may previously only know from graphics programs. The pixels of your overlaying and underlying layers are mixed through the settings described in Mischmodi.

    • Wenden Sie Zeicheneffekte auf alle Layerobjekte an, mit dem Zeicheneffekte Knopf.

    Some of these options are accessible from the feature annotation Symbology properties.

Interacting with features

The Feature annotations have dedicated tools for creation depending on their type:

  • addPolygon Create Polygon Annotation

  • addPolyline Create Line Annotation

  • addMarker Create Marker Annotation

  • actionText Create Text Annotation at Point

  • textAlongLine Create Text Annotation along Line

All the usual QGIS shortcuts for creating features apply when creating annotation items. A line or polygon annotation is drawn by left-clicking once for each vertex, with a final right mouse click to complete the shape. Snapping can be enabled while you draw, you can use the Advanced Digitizing Tools to precisely place vertices, and even switch the drawing tools to the streaming mode for completely free-form shapes.

Unlike common layers, an annotation layer does not need to be active before you select its features. Simply grab the select Modify Annotations tool and you will be able to interact with any feature annotation:

  • Selection: left-click on the annotation. By default, annotations are rendered in the order of creation, meaning that recent annotations will be placed on top of older. You may need to play with the Z-index property of features in order to select ones they would sit above.

  • Moving: Left click on a selected annotation item to start moving it. A right-click or pressing Esc key cancels the move, while a second left click will confirm the move. The displacement can also be controlled pressing the cursor keys:

    • Shift+key for big movement

    • Alt+key for 1 px movement

  • Geometry modification: for line or polygon annotations, left-click on a vertex of the geometry, move and click again. Double-click a segment to add a new vertex.

  • Delete: Pressing the Del or Backspace key while an annotation is selected will delete that annotation

  • Change feature symbology

Feature symbology

A selected annotation will display its Symbology properties in the Layer styling panel. You can:

  • Modify the appearance using full capabilities of:

    • the symbol properties for polygon, polyline and marker annotations

    • the text format properties for text-based annotations. A text area allows you to construct the string to display using QGIS expression functions. It is also possible to set the Alignment for text annotation at point (left, center or right of the text point).

  • For text annotation at point, also configure whether it should Ignore map rotation or Rotate with map. In both cases, a custom Angle can be set for the feature orientation.

  • For text annotation along a line, configure an Offset from line in the unit of your choice

  • Configure a unchecked Reference scale: indicates the map scale at which symbol or text sizes which uses paper-based units (such as millimeters or points) relate to. The sizes will be scaled accordingly whenever the map is viewed at a different scale. For instance, a line feature wide of 2mm at 1:2000 Reference scale will be rendered using 4mm when the map is viewed at 1:1000.

  • Set a Z-index: a feature with a higher index is placed on top of features with lower index. A convenient setting for both feature display and selection.

  • Modify some of the Layer rendering settings

11.1.6.2. Balloon annotations

You can add balloon annotations through Edit ► Add Annotation ► menu or from the Annotations Toolbar:

../../../_images/custom_annotation.png

Abb. 11.14 Examples of balloon annotations

To add a balloon annotation, select the corresponding tool and click on the map canvas. An empty balloon is added. Double-click on it and a dialog opens with various options. This dialog is almost the same for all the annotation types:

  • At the top, a file selector to fill with the path to an html, svg or ui file depending on the type of annotation. For text annotation, you can enter your message in a text box and set its rendering with the normal font tools.

  • checkbox Fixed map position: when unchecked, the balloon placement is based on a screen position (instead of the map), meaning that it’s always shown regardless the map canvas extent.

  • Linked layer: associates the annotation with a map layer, making it visible only when that layer is visible.

  • Map marker: using QGIS symbols, sets the symbol to display at the balloon anchor position (shown only when Fixed map position is checked).

  • Frame style: sets the frame background color, transparency, stroke color or width of the balloon using QGIS symbols.

  • Contents margins: sets interior margins of the annotation frame.

  • checkbox Live update allows you to live preview your changes.

../../../_images/annotation.png

Abb. 11.15 A ballon annotation text dialog

When a balloon annotation tool is active, you can also:

  • Select an annotation

  • Resize an annotation

  • Move an annotation by map position (by dragging the map marker) or by moving only the balloon.

  • Delete an annotation: select it and either press the Del or Backspace button, or double-click it and press the Delete button in the properties dialog.

  • Right-click and in the contextual menu:

    • editCopy Copy coordinate of the annotation’s map marker in various CRS

    • toggleEditing Edit properties of the annotation. Same as double-clicking the annotation.

    • deleteSelected Delete the annotation

11.1.7. Messen

11.1.7.1. Allgemeine Informationen

QGIS bietet vier Mittel zur Geometriemessung:

  • interactive measurement tools measure

  • measuring in the calculateField Field Calculator

  • derived measurements in the Identifying Features tool

  • the vector analysis tool: Vector ► Geometry Tools ► Export/Add Geometry Columns

Das Messen funktioniert innerhalb projizierter Koordinatensystemen (z. B. UTM) und unprojizierten Daten. Die ersten drei Messwerkzeuge verhalten gleich, für globale Projekteinstellungen:

  • Unlike most other GIS, the default measurement metric is ellipsoidal, using the ellipsoid defined in Project ► Properties… ► General. This is true both when geographic and projected coordinate systems are defined for the project.

  • If you want to calculate the projected/planimetric area or distance using cartesian maths, the measurement ellipsoid has to be set to „None/Planimetric“ (Project ► Properties… ► General). However, with a geographic (ie unprojected) CRS defined for the data and project, area and distance measurement will be ellipsoidal.

However, neither the identify tool nor the field calculator will transform your data to the project CRS before measuring. If you want to achieve this, you have to use the vector analysis tool: Vector ► Geometry Tools ► Add Geometry Attributes…. Here, measurement is planimetric, unless you choose the ellipsoidal measurement.

11.1.7.2. Measure length, areas, bearings and angles interactively

Click the measure icon in the Attribute toolbar to begin measurements. The down arrow near the icon switches between measure length, measureArea area, measureBearing bearing or measureAngle angle. The default unit used in the dialog is the one set in Project ► Properties… ► General menu.

For the Measure Line and the Measure Area the measurements can be done in radioButtonOn Cartesian or radioButtonOn Ellipsoidal measure.

Bemerkung

Configuring the measure tool

While measuring length or area, clicking the Configuration button at the bottom of the widget opens the Settings ► Options ► Map Tools menu, where you can select the rubberband color, the precision of the measurements and the unit behavior. You can also choose your preferred measurement or angle units, but keep in mind that those values are overridden in the current project by the selection made in the Project ► Properties… ► General menu, and by the selection made in the measurement widget.

All measuring modules use the snapping settings from the digitizing module (see section Einrasttoleranz und Suchradius einstellen). So, if you want to measure exactly along a line feature, or around a polygon feature, first set its layer snapping tolerance. Now, when using the measuring tools, each mouse click (within the tolerance setting) will snap to that layer.

The measure Measure Line measures distances between given points. The tool then allows you to click points on the map. Each segment length, as well as the total, shows up in the measure window. In the measure window, you will see coordinates for all your points and distances. Keep in mind that the first row will contain only coordinates, as it represents your starting point. Now it is possible to copy all your line measurements at once to the clipboard using the Copy button. Clicking the Configuration button you will access to Measure Tool Copy Settings where you can set up copy options. To stop measuring, click the right mouse button.

Note that you can use the drop-down list near the total to change the measurement units interactively while working with the measure tool. This unit is retained for the widget until a new project is created or another project is opened.

The Info section in the dialog explains how calculations are made according to the CRS settings available.

../../../_images/measure_line.png

Abb. 11.16 Entfernung messen

measureArea Measure Area: Areas can also be measured. In the measure window, the accumulated area size appears. Right-click to stop drawing. The Info section is also available as well as the ability to switch between different area units.

../../../_images/measure_area.png

Abb. 11.17 Fläche messen

measureBearing Measure Bearing: You can also measure bearings. The cursor becomes cross-shaped. Click to draw the first point of the bearing, then move the cursor to draw the second point. The measurement is displayed in a pop-up dialog.

../../../_images/measure_bearing.png

Abb. 11.18 Measure Bearing

measureAngle Measure Angle: You can also measure angles. The cursor becomes cross-shaped. Click to draw the first segment of the angle you wish to measure, then move the cursor to draw the desired angle. The measurement is displayed in a pop-up dialog.

../../../_images/measure_angle.png

Abb. 11.19 Winkel messen

11.1.8. Weitere Kartenansichten hinzufügen

It is also possible to open additional map views whose content could diverge from the Layers panel current state. To add a new map view, go to View ► newMap New Map View. A new floating widget, mimicking the main map view’s rendering, is added to QGIS. You can add as many map views as you need. They can be kept floating, placed side by side or stacked on top of each other.

../../../_images/map_views.png

Abb. 11.20 Verschiedene Kartenansichten mit unterschiedlichen Einstellungen

Am oberen Rand jeder Kartenansicht befindet sich eine Werkzeugleiste mit den folgenden Möglichkeiten:

  • zoomFullExtent Volle Ausdehnung, zoomToSelected Zu ausgewählten Objekten zoomen und zoomToLayer Auf Layer zoomen um in der Ansicht zu navigieren

  • showPresets Kartenthema der Ansicht setzen, um das Kartenthema zur Anzeige in dieser Kartenansicht auszuwählen. Wenn es auf (keine) eingestellt ist, folgt die Darstellung den Änderungen im :guilabel:`Layer `Bedienfeld.

  • options Ansichtseinstellungen um die Kartenansicht zu konfigurieren:

    • radioButtonOn Ansichtszentrum mit Hauptkarte synchronisieren: synchronisiert die Mitte der Kartenansichten, ohne den Maßstab zu ändern; so können Sie eine Übersichtskarte oder eine vergrößerte Karte erstellen, die der Mitte der Kartenansicht folgt.

    • radioButtonOff Ansicht mit Auswahl synchronisieren: das gleiche wie Zu ausgewählten Objekten zoomen

    • Maßstab

    • Drehung

    • Vergrößerung

    • unchecked Maßstäbe synchronisieren: der Maßstab wird mit dem der Hauptkarte synchron gehalten. Ein Maßstabsfaktor kann dann angegeben werden, so dass Sie eine Ansicht erhalten, die immer z.B. den zweifachen Maßstab der Hauptkarte hat.

    • checkbox Anmerkungen anzeigen

    • checkbox Cursor-Position anzeigen

    • unchecked Hauptkartenausdehnung anzeigen

    • checkbox Beschriftungen anzeigen: erlaubt es die Beschriftungen auszublenden, auch wenn sie in den Einstellungen des Layers aktiviert sind

    • Karten-KBS ändern…

    • Ansicht umbenennen…

11.1.9. Exportieren der Kartenansicht

Die von Ihnen erstellten QGIS-Projekte können als komplexe Layouts oder Berichte in verschiedene Formate exportiert werden. Es ist aber auch möglich, die aktuelle Darstellung in der Kartenansicht direkt zu exportieren, ohne ein zusätzliches Layout. Dieser schnelle „Screenshot“ der Kartenansicht hat einige praktische Funktionen.

Um die aktuellle Darstellung im Kartenfenster zu exportieren, müssen sie folgendes tun:

  1. Gehen sich zum Menü Projekt ► Import/Export

  2. abhängig davon, was Sie exportieren möchten, wählen Sie entweder

    • saveMapAsImage Karte als Bild speichern …

    • oder saveAsPDF Karte als PDF exportieren…

The two tools provide you with a common set of options. In the dialog that opens:

../../../_images/saveMapAsImage.png

Abb. 11.21 The Save Map as Image dialog

  1. Choose the Extent to export: it can be the current view extent (the default), the extent of a layer or a custom extent drawn over the map canvas. Coordinates of the selected area are displayed and manually editable.

  2. Enter the Scale of the map or select it from the predefined scales: changing the scale will resize the extent to export (from the center).

  3. Set the Resolution of the output

  4. Control the Output width and Output height in pixels of the image: based by default on the current resolution and extent, they can be customized and will resize the map extent (from the center). The size ratio can be locked, which may be particularly convenient when drawing the extent on the canvas.

  5. checkbox Draw active decorations: in use decorations (scale bar, title, grid, north arrow…) are exported with the map

  6. checkbox Draw annotations to export any annotation

  7. checkbox Append georeference information (embedded or via world file): depending on the output format, a world file of the same name (with extension PNGW for PNG images, JPGW for JPG, …) is saved in the same folder as your image. The PDF format embeds the information in the PDF file.

  8. When exporting to PDF, more options are available in the Save map as PDF… dialog:

    ../../../_images/saveMapAsPDF.png

    Abb. 11.22 The Save Map as PDF dialog

    • checkbox Export RDF metadata of the document such as the title, author, date, description…

    • unchecked Create Geospatial PDF (GeoPDF): Generate a georeferenced PDF file. You can:

      • Choose the GeoPDF Format

      • checkbox Include vector feature information in the GeoPDF file: will include all the geometry and attribute information from features visible within the map in the output GeoPDF file.

      Bemerkung

      A GeoPDF file can also be used as a data source. For more on GeoPDF support in QGIS, see https://north-road.com/2019/09/03/qgis-3-10-loves-geopdf/.

    • Rasterize map

    • checkbox Simplify geometries to reduce output file size: Geometries will be simplified while exporting the map by removing vertices that are not discernibly different at the export resolution (e.g. if the export resolution is 300 dpi, vertices that are less than 1/600 inch apart will be removed). This can reduce the size and complexity of the export file (very large files can fail to load in other applications).

    • Set the Text export: controls whether text labels are exported as proper text objects (Always export texts as text objects) or as paths only (Always export texts as paths). If they are exported as text objects then they can be edited in external applications (e.g. Inkscape) as normal text. BUT the side effect is that the rendering quality is decreased, AND there are issues with rendering when certain text settings like buffers are in place. That’s why exporting as paths is recommended.

  9. Click Save to select file location, name and format.

    When exporting to image, it’s also possible to Copy to clipboard the expected result of the above settings and paste the map in another application such as LibreOffice, GIMP…