Outdated version of the documentation. Find the latest one here.

.

QGIS Configuration

QGIS is highly configurable through the Settings menu. Choose between Panels, Toolbars, Project Properties, Options and Customization.

Nota

QGIS follows desktop guidelines for the location of options and project properties item. Consequently related to the OS you are using, location of some of items described above could be located in the View menu (Panels and Toolbars) or in Project for Options.

Panels and Toolbars

In the Panels‣ menu, you can switch on and off QGIS widgets. The Toolbars‣ menu provides the possibility to switch on and off icon groups in the QGIS toolbar (see figure_panels_toolbars).

Figure Panels and Toolbars:

../../../_images/panels_and_toolbars.png

The Panels and Toolbars menu nix

Truco

Activating the QGIS Overview

In QGIS, you can use an overview panel that provides a full extent view of layers added to it. It can be selected under the menu nix Settings ‣ Panels or win View ‣ Panels. Within the view is a rectangle showing the current map extent. This allows you to quickly determine which area of the map you are currently viewing. Note that labels are not rendered to the map overview even if the layers in the map overview have been set up for labeling. If you click and drag the red rectangle in the overview that shows your current extent, the main map view will update accordingly.

Truco

Show Log Messages

It’s possible to track the QGIS messages. You can activate checkbox Log Messages in the menu nix Settings ‣ Panels or win View ‣ Panels and follow the messages that appear in the different tabs during loading and operation.

Propiedades del proyecto

In the properties window for the project under nix Settings ‣ Project Properties (kde) or nix win Project ‣ Project Properties (Gnome), you can set project-specific options. These include:

  • In the General menu, the project title, selection and background color, layer units, precision, and the option to save relative paths to layers can be defined. If the CRS transformation is on, you can choose an ellipsoid for distance calculations. You can define the canvas units (only used when CRS transformation is disabled) and the precision of decimal places to use. You can also define a project scale list, which overrides the global predefined scales.
  • El menú SRC habilitado para elegir el Sistema de Referencia de Coordenadas para este proyecto, y para habilitar la reproyección al vuelo de capas ráster y vector cuando se muestran capas de un diferente SRC.

  • With the third Identify layers menu, you set (or disable) which layers will respond to the identify tool (see the “Map tools” paragraph from the Opciones section to enable identifying of multiple layers).
  • The Default Styles menu lets you control how new layers will be drawn when they do not have an existing .qml style defined. You can also set the default transparency level for new layers and whether symbols should have random colours assigned to them. There is also an additional section where you can define specific colors for the running project. You can find the added colors in the drop down menu of the color dialog window present in each renderer.
  • The tab OWS Server allows you to define information about the QGIS Server WMS and WFS capabilities, extent and CRS restrictions.
  • El menú Macros es utilizado para editar macros de Python para proyectos. Actualmente, solo tres macros están disponibles: openProject(), saveProject() and closeProject().

Figure Macro Menu:

../../../_images/macro.png

Macro settings in QGIS

  • El menú Relaciones es utilizado para definir relaciones 1:n. Las relaciones están definidas en el diálogo de propiedades del proyecto. Una vez que existen las relaciones de una capa, un nuevo elemento de la interfaz de usuario en la vista del formulario (por ejemplo al identificar un elemento espacial y abrir el formulario) mostrará una lista de las entidades relacionadas. Este proporciona un poderosa forma para expresar, por ejemplo la inspección de la longitud de una tubería o el segmento de carretera. Se puede encontrar más información acerca de relaciones 1:n y soporte en la sección Creating one to many relations.

Opciones

mActionOptions Some basic options for QGIS can be selected using the Options dialog. Select the menu option Settings ‣ mActionOptions Options. The tabs where you can customize your options are described below.

Menú General

Aplicación

  • Select the Style (QGIS restart required) selectstring and choose between ‘Oxygen’,’Windows’,’Motif’,’CDE’, ‘Plastique’ and ‘Cleanlooks’ (nix).
  • Define the Icon theme selectstring. Currently only ‘default’ is possible.
  • Define the Icon size selectstring.
  • Define the Font. Choose between radiobuttonon Qt default and a user-defined font.
  • Change the Timeout for timed messages or dialogs selectstring.
  • checkbox Ocultar la pantalla de bienvenida al iniciar la aplicación

  • checkbox Mostrar consejos al iniciar

  • checkbox Títulos de cajas de grupos en negrita

  • checkbox Cajas de grupo al estilo QGIS

  • checkbox Utilizar los diálogos de selección de colores nativos

  • checkbox Usar diálogos de selección de color actualizadas en vivo

  • checkbox Estilo de barra lateral personalizado

  • checkbox Apoyo para rotación del lienzo experimental (requiere reiniciar)

Los archivos de proyecto

  • Open project on launch selectstring (choose between ‘New’, ‘Most recent’ and ‘Specific’). When choosing ‘Specific’ use the browsebutton to define a project.
  • checkbox Crear nuevo proyecto desde el proyecto predeterminado. Tiene la posibilidad de presionar Establecer el actual proyecto como predeterminado o sobre Restablecer el predeterminado. Puede navegar a través de sus archivos y definir un directorio donde se encuentra las plantillas definidas por el usuario. Esto se añadirá a Proyecto ‣ Nueva plantilla de formulario. Si activa primero checkbox Crear nuevo proyecto desde proyecto predeterminado y entonces guarde un proyecto en l la carpeta de las plantillas de proyecto.

  • checkbox Solicitar guardar proyectos y fuentes de datos modificadas cuando sea necesario

  • checkbox Pedir confirmación cuando se va a eliminar una capa

  • checkbox Avisar cuando se abra un proyecto guardado con una versión anterior de QGIS

  • Enable macros selectstring. This option was created to handle macros that are written to perform an action on project events. You can choose between ‘Never’, ‘Ask’, ‘For this session only’ and ‘Always (not recommended)’.

Menú Sistema

Entorno

Variables de entorno del sistema ahora se puede ver, y muchos lo configuran en el grupo Entorno (ver figure_environment_variables). Esto es útil para las plataformas, como Mac, donde una aplicación GUI no heredan necesariamente entorno del casco del usuario. También es útil para configurar y visualizar las variables de entorno para los conjuntos de herramientas externas controladas por la caja de herramientas de procesamiento (por ejemplo, SAGA, GRASS), y para activar la salida de depuración para secciones específicas del código fuente.

  • checkbox Utilizar variables personalizadas (requiere reiniciar - incluir separadores). Puede [Añadir] y [Borrar] variables. Las variables de entorno ya definidas se muestran en Variables de entorno actuales, y es posible filtrarlos activando checkbox Mostrar sólo variables de QGIS específicas.

Figure System Environment:

../../../_images/sys-env-options.png

System environment variables in QGIS

Rutas de complemento

[Añadir] o [Borrar] Ruta(s) para buscar librerías de componentes en C++ adicionales

Menú Fuente de datos

Atributos de entidades espaciales y tabla

  • checkbox Abrir tabla de atributos en la ventana adosada (requiere reiniciar QGIS)

  • checkbox Copy geometry in WKT representation from attribute table. When using mActionCopySelected Copy selected rows to clipboard from the Attribute table dialog, this has the result that the coordinates of points or vertices are also copied to the clipboard.
  • Attribute table behaviour selectstring. There are three possibilities: ‘Show all features’, ‘Show selected features’ and ‘Show features visible on map’.
  • Attribute table row cache selectnumber. This row cache makes it possible to save the last loaded N attribute rows so that working with the attribute table will be quicker. The cache will be deleted when closing the attribute table.
  • Representación de valores NULOS. Aquí, puede definir un valor para los datos de campos que tienen un valor NULO.

Manejo de fuente de datos

  • Scan for valid items in the browser dock selectstring. You can choose between ‘Check extension’ and ‘Check file contents’.
  • Scan for contents of compressed files (.zip) in browser dock selectstring. ‘No’, ‘Basic scan’ and ‘Full scan’ are possible.
  • Solicitar subcapas raster al abrir. Algunas subcapas raster soportadas — se les llama subdataset en GDAL. Un ejemplo son los archivos netCDF — si hay muchos variables netCDF, GDAL ve cada variable como un subconjunto de datos. La opción le permite controlar cómo lidiar con subcapas cuando se abre un archivo con subcapas. Dispone de las siguientes opciones:

    • ‘Siempre’: Siempre preguntar (Si hay subcapas existentes)

    • ‘Si es necesario’: Preguntar si la capa no tiene bandas, pero tiene subcapas

    • ‘Nunca’: Nunca preguntar, no se cargará nada

    • ‘Cargar todo’: Nunca preguntar, pero cargar todas las subcapas

  • checkbox Ignore shapefile encoding declaration. If a shapefile has encoding information, this will be ignored by QGIS.
  • checkbox Añadir capas PostGIS con doble clic y seleccionar en modo extendido

  • checkbox Añadir capas de Oracle con doble clic y seleccionar en modo extendido

Menú representación

Rendering behaviour

  • checkbox Por defecto las nuevas capas añadidas al mapa se deben mostrar

  • checkbox Utilizar el cacheo de presentación en lo posible a la velocidad de regeneración

  • checkbox Representación de capas en paralelo utilizando muchos núcleos CPU

  • checkbox Máximo de núcleos a utilizar

  • Intervalo de actualización del mapa (por defecto 250 ms)

  • checkbox Enable feature simplication by default for newly added layers
  • Simplificación del umbral

  • checkbox Simplifique el lado del proveedor si es posible

  • Escala máxima a la que la capa se debe simplificar

Calidad de representación

  • checkbox Hacer que las líneas se muestren menos quebradas a expensas del rendimiento de la representación

Rásters

  • Con Selección de la banda RGB, puede definir el numero para la banda Roja, Verde y Azul.

Mejora de contraste

  • Single band gray selectstring. A single band gray can have ‘No stretch’, ‘Stretch to MinMax’, ‘Stretch and Clip to MinMax’ and also ‘Clip to MinMax’.
  • Multi band color (byte/band) selectstring. Options are ‘No stretch’, ‘Stretch to MinMax’, ‘Stretch and Clip to MinMax’ and ‘Clip to MinMax’.
  • Multi band color (>byte/band) selectstring. Options are ‘No stretch’, ‘Stretch to MinMax’, ‘Stretch and Clip to MinMax’ and ‘Clip to MinMax’.
  • Limits (minimum/maximum) selectstring. Options are ‘Cumulative pixel count cut’, ‘Minimum/Maximum’, ‘Mean +/- standard deviation’.
  • Límite para corte del conteo acumulativo de píxeles

  • Multiplicador de la desviación estándar

Depuración

  • checkbox Refrescar lienzo de mapa

Menú de Colores

Este menú le permite añadir algunos colores personalizados que puede encontrar en cada ventana de diálogo de color de la representación. Verá un conjunto de colores predefinidos en la pestaña: se puede eliminar o editar todos ellos. Por otra parte se puede añadir el color que se desea y realizar algunas operaciones de copiar y pegar. Finalmente se puede exportar el conjunto de colores como un archivo gpl o importarlos.

Menú Vista del mapa y leyenda

Apariencia del mapa predeterminado (anulado por las propiedades del proyecto)

  • Definir un Color de selección y un Color de fondo.

Leyenda de capa

  • Double click action in legend selectstring. You can either ‘Open layer properties’ or ‘Open attribute table’ with the double click.
  • Lo siguiente es posible Estilos de elementos de la leyenda:

    • checkbox Comenzar el nombre de las capas con mayúsculas

    • checkbox Poner en negrita los nombres de la capa

    • checkbox Poner en negrita los nombres de grupo

    • checkbox Mostrar nombres de atributos de clasificación

    • checkbox Crear iconos de ráster (puede ser lento)

Menú Herramientas de mapa

This menu offers some options regarding the behaviour of the Identify tool.

  • Radio de búsqueda para identificar y visualizar avisos en el mapa es un factor de tolerancia expresada como un porcentaje del ancho de mapa. Esto significa que la herramienta de identificación representara los resultados siempre y cuando haga clic dentro de esta tolerancia.

  • Color de realce le permite elegir con que color deben ser identificados los objetos espaciales que están resaltados.

  • Buffer expressed as a percentage of the map width, determines a buffer distance to be rendered from the outline of the identify highlight.
  • Minimum width expressed as a percentage of the map width, determines how thick should the outline of a highlighted object be.

Herramienta de medición

  • Definir Color de la banda de medida para herramienta de medida

  • Definir Lugares decimales

  • checkbox Keep base unit
  • Preferred measurements units radiobuttonon (‘Meters’, ‘Feet’, ‘Nautical Miles’ or ‘Degrees’)`
  • Preferred angle units radiobuttonon (‘Degrees’, ‘Radians’ or ‘Gon’)

Mover y zum

  • Define Mouse wheel action selectstring (‘Zoom’, ‘Zoom and recenter’, ‘Zoom to mouse cursor’, ‘Nothing’)
  • Definir Factor de zum para la rueda del ratón

Escalas predefinidas

Here, you find a list of predefined scales. With the [+] and [-] buttons you can add or remove your individual scales.

Menú Diseñador

Predeterminados de la composición

Se puede definir el Tipo de letra predeterminado aquí.

Apariencia de la cuadrícula

  • Define the Grid style selectstring (‘Solid’, ‘Dots’, ‘Crosses’)
  • Definir el Color de la cuadrícula

Valores predeterminados de la cuadrícula y guía

  • Define the Grid spacing selectnumber
  • Define the Grid offset selectnumber for x and y
  • Define the Snap tolerance selectnumber

Menú Digitalización

Creación de entidades espaciales

  • checkbox Suprimir formulario emergente de atributos después de crear objetos espaciales

  • checkbox Reutilizar últimos valores de atributos introducidos

  • Validate geometries. Editing complex lines and polygons with many nodes can result in very slow rendering. This is because the default validation procedures in QGIS can take a lot of time. To speed up rendering, it is possible to select GEOS geometry validation (starting from GEOS 3.3) or to switch it off. GEOS geometry validation is much faster, but the disadvantage is that only the first geometry problem will be reported.

Banda de medición

  • Definir banda elástica Ancho de línea y Color de línea

Autoensamblado

  • checkbox Abrir opciones de autoensamblado en una ventana adosada(requiere reiniciar QGIS)

  • Define Default snap mode selectstring (‘To vertex’, ‘To segment’, ‘To vertex and segment’, ‘Off’)
  • Definir Tolerancia de autoensamblado predeterminado en unidades de mapa o píxeles

  • Definir el Radio de búsqueda para edición de vértices en unidades de mapa o píxeles

Marcar vértices

  • checkbox Mostrar marcadores sólo para los objetos espaciales seleccionados

  • Define vertex Marker style selectstring (‘Cross’ (default), ‘Semi transparent circle’ or ‘None’)
  • Definir vértice Tamaño de marcador

Herramienta de desplazamiento de curva

The next 3 options refer to the mActionOffsetCurve Offset Curve tool in Digitalización avanzada. Through the various settings, it is possible to influence the shape of the line offset. These options are possible starting from GEOS 3.3.

  • Estilo de la unión

  • Segmentos del cuadrante

  • Límite Miter

Menú GDAL

GDAL es una biblioteca de intercambio de datos para archivos ráster. Es esta pestaña, puede Editar opciones de creación y Editar opciones de pirámides de los formatos ráster. Definir que controlador GDAL se va a utilizar para un formato ráster, como en algunos casos más de un controlador está disponible.

Menú SRC

SRC predeterminado para nuevos proyectos

  • radiobuttonoff Don’t enable ‘on the fly’ reprojection
  • radiobuttonon Automatically enable ‘on the fly’ reprojection if layers have different CRS
  • radiobuttonoff Enable ‘on the fly’ reprojection by default
  • Seleccionar un SRC y Empezar siempre nuevos proyectos con este SRC

SRC para nuevas capas

Esta área permite definir la acción a realizar cuando una nueva capa es creada, o cuando una capa sin SRC es cargada.

  • radiobuttonon Prompt for CRS
  • radiobuttonoff Use project CRS
  • radiobuttonoff Use default CRS

Por defecto transformación de datum

  • checkbox Preguntar por la trasformación del datum cuando el predeterminado no este definido

  • Si ha trabajado con la trasformación de SRC ‘al vuelo’ puede ver el resultado de la transformación en la ventana de abajo. Puede encontrar información acerca de ‘Origen SRC’ y ‘Destino SRC’ así como también ‘Transformación de datum de origen’ y ‘Trasformación de datum destino’.

Menú Idioma

  • checkbox Ignorar el idioma del sistema y Idioma a usar en su lugar

  • Información acerca del idioma del sistema

Menú Red

General

  • Definir Dirección de búsqueda de WMS, por omisión es http://geopole.org/wms/search?search=\%1\&type=rss

  • Definir Expiró el tiempo para solicitudes de red - por omisión 60000

  • Definir Periodo de expiración predeterminada para teselas WMS-C/WMTS (en horas) - por omisión 24

  • Definir Reintentar al máximo en caso de errores en la solicitud de tile

  • Definir Agente- Usuario

Figure Network Tab:

../../../_images/proxy-settings.png

Proxy-settings in QGIS

Configuración de caché

Definir la configuración del caché Directorio y un Tamaño.

  • checkbox Usar proxy para acceso web y definir ‘Servidor’, ‘Puerto’, ‘Usuario’, y ‘Contraseña’.

  • Set the Proxy type selectstring according to your needs.
    • Default Proxy: Proxy se determina con base en el proxy de aplicación que establece el uso

    • Socks5Proxy: Proxy genérico para cualquier tipo de conexión. Soporta TCP, UDP, unión a un puerto (conexiones entrantes) y autenticación.

    • HttpProxy: Implementado con el comando “CONNECT”, sólo admite conexiones TCP salientes; admite la autenticación.

    • HttpCachingProxy: Implementando el uso de comandos HTTP normales, es útil sólo en el contexto de peticiones HTTP.

    • FtpCachingProxy: Implementar el uso de un proxy FTP, es útil sólo en el contexto de las peticiones FTP.

Excluir algunas URLs se puede agregar a la caja de texto debajo los valores del proxy (ver Figure_Network_Tab).

Si necesita más información detallada acerca de las diferentes configuraciones de proxy, consulte el manual de documentación de la biblioteca QT en http://doc.trolltech.com/4.5/qnetworkproxy.html#ProxyType-enum.

Truco

Utilizar proxies

El uso de proxies a veces puede ser complicado. Es útil para proceder por ‘prueba y error’ con los tipos de proxies anteriores, comprobar para ver si en su caso tiene éxito.

You can modify the options according to your needs. Some of the changes may require a restart of QGIS before they will be effective.

  • nix La configuración se guarda en un archivo de texto: $HOME/.config/QGIS/QGIS2.conf

  • osx Puede encontrar sus ajustes en: $HOME/Library/Preferences/org.qgis.qgis.plist

  • win Los ajustes se almacenan bajo el registro: HKEY\CURRENT_USER\Software\QGIS\qgis

Personalización

The customization tool lets you (de)activate almost every element in the QGIS user interface. This can be very useful if you have a lot of plugins installed that you never use and that are filling your screen.

Figure Customization 1:

../../../_images/customization.png

The Customization dialog nix

QGIS Customization is divided into five groups. In checkbox Menus, you can hide entries in the Menu bar. In checkbox Panels, you find the panel windows. Panel windows are applications that can be started and used as a floating, top-level window or embedded to the QGIS main window as a docked widget (see also Panels and Toolbars). In the checkbox Status Bar, features like the coordinate information can be deactivated. In checkbox Toolbars, you can (de)activate the toolbar icons of QGIS, and in checkbox Widgets, you can (de)activate dialogs as well as their buttons.

With mActionSelect Switch to catching widgets in main application, you can click on elements in QGIS that you want to be hidden and find the corresponding entry in Customization (see figure_customization). You can also save your various setups for different use cases as well. Before your changes are applied, you need to restart QGIS.