Outdated version of the documentation. Find the latest one here.

Allgemeine Werkzeuge

Tastenkürzel

QGIS bietet Standard Tastenkürzel für zahlreiche Funktionen. Sie können im Kapitel Menüleiste nachgelesen werden. Zusätzlich ist es aber auch möglich, eigene Tastenkürzel zu definieren und bestehende zu ändern. Öffnen Sie dazu das Menü Einstellungen ‣ Tastenkürzel festlegen.

Figure Shortcuts 1:

../../../_images/shortcuts.png

Tastenkürzel Optionen festlegen

Die Konfiguration ist sehr einfach. Wählen Sie einfach auf eine Eigenschaft von der Liste und klicken Sie auf:

  • [Ändern] und drücken Sie die neue Kombination, der sie eine Verknüpfung zwueisen wollen

  • [Keine einstellen] jede zugewiesene Verknüpfung löschen

  • oder [Standarteinstellung] um die Verknüpfung auf ihre originalen, voreingestellten Werte zurückzusetzen.

Wenn Sie ihre Einstellung gefunden haben, kann diese als XML-Datei abgespeichert und somit auch für eine andere QGIS Installation genutzt werden.

Hilfe

Wenn Sie Hilfe zu bestimmten Themen brauchen erreichen Sie die Kontext-Hilfe über den [Hilfe] Knopf der Ihnen in den meisten Dialogen zur Verfügung steht. Bitte beachten Sie daß Erweiterungen von Drittanbietern zu dementsprechend gewidmeten Internetseiten verweisen.

Layeranzeige kontrollieren

QGIS rendert standardmäßig alle sichtbaren Layer wenn das Kartenfenster aktualisirt werden muss. Die Abläufe, die eine ‘Erneuerung’ der Wiedergabe verursachen sind:

  • Einen Layer hinzufügen

  • Karten verschieben, hinein- oder herauszoomen

  • Größe des QGIS-Fensters verändern

  • Layer ein- oder ausblenden

QGIS ermöglicht es, den Wiedergabeprozess auf verschiedene Arten zu kontrollieren.

Maßstabsabhängige Layeranzeige

Die maßstabsabhängige Wiedergabe erlaubt es, einen mini- und maximalen Maßstab, in dessen Rahmen ein Layer angezeigt wird, anzugeben. Um die maßstabsabhängige Wiedergabe einzustellen öffnen Sie den Eigenschaften Dialog eines Layers, indem Sie diesen in der Legende doppelt anklicken, im Menü Allgemein die entsprechenden Einstellungen vornehmen und das Kontrollkästchen checkbox Maßstabsabhängige Sichtbarkeit aktivieren.

Sie können es einstellen, in dem Sie erst mit der Maus im Kartenfenster den gewünschten Maßstab wählen und dann die Werte aus der Statusleiste übernehmen.

Layeranzeige kontrollieren

Die Kartendarstellung kann wie unten beschrieben auf verschiedene Art und Weise gesteuert werden.

Wiedergabe unterdrücken

Um die Wiedergabe einer Karte zu unterdrücken, klicke Sie auf das Kontrollkästchen checkbox Zeichnen auf der rechten Seite der Statusleiste. Wenn das Kontrollkästchen nicht aktiv ist, führt QGIS keine Erneuerung der Wiedergabe des Kartenfensters durch wie in Abschnitt Layeranzeige kontrollieren beschrieben. Beispiele, bei denen das Unterdrücke der Wiedergabe angewendet wird, sind:

  • Viele Layer hinzufügen und ihre Symbologie vor der Visualisierung einstellen

  • Einen oder mehrere große Layer hinzufügen und erst die maßstabsabhängige Wiedergabe einstellen

  • Einen oder mehrere große Layer hinzufügen und erst in ein bestimmtes Gebiet hineinzoomen

  • Eine Kombination aus den oben genannten Punkten

Wenn Sie die checkbox Zeichnen aktivieren, findet automatisch eine Erneuerung der Wiedergabe des Kartenfensters statt.

Option für Layer hinzufügen

Sie können für das Hinzuladen neuer Layer eine Einstellung vornehmen, die bewirkt, dass diese beim Laden erst einmal nicht angezeigt werden. Um diese Option zu nutzen deaktivieren Sie in der Menüleiste unter Einstellungen ‣ Optionen im Menü Darstellung das Kontrollkästchen checkbox Normalerweise werden alle neuen Layer im Kartenfenster angezeigt. Dadurch werden alle neu geladenen Layer erstmal nicht angezeigt.

Zeichnen stoppen

Um die Wiedergabe einer Karte zu stoppen drücken Sie die ESC Taste. Dies stoppt die Erneuerung der Wiedergabe und die Karte wird nur zum Teil angezeigt. Es kann sein dass etwas Zeit zwischen dem Drücken der Esc Taste und dem Stoppen der Kartenwiedergabe vergeht.

Bemerkung

Es ist derzeit nicht möglich das Zeichnen zu stoppen - diese Funktion wurde mit der Version qt4 ausgeschaltet da es zu Problemen und Abstürzen der Benutzeroberfläche kam.

Die Qualität der Wiedergabe beeinflussen

Um die Wiedergabequalität der Layer zu beeinflussen gibt es drei Möglichkeiten. Öffnen Sie den Reiter Darstellung im Menü Einstellungen ‣Optionen ‣ und aktivieren bzw. deaktivieren Sie checkbox Linien auf Kosten der Zeichengeschwindigkeit weniger gezackt zechnen.

Darstellung beschleunigen

Es gibt zwei Einstellungen die es Ihnen ermöglichen die Darstellungsgeschwindigkeit zu erhöhen. Öffnen Sie den QGIS Optionen Dialog indem Sie Einstellungen ‣ Optionen benutzen, gehen Sie zum Darstellung Menü und aktivieren oder deaktivieren Sie die folgenden Kontrollkästchen:

  • checkbox Wo möglich den Darstellungscache benutzen, um das Neuzeichnen zu beschleunigen

  • checkbox Layer mit vielen CPU-Kernen parallel zeichnen und legen Sie dann die checkbox Max. zu benutzende Kerne fest.

  • Die Karte rendert im Hintergrund auf einem separaten Bild und jedes checkbox Map Update interval, der Inhalt von diesem (Off-Screen) Bild wird durch die sichtbare Bildschirmdarstellung getroffen werden, um aktuell zu bleiben. Wenn das Rendering jedoch schneller ist, als diese Dauer beendet ist, wird es sofort angezeigt.

  • Mit checkbox Enable Feature simplification by default for newly added layers, wird die Objektgeometrie (weniger Knoten) vereinfacht und als Ergebnis, erscheinen Sie schneller. Beachten Sie, dass Sie auch Darstellungsinkonsistenzen begegnen können.

Farbauswahl

Der Farbe auswählen Dialog erscheint, wenn Sie das selectColor Icon drücken, um eine Farbe auszuwählen. Die Merkmale dieses Dialogs hängen von dem Zustand der Use native color chooser dialogs Parameter Checkbox im Einstellungen‣ Optionen ‣ Allgemein Menü ab. Wenn diese Option aktiviert ist, ist der genutzze Farbdialog derjenige, den das OS nutzt. Andernfalls nutzt QGIS eine benutzerdefinierte Farbauswahl.

Der Dialog besitzt 4 verschiedene Reiter, die es Ihnen ermöglichen Farben anhand des colorBox Farbverlauf, colorWheel Farbkreis, colorSwatches Farbproben or colorPicker Farbwahl (nicht unter osx verfügbar).

Egal welche Methode Sie verwenden, die ausgewählte Farbe wird immer durch Farbregler für HSV- (Hue, Saturation, Value) und RGB- (Rot, Blau, Grün) Werte beschrieben. Es gibt auch einen Deckkraft-Regler um den Transparenzgrad einzustellen. Im linken unteren Teil des Dialogs können Sie einen Vergleich zwischen Aktuell und Alt Farbe, die Sie zur Zeit auswählen und im rechten unteren Teil haben Sie die Option eine Farbe hinzuzufügen, aus der Sie gerade einen Farbknopf gemacht haben.

Figure color selector 1:

../../../_images/color_selector_ramp.png

Farbauswahl Verlaufstyp

Tipp

Farbe dynamisch ändern mit der Live-Aktualisierungsfunktion

Aktivieren Sie die Use live-updating color chooser dialogs option in den Allgemeinen Einstellungen um die Farbe auf Ihre Elemente angewendet zu haben, wenn Sie die Farbparameter in dem benutzerdefinierten QGIS Farbauswahldialog ändern.

Mit dem colorBox Farbverlauf oder dem colorWheel Farbkreis, können Sie alle möglichen Farbkombinationen suchen. Dennoch gibt es auch noch andere Möglichkeiten. Indem Sie colorSwatches Farbproben verwenden können Sie aus einer vorausgewählten Liste wählen. Diese ausgewählte Liste wird mit einer von drei Methoden aufgefüllt:

  • Kürzlich verwendete Farben,

  • Standardfarben, eine Nutzer definierte Liste die Sie unter Einstellungen ‣ Optionen ‣ Farben einstellen können

  • or Project colors, eine Nutzer definierte Liste die Sie unter Einstellungen ‣ Projekteigenschaften ‣ Vorgabestile einstellen können.

Figure color selector 2:

../../../_images/color_selector_recent_colors.png

Farbauswahl

Eine andere Option ist die Farbwahl zu benutzen, die es Ihnen ermöglicht eine Farbprobe unter Ihrem Mauszeiger in jedem Teil von QGIS oder sogar von einer anderen Anwendung zu nehmen, indem Sie die Leertaste drücken. Bitte beachten Sie, dass die Farbwahl betriebssystemabhängig ist und aktuell nicht von OSX unterstützt wird.

Tipp

** schnelle Farbwahl + Farben kopieren/einfügen**

Sie können schnell aus Kürzlich verwendete Farben, Standardfarben auswählen oder einfach eine Farbe Kopieren oder Einfügen indem Sie den Drop-down-Pfeil klicken, der einer aktuellen selectColor Farbbox folgt.

Figure color selector 3:

../../../_images/quick_color_selector.png

Schnelle Farbwahl Menü

Mischmodi

QGIS bietet verschiedene Optionen für spezielle Darstellungseffekte, mit diesen Werkzeugen, die Sie bisher nur von Grafikprogrammen kennen. :Index: Mischmodi können auf Layer aufgetragen werden, auf Objekte und auch auf Items der Druckzusammenstellungen:

  • Normal: Dies ist der Standardmischmodus, der den Alphakanal des oben liegenden Pixels mit dem darunter liegenden Pixel vermischt. Die Farben werden nicht vermischt.

  • Heller: Dies wählt das Maximum jeder Komponente der Vordergrund- und Hintergrundpixel. Seien Sie sich bewusst dass die Ergebnisse zackig und hart aussehen können.

  • Bildschirm: Helle Pixel der Quelle werden über die des Ziels gezeichnet, wohingegen dunkle Pixel nicht verwendet werden. Dieser Modus ist am nützlichsten für das Mischen der Textur eines Layers mit einem anderen Layer (z.B. kann man eine Schummerung dazu verwenden einen anderen Layer mit einer Textur zu versehen).

  • Abwedeln: Das Abwedeln erhellt und sättigt unten liegende Pixel auf Basis der Helligkeit des oben liegenden Pixels. Demzufolge erhöhen hellere oben liegende Pixel die Sättigung und Helligkeit des unten liegenden Pixels. Dies funktioniert am Besten wenn die oben liegenden Pixel nicht zu hell sind; andernfalls ist der Effekt zu extrem.

  • Addition: Dieser Mischmodus fügt einfach die Pixelwerte eines Layers denen eines anderen Layers hinzu. Im Falle von Werten größer 1 (im Fall von RGB) wird weiß dargestellt. Dieser Modus ist dafür geeignet Objekte hervorzuheben.

  • Dunkler: Dies erstellt ein Ergebnispixel das die kleinste Komponente der Vordergrund und Hintergrundpixel erhält. Wie das Aufhellen neigen die Ergebnisse dazu zackig und hart zu sein.

  • Multiplizieren: Hier werden die Nummern für jedes Pixel des oben liegenden Layers mit den entsprechenden Pixeln des unteren Layers multipliziert. Das Ergebnis sind dunklere Bilder.

  • Einbrennen: Dunklere Farben im oben liegenden Layer bewirken ein Verdunkeln des unten liegenden Layers. Einbrennen kann dazu benutzt werden um unten liegende Layer zu optimieren und zu kolorieren.

  • Überlagern: Dieser Modus kombiniert die Multiplizieren und Bildschirm Mischmodi. Im Ergebnispixel werden helle Bereiche heller und dunkle Bereiche dunkler.

  • Weiches Licht: Dieses ist dem Überlagern sehr ähnlich nur dass anstelle Multiplizieren/Bildschirm Einbrennen/Abwedeln verwendet wird. Hier soll das Leuchten eines weichen Lichtes auf ein Bild nachgeahmt werden.

  • Hartes Licht: Auch Hartes Licht ist dem Überlagerungsmodus sehr ähnlich. Hier soll die Projektion eines sehr intensiven Lichts auf ein Bild nachgeahmt werden.

  • Unterschied: Unterschied subtrahiert das oben liegende Pixel von dem unten liegenden Pixel oder andersherum um immer einen positiven Wert zu bekommen. Das Mischen mit Schwarz produziert keinen Unterschied, da die Differenz mit allen Farben Null ist.

  • Abziehen: Dieser Mischmodus zieht einfach die Pixelwerte eines Layers von dem anderen ab. Im Fall von negativen Werten wird Schwarz dargestellt.

Zoomen und Karte verschieben

QGIS bietet Werkzeuge zum zoomen oder verschieben des Kartenfensters zu einem Ausschnitt Ihrer Wahl.

Neben den Karte verschieben und ZoomIn| Hineinzoomen / ZoomOut| Hinauszoomen Icons in der Werkzeugleiste können Sie auch mit dem Mausrad, der Leertaste und den Pfeiltasten navigieren.

Mit dem Mausrad im Kartenfenster zoomen und verschieben

Während des Digitalisierens können Sie das Mausrad zum Verschieben innerhalb des Hauptfensters drücken und Sie können das Mausrad zum hinein- und hinauszoomen drehen. Zum Zoomen platzieren Sie den Mauscursor in die Karte und rollen es vorwärts (von Ihnen weg) um hineinzuzoomen und rückwärts (zu Ihnen hin) um herauszuzoomen. Die Position des Mauscursors wird das Zentrum des Sie interessierenden Bereichs sein. Sie können das Verhalten des Mausrad-Zooms anhand des Reiters Kartenwerkzeuge unter Einstellungen ‣ options| Optionen anpassen.

Den Layer mit den Pfeiltasten verschieben

Das Verschieben der Karte während des Digitalisierens ist mit den Pfeiltasten möglich. Platzieren Sie die Maus in das Kartenfenster und klicken Sie auf die rechts-Pfeiltaste um nach Osten zu verschieben, auf die links-Pfeiltaste um nach Westen zu verschieben, auf die aufwärts-Pfeiltaste um nach Norden zu verschieben und die abwärts-Pfeiltaste um nach Süden zu verschieben.

Sie können auch die Leertaste verwenden um vorübergehend Mausbewegungen die die Karte verschieben auszulösen. Die Bild hoch und Bild runter Tasten auf Ihrer Tastatur bewirken bei der Kartenanzeige hinein- oder hinauszuzoomen ohne Ihre Digitalisiersitzung zu unterbrechen.

Messen

QGIS bietet vier Mittel zur Geometriemessung:

  • das interaktive Messen Werkzeug measure,

  • messen in dem calculateField Feldrechner,

  • abgeleitet messen mit dem Identifizieren Werkzeug,

  • und ein Vektoranalyse Werkzeug Vektor ‣ Geometrie-Werkzeuge ‣ Geometriespalten exportieren/hinzufügen

Das Messen funktioniert innerhalb projizierter Koordinatensystemen (z. B. UTM) und unprojizierten Daten. Die ersten drei Messwerkzeuge verhalten gleich, für globale Projekteinstellungen:

Wenn die “on the fly” KBS Transformation aktiviert ist, ist die vorgegebene Metrik - anders als in den meisten anderen GIS - ellipsoid, unter Verwendung der Ellipsoid Definition in Einstellungen ‣ Projekteigenschaften ‣ Allgemein. Das gilt sowohl bei geographischen und projizierten Koordinaten Systemen die für das Projekt definiert sind. Wenn Sie projizierte/planimetrische Flächen oder Distanzen mit kartesischer Mathematik berechnen wollen, muss die Messung Ellipsoid “Keine / Planimetrische” eingestellt werden (Einstellungen ‣ Projekteigenschaften ‣ KBS). Allerdings mit einem geographischen (=unprojizierten) KBS für die Daten und das Projekt, werden Fläche und Distanz Messung Ellipsoid sein. Wenn die “on the fly” KBS Transformation deaktiviert ist, ist die Messmetrik planimetrisch, wenn das Projektkoordinatensystem projiziert ist und ellipsoid, whenn das Projektkoordinatensystem unprojiziert/geographisch ist.

Doch weder das Identifizierungswerkzeug, noch der Feldrechner werden Ihre Daten vor dem Messen in das Projekt KBS transformieren. Wenn Sie dies erreichen wollen, müssen Sie das Vektor Analyse Werkzeug Vektor ‣ Geometrie-Werkzeuge ‣ Geometriespalten exportieren/hinzufügen benutzen. Hier ist die Messung standardmäßig planimetrisch, außer, Sie wählen die ellipsoide Messung.

Strecken, Flächen und Winkel interaktiv messen

Alle Messmodule verwenden die Snapping Einstellungen aus dem Digitalisierungsmodul. Dies ist nützlich, wenn man entlang einer Linie oder Fläche in Vektorebenen messen möchte.

Um ein Meßwerkzeug auszuwählen klicken Sie auf measure und suchen das Werkzeug das Sie benutzen wollen aus.

Voreingestellt measure Linie messen: QGIS kann reale Distanzen zwischen Punkten auf Basis eines vorgegebenen Ellipsoiden messen. Dazu wählen Sie im Menü Einstellungen ‣ Optionen im Menü Kartenwerkzeuge einen Ellipsoiden aus. Es kann außerdem die Gummibandfarbe, die bevorzugte Maßeinheit (Meter oder Fuß) und das bevorzugte Winkelmaß (Grad, Bogenmaß, Gon) in Einstellungen ‣ Optionen ‣ Kartenwerkzeuge eingestellt werden. Das Werkzeug ermöglicht es, Punkte im Kartenfenster auszuwählen. Jedes Längensegment wird in einem Popup angezeigt und zusätzlich auch die Gesamtlänge aller Längensegmente. Um das Messen von Strecken zu beenden, klicken Sie auf die rechte Maustaste. Beachten Sie, dass Sie interaktiv die Maßeinheiten im Messdialog ändern können. Es überschreibt die Bevorzugte Messeinheit in den Optionen. Es gibt einen Info-Bereich in dem Dialog, der zeigt, welche KBS-Einstellungen während der Messung verwendet werden.

Figure Measure 1:

../../../_images/measure_line.png

Entfernung messen

measureArea Fläche messen: Auch Flächengrößen können gemessen werden. Das Popup zeigt dabei die akkumulierte Flächengröße. Zusätzlich schnappt das Meßwerkzeug auf den gerade ausgewählten Layer wenn für den entsprechenden Layer ein Fangmodus eingestellt wurde (siehe Abschnitt Einstellen der Fangtoleranz und des Suchradius). Wenn Sie also exakt entlang einer Linie oder Polygonumrandung messen möchten, setzen Sie erst eine Fangtoleranz und selektieren dann den Layer. Wenn Sie jetzt das Meßwerkzeug benutzen schnappt man mit jedem Mausklick (innerhalb der eingestellten Toleranz) auf den Layer.

Figure Measure 2:

../../../_images/measure_area.png

Fläche messen

measureAngle Winkel messen: Auch Winkel können mit dem Winkel messen- Werkzeug gemessen werden. Der Mauszeiger wird zum Kreuz. Drücken Sie die linke Maustaste und zeichnen Sie das erste Segment des Winkels, klicken nochmals auf die linke Maustaste und messen sie den Winkel, der im Dialogfenster angezeigt wird.

Figure Measure 3:

../../../_images/measure_angle.png

Winkel messen

Objekte auswählen und Auswahl aufheben

Die Werkzeugleiste bietet mehrere Werkzeuge, um Objekte im Kartenfenster auszuwählen. Um ein oder mehrere Objekte auszuwählen, klicken Sie auf select und wählen Sie dann das entsprechende Werkzeug:

  • selectRectangle Objekte über Fläche oder Einzelklick wählen um Objekte entweder durch einfachen Klick oder durch das zeichnen eines Rechtecks auszuwählen

  • selectPolygon Objekte durch Polygon wählen

  • selectFreehand Objekte freihändig wählen

  • selectRadius Objekte durch Radius wählen

Um die Auswahl von Objekten wieder aufzuheben, klicken Sie auf den Knopf deselectAll.

expressionSelect Objekte mit einem Ausdruck wählen ermöglicht es dem Anwender ein Objekt anhand eines Ausdruckdialoges auszuwählen. Siehe auch die Beispiele in Kapitel Ausdrücke .

Anwender können eine Objektauswahl in Neuer Memory-Vektorlayer oder Neuer Vektorlayer anhand von Bearbeiten ‣ Objekte einfügen und Bearbeiten ‣ Objekte einfügen als speichern indem Sie den gewünschten Modus auswählen.

Datendefinierte Übersteuerung Setup

Neben vielen Optionen in dem Vektorlayer Eigenschaften Dialog oder Einstellungen in der Druckzusammenstellung können Sie ein dataDefined Datendefinierte Übersteuerung Icon finden. Dank den Ausdrücken, basierend auf Layerattributen oder Elementeinstellungen, vorgebauten oder selbst erstellen Funktionen und Variablen, ermöglicht Ihnen dieses Werkzeug dynamische Werte für die betroffenen Werte einzustellen. Wenn aktiviert, wird der zurückgegebene Wert dieses Widget angewendet, unabhängig vom normalen Wert (Checkbox, Textbox, Schieber...).

Ein Klick auf den dataDefined Datendefinierte Übersteuerung Knopf zeigt:

  • Beschreibung ..., dass, wenn es aktiviert ist, anzeigt welche Eingabe erwartet wird, gültige Eingabe und die aktuelle Definition,

  • ein verfügbarer Eintrag in der Liste Fieldtyp,

  • ein verfügbarer Eintrag in der Liste Variable,

  • Bearbeiten ... Knopf um Ausdrücke zu erstellen oder zu bearbeiten,

  • Einfügen und Kopieren Knöpfe,

  • Löschen Knopf, um das Setup zu entfernen.

Tipp

Wenn die Datendefinierte Übersteuerung Option nicht richtig konfiguriert ist, ist das Symbol gelb dataDefineOn oder dataDefineExpressionOn, wenn es defekt ist, ist das Icon rot dataDefineError oder dataDefineExpressionError.

Parameter, die mit Daten definierten Werkzeuge verwendet werden können, sind:

  • Stil- und Symbolparameter

  • Beschriftung Parameter

  • Druckzusammenstellung Parameter

Objekte abfragen

Das Objekte abfragen Werkzeug ermöglicht es Ihnen mit dem Kartenfenster zu interagieren und Informationen über Objekte über eine Pop-Up Fenster abzurufen. Um ein Objekt abzufragen verwenden Sie Ansicht ‣ Objekte abfragen oder drücken Sie Strg + Umschalt + I oder klicken Sie auf das identify Objekte abfragen Icon in der Attribut Werkzeugleiste.

QGIS bietet zwei Optionen Objekte zu identifizieren mit dem identify Objekte abfragen Werkzeug:

  • Linksklick identifiziert Objekte gemäß dem eingestellten Modus in dem Identifikationsergebnis Panel

  • Rechtsklick ruft alle sichtbaren Layer ab. Dadurch wird ein Kontextmenü geöffnet, sodass der Benutzer genauer ein abfragendes Objekt auswählen kann.

Wenn Sie auf Objekte klicken gibt der Identifikationsergebnis Dialog die Informationen über die ausgewählten Objekte in einer Liste wieder. Die Standardansicht ist eine Baumansicht, in der das erste Element der Name des Layers ist und die Unterkategorien sind die identifizierten Merkmale. Jede Funktion wird durch den Namen eines Feldes beschrieben, zusammen mit seinem Wert. Dieses Feld wird unter Eigenschaften ‣ Anzeige eingestellt. Dann folgen alle anderen Informationen über das Objekt.

Dieses Fenster kann angepasst werden um benutzerdefinierte Felder anzuzeigen, standardmäßig gibt es drei Arten von Informationen wieder:

  • Aktionen: Aktionen können zum Objekte abfragen Fenster hinzugefügt werden. Wenn Sie dann auf das Aktionen-Icon klicken wird eine Aktion ausgeführt. Standardmäßig wird nur eine Aktion hinzugefügt, nämlich Objektformular anzeigen zum bearbeiten. Sie können mehr Aktionen in den Layereigenschaften festlegen.

  • Abgeleitet: Diese Informationen werden berechnet oder aus anderen Informationen abgeleitet. Dazu gehört auch die Objekt ID, seine Länge oder der Umfang und die Fläche in Karteneinheiten abhängig von der Geometrie, die Anzahl der räumlichen Teile und die Anzahl der angeklickten Teile im Falle von Multi-Geometrie, die Anzahl der Scheitelpunkte in der Funktion und die Anzahl des nächsten angeklickten Punkts. Es berichtet auch die X- und Y- (Z/M falls vorhanden) Koordinatenwerte beider angeklickter Punkte und den nächsten Objektscheitel.

  • Datenattribute: Dies ist die Liste von Attributfeldern und Werten für das Objekt, welches angeklickt wurde.

Figure Identify 1:

../../../_images/identify_features.png

Objekte abfragen Dialog

Am oberen Rand des Fensters gibt es sieben Icons:

  • expandTree Expand tree
  • collapseTree Collapse tree
  • expandNewTree Standardverhalten um festzulegen, ob neben abgefragten Objekten weitere Merkmale angezeigt oder ausgeblendet werden sollen.

  • propertyItem View the feature form
  • deselectAll Ergebnisse leeren

  • editCopy Copy selected feature to clipboard
  • filePrint Print selected HTML response

Unten an dem Fenster haben Sie die Modus und Übersicht Komboboxen. Mit der Modus Kombobox können Sie festlegen von welchem Layer Objekte abgefragt werden sollen:

  • ‘Aktueller Layer’: nur Objekte von dem ausgewählten Layer werden abgefragt. Der Layer ist möglicherweise nicht im Kartenfenster sichtbar.

  • ‘Von oben nach unten, stoppe beim ersten’: nur für Objekte von dem oberen, sichtbaren Layer.

  • ‘Von oben nach unten’: für alle Objekte des sichtbaren Layers. Die Ergebnisse werden im Panel dargestellt.

  • und ‘Layerauswahl’: öffnet ein Kontextmenü, indem der Benutzer den Layer auswählen kann, von dem er Objekte abfragen möchte. Funktioniert wie ein Rechtsklick. Nur die ausgewählten Funktionen werden im Ergebnisfenster angezeigt.

Die Übersicht kann als ‘Baum’, ‘Tabelle’ oder ‘Graph’ eingestellt werden. ‘Tabelle’ und ‘Graph’ Übersichten können nur bei Rasterlayern eingestellt werden.

Das Abfragewerkzeug erlaubt es Ihnen checkboxautomatisch ein Formular öffnen. Wenn diese Option aktiviert ist und ein einzelnes Objekt abgefragt wird, öffnet QGIS ein Formular welches die Attribute zeigt. Dies ist eine praktische Möglichkeit, um schnell die Objektattribute zu bearbeiten.

Andere Funktionen können im Kontextmenü des abgefragten Objekts gefunden werden. Im Kontextmenü können Sie z.B.:

  • Das Objektformular anzeigen

  • Zum Objekt zoomen

  • Objekt kopieren: Kopieren Sie alle Objektgeometrien und -attribute

  • Auswahl des Objekts umkehren: fügt das ausgewählte Objekt der Auswahl hinzu

  • Attributwert kopieren: Kopieren Sie nur den Wert des Attributes auf das Sie klicken

  • Objektattribute kopieren: Kopieren Sie die Attribute des Objekts

  • Ergebnisse löschen: Löschen Sie Ergebnisse im Fenster

  • Hervorhebungen löschen: Entfernen Sie in der Karte hervorgehobene Objekte

  • Alle hervorheben

  • Layer hervorheben

  • Layer aktivieren: Wählen Sie einen Layer der aktiviert werden soll

  • Layereigenschaften ... : Öffnen Sie das Layereigenschaften Fenster

  • Alles ausklappen

  • Alles zusammenfalten

Beschriftungstools

Das textAnnotation Beschriftungstext-Werkzeug in der Atrribut-Werkzeugleiste bietet die Möglichkeit formatierten Text in einer Sprechblase im QGIS Kartenfenster zu platzieren. Aktivieren Sie dazu einfach das Beschriftungstext Werkzeug und klicken Sie in das Kartenfenster.

Figure annotation 1:

../../../_images/annotation.png

Anmerkungstext Dialog

Ein Doppelklick auf das Element öffnet den Dialog mit verschiedenen Optionen. Im Texteditor können Sie den formatierten Text eingeben und einige Einstellungen vornehmen. Z.B. kann das Objekt an einer bestimmten Stelle positioniert werden, was dann durch ein Markersymbol angezeigt wird. Oder das es unabhängig von dem Objekt im Kartenfenster angezeigt wird. Der Text kann entweder durch Verschieben der Markierung oder der Sprechblase im Kartenfenster verschoben werden.

Das annotation Beschriftung verschieben Werkzeug ermöglicht es Ihnen die Beschriftung auf den Kartenfenster zu verschieben.

HTML-Beschriftung

Die formAnnotation HTML-Beschriftung Werkzeuge in der Attribut-Werkzeugleiste ermöglichen es den Inhalt einer HTML-Datei in einer Sprechblase auf dem QGIS-Kartenfenster zu platzieren. Benutzen Sie das HTML-Beschriftung Werkzeug indem Sie ins Kartenfenster klicken und den Pfad zur HTML-Datei in den Dialog einfügen.

SVG-Anmerkung

Das saveAsSVG SVG-Anmerkung Werkzeug in der Attribut-Werkzeugleiste ermöglicht es ein SVG-Symbol in einer Sprechblase auf dem QGIS-Kartenfenster zu platzieren. Um das SVG-Anmerkung Werkzeug zu benutzen klicken Sie in das Kartenfenster und fügen Sie den Pfad zur SVG-Datei in den Dialog ein.

Beschriftungsformular

Zusätzlich können Sie eigene Beschriftungsformulare erstellen. Das formAnnotation Beschriftungsformular Werkzeug ist nützlich um Attribute eines Vektorlayers in einem maßgeschneiderten QT-Designer Beschriftungsformular anzuzeigen (siehe figure_custom_annotation). Es ist ähnlich wie die Designer-Formulare für das Identifizierungswerkzeug, wird aber als Beschriftungstext angezeigt. Siehe auch das Video https://youtu.be/0pDBuSbQ02o?t=2m25s von Tim Sutton für weitere Informationen.

Figure annotation 2:

../../../_images/custom_annotation.png

Benutzerfreundliches QT Designer Beschriftungsformular

Bemerkung

Wenn Sie das Tastenkürzel Ctrl+T drücken während ein Beschriftungswerkzeug aktiv ist ändert sich deren Anzeigestatus zwischen an und aus.

Räumliche Lesezeichen

Räumliche Lesezeichen ermöglichen es, geografische Orte zu markieren und als Lesezeichen abzuspeichern, um dorthin später zurückzufinden. Lesezeichen werden auf dem Computer gespeichert, so dass sie in jedem Projekt auf demselben Computer verfügbar sind.

Ein Lesezeichen erstellen

Um ein Lesezeichen zu erstellen:

  1. Zoomen oder verschieben Sie das Kartenfenster in einen Ausschnitt Ihrer Wahl.

  2. Wählen Sie in der Menüleiste Ansicht ‣ Neues Lesezeichen oder drücken Sie kbd:Ctrl-B. Die räumliche Lesezeichen-Palette öffnet sich mit dem neu angelegten Lesezeichen.

  3. Geben Sie eine Beschreibung für das Lesezeichen ein (bis zu 255 Zeichen).

  4. Drücke Sie Enter um ein Lesezeichen hinzuzufügen oder klicken Sie irgendwo hin.

Sie können mehrere Lesezeichen mit demselben Namen erstellen.

Arbeiten mit Lesezeichen

Um räumliche Lesezeichen zu verwenden oder zu verwalten wählen Sie die Menüoption Ansicht ‣ Lesezeichen anzeigen . Mit dem Räumliches Lesezeichen Panel erlaubt Ihnen:

  • Auf ein Lesezeichen zoomen: wählen Sie das gewünschte Lesezeichen aus und klicken Sie dann Auf Lesezeichen zoomen. Sie können ebenfalls auf ein Lesezeichen zoomen, indem Sie es doppelt anklicken.

  • Löschen eines Lesezeichens: Wählen Sie das Lesezeichen aus und klicken Sie Lesezeichen löschen. Bestätigen Sie anschließend.

  • Importieren oder exportieren Sie ein Lesezeichen: Um diese zu teilen oder Lesezeichen auf andere Computer zu transferieren, können Sie das Lesezeichen Importieren/Exportieren Pull-down-Menü nutzen in dem Räumliche Lesezeichen Dialog. Alle Lesezeichen werden übertragen.

Layer/Gruppen einbinden

Wenn Sie Inhalte von anderen Projekten in Ihr Projekt einbinden wollen wählen Sie Layer ‣ Eingebettete Layer und Gruppen ....

Layer einbetten

Mit dem folgenden Dialog können Sie Layer von anderen Projekten einbetten. Hier ein kleines Beispiel:

  1. Drücken Sie browseButton um nach einem anderen Projekt des Alaskadatensatzes zu suchen.

  2. Wählen Sie die Projektdatei relations.qgs. Sie können hier den Inhalt des Projektes einsehen (siehe figure_embed_dialog).

  3. Klicken Sie Strg und klicken Sie auf die Layer grassland und regions. Klicken Sie [OK]. Die ausgewählten Layer sind jetzt in Legende und Kartenfenster eingebettet.

Figure Nesting 1:

../../../_images/embed_dialog.png

Einzubettende Layer und Gruppen wählen

Währenddessen die Layer editierbar sind können Sie Ihre Eigenschaften wie Darstellung und Beschriftung nicht ändern.

Eingebettete Layer entfernen

Machen Sie einen Rechtsklick auf den eingebetteten Layer und wählen Sie removeLayer Entfernen.

Dekorationen

Die Dekorationen von QGIS umfassen das Gitter, den Urheberrechtshinweis, den Nordpfeil und die Maßstabsleiste. Sie werden zum Dekorieren der Karte durch Hinzufügen von kartografischen Elementen benutzt.

Gitter

transformed Gitter ermöglicht es Ihnen ein Koordinatengitter und Koordinatenbeschriftungen der Karte hinzuzufügen.

Figure Decorations 1:

../../../_images/grid_dialog.png

Der Gitter Dialog

  1. Wählen Sie das Menü Ansicht‣ Dekorationen ‣ Gitter. Der Dialog öffnet sich (siehe figure_decorations_1).

  2. Aktivieren Sie das Kontrollkästchen checkbox Aktiviere Gitter und machen Sie Definitionen gemäß den Layern die Sie ins Kartenfenster geladen haben.

  3. Aktivieren Sie das Kontrollkästchen checkbox Beschriftungen zeichnen und machen Sie Beschriftungsdefinitionen gemäß den im Kartenfenster geladenen Layern.

  4. Klicken Sie [Anwenden] um sicherzugehen, dass es so aussieht wie sie es erwarten oder [OK], wenn Sie zufrieden sind.

Nordpfeil

|north_arrow| Nordpfeil platziert einen einfachen Nordpfeil im Kartenfenster. Bislang steht hierfür lediglich eine Pfeilform zur Verfügung. Sie können die Richtung des Nordpfeiles entweder selbst anpassen oder dies automatisch von QGIS bewerkstelligen lassen. Wenn Sie es QGIS überlassen die Richtung zu bestimmen, entscheidet das Programm, in welche Richtung der Nordpfeil idealerweise zeigen sollte. Sie können die Platzierung des Pfeils durch eine horizontale und/oder vertikale Einstellung verfeinern Marging aus (Canvas) Edge. Diese Werte können in einem Abstand in Millimeter oder Pixel ** oder **Prozentsatz der Breite oder Höhe der Kartenansicht eingestellt sein.

Figure Decorations 3:

../../../_images/north_arrow_dialog.png

Der Nordpfeil Dialog

Maßstab

scaleBar Maßstab fügt einen einfachen Maßstab in das Kartenfenster ein. Sie können Maßstabstil und Platzierung so wie die Beschriftung des Balkens steuern.

Figure Decorations 4:

../../../_images/scale_bar_dialog.png

Der Maßstab Dialog

QGIS unterstützt hierbei jedoch lediglich die Darstellung des Balkens in denjenigen Einheiten, die auch in Ihren entsprechenden Karten verwendet werden. Dies bedeutet, dass Sie einer Karte deren Layer der Einheit Meter entsprechen, keinen Maßstabsbalken in den Einheiten Fuß oder Zoll hinzufügen können.

Das Hinzufügen eines Maßstabbalkens geht folgendermaßen:

  1. Klicken Sie auf Ansicht ‣ Dekorationen ‣ Maßstab. Der Dialog startet (siehe figure_decorations_4).

  2. Versichern Sie sich dass das checkbox Aktiviere Maßstab Kontrollkästchen aktiviert ist.

  3. Wählen Sie den Stil aus der Maßstabsstil selectString Kombobox aus.

  4. Wählen Sie die Farbe für den Balken unter Balkenfarbe selectColor oder benutzen Sie die standardmäßig eingestellte schwarze Farbe.

  5. Legen Sie die Größe des Maßstabs selectNumber fest.

  6. Optional, stellen SIe checkbox Bei Größenänderungen automatisch runde Zahlen einstellen ein, um Zahlen einfach lesar darzustellen.

  7. Wählen Sie die Platzierung aus der Platzierung selectString Kombobox aus.

  8. Sie können die Platzierung des Elements verfeinern durch eine horizontale Einstellung und/oder vertikale Marging from (Canvas) Edge. Diese Werte können in einem Abstand in Millimeter oder Pixel ** oder eingestellt als **Prozentsatz der Höhe oder Breite der Kartenansicht.

  9. Klicken Sie [Anwenden] um sicherzugehen, dass es so aussieht wie sie es erwarten oder [OK], wenn Sie zufrieden sind.

Tipp

Einstellungen von Dekorationen

Wenn Sie ein .qgs -Projekt speichern werden alle bezüglich Nordpfeil, Maßstab und Urheberrechtshinweis gemachten Änderungen im Projekt gespeichert und das nächste Mal wenn das Projekt geladen wird wiederhergestellt

Authentifizierung

QGIS hat die Möglichkeit zum abrufen/speichern von Authentifizierungsinformationen auf sichere Art und Weise. Benutzer können Anmeldeinformationen in Authentifizierungskonfigurationen sicher speichern, die in tragbaren Datenbanken gespeichert sind, können auf Server oder Datenbankverbindungen angewendet werden und sicher durch ihre ID-Token in Projekt oder Einstellungsdateien verwiesen werden. Für weitere Informationen siehe: ref:authentication_index.

Ein Hauptpasswort muss eingerichtet werden, wenn das Authentifizierungssystem und seine tragbare Datenbank initialisiert werden sollen.

Layer als Datei speichern

Layer (Raster oder Vektoren) können mit Speichern als... in ein anderen Format transformiert werden, in dem Layerkontextmenü (durch rechtsklicken auf den Layer in dem Layerbaum) oder in dem Layer ‣ Speichern als... Menü.

Der Speichern als Dialog zeigt verschiedene Parameter die das Verhalten des Layers, beim Speichern, verändern. Gemeinsame Parameter (Raster und Vektor) sind:

  • Format
  • Dateiname

  • KBS

  • Sicherungsdatei zur Karte hinzufügen, um einen neuen Layer zur Kartenansicht hinzuzufügen

  • Ausmaß (mögliche Werte sind Layer, Kartenansicht oder benutzerdefinierte Maße)

  • Erstellen (für Raster) Sie, Layer oder angepasste Optionen, die es Ihnen ermöglichen, einige erweiterte Optionen zu ändern. Erfahrene Nutzer können in der Dokumentation der Treiber in gdal-ogr weitere Informationen finden.

Allerdings sind einige Parameter spezifisch für Raster- und Vektorformate:

  • Raster spezifische Parameter:

    • Auflösung (Horizontal und Vertikal)

    • Pyramidenerzeugung

    • Ausgabemodus (Rohdaten oder gerendertes Bild)

  • Vektor spezifische Parameter:

    • Kodierung

    • Nur gewählte Objekt speichern

    • Attributerzeugung unterdrücken

    • Symbologie-Export: kann vor allem für den DXF-Export und für alle Dateiformate verwendet werden, die OGR-Objektstile verwalten (siehe Hinweis unten) als DXF, KML, Registerkarten Dateiformate:

      • Keine Symbologie: Standardstil der Anwendung, die die Daten liest

      • Objekt-Symbologie: speichert Stile mit OGR-Objektstilen (siehe Hinweis unten)

      • Symbol-Layer-Symbologie: speichert mit OGR-Objektstil (siehe Hinweis unten), aber exportiert die selbe Geometrie mehrfach, wenn mehrere Symbol-Layer-Symbologien benutzt werden

    • Geometrie:

      • Zu Mehrfachgeometrie erzwingen

      • Z-Dimension hinzufügen

      • Hinzufügen oder löschen einer Geometriespalte mit dem Drop-down-Menü. Dies ist nicht mit dem aktuellen Geometrietyp des Layers verbunden. Sie können eine leere Geometriespalte zu einer Attributtabelle hinzufügen, entfernen Sie die Geometriespalte eines räumlichen Layers.

Bemerkung

OGR-Objektstile sind ein Weg, Stile direkt in der Datei als verstecktes Attribut zu speichern. Nur einige Formate können diese Art von Information verarbeiten. KML, DXF und TAB Dateien sind solche Formate. Fortgeschrittene Nutzer, können das OGR Feature Styles specification Dokument lesen.

Bemerkung

Über DXF Dateien

Vektorlayer können in DXF Dateien exportiert werden, nutzen Sie das DXF Exportieren ... Werkzeug, welches sie unter Projekt finden. Dieses Fenster erlaubt es dem Nutzer die Layerdatei, den Symbolmodus (siehe den Hinweis oben), die Symbol Skala, die Codierung, die voreingestellte Sichtbarkeit und den Layer, welcher in die DXF Datei aufgenommen werden soll, auszuwählen.

Als eine Option können Sie checkbox Nutze den Layernamen als Titel oder Exportiere Objekte die die aktuelle Kartenansicht schneiden, wählen.

Verwendung von Variablen für dynamische Inhalte

Sie können benutzerdefinierte Variablen in Ausdruck einstellen. Variablen können bei der Anwendung globaler Ebenen, Projektebenen, Layer-Ebenen und Zusammenstellungsebenen definiert werden. Genau wie CSS Kaskadierungsregeln können Variablen überschrieben werden - z. B. eine Projektebenen-Variable überschreibt alle Anwendungsebenen-Variablen. Sie können diese Variablen verwenden, um Textzeichenfolgen oder andere benutzerdefinierte Ausdrücke mit @ Zeichen vor dem Variablennamen aufzubauen. Zum Beispiel in Druckerstellungen den Inhalt eines Namens:

This map was made using QGIS [% @qgis_version %]. The project file for this
map is: [% @project_path %]

Wird diesen Namen wie folgt darstellen:

This map was made using QGIS 2.14. The project file for this map is:
/gis/qgis-user-conference-2015.qgs

Globale Variabeln können im Menü Einstellungen -> Optionen und Projektvariablen in den Projekteigenschaften verwaltet werden (Auch eigene Variabeln).

Figure Variables dialog 2:

../../../_images/options_variables.png

Variable auf Projektlevel bearbeiten

Bemerkung

Weitere Informationen und Beispiele finden Sie hier Exploring variables in QGIS 2.12, part 1, part 2 and part 3.