Outdated version of the documentation. Find the latest one here.

Editierfunktionen

QGIS unterstützt vielfältige Möglichkeiten OGR, SpatiaLite, PostGIS, MSSQL Spatial und Oracle Spatial Vektorlayer und -tabellen zu editieren.

Bemerkung

Die Vorgehensweise GRASS Layer zu bearbeiten ist anders - siehe Abschnitt Digitalisieren und Editieren eines GRASS Vektorlayers für Details.

Tipp

Zeitgleiches Editieren

Diese Version von QGIS kontrolliert nicht, ob noch jemand ein Objekt zur gleichen Zeit editiert wie Sie. Die zuletzt schreibende Person gewinnt.

Einstellen der Fangtoleranz und des Suchradius

Für eine optimale und präzise Bearbeitung der Vektorlayer Geometrien, müssen wir für Objektknoten einen entsprechenden Wert von Fangtoleranz und den Suchradius einzustellen.

Fangtoleranz

Die Fangtoleranz ist der Abstand den QGIS verwendet um den nächstgelegenen Stützpunkt bzw. das nächstgelegene Liniensegment zu suchen mit dem sie versuchen sich zu verbinden wenn sie einen neuen Stützpunkt setzen wollen oder einen bestehenden Stützpunkt verschieben wollen. Wenn Sie sich nicht innerhalb der definierten Fangtoleranz befinden wird QGIS den Stützpunkt dort lassen wo sich der Mauszeiger gerade befindet anstatt zu einem bestehenden Stützpunkt oder Liniensegment zu snappen. Die Fangtoleranz Einstellungen betreffen alle Werkzeuge die mit Toleranz arbeiten.

  1. Eine globale, projektweite Fangtoleranz kann definiert werden indem Sie Einstellungen ‣ options Optionen auswählen. Im Menü Digitalisierung können Sie zwischen ‘zum Stützpunkt’, ‘zum Segment’ oder ‘Zum Stützpunkt und Segment’ als Standard Fangmodus wählen. Sie können auch eine Voreingestellte Fangtoleranz und einen Suchradius für die Stützpunktbearbeitung definieren. Die Toleranz kann entweder in Karteneinheiten oder in Pixeln eingestellt werden. Der Vorteil wenn man Pixel wählt ist dass die Fangtoleranz sich nicht nach Zoomoperationen verändert. In unserem kleinen Digitalisierprojekt (Arbeiten mit dem Alaskadatensatz) definieren wir die Fangeinheiten in Fuß. Ihre Ergebnisse können variieren etwas in der Größenordnung von 300 ft bei einem Maßstab von 1:10000 sollte eine hinreichende Einstellung sein.

  2. Eine layerbezogene Fangtoleranz, die die globale Fangtoleranz Optionen überschreibt, kann unter Einstellungen ‣ (oder Datei ‣) Fangoptionen ... um den Fangmodus und die Fangtoleranz auf Layerbasis zu ermöglichen und anzupasssen definiert werden (siehe figure_edit_1 ). Der Dialog bietet drei verschiedene Modi, um die zu fangenden Layer auszuwählen:

    • Aktueller Layer: nur der aktuelle Layer wird genutzt, eine praktische Möglichkeit die Topologie abzusichern, während der Layer bearbeitet wird

    • Alle Layer: eine schnelle und einfache Einstellung für alle sichtbaren Layer in dem Projekt, sodass der Zeiger alle Ecken und/oder Segmente fängt. In den meisten Fällen reicht es aus, diesen Fangmodus zu verwenden.

    • Erweitert: Wenn Sie einen Layer bearbeiten wollen und dass seine Stützpunkte zu einem anderen Layer snappen sollen, dann aktivieren Sie das Fangen nur auf den zu snappenden Layer und verringern Sie die globale Fangtoleranz auf einen kleineren Wert. Darüberhinaus wird das Fangen nicht mit einem Layer funktionieren der nicht im Fangoptionen Dialog aktiviert ist, was unabhängig von der globalen Fangtoleranz funktioniert. Vergewissern Sie sich also dass das Kontrollkästchen für die Layer auf die Sie snappen wollen aktiviert ist.

Figure Edit 1:

../../../_images/editProjectSnapping.png

Das Bearbeiten von Snappingoptionen auf Layerbasis (Fortgeschrittener Modus)

Tipp

Steuern Sie die Liste der zu fangenden Layer

Der Dialog Fangoptionen ist standardmäßig mit Parametern bevölkert (Modus, Toleranz, Einheiten) die in dem Reiter Digitalisierung einzustellen sind. Um zu vermeiden, dass Layer standardmäßig überprüft werden im Erweiterten Modus und daher fangbar eingestellt sind, setzen Sie den Standard Fangmodus auf Aus.

Die Fangtoleranz kann in Pixeln oder Karteneinheiten (die Einheit der Kartenansicht) eingestellt werden. Während dem Erweiterten Layer Auswahlmodus, möglich ist eine Fangtoleranz zu nutzen die sich auf die Layereinheiten bezieht, die Einheiten des reprojizierten Layers, wenn ‘on-the-fly’ Transformation aktiviert ist.

Suchradius

Der Suchradius ist der Abstand, den QGIS verwendet, um nach dem nächsten Stützpunkt den Sie versuchen zu verschieben, wenn Sie auf die Karte klicken zu suchen. Wenn Sie sich nicht innerhalb des Suchradius befinden wird QGIS keinen Stützpunkt für das Bearbeiten finden und auswählen. Die Fangtoleranz und der Suchradius werden in Karteneinheiten oder Pixeln eingestellt so dass Sie vielleicht experimentieren müssen um Sie passend einzustellen. Wenn Sie eine zu große Toleranz angeben snappt QGIS zum falschen Stützpunkt, besonders wenn Sie es mit einer großen Anzahl von Stützpunkten in kurzer Distanz zu tun haben. Stellen Sie den Suchradius zu klein ein wird nichts zum Verschieben gefunden.

Der Suchradius für die Stützpunktbearbeitung in Layereinheiten kann im Menü Digitalisierung unter Einstellungen ‣ options Optionen definiert werden. An der gleichen Stellen wo Sie die allgemeine, projektweite Fangtoleranz definieren.

Topologisches Editieren

Abgesehen von der Einstellung des layerbasierten Fangmodus können im Menü Einstellungen ‣ Fangoptionen... (oder Datei ‣ Fangoptionen) auch topologische Funktionen aktiviert werden. Hier können Sie checkbox Topologische Bearbeitung an definieren und/oder für Polygonlayer können Sie die Spalte checkbox Überschn. verm. aktivieren.

Topologisches Editieren ermöglichen

Die Option checkbox Topologische Bearbeitung an dient dem Bearbeiten und Aufrechterhalten von gemeinsamen Grenzen in Objektmosaiken. QGIS ‘erkennt’ gemeinsame Grenzen in Objektmosaiken so, dass Sie einfach den Stützpunkt einmal verschieben müssen und QGIS dann die Aufgabe übernimmt die benachbarten Objekte zu updaten.

Überschneidung neuer Polygone vermeiden

Die zweite topologische Option genannt checkbox Überschneidungen vermeiden verhindert ein Zeichnen von Objekten über ein existierendes. Es dient dazu aneinanderhängende Polygone schneller zu digitalisieren. Wenn Sie bereits ein Polygon erstellt haben ist es mit dieser Option möglich das zweite zu digitalisieren, so dass beide sich überschneiden und QGIS schneidet dann das zweite Polygon gemäß der gemeinsamen Grenze aus. Der Vorteil ist dass Sie nicht alle Stützpunkte der gemeinsamen Grenze digitalisieren müssen.

Bemerkung

Wenn die neue Geometrie vollständig durch bestehende abgedeckt ist, wird sie gelöscht und die neue Funktion wird keine Geometrie haben, wenn vom Anbieter erlaubt, ansonsten werden gespeicherte Änderungen eine QGIS Pop-up Fehlermeldung erzeugen.

Warnung

Überschneidungen vermeiden Option Vorsichtig nutzen

Da die Option Geometrien jedes überschneidenden Objekt jedes Polygonlayers schneidet oder löscht, vergessen Sie nicht, diese Option bei Nichtbenutzung zu deaktivieren, andererseits können Sie unerwartete Geometrien erhalten.

Fang auf Schnittpunkte aktivieren

Ein andere Möglichkeit stellt das checkbox Fang auf Schnittpunkte aktivieren dar. Sie können damit auf einen Schnittpunkt von Hintergrundlayern snappen selbst wenn es keinen Stützpunkt auf dem Schnittpunkt gibt.

Geometrieprüfung

Ein Kern-Plugin, dass dem Anwender hilft, Geometrieungültigkeiten zu finden. Weitere Informationen über diese Plugin erhalten Sie unter Geometrieprüfung Plugin.

Einen vorhandenen Layer editieren

Standardmäßig lädt QGIS Vektorlayer im ‘read-only’ Modus, um ungewolltes Editieren zu verhindern wenn Sie versehentlich die Maus klicken. Ansonsten können aber alle Ebenen editiert werden, wenn es der Datenanbieter erlaubt bzw. die Rechte entsprechend gesetzt sind.

Im Allgemeinen werden die Werkzeuge zum Bearbeiten von Vektorlayern in eine Digitalisierung und eine Erweiterte Digitalisierung Werkzeugleiste aufgeteilt, wie in Abschnitt Erweiterte Digitalisierung beschrieben. Sie können beides unter Einstellungen ‣ Werkzeuge ‣ auswählen oder abwählen. Wenn Sie die grundlegenden digitizing tools verwenden können Sie die folgenden Funktionen ausführen:

Icon

Funktion

Icon

Funktion

allEdits

Aktuelle Änderungen

toggleEditing

Bearbeitungsstatus umschalten

capturePoint

Objekt hinzufügen: Punkt hinzufügen

captureLine

Objekt hinzufügen: Linie hinzufügen

capturePolygon

Objekt hinzufügen: Polygon hinzufügen

moveFeature

Objekt(e) verschieben

circularStringCurvePoint

Kreisbogen hinzufügen

circularStringRadius

Kreisbogen über Radius hinzufügen

nodeTool

Knotenwerkzeug

deleteSelected

Ausgewähltes Löschen

editCut

Ausgewählte Objekte ausschneiden

editCopy

Objekte kopieren

editPaste

Objekte einfügen

saveEdits

Layeränderungen speichern

Tabelle Bearbeiten: Funktionen der Werkzeugleiste Digitalisierung

Beachten Sie, dass Sie während der Nutzung des Digitalisierungswerkzeugs, weiterhin in dem Kartenfenster zoomen oder ziehen können, ohne den Fokus auf das Werkzeug zu verlieren.

Alle Bearbeitung-ssessions beginnen mit dem Aktivieren der Funktion toggleEditing Bearbeitungsstatus umschalten, die Sie im Kontextmenü eines gegebenen Layers, in dem Dialog der Attributtabelle, der Digitalisierungswerkzeugleiste oder dem Menü Bearbeiten finden.

Sobald der Layer im Bearbeitungsmodus ist, werden zusätzliche Werkzeuge verfügbar und Markierungen an den Eckpunkten alles Objekte erscheinen, bis Sie die Markierungen nur für gewählte Objekte anzeigen Option unter Einstellungen ‣ Optionen... ‣ Digitalisierung aktiviert haben.

Tipp

Regelmäßiges Sichern der Daten

Denken Sie daran saveEdits Layeränderungen regelmäßig zu speichern. Dies überprüft auch dass Ihre Datenquelle alle Änderungen akzeptiert.

Objekte digitalisieren

Danach können Sie mit den Icons capturePoint Objekt hinzufügen, captureLine Objekt hinzufügen oder capturePolygon Objekt hinzufügen in der Werkzeugleiste neue Objekte (Punkte, Linien und Polygone) in dem aktuellen Layer hinzufügen.

Die nächsten Knöpfe circularStringCurvePoint Add circular string oder circularStringRadius Add circular string by radius erlaubt Benutzern, Linien- oder Polygon-Features mit einer kreisförmigen Geometrie hinzuzufügen.

Um mit diesen Werkzeugen Objekte erzeugen, wird erst die Geometrie digitalisiert und dann das Attribut hinzugefügt. Um eine Geometrie zu digitalisieren, klicken Sie mit der linken Maustaste an eine gewünschte Stelle im Kartenfenster, um den ersten Punkt zu erstellen.

Für lineare oder gebogene Geometrien, halten Sie die linke Maustaste für jeden weiteren Punkt den Sie erfassen oder verwenden wollen oder nutzen Sie automatische Verfolgung, um die Digitalisierung zu beschleunigen. Sie können zwischen linearen Objekt hinzufügen und gebogenen Add circular string... hin und her schalten, um Geometrien zu erzeugen. Drücken Sie die Entfernen oder Rücktaste, um zum letzten Knoten zurückzukehren. Wenn Sie fertig sind, rechtsklicken Sie irgendwo in dem Kartenfenster und bestätigen Sie.

Bemerkung

Gebogene Geometrien sind als solche nur in kompatiblen Datenanbieter gespeichert

Obwohl QGIS es ermöglicht innerhalb jedes editierbaren Dateiformats gebogene Geometrien zu digitalisieren, müssen Sie einen Datenanbieter nutzen (z. B. PostGIS, GML oder WFS) der gebogene Objekte gespeichert als gebogene Geometrien speichert, ansonsten werden sie als kreisförmige segmentiert,

Tipp

Das Digitalisierungsgummiband anpassen

Während dem Erfassen von Polygonen, kann das voreingestellte rote Band unterliegende Objekte oder Orte verstecken, um einen Punkt zu erfassen. Dies kann durch Einstellen einer geringeren Opazität (oder Alpha-Kanal) des Bands ausgebessert werden Farbe füllen im Menü Einstellungen ‣ Optionen ‣ Digitalisierung. Sie können auch die Verwendung des Gummibands vermeiden Don’t update rubber band during node editing.

Das Attribute Fenster wird erscheinen in dem Sie Informationen für das neue Objekt eingeben können. Figure_edit_2 zeigt die Eingabe von Attributen für einen fiktiven neuen Fluss in Alaska. In dem Menü Digitalisierung unter Einstellungen ‣ Optionen können Sie auch folgende aktivieren:

  • checkbox Attributeingabeformular bei der Objekteerstellung unterdrücken um das Öffnen des Formulares zu vermeiden

  • oder checkbox Letzte Attributwerteingaben wiederverwenden um Felder beim Öffnen automatisch gefüllt zu haben und nur ändernde Werte zu korrigieren.

Figure Edit 2:

../../../_images/editDigitizing.png

Der Attributwertedialog nach dem Digitalisieren eines neuen Vektorobjekts

Mit dem moveFeature Objekt(e) verschieben Icon in der Werkzeugleiste können Sie bestehende Objekte verschieben.

Knotenwerkzeug

Für Shapedatei basierte oder MapInfo Layer genauso wie für SpatialLite, PostgreSQL/Post GIS, MSSQL Spatial und Oracle Spatial Tabellen stellt das nodeTool Knotenwerkzeug Bearbeitungsmöglichkeiten für Stützpunkte ähnlich wie CAD Programme zur Verfügung. Es ist möglich einfach mehrere Stützpunkte auf einmal auszuwählen und diese zu verschieben, hinzuzufügen und alle zusammen zu löschen. Das Knotenwerkzeug funktioniert auch mit angeschalteter ‘Spontan` Reprojektion und unterstützt die topologische Bearbeitungsfunktion. Dieses Werkzeug ist, anders als andere Werkzeuge in QGIS, nachhaltig, so dass wenn eine Operation durchgeführt wird die Auswahl für dieses Objekt und Werkzeug aktiv bleibt.

Es ist wichtig die Eigenschaften unter menuselection:Einstellungen –> options Optionen ‣ Digitalisierung ‣ Suchradius: selectNumber auf eine Zahl größer als Null einzustellen. Andernfalls ist QGIS nicht in der Lage mitzuteilen welcher Stützpunkt bearbeitet werden soll und wird einen Warnhinweis zeigen.

Tipp

Stützpunktmarken

Die aktuelle Version von QGIS unterstützt drei Arten von Stützpunktmarkern:’Teiltransparenter Kreis’, ‘Kreuz’ und ‘Keine’. Um den Markierungsstil zu ändern wählen Sie options Optionen aus dem Einstellungen Menü, klicken Sie auf das Digitalisierung Menü und wählen Sie den entsprechenden Eintrag.

Eine einfache Übung

Beginnen Sie, indem Sie das nodeTool Knotenwerkzeug aktivieren und dann ein Objekt selektieren. Rote Boxen erscheinen an jedem Stützpunkt des Objektes. Nun sind folgende Funktionen vorhanden.

  • Stützpunkte auswählen: Sie können Stützpunkte auswählen indem Sie nacheinander darauf klicken, indem Sie auf eine Ecke klicken um die Stützpunkte an beiden Ecken auszuwählen oder indem Sie ein Rechteck um einige Stützpunkte klicken und ziehen. Wenn ein Stützpunkt ausgewählt ist ändert sich die Farbe zu blau. Um der aktuellen Auswahl mehr Stützpunkte hinzuzufügen halten Sie die Strg Taste beim Klicken gedrückt. Halten Sie Strg gedrückt, wenn Sie Klicken um den Auswahlstatus der Stützpunkte umzuschalten (Stützpunkte die gerade nicht selektiert sind werden wie immer ausgewählt, aber auch Stützpunkte die schon ausgewählt sind werden deselektiert).

  • Stützpunkte hinzufügen: Um einen Stützpunkt hinzuzufügen machen Sie einfach einen Doppleklick in der Nähe einer Ecke und ein neuer Stützpunkt erscheint auf der Ecke in der Nähe des Mauszeigers; deswegen muss er wenn nötig noch verschoben werden.

  • Stützpunkte löschen: Wählen Sie die Stützpunkte und klicken Sie die Entfernen Taste. Das Löschen aller Stützpunkte erzeugt, wenn mit der Datenquelle kompatibel, eine Geometrieloses Objekt. Beachten Sie, dass das nicht das gesamte Objekt löscht, sondern nur den Geometrieteil; um ein vollständiges Objekt zu löschen müssen Sie das deleteSelected Ausgewähltes löschen Werkzeug benutzen.

  • Stützpunkte verschieben:Wählen Sie alle Stützpunkte aus, die verschoben werden sollen. Alle ausgewählten Stützpunkte werden in dieselbe Richtung wie der Mauspfeil verschoben. Wenn eine Fangtoleranz eingestellt ist, können die Stützpunkte zu dem nächstgelegenen Stützpunkt oder Segment snappen.

Jede Veränderung die mit dem Knotenwerkzeug gemacht wurde ist als separater Eintrag im Rückgängig Dialog eingetragen. Beachten Sie dass alle Operationen topologisches Bearbeiten unterstützen wenn dies eingeschaltet ist. Spontanreprojektion wird auch unterstützt und das Knotenwerkzeug erstellt Tooltips um einen Stützpunkt ausfindig zu machen wenn man mit dem Mauszeiger darübergeht.

Tipp

Objekte genau verschieben

Das moveFeature Objekt bewegen Werkzeug erlaubt derzeit kein Fangen von Objekten während der Bewegung. Mit dem nodeTool Knotenwerkzeug, können Sie ALLE Stützpunkte des Objekts wählen, klicken Sie auf einen Stützpunkt, ziehen und fangen Sie ihn zum Zielstützpunkt: das gesamte Objekt wird bewegt und zu einem anderen Objekt gesnappt.

Die Stützpunktbearbeitung

Durch Aktivieren des Knotenwerkzeug auf ein Objekt, wird durch QGIS die Stützpunktbearbeitung geöffnet mit einer Liste aller Stützpunkte des Objekts und seinen X-,Y- (Z-, M- falls zutreffend) Koordinaten und R (für den Radius, bei Kreisgeometrie). Wählen Sie einfach die entsprechenden Knoten in dem Kartenfenster und umgekehrt eine Zeile in der Tabelle. Ändern Sie einfach eine Koordinate in der Tabelle und der Stützpunkt wird aktualisiert. Sie können ebenso mehrere Reihen auswählen und diese löschen.

Figure Edit 3:

../../../_images/vertex_editor_panel.png

Stützpunktbearbeitungsbedienfeld mit ausgewählten Knoten

Objekte ausschneiden, kopieren und einfügen

Ausgewählte Objekte können ausgeschnitten, kopiert und an andere Ebenen im aktuellen QGIS-Projekt übergeben (eingefügt) werden, wenn sich der Ziellayer auch im Editiermodus befindet, indem Sie nach Auswahl des Ziellayers auf den Knopf toggleEditing Bearbeitungsstatus umschalten klicken.

Tipp

Polygone in Linien und umgekehrt transformieren mit copy/paste

Kopieren Sie ein Linienobjekt und fügen Sie ihn in ein Polygonlayer ein: QGIS fügt ihn in den Ziellayer dessen Begrenzung am nächsten der Geometrie des Linienobjekts entspricht. Dies ist ein einfacher Weg, um verschiedene Geometrien der selben Daten zu erzeugen.

Objekte können an externe Anwendungen als Text abgelegt werden. Dabei werden die Objekte im CSV-Format dargestellt und die Geometriedaten im OGC Well-Know Text (WKT) Format. WKT-Objekte außerhalb von QGIS können ebenso auf einen Layer innerhalb von QGIS eingefügt werden.

Aber wann macht es Sinn, Objekte zum kopieren, auszuschneiden und einzufügen? Ein Beispiel ist, wenn Sie parallel an mehreren Layern arbeiten und Objekte zwischen den Layern hin- und herkopieren möchten. Ein Szenario könnte sein, dass Sie einen neuen Layer erstellen möchten, in dem aber nur einige Objekte aus einem bereits existierenden Layer verwendet werden sollen, wie etwa 5 Seen aus der Karte lakes.shp , die insgesamt aber tausende Seen enthält.

Als Beispiel werden wir einige Seen in einen neuen Layer kopieren:

  1. Laden Sie den Layer, von dem Sie einige Objekte kopieren wollen (Quelle)

  2. Laden oder erstellen Sie einen Layer, in den die kopierten Objekte eingefügt werden sollen (Ziel)

  3. Schalten Sie für den Ziel Layer den Bearbeitungsstatus ein

  4. Stellen Sie die Quelle aktiv, indem Sie es in der Legende anklicken

  5. selectRectangle Objekte über Fläche oder Einzelklick wählen um Objekte aus dessen Quelllayer zu wählen

  6. Klicken Sie auf das Icon editCopy Objekte kopieren

  7. Stellen Sie das ‘Ziel’ aktiv, indem Sie es in der Legende anklicken

  8. Klicken Sie auf das Icon editPaste Objekte einfügen

  9. Beenden Sie den Bearbeitungsstatus für beide Layer und speichern Sie das Ergebnis ab

Was passiert, wenn der Quell- und Ziellayer ein unterschiedliches Schema enthält (Spaltennamen und -typen unterscheiden sich)? QGIS verwendet die Einträge, die gleich sind und ignoriert den Rest. Wenn es Ihnen egal ist, ob die Attribute korrekt übernommen werden, dann ist es egal, wie Sie die Spaltennamen und -typen der Attributtabelle erstellen. Wenn auch die Attributdaten korrekt übernommen werden sollen, dann stellen Sie sicher, dass auch die Spaltennamen und -typen beider Layer zueinander passen.

Bemerkung

Deckungsgleichheit eingefügter Objekte

Wenn Ihre Quell- und Ziellayer die gleiche Projektion verwenden dann haben die eingefügten Objekte die identische Geometrie wie der Quellayer. Wenn der Ziellayer jedoch eine andere Projektion hat dann kann QGIS nicht garantieren dass die Geometrie identisch ist. Dies ist einfach aus dem Grund so, dass sich kleine Rundungsfehler ergeben wenn zwischen Projektionen konvertiert wird.

Tipp

Zeichenketten Attribut in ein anderes kopieren

Wenn Sie eine neue Spalte in die Attributtabelle mit dem Typ ‘string’ erstellt haben und die Werte von einer anderen Attributspalte einfügen, die eine größere Länge als die Länge der Spaltengröße hat, wird diese auf den gleichen Betrag verlängert werden. Dies ist so, weil der GDAL Shapedatei Driver beginnend ab GDAL/OGR 1.10 String und Integer Fehler auto-erkennt und die Felder auf die benötigte Länge der eingefügten Daten anpasst.

Ausgewählte Objekte löschen

Wenn Sie ein gesamtes Objekt (Attribut und Geometrie) löschen wollen, können Sie das tun, indem Sie zunächst die Geometrie der selectRectangleObjekte über Fläche oder Einzelklick wählen auswählen. Die Auswahl kann auch über die Attributtabelle erfolgen. Sobald Sie die Auswahl festgelegt haben, drücken Sie :knd:`Entfernen` oder Rücktaste oder nutzen Sie deleteSelected Ausgewähltes löschen um Objekte zu löschen. Mehrfachauswahlen können ebenso auf einmal gelöscht werden.

Das Werkzeug editCut Ausgewählte Objekte ausschneiden kann auch benutzt werden, um Objekte zu löschen. Die Objekte werden gelöscht aber zusätzlich noch im ‘spatial clipboard’ abgelegt. In diesem Fall könnte man dann den letzten Schritt, falls ein Fehler unterlaufen ist, wieder rückgängig machen, indem wir auf das Werkzeug editPaste Objekte einfügen drücken. Ausschneiden, kopieren und übergeben von Objekten funktioniert mit den gerade ausgewählten Objekten und können nach Bedarf kombiniert verwendet werden.

Änderungen speichern

Wenn ein Layer im Bearbeitungsmodus ist behält QGIS alle Änderungen im Speicher. Aus diesem Grund werden diese nicht umgehend der Datenquelle oder -platte übermittelt. Wenn Sie Bearbeitungen in dem aktuellen Layer speichern wollen aber mit dem Bearbeiten fortfahren wollen ohne den Bearbeitungsmodus verlassen zu wollen können Sie den saveEdits Layeränderungen speichern Knopf klicken. Wenn Sie den Editiermodus mit toggleEditing Bearbeitungsstatus umschalten aussschalten wollen werden Sie ebenfalls gefragrt ob Sie Ihre Änderungen speichern oder verwerfen wollen.

Wenn die Änderungen nicht gespeichert werden können (z.B. weil die Festplatte voll ist oder Attribute Werte aufweisen, die außerhalb der Wertespanne liegen), bleiben die Änderungen erstmal im QGIS Arbeitsspeicher. Dies ermöglicht es, Änderungen vorzunehmen und dann nochmals die Daten zu speichern.

Tipp

Datenintegrität

Es ist immer gut ein Backup von Ihren Daten zu machen bevor Sie mit dem Bearbeiten starten. Während die Autoren von QGIS sich bemühen die Integrität Ihrer Daten zu bewahren bieten wir keine Garantie in dieser Hinsicht.

Mehrere Layer auf einmal speichern

Mit dieser neuen Funktion können Sie mehrere Layer digitalisieren. Wählen Sie fileSaveAs Layeränderungen speichern um alle Änderungen, die Sie in mehreren Layern gemacht haben, zu speichern. Sie haben auch die Möglichkeit rollbackEdits Verwerfen für gewählte Layer zu benutzen so dass die Digitalisierung für alle selektierten Layer rückgängig gemacht werden kann. Wenn Sie das Bearbeiten der selektierten Layer beenden wollen kann man das einfach mit der Funktion cancelEdits Abbruch für gewählte Layer erreichen.

Die gleichen Funktionen sind für das Bearbeiten aller Layer des Projektes zugängig.

Erweiterte Digitalisierung

Icon

Funktion

Icon

Funktion

cad

Erweiterte Digitalsierungswerkzeuge einschalten

tracing

Spurverfolgung einschalten

undo

Rückgängig

redo

Wiederholen

rotateFeature

Objekt(e) drehen

simplifyFeatures

Objekt vereinfachen

addRing

Ring hinzufügen

addPart

Teil hinzufügen

fillRing

Ring füllen

deleteRing

Ring löschen

deletePart

Teil löschen

reshape

Objekte überarbeiten

offsetCurve

Linie versetzen

splitFeatures

Objekte trennen

splitParts

Teile zerlegen

mergeFeatures

Gewählte Objekte verschmelzen

mergeFeatAttributes

Attribute gewählter Objekte vereinen

rotatePointSymbols

Punktsymbole drehen

Tabelle Erweiterte Digitalisierung: Werkzeugleiste Erweiterte Digitalisierung für Vektorlayer

Rückgängig und Wiederholen

Mit dem undo Rückgängig und redo Wiederholen Werkzeug können Sie Vektorbearbeitungsoperationen rückgängig machen oder wiederholen. Es gibt auch ein andockbares Bedienfeld das alle Operationen in der Rücknahme/Wiederholung History zeigt (siehe Figure_edit_4). Dieses Bedienfeld wird nicht standardmäßig angezeigt; es kann kann angezeigt werden indem man auf die Werkzeugleiste klickt und das Rücknahme/Wiederholung Kontrollkästchen aktiviert. Rücknahme/Wiederholung ist auch dann noch aktiv wenn das Bedienfeld nicht angezeigt wird.

Figure Edit 4:

../../../_images/redo_undo.png

Rückgängig und Wiederholen von Digitalisierschritten

Wenn Rückgängig oder Strg+z (oder:kbd:Cmd+z) gedrückt wird wird der Status aller Objekte und Attribute auf den Status bevor die zurückgenommene Aktion durchgeführt wurde zurückgesetzt. Änderungen die keine normalen Vektorbearbeitungsoperationen sind (z.B. Änderungen die durch ein Plugin durchgeführt werden) können oder können nicht rückgängig gemacht werden. Dies hängt davon ab wie die Änderungen durchgeführt werden.

Wenn Sie Rücknahme/Wiederholung verwenden wollen klicken Sie einfach auf eine Operation in der History; alle Objekte werden dann auf den Stand vor der ausgewählten Operation zurückgesetzt.

Objekt(e) drehen

Verwenden Sie rotateFeatureObjekt(e) drehen um ein oder mehrere ausgewählte Objekte in der Kartenansicht zu drehen. Sie müssen erst das Objekt auswählen und dann das rotateFeatureObjekt(e) drehen Icon drücken. Klicken Sie entweder auf der Karte das Drehung-Symbol oder geben Sie einen Winkel in dem Benutzerinterface ein. Wenn Sie mehrere Objekte drehen möchten, müssen sie diese zuerst auswählen.

Wenn Sie die Kartenwerkzeuge mit ausgewählten Objekten aktivieren, erscheinen ihre Schwerpunkte und wird der Drehankerpunkt sein. Wenn Sie den Drehankerpunkt bewegen möchten, halten Sie Strg und klicken Sie auf die Karte um diesen zu platzieren.

Wenn Sie Shift vor dem Klick auf die Karte halten, wird die Drehung in 45 Grad Schritten erfolgen, was anschließend in dem Benutzerinterface-Widget bearbeitet werden kann.

Zum Abbrechen der Objektdrehung, müssen Sie auf das rotateFeature Objekt(e) drehen Icon klicken.

Objekt vereinfachen

Das simplifyFeatures Objekte vereinfachen Werkzeug erlaubt Ihnen die Anzahl der Eckesn eines Objekts, so lange die Geometrie gültig bleibt, zu reduzieren. Mit dem Werkzeug können Sie einfach viele Objekte auf einmal oder mehrteilige Objekte vereinfachen.

Zuerst, klicken Sie auf das Objekt oder ziehen Sie ein Rechteck über das Objekt. Ein Dialog öffnet sich, dort können Sie die Toleranz in Karteneinheiten, Layereinheiten oder Pixeln und eine Farbe und eine vereinfachte Kopie des Objekts, mit der gegebenen Toleranz, einstellen und es erscheint über dem eigentlichen Objekt. QGIS berechnet die Menge von Eckpunkten, die gelöscht werden können, während die Geometrie beibehalten wird. Je höher die Toleranz ist, desto mehr Eckpunkte können gelöscht werden. Wenn die erwartete Geometrie Ihren Bedürfnissen entspricht, klicken Sie einfach [OK]. Die genutzte Toleranz wird bei Beendigung des Projekts oder dem Verlassen des Editiermodi gespeichert. So können Sie einfach zur selben Toleranz zurückkehren, wenn Sie das nächste Mal Objekte vereinfachen.

Zum Abbrechen der Objektvereinfachung, müssen Sie auf das simplifyFeatures Objekt(e) vereinfachen Icon klicken.

Bemerkung

im Gegensatz zur Objektvereinfachung im Menü Einstellungen ‣ Optionen ‣ Darstellung, welches die Geometrie nur zur Darstellung vereinfacht, bearbeitet das simplifyFeatures Objekt(e) vereinfachen Werkzeug die Geometrie in der Datenquelle.

Teil hinzufügen

Sie können zu einem ausgewählten Objekt einen addPart Teil hinzufügen, das erzeugt Multipunkt, Multilinie oder Multipolygon Objekte. Der neue Teil muss außerhalb eines existierenden digitalisiert werden.

Der addPart Teil hinzufügen Knopf kann ebenfalls benutzt werden, um eine Geometrie zu einem Geometrielosen Objekt hinzuzufügen. Zuerst, wählen Sie das Objekt in der Attributtabelle und digitalisieren Sie eine neue Geometrie mit dem Teil hinzufügen Werkzeug.

Teil löschen

Mit dem deletePart Teil löschen Werkzeug können Teile eines Multi-Feature Objektes gelöscht werden (z.B. ein Polygon von einem Multipolygon Objekt löschen). Das Werkzeug funktioniert mit allen Multi-Feature Geometrien Punkte, Linien und Polygone. Weiterhin kann es verwendet werden, um vollständig die geometrische Komponente eines Objekts zu entfernen. Um einen Teil löschen, klicken Sie einfach in den Zielteil.

Ring hinzufügen

Sie können Ring-Polygone mit dem Werkzeug addRing Ring hinzufügen erstellen. Das bedeutet, dass Sie innerhalb eines bestehenden Polygons weitere Polygone digitalisieren können. Diese erscheinen dann als ‘Loch’, so dass nur der Zwischenraum des inneren und des äußeren Polygons als Ring-Polygon übrig bleibt.

Ring füllen

Sie können die fillRing Ring füllen Funktion verwenden um gleichzeitig einen Ring in ein Polygon einzufügen und dem Layer ein neues Objekt zuzufügen. Mit diesem Tool, können Sie einfach ein Polygon innerhalb eines anderen digitalisieren. So brauchen Sie nicht erst das addRing Ring hinzufügen Icon und dann die capturePolygon Objekt hinzufügen Funktion benutzen.

Ring löschen

Das Werkzeug deleteRing Ring löschen ermöglicht es, Ringpolygone innerhalb eines existierenden Fläche zu löschen. Das Werkzeug funktioniert nur mit Polygon- und Multipolygonlayern. Es findet keine Veränderung statt, wenn es auf den äußeren Ring eines Polygons angewendet wird.

Objekte überarbeiten

Die Geometrien von Linien und Polygonen können mit dem Werkzeug reshape Objekt überarbeiten verändert werden. Dabei ersetzt die gezogene Linie die originale Linie oder Flächenlinie eines Objektes von der ersten bis zur zweiten Überschneidung. Für Polygone kann dies manchmal zu unerwünschten Resultaten führen und ist vorwiegend sinnvoll, wenn man nur kleinere Teile einer Fläche ersetzen möchte und nicht für eine vollständige Überarbeitung. Dabei ist es für die Vereinfachungslinie auch nicht erlaubt, mehrere Polygongrenzen zu überschneiden.

Als Beispiel können Sie die Grenze eines Polygons mit diesem Tool bearbeiten. Klicken Sie als erstes in die Fläche des Polygons neben den Punkt wo Sie den neuen Stützpunkt hinzufügen wollen. Dann überqueren Sie die Grenze und fügen sie Stützpunkte außerhalb des Polygons ein. Machen Sie einen Rechtsklick in die Fläche des Polygons zum Vervollständigen. Das Werkzeug wird automatisch einen Knoten an der Stelle wo die neue Linie die grenze kreuzt hinzufügen. Es ist auch möglich einen Teil der Polygonfläche zu entfernen indem man außerhalb des Polygons anfängt, Stützpunkte innerhalb des Polygons hinzufügt und außerhalb des Ploygons mit einem Rechtklick aufhört.

Bemerkung

Das Objekte überarbeiten Werkzeug kann die Startposition eines Polygonringes oder einer geschlossenen Linie verändern. Der Punkt, der zweimal abgebildet ist wird also nicht mehr der gleiche sein. Dies mag kein Problem für die meisten Anwendungen sein, sollte aber beachtet werden.

Linie versetzen

Das offsetCurve Linie versetzen Werkzeug erstellt parallele Linien von Linienlayern. Das Werkzeug kann auf den bearbeiteten Layer (die Geometrien werden verändert) und auch auf Hintergrundlayer (in diesem Fall erstellt es Kopien von Linien/ Ringen und fügt Sie dem bearbeiteten Layer hinzu) angewendet werden. Es ist auf diese Weise ideal geeignet Abstandslinienlayer zu erstellen. Der Benutzereingabe Dialog erscheint und zeigt den Versatz.

Um einen Versatz eines Linienlayers zu erstellen müssen Sie erst in den Bearbeitungsmodus gehen und das offsetCurve Offset Curve Werkzeug aktivieren. Klicken Sie dann auf ein Objekt, um es zu verschieben. Bewegen Sie die Maus und klicken Sie, wo Sie es haben wollen oder geben Sie die gewünschte Distanz in der Benutzereingabe ein. Ihre Änderungen können dann mit dem saveEditsLayeränderungen speichern Werkzeug gespeichert werden.

Der QGIS Optionen Dialog (Digitalisierung Reiter dann Werkzeug zum Linien versetzen Abschnitt) ermöglicht es Ihnen einige Parameter wie Verbindungsstil,**Quadrantsegmente**, Eckengrenze zu konfigurieren.

Objekte trennen

Objekte können mit dem Werkzeug splitFeatures Objekt teilen geteilt werden. Zeichnen Sie dazu einfach eine Linie durch das Objekt, das Sie teilen wollen.

Teile zerlegen

In QGIS ist es möglich die Teile eines Multi-Part Features zu zerlegen so dass die Anzahl der Teile sich erhöht. Zeichnen Sie einfach eine Linie über den Teil den Sie zerlegen wollen indem Sie dafür das splitParts Teile zerlegen Icon verwenden.

Gewählte Objekte verschmelzen

Mit dem mergeFeatures Gewählte Objekte verschmelzen Werkzeug können Sie Objekte verschmelzen, die gemeinsame Grenzen haben. Mit einem neuen Dialog können Sie auswählen welcher Wert zwischen jedem ausgewählten Objekt gewählt wird oder eine Funktion auswählen (Minimum, Maximum, Mittel, Summe, Attribut überspringen), die für jede Spalte benutzt werden soll, auswählen. Wenn Objekte keine gemeinsame Grenze haben, wird ein Multipolygon erzeugt.

Attribute gewählter Objekte vereinen

Mit dem mergeFeatAttributes Attribute gewählter Objekte vereinen Werkzeug können Sie Attribute von Objekten vereinen die gemeinsame Grenzen und Attribute haben ohne Ihre Grenzen zu vereinen. Wählen Sie zuerst mehrere Objekte auf einmal aus. Drücken Sie dann den mergeFeatAttributes Attribute gewählter Objekte Knopf. Jetzt fragt Sie QGIS welche Attribute auf alle ausgewählten Objekte angewendet werden sollen. Im Ergebnis haben alle ausgewählten Objekte die gleichen Attributeinträge.

Punktsymbole drehen

Mit rotatePointSymbols Punktsymbole drehen können Sie die Rotation von Punktsymbolen in der Kartenansicht verändern. Sie müssen erst ein Drehungsfeld in der Attributtabelle des Punktlayers im Erweitert Menü des Stil Menü der Layereigenschaften definieren. Sie werden auch nach ‘SVG Markierung’ gehen müssen und Datendefinierte Eigenschaften ... wählen. Aktivieren Sie checkbox Winkel und wählen Sie ‘Drehung’ als Feld. Ohne diese Einstellungen ist das Werkzeug inaktiv.

Figure Edit 5:

../../../_images/rotatepointsymbol.png

Punktsymbole drehen

Um die Drehung zu ändern, wählen Sie einen Punkt im Kartenfenster aus und drehen diesen, indem Sie die linke Maustaste gedrückt halten. Ein roter Pfeil mit dem Drehwinkel wird dann angezeigt (siehe Figure_edit_5). Wenn Sie die linke Maustaste wieder loslassen, wird der neue Wert in der Attributtabelle aktualisiert.

Bemerkung

Wenn Sie zusätzlich die Strg-Taste gedrückt halten, findet die Drehung in 15 Grad Schritten statt.

Automatische Verfolgung

Normalerweise, wenn Sie Erfassungs-Kartenwerkzeuge (Objekt hinzufügen, Teil zinzufügen, neu gestalten und aufteilen) nutzen, müssen Sie jede einzelne Ecke des Objekts anklicken.

Mit dem automatischen Verfolgungsmodus können Sie den Digitalisierungsprozess beschleunigen. Aktivieren Sie das tracing Verfolgung Werkzeug durch anklicken des Icons oder drücken Sie die T Tastend :ref:`snap to <snapping_tolerance>`einem Stützpunkt oder Segment des Objekts, dem Sie folgen möchten. Bewegen Sie die Maus über einen anderen Stützpunkt oder ein anderes Segment, das Sie fangen möchten und anstelle einer üblichen geraden Linie, repräsentiert das Digitalisierungsgummiband einen Pfad vom letzten gefangenen Punkt zur aktuellen position. QGIS verwendet tatsächlich die dem Objekt zugrundeliegende Topologie, um den kürzesten Pfad zwischen den beiden Punkten zu bauen. Klicken Sie und QGIS platziert die Zwischenecke, dem Pfad folgend. Sie müssen nicht mehr manuell alle Eckpunkte während der Digitalisierung platzieren.

Verfolgung erfordert Fangen um in rückverfolgbaren Layern aktiviert zu werden, um den Weg zu bauen. Sie sollten auch auf eine existierende Ecke oder ein Segment snappen während dem Digitalisieren und sicherstellen, dass die beiden Knoten topologisch anschließbar sind zu den folgenden existierenden Objekten, ansonsten ist QGIS nicht in der Lage sie zu verbinden und dadurch verfolgt es eine einzelne gerade Linie.

Bemerkung

Justieren Sie den Kartenmaßstab oder die Fangeinstellungen für eine optimale Verfolgung

Wenn zu viele Objekte in der Karte gezeigt werden, ist Verfolgung möglicherweise deaktiviert, um potentielle langsame Verfolgung und große Speicherzuschläge zu vermeiden. Nach dem hereinzoomen oder dem ausblenden einiger Layer, ist die Funktion wieder aktiviert.

Tipp

Schalten Sie schnell zwischen automatischer Verfolgung hin und her, indem Sie :kbd:`T` drücken

Durch Drücken der t Taste, können Sie Verfolgen an- und ausschalten jedes mal, wenn Sie ein Objekt digitalisieren, so ist es mögliche einige Teile mit aktiviertem Verfolgen und andere mit deaktiviertem Verfolgen zu digitalisieren. Die Werkzeuge verhalten sich normal, wenn Verfolgen aktiv ist.

Das erweiterte Digitalisierungsfenster

Wenn neue Geometrien oder Geometrieteile erfasst werden, haben Sie auch die Möglichkeit, das erweiterte Digitalisierungsbedienfeld zu verwenden. Sie können Linien exakt parallel oder in einem bestimmten Winkel digitalisieren oder Linien auf bestimmten Winkeln sperren. Darüber hinaus können Sie Koordinaten direkt eingeben, so dass Sie eine genaue Definition für die neue Geometrie machen können.

Figure Advanced Edit 1:

../../../_images/advanced_digitizing.png

Das erweiterte Digitalisierungsfenster

Bemerkung

Die Werkzeuge sind nicht aktiviert, wenn die Kartenansicht geographische Koordinaten zeigt.

Neue Vektorlayer erstellen

Mit QGIS können Sie neue Shapedateilayer, neue SpatiaLite Layer, GPX Layer und neue temporäre Scratch Layer erstellen. Die Erstellung eines neuen GRASS Layers wird durch das GRASS Plugin unterstützt. Bitte gehen Sie zu Abschnitt Einen neuen GRASS Vektorlayer erstellen für mehr Informationen über das Erstellen von GRASS Vektorlayern.

Eine neue Shapedatei erstellen

Um einen neuen Shapelayer zum Bearbeiten zu erstellen wählen Sie Neu ‣ newVectorLayer Neuer Shapedateilayer ... aus dem Layer Menü. Der Neuer Vektorlayer Dialog wird dargestellt wie in Figure_edit_6 gezeigt. Wählen Sie den Layertyp (Punkt, Linie oder Polygon) und das KBS (Koordinatenbezugssystem).

Beachten Sie dass QGIS noch nicht die Erstellung von 2.5D Objekten unterstützt (d.h. Objekte mit X,Y,Z Koordinaten).

Figure Edit 6:

../../../_images/editNewVector.png

Neuer Vektorlayer Dialog

Um die Erstellung des neuen Shapedateilayer zu vervollständigen fügen Sie die gewünschten Attribute ein indem Sie den [Der Attributliste hinzufügen] Knopf drücken und einen Namen und einen Typ für das Attribut festlegen. Eine erste ‘id’ Spalte wird standardmäßig hinzugefügt, kann aber, falls nicht gewünscht, wieder gelöscht werden. Es werden nur Typ:Text selectString, Typ: Ganzzahl, Typ: Dezimalzahl und Typ: Datum Attribute unterstützt. Zusätzlich und gemäß des Attributtyps können Sie auch die Breite und Präzision der neuen Attributspalte definieren. Sind Sie einmal zufrieden mit den Attributen, klicken Sie [OK] und vergeben Sie einen Namen für die Shapedatei. QGIS wird dem Namen automatisch eine .shp Erweiterung hinzufügen. Ist der Layer einmal erstellt wird dieser der Karte hinzugefügt und Sie können Ihn auf die gleiche Weise wie in Abschnitt Einen vorhandenen Layer editieren bearbeiten.

Einen neuen SpatiaLite Layer erstellen

Um einen neuen SpatiaLite Layer zum Bearbeiten zu erstellen wählen Sie Neu ‣ newSpatiaLiteLayer SpatiaLite Layer erstellen ... aus dem Layer Menü. Der Neuer SpatiaLite Layer Dialog wird dargestellt wie in Figure_edit_7 beschrieben.

Figure Edit 7:

../../../_images/editNewSpatialite.png

Neuer SpatiaLite-Layer Dialog

Der erste Schritt ist eine bestehende SpatiaLite Datenbank auszuwählen oder eine neue SpatiaLite Datenbank zu erstellen. Dies kann mit dem Suchen Knopf browseButton auf der rechten Seite des Datenbankfeldes durchgeführt werden. Fügen Sie dann einen Namen für den neuen Layer ein, definieren Sie den Layertyp und legen Sie das Koordinatenbezugssystem mit [KBS angeben] fest. Falls gewünscht können Sie einen checkbox automatisch inkrementierenden Primärschlüssel erzeugen.

Um eine Attributtabelle für den neuen SpatiaLite Layer zu definieren fügen Sie die Namen der Attributspalten, die Sie mit dem entsprechenden Spaltentyp erstellen wollen, ein und klicken Sie den [Der Attributliste hinzufügen] Knopf. Sind Sie mit den Attributen zufrieden klicken Sie [OK]. QGIS wird automatisch den neuen Layer in die Legende einfügen und Sie können diesen dann auf die gleiche Art und Weise bearbeiten wie in Abschnitt Einen vorhandenen Layer editieren.

Mit dem DB Manager können Sie SpatiaLite Layer ausführlicher managen. Siehe DB Manager Plugin.

Einen neuen GPX Layer erstellen

Um eine GPX-Datei zu laden, müssen Sie das GPS Plugin laden. Das Menü Erweiterungen showPluginManager Erweiterungen verwalten und installieren ... öffnet den Erweiterungen Dialog . Aktivieren Sie das checkbox GPS Werkzeuge Kontrollkästchen.

Wenn dieses Plugin geladen ist wählen Sie Neu ‣ createGPX Erstelle neuen GPX Layer im Layer Menü. Im Neue GPX-Datei speichern als ... Dialog können Sie auswählen wo der neue GPX Layer gespeichert werden soll.

Neuen Temporärlayer erstellen

Leere, bearbeitbare Speicherlayer können Sie einstellen, indem Sie Layer ‣ Layer erstellen ‣ Neuer temporärer Scratch Layer wählen. hier können Sie ebenfalls radioButtonOffMultipunkt, radioButtonOffMultilinie und radioButtonOffMultipolygon Layer unter radioButtonOnPunkt, radioButtonOffLinie und radioButtonOffPolygon Layers erstellen. Temporäre Scratch Layer werden nicht gespeichert und werden verworfen, wenn QGIS geschlossen wird. Siehe In neuen Layer einfügen.