14.2. Lesson: 地図を地理参照する

林業においてよくある作業は、森林地域についての情報の更新でしょう。その地域についての以前の情報は何年も前にアナログで(つまり紙で)集めた、あるいはおそらくそれはデジタル化されたが残されているのはその調査データの紙版しかない、といったことがよくありそうです。

その情報をGISで、例えば後で後の調査と比較するために、使用したいときっと思うでしょう。これは、GISソフトウェアを用いて手で情報をデジタル化する必要があることを意味します。しかし、最初に重要なステップ、紙の地図をスキャンし地理参照しなければ、デジタル化は開始できません。

このレッスンの目標: QGISで地理参照ツールを使用する方法を学ぶ。

14.2.1. basic 地図をスキャン

するべき最初のタスクは、地図をスキャンすることです。地図が大きすぎる場合は、部分に分けてそれをスキャンできますが、各部分について前処理とジオリファレンスの作業を繰り返す必要があることを心に留めておいてください。ですからできれば、可能な限り少ない部分に分けて地図をスキャンします。

このマニュアルで提供される一つは、画像ファイルとして地図をスキャンするために、独自のスキャナを使用する異なる地図を使用しようとしている場合は、300 DPIの解像度が行います。地図が色付きの場合は色付きで画像をスキャンし、後でそれらの色を使用して地図からの情報を別々のレイヤー(例えば、林分、道路、等高線...)に分離できるようにしておきます。

For this exercise you will use a previously scanned map, you can find it as rautjarvi_map.tif in the data folder exercise_data/forestry

14.2.2. basic Follow Along: スキャンした地図を地理参照する

  1. Open QGIS and set the project's CRS to EPSG:3067 - ETRS89 / TM35FIN(E,N) in Project ► Properties ► CRS, which is the currently used CRS in Finland.

    ../../../_images/f_1.png
  2. Save the QGIS project as map_digitizing.qgs.

You will use the georeferencing tool from QGIS named Georeferencer. To georeference the map:

  1. Open the georeference tool, Raster ► georefRun Georeferencer....

    ../../../_images/georeferencer.png
  2. Add the map image file, rautjarvi_map.tif, as the image to georeference, File ► Open raster.

  3. OK をクリックします。

次は地図を地理参照するための変換設定を定義する必要があります。

  1. 設定 ► 変換設定 を開きます。

  2. Set the Transformation type to Linear and the Resampling method to Nearest neighbour.

  3. Press the setProjection Select CRS button next to the Target SRS option and select the EPSG:2392 - KKJ / Finland zone 2 CRS; it is the CRS that was used in Finland back in 1994 when this map was created.

  4. Click the icon next to the Output raster box, go to the folder and create the folder exercise_data\forestry\digitizing and name the file as rautjarvi_georef.tif.

  5. Check checkbox Load in QGIS when done

  6. Leave the rest of parameters as default.

    ../../../_images/Clipboard10.png
  7. OK をクリックします。

The map contains several cross-hairs marking the coordinates in the map, we will use those to georeference this image. You can use the zooming and panning tools as you usually do in QGIS to inspect the image in the Georeferencer's window.

  1. Zoom in to the left lower corner of the map and note that there is a cross-hair with a coordinate pair, X and Y, that as mentioned before are in KKJ / Finland zone 2 CRS. You will use this point as the first ground control point for the georeferencing your map.

  2. point ツールを追加し、(必要に応じてパンとズーム)十字線の交点をクリックし選択します。

  3. In the Enter map coordinates dialogue write the coordinates that appear in the map (X: 2557000 and Y: 6786000) and their CRS (EPSG:2392 - KKJ / Finland zone 2)

    ../../../_images/fillcoordinates.png
  4. OK をクリックします。

    地理参照のための最初の座標の準備ができました。

  5. Look for other black cross-hairs in the image, they are separated 1000 meters from each other both in North and East direction. You should be able to calculate the coordinates of those points in relation to the first one.

  6. Zoom out in the image and move to the right or the top until you find other cross-hair, and estimate how many kilometres you have moved. Try to get ground control points as far from each other as possible.

  7. Digitize at least three more ground control points in the same way you did the first one. You should end up with something similar to this:

    ../../../_images/Clipboard09.png

With already three digitized ground control points you will be able to see the georeferencing error as a red line coming out of the points. The error in pixels can be seen also in the GCP table in the dX[pixels] and dY[pixels] columns. The error in pixels should not be higher than 10 pixels. If it is, you should review the points you have digitized and the coordinates you have entered to find what the problem is. You can use the image above as a guide.

Once you are happy with your control points, you can save them for later use:

  1. Go to File ► Save GCP points as....

  2. In the folder exercise_data\forestry\digitizing, name the file rautjarvi_map.tif.points.

Finally, georeference your map:

  1. Go to File ► Start georeferencing.

  2. Note that you named the file already as rautjarvi_georef.tif when you edited the Georeferencer settings.

    Now you can see the map in QGIS project as a georeferenced raster. Note that the raster seems to be slightly rotated, but that is simply because the data is in KKJ / Finland zone 2 and your project is in ETRS89 / TM35FIN(E,N).

  3. To check that your data is properly georeferenced, you can

    1. Open the aerial image in the exercise_data\forestry folder, named rautjarvi_aerial.tif.

    2. Your map and this image should match quite well: set the map transparency to 50% and compare it to the aerial image.

    ../../../_images/Clipboard14.png
  4. QGISプロジェクトへの変更を保存し、次のレッスンはこの時点から継続します。

14.2.3. In Conclusion

You have now georeferenced a paper map, making it possible to use it as a map layer in QGIS.

14.2.4. What's Next?

In the next lesson, you will digitize the forest stands in your map as polygons and add the inventory data to them.