14.2. Lesson: 地図を地理参照する

林業においてよくある作業は、森林地域についての情報の更新でしょう。その地域についての以前の情報は何年も前にアナログで(つまり紙で)集めた、あるいはおそらくそれはデジタル化されたが残されているのはその調査データの紙版しかない、といったことがよくありそうです。

その情報をGISで、例えば後で後の調査と比較するために、使用したいときっと思うでしょう。これは、GISソフトウェアを用いて手で情報をデジタル化する必要があることを意味します。しかし、最初に重要なステップ、紙の地図をスキャンし地理参照しなければ、デジタル化は開始できません。

このレッスンの目標: QGISで地理参照ツールを使用する方法を学ぶ。

14.2.1. basic 地図をスキャン

するべき最初のタスクは、地図をスキャンすることです。地図が大きすぎる場合は、部分に分けてそれをスキャンできますが、各部分について前処理とジオリファレンスの作業を繰り返す必要があることを心に留めておいてください。ですからできれば、可能な限り少ない部分に分けて地図をスキャンします。

このマニュアルで提供される一つは、画像ファイルとして地図をスキャンするために、独自のスキャナを使用する異なる地図を使用しようとしている場合は、300 DPIの解像度が行います。地図が色付きの場合は色付きで画像をスキャンし、後でそれらの色を使用して地図からの情報を別々のレイヤー(例えば、林分、道路、等高線...)に分離できるようにしておきます。

この演習では以前にスキャンした地図を使用します。データフォルダ exercise_data/forestry 内に rautjarvi_map.tif として見つかります

14.2.2. basic Follow Along: スキャンした地図を地理参照する

Open QGIS and set the project's CRS to ETRS89 / ETRS-TM35FIN in Project ‣ Properties ‣ CRS, which is the currently used CRS in Finland.

../../../_images/f_1.png

map_digitizing.qgs としてQGISプロジェクトを保存します。

QGISから地理参照 プラグイン を使用します。この プラグイン はすでにQGISにインストールされています。前のモジュールで行ったように、 プラグイン マネージャを使用して プラグイン を有効にします。 プラグイン の名前は Georeferencer GDAL です。

地図を地理参照するには:

  • 地理参照ツールを開きます ラスター ‣ ジオリファレンサ ‣ ジオリファレンサ

  • Add the map image file, rautjarvi_map.tif, as the image to georeference, File ‣ Open raster.

  • 求められたら KKJ/フィンランドゾーン2 CRSを検索して選択します。それは昔この地図が作成された1994年にフィンランドで使用されていたCRSです。

  • OK をクリックします。

次は地図を地理参照するための変換設定を定義する必要があります。

  • 設定 ‣ 変換設定 を開きます。

  • 出力ラスター ボックスの隣にあるアイコンをクリックして、フォルダに移動し、フォルダ exercise_data\forestry\digitizing を作成し、ファイルの名前を rautjarvi_georef.tif とします。

  • 下記に示すように、残りのパラメーターを設定します。

../../../_images/Clipboard10.png
  • OK をクリックします。

The map contains several cross-hairs marking the coordinates in the map, we will use those to georeference this image. You can use the zooming and panning tools as you usually do in QGIS to inspect the image in the Georeferencer's window.

  • Zoom in to the left lower corner of the map and note that there is a cross-hair with a coordinate pair, X and Y, that as mentioned before are in KKJ / Finland zone 2 CRS. You will use this point as the first ground control point for the georeferencing your map.

  • point ツールを追加し、(必要に応じてパンとズーム)十字線の交点をクリックし選択します。

  • 地図座標を入力 ダイアログで地図に表示される座標(X:2557000とY:6786000 )を書き込みます。

  • OK をクリックします。

地理参照のための最初の座標の準備ができました。

黒い線の画像で他の十字線を探すと、北と東の両方の方向で互いに1000メートル離れています。最初のポイントとの関係でそれらのポイントの座標を計算できるはずです。

画像にズームアウトして、他の十字を見つけるまで右に移動し、何キロメートル移動してきたか見積もります。地上基準点はできるだけ互いに離して取得してください。1つめをやったのと同じ方法で、少なくとも3つの地上基準点をデジタル化します。終わりにはこのようになっている必要があります:

../../../_images/Clipboard09.png

3つの地上基準点がすでにデジタル化されていると、地理参照の誤差をポイントから出てくる赤い線として見ることができます。 GCPテーブル の中でも dX [ピクセル]dY [ピクセル] 列でピクセル単位の誤差を見ることができます。ピクセル単位の誤差は10ピクセルよりも大きくならないように。そうである場合は、問題がないかどうか、デジタル化された点および入力した座標を見直してください。ガイドとして上記の画像を使用できます。

Once you are happy with your control points, you can save them for later use:

  • ファイル ‣ 名前をつけてGCP点を保存...

  • フォルダ exercise_data\forestry\digitizing 中で、ファイルに rautjarvi_map.tif.points という名前を付けます。

最後に、地図を地理参照します:

  • ファイル ‣ 地理参照を開始

  • 地理参照の設定を編集したときに 既にファイルを rautjarvi_georef.tif と名前つけていることに注意。

今、地理参照ラスターとしてQGISプロジェクトの地図を見ることができます。ラスターがわずかに回転しているように見えますが、それはデータが KKJ/フィンランドゾーン2 でありプロジェクトが ETRS89 / ETRS-TM35FIN であるというだけの理由であることに注意してください。

exercise_data\forestry フォルダの、 rautjarvi_aerial.tif という名前の空撮画像を開き、データが適切に地理参照されていることを確認できます。地図とこの画像は非常によく一致している必要があります。地図の透明度を50%に設定して空撮画像と比較します。

../../../_images/Clipboard14.png

QGISプロジェクトへの変更を保存し、次のレッスンはこの時点から継続します。

14.2.3. In Conclusion

You have now georeferenced a paper map, making it possible to use it as a map layer in QGIS.

14.2.4. What's Next?

In the next lesson, you will digitize the forest stands in your map as polygons and add the inventory data to them.