14.2. Lesson: Georreferenciando un Mapa

Una tarea forestal común sería la acutalización de información de un área forestal. Es posible que la información anterior para esa área date de muchos años atrás y fuera tomada analógicamente (es decir, en papel) o puede que fuera digitalizada pero todo lo que queda sea la versión en papel del área inventariada.

Segúramente querrás utilizar esa información en tu SIG para, por ejemplo, comparar con los inventarios posteriores. Esto implica que necesitarás digitalizar la información a mano en tu software SIG. Pero antes de que puedas empezar a digitalizar, hay un importante primer paso para hacer, escanear y georreferenciar tu mapa de papel.

El objetivo de esta lección: Aprender a usar la herramienta de Georreferenciación en QGIS.

14.2.1. basic Escanear el mapa

La primera tarea que deberás hacer es escanear tu mapa, si el mapa es demasiado grande, puedes escanearlo en partes diferentes pero teniendo en cuenta que tendrás que repetir las tareas de preprocesado y georreferenciación para cada parte. Así que si es posible, escanea el mapa en el menor número de partes posible.

Si vas a utilizar diferentes mapas al proporcionado en este manual, utiliza tu propio escaner para escanear el mapa como un archivo de imagen, una resolución de 300 DPI funcionará. Si tu mapa tiene colores, escanea la imagen en color para luego utilizar esos colores para separar la información de tu mapa en diferentes capas (por ejemplo, masas forestales, curvas de nivel, calles…).

For this exercise you will use a previously scanned map, you can find it as rautjarvi_map.tif in the data folder exercise_data/forestry

14.2.2. basic Follow Along: Georreferenciar el mapa escaneado

  1. Open QGIS and set the project’s CRS to EPSG:3067 - ETRS89 / TM35FIN(E,N) in Project ► Properties ► CRS, which is the currently used CRS in Finland.

    ../../../_images/f_1.png
  2. Save the QGIS project as map_digitizing.qgs.

You will use the georeferencing tool from QGIS named Georeferencer. To georeference the map:

  1. Open the georeference tool, Raster ► georefRun Georeferencer….

    ../../../_images/georeferencer.png
  2. Add the map image file, rautjarvi_map.tif, as the image to georeference, File ► Open raster.

  3. Haz clic en OK.

Acontinuación deberás definir los ajustes de transformación para georreferenciar el mapa:

  1. Abre Settings ► Transformation settings.

  2. Set the Transformation type to Linear and the Resampling method to Nearest neighbour.

  3. Press the setProjection Select CRS button next to the Target SRS option and select the EPSG:2392 - KKJ / Finland zone 2 CRS; it is the CRS that was used in Finland back in 1994 when this map was created.

  4. Click the icon next to the Output raster box, go to the folder and create the folder exercise_data\forestry\digitizing and name the file as rautjarvi_georef.tif.

  5. Check checkbox Load in QGIS when done

  6. Leave the rest of parameters as default.

    ../../../_images/Clipboard10.png
  7. Haz clic en OK.

The map contains several cross-hairs marking the coordinates in the map, we will use those to georeference this image. You can use the zooming and panning tools as you usually do in QGIS to inspect the image in the Georeferencer’s window.

  1. Zoom in to the left lower corner of the map and note that there is a cross-hair with a coordinate pair, X and Y, that as mentioned before are in KKJ / Finland zone 2 CRS. You will use this point as the first ground control point for the georeferencing your map.

  2. Selecciona la herramienta Add point y haz clic en la intersección de la cruz (desplázate y haz zoom como necesites).

  3. In the Enter map coordinates dialogue write the coordinates that appear in the map (X: 2557000 and Y: 6786000) and their CRS (EPSG:2392 - KKJ / Finland zone 2)

    ../../../_images/fillcoordinates.png
  4. Haz clic en OK.

    La primera coordenada de la georreferenciación ya está lista.

  5. Look for other black cross-hairs in the image, they are separated 1000 meters from each other both in North and East direction. You should be able to calculate the coordinates of those points in relation to the first one.

  6. Zoom out in the image and move to the right or the top until you find other cross-hair, and estimate how many kilometres you have moved. Try to get ground control points as far from each other as possible.

  7. Digitize at least three more ground control points in the same way you did the first one. You should end up with something similar to this:

    ../../../_images/Clipboard09.png

With already three digitized ground control points you will be able to see the georeferencing error as a red line coming out of the points. The error in pixels can be seen also in the GCP table in the dX[pixels] and dY[pixels] columns. The error in pixels should not be higher than 10 pixels. If it is, you should review the points you have digitized and the coordinates you have entered to find what the problem is. You can use the image above as a guide.

Quando estiver satisfeito com seus pontos de controle, você poderá salvá-los para uso posterior:

  1. Go to File ► Save GCP points as….

  2. In the folder exercise_data\forestry\digitizing, name the file rautjarvi_map.tif.points.

Finally, georeference your map:

  1. Go to File ► Start georeferencing.

  2. Note that you named the file already as rautjarvi_georef.tif when you edited the Georeferencer settings.

    Now you can see the map in QGIS project as a georeferenced raster. Note that the raster seems to be slightly rotated, but that is simply because the data is in KKJ / Finland zone 2 and your project is in ETRS89 / TM35FIN(E,N).

  3. To check that your data is properly georeferenced, you can

    1. Open the aerial image in the exercise_data\forestry folder, named rautjarvi_aerial.tif.

    2. Your map and this image should match quite well: set the map transparency to 50% and compare it to the aerial image.

    ../../../_images/Clipboard14.png
  4. Guarda los cambios en tu proyecto QGIS, continuarás desde este punto en la siguiente lección.

14.2.3. In Conclusion

Agora você georreferenciou um mapa em papel, possibilitando usá-lo como uma camada de mapa no QGIS.

14.2.4. What’s Next?

Na próxima lição, você digitalizará a floresta em seu mapa como polígonos e adicionará os dados do inventário a eles.