14.2. Lesson: Géoréférencement d’une carte

Une tâche forestière commune serait la mise à jour des informations relatives à une zone forestière. Il est possible que les informations précédentes pour cette zone datent de plusieurs années et aient été collectées de manière analogique (c’est-à-dire sur papier) ou peut-être qu’elles aient été numérisées mais qu’il ne vous reste que la version papier de ces données d’inventaire.

Il est fort probable que vous souhaitiez utiliser ces informations dans votre SIG pour, par exemple, les comparer plus tard avec des inventaires ultérieurs. Cela signifie que vous devrez numériser les informations dont vous disposez à l’aide de votre logiciel SIG. Mais avant de pouvoir commencer la numérisation, il y a une première étape importante à franchir, à savoir la numérisation et le géoréférencement de votre carte papier.

Le but de cette leçon: Apprendre à utiliser l’outil Georeferencer dans QGIS.

14.2.1. basic Scanner la carte

La première tâche que vous aurez à faire est de scanner votre carte. Si votre carte est trop grande, vous pouvez la numériser en plusieurs parties, mais n’oubliez pas que vous devrez répéter les tâches de prétraitement et de géoréférencement pour chaque partie. Donc, si possible, scannez la carte en un nombre de parties aussi réduit que possible.

Si vous devez utiliser une carte différente de celle fournie avec ce manuel, utilisez votre propre scanner pour scanner la carte sous forme de fichier image, une résolution de 300 DPI fera l’affaire. Si votre carte comporte des couleurs, scannez l’image en couleur afin de pouvoir utiliser ces couleurs plus tard pour séparer les informations de votre carte en différentes couches (par exemple, les peuplements forestiers, les courbes de niveau, les routes…).

For this exercise you will use a previously scanned map, you can find it as rautjarvi_map.tif in the data folder exercise_data/forestry

14.2.2. basic Follow Along: Géoréférencement de la carte scannée

  1. Open QGIS and set the project’s CRS to EPSG:3067 - ETRS89 / TM35FIN(E,N) in Project ► Properties ► CRS, which is the currently used CRS in Finland.

    ../../../_images/f_1.png
  2. Save the QGIS project as map_digitizing.qgs.

You will use the georeferencing tool from QGIS named Georeferencer. To georeference the map:

  1. Open the georeference tool, Raster ► georefRun Georeferencer….

    ../../../_images/georeferencer.png
  2. Add the map image file, rautjarvi_map.tif, as the image to georeference, File ► Open raster.

  3. Cliquez sur OK.

Ensuite, vous devez définir les paramètres de transformation pour le géoréférencement de la carte :

  1. Ouvrez Paramètres ► Paramètres de transformation.

  2. Set the Transformation type to Linear and the Resampling method to Nearest neighbour.

  3. Press the setProjection Select CRS button next to the Target SRS option and select the EPSG:2392 - KKJ / Finland zone 2 CRS; it is the CRS that was used in Finland back in 1994 when this map was created.

  4. Click the icon next to the Output raster box, go to the folder and create the folder exercise_data\forestry\digitizing and name the file as rautjarvi_georef.tif.

  5. Check checkbox Load in QGIS when done

  6. Leave the rest of parameters as default.

    ../../../_images/Clipboard10.png
  7. Cliquez sur OK.

La carte contient plusieurs croix marquant les coordonnées dans la carte, nous les utiliserons pour géoréférencer cette image. Vous pouvez utiliser les outils de zoom et de panoramique comme vous le faites habituellement dans QGIS pour inspecter l’image dans la fenêtre géoréférencer.

  1. Zoom in to the left lower corner of the map and note that there is a cross-hair with a coordinate pair, X and Y, that as mentioned before are in KKJ / Finland zone 2 CRS. You will use this point as the first ground control point for the georeferencing your map.

  2. Sélectionnez l’outil Ajouter point et cliquez dans l’intersection du réticule (pan et zoom si nécessaire).

  3. In the Enter map coordinates dialogue write the coordinates that appear in the map (X: 2557000 and Y: 6786000) and their CRS (EPSG:2392 - KKJ / Finland zone 2)

    ../../../_images/fillcoordinates.png
  4. Cliquez sur OK.

    La première coordonnée pour le géoréférencement est maintenant prête.

  5. Look for other black cross-hairs in the image, they are separated 1000 meters from each other both in North and East direction. You should be able to calculate the coordinates of those points in relation to the first one.

  6. Zoom out in the image and move to the right or the top until you find other cross-hair, and estimate how many kilometres you have moved. Try to get ground control points as far from each other as possible.

  7. Digitize at least three more ground control points in the same way you did the first one. You should end up with something similar to this:

    ../../../_images/Clipboard09.png

With already three digitized ground control points you will be able to see the georeferencing error as a red line coming out of the points. The error in pixels can be seen also in the GCP table in the dX[pixels] and dY[pixels] columns. The error in pixels should not be higher than 10 pixels. If it is, you should review the points you have digitized and the coordinates you have entered to find what the problem is. You can use the image above as a guide.

Une fois que vous êtes satisfait de vos points de contrôle, vous pouvez les conserver pour une utilisation ultérieure :

  1. Go to File ► Save GCP points as….

  2. In the folder exercise_data\forestry\digitizing, name the file rautjarvi_map.tif.points.

Finally, georeference your map:

  1. Go to File ► Start georeferencing.

  2. Note that you named the file already as rautjarvi_georef.tif when you edited the Georeferencer settings.

    Now you can see the map in QGIS project as a georeferenced raster. Note that the raster seems to be slightly rotated, but that is simply because the data is in KKJ / Finland zone 2 and your project is in ETRS89 / TM35FIN(E,N).

  3. To check that your data is properly georeferenced, you can

    1. Open the aerial image in the exercise_data\forestry folder, named rautjarvi_aerial.tif.

    2. Your map and this image should match quite well: set the map transparency to 50% and compare it to the aerial image.

    ../../../_images/Clipboard14.png
  4. Enregistrez les modifications apportées à votre projet QGIS, vous continuerez à partir de ce point pour la prochaine leçon.

14.2.3. In Conclusion

Vous avez maintenant géoréférencé une carte papier, ce qui permet de l’utiliser comme couche cartographique dans QGIS.

14.2.4. What’s Next?

Dans la prochaine leçon, vous numériserez les peuplements forestiers de votre carte sous forme de polygones et y ajouterez les données d’inventaire.