14.2. Lesson: Géoréférencer une carte

Une tâche usuelle en forêt est la mise à jour des informations pour une zone forestière. Il est possible que les informations précédentes pour cette zone datent de plusieurs années et ont été collectées en analogique (c’est à dire sur papier) ou peut-être qu’elles ont été digitalisées mais que vous avez seulement une version papier de ces données d’inventaire.

Il est probable que vous souhaitiez utiliser cette information dans votre SIG pour, par exemple, comparer les nouveaux inventaires avec des anciens. Cela signifie que vous allez avoir besoin de numériser l’information obtenue manuellement en utilisant votre logiciel de SIG. Mais dans un premier temps, vous allez devoir scanner et géo-référencer votre carte papier.

Objectif de cette leçon : Apprendre à utiliser l’outil Géoréférencer dans QGIS.

14.2.1. basic Scanner la carte

La première tâche que vous devrez faire est de scanner votre carte. Si votre carte est trop grande, alors vous pouvez la scanner en différentes parties mais gardez en tête que vous devrez répéter les tâches de prétraitement et de géoréférencement pour chaque partie. Donc si cela est possible, scannez la carte en le moins de parties possible.

Si vous utilisez une carte différente de celle fournie avec ce manuel, scannez donc la carte en tant que fichier image, avec une résolution de 300 DPI. Si votre carte est en couleur, scannez l’image en couleur pour que vous puissiez plus tard utiliser ces couleurs pour séparer les informations de votre carte dans différentes couches (par ex, massifs forestiers, lignes de contour, routes…).

Pour cet exercice, vous utiliserez une carte précédemment scannée. Il est disponible sous le nom de rautjarvi_map.tif dans le dossier de données exercise_data/forestry.

14.2.2. basic Follow Along: Géoréférencer la carte scannée

Ouvrez QGIS et réglez le CRS du projet sur ETRS89 / ETRS-TM35FIN dans Projet ‣ Proprietes ‣ CRS, qui est le CRS actuellement utilisé en Finlande.

../../../_images/f_1.png

Sauvegardez le projet QGIS sous map_digitizing.qgs.

Vous utiliserez l’extension géoréférencement de QGIS. L’extension est déjà installée dans QGIS. Activez l’extension en utilisant le gestionnaire d’extensions comme vous l’avez fait dans des modules précédents. L’extension est appelée Géoréférenceur GDAL.

Pour géoréférencer la carte :

  • Ouvrez l’outil de géoréférence, Raster ‣ Géoréférencer ‣ Géoréférencer.

  • Ajouter le fichier image de la carte, rautjarvi_map.tif, comme image à géoréférencer, File ‣ Open raster.

  • Quand demandé, trouvez et sélectionnez le SCR KKJ / Finland zone 2, c’est le SCR qui a été utilisé en Finlande en 1994 lorsque cette carte a été créée.

  • Cliquez sur OK.

Ensuite, vous devez définir les paramètres de transformation pour le géoréférencement de la carte :

  • Ouvrez Paramètres ‣ Paramètres de transformation.

  • Cliquez sur l’icône à côté de la boîte Raster de sortie, allez dans le dossier et créez le dossier exercise_data\forestry\digitizing et nommez le fichier rautjarvi_georef.tif.

  • Mettez le reste des paramètres comme montré ci-dessous.

../../../_images/Clipboard10.png
  • Cliquez sur OK.

La carte contient plusieurs croix marquant les coordonnées dans la carte, nous les utiliserons pour géoréférencer cette image. Vous pouvez utiliser les outils de zoom et de panoramique comme vous le faites habituellement dans les QGIS pour inspecter l’image dans la fenêtre degéoréférencer.

  • Faites un zoom sur le coin inférieur gauche de la carte et notez qu’il y a un réticule avec une paire de coordonnées, X et Y, qui, comme mentionné précédemment, se trouvent dans KKJ / Finlande zone 2 CRS. Vous utiliserez ce point comme premier point de contrôle au sol pour le géoréférencement de votre carte.

  • Sélectionnez l’outil Ajouter un point et cliquez sur l’intersection de la croix (déplacez-vous et zoomez au besoin).

  • Dans la boîte de dialogue Enter les coordonnées de la carte écrivez les coordonnées qui apparaissent dans la carte (X: 2557000 et Y: 6786000).

  • Cliquez sur OK.

La première coordonnée pour le géoréférencement est maintenant prête.

Recherchez d’autres réticules dans l’image faite de lignes noires, ils sont séparés de 1000 mètres dans les deux directions Nord et Est. Vous devriez être capable de calculer les coordonnées de ces points par comparaison au premier.

Dézoomez l’image et bougez sur la droite jusqu’à ce que vous trouviez une autre croix, et estimez de combien de kilomètres vous avez bougé. Essayez d’obtenir des points de contrôle aussi loin que possible les uns des autres. Numérisez au moins trois points de contrôle supplémentaires de la même manière que vous avez fait pour le premier. Vous devriez arriver à quelque chose comme ceci :

../../../_images/Clipboard09.png

Dès que vous aurez trois points de contrôle, vous allez pouvoir évaluer l’erreur de géo-référencement sous la forme d’une ligne rouge à l’extérieur des points. Les pixels d’erreur sont visibles aussi dans la Table des points de contrôle dans les colonnes dX[pixels] et dY[pixels]. L’erreur en pixel ne doit pas être supérieure à 10 pixels, si c’est le cas vous devez vérifier les coordonnées que vous avez saisies pour trouver le problème. Vous pouvez utiliser l’image ci-dessus comme un guide.

Une fois que vous êtes satisfait de vos points de contrôle, vous pouvez les conserver pour une utilisation ultérieure :

  • Fichier ‣ Enregistrer les points de contrôle sous….

  • Dans le répertoire exercise_data\forestry\digitizing, nommez le fichier rautjarvi_map.tif.points.

Enfin, géoréférencez votre carte :

  • Fichier ‣ Commencer le géoréférencement.

  • Notez que vous avez déjà nommé le fichier rautjarvi_georef.tif quand vous avez configuré les paramètres du Géoréférenceur.

Vous pouvez maintenant voir la carte dans le projet QGIS comme un raster géoréférencé. Notez que le raster semble être légèrement tourné, mais c’est simplement à cause du fait que les données sont dans KKJ / Finland zone 2 et votre projet dans ETRS89 / ETRS-TM35FIN.

Pour vérifier que vos données sont correctement géo-référencées, vous pouvez ouvrir l’image aérienne dans le répertoire exercise_data\forestry, nommée rautjarvi_aerial.tif. Votre carte et cette image devraient correspondre assez bien. Mettez la transparence de la carte à 50% et comparez-la à l’image aérienne.

../../../_images/Clipboard14.png

Sauvegardez les changements dans votre projet QGIS, vous continuerez à partir de ce point pour la prochaine leçon.

14.2.3. In Conclusion

Vous avez maintenant géoréférencé une carte papier, ce qui permet de l’utiliser comme couche cartographique dans le qgis.

14.2.4. What’s Next?

Dans la prochaine leçon, vous numériserez les peuplements forestiers de votre carte sous forme de polygones et y ajouterez les données d’inventaire.