14.6. Lesson: Création de cartes détaillées avec l’outil Atlas

La conception d’un échantillonnage systématique est prête et les équipes de terrain ont chargé les coordonnées GPS dans leurs appareils de navigation. Elles ont aussi un formulaire de données de terrain dans lequel elles vont collecter les informations mesurées sur chaque parcelle d’échantillon. Pour trouver plus facilement leur chemin vers chaque parcelle d’échantillon, elles auront recours à un certain nombre de cartes détaillées sur lesquelles des informations de terrain sont clairement visibles avec un petit sous-ensemble de parcelles d’échantillon et des informations sur la zone de la carte. Vous pouvez utiliser l’outil Atlas pour générer automatiquement un nombre de cartes avec un format commun.

Objectif de cette leçon : Apprendre à utiliser l’outil Atlas dans QGIS pour générer des cartes détaillées imprimables pour assister le travail d’inventaire sur le terrain.

14.6.1. basic Follow Along: Préparation de la mise en page d’impression

Avant que nous ne puissions automatiser les cartes détaillées de la zone forestière et de nos parcelles d’échantillon, nous devons créer un modèle de carte avec tous les éléments que nous considérons comme utiles pour le travail de terrain. Bien sûr, le plus important sera d’avoir un bon style mais, comme vous l’avez vu plus tôt, vous devrez aussi ajouter beaucoup d’autres éléments qui complètent la carte imprimée.

Ouvrez le projet QGIS de la leçon précédente forest_inventory.qgs. Vous devriez au moins avoir les couches suivantes :

  • forest_stands_2012 (avec une transparence à 50%, un remplissage vert et une bordure verte plus foncée).

  • systematic_plots_clip.

  • rautjarvi_aerial.

Sauvegardez le projet sous un nouveau nom, map_creation.qgs.

Pour créer une carte imprimable, souvenez-vous que vous utilisez le Gestionnaire de mise en page:

  • Ouvrez Project ‣ Gestionnaire de mise en page….

  • Dans la boîte de dialogue Gestionnaire de mise en page.

  • Cliquez sur le bouton Ajouter et nommez votre gestionnaire de mise en page forest_map.

  • Cliquez sur OK.

  • Cliquez sur le bouton Montrer.

Configurez les options d’impression afin que vos cartes soient adaptées à votre papier et vos marges, pour un feuille A4 :

  • Ouvrez menuselection:Mise en page –> Propriétés de la page….

  • La Taille est A4 (217 x 297 mm).

  • L”Orientation est Paysage.

  • Marges (millimetres) sont tous prêts à 5.

Dans le composeur impression, allez dans l’onglet Composition (sur le panneau de droite) et assurez-vous que ces paramètres pour Papier et qualité sont les mêmes que ceux que vous avez définis pour l’imprimante :

  • Taille : A4 (210x297mm).

  • Orientation : Paysage.

  • Qualité : 300dpi.

La composition d’une carte est plus facile si vous utilisez la grille du canvas pour positionner les différents éléments. Passez en revue les paramètres de la grille de mise en page:

  • Dans l’onglet Composition étendez la région de la Grille.

  • Vérifiez que l”Espacement est fixé à 10 mm.

  • Et que la Tolérance est fixée à 2 mm.

Vous avez besoin d’activer l’utilisation de la grille :

  • Ouvrez le menu Vue.

  • Cochez Afficher la grille.

  • Cochez Accrochage à la grille.

  • Notez que les options d’utilisation de guides sont cochées par défaut, ce qui vous permet de voir des lignes de guidage rouges lorsque vous déplacez des éléments dans la mise en page.

Vous pouvez maintenant commencer à ajouter des éléments à votre canevas de carte. Ajoutez d’abord un élément de carte afin que vous puissiez vérifier à quoi ça ressemble lorsque vous serez en train de faire des changements dans la symbologie des couches :

  • Cliquez sur le bouton Ajouter une nouvelle carte : addMap.

  • Cliquez et faites glisser une zone sur le canevas de sorte que la carte occupe la majeure partie de celui-ci.

../../../_images/composer_1.png

Notez comment le curseur de la souris s’accroche à la grille du canevas. Utilisez cette fonction lorsque vous ajoutez d’autres éléments. Si vous voulez avoir plus de précision, changer le paramètre d”Espacement de la grille. Si pour quelque raison vous ne voulez pas accrocher à la grille à certains points, vous pouvez toujours cocher ou décocher l’option dans le menu Vue.

14.6.2. basic Follow Along: Ajout d’une carte de fond

Laissez le composeur ouvert, mais revenez à la carte. Ajoutons quelques données de fond et créons un style pour que le contenu de la carte soit aussi clair que possible.

  • Ajoutez le raster en fond de plan basic_map.tif que vous pouvez trouver dans le dossier :file:`exercise_data`forestry.

  • Lorsque demandé, sélectionnez le SCR ETRS89 / ETRS-TM35FIN pour le raster.

Comme vous pouvez voir, la carte de fond a déjà un style. Ce type de raster cartographique prêt à l’emploi est très courant. Il est créé à partir de données vectorielles, de style dans un format standard et enregistré comme raster, de sorte que vous ne deviez pas créer plusieurs couches vectorielles et vous souciez d’obtenir un bon résultat.

  • Zoomez maintenant sur vos parcelles d’échantillon, afin que vous puissiez voir seulement quatre ou cinq lignes de parcelles.

Le style actuel des parcelles échantillons n’est pas le meilleur, mais comment se présente-t-il dans la mise en page d’impression ?

../../../_images/plots_zoom1-2.png

Alors que lors des derniers exercices, le tampon blanc était correct sur l’image aérienne, maintenant que l’image de fond est principalement blanche, on peut à peine voir les étiquettes. Vous pouvez également vérifier l’aspect de l’image sur la mise en page :

  • Allez dans la fenêtre composeur impression.

  • Utilisez le bouton select pour sélectionner l’élément de la carte dans la mise en page.

  • Rendez-vous à l’onglet Propriétés de l’objet.

  • Sous Emprise, cliquez sur Fixer sur l’emprise courante de la carte.

  • Si vous devez rafraîchir l’élément, sous Propriétés principales cliquez sur Mise à jour de l’aperçu.

Ce n’est de toute évidence pas suffisamment bon, vous voulez avoir des numéros de parcelle aussi visible que possible pour les équipes de terrain.

14.6.3. basic Try Yourself Changement de la symbologie des couches

Vous avez travaillé la symbologie dans Création et exploration d’une carte de base et l’étiquetage dans Module: Classer des données vectorielles. Retournez à ces modules si vous avez besoin de quelques rappels sur certaines options et les outils disponibles. Votre but est d’obtenir la localisation des parcelles et que leur nom soit visible aussi clairement que possible, mais permettant toujours de voir les éléments de carte en arrière-plan. Vous pouvez prendre une certaine direction de cette image :

../../../_images/plots_zoom2_symbology.png

Vous utiliserez plus tard le style vert de la couche forest_stands_2012. Pour le garder, et pour avoir une visualisation de ce qui ne montre que les bordures du massif :

  • Faites un clic droit sur forest_stands_2012 et sélectionnez Dupliquer.

  • vous avez une nouvelle couche nommée forest_stands_2012 copy que vous pouvez utiliser pour définir un style différent, par exemple avec pas de remplissage et des bords rouges.

Vous avez maintenant deux visualisations différentes des massifs de forêt et vous pouvez décider lequel afficher pour votre carte détaillée.

Retournez souvent à la fenêtre composeur impression pour voir à quoi ressemblerait la carte. Pour la création de cartes détaillées, vous recherchez une symbologie qui soit belle non pas à l’échelle de toute la zone forestière (image de gauche ci-dessous) mais à une échelle plus proche (image de droite ci-dessous). N’oubliez pas d’utiliser Mettre à jour l’aperçu et Régler l’étendue du canevas de la carte chaque fois que vous modifiez le zoom de votre carte ou la mise en page.

../../../_images/composer_2-3.png

14.6.4. basic Try Yourself Créer un modèle de carte de base

Une fois que vous avez une symbologie avec laquelle vous êtes content, vous êtes prêt à ajouter plus d’informations à votre carte imprimée. Ajoutez au moins les éléments suivants :

  • Titre.

  • Une barre d’échelle

  • Cadre de la grille de votre carte.

  • Coordonnées au niveau des côtés de la grille.

Vous avez déjà créé une composition similaire dans Module: Laying out the Maps. Revenez à ce module autant que vous en avez besoin. Vous pouvez regarder cet exemple d’image à titre de référence :

../../../_images/map_template1.png

Exportez votre carte en tant qu’image et observez-la.

  • Layout ‣ Export as Image….

  • Utilisez par exemple le Format JPG.

C’est ce à quoi elle doit ressembler lorsqu’elle est imprimée.

14.6.5. basic Follow Along: Adding More Elements to the Print Layout

Comme vous l’avez probablement remarqué dans les images du modèle de carte suggéré, il y a beaucoup de place sur le côté droit du canevas. Voyons ce qu’il pourrait encore aller là-bas. Pour les fins de notre carte, une légende n’est pas vraiment nécessaire, mais un aperçu de la carte et des zones de textes pourraient être ajoutés à la carte.

L’aperçu de la carte aidera les équipes de terrain à placer la carte détaillée dans la zone forestière générale :

  • Ajoutez un autre élément de carte au canevas, juste sous le texte du titre.

  • Dans l’onglet Propriétés de l’objet, ouvrez le menu déroulant Aperçu.

  • Mettez le Cadre d’aperçu à Carte 0. Cela crée un rectangle d’ombre sur la plus petite carte représentant l’étendue visible dans la plus grande carte.

  • Vérifiez également l’option Cadre avec une couleur blanche et une Épaisseur de 0.30.

../../../_images/more_elements1.png

Remarquez que votre carte générale ne donne pas vraiment une vue d’ensemble de la zone forestière, ce qui est ce que vous voulez. Vous voulez que cette carte représente la totalité de la zone forestière et vous voulez qu’elle ne montre que la carte de fond et la couche forest_stands_2012, et non les placettes d’échantillonnage. Et vous voulez aussi verrouiller sa vue pour qu’elle ne change plus chaque fois que vous modifiez la visibilité ou l’ordre des couches.

  • Retournez à la carte, mais ne fermez pas le composeur impression.

  • Faites un clic-droit sur la couche forest_stands_2012 et cliquez sur Zoomer sur l’emprise de la couche.

  • Désactivez toutes les couches exceptées basic_map et forest_stands_2012.

  • Retournez à la page composeur impression.

  • Avec la petite carte sélectionnée, cliquez sur Fixez sur l’emprise courante de la carte pour fixer son étendue à ce que vous pouvez voir dans la fenêtre de la carte.

  • Verrouillez la vue pour la carte d’aperçu en cochant Verrouiller les couches pour cette carte sous Propriétés principales.

Votre carte d’aperçu est maintenant comme vous vous y attendiez et sa vue ne changera plus. Mais, bien sûr, votre carte détaillée ne montre maintenant plus ni les bordures du massif ni les parcelles d’échantillon. Fixons-les :

  • Rendez-vous à nouveau à la fenêtre de la carte et sélectionnez les couches que vous voulez visibles (systematic_plots_clip, forest_stands_2012 copy et Basic_map).

  • Zoomez à nouveau pour avoir seulement quelques lignes de parcelles d’échantillon visibles.

  • Retournez à la fenêtre composeur impression.

  • Sélectionnez la carte la plus grande dans votre mise en page ( select ).

  • Dans les Propriétés de l’objet, cliquez sur Mise à jour de l’aperçu et :guilabel:`Fixer sur l’emprise de la carte.

Notez que seule la grande carte affiche la vue actuelle de la carte, et le petit aperçu conserve la même vue que vous aviez lorsque vous l’avez verrouillé.

Notez également que l’aperçu montre un cadre ombragé pour le contenu affiché dans la carte détaillée.

../../../_images/more_elements2.png

Votre modèle de carte est presque prêt. Ajoutez maintenant deux zones de textes en-dessous de la carte, une contenant le texte “Zone de la carte détaillée : “ et l’autre “Remarques : “. Placez-les comme vous pouvez le voir dans l’image ci-dessous.

Vous pouvez également ajouter une flèche nord à la carte générale :

  • Utilisez l’outil Ajouter une image, addImage.

  • Cliquez au niveau du coin supérieur droit de la carte générale.

  • Dans les Propriétés de l’objet, ouvrez Rechercher dans les répertoires et recherchez une image de flèche.

  • Sous Rotation de l’image, cochez Synchroniser avec la carte et sélectionnez Map 1 (la carte d’aperçu).

  • Décochez Fond.

  • Redimensionnez l’image de la flèche en une taille qui semble bien avec la petite carte.

La mise en page de base de la carte est prête, maintenant vous voulez utiliser l’outil Atlas pour générer autant de cartes détaillées dans ce format que vous le jugez nécessaire.

14.6.6. basic Follow Along: Création d’une couverture d’Atlas

La couverture d’Atlas est juste une couche vectorielle qui sera utilisée pour générer des cartes détaillées; une carte pour chaque entité dans la couverture. Pour avoir une idée de ce que vous ferez par la suite, voici un ensemble entier de cartes détaillées pour la zone forestière :

../../../_images/preview_atlas_results.png

La couverture pourrait être n’importe quelle couche existante, mais il est en général plus logique d’en créer une dans ce but spécifique. Créons une grille de polygones couvrant la zone forestière :

  • Dans l’affichage de la carte de QGIS, ouvrez Vecteur ‣ Outils de recherche ‣ Grille vectorielle.

  • Configurez l’outil comme montrée dans cette image :

../../../_images/coverage_polygons.png
  • Sauvegardez la sortie sous atlas_coverage.shp.

  • Mettez un style à la nouvelle couche atlas_coverage afin que les polygones n’aient pas de remplissage.

Les nouveaux polygones recouvrent l’étendue de la forêt et ils vous donnent une idée du contenu de chaque carte (créée à partir de chaque polygone).

../../../_images/atlas_coverage.png

14.6.7. basic Follow Along: Configuration de l’outil Atlas

La dernière étape est la configuration de l’outil Atlas :

  • Retournez à la page composeur impression.

  • Dans le panneau sur la droite, rendez-vous à l’onglet Génération d’Atlas.

  • Mettez les options comme suit :

../../../_images/atlas_settings.png

Cela indique à l’outil Atlas d’utiliser les caractéristiques (polygones) à l’intérieur de atlas_coverage comme point central pour chaque carte détaillée. Il produira une carte pour chaque élément de la couche. Le Couche de couverture cachée indique à l’Atlas de ne pas afficher les polygones dans les cartes de sortie.

Une chose doit encore être faite. Vous devez dire à l’outil Atlas quel élément de carte doit être mis à jour pour chaque carte de sortie. À présent, vous pouvez probablement deviner que la carte qui doit changer pour chaque entité est celle que vous avez préparé pour contenir les vues détaillées des parcelles d’échantillon, qui est la plus grande carte dans votre canevas :

  • Sélectionnez la plus grande carte.

  • Rendez-vous à l’onglet Propriétés de l’objet.

  • Dans la liste, cochez Contrôlé par l’atlas.

  • Et mettez les Marges autour des entités à 10%. L’étendue de la vue sera 10% plus grande que les polygones, ce qui signifie que vos cartes détaillées auront un chevauchement de 10%.

../../../_images/controlled_by_atlas.png

Vous pouvez maintenant utiliser l’outil de prévisualisation pour les cartes d’Atlas pour voir à quoi vos cartes ressembleront :

  • Activez les prévisualisations de l’Atlas en utilisant le bouton atlas ou si votre barre d’outil Atlas n’est pas visible, via Atlas ‣ Aperçu de l’Atlas.

  • Vous pouvez utiliser les flèches dans la barre d’outils Atlas ou dans le menu Atlas pour se déplacer à travers les cartes qui seront créées.

Notez que certaines d’entre elles couvrent des zones qui ne sont pas intéressantes. Faisons quelque chose par rapport à ça et sauvegardons quelques arbres en n’imprimant pas ces cartes inutiles.

14.6.8. basic Follow Along: Édition de la couche de couverture

Outre la suppression des polygones pour ces zones qui ne sont pas intéressantes, vous pouvez aussi personnaliser les étiquettes de texte dans votre carte à générer avec le contenu de la Table attributaire de votre couche de couverture :

  • Retournez à l’affichage de la carte.

  • Activez l’édition pour la couche atlas_coverage.

  • Sélectionnez les polygones qui sont sélectionnés (en jaune) dans l’image ci-dessous.

  • Retirez les polygones sélectionnés.

  • Désactivez l’édition et sauvegardez les modifications.

../../../_images/remove_polygons.png

Vous pouvez retourner à la page composeur impression et vérifier que les aperçus de l’Atlas utilisent uniquement les polygones que vous avez laissés dans la couche.

La couche de couverture que vous utilisez ne dispose pas encore d’informations utiles que vous pouvez utiliser pour personnaliser le contenu des étiquettes de votre carte. La première étape est de les créer, vous pouvez ajouter par exemple un code de zone pour les aires de polygones et un champ avec quelques remarques pour les équipes de terrain à prendre en compte.

  • Ouvrez la Table attributaire pour la couche atlas_coverage.

  • Activez l’édition.

  • Utilisez la calculatrice calculateField pour créer et compléter les deux champs suivants.

  • Créez un champ nommé Zone et de type Nombre entier (entier).

  • Dans la boîte Expression écrivez/copiez/construisez $rownum.

  • Créez un autre champ nommé Remarques, de type Texte (chaîne de caractères) et d’une largeur de 255.

  • Dans la boîte Expression écrivez 'Pas de remarque.'. Cela va mettre cette valeur par défaut pour tous les polygones.

Le gestionnaire de forêt aura des informations sur les zones qui peuvent être utiles lors des visites des zones. Par exemple, l’existence d’un point, d’un marais ou l’emplacement d’espèces protégées. La couche atlas_coverage est probablement encore en mode d’édition, ajoutez le texte suivant dans le champ Remarques aux polygones correspondants (double-cliquez sur les cellules pour les modifier) :

  • Pour la Zone 2:, Pont vers la Nord de la parcelle 19. Écureuils de Sibérie entre p_13 et p_14..

  • Pour la Zone 6:, Difficultés de transit dans les marais au Nord du lac..

  • Pour la Zone 7:, Écureuils de Sibérie au Sud-Est de p_94..

  • Désactivez l’édition et sauvegardez vos modifications.

Presque prêt, vous devez maintenant dire à l’outil Atlas que vous voulez que certaines des étiquettes de texte utilisent les informations de la table attributaire de la couche atlas_coverage.

  • Retournez à la page composeur impression.

  • Sélectionnez l’étiquette de texte contenant Carte détaillée....

  • Mettez la taille de Police à 12.

  • Mettez le curseur à la fin du texte dans l’étiquette.

  • Dans l’onglet Propriétés de l’objet, dans les Propriétés principales, cliquez sur Insérer une expression.

  • Dans la Liste des fonctions, double-cliquez sur le champ Zone sous Champ et Valeurs.

  • Cliquez sur OK.

  • Le texte à l’intérieur de la boîte dans les Propriétés de l’objet devrait montrer Carte détaillée de la zone d'inventaire : [% "Zone" %]. Notez que [% "Zone" %] sera remplacé par la valeur du champ Zone pour l’entité correspondante de atlas_coverage.

Testez les contenus des étiquettes en regardant les différents aperçus des cartes de l’Atlas.

Faites de même pour les étiquettes avec le texte Remarques : utilisant le champ avec l’information de zone. Vous pouvez laisser une ligne vide avant d’entrer l’expression. Vous pouvez voir le résultat avec l’aperçu de la zone 2 dans l’image ci-dessous :

../../../_images/preview_zone2.png

Utilisez l’aperçu de l’Atlas pour naviguer à travers toutes les cartes que vous créerez bientôt et appréciez !

14.6.9. basic Follow Along: Impression de cartes

Enfin et surtout, imprimer ou exporter vos carte en fichiers image ou PDF. Vous pouvez utiliser Atlas ‣ Exporter l’Atlas en tant qu’image… ou Atlas ‣ Exporter l’Atlas au format PDF…. Actuellement, le format d’exportation SVG ne fonctionne pas correctement et donnera un mauvais résultat.

Imprimons les cartes dans un seul PDF que vous pouvez envoyer au bureau des équipes de terrain pour impression :

  • Rendez-vous à l’onglet Génération d’Atlas sur le panneau de droite.

  • Sous la Sortie, cochez Export d’un seul fichier, si possible. Cela mettra toutes les cartes ensemble dans un fichier PDF, si cette option n’est pas cochée, vous aurez un fichier pour chaque carte.

  • Ouvrez Layout ‣ Export as PDF….

  • Sauvegardez le fichier PDF comme inventory_2012_maps.pdf dans votre dossier exercise_data\forestry\samplig\map_creation\.

Ouvrez le fichier PDF pour vérifier que tout est conforme à ce à que vous vous attendiez.

Vous pourriez tout aussi facilement créer des images séparées pour chaque carte (souvenez-vous de décochez la création de fichier unique), ici vous pouvez voir les miniatures des images qui seront créées.

../../../_images/maps_as_images.png

Dans composeur impression, sauvegardez votre carte comme modèle de mise en page sous le nom forestry_atlas.qpt dans votre dossier exercise_data\forestry\création_de_carte\. Utilisez Layout ‣ Save as Template. Vous pourrez utiliser ce modèle encore et encore.

Fermez le composeur impression et sauvegardez votre projet QGIS.

14.6.10. In Conclusion

Vous avez réussi à créer un modèle de carte qui peut être utilisé pour générer automatiquement des cartes détaillées qui seront utilisées sur le terrain comme aide à la navigation vers les différentes parcelles. Comme vous l’avez remarqué, ce n’était pas une tâche facile, mais le bénéfice viendra lorsque vous aurez besoin de créer des cartes similaires pour d’autres régions et vous pourrez utiliser le modèle que vous venez de sauvegarder.

14.6.11. What’s Next?

Dans la prochaine leçon, vous verrez comment vous pouvez utiliser des données LiDAR pour créer un MNE et ensuite l’utiliser pour améliorer vos données et la visibilité de vos cartes.