14.2. Lesson: Georreferenciando un Mapa

Una tarea forestal común sería la acutalización de información de un área forestal. Es posible que la información anterior para esa área date de muchos años atrás y fuera tomada analógicamente (es decir, en papel) o puede que fuera digitalizada pero todo lo que queda sea la versión en papel del área inventariada.

Segúramente querrás utilizar esa información en tu SIG para, por ejemplo, comparar con los inventarios posteriores. Esto implica que necesitarás digitalizar la información a mano en tu software SIG. Pero antes de que puedas empezar a digitalizar, hay un importante primer paso para hacer, escanear y georreferenciar tu mapa de papel.

El objetivo de esta lección: Aprender a usar la herramienta de Georreferenciación en QGIS.

14.2.1. basic Escanear el mapa

La primera tarea que deberás hacer es escanear tu mapa, si el mapa es demasiado grande, puedes escanearlo en partes diferentes pero teniendo en cuenta que tendrás que repetir las tareas de preprocesado y georreferenciación para cada parte. Así que si es posible, escanea el mapa en el menor número de partes posible.

Si vas a utilizar diferentes mapas al proporcionado en este manual, utiliza tu propio escaner para escanear el mapa como un archivo de imagen, una resolución de 300 DPI funcionará. Si tu mapa tiene colores, escanea la imagen en color para luego utilizar esos colores para separar la información de tu mapa en diferentes capas (por ejemplo, masas forestales, curvas de nivel, calles…).

Para este ejercicio utilizarás un mapa previamente escaneado, puedes encontrarlo como rautjarvi_map.tif en la carpeta de datos exercise_data/forestry

14.2.2. basic Follow Along: Georreferenciar el mapa escaneado

Abra o QGIS e defina o SRC do projeto para ETRS89 / ETRS-TM35FIN em Projeto ‣ Propriedades ‣ SRC, que é o SRC usado atualmente na Finlândia.

../../../_images/f_1.png

Guarda el proyecto QGIS como map_digitizing.qgs.

Utilizarás los complementos de georreferenciación del QGIS, los complementos ya están instalados en QGIS. Activa los complementos utilizando el administrador de complementos como has hecho en módulos anteriores. El complemento se llama Georeferencer GDAL.

Para georeferenciar el mapa:

  • Abre la herramienta de georreferenciado, Raster ‣ Georeferencer ‣ Georeferencer.

  • Adicione o arquivo de imagem do mapa, rautjarvi_map.tif, como a imagem à georreferência, Arquivo ‣ Abrir raster.

  • Cuando se solicite encuentra y selecciona el SRC KKJ / Finland zone 2, es el SRC que fue utilizado en Finlandia en 1994 cuando el mapa fue creado.

  • Haz clic en OK.

Acontinuación deberás definir los ajustes de transformación para georreferenciar el mapa:

  • Abre Settings ‣ Transformation settings.

  • Haz clic en el icono junto a la caja Output raster, ve a la carpeta y crea la carpeta exercise_data\forestry\digitizing y nombra el archivo como rautjarvi_georef.tif.

  • Ajusta el resto de los parámetros como se muestra abajo.

../../../_images/Clipboard10.png
  • Haz clic en OK.

The map contains several cross-hairs marking the coordinates in the map, we will use those to georeference this image. You can use the zooming and panning tools as you usually do in QGIS to inspect the image in the Georeferencer’s window.

  • Zoom in to the left lower corner of the map and note that there is a cross-hair with a coordinate pair, X and Y, that as mentioned before are in KKJ / Finland zone 2 CRS. You will use this point as the first ground control point for the georeferencing your map.

  • Selecciona la herramienta Add point y haz clic en la intersección de la cruz (desplázate y haz zoom como necesites).

  • En el diálogo Enter map coordinates escribe las coordenadas que aparecen en el mapa (X: 2557000 e Y: 6786000).

  • Haz clic en OK.

La primera coordenada de la georreferenciación ya está lista.

Busca otras cruces en las líneas negras de la imagen, están separadas 1000 metros entre ellas en dirección Norte y Este. Deberías ser capaz de calcular las coordenadas de esos puntos en relación al primero.

Zoom menos na imagem e passe para a direita até encontrar outra forma de cruz, e estimar quantos quilômetros você se moveu. Tente obter pontos de controle no terreno o mais longe possível uns dos outros. Digitalize, pelo menos, mais três pontos de controle, da mesma forma que você fez o primeiro. Você deve acabar com algo semelhante a isto:

../../../_images/Clipboard09.png

Con los puntos de control ya digitalizados serás capaz de ver los errores de georreferenciación como una línea roja saliendose de los puntos. El error en píxels puede ser visto también en GCP table en las columnas dX[pixels] y dY[pixels]. El error en píxels no debería ser mayor de 10 píxels, si lo es deberías revisar los puntos que has digitalizado y las coordenadas que has introducido para encontrar dónde está el problema. Puedes utilizar la imagen anterior como guía.

Quando estiver satisfeito com seus pontos de controle, você poderá salvá-los para uso posterior:

  • File ‣ Save GCP points as….

  • Na pasta exercise_data\forestry\digitizing, nome do arquivo rautjarvi_map.tif.points.

Finalmente, georreferencia tu mapa:

  • File ‣ Start georeferencing.

  • Observa que ya has nombrado tu archivo como rautjarvi_georef.tif cuando editaste los ajustes del Georreferenciador.

Ahora puedes ver el mapa en el proyecto QGIS como un ráster georreferenciado. Observa que el ráster parece estar ligeramente rotado, pero eso solo se debe a que los datos están en KKJ / Finland zone 2 y tu proyecto está en ETRS89 / ETRS-TM35FIN.

Para verificar se os seus dados estão devidamente georreferenciados você pode abrir a imagem aérea na pasta: kbd: exercise_data\forestry , com o nome: kbd:` rautjarvi_aerial.tif`. Seu mapa e esta imagem devem sobrepor muito bem. Defina a transparência mapa para 50% e compará-la com a imagem aérea.

../../../_images/Clipboard14.png

Guarda los cambios en tu proyecto QGIS, continuarás desde este punto en la siguiente lección.

14.2.3. In Conclusion

Agora você georreferenciou um mapa em papel, possibilitando usá-lo como uma camada de mapa no QGIS.

14.2.4. What’s Next?

Na próxima lição, você digitalizará a floresta em seu mapa como polígonos e adicionará os dados do inventário a eles.