Outdated version of the documentation. Find the latest one here.

.

Allgemeine Werkzeuge

Tastenkürzel

QGIS bietet Standard Tastenkürzel für zahlreiche Funktionen. Sie können im Kapitel Menüleiste nachgelesen werden. Zusätzlich ist es aber auch möglich, eigene Tastenkürzel zu definieren und bestehende zu ändern. Öffnen Sie dazu das Menü Einstellungen ‣ Tastenkürzel festlegen ....

Figure Shortcuts 1:

../../../_images/shortcuts.png

Tastenkürzel festlegen nix (Gnome)

Die Konfiguration ist sehr einfach. Wählen Sie einfach eine Aktion aus und drücken dann auf [Ändern], [Keins setzen] oder [Voreinstellung]. Wenn Sie ihre Einstellung gefunden haben, kann diese als XML-Datei abgespeichert und somit auch für eine andere QGIS Installation genutzt werden.

Hilfe

Wenn Sie Hilfe zu bestimmten Themen brauchen erreichen Sie die Kontext-Hilfe über den [Hilfe] Knopf der Ihnen in den meisten Dialogen zur Verfügung steht. Bitte beachten Sie daß Erweiterungen von Drittanbietern zu dementsprechend gewidmeten Internetseiten verweisen.

Layeranzeige kontrollieren

QGIS rendert standardmäßig alle sichtbaren Layer wenn das Kartenfenster aktualisiert werden muss. Die Abläufe, die eine ‘Erneuerung’ der Wiedergabe verursachen sind:

  • Einen Layer hinzufügen

  • Karten verschieben, hinein- oder herauszoomen

  • Die Größe des QGIS Fensters ändern

  • Layer ein- oder ausblenden

QGIS ermöglicht Ihnen den Darstellungsprozess in einer Reihe von Möglichkeiten zu steuern.

Maßstabsabhängige Layeranzeige

Die maßstabsabhängige Wiedergabe erlaubt es, einen mini- und maximalen Maßstab, in dessen Rahmen ein Layer angezeigt wird, anzugeben. Um die maßstabsabhängige Wiedergabe einzustellen öffnen Sie den Eigenschaften Dialog eines Layers, indem Sie diesen in der Legende doppelt anklicken, im Menü Allgemein die entsprechenden Einstellungen vornehmen und das Kontrollkästchen checkbox Maßstabsabhängige Sichtbarkeit aktivieren.

Sie können die Maßstabswerte bestimmen indem Sie erst auf den Level den Sie benutzen wollen zoomen und den Maßstabswert in der QGIS Statusleiste notieren.

Layeranzeige kontrollieren

Die Kartendarstellung kann wie unten beschrieben auf verschiedene Art und Weise gesteuert werden.

Wiedergabe unterdrücken

Um die Wiedergabe einer Karte zu unterdrücken, klicken Sie auf das Kontrollkästchen checkbox Zeichnen auf der rechten Seite der Statusleiste. Wenn das Kontrollkästchen nicht aktiv ist, führt QGIS keine Erneuerung der Wiedergabe des Kartenfensters durch wie in Abschnitt Layeranzeige kontrollieren beschrieben. Beispiele, bei denen das Unterdrücken der Wiedergabe angewendet wird, sind:

  • Viele Layer hinzufügen und ihre Symbologie vor der Visualisierung einstellen

  • Einen oder mehrere große Layer hinzufügen und erst die maßstabsabhängige Wiedergabe einstellen

  • Einen oder mehrere große Layer hinzufügen und erst in ein bestimmtes Gebiet hineinzoomen

  • Eine Kombination aus den oben genannten Punkten

Wenn Sie die checkbox Zeichnen aktivieren, findet automatisch eine Erneuerung der Wiedergabe des Kartenfensters statt.

Option für Layer hinzufügen

Sie können für das Hinzuladen neuer Layer eine Einstellung vornehmen, die bewirkt, dass diese beim Laden erst einmal nicht angezeigt werden. Um diese Option zu nutzen deaktivieren Sie in der Menüleiste unter Einstellungen ‣ Optionen im Menü Darstellung das Kontrollkästchen checkbox Normalerweise werden alle neuen Layer im Kartenfenster angezeigt. Dadurch werden alle neu geladenen Layer erstmal nicht angezeigt.

Zeichnen stoppen

Um die Wiedergabe einer Karte zu stoppen drücken Sie die ESC Taste. Dies stoppt die Erneuerung der Wiedergabe und die Karte wird nur zum Teil angezeigt. Es kann sein dass etwas Zeit zwischen dem Drücken der Esc Taste und dem Stoppen der Kartenwiedergabe vergeht.

Bemerkung

Es ist derzeit nicht möglich das Zeichnen zu stoppen - diese Funktion wurde mit der Version qt4 ausgeschaltet da es zu Problemen und Abstürzen der Benutzeroberfläche kam.

Anpassen des Kartenfensters bei der Wiedergabe

Normalerweise werden in QGIS Inhalte von Layern erst visualisiert wenn sämtliche Daten geladen sind. Um zu bewirken, dass die Inhalte von Layern direkt beim Lesen angezeigt werden, verändern Sie in der Menüleiste unter Einstellungen ‣Optionen im Menü Darstellung die Anzahl von Objekten, nach deren Zeichnung die Anzeige aktualisiert werden soll. Der Wert 0 (Standard) verhindert die Aktualisierung während des Zeichnens. Bei zu niedrigem Wert leidet die Leistung, das ständig ein Update der Wiedergabe stattfindet. Zu Beginn ist oftmals ein Wert von 500 sinnvoll.

Die Qualität der Wiedergabe beeinflussen

Um die Wiedergabequalität der Layer zu beeinflussen gibt es zwei Möglichkeiten. Öffnen Sie das Menü Darstellung im Menü Einstellungen ‣ Optionen und aktivieren bzw. deaktivieren Sie folgende Kontrollkästchen.

  • checkbox Linien auf Kosten der Zeichengeschwindigkeit weniger gezackt zeichnen

  • checkbox Problem mit falsch gefüllten Polygonen beheben

Darstellung beschleunigen

Es gibt zwei Einstellungen die es Ihnen ermöglichen die Darstellungsgeschwindigkeit zu erhöhen. Öffnen Sie den QGIS Optionen Dialog indem Sie Einstellungen ‣ Optionen benutzen, gehen Sie zum Darstellung Menü und aktivieren oder deaktivieren Sie die folgenden Kontrollkästchen:

  • checkbox Hintergrundpuffer aktivieren. Dies sorgt für eine bessere Grafikleistung wobei dann das Darstellen dann nicht mehr gestoppt und Objekte nicht mehr stufenweise dargestellt werden können. Wenn es deaktiviert ist können Sie die Anzahl von Objekten nach deren Zeichnung die Anzeige aktualisiert werden soll selectnumber festlegen, sonst ist diese Option nicht aktiv.

  • checkbox Wo möglich den Darstellungscache benutzen, um das Neuzeichnen zu beschleunigen

Messen

Das Messen funktioniert mit Projektionen (z.B. UTM) und auch mit nicht projizierten Daten. Wenn die geladene Karte als Geografisches Koordinatensystem abgebildet wird (z.B. Latitude/Longitude) sind die Messergebnisse falsch. Sie müssen dann ein passendes KBS mit einer Projektion verwenden (siehe Abschnitt Arbeiten mit Projektionen). Alle Meßwerkzeuge verwenden auch die eingestellte Fangtoleranz der Digitalisierung. Dies ist zum Beispiel dann sinnvoll, wenn Sie entlang von Linien oder Polygongrenzen geladener Vektorlayer messen wollen.

Um ein Meßwerkzeug auszuwählen klicken Sie auf mActionMeasure und suchen das Werkzeug das Sie benutzen wollen aus.

Strecken, Flächen und Winkel messen

mActionMeasure Linie messen: QGIS kann reale Distanzen zwischen Punkten auf Basis eines vorgegebenen Ellipsoiden messen. Dazu wählen Sie im Menü Einstellungen ‣ Optionen im Menü Kartenwerkzeuge einen Ellipsoiden aus. Es kann außerdem die Gummibandfarbe, die bevorzugte Maßeinheit (Meter oder Fuß) und das bevorzugte Winkelmaß (Grad, Bogenmaß, Gon) eingestellt werden. Das Werkzeug ermöglicht es, Punkte im Kartenfenster auszuwählen. Jedes Längensegment wird in einem Popup angezeigt und zusätzlich auch die Gesamtlänge aller Längensegmente. Um das Messen von Strecken zu beenden, klicken Sie auf die rechte Maustaste

Figure Measure 1:

../../../_images/measure_line.png

Entfernungen messen nix (Gnome)

mActionMeasureArea Fläche messen: Auch Flächengrößen können gemessen werden. Das Popup zeigt dabei die akkumulierte Flächengröße. Zusätzlich schnappt das Meßwerkzeug auf den gerade ausgewählten Layer wenn für den entsprechenden Layer ein Fangmodus eingestellt wurde (siehe Abschnitt Einstellen der Fangtoleranz und des Suchradius). Wenn Sie also exakt entlang einer Linie oder Polygonumrandung messen möchten, setzen Sie erst eine Fangtoleranz und selektieren dann den Layer. Wenn Sie jetzt das Meßwerkzeug benutzen schnappt man mit jedem Mausklick (innerhalb der eingestellten Toleranz) auf den Layer.

Figure Measure 2:

../../../_images/measure_area.png

Flächen messen nix (Gnome)

mActionMeasureAngle Winkel messen: Auch Winkel können mit dem Winkel messen- Werkzeug gemessen werden. Der Mauszeiger wird zum Kreuz. Drücken Sie die linke Maustaste und zeichnen Sie das erste Segment des Winkels, klicken nochmals auf die linke Maustaste und messen sie den Winkel, der im Dialogfenster angezeigt wird.

Figure Measure 3:

../../../_images/measure_angle.png

Winkel messen nix (Gnome)

Objekte auswählen und Auswahl aufheben

Die Werkzeugleiste bietet mehrere Werkzeuge, um Objekte im Kartenfenster auszuwählen. Um ein oder mehrere Objekte auszuwählen, klicken Sie auf mActionSelect und wählen Sie dann das entsprechende Werkzeug:

  • mActionSelect Einzelnes Objekt wählen

  • mActionSelectRectangle Objekte durch Rechteck wählen

  • mActionSelectPolygon Objekte durch Polygon wählen

  • mActionSelectFreehand Objekte freihändig wählen

  • mActionSelectRadius Objekte durch Radius wählen

Um die Auswahl von Objekten wieder aufzuheben, klicken Sie auf den Knopf mActionDeselectAll.

mIconExpressionSelect Objekte mit einem Ausdruck wählen ermöglicht es dem Anwender ein Objekt anhand eines Ausdruckdialoges auszuwählen. Siehe auch die Beispiele in Kapitel Ausdrücke .

Anwender können eine Objektauswahl in Neuer Memory-Vektorlayer oder Neuer Vektorlayer anhand von Bearbeiten ‣ Objekte einfügen als ‣ speichern indem Sie den gewünschten Modus auswählen.

Objekte abfragen

Das Objekte abfragen Werkzeug ermöglicht es Ihnen mit dem Kartenfenster zu interagieren und Informationen über Objekte über eine Pop-Up Fenster abzurufen. Um ein Objekt abzufragen verwenden Sie Ansicht ‣ Objekte abfragen, drücken Sie Strg + Umschalt + I oder klicken Sie auf das mActionIdentify Objekte abfragen Icon in der Werkzeugleiste.

Wenn Sie auf mehrere Objekte klicken gibt der Identifikationsergebnis Dialog die Informationen über die ausgewählten Objekte in einer Liste wieder. Das erste Element ist die Nummer des Objekts in der Ergebnisliste, gefolgt vom Layernamen. Das erste Untermenü ist der Name eines Feldes mit seinem Wert. Schließlich werden alle Informationen über das Objekt abgebildet.

Dieses Fenster kann angepasst werden um benutzerdefinierte Felder anzuzeigen, standardmäßig gibt es drei Arten von Informationen wieder:

  • Aktionen: Aktionen können zum Objekte abfragen Fenster hinzugefügt werden. Wenn Sie dann auf das Aktionen-Icon klicken wird eine Aktion ausgeführt. Standardmäßig wird nur eine Aktion hinzugefügt um das Objektformular zum Bearbeiten darzustellen.

  • Abgeleitet: Diese Information wird von anderen Informationen berechnet oder abgeleitet. Sie können hier durch einen Klick X- und Y-Koordinate, Fläche in Karteneinheiten und Umfang in Karteneinheiten von Polygonen, Längen in Karteneinheiten von Linien und Objekt IDs herausfinden.

  • Datenattribute: Dies ist die Liste von Attributfeldern aus den Daten.

Figure Identify 1:

../../../_images/identify_features.png

Objekte abfragen Dialog nix (Gnome)

Am unteren Rand des Fensters gibt es fünf Icons:

  • mActionIdentifyExpand Baum ausklappen

  • mActionIdentifyCollapse Baum einklappen

  • mActionIdentifyDefaultExpand Neue Ergebnisse erscheinen automatisch ausgeklappt.

  • mActionIdentifyCopyAttributes Gewählte Objekte in Zwischenablage kopieren.

  • mActionIdentifyPrint Gewählte HTML-Antwort drucken

Andere Funktionen können im Kontextmenü des abgefrageten Objekts gefunden werden. Im Kontextmenü können Sie z.B.:

  • Das Objektformular anzeigen

  • Zum Objekt zoomen

  • Objekt kopieren: Kopieren Sie alle Objektgeometrien und -attribute

  • Auswahl des Objekts umkehren: fügt das ausgewählte Objekt der Auswahl hinzu

  • Attributwert kopieren: Kopieren Sie nur den Wert des Attributes auf das Sie klicken

  • Objektattribute kopieren: Kopieren Sie nur die Attribute

  • Ergebnisse löschen: Löschen Sie Ergebnisse im Fenster

  • Hervorhebungen löschen: Entfernen Sie in der Karte hervorgehobene Objekte

  • Alle hervorheben

  • Layer hervorheben

  • Layer aktivieren: Wählen Sie einen Layer der aktiviert werden soll

  • Layereigenschaften ... : Öffnen Sie das Layereigenschaften Fenster

  • Alles ausklappen

  • Alles zusammenfalten

Dekorationen

Die Dekorationen von QGIS umfassen das Gitter, den Urheberrechtshinweis, den Nordpfeil und die Maßstabsleiste. Sie werden zum Dekorieren der Karte durch Hinzufügen von kartografischen Elementen benutzt.

Gitter

transformed Gitter ermöglicht es Ihnen ein Koordinatengitter und Koordinatenbeschriftungen der Karte hinzuzufügen.

Figure Decorations 1:

../../../_images/grid_dialog.png

Der Gitter Dialog nix

  1. Wählen Sie das Menü Ansicht‣ Dekorationen ‣ Gitter. Der Dialog öffnet sich (siehe figure_decorations_1).

  2. Aktivieren Sie das Kontrollkästchen checkbox Aktiviere Gitter und machen Sie Definitionen gemäß den Layern die Sie ins Kartenfenster geladen haben.

  3. Aktivieren Sie das Kontrollkästchen checkbox Beschriftungen zeichnen und machen Sie Beschriftungsdefinitionen gemäß den im Kartenfenster geladenen Layern.

  4. Klicken Sie [Anwenden] um sicherzugehen dass es so aussieht wie sie es erwarten.

  5. Klicken Sie [OK] um den Dialog zu schließen.

Nordpfeil

north_arrow Nordpfeil platziert einen einfachen Nordpfeil im Kartenfenster. Bislang steht hierfür lediglich eine Pfeilform zur Verfügung. Sie können die Richtung des Nordpfeiles entweder selbst anpassen oder dies automatisch von QGIS bewerkstellingen lassen. Wenn Sie es QGIS überlassen die Richtung zu bestimmen, entscheided das Programm, in welche Richtung der Nordpfeil idealerweise zeigen sollte. Zum Platzieren des Pfeils haben Sie vier Möglichkeiten entsprechend den vier Ecken des Kartenfensters.

Figure Decorations 3:

../../../_images/north_arrow_dialog.png

Der Nordpfeil Dialog nix

Maßstab

scale_bar Maßstab fügt einen einfachen Maßstab in das Kartenfenster ein. Sie können Maßstabstil und Platzierung so wie die Beschriftung des Balkens steuern.

Figure Decorations 4:

../../../_images/scale_bar_dialog.png

Der Maßstab Dialog nix

QGIS unterstützt hierbei jedoch lediglich die Darstellung des Balkens in denjenigen Einheiten, die auch in Ihren entsprechenden Karten verwendet werden. Dies bedeutet, dass Sie einer Karte deren Layer der Einheit Meter entsprechen, keinen Maßstabsbalken in den Einheiten Fuß oder Zoll hinzufügen können.

Das Hinzufügen eines Maßstabbalkens geht folgendermaßen:

  1. Klicken Sie auf Ansicht ‣ Dekorationen ‣ Maßstab. Der Dialog startet (siehe figure_decorations_4).

  2. Wählen Sie die Platzierung aus der Platzierung selectstring Kombobox aus.

  3. Wählen Sie den Stil aus der Maßstabsstil selectstring Kombobox aus.

  4. Wählen Sie die Farbe für den Balken unter Balkenfarbe selectcolor oder benutzen Sie die standardmäßig eingestellte schwarze Farbe.

  5. Legen Sie die Größe des Balkens und seine Beschriftung unter Größe des Maßstabs selectnumber fest.

  6. Versichern Sie sich dass das checkbox Aktiviere Maßstab Kontrollkästchen aktiviert ist.

  7. Gegebenenfalls können Sie checkbox Bei Größenänderungen automatisch runde Zahlen einstellen aktivieren.

  8. Klicken Sie [OK].

Tipp

Einstellungen von Dekorationen

Wenn Sie ein .qgs -Projekt speichern werden alle bezüglich Nordpfeil, Maßstab und Urheberrechtshinweis gemachten Änderungen im Projekt gespeichert und das nächste Mal wenn das Projekt geladen wird wiederhergestellt

Beschriftungstools

Das mActionTextAnnotation Beschriftungstext-Werkzeug in der Atrribut-Werkzeugleiste bietet die Möglichkeit formatierten Text in einer Sprechblase im QGIS Kartenfenster zu platzieren. Aktivieren Sie dazu einfach das Beschriftungstext-Werkzeug und klicken Sie in das Kartenfenster.

Figure annotation 1:

../../../_images/annotation.png

Anmerkungstext Dialog nix

Ein Doppelklick auf das Element öffnet den Dialog mit verschiedenen Optionen. Im Texteditor können Sie den formatierten Text eingeben und einige Einstellungen vornehmen. Z.B. kann das Objekt an einer bestimmten Stelle positioniert werden, was dann durch ein Markersymbol angezeigt wird. Oder das es unabhängig von dem Objekt im Kartenfenster angezeigt wird. Der Text kann entweder durch Verschieben der Markierung oder der Sprechblase im Kartenfenster verschoben werden.

Das mActionAnnotation Beschriftung verschieben Werkzeug ermöglicht es Ihnen die Beschriftung auf den Kartenfenster zu verschieben.

HTML-Beschriftung

Die mActionFormAnnotation HTML-Beschriftung Werkzeuge in der Attribut-Werkzeugleiste ermöglichen es den Inhalt einer HTML-Datei in einer Sprechblase auf dem QGIS-Kartenfenster zu platzieren. Benutzen Sie das HTML-Beschriftung Werkzeug indem Sie ins Kartenfenster klicken und den Pfad zur HTML-Datei in den Dialog einfügen.

SVG-Anmerkung

Das mActionSaveAsSVG SVG-Anmerkung Werkzeug in der Attribut-Werkzeugleiste ermöglicht es ein SVG-Symbol in einer Sprechblase auf dem QGIS-Kartenfenster zu platzieren. Um das SVG-Anmerkung Werkzeug zu benutzen klicken Sie in das Kartenfenster und fügen Sie den Pfad zur SVG-Datei in den Dialog ein.

Beschriftungsformular

Zusätzlich können Sie eigene Beschriftungsformulare erstellen. Das mActionFormAnnotation Beschriftungsformular Werkzeug ist nützlich um Attribute eines Vektorlayers in einem maßgeschneiderten QT-Designer Beschriftungsformular anzuzeigen (siehe figure_custom_annotation). Es ist ähnlich wie die Designer-Formulare für das Identifizierungswerkzeug, wird aber als Beschriftungstext angezeigt. Siehe auch das Video https://www.youtube.com/watch?v=0pDBuSbQ02o von Tim Sutton für weitere Informationen.

Figure annotation 2:

../../../_images/custom_annotation.png

Benutzerfreundliches QT Designer Beschriftungsformular nix

Bemerkung

Wenn Sie das Tastenkürzel Ctrl+T drücken während ein Beschriftungswerkzeug aktiv ist ändert sich deren Anzeigestatus zwischen an und aus.

Räumliche Lesezeichen

Räumliche Lesezeichen ermöglichen es, geografische Orte zu markieren und als Lesezeichen abzuspeichern, um dorthin später zurückzufinden.

Ein Lesezeichen erstellen

Um ein Lesezeichen zu erstellen:

  1. Zoomen oder verschieben Sie das Kartenfenster in einen Ausschnitt Ihrer Wahl.

  2. Wählen Sie in der Menüleiste Ansicht ‣ Neues Lesezeichen oder drücken Sie kbd:Ctrl-B.

  3. Geben Sie eine Beschreibung für das Lesezeichen ein (bis zu 255 Zeichen).

  4. Klicken Sie auf Enter um das Lesezeichen hinzuzufügen oder auf [Löschen] um das Lesezeichen zu entfernen.

Sie können mehrere Lesezeichen mit demselben Namen erstellen.

Arbeiten mit Lesezeichen

Um räumliche Lesezeichen zu verwenden oder zu verwalten wählen Sie die Menüoption Ansicht ‣ Lesezeichen anzeigen . Mit dem Räumliches Lesezeichen Dialog können Sie zu einem räumlichen Lesezeichen zoomen oder ein Lesezeichen löschen. Sie können hier den Namen und die Koordinaten des Lesezeichens bearbeiten.

Auf ein Lesezeichen zoomen

Im Dialogfenster Räumliches Lesezeichen klicken Sie auf das gewünschte Lesezeichen und wählen dann den Knopf [Zoomen auf]. Sie können auch auf ein Lesezeichen zoomen, indem Sie es mit einem Doppelklick auswählen.

Ein Lesezeichen löschen

Um ein Lesezeichen aus dem Räumliches Lesezeichen Dialog zu löschen klicken Sie es an und klicken Sie dann [Löschen]. Bestätigen Sie Ihre Wahl indem Sie [OK] klicken oder brechen Sie das Löschen mit [Abbrechen] ab.

Layer/Gruppen einbinden

Wenn Sie Inhalte von anderen Projekten in Ihr Projekt einbinden wollen wählen Sie Layer ‣ Eingebettete Layer und Gruppen ....

Layer einbetten

Mit dem folgenden Dialog können Sie Layer von anderen Projekten einbetten. Hier ein kleines Beispiel:

  1. Drückekn Sie browsebutton um nach einem anderen Projekt des Alaskadatensatzes zu suchen.

  2. Wählen Sie die Projektdatei grassland. Sie können hier den Inhalt des Projektes einsehen (siehe figure_embed_dialog).

  3. Klicken Sie Strg und klicken Sie auf die Layer grassland und regions. Klicken Sie [OK]. Die ausgewählten Layer sind jetzt in Legende und Kartenfenster eingebettet.

Figure Nesting 1:

../../../_images/embed_dialog.png

Einzubettende Layer und Gruppen wählen nix

Währenddessen die Layer editierbar sind können Sie Ihre Eigenschaften wie Darstellung und Beschriftung nicht ändern.

Eingebettete Layer entfernen

Machen Sie einen Rechtsklick auf den eingebetteten Layer und wählen Sie mActionRemoveLayer Entfernen.