Outdated version of the documentation. Find the latest one here.

.

Editierfunktionen

QGIS unterstützt vielfältige Möglichkeiten OGR, SpatiaLite, PostGIS, MSSQL Spatial und Oracle Spatial Vektorlayer und -tabellen zu editieren.

Bemerkung

Die Vorgehensweise GRASS Layer zu bearbeiten ist anders - siehe Abschnitt Digitalisieren und Editieren eines GRASS Vektorlayers für Details.

Tipp

Zeitgleiches Editieren

Diese Version von QGIS kontrolliert nicht, ob noch jemand ein Objekt zur gleichen Zeit editiert wie Sie. Die zuletzt schreibende Person gewinnt.

Einstellen der Fangtoleranz und des Suchradius

Bevor wir damit beginnen können Stützpunkte zu editieren ist es sehr wichtig die Fangtoleranz und den Suchradius für Stützpunkte festzulegen um Vektorlayergeometrien optimal editieren zu können.

Fangtoleranz

Die Fangtoleranz ist der Abstand den QGIS verwendet um den nächstgelegenen Stützpunkt bzw. das nächstgelegene Liniensegment zu suchen mit dem sie versuchen sich zu verbinden wenn sie einen neuen Stützpunkt setzen wollen oder einen bestehenden Stützpunkt verschieben wollen. Wenn Sie sich nicht innerhalb der definierten Fangtoleranz befinden wird QGIS den Stützpunkt dort lassen wo sich der Mauszeiger gerade befindet anstatt zu einem bestehenden Stützpunkt oder Liniensegment zu snappen. Die Fangtoleranz Einstellungen betreffen alle Werkzeuge die mit Toleranz arbeiten.

  1. Eine globale, projektweite Fangtoleranz kann definiert werden indem Sie Einstellungen ‣ mActionOptions Optionen auswählen. Gehen Sie unter Mac zu QGIS ‣ mActionOptions Einstellungen ... . Unter Linux: Bearbeiten ‣ mActionOptions Optionen. Im Menü Digitalisierung können Sie zwischen ‘zum Stützpunkt’, ‘zum Segment’ oder ‘Zum Stützpunkt und Segment’ als Standard Fangmodus wählen. Sie können auch eine Voreingestellte Fangtoleranz und einen Suchradius für die Stützpunktbearbeitung definieren. Die Toleranz kann entweder in Karteneinheiten oder in Pixeln eingestellt werden. Der Vorteil wenn man Pixel wählt ist dass die Fangtoleranz sich nicht nach Zoomoperationen verändert. In unserem kleinen Digitalisierprojekt (Arbeiten mit dem Alaskadatensatz) definieren wir die Fangeinheiten in Fuß. Ihre Ergebnisse können variieren etwas in der Größenordnung von 300 ft bei einem Maßstab von 1:10000 sollte eine hinreichende Einstellung sein.

  2. Eine layerbezogene Fangtoleranz kann unter Einstellungen ‣ (oder Datei ‣) Fangoptionen ... um den Fangmodus und die Fangtoleranz auf Layerbasis zu ermöglichen und anzupasssen definiert werden (siehe figure_edit_1 ).

Beachten Sie dass dieses layerbasierte Fangen die globalen Fangoptionen im Menü Digitalisieren überschreibt. Also wenn Sie einen Layer bearbeiten wollen und dass seine Stützpunkte zu einem anderen Layer snappen sollen, dann aktivieren Sie das Fangen nur auf den zu snappenden Layer und verringern Sie die globale Fangtoleranz auf einen kleineren Wert. Darüberhinaus wird das Fangen nicht mit einem Layer funktionieren der nicht im Fangoptionen Dialog aktiviert ist, was unabhängig von der globalen Fangtoleranz funktioniert. Vergewissern Sie sich also dass das Kontrollkästchen für die Layer auf die Sie snappen wollen aktiviert ist.

Figure Edit 1:

../../../_images/editProjectSnapping.png

Das Bearbeiten von Snappingoptionen auf Layerbasis nix

Suchradius

Der Suchradius ist der Abstand den QGIS verwendet um nach dem nächsten Stützpunkt den Sie versuchen zu verschieben wenn Sie auf die Karte klicken zu suchen. Wenn Sie sich nicht innerhalb des Suchradius befinden wird QGIS keinen Stützpunkt für das Bearbeiten finden und auswählen und dementsprechend wird eine lästige Warnung auftauchen. Die Fangtoleranz und der Suchradius werden in Karteneinheiten oder Pixeln eingestellt so dass Sie vielleicht experimentieren müssen um Sie passend einzustellen. Wenn Sie eine zu große Toleranz angeben snappt QGIS zum falschen Stützpunkt, besonders wenn Sie es mit einer großen Anzahl von Stützpunkten in kurzer Distanz zu tun haben. Stellen Sie den Suchradius zu klein ein wird nichts zum Verschieben gefunden.

Der Suchradius für die Stützpunktbearbeitung in Layereinheiten kann im Menü Digitalisierung unter Einstellungen ‣ mActionOptions Optionen definiert werden. An der gleichen Stellen wo Sie die allgemeine, projektweite Fangtoleranz definieren.

Zoomen und Karte verschieben

Bevor Sie einen Layer editieren sollten Sie in den Bereich hineinzoomen, den Sie bearbeiten wollen. Dadurch vermeiden Sie lange Wartezeiten, bis alle Stützpunkte des Layers visualisiert werden.

Neben den mActionPan Karte verschieben und mActionZoomIn Hineinzoomen / mActionZoomOut Hinauszoomen Icons in der Werkzeugleiste können Sie auch mit dem Mausrad, der Leertaste und den Pfeiltasten navigieren.

Mit dem Mausrad im Kartenfenster zoomen und verschieben

Während des Digitalisierens können Sie das Mausrad zum Verschieben innerhalb des Hauptfensters drücken und Sie können das Mausrad zum hinein- und hinauszoomen drehen. Zum Zoomen platzieren Sie den Mauscursor in die Karte und rollen es vorwärts (von Ihnen weg) um hineinzuzoomen und rückwärts (zu Ihnen hin) um herauszuzoomen. Die Position des Mauscursors wird das Zentrum des Sie interessierenden Bereichs sein. Sie können das Verhalten des Mausrad-Zooms anhand des Reiters Kartenwerkzeuge unter Einstellungen ‣ mActionOptions Optionen anpassen.

Den Layer mit den Pfeiltasten verschieben

Das Verschieben der Karte während des Digitalisierens ist mit den Pfeiltasten möglich. Platzieren Sie die Maus in das Kartenfenster und klicken Sie auf die rechts-Pfeiltaste um nach Osten zu verschieben, auf die links-Pfeiltaste um nach Westen zu verschieben, auf die Aufwärts-Pfeiltaste um nach Norden zu verschieben und die Abwärts-Pfeiltaste um nach Süden zu verschieben.

Sie können auch die Leertaste verwenden um vorübergehend Mausbewegungen die die Karte verschieben auszulösen. Die Bild hoch und Bild runter Tasten auf Ihrer Tastatur bewirken bei der Kartenanzeige hinein- oder hinauszuzoomen ohne Ihre Digitalisiersitzung zu unterbrechen.

Topologisches Editieren

Abgesehen von der Einstellung des layerbasierten Fangmodus können im Menü Einstellungen ‣ Fangoptionen... (oder Datei ‣ Fangoptionen) auch topologische Funktionen aktiviert werden. Hier können Sie checkbox Topologische Bearbeitung an definieren und/oder für Polygonlayer können Sie die Spalte checkbox Überschn. verm. aktivieren, die eine Überschneidung neuer Polygone vermeided.

Topologisches Editieren ermöglichen

Die Option checkbox Topologische Bearbeitung an dient dem Bearbeiten und Aufrechterhalten von gemeinsamen Grenzen in Polygonmosaiken. QGIS ‘erkennt’ gemeinsame Grenzen in Polygonmosaiken so dass Sie einfach den Stützpunkt einmal verschieben müssen und QGIS dann die Aufgabe übernimmt die andere Grenze zu updaten.

Überschneidung neuer Polygone vermeiden

Die zweite topologische Option in der checkbox Überschn. verm. Spalte, Überschneidungen von neuen Polygonen vermeiden, verhindert ein Überlappen in Polygonmosaiken. Es dient dazu aneinanderhängende Polygone schneller zu digitalisieren. Wenn Sie bereits ein Polygon erstellt haben ist es mit dieser Option möglich das zweite zu digitalisieren, so dass beide sich überschneiden und QGIS schneidet dann das zweite Polygon gemäß der gemeinsamen Grenze aus. Der Vorteil ist dass Sie nicht alle Stützpunkte der gemeinsamen Grenze digitalisieren müssen.

Fang auf Schnittpunkte aktivieren

Ein andere Möglichkeit stellt das checkbox Fang auf Schnittpunkte aktivieren dar. Sie können damit auf einen Schnittpunkt von Hintergrundlayern snappen selbst wenn es keinen Stützpunkt auf dem Schnittpunkt gibt.

Einen vorhandenen Layer editieren

Standardmäßig lädt QGIS Vektorlayer im ‘read-only’ Modus, um ungewolltes Editieren zu verhindern wenn Sie versehentlich die Maus klicken. Ansonsten können aber alle Ebenen editiert werden, wenn es der Datenanbieter erlaubt bzw. die Rechte entsprechend gesetzt sind.

Im Allgemeinen werden die Werkzeuge zum Bearbeiten von Vektorlayern in eine Digitalisierung und eine Erweiterte Digitalisierung Werkzeugleiste aufgeteilt, wie in Abschnitt Erweiterte Digitalisierung beschrieben. Sie können beides unter Einstellungen ‣ Werkzeuge ‣ auswählen oder abwählen. Wenn Sie die grundlegenden Digitalisiertools verwenden können Sie die folgenden Funktionen ausführen:

Icon

Funktion

Icon

Funktion

mActionAllEdits

Aktuelle Änderungen

mActionToggleEditing

Bearbeitungsstatus umschalten

mActionCapturePoint

Objekt hinzufügen: Punkt hinzufügen

mActionCaptureLine

Objekt hinzufügen: Linie hinzufügen

mActionCapturePolygon

Objekt hinzufügen: Polygon hinzufügen

mActionMoveFeature

Objekt(e) verschieben

mActionNodeTool

Knotenwerkzeug

mActionDeleteSelected

Ausgewähltes Löschen

mActionEditCut

Ausgewählte Objekte ausschneiden

mActionEditCopy

Objekte kopieren

mActionEditPaste

Objekte einfügen

mActionSaveEdits

Layeränderungen speichern

Tabelle Bearbeiten: Funktionen der Werkzeugleiste Digitalisierung

Alle Editiersitzungen fangen mit dem Anwählen der mActionToggleEditing Bearbeitungsstatus umschalten Option an. Sie können dies im Kontextmenu nach dem Rechtsklicken auf den Legendeneintrag für einen vorhandenen Layer finden.

Alternativ können Sie den Bearbeitungsstatus umschalten Knopf aus der Digitalisierung Werkzeugleiste verwenden um den Bearbeitungsstatus ein- oder auszuschalten. Sobald der Layer im Bearbeitungsstatus ist, erscheinen die Stützpunkte als das von Ihnen gewählte Stützpunktsymbol und zusätzlich werden die Digitalisier-Tools in der Werkzeugleiste aktiv.

Tipp

Regelmäßiges Sichern der Daten

Denken Sie daran mActionSaveEdits Layeränderungen regelmäßig zu speichern. Dies überprüft auch dass Ihre Datenquelle alle Änderungen akzeptiert.

Objekte digitalisieren

Danach können Sie mit den Icons mActionCapturePoint Objekt hinzufügen, mActionCaptureLine Objekt hinzufügen oder mActionCapturePolygon Objekt hinzufügen in der Werkzeugleiste den Mauszeiger in den Digitalisiermodus bringen.

Für jedes Objekt wird erst die Geometrie digitalisiert und dann das Attribut hinzugefügt. Um eine Geometrie zu digitalisieren, klicken Sie mit der linken Maustaste an eine gewünschte Stelle im Kartenfenster, um den ersten Punkt zu erstellen.

Für Linien und Polygone klicken Sie für jeden weiteren Knotenpunkt wieder die linke Maustaste. Zum Beenden klicken Sie irgendwo im Kartenfenster auf die rechte Maustaste, um anzuzeigen, dass die Geometrie ihres Objektes fertig gestellt ist.

Das Attribute Fenster wird erscheinen in dem Sie Informationen für das neue Objekt eingeben können. Figure_edit_2 zeigt die Eingabe von Attributen für einen fiktiven neuen Fluss in Alaska. In dem Menü Digitalisierung unter Einstellungen ‣ Optionen können Sie auch checkbox Attributeingabeformular bei der Objekteerstellung unterdrücken und checkbox Letzte Attributwerteingaben wiederverwenden aktivieren.

Figure Edit 2:

../../../_images/editDigitizing.png

Der Attributwertedialog nach dem Digitalisieren eines neuen Vektorobjekts nix

Mit dem mActionMoveFeature Objekt(e) verschieben Icon in der Werkzeugleiste können Sie bestehende Objekte verschieben.

Tipp

Datentyp der Attribute

Beim Editieren werden die Attributtypen während der Dateneingabe überprüft. Deswegen ist es nicht möglich eine Zahl in eine Textspalte im Dialog Attribute oder andersherum einzugeben. Wenn Sie das tun müssen sollten Sie die Attribute in einem zweiten Schritt innerhalb des Attributtabelle Dialogs bearbeiten.

Aktuelle Änderungen

Mit dieser neuen Funktion können Sie mehrere Layer digitalisieren. Wählen Sie mActionFileSaveAs Layeränderungen speichern um alle Änderungen, die Sie in mehreren Layern gemacht haben, zu speichern. Sie haben auch die Möglichkeit mActionRollbackEdits Verwerfen für gewählte Layer zu benutzen so dass die Digitalisierung für alle selektierten Layer rückgängig gemacht werden kann. Wenn Sie das Bearbeiten der selektierten Layer beenden wollen kann man das einfach mit der Funktion mActionCancelEdits Abbruch für gewählte Layer erreichen.

Die gleichen Funktionen sind für das Bearbeiten aller Layer des Projektes zugängig.

Knotenwerkzeug

Für Shapedatei basierte Layer genauso wie für SpatialLite, PostgreSQL/Post GIS, MSSQL Spatial und Oracle Spatial Tabellen stellt das mActionNodeTool Knotenwerkzeug Bearbeitungsmöglichkeiten für Stützpunkte ähnlich wie CAD Programme zur Verfügung. Es ist möglich einfach mehrere Stützpunkte auf einmal auszuwählen und diese zu verschieben, hinzuzufügen und alle zusammen zu löschen. Das Knotenwerkzeug funktioniert auch mit angeschalteter ‘Spontan` Reprojektion und unterstützt die topologische Bearbeitungsfunktion. Dieses Werkzeug ist, anders als andere Werkzeuge in QGIS, nachhaltig, so dass wenn eine Operation durchgeführt wird die Auswahl für dieses Objekt und Werkzeug aktiv bleibt. Wenn das Knotenwerkzeug nicht in der Lage ist Objekte zu finden wird eine Warnung gezeigt.

Es ist wichtig die Eigenschaften unter menuselection:Einstellungen –> mActionOptions Optionen ‣ Digitalisierung ‣ Suchradius: selectnumber auf eine Zahl größer als Null (z.B. 10) einzustellen. Andernfalls ist QGIS nicht in der Lage mitzuteilen welcher Stützpunkt bearbeitet werden soll.

Tipp

Stützpunktmarken

Die aktuelle Version von QGIS unterstützt drei Arten von Stützpunktmarkern:’Teiltransparenter Kreis’, ‘Kreuz’ und ‘Keine’. Um den Markierungsstil zu ändern wählen Sie mActionOptions Optionen aus dem Einstellungen Menü, klicken Sie auf das Digitalisierung Menü und wählen Sie den entsprechenden Eintrag.

Eine einfache Übung

Beginnen Sie, indem Sie das mActionNodeTool Knotenwerkzeug aktivieren und dann ein Objekt selektieren. Rote Boxen erscheinen an jedem Stützpunkt des Objektes. Nun sind folgende Funktionen vorhanden.

  • Stützpunkte auswählen: Sie können Stützpunkte auswählen indem Sie nacheinander darauf klicken, indem Sie auf eine Ecke klicken um die Stützpunkte an beiden Ecken auszuwählen oder indem Sie ein Rechteck um einige Stützpunkte klicken und ziehen. Wenn ein Stützpunkt ausgewählt ist ändert sich die Farbe zu blau. Um der aktuellen Auswahl mehr Stützpunkte hinzuzufügen halten Sie die Strg Taste beim Klicken gedrückt. Halten Sie Strg oder Umschalt -Taste gedrückt wenn Sie Klicken um den Auswahlstatus der Stützpunkte umzuschalten (Stützpunkte die gerade nicht selektiert sind werden wie immer ausgewählt, aber auch Stützpunkte die schon ausgewählt sind werden deselektiert).

  • Stützpunkte hinzufügen: Um einen Stützpunkt hinzuzufügen machen Sie einfach einen Doppleklick in der Nähe einer Ecke und ein neuer Stützpunkt erscheint auf der Ecke in der Nähe des Mauszeigers; deswegen muss er wenn nötig noch verschoben werden.

  • Stützpunkte löschen: Wählen Sie dazu Stützpunkte aus, die gelöscht werden sollen und klicken Sie dann auf die Taste Entfernen. Beachten Sie dass das mActionNodeTool Knotenwerkzeug nicht für das Löschen eines vollständigen Objekts benutzen können, QGIS stellt sicher dass die minimal erforderliche Anzahl von Stützpunkten für das Objekt an dem Sie arbeiten erhalten bleibt. Um ein vollständiges Objekt zu löschen müssen Sie das mActionDeleteSelected Ausgewähltes löschen Werkzeug benutzen.

  • Stützpunkte verschieben:Wählen Sie alle Stützpunkte aus, die verschoben werden sollen. Alle ausgewählten Stützpunkte werden in dieselbe Richtung wie der Mauspfeil verschoben. Wenn eine Fangtolerazt eingestellt ist, können die Stützpunkte zu dem nächstgelegenen Stützpunkt oder Segment snappen.

Jede Veränderung die mit dem Knotenwerkzeug gemacht wurde ist als separater Eintrag im Rückgängig Dialog eingetragen. Beachten Sie dass alle Operationen topologisches Bearbeiten unterstützen wenn dies eingeschaltet ist. Spontanreprojektion wird auch unterstützt und das Knotenwerkzeug erstellt Tooltips um einen Stützpunkt ausfindig zu machen wenn man mit dem Mauszeiger darübergeht.

Objekte ausschneiden, kopieren und einfügen

Ausgewählte Objekte können ausgeschnitten, kopiert und an andere Ebenen im aktuellen QGIS-Projekt übergeben (eingefügt) werden, wenn sich der Ziellayer auch im Editiermodus befindet, indem Sie nach Auswahl des Ziellayers auf den Knopf mActionToggleEditing Bearbeitungsstatus umschalten klicken.

Objekte können an externe Anwendungen als Text abgelegt werden. Dabei werden die Objekte im CSV-Format dargestellt und die Geometriedaten im OGC Well-Know Text (WKT) Format.

In dieser Version von QGIS können jedoch Textobjekte von außen nicht in einen Layer innerhalb von QGIS eingefügt werden. Wann würde dann die Kopieren und Einfügen Funktion zum Einsatz kömmen? Wie sich herausstellt kann man mehr als einen Layer zur gleichen Zeit bearbeiten und Objekte zwischen Layern Kopieren/Einfügen. Warum würden wir das tun wollen? Sagen wir wir müssen an einem Layer arbeiten, brauchen davon aber nur ein- bis zwei Seen, nicht die gesamten 5.000 aus unserem big_lakes Layer. Wir können einen neuen Layer erstellen und Kopieren/Einfügen verwenden um die erforderlichen Seen hineinzukopieren.

Als Beispiel werden wir einige Seen in einen neuen Layer kopieren:

  1. Laden Sie den Layer, von dem Sie einige Objekte kopieren wollen (Quelle)

  2. Laden oder erstellen Sie einen Layer, in den die kopierten Objekte eingefügt werden sollen (Ziel)

  3. Schalten Sie für den Ziel Layer den Bearbeitungsstatus ein

  4. Stellen Sie die Quelle aktiv, indem Sie es in der Legende anklicken

  5. Benutzen Sie das mActionSelect Einzelnes Objekt auswählen Werkzeug und wählen ein paar Objekte in der Quelle aus

  6. Klicken Sie auf das Icon mActionEditCopy Objekte kopieren

  7. Stellen Sie das ‘Ziel’ aktiv, indem Sie es in der Legende anklicken

  8. Klicken Sie auf das Icon mActionEditPaste Objekte einfügen

  9. Beenden Sie den Bearbeitungsstatus für beide Layer und speichern Sie das Ergebnis ab

Was passiert, wenn der Quell- und Ziellayer ein unterschiedliches Schema enthält (Spaltennamen und -typen unterscheiden sich)? QGIS verwendet die Einträge, die gleich sind und ignoriert den Rest. Wenn es Ihnen egal ist, ob die Attribute korrekt übernommen werden, dann ist es egal, wie Sie die Spaltennamen und -typen der Attributtabelle erstellen. Wenn auch die Attributdaten korrekt übernommen werden sollen, dann stellen Sie sicher, dass auch die Spaltennamen und -typen beider Layer zueinander passen.

Tipp

Deckungsgleichheit eingefügter Objekte

Wenn Ihre Quell- und Ziellayer die gleiche Projektion verwenden dann haben die eingefügten Objekte die identische Geometrie wie der Quellayer. Wenn der Ziellayer jedoch eine andere Projektion hat dann kann QGIS nicht garantieren dass die Geometrie identisch ist. Dies ist einfach aus dem Grund so, dass sich kleine Rundungsfehler ergeben wenn zwischen Projektionen konvertiert wird.

Ausgewählte Objekte löschen

Wenn Sie ein ganzes Polygon löschen möchten, selektieren Sie es erst mit dem mActionSelect Einzelnes Objekt auswählen Werkzeug. Sie können dabei auch mehrere Objekte gleichzeitig auswählen. Wenn Sie die Objekte ausgewählt haben, klicken Sie auf das Icon mActionDeleteSelected Ausgewähltes löschen.

Das Werkzeug mActionEditCut Ausgewählte Objekte ausschneiden kann auch benutzt werden, um Objekte zu löschen. Die Objekte werden gelöscht aber zusätzlich noch im ‘spatial clipboard’ abgelegt. In diesem Fall könnte man dann den letzten Schritt, falls ein Fehler unterlaufen ist, wieder rückgängig machen, indem wir auf das Werkzeug mActionEditPaste Objekte einfügen drücken. Ausschneiden, kopieren und übergeben von Objekten funktioniert mit den gerade ausgewählten Objekten und können nach Bedarf kombiniert verwendet werden.

Änderungen speichern

Wenn ein Layer im Bearbeitungsmodus ist behält QGIS alle Änderungen im Speicher. Aus diesem Grund werden diese nicht umgehend der Datenquelle oder -platte übermittelt. Wenn Sie Bearbeitungen in dem aktuellen Layer speichern wollen aber mit dem Bearbeiten fortfahren wollen ohne den Bearbeitungsmodus verlassen zu wollen können Sie den mActionSaveEdits Layeränderungen speichern Knopf klicken. Wenn Sie den Editiermodus mit mActionToggleEditing Bearbeitungsstatus umschalten aussschalten wollen werden Sie ebenfalls gefragrt ob Sie Ihre Änderungen speichern oder verwerfen wollen.

Wenn die Änderungen nicht gespeichert werden können (z.B. weil die Festplatte voll ist oder Attribute Werte aufweisen, die außerhalb der Wertespanne liegen), bleiben die Änderungen erstmal im QGIS Arbeitsspeicher. Dies ermöglicht es, Änderungen vorzunehmen und dann nochmals die Daten zu speichern.

Tipp

Datenintegrität

Es ist immer gut ein Backup von Ihren Daten zu machen bevor Sie mit dem Bearbeiten starten. Während die Autoren von QGIS sich bemühen die Integrität Ihrer Daten zu bewahren bieten wir keine Garantie in dieser Hinsicht.

Erweiterte Digitalisierung

Icon

Funktion

Icon

Funktion

mActionUndo

Rückgängig

mActionRedo

Wiederholen

mActionRotateFeature

Objekt(e) drehen

mActionSimplify

Objekt vereinfachen

mActionAddRing

Ring hinzufügen

mActionAddPart

Teil hinzufügen

mActionFillRing

Ring füllen

mActionDeleteRing

Ring löschen

mActionDeletePart

Teil löschen

mActionReshape

Objekte überarbeiten

mActionOffsetCurve

Linie versetzen

mActionSplitFeatures

Objekte trennen

mActionSplitParts

Teile zerlegen

mActionMergeFeatures

Gewählte Objekte verschmelzen

mActionMergeFeatureAttributes

Attribute gewählter Objekte vereinen

mActionRotatePointSymbols

Punktsymbole drehen

Tabelle Erweiterte Digitalisierung: Werkzeugleiste Erweiterte Digitalisierung für Vektorlayer

Rückgängig und Wiederholen

Mit dem mActionUndo Rückgängig und mActionRedo Wiederholen Werkzeug können Sie Vektorbearbeitungsoperationen rückgängig machen oder wiederholen. Es gibt auch ein andockbares Bedienfeld das alle Operationen in der Rücknahme/Wiederholung History zeigt (siehe Figure_edit_3). Dieses Bedienfeld wird nicht standardmäßig angezeigt; es kann kann angezeigt werden indem man auf die Werkzeugleiste klickt und das Rücknahme/Wiederholung Kontrollkästchen aktiviert. Rücknahme/Wiederholung ist auch dann noch aktiv wenn das Bedienfeld nicht angezeigt wird.

Figure Edit 3:

../../../_images/redo_undo.png

Rückgängig und Wiederholen von Digitalisierschritten nix

Wenn Rückgängig gedrückt wird wird der Status aller Objekte und Attribute auf den Status bevor die zurückgenommene Aktion durchgeführt wurde zurückgesetzt. Änderungen die keine normalen Vektorbearbeitungsoperationen sind (z.B. Änderungen die durch ein Plugin durchgeführt werden) können oder können nicht rückgängig gemacht werden. Dies hängt davon ab wie die Änderungen durchgeführt werden.

Wenn Sie Rücknahme/Wiederholung verwenden wollen klicken Sie einfach auf eine Operation in der History; alle Objekte werden dann auf den Stand vor der ausgewählten Operation zurückgesetzt.

Objekt(e) drehen

Verwenden Sie mActionRotateFeatureObjekt(e) drehen um ein oder mehrere ausgewählte Objekte in der Kartenansicht zu drehen. Sie müssen erst die Objekte auswählen und dann das mActionRotateFeatureObjekt(e) drehen Icon drücken. Der Zentroid des/der Objekte(s) erscheint und wird zum Drehungsankerpunkt. Wenn Sie mehrere Objekte auswählen liegt der Drehungsankerpunkt im gemeinsamen Zentrum der Objekte. Drücken und ziehen Sie den linke Maustaste in die gewünschte Richtung um die ausgewählten Objekte zu drehen.

Es ist auch möglich einen benutzerdefinierten Drehungsankerpunkt, um den dann die ausgewählten Objekte rotieren, zu erstellen. Wählen Sie die Objekte, die gedreht werden sollen und aktivieren Sie das mActionRotateFeatureObjekt(e) drehen Werkzeug. Drücken und halten Sie den Strg Knopf und bewegen Sie den Mauszeiger (ohne die Maustaste zu drücken) zu der Stelle wohin Sie den Rotationsanker verschieben wollen. Lassen Sie den Strg Knopf los wenn der gewünschte Rotationsankerpunkt erreicht ist. Jetzt können Sie die Linke Maustaste in die gewünschte Richtung drücken und ziehen um das/die ausgewählte(n) Objekt(e) zu drehen.

Objekt vereinfachen

Das Werkzeug mActionSimplify Objekt vereinfachen ermöglicht es, die Anzahl der Stützpunkte eines Objektes zu veringern, solange sich die Geometrie nicht verändert und der Geometrietyp nicht eine Mehrfachgeometrie ist. Sie müssen dazu eines oder mehrere Objekte auswählen. Dadurch werden diese von einem roten Gummiband umrandet und ein Schieber erscheint. Wenn Sie die Stellung des Schiebers verändern, können Sie sehen, wie das Objekt vereinfacht wird. Durch einen Klick auf [OK] wird die neue Geometrie abgespeichert. Wenn ein Objekt nicht vereinfacht werden kann (z.B. bei MultiPolygonen), erscheint ein Fenster mit einer entsprechenden Meldung.

Ring hinzufügen

Sie können Ring-Polygone mit dem Werkzeug mActionAddRing Ring hinzufügen erstellen. Das bedeutet, dass Sie innerhalb eines bestehenden Polygons weitere Polygone digitalisieren können. Diese erscheinen dann als ‘Loch’, so dass nur der Zwischenraum des inneren und des äußeren Polygons als Ring-Polygon übrig bleibt.

Teil hinzufügen

Sie können mit mActionAddPart Teil hinzufügen einem ausgewählten multipolygon Polygone hinzufügen. Das neue Teilpolygon muss außerhalb des ausgewählten Multipolygons digitalisiert werden.

Ring füllen

Sie können die mActionFillRing Ring füllen Funktion verwenden um gleichzeitig einen Ring in ein Polygon einzufügen und dem Layer ein neues Objekt zuzufügen. So brauchen Sie nicht erst das mActionAddRing Ring hinzufügen Icon und dann die mActionCapturePolygon Objekt hinzufügen Funktion benutzen.

Ring löschen

Das Werkzeug mActionDeleteRing Ring löschen ermöglicht es, Ringpolygone innerhalb eines existierenden Fläche zu löschen. Das Werkzeug funktioniert nur mit Polygonlayern und kann für Polygon- und Multipolygon-Objekte benutzt werden. Es findet keine Veränderung statt, wenn es auf den äußeren Ring eines Polygons angewendet wird. Bevor Sie die Stützpunkte des Ringes selektieren, stellen Sie bitte die Fangtoleranz entsprechend ein.

Teil löschen

Mit dem mActionDeletePart Teil löschen Werkzeug können Teile eines Multi-Feature Objektes gelöscht werden (z.B. ein Polygon von einem Multipolygon Objekt löschen). Dabei wird der letzte Teil des Multi-Feature Objektes nicht gelöscht. Das Werkzeug funktioniert mit allen Multi-Feature Geometrien Punkte, Linien und Polygone. Bevor Sie die Stützpunkte des Teils selektieren, stellen Sie bitte die Fangtoleranz entsprechend ein.

Objekte überarbeiten

Die Geometrien von Linien und Polygonen können mit dem Werkzeug mActionReshape Objekt überarbeiten verändert werden. Dabei ersetzt die gezogene Linie die originale Linie oder Flächenlinie eines Objektes von der ersten bis zur zweiten Überschneidung. Für Polygone kann dies manchmal zu unerwünschten Resultaten führen und ist vorwiegend sinnvoll, wenn man nur kleinere Teile einer Fläche ersetzen möchte und nicht für eine vollständige Überarbeitung. Dabei ist es für die Vereinfachungslinie auch nicht erlaubt, mehrere Polygongrenzen zu überschneiden.

Als Beispiel können Sie die Grenze eines Polygons mit diesem Tool bearbeiten. Klicken Sie als erstes in die Fläche des Polygons neben den Punkt wo Sie den neuen Stützpunkt hinzufügen wollen. Dann überqueren Sie die Grenze und fügen sie Stützpunkte außerhalb des Polygons ein. Machen Sie einen Rechtsklick in die Fläche des Polygons zum Vervollständigen. Das Werkzeug wird automatisch einen Knoten an der Stelle wo die neue Linie die grenze kreuzt hinzufügen. Es ist auch möglich einen Teil der Polygonfläche zu entfernen indem man außerhalb des Polygons anfängt, Stützpunkte innerhalb des Polygons hinzufügt und außerhalb des Ploygons mit einem Rechtklick aufhört.

Bemerkung

Das Objekte überarbeiten Werkzeug kann die Startposition eines Polygonringes oder einer geschlossenen Linie verändern. Der Punkt, der zweimal abgebildet ist wird also nicht mehr der gleiche sein. Dies mag kein Problem für die meisten Anwendungen sein, sollte aber beachtet werden.

Linie versetzen

Das mActionOffsetCurve Linie versetzen Werkzeug erstellt parallele Linien von Linienlayern. Das Werkzeug kann auf den bearbeiteten Layer (die Geometrien werden verändert) und auch auf Hintergrundlayer (in diesem Fall erstellt es Kopien von Linien/ Ringen und fügt Sie dem bearbeiteten Layer hinzu) angewendet werden. Es ist auf diese Weise ideal geeignet Abstandslinienlayer zu erstellen. Der Versatz wird unten links in der Taskleiste angezeigt.

Um einen Versatz eines Linienlayers zu erstellen müssen Sie erst in den Bearbeitungsmodus gehen und dann das Objekt auswählen. Sie können das mActionOffsetCurve Linie versetzen Werkzeug aktiv machen und das Kreuz in den gewünschten Abstand ziehen. Ihre Änderungen können dann mit dem mActionSaveEditsLayeränderungen speichern Werkzeug gespeichert werden.

Der QGIS Optionen Dialog (Digitalisierung Reiter dann Werkzeug zum Linien versetzen Abschnitt) ermöglicht es Ihnen einige Parameter wie Verbindungsstil,**Quadrantsegmente**, Eckengrenze zu konfigurieren.

Objekte trennen

Objekte können mit dem Werkzeug mActionSplitFeatures Objekt teilen geteilt werden. Zeichnen Sie dazu einfach eine Linie durch das Objekt, das Sie teilen wollen.

Teile zerlegen

In QGIS 2.0 ist es jetzt möglich die Teile eines Multi-Part Features zu zerlegen so dass die Anzahl der Teile sich erhöht. Zeichnen Sie einfach eine Linie über den Teil den Sie zerlegen wollen indem Sie dafür das mActionSplitParts Teile zerlegen Icon verwenden.

Gewählte Objekte verschmelzen

Mit dem mActionMergeFeatures Gewählte Objekte verschmelzen Werkzeug können Sie Objekte verschmelzen, die gemeinsame Grenzen haben. Mit einem neuen Dialog können Sie auswählen welcher Wert zwischen jedem ausgewählten Objekt gewählt wird oder eine Funktion auswählen (Minimum, Maximum, Mittel, Summe, Attribut überspringen), die für jede Spalte benutzt werden soll, auswählen.

Attribute gewählter Objekte vereinen

Mit dem mActionMergeFeatureAttributes Attribute gewählter Objekte vereinen Werkzeug können Sie Attribute von Objekten vereinen die gemeinsame Grenzen und Attribute haben ohne Ihre Grenzen zu vereinen. Wählen Sie zuerst mehrere Objekte auf einmal aus. Drücken Sie dann den mActionMergeFeatureAttributes Attribute gewählter Objekte Knopf. Jetzt fragt Sie QGIS welche Attribute auf alle ausgewählten Objekte angewendet werden sollen. Im Ergebnis haben alle ausgewählten Objekte die gleichen Attributeinträge.

Punktsymbole drehen

Mit mActionRotatePointSymbols Punktsymbole drehen können Sie die Rotation von Punktsymbolen in der Kartenansicht verändern. Sie müssen erst ein Drehungsfeld in der Attributtabelle des Punktlayers im Erweitert Menü des Stil Menü der Layereigenschaften definieren. Sie werden auch nach ‘SVG Markierung’ gehen müssen und Datendefinierte Eigenschaften ... wählen. Aktivieren Sie checkbox Winkel und wählen Sie ‘Drehung’ als Feld. Ohne diese Einstellungen ist das Werkzeug inaktiv.

Figure Edit 4:

../../../_images/rotatepointsymbol.png

Drehen von Punktsymbolen nix

Um die Drehung zu ändern, wählen Sie einen Punkt im Kartenfenster aus und drehen diesen, indem Sie die linke Maustaste gedrückt halten. Ein roter Pfeil mit dem Drehwinkel wird dann angezeigt (siehe Figure_edit_4). Wenn Sie die linke Maustaste wieder loslassen, wird der neue Wert in der Attributtabelle aktualisiert.

Bemerkung

Wenn Sie zusätzlich die Strg-Taste gedrückt halten, findet die Drehung in 15 Grad Schritten statt.

Neue Vektorlayer erstellen

Mit QGIS können Sie neue Shapedateilayer, neue SpatiaLite Layer und neue GPX Layer erstellen. Die Erstellung eines neuen GRASS Layers wird durch das GRASS Plugin unterstützt. Bitte gehen Sie zu Abschnitt Einen neuen GRASS Vektorlayer erstellen für mehr Informationen über das Erstellen von GRASS Vektorlayern.

Eine neue Shapedatei erstellen

Um einen neuen Shapelayer zum Bearbeiten zu erstellen wählen Sie Neu ‣ mActionNewVectorLayer Neuer Shapedateilayer ... aus dem Layer Menü. Der Neuer Vektorlayer Dialog wird dargestellt wie in Figure_edit_5 gezeigt. Wählen Sie den Layertyp (Punkt, Linie oder Polygon) und das KBS (Koordinatenbezugssystem).

Beachten Sie dass QGIS noch nicht die Erstellung von 2.5D Objekten unterstützt (d.h. Objekte mit X,Y,Z Koordinaten).

Figure Edit 5:

../../../_images/editNewVector.png

Neuer Vektorlayer Dialog nix

Um die Erstellung des neuen Shapedateilayer zu vervollständigen fügen Sie die gewünschten Attribute ein indem Sie den [Der Attributliste hinzufügen] Knopf drücken und einen Namen und einen Typ für das Attribut festlegen. Eine erste ‘id’ Spalte wird standardmäßig hinzugefügt, kann aber, falls nicht gewünscht, wieder gelöscht werden. Es werden nur Typ:Text selectstring, Typ: Ganzzahl, Typ: Dezimalzahl und Typ: Datum Attribute unterstützt. Zusätzlich und gemäß des Attributtyps können Sie auch die Breite und Präzision der neuen Attributspalte definieren. Sind Sie einmal zufrieden mit den Attributen, klicken Sie [OK] und vergeben Sie einen Namen für die Shapedatei. QGIS wird dem Namen automatisch eine .shp Erweiterung hinzufügen. Ist der Layer einmal erstellt wird dieser der Karte hinzugefügt und Sie können Ihn auf die gleiche Weise wie in Abschnitt Einen vorhandenen Layer editieren bearbeiten.

Einen neuen SpatiaLite Layer erstellen

Um einen neuen SpatiaLite Layer zum Bearbeiten zu erstellen wählen Sie Neu ‣ mActionNewSpatiaLiteLayer SpatiaLite Layer erstellen ... aus dem Layer Menü. Der Neuer SpatiaLite Layer Dialog wird dargestellt wie in Figure_edit_6 beschrieben.

Figure Edit 6:

../../../_images/editNewSpatialite.png

Neuer SpatiaLite-Layer Dialog nix

Der erste Schritt ist eine bestehende SpatiaLite Datenbank auszuwählen oder eine neue SpatiaLite Datenbank zu erstellen. Dies kann mit dem Suchen Knopf browsebutton auf der rechten Seite des Datenbankfeldes durchgeführt werden. Fügen Sie dann einen Namen für den neuen Layer ein, definieren Sie den Layertyp und legen Sie das Koordinatenbezugssystem mit [KBS angeben] fest. Falls gewünscht können Sie einen checkbox automatisch inkrementierenden Primärschlüssel erzeugen.

Um eine Attributtabelle für den neuen SpatiaLite Layer zu definieren fügen Sie die Namen der Attributspalten, die Sie mit dem entsprechenden Spaltentyp erstellen wollen, ein und klicken Sie den [Der Attributliste hinzufügen] Knopf. Sind Sie mit den Attributen zufrieden klicken Sie [OK]. QGIS wird automatisch den neuen Layer in die Legende einfügen und Sie können diesen dann auf die gleiche Art und Weise bearbeiten wie in Abschnitt Einen vorhandenen Layer editieren.

Mit dem DB Manager können Sie SpatiaLite Layer ausführlicher managen. Siehe DB Manager Plugin.

Einen neuen GPX Layer erstellen

Um eine GPX-Datei zu laden, müssen Sie das GPS Plugin laden. Das Menü Erweiterungen mActionShowPluginManager Erweiterungen verwalten und installieren ... öffnet den Erweiterungen Dialog . Aktivieren Sie das checkbox GPS Werkzeuge Kontrollkästchen.

Wenn dieses Plugin geladen ist wählen Sie Neu ‣ icon_newgpx Erstelle neuen GPX Layer im Layer Menü. Im Neue GPX-Datei speichern als ... Dialog können Sie auswählen wo der neue GPX Layer gespeichert werden soll.

Mit Attributtabelle arbeiten

Die Attributtabelle stellt die Objekte eines ausgewählten Layers dar. Jede Zeile in der Tabelle repräsentiert ein Kartenobjekt und jede Spalte enthält bestimmte Informationen über das Objekt. Objekte in der Tabelle können gesucht, ausgewählt, verschoben oder sogar bearbeitet werden.

Um die Attributtabelle eines Vektorlayers zu öffnen machen Sie Ihn aktiv indem Sie auf ihn in der Legende klicken. Dann wählen Sie aus dem Layer Menü mActionOpenTable Attributtabelle öffnen. Es ist auch möglich einen Rechtsklick auf einen Layer zu machen und mActionOpenTable Attributtabelle öffnen aus dem Drop-Down Menü auszuwählen und auf den mActionOpenTable Attributtabelle öffnen Knopf in der Attribute Werkzeugleiste zu klicken.

Dies wird ein neues Fenster öffnen das die Attribute des Layers zeigt (figure_attributes_1). Die Anzahl der Objekte und die Anzahl der gewählten Objekte werden im Attributtabellentitel gezeigt.

Figure Attributes 1:

../../../_images/vectorAttributeTable.png

Attributtabelle des regions Layer nix

Objekte einer Attributtabelle abfragen

Jede selektierte Zeile in einer Attributtabelle repräsentiert alle Attribute eines Objektes in dem ausgewählten Layer. Die Attributtabelle zeigt alle Veränderungen bei einer Abfrage in der Attributtabelle im Kartenfenster und umgekehrt. Eine neue Abfrage in der Attributtabelle verursacht also eine Veränderung der im Kartenfenster als ausgewählt dargestellten Objekte und eine im Kartenfenster geänderte Auswahl von Objekten spiegelt sich durch eine Veränderung der ausgwählten Zeilen in der Attributtabelle wider.

Zeilen können ausgewählt werden, indem Sie auf die Zeilennummer links neben der Zeile klicken. Mehrere Zeilen können ausgewählt werden, indem die Strg Taste während der Auswahl gedrückt wird.Eine kontinuierliche Auswahl ist möglich, indem Sie bei der Selektion die Umschalt Taste gedrückt halten, während Sie die Zeilennummern auswählen. Alle Zeilen zwischen der aktuell ausgewählten Zeile und der Mauspfeilposition werden dadurch selektiert. Bewegt man den Mauszeiger in der Attributtabelle indem man in eine Zelle in der Tabelle klickt ändert die Zeilenauswahl nicht. Verändert man die Auswahl im Kartenfenster bewegt sich der Mauszeiger in der Attributtabelle nicht.

Jede Spalte kann sortiert werden, indem Sie auf die Kopfzeile klicken. Ein kleiner Pfeil zeigt die Sortierfolge an. Wenn er nach unten zeigt, werden die Werte von oben nach unten absteigend angezeigt. Wenn der Pfeil nach oben zeigt, werden die von oben nach unten aufsteigend angezeigt.

For a simple search by attributes on only one column, choose the Column filter ‣ from the menu in the bottom left corner. Select the field (column) on which the search should be performed from the drop-down menu, and hit the [Apply] button. Then, only the matching features are shown in the attribute table.

Um eine Auswahl zu treffen müssen Sie das mIconExpressionSelect Objekte mit einem Ausdruck wählen Icon oberhalb der Atributtabelle verwenden. Mit mIconExpressionSelect Objekte mit einem Ausdruck wählen können Sie eine Untermenge einer Tabelle anhand einer Funktionsliste, wie Sie im mActionCalculateField Feldrechner vorhanden ist, definieren (siehe Feldrechner). Das Abfrageergebnis kann dann als neuer Vektorlayer gespeichert werden. Wenn Sie zum Beispiel Regionen vom Typ borough aus der Datei regions.shp der QGIS Beispieldaten finden wollen, müssen Sie das Felder und Werte Menü öffnen und das Feld, das Sie abfragen wollen, auswählen. Doppelklicken Sie das Feld ‘TYPE_2’ und auch [Alle eindeutigen]. Wählen und doppelklicken Sie ‘Borough’ in der Liste. Im Feld Ausdruck erscheint die folgende Abfrage:

"TYPE_2"  =  'Borough'

Hier können Sie auch Funktionsliste ‣ Letztes (Selection) verwenden um eine Auswahl zu treffen die Sie schon einmal verwendet haben. Der Ausdruckseditor speichert die letzten 20 verwendeten Ausdrücke ab.

Die zutreffenden Zeilen werden ausgewählt und die volle Anzahl zutreffender Zeilen erscheint dann in der Titelleiste der Attributtabelle sowie in der Statusleiste des Hauptfensters. Wollen Sie eine Suche durchführen, die dann nur die gewählten Objekte auf der Karte darstellt, verwenden Sie die Abfrageerstellung die in Kapitel Abfrageeditor beschrieben wird.

Um nur ausgewählte Objekte anzuzeigen verwenden Sie Alle gewählten Objekte anzeigen aus dem Menü links unten.

Die anderen Knöpfe im Kopf der Attributtabelle stellen die folgenden Funktionalitäten zur Verfügung:

  • mActionToggleEditing Bearbeitungsmodus umschalten um einen einzelnen Wert zu bearbeiten und um die unten beschriebenen Funktionalitäten zu ermöglichen (auch mit Strg+E)

  • mActionSaveEdits Änderungen speichern (auch mit Strg+S)

  • mActionUnselectAttributes Alles abwählen (auch mit Strg+U)

  • mActionSelectedToTop Auswahl nach Oben (auch mit Strg+T)

  • mActionInvertSelection Auswahl umkehren (auch mit Strg+R)

  • mActionCopySelected Ausgewählte Zeilen in die Zwischenablage kopieren (auch mit Strg+C)

  • mActionZoomToSelected Zu den gewählten Zeilen zoomen (auch mit Strg+J)

  • PanToSelected Zu den gewählten Zeilen verschieben (auch mit Strg+P)

  • mActionDeleteSelected Gewählte Objekte löschen (auch mit Strg+D)

  • mActionNewAttribute Neue Spalte für PostGIS Layer und für OGR Layer mit GDAL Version >=1.6 (auch mit Strg+W)

  • mActionDeleteAttribute Spalte löschen für PostGIS Layer und für OGR Layer mit GDAL Version >=1.9 (auch mit Strg+L)

  • mActionCalculateField Feldrechner öffnen (auch mit Strg+I)

Unter diesen Knöpfen ist die Feldrechnerleiste, die Berechnungen, die schnell auf Attribute angewendet werden sollen, ermöglicht. Diese Leiste verwendet die gleichen Ausdrücke wie der mActionCalculateField Feldrechner (see Feldrechner).

Tipp

WKT Geometrie überspringen

Wenn Sie Attributdaten in externen Programmen (wie Excel) nutzen wollen verwenden Sie den mActionCopySelected Ausgewählte Zeilen in die Zwischenablage kopieren Knopf. Sie können die Informationen ohne Vektorgeometrien kopieren wenn Sie Einstellungen ‣ Optionen ‣ Datenquellen Menü checkbox Geometrie in WKT aus Attributtabelle kopieren deaktiveren.

Ausgewählte Objekte als neuer Layer speichern

Die ausgewählten Objekte können in jedem OGR-unterstützen Vektorformat gespeichert werden und auch in ein anderes Koordinatenbezugssystem (KBS) transformiert werden. Öffnen Sie einfach das Rechte-Maus-Menü des Layers und klicken Sie auf :menuselection: Speichern als –> um den Namen, das Format und das KBS der Ausgabedatei zu definieren (siehe Kapitel Legende). Um die Auswahl zu speichern vergewissern Sie sich dass|checkbox| nur gewählte Objekt speichern ausgewählt ist. Es ist genauso möglich OGR-Erstellungsoptionen innerhalb des Dialogs festzulegen.

In neuen Layer einfügen

Objekte, die sich in der Zwischenablage befinden, können in einen neuen Layer eingefügt werden. Versetzen Sie den Layer zuerst in den Bearbeitungsmodus. Wählen Sie einige Objekte aus, kopieren Sie sie in die Zwischenablage und fügen Sie sie unter Zuhilfenahme von Bearbeiten ‣ Objekte einfügen als und Neuer Vektorlayer oder Neuer Memory-Vektorlayer ein.

Dieses gilt für Objekte, die innerhalb von QGIS ausgewählt und kopiert wurden und auch für Objekte einer anderen Quelle die als Well-Known Text (WKT) definiert wurden.

Arbeiten mit nicht räumlichen Attributtabellen

Mit QGIS können Sie auch nicht-räumliche Tabellen laden. Dies beinhaltet derzeit Tabellen die von OGR und Delimited Text, sowie vom PostgreSQL, MSSQL and Oracle Provider unterstützt werden. Die Tabellen können zum Nachschlagen benutzt werden oder nur um allgemein zu suchen und zu bearbeiten anhand der Tabellenansicht. Wenn Sie die Tabelle laden sehen Sie dies in der Legende. Sie kann mit dem mActionOpenTable Attributtabelle öffnen Werkzeug geöffnet werden und ist dann editierbar wie jeder andere Attributtabelle.

Sie können zum Beispiel Spalten von nicht-räumlichen Tabellen verwenden um Attributwerte oder eine Spanne von Werten, die erlaubt ist, in einen bestimmten Vektorlayer während der Bearbeitung hinzugefügt zu werden definieren. Sehen Sie sich das Bearbeitungselement genauer im Abschnitt Menü Felder an, um mehr zu erfahren.

Ein-Zu-Mehrere-Beziehungen erstellen

Beziehungen sind eine Technik, die oft in Datenbanken zum Einsatz kommen. Das Konzept ist dass Objekte (Zeilen) verschiedener Layer (Tabellen) zueinander gehören können.

Als Beispiel nehmen wir einen Layer mit allen Regionen von Alaska (Polygon) in dem einige Attribute über den Namen und den Regionstyp sowie eine eindeutige ID (die als Primärschlüssel eingesetzt wird) vorhanden sind.

Fremdschlüssel

Dann erhalten Sie einen anderen Punktlayer oder Tabelle mit Informationen über Flughäfen die in den Regionen liegen und wollen diese ebenfalls im Auge behalten. Wenn Sie diese dem Regionen Layer hinzufügen wollen müssen Sie eine Eine-Zu-Mehrere-Beziehung anhand von Fremdschlüsseln erstellen weil es in den meisten Regionen mehrere Flughäfen gibt.

Figure Relations 1:

../../../_images/relations1.png

Die Region Alaska mit Flughäfen nix

Zusätzlich zu den bereits bestehenden Attributen in der Airport Attributtabelle wird ein anderes Feld fk_region das als Fremdschlüssel verwendet werden soll, eingefügt (wenn Sie eine Datenbank verwenden würden Sie wahrscheinlich dafür einen Constraint definieren).

Dieses Feld fk_region enthält immer eine ID einer Region. Man kann es als Zeiger zu der Region, zu der es gehört, betrachten. Und sie können eine benutzerdefinierte Eingabemaske erstellen wobei QGIS sich um das Einrichten kümmert. Es funktioniert mit verschiedenen Anbietern (so dass sie es mit Shape- und CSV-Dateien benutzen können) und alles was Sie tun müssen ist QGIS die Beziehung zwischen Ihren Tabellen mitzuteilen.

Layer

QGIS unterscheidet nicht zwischen einer Tabelle und einem Vektorlayer. Grundsätzlich gesehen ist ein Vektorlayer eine Tabelle mit einer Geometrie. Sie können Ihre Tabelle also als Vektorlayer einfügen. Zu Demonstrationszwecken können Sie die ‘region’ Shapedatei (mit Geometrien) und die ‘airport’ CSV-Tabelle (ohne Geometrien) und einen Fremdschlüssel (fk_region) zu dem Layer ‘region’ laden (eine typische Ein-Zu-Mehrere Beziehung).

Definition (Relation Manager)

Das erste was wir machen müssen ist QGIS über die Beziehungen zwischen den Layern wissen lassen. Dies wird in Einstellungen ‣ Projekteigenschaften gemacht. Öffnen Sie das Beziehungen Menü und klicken Sie auf Beziehung hinzufügen.

  • Name wird als Titel verwendet. Es sollte eine lesbare Zeichenfolge sein, die beschreibt, wofür die Beziehung verwendet werden soll. Wir werden ihn in diesem Fall einfach ‘Airports’ nennen.

  • Referenzierender Layer ist der in dem der Fremdschlüssel steht. In diesem Fall ist dies der ‘airports’ Layer.

  • Referenzierendes Feld zeigt an welches Feld auf den anderen Layer zeigt, also ist dies in diesem Fall fk_region

  • Referenzierter Layer ist der mit dem Primärschlüssel, auf den gezeigt wird, also ist dies in diesem Fall der ‘regions’ Layer

  • Referenziertes Feld ist der Primärschlüssel des referenzierten Layers, also die ID.

  • ID wird für interne Zwecke benutzt und muss eindeutig sein. Sie brauchen es vielleicht um benutzerdefinierte Eingabemasken zu erstellen sobald dies unterstützt wird. Wenn Sie es leer lassen wird eines für Sie erstellt aber Sie können auch selber eine zuweisen die einfacher zu handhaben ist.

Figure Relations 2:

../../../_images/relations2.png

Relation Manager nix

Formulare

Jetzt wo QGIS von der Beziehung weiss wird es dazu benutzt das Formular das es erstellt zu verbessern. Da wir die Standard Formular Methode (autogenerated) nicht verändert haben, wird es Ihrem Formular einfach ein neues Bearbeitungselement hinzufügen. Also lassen Sie uns einen Layer ‘region’ in der Legende auswählen und das Objekte abfragen Werkzeug benutzen. Abhängig von Ihren Einstellungen öffnet sich das Formular entweder direkt oder Sie müssen den Identifizieren Dialog unter Aktionen öffnen.

Figure Relations 3:

../../../_images/relations3.png

identifikationsergebnis Dialog von regions mit Beziehung zu airports nix

Wie Sie sehen können werden die dieser bestimmten region zugeordneten airports alle in einer Tabelle gezeigt. Und es ikönnen außerdem einige Knöpfe benutzt werden. Lassen Sie uns einen kurzen Blick daruf werfen

  • Der mActionToggleEditing Knopf ist zum Umschalten des Bearbeitungsmodus da. Seien Sie sich dessen bewusst dass es den Bearbeitungsmodus des ‘airport’ Layers umschaltet, trotzdessen wir uns im Objektformular eines Objektes aus dem ‘region’ Layer befinden. Die Tabelle jedoch stellt Objekte des ‘aiport’ Layer dar.

  • Der mActionSignPlus Knopf wird dem ‘airport’ Layer ein neues Objekt hinzufügen. Und es wird den neuen airport der aktuellen region standardmäßig zuordnen.

  • Der mActionRemove Knopf löscht den ausgewählten airport dauerhaft.

  • Das mActionLink Symbol öffnet einen neuen Dialog in dem Sie jeden vorhandenen ‘airport’ auswählen können was dann der aktuellen ‘region’ zugewiesen wird. Dies kann nützlich sein wenn Sie den ‘airport’ aus Versehen in der falschen ‘region’ erstellt haben.

  • Das mActionUnlink Symbol hebt die Verbindung zwischen dem ausgewählten ‘airport’ und der aktuellen ‘region’ wieder auf so dass dieser auf wirksame Art und Weise nicht mehr zugewiesen ist (der Fremdschlüssel wird auf NULL gesetzt).

  • Die zwei Knöpfe rechts wechseln zwischen Tabellenansicht und Formularansicht wobei Sie bei der letzten Einstellung alle ‘airports’ in ihrer jeweiligen Form sehen können.

Wenn Sie an der ‘airport’ Tabelle arbeiten steht ein neuer Typ von Bearbeitungselement zur Verfügung, mit dem Sie das Objektformular der referenzierten ‘region’ in das Objektformular der ‘airports’ einbetten können. Es kann verwendet werden wenn Sie die Layereigenschaften der ‘airports’ Tabelle öffnen, zum Felder Menü wechseln und den Typ des Bearbeitungselements des Fremdschlüssels ‘fk_region’ auf Beziehungsreferenz ändern.

Wenn Sie jetzt einen Blick auf den Objektdialog werfen werden Sie sehen dass das Formular der ‘region’ in das ‘airports’ Formular eingebettet ist und sogar eine Kombobox vorhanden ist mit dem der aktuelle ‘airport’ zu einer anderen ‘region’ zugeordnet werden kann.

Figure Relations 4:

../../../_images/relations4.png

Objekte abfragen Dialog von ‘airport’ mit Beziehung zu ‘regions’ nix