Outdated version of the documentation. Find the latest one here.

.

QGIS Konfiguration

Sie können QGIS auf vielfache Art und Weise im Menü Einstellungen ‣ anpassen. Wählen Sie zwischen Bedienfeldern, Werkzeugkästen, Projekteinstellungen, Optionen und Anpassungen.

Bemerkung

QGIS befolgt die Desktopvorgaben zum Lokalisieren der Optionen und Projekteigenschaften. Im Zusammenhang mit dem von Ihnen verwendeten Betriebssystem können die oben Beschriebenen Dialoge entweder im Menü Ansicht (Bedienfelder und Werkzeugleisten) oder in Projekt für Optionen gefunden werden.

Bedienfelder und Werkzeugkästen

Im Bedienfelder ‣ Menü können Sie QGIS Widgeds an- und ausschalten. Das Werkzeugkäste ‣ Menü bietet Ihnen die Möglichkeit Icongruppen in der QGIS Werkzeugleiste an- und auszuschalten (siehe figure_panels_toolbars).

Figure Panels and Toolbars:

../../../_images/panels_and_toolbars.png

Das Bedienfelder und Werkzeugkästen Menü nix

Tipp

Die QGIS-Übersicht aktivieren

Sie können in QGIS eine Übersicht, die die Gesamtausdehnung der hinzugefügten Layer wiedergibt, benutzen. Sie kann unter dem Menu Einstellungen ‣ Bedienfelder ausgewählt werden. Innerhalb des Fensters zeigt ein Rechteck die aktuelle Kartenausdehnung an. Dies ermöglicht es Ihnen schnell zu bestimmen welchen Bereich der Karte Sie gerade sehen. Beachten Sie dass Beschriftungen auch wenn die Layer explizit beschriftet worden sind in der Übersicht nicht dargestellt werden. Wenn Sie auf das Rechteck klicken und es in der Übersicht, die die aktuelle Kartenausdehnung zeigt, verschieben wird das Kartenfenster entsprechend geupdatet.

Tipp

Protokoll anzeigen lassen

Es ist möglich das QGIS Protokoll zu verfolgen. Sie können checkbox Protokoll im Menü nix Einstellungen ‣ Bedienfelder oder win Ansicht ‣ Bedienfelder aktivieren und die Meldungen, die in den verschiedene Reitern während des Ladens und im Laufe von Operationen angezeigt werden, verfolgen.

Projekteigenschaften

Im Eigenschaftenfenster für das Projekt unter nix Einstellungen ‣ Projekteinstellungen (kde) oder nix win Projekt ‣ Projekteigenschaften (Gnome) können Sie die projektbezogenen Optionen einstellen. Diese beinhalten:

  • Im Menü Allgemein den Projekttitel, die Auswahl- und Hintergrundfarbe, Layereinheiten, Genauigkeit und die Option die Pfade der Layer relativ zu speichern. Wenn die KBS-Transformation eingeschaltet ist können Sie einen Ellipsoiden für Abstandsberechnungen auswählen. Sie können die Karteneinheiten definieren (nur wenn die KBS-Transformation ausgeschaltet ist) sowie die Genauigkeit der benutzten Dezimalstellen. Auch können Sie eine Liste von Projektmaßstäben festlegen die die global voreingestellten Maßstäbe überschreibt.

  • Im KBS Menü können Sie das Koordinatenbezugssystem für dieses Projekt auswählen und Spontan-Reprojektion für das Darstellen von Vektor- und Rasterlayern mit verschiedenen KBS einschalten.

  • Mit dem dritten Abfragbare Layer Menü legen Sie fest (oder verhindern) welche Layer auf das ‘Objekte abfragen’-Werkzeug reagieren (siehe der Abschnitt über Kartenwerkzeuge im Abschnitt Optionen über das Einschalten der Identifizierung von Mehrfachlayern.).

  • Mit dem Vorgabestile Menü können Sie steuern wie neue Layer dargestellt werden wenn kein .qml Stil definiert wurde. Sie können hier auch den voreingestellten Transparenzlevel bestimmen und einstellen ob Symbolen Zufallsfarben zugewiesen werden sollen. Es gibt auch einen zusätzlichen Abschnitt in dem Sie bestimmte Farben für das laufende Projekt festlegen können. Sie können die hinzugefügten Farben im Drop-down-Menü des Farbdialogfensters, das Sie in jeder Darstellung zur Verfügung steht.

  • Im Menü OWS Server können Sie Informationen über die QGIS Server WMS- und WFS-Eigenschaften, Ausdehnung und KBS-Beschränkungen definieren.

  • Das Menü Macros wird verwendet um Python-Makros für Projekte zu bearbeiten. Zur Zeit sind nur drei Makros möglich:openProject(), saveProject() und closeProject().

Figure Macro Menu:

../../../_images/macro.png

Makroeinstellungen in QGIS

  • Das Menü Beziehungen wird verwendet um 1:n-Beziehungen zu definieren. Die Beziehungen werden im Dialog Projekteigenschaften definiert. Sind einmal Beziehungen für einen Layer erstellt erscheint ein neues Schnittstellenelement im Objektformular (z.B. wenn Sie ein Objekt abfragen und sein Formular öffnen) das die damit verknüpften Elemente auflistet. Dies ist eine leistungsfähige Methode um z.B. die Inspektionsgeschichte eines Pipelineabschnittes oder Straßenabsschnittes auszudrücken. Sie können mehr über die Unterstützung von 1:n Beziehungen im Abschnitt Ein-Zu-Mehrere-Beziehungen erstellen finden.

Optionen

mActionOptions Einige grundlegende Optionen für QGIS können mit dem Optionen Dialog gewählt werden. Wählen Sie die Menüoption Einstellungen ‣ mActionOptions Optionen. Die Menüs mit denen Sie Ihre Optionen optimieren können sind:

Menü Allgemein

Anwendung

  • Wählen Sie Stil (QGIS-Neustart erforderlich) selectstring und wählen Sie zwischen ‘Oxygen’,’Windows’,’Motif’,’CDE’, ‘Plastique’, ‘GTK+’ und ‘Cleanlooks’ (nix).

  • Definieren Sie das Icon-Thema selectstring. Derzeit ist nur ‘default’ möglich.

  • Definieren Sie die Icon-Größe selectstring.

  • Definieren Sie die Schriftart. Wählen Sie zwischen radiobuttonon Qt-Voreinstellung und einer benutzerdefinierten Schriftart.

  • Verändern Sie Dauer von zeitweiligen Meldungen oder Dialogen selectstring.

  • checkbox Splashscreen beim Start nicht anzeigen

  • checkbox Tipps beim Starten anzeigen

  • checkbox Gruppenrahmentitel fett

  • checkbox Gruppenrahmen im QGIS-Stil

  • checkbox Farbauswahldialoge verwenden, die laufend aktualisieren

Projektdateien

  • Projekt beim Starten öffnen selectstring (wählen Sie zwischen ‘Neu’, ‘Zuletzt verwendetes’ und ‘Bestimmtes’). Wenn Sie ‘Bestimmtes’ wählen benutzen Sie den browsebutton Knopf um ein Projekt festzulegen.

  • checkbox Neues Projekt aus Vorgabeprojekt erstellen. Sie haben die Möglichkeit auf Aktuelles Projekt als Vorgabe speichern oder Vorgabe zurücksetzen zu drücken. Sie können durch Ihre Dateien gehen und ein Verzeichnis definieren in dem Sie ihre benutzerdefinierten Projektvorlagen festlegen. Diese werden dann dem Menü Projekt ‣ Neu aus Vorlage hinzugefügt wenn Sie erst checkbox Neues Projekt aus Vorgabeprojekt erstellen aktivieren und dann ein Projekt in den Projektvorlagenordner speichern.

  • checkbox Bei Bedarf nachfragen, ob geänderte Projekt und Datenquellen gespeichert werden sollen

  • checkbox Warnung ausgeben wenn QGIS-Projekt einer früheren Version geöffnet wird

  • Makros aktivieren selectstring. Diese Option wurde erstellt um Makros zu handhaben die geschrieben wurden um eine Aktion auf Projektereignisse auszuführen. Sie können zwischen ‘Nie’, ‘Fragen’, ‘Nur in dieser Sitzung’ und ‘Immer (nicht empfohlen)’ wählen.

Menü System

Umgebung

Systemumgebungsvariablen können nun eingesehen werden und viele von ihnen konfiguriert in der Umgebung Gruppe (siehe figure_environment_variables). Dies ist für Betriebssysteme wie Mac nützlich da dort eine GUI Anwendung nicht notwendigerweise die Shellumgebung des Benutzers übernimmt. Sie ist auch nützlich um Umgebungsvariablen für externe Werkzeuge die von der Verarbeitungs-Toolbox (z.B. SAGA, GRASS) kontrolliert werden zu setzen und zu visualisieren und um die Debug-Ausgabe für bestimmte Abschnitte des Quellcodes anzuschalten.

  • checkbox Benutzerdefinierte Umgebungsvariablen verwenden (Neustart erforderlich - Trennzeichen einschließen). Sie können Variablen [Hinzufügen] und [Entfernen]. Bereits definierte Umgebungsvariablen sind unter Aktuelle Umgebungsvariablen dargestellt und es ist möglich sie zu filtern indem Sie checkbox Nur QGIS-spezifische Variablen anzeigen aktivieren.

Figure System Environment:

../../../_images/sys-env-options.png

Systemumgebungsvariablen in QGIS

Erweiterungspfade

[Hinzufügen] und [Entfernen] von Nach zusätzlichen C++ Erweiterungsbibliotheken zu durchsuchende Pfad(e)

Menü Datenquellen

Objektattribute und -tabelle

  • checkbox Attributtabelle gedockt öffnen (QGIS-Neustart erforderlich)

  • checkbox Geometrie in WKT aus Attributtabelle kopieren. Wenn Sie mActionCopySelected Ausgewählte Zeilen in die Zwischenablage kopieren aus dem Attributtabelle Dialog verwenden, hat dies zum Ergebnis dass auch die Koordinaten von Punkten und Stützpunkten auch in die Zwischenablage kopiert werden.

  • Attributtabellenverhalten selectstring. Es gibt drei Möglichkeiten: ‘Alle Objekte anzeigen’, ‘Alle gewählten Objekte anzeigen’ und ‘Sichtbare Objekte der Karte anzeigen’

  • Attributtabellenzeilencache selectnumber. Dieser Zeilencache erlaubt es, die N zuletzt geladenen Attributzeilen im Cache zu speichern. Dadurch wird das Arbeiten mit der Attributtabelle schneller. Der Cache wird wieder gelöscht, wenn man die Attributtabelle schliesst.

  • Repräsentation für NULL-Werte. Hier können Sie einen Wert für Datenfelder die einen NULL-Wert enthalten festlegen.

Datenquellenbehandlung

  • Nach gültigen Element im Browser suchen selectstring. Sie können zwischen ‘Erweiterung prüfen’ und ‘Dateiinhalt prüfen’ wählen.

  • Inhalt komprimierter Dateien (.zip) im Browser durchsuchen selectstring. ‘Nein’, ‘Grundsuche’ und ‘Vollsuche’ sind möglich.

  • Beim Öffnen nach Rasterunterlayern fragen. Einige Rasterformate unterstützen Unterlayer - sie werden Subdataset in GDAL genannt. Ein Beispiel sind netCDF-Dateien - wenn es viele netCDF-Variablen gibt interpretiert GDAL jede Variable als Subdataset. Die Option ermöglicht es Ihnen zu steuern wie mit Unterlayern umgegangen wird wenn eine Datei mit Unterlayern geöffnet wird. Sie haben die folgenden Wahlmöglichkeiten:

    • ‘Immer’: Immer fragen (ob es Unterlayer gibt)

    • ‘Wenn nötig’: Fragen ob Layer keine Bänder aber Unterlayer hat

    • ‘Nie’: Nie fragen, lädt dann nichts

    • ‘Alle laden’: Nie auffordern aber alle Unterlayer laden

  • checkbox Shapefile-Kodierungsangabe ignorieren. Wenn eine Shapedatei Kodierungsinformationen enthält wird dieses von QGIS ignoriert.

  • checkbox PostGIS-Layer per Doppelklick hinzufügen und zur Auswahl den erweiterten Modus verwenden

  • checkbox Oracle-Layer mit Doppelklick hinzufügen und zur Auswahl den erweiterten Modus verwenden

Menü Darstellung

Zeichenverhalten

  • checkbox Normalerweise werden alle neuen Layer im Kartenfenster angezeigt

  • checkbox Wo möglich den Darstellungscache benutzen, um das Neuzeichnen zu beschleunigen

  • checkbox Layer mit vielen CPU-Kernen parallel zeichnen

  • checkbox Max. zu benutzende Kerne

  • Kartenaktualisierungsintervall

  • checkbox Geometrievereinfachung für neue Layer voreinstellen

  • Vereinfachungsschwelle

  • checkbox Auf Datenlieferantenebene vereinfachen, wenn möglich

  • Größter Maßstab bis zu dem der Layer vereinfacht werden soll

Zeichenqualität

  • checkbox Linie auf Kosten der Zeichengeschwindigkeit weniger gezackt zeichnen

Raster

  • Mit RGB Kanalauswahl können Sie Nummer für den Roten Kanal, Grünen Kanal und Blauen Kanal festlegen.

Kontrasverbesserung

  • Einkanalgraustufen selectstring. Für ein Einkanalgraustufenband kann eingestellt werden: ‘Kein Stretch’, ‘Strecken auf MinMax’, ‘Strecken und Zuschneiden auf MinMax’ und ‘Zuschneiden auf ‘MinMax’.

  • Multikanalfarbe (Byte/Kanal) selectstring. Optionen sind ‘Kein Strecken’, ‘Strecken auf MinMax’, ‘Strecken und Zuschneiden auf MinMax’ und ‘Zuschneiden auf MinMax’.

  • Multikanalfarbe (>Byte/Band) selectstring. Optionen sind ‘Kein Strecken’, ‘Strecken auf MinMax’, ‘Strecken und Zuschneiden auf MinMax’ und ‘Zuschneiden auf MinMax’

  • Grenzen (Minimum/Maximum) selectstring. Optionen sind ‘Kumulativer Pixelanzahl-Schnitt’, ‘Minimum/Maximum’, ‘Mittlere +/- Standardabweichung’

  • Kommulative Pixelanzahl-Schnittgrenzen

  • Standardabweichungsfaktor

Fehlersuche

  • checkbox Kartenaktualisierung

Menü Farben

Dieses Menü ermöglicht es Ihnen benutzerdefinierte Farben hinzuzufügen die Sie in jedem Farbdialogfenster der Darstellungen finden können. Sie sehen in dem Reiter eine Reihe von vordefnierten Farben: Sie können alle löschen oder bearbeiten. Darüberhinaus können Sie eine Farbe Ihrer Wahl hinzufügen und eine Kopieren und Einfügen Operation durchführen. Schließlich können Sie den Farbsatz als gpl Datei exportieren oder importieren.

Menü Karte und Legende

Voreingestelltes Kartenaussehen (Projekteigenschaften überschreiben)

  • Definieren Sie eine Farbe für Auswahlen und eine Hintergrundfarbe

Layerlegende

  • Doppelklickaktion in Legende selectstring. Sie können mit dem Doppelklick entweder ‘Layereigenschaften öffnen’ oder ‘Attributtabelle öffnen’.

  • Die folgenden Legendenelementstile sind möglich:

    • checkbox Layernamen groß schreiben

    • checkbox Layernamen fett

    • checkbox Gruppennamen fett

    • checkbox Klassifikationsattributnamen anzeigen

    • checkbox Rastericons erzeugen (kann langsam sein)

    • checkbox Neue Layer zur gewählten oder aktuellen Gruppe hinzufügen

Menü Kartenwerkzeuge

Dieses Menü bietet einige Optionen in Bezug auf das Verhalten des Objekte abfragen Werkzeugs.

  • Suchradius für die Objektidentifikation und zur Maptipanzeige ist ein Toleranzfaktor ausgedrückt als Prozentsatz der Kartenbreite. Das heißt dass das Objekte abfragen Werkzeug so lange Ergebnisse anzeigt wie sie innerhalb dieser Toleranz klicken.

  • Mit Hervorhebungsfarbe können Sie wählen mit welcher Farbe abgefragte Objekte hervorgehoben werden solllen.

  • Puffer, ausgedrückt als Prozentsatz der Kartenbreite, legt eine Pufferdistanz, die durch die Umrisslinie der Hervorhebung dargestellt wird, fest.

  • Minimalbreite, ausgedrückt als Prozentsatz der Kartenbreite, legt fest wie dick die Umrisslinie eines hervorgehobenen Objektes sein soll.

Messwerkzeug

  • Definieren Sie Gummibandfarbe für das Meßwerkzeug

  • Definieren Sie Dezimalstellen

  • checkbox Basiseinheit beibehalten

  • Bevorzugte Maßeinheiten radiobuttonon (‘Meter’, ‘Fuß’, ‘Seemeilen’ oder ‘Grad’)

  • Bevorzugtes Winkelmaß radiobuttonon (‘Grad’, ‘Bogenmaß’ oder ‘Gon’)

Verschieben und Zoomen

  • Definieren Sie Mausradaktion (‘Zoom’, `Zoomen und mittig zentrieren, Zur Mausposition zoomen, Nichts)

  • Definieren Sie Zoomfaktor für das Mausrad

Vordefinierte Maßstäbe

Hier finden Sie eine Liste von vordefinierten Maßstäben. Mit den [+] und [-]-Knöpfen können Sie Ihre individuellen Maßstäbe hinzufügen oder löschen.

Menü Zusammenstellung

Zusammenstellungsvoreinstellungen

Sie können hier die Vorgabeschriftart festlegen

Gitterdarstellung

  • Definieren Sie den Gitterstil selectstring (‘Ausgefüllt’, ‘Punkte’, ‘Kreuze’)

  • Definieren Sie Farbe ...

Gittervoreinstellungen

  • Legen Sie Zwischenräume selectnumber fest

  • Legen Sie den Gitterversatz selectnumber für x und y fest

  • Legen Sie die Fangtoleranz selectnumber fest

Führungsvorgaben

  • Legen Sie die Fangtoleranz selectnumber fest

Menü Kartenwerkzeuge

Objekterzeugung

  • checkbox Eingabe der Attributwerte bei der Erstellung neuer Objekte unterdrücken

  • checkbox Letzte Attributwerteingaben wiederverwenden

  • Geometrien prüfen. Das Bearbeiten komplexer Linien/Polygone mit vielen Stützpunkten kann zu einer erheblichen Verlangsamung der Darstellung führen. Das liegt an den Standard-Validierungsverfahren, die viel Zeit benötigen. Um die Darstellung zu beschleunigen ist es möglich die Geometrieüberprüfung von GEOS (von GEOS 3.3.an) zu wählen oder die Validierung ganz auszuschalten. Die GEOS Geometrieüberprüfung ist viel schneller, aber der Nachteil ist dass nur das erste Geometrieproblem gemeldet wird.

Gummiband

  • Definieren Sie für das Gummiband die Linienbreite und Linienfarbe

Objektfang

  • checkbox Fangoptionsdialog in einem Dockfenster anzeigen (QGIS-Neustart erforderlich)

  • Legen Sie den Voreingestellten Fangmodus selectstring (‘Zum Stützpunkt’, ‘Zum Segment’, ‘Zum Stützpunkt und Segment’, ‘Aus’) fest

  • Definieren Sie die Voreingestellte Fangtoleranz in Karteneinheiten oder Pixeln

  • Definieren Sie den Suchradius für die Stützpunktbearbeitung in Karteneinheiten oder Pixeln.

Stützpunktmarken

  • checkbox Markierungen nur für gewählte Objekte anzeigen

  • Legen Sie für die Stützpunktmarken den Markierungsstil selectstring (‘Kreuz’ (standard), ‘Teiltransparenter Kreis’ oder ‘Keine’) fest

  • Definieren Sie die Markierungsgröße für die Stützpunktmarken

Werkzeug zum Linien versetzen

Die nächsten 3 Optionen beziehen sich auf das mActionOffsetCurve Linie versetzen Werkzeug in Erweiterte Digitalisierung. Durch die verschiedenen Einstellungen ist es möglich die Form des Linienversatzes zu beeinflussen. Diese Optionen sind von GEOS 3.3 an möglich.

  • Verbindungsstil

  • Quadrantensegmente

  • Eckengrenze

Menü GDAL

GDAL ist eine Datenaustauschbibliothek für Rasterdateien. In diesem Menü können Sie Erzeugungsoptionen bearbeiten und Pyramidenoptionen bearbeiten . Definieren Sie welcher GDAL-Treiber für ein Rasterformat benutzt wird, da in einigen Fällen mehr als ein Treiber zur Verfügung gestellt wird.

Menü KBS

Vorgabe-KBS für neue Projekte

  • radiobuttonoff ‘Spontanreprojektion’ nicht einschalten

  • radiobuttonon Spontanreprojektion (SRP) automatisch aktivieren wenn die Layer unterschiedliche KBS haben

  • radiobuttonoff Spontanreprojektion voreinstellen

  • Wählen Sie ein KBS aus und Neue Projekte immer in diesem KBS beginnen

KBS für neue Layer

Der zweite Bereich ermöglicht es, Voreinstellungen vorzunehmen, wenn ein neuer Layer erzeugt wird oder ein Layer geladen wird, der keine KBS Information besitzt.

  • radiobuttonon KBS abfragen

  • radiobuttonoff KBS des Projekts benutzen

  • radiobuttonoff Folgendes KBS benutzen

Datumtransformationsvorgaben

  • checkbox Datumtransformation erfragen wenn keine Vorgabe definiert ist

  • Wenn Sie mit der ‘Spontan’ KBS Transformation gearbeitet haben können sie das Ergebnis der Transformation im Fenster unten sehen. Sie können Informationen über das ‘Quell-KBS’ und das ‘Ziel-KBS’ genauso wie über ‘Quell-Datumstransformation’ und ‘Ziel-Datumstransformation’ finden.

Menü Sprache

  • checkbox System-Locale überschreiben und Stattdessen folgende Spracheinstellungen benutzen

  • Informationen über die aktive System-Locale

Menü Netzwerk

Allgemein

  • WMS Suchadresse - Standard ist http://geopole.org/wms/search?search=%1&type=rss

  • Definieren Sie Zeitüberschreitung für Netzwerkanfragen (ms) - Standard ist 60000

  • Definieren Sie Verfallszeitraumvorgabe für WMS-C/WMTS Kacheln (Stunden) - Standard ist 24

  • Legen Sie Maximale Wiederholungen bei Kachelabfragefehlern fest.

  • Definieren Sie User-Agent

Figure Network Tab:

../../../_images/proxy-settings.png

Proxy-Einstellungen in QGIS

Cache-Einstellungen

Definieren Sie das Verzeichnis und eine Größe für den Cache.

  • checkbox Proxy für Web-Zugriff benutzen und entsprechend ‘Host’, ‘Port’, ‘Benutzer’ und ‘Passwort’ definieren.

  • Definieren Sie den Proxytyp ‣ entsprechend ihrer Bedürfnisse.

    • DefaultProxy ‣: Proxy wird auf Grundlage des Proxy der Anwendung festgelegt

    • Socks5Proxy ‣: Proxy für jede Art von Verbindung. Unterstützt TCP, UDP, Bindung an einen Port (eingehende Verbindungen) und Authentifizierung.

    • HttpProxy ‣: Umgesetzt mit dem “CONNECT”-Befehl, unterstützt nur ausgehende TCP-Verbindungen und Authentifizierung.

    • HttpCachingProxy:Umgesetzt mit normalen HTTP Befehlen ist dies nur im Zusammenhang mit HTTP Befehlen sinnvoll einzusetzen.

    • FtpCachingProxy: Mit einem FTP-Proxy umgesetzt ist dies nur sinnvoll im Zusammenhang mit FTP-Anforderungen anzuwenden

Das Ausschließen von URLs kann in das Textfenster unter den Proxyeinstellungen eingetragen werden (siehe Figure_Network_Tab).

Wenn Sie weitere Informationen über die verschiedenen Proxyeinstellungen benötigen, schauen Sie bitte im Handbuch der QT-Bibliothek nach unter der http://doc.trolltech.com/4.5/qnetworkproxy.html#ProxyType-enum.

Tipp

Proxy richtig anwenden

Das Verwenden von Proxys kann manchmal schwierig sein. Es ist sinnvoll die oben angesprochenen Proxytypen auszuprobieren, um zu sehen, welcher in dem jeweiligen Fall am besten funktioniert.

Sie können die Optionen nach Ihren Bedürfnissen verändern. Bei einigen der Änderungen kann ein Neustart von QGIS erforderlich sein bevor sie wirksam werden.

  • nix Einstellungen sind gespeichert in einer Textdatei: $HOME/.config/QGIS/QGIS2.conf

  • osx Alle Einstellungen sind gespeichert in: $HOME/Library/Preferences/org.qgis.qgis.plist

  • win Einstellungen sind gespeichert in der Registry unter: HKEYCURRENT_USERSoftwareQGISqgis

Anpassung

Mit dem Anpassungswerkzeug können fast jedes Element in der QGIS Benutzeroberfläche (de)aktivieren. Dies kann sehr nützlich sein wenn man viele Plugins, die sie nie benutzen und die den Bildschirm überfüllen, installiert hat.

Figure Customization 1:

../../../_images/customization.png

Der Anpassung Dialog nix

Die QGIS-Anpassung ist in fünf Gruppen unterteilt. Mit checkbox Menus können Sie Einträge aus der Menüleiste verstecken. In checkbox Panels finden Sie die Dock-Fenster. Dock-Fenster sind Anwendungen die als frei schwebendes top-level Fenster oder eingebettet in das QGIS Hauptfenster a gedocktes Widged gestartet und genutzt werden können (siehe auch Bedienfelder und Werkzeugkästen). Mit checkbox Status Bar können Features wie die Koordinateninformation deaktiviert werden. Mit checkbox Toolbars können Sie Werkzeugleisteneinträge von QGIS und mit checkbox Widgeds können Sie Dialoge genauso wie Ihre Knöpfe (de)aktivieren.

Mit mActionSelect Umschalten um Bedienelemente der Hauptapplikation zu fangen können Sie auf Elemente in QGIS die sie verstecken wollen klicken und den enstprechenden Eintrag in Anpassung finden (siehe figure_customization). Sie können genauso ihre verschiedenen Setups für verschiedene Anwendungen speichern. Sie müssen QGIS neustarten bevor die Änderungen angewendet werden.