Outdated version of the documentation. Find the latest one here.

Editar

QGIS supports various capabilities for editing OGR, SpatiaLite, PostGIS, MSSQL Spatial and Oracle Spatial vector layers and tables.

Nota

El procedimiento para edición de capas GRASS es diferente - vea la sección Digitalizar y editar una capa vectorial GRASS para más detalles.

Truco

Las ediciones simultáneas

This version of QGIS does not track if somebody else is editing the same feature at the same time as you are. The last person to save its edits wins.

Configurar la tolerancia del autoensamblado y radio de búsqueda

For an optimal and accurate edit of the vector layer geometries, we need to set an appropriate value of snapping tolerance and search radius for features vertices.

Tolerancia de autoensamblado

Snapping tolerance is the distance QGIS uses to search for the closest vertex and/or segment you are trying to connect to when you set a new vertex or move an existing vertex. If you aren’t within the snapping tolerance, QGIS will leave the vertex where you release the mouse button, instead of snapping it to an existing vertex and/or segment. The snapping tolerance setting affects all tools that work with tolerance.

  1. A general, project-wide snapping tolerance can be defined by choosing Settings ‣ options Options..., Digitizing tab. You can select between ‘To vertex’, ‘To segment’ or ‘To vertex and segment’ as default snap mode. You can also define a default snapping tolerance and a search radius for vertex edits. The tolerance can be set either in map units or in pixels. The advantage of choosing pixels is that the snapping tolerance doesn’t have to be changed after zoom operations. In our small digitizing project (working with the Alaska dataset), we define the snapping units in feet. Your results may vary, but something on the order of 300 ft at a scale of 1:10000 should be a reasonable setting.
  2. A layer-based snapping tolerance that overrides the global snapping options can be defined by choosing Settings ‣ Snapping options. It enables and adjusts snapping mode and tolerance on a layer basis (see figure_edit_1 ). This dialog offers three different modes to select the layer(s) to snap to:
    • Current layer: only the active layer is used, a convenient way to ensure topology within the layer being edited
    • All layers: a quick and simple setting for all visible layers in the project so that the pointer snaps to all vertices and/or segments. In most cases it is sufficient to use this snapping mode.
    • Advanced: if you need to edit a layer and snap its vertices to another layer, ensure the target layer is checked and increase the snapping tolerance to a greater value. Furthermore, snapping will never occur to a layer that is not checked in the snapping options dialog, regardless of the global snapping tolerance. So be sure to mark the checkbox for those layers that you need to snap to.

Figure Edit 1:

../../../_images/editProjectSnapping.png

Editar opciones de autoensamblado en base a una capa (modo Avanzado)

Truco

Control the list of layers to snap

The Snapping Options dialog is by default populated with parameters (mode, tolerance, units) set in the global Digitizing tab. To avoid layers being checked by default in the Advanced mode and hence set snappable, define the Default Snap mode to Off.

Snapping tolerance can be set in pixels or map units (the units of the map view). While in the Advanced layer selection mode, it is possible to use a snapping tolerance that refers to layer units, the units of the reprojected layer when ‘on-the-fly’ CRS transformation is on.

Radio de búsqueda

Search radius is the distance QGIS uses to search for the closest vertex you are trying to select when you click on the map. If you aren’t within the search radius, QGIS won’t find and select any vertex for editing. Snap tolerance and search radius are set in map units or pixels, so you may find you need to experiment to get them set right. If you specify too big of a tolerance, QGIS may snap to the wrong vertex, especially if you are dealing with a large number of vertices in close proximity. Set search radius too small, and it won’t find anything to move.

El radio de búsqueda para edición de vértices en las unidades de capa se pueden definir en la pestaña Digitalizar bajo Configuración‣ options Opciones. Este es el mismo lugar donde se define lo general, proyecto de tolenancia de autoensamblado.

Edición topológica

Besides layer-based snapping options, you can also define topological functionalities in the Snapping options... dialog in the Settings (or File) menu. Here, you can define checkbox Enable topological editing, and/or for polygon layers, activate the checkbox Avoid Intersections option.

Habilitar edición topológica

The option checkbox Enable topological editing is for editing and maintaining common boundaries in features mosaics. QGIS ‘detects’ shared boundary by the features, so you only have to move a common vertex/segment once, and QGIS will take care of updating the neighboring features.

Evitar intersecciones de nuevos polígonos

A second topological option called checkbox Avoid intersections prevents you to draw new features that overlap an existing one. It is for quicker digitizing of adjacent polygons. If you already have one polygon, it is possible with this option to digitize the second one such that both intersect, and QGIS then cuts the second polygon to the boundary of the existing one. The advantage is that you don’t have to digitize all vertices of the common boundary.

Nota

If the new geometry is totally covered by existing ones, it gets cleared and the new feature will have no geometry when allowed by the provider, otherwise saving modifications will make QGIS pop-up an error message.

Advertencia

Use cautiously the Avoid Intersections option

Because the option cuts or clears geometry of any overlaping feature from any polygon layer, do not forget to uncheck this option once you no longer need it otherwise, you can get unexpected geometries.

Habilitar autoensamblado en intersecciones

Otra opción es utilizar checkbox Habilitar autoensamblado en intersección. Le permitirá que se ajuste a una intersección de las capas de fondo, incluso si no hay ningún vértice en la intersección.

Comprobador de Geometría

A core plugin can help the user to find the geometry invalidity. You can find more information on this plugin at Complemento Comprobador de geometría.

Digitalizando una capa existente

Por defecto, QGIS carga las capas en sólo lectura. Esta es una salvaguardia para evitar la edición de una capa de forma accidental, si hay un deslizamiento del ratón. Sin embargo, se puede optar por editar cualquier capa, siempre y cuando el proveedor de datos lo reconozca, y la fuente de datos subyacente es de escritura (es decir, sus archivos no son de sólo lectura).

In general, tools for editing vector layers are divided into a digitizing and an advanced digitizing toolbar, described in section Digitalización avanzada. You can select and unselect both under View ‣ Toolbars ‣. Using the basic digitizing tools, you can perform the following functions:

Icono

Propósito

Icono

Propósito

allEdits

Ediciones actuales

toggleEditing

Conmutar edición

capturePoint

Adicionar Característica: Capturar Punto

captureLine Add Feature: Capture Line
capturePolygon Add Feature: Capture Polygon moveFeature

Mover objeto espacial

circularStringCurvePoint

Agregar Cadena Circular

circularStringRadius Add Circular String By Radius
nodeTool

Herramienta de nodos

deleteSelected

Borrar lo seleccionado

editCut

Cortar objetos espaciales

editCopy

Copiar objetos espaciales

editPaste

Pegar objetos espaciales

saveEdits

Guardar cambios de la capa

Edición de tabla: Barra de herramientas de edición básica de capa vectorial

Note that while using any of the digitizing tools, you can still zoom or pan in the map canvas without losing the focus on the tool.

All editing sessions start by choosing the toggleEditing Toggle editing option found in the context menu of a given layer, from the attribute table dialog, the digitizing toolbar or the Edit menu.

Once the layer is in edit mode, additional tool buttons on the editing toolbar will become available and markers will appear at the vertices of all features unless Show markers only for selected features option under Settings ‣ Options... ‣ Digitizing menu is checked.

Truco

Guardar regularmente

Remember to saveEdits Save Layer Edits regularly. This will also check that your data source can accept all the changes.

Añadir objetos espaciales

You can use the capturePoint Add Feature, captureLine Add Feature or capturePolygon Add Feature icons on the toolbar to add new feature (point, line and polygon) into the current layer.

The next buttons circularStringCurvePoint Add circular string or circularStringRadius Add circular string by radius allow users to add line or polygon features with a circular geometry.

To create features with these tools, you first digitize the geometry then enter its attributes. To digitize the geometry, left-click on the map area to create the first point of your new feature.

For linear or curved geometries, keep on left-clicking for each additional point you wish to capture or use automatic tracing capability to accelerate the digitization. You can switch back and forth between linear Add feature tool and curved Add circular string... tools to create compound curved geometry. Pressing Delete or Backspace key reverts the last node you add. When you have finished adding points, right-click anywhere on the map area to confirm you have finished entering the geometry of that feature.

Nota

Curved geometries are stored as such only in compatible data provider

Although QGIS allows to digitize curved geometries within any editable data format, you need to be using a data provider (e.g. PostGIS, GML or WFS) that supports curves to have features stored as curved, otherwise QGIS segmentizes the circular arcs. The memory layer provider also supports curves.

Truco

Customize the digitizing rubber band

While capturing polygon, the by-default red rubber band can hide underlying features or places you’d like to capture a point. This can be fixed by setting a lower opacity (or alpha channel) to the rubber band’s Fill Color in Settings ‣ Options ‣ Digitizing menu. You can also avoid the use of the rubber band by checking Don’t update rubber band during node editing.

The attribute window will appear, allowing you to enter the information for the new feature. Figure_edit_2 shows setting attributes for a fictitious new river in Alaska. However, in the Digitizing menu under the Settings ‣ Options menu, you can also activate:

  • checkbox Suppress attributes pop-up windows after each created feature to avoid the form opening
  • or checkbox Reuse last entered attribute values to have fields automatically filled at the opening of the form and just have to type changing values.

Figure Edit 2:

../../../_images/editDigitizing.png

Enter Attribute Values Dialog after digitizing a new vector feature

With the moveFeature Move Feature(s) icon on the toolbar, you can move existing features.

Herramienta de nodos

For shapefile-based or MapInfo layers as well as SpatiaLite, PostgreSQL/PostGIS, MSSQL Spatial, and Oracle Spatial tables, the nodeTool Node Tool provides manipulation capabilities of feature vertices similar to CAD programs. It is possible to simply select multiple vertices at once and to move, add or delete them altogether. The node tool also works with ‘on the fly’ projection turned on and supports the topological editing feature. This tool is, unlike other tools in QGIS, persistent, so when some operation is done, selection stays active for this feature and tool.

It is important to set the property Settings ‣ options Options ‣ Digitizing ‣ Search Radius: selectNumber to a number greater than zero. Otherwise, QGIS will not be able to tell which vertex is being edited and will display a warning.

Truco

Marcadores vértices

La actual versión de QGIS reconoce tres tipos de marcadores de vértices: ‘Círculo semitransparente’, ‘Cruz’ y ‘Nada’. Para cambiar el estilo del marcador, seleccione options Opciones del menú Configuración, haga clic en la pestaña Digitalización y seleccione la entrada apropiada.

Operaciones básicas

Start by activating the nodeTool Node Tool and selecting a feature by clicking on it. Red boxes will appear at each vertex of this feature.

  • Selección de vértices: Se pueden seleccionar los vértices al hacer clic sobre ellos uno a la vez, al hacer clic en un borde para seleccionar los vértices en ambos extremos, o haciendo clic y arrastrando un rectángulo alrededor de algunos vértices. Cuando se selecciona un vértice, su color cambia a azul. Para añadir más vértices a la selección actual, mantenga pulsado la tecla Ctrl mientras se hace clic. Mantenga pulsada la tecla Ctrl cuando haga clic para cambiar el estado de selección de vértices (los vértices que no están actualmente seleccionados serán seleccionados como de costumbre y los vértices que ya están seleccionados se convertirán en no seleccionado).

  • Añadir vértices: Para añadir un vértice, sólo haga doble clic cerca de un borde y un nuevo vértice aparecerá en el borde cerca del cursor. Tome en cuenta que el vértice aparecerá en el borde, no el la posición del cursor; por lo tanto se debe mover si es necesario.

  • Deleting vertices: Select the vertices and click the Delete key. Deleting all the vertices of a feature generates, if compatible with the datasource, a geometryless feature. Note that this doesn’t delete the complete feature, just the geometry part; To delete a complete feature use the deleteSelected Delete Selected tool.
  • Moving vertices: Select all the vertices you want to move, click on a selected vertex or edge and drag in the direction you wish to move. All the selected vertices will move together. If snapping is enabled, the whole selection can jump to the nearest vertex or line.

Each change made with the node tool is stored as a separate entry in the Undo dialog. Remember that all operations support topological editing when this is turned on. On-the-fly projection is also supported, and the node tool provides tooltips to identify a vertex by hovering the pointer over it.

Truco

Move features with precision

The moveFeature Move Feature tool doesn’t currently allow to snap features while moving. Using the nodeTool Node Tool, select ALL the vertices of the feature, click a vertex, drag and snap it to a target vertex: the whole feature is moved and snapped to the other feature.

El Editor de Vértice

With activating the Node Tool on a feature, QGIS opens the Vertex Editor panel listing all the vertices of the feature with their x, y (z, m if applicable) coordinates and r (for the radius, in case of circular geometry). Simply select a row in the table does select the corresponding vertex in the map canvas, and vice versa. Simply change a coordinate in the table and your vertex position is updated. You can also select multiple rows and delete them altogether.

Figure Edit 3:

../../../_images/vertex_editor_panel.png

Vertex editor panel showing selected nodes

Cortar, copiar, y pegar objetos espaciales

Selected features can be cut, copied and pasted between layers in the same QGIS project, as long as destination layers are set to toggleEditing Toggle editing beforehand.

Truco

Transform polygon into line and vice-versa using copy/paste

Copy a line feature and paste it in a polygon layer: QGIS pastes in the target layer a polygon whose boundary corresponds to the closed geometry of the line feature. This is a quick way to generate different geometries of the same data.

Features can also be pasted to external applications as text. That is, the features are represented in CSV format, with the geometry data appearing in the OGC Well-Known Text (WKT) format. WKT features from outside QGIS can also be pasted to a layer within QGIS.

When would the copy and paste function come in handy? Well, it turns out that you can edit more than one layer at a time and copy/paste features between layers. Why would we want to do this? Say we need to do some work on a new layer but only need one or two lakes, not the 5,000 on our big_lakes layer. We can create a new layer and use copy/paste to plop the needed lakes into it.

Como un ejemplo, copiaremos algunos lagos a una nueva capa:

  1. Cargar la capa desde donde desee copiar (capa fuente)

  2. Cargar o crear la capa a la que desee copiar (capa destino)

  3. Comenzar a editar la capa destino

  4. Hacer la capa de fuente activa haciendo clic sobre ella en la leyenda

  5. Use the selectRectangle Select Features by area or single click tool to select the feature(s) on the source layer
  6. Click on the editCopy Copy Features tool
  7. Hacer la capa de destino activa haciendo clic en la leyenda.

  8. Click on the editPaste Paste Features tool
  9. Detener edición y guardar los cambios

¿Qué pasa si la capa de origen y destino tienen diferentes esquemas (los nombres de campo y tipo no son los mismos)? QGIS poblará los que coinciden e ignorará el resto. Si no son importantes los atributos que se copian a la capa de destino, no importa la forma de diseñar los campos y tipos de datos. Si desea asegurarse de que todo - el objeto espacial y sus atributos - se copia, asegúrese de que los esquemas coincidan.

Nota

Congruencia del pegado de objetos espaciales

Si su capa de origen y destino utilizan la misma proyección, entonces el pegado de objetos espaciales tendrá la geometría idéntica a la capa origen. Sin embargo, si el destino tiene una proyección diferente, entonces QGIS no puede garantizar que la geometría sea idéntica. Esto es simplemente porque hay pequeños errores de redondeo involucrados en la conversión entre las proyecciones.

Truco

Copiar atributos de texto en otro

If you have created a new column in your attribute table with type ‘string’ and want to paste values from another attribute column that has a greater length the length of the column size will be extended to the same amount. This is because the GDAL Shapefile driver starting with GDAL/OGR 1.10 knows to auto-extend string and integer fields to dynamically accommodate for the length of the data to be inserted.

Borrar objetos espaciales seleccionados

If we want to delete an entire feature (attribute and geometry), we can do that by first selecting the geometry using the regular selectRectangle Select Features by area or single click tool. Selection can also be done from the attribute table. Once you have the selection set, press Delete or Backspace key or use the deleteSelected Delete Selected tool to delete the features. Multiple selected features can be deleted at once.

La herramienta editCut Cortar objetos espaciales en la barra de herramientas de digitalización también se puede utilizar para borrar objetos espaciales. Este efectivamente borra el objeto espacial pero también lo coloca en un “portapapeles espacial”. Por lo tanto, cortamos el objeto espacial para borrar. Entonces podríamos utilizar la herramienta editPaste Pegar objetos espaciales para colocarlo de nuevo, nos da una capacidad de deshacer de un nivel. Cortar, copiar y pegar funcionan sobre los objetos espaciales seleccionados, lo que significa que podemos operar más de una a la vez.

Guardar capas editadas

When a layer is in editing mode, any changes remain in the memory of QGIS. Therefore, they are not committed/saved immediately to the data source or disk. If you want to save edits to the current layer but want to continue editing without leaving the editing mode, you can click the saveEdits Save Layer Edits button. When you turn editing mode off with toggleEditing Toggle editing (or quit QGIS for that matter), you are also asked if you want to save your changes or discard them.

Si los cambios no se pueden guardar (por ejemplo, disco lleno, o los atributos tienen valores que están fuera de rango), el estado de memoria de QGIS es preservado. Esto le permite ajustar sus ediciones e intentar de nuevo.

Truco

Integridad de datos

Siempre es buena idea respaldar sus datos fuente antes de iniciar la edición. Mientras los autores de QGIS han hecho todo el esfuerzo para preservar la integridad de sus datos, nosotros no ofrecemos garantía en este sentido.

Saving multiple layers at once

Este objeto espacial permite la digitalización de múltiples capas. Elegir fileSaveAs Guardar las capas seleccionadas para guardar todos los cambios que se hicieron en múltiples capas. Se tiene la oportunidad para rollbackEdits Revertir las capas seleccionadas, así que la digitalización puede ser retirada de todas las capas seleccionadas. Si se desea detener la edición de las capas seleccionadas, cancelEdits Cancelar para la capa(s) seleccionada(s) es una forma fácil.

Las mismas funciones están disponibles para editar todas las capas del proyecto.

Digitalización avanzada

Icono

Propósito

Icono

Propósito

cad

Habilitar herramientas de digitalización avanzada

tracing

Habilitar Trazado

undo

Deshacer

redo

Rehacer

rotateFeature

Rotar objeto(s) espacial(es)

simplifyFeatures

Simplificar objeto espacial

addRing

Añadir anillo

addPart

Añadir parte

fillRing

Rellenar anillo

deleteRing

Borrar anillo

deletePart

Borrar parte

reshape

Remodelar objetos espaciales

offsetCurve

Desplazar curva

splitFeatures

Dividir objetos espaciales

splitParts

Dividir partes

mergeFeatures

Combinar objetos espaciales seleccionados

mergeFeatAttributes

Combinar atributos de objetos espaciales seleccionados

rotatePointSymbols

Rotar símbolos de puntos

Edición avanzada de tabla: la barra de herramientas de edición avanzada de capa vectorial

Deshacer y rehacer

The undo Undo and redo Redo tools allows you to undo or redo vector editing operations. There is also a dockable widget, which shows all operations in the undo/redo history (see Figure_edit_4). This widget is not displayed by default; it can be displayed by right clicking on the toolbar and activating the Undo/Redo checkbox. Undo/Redo is however active, even if the widget is not displayed.

Figure Edit 4:

../../../_images/redo_undo.png

Rehacer y deshacer pasos digitalizados

When Undo is hit or Ctrl+z (or Cmd+z) pressed, the state of all features and attributes are reverted to the state before the reverted operation happened. Changes other than normal vector editing operations (for example, changes done by a plugin) may or may not be reverted, depending on how the changes were performed.

Utilizar el widget de historial de deshacer/rehacer, sólo haga clic para seleccionar la operación en la lista del histórico. Todos los objetos espaciales se revertirán al estado que tenían después de la operación de seleccionada.

Rotar objeto(s) espacial(es)

Use rotateFeature Rotate Feature(s) to rotate one or multiple features in the map canvas. Press the rotateFeature Rotate Feature(s) icon and then click on the feature to rotate. Either click on the map to place the rotated feature or enter an angle in the user input widget. If you want to rotate several features, they shall be selected first.

Si se habilita la herramienta del mapa con objeto(s) seleccionados, su (ellos) centroide aparecerá y será el punto de delimitación de rotación. Si se desea mover el punto de delimitación, mantenga el botón Ctrl y haga clic en el mapa para colocarlo.

Si se mantiene Shift antes de hacer clic en el mapa, la rotación se hará en pasos de 45 grados, que pueden ser modificados después en el widget de entrada del usuario.

To abort feature rotation, you need to click on rotateFeature Rotate Feature(s) icon.

Simplificar objeto espacial

The simplifyFeatures Simplify Feature tool allows you to reduce the number of vertices of a feature, as long as the geometry remains valid. With the tool you can also simplify many features at once or multi-part features.

First, click on the feature or drag a rectangle over the features. A dialog where you can define a tolerance in map units, layer units or pixels pops up and a colored and simplified copy of the feature(s), using the given tolerance, appears over them. QGIS calculates the amount of vertices that can be deleted while maintaining the geometry. The higher the tolerance is the more vertices can be deleted. When the expected geometry fits your needs just click the [OK] button. The tolerance you used will be saved when leaving a project or when leaving an edit session. So you can go back to the same tolerance the next time when simplifying a feature.

To abort feature simplification, you need to click on simplifyFeatures Simplify Feature icon.

Nota

unlike the feature simplification option in Settings ‣ Options ‣ Rendering menu which simplifies the geometry just for rendering, the simplifyFeatures Simplify Feature tool really modifies feature’s geometry in data source.

Añadir parte

You can addPart Add Part to a selected feature generating a multipoint, multiline or multipolygon feature. The new part must be digitized outside the existing one which should be selected beforehand.

The addPart Add Part can also be used to add a geometry to a geometryless feature. First, select the feature in the attribute table and digitize the new geometry with the Add Part tool.

Borrar parte

The deletePart Delete Part tool allows you to delete parts from multifeatures (e.g., to delete polygons from a multi-polygon feature). This tool works with all multi-part geometries: point, line and polygon. Furthermore, it can be used to totally remove the geometric component of a feature. To delete a part, simply click within the target part.

Añadir anillo

You can create ring polygons using the addRing Add Ring icon in the toolbar. This means that inside an existing area, it is possible to digitize further polygons that will occur as a ‘hole’, so only the area between the boundaries of the outer and inner polygons remains as a ring polygon.

Rellenar anillo

You can use the fillRing Fill Ring function to add a ring to a polygon and add a new feature to the layer at the same time. Using this tool, you simply have to digitize a polygon within an existing one. Thus you need not first use the addRing Add Ring icon and then the capturePolygon Add feature function anymore.

Borrar anillo

The deleteRing Delete Ring tool allows you to delete rings within an existing polygon, by clicking inside the hole. This tool only works with polygon and multi-polygon features. It doesn’t change anything when it is used on the outer ring of the polygon.

Remodelar objetos espaciales

Se puede remodelar objetos espaciales de línea y polígono se utiliza el icono reshape Remodelar objeto espacial en la barra de herramientas. Sustituye a la línea o polígono parte de la primera a la última intersección con la línea original. Con polígonos, esto a veces puede conducir a resultados no deseados. Es útil principalmente para reemplazar las piezas más pequeñas de un polígono, no para reparaciones importantes, y la línea remodelada, no se permite atravesar varios anillos poligonales, ya que esto generaría un polígono inválido.

Por ejemplo, se puede editar el limite de un polígono con esta herramienta. En primer lugar, haga clic en la zona interior del polígono junto al punto en el que desea añadir un nuevo vértice. A continuación, cruce el limite y añada los vértices fuera del polígono. Para finalizar, haga clic derecho en la zona interior del polígono. La herramienta añadirá automáticamente un nodo en la nueva línea que cruza el limite. También es posible eliminar parte de la zona del polígono, a partir de la nueva línea fuera del polígono, agregar vértices en el interior, y poner fin a la línea exterior del polígono con un clic derecho.

Nota

La herramienta de remodelar podría alterar la posición inicial de un anillo de polígono o una linea cerrada. Por lo tanto, el punto que está representado ‘dos veces’ no será más el mismo. Esto puede no ser un problema para la mayoría de las aplicaciones, pero es algo a considerar.

Desplazar curva

The offsetCurve Offset Curve tool creates parallel shifts of line layers. The tool can be applied to the edited layer (the geometries are modified) or also to background layers (in which case it creates copies of the lines / rings and adds them to the edited layer). It is thus ideally suited for the creation of distance line layers. The User Input dialog pops-up, showing the displacement distance.

To create a shift of a line layer, you must first go into editing mode and activate the offsetCurve Offset Curve tool. Then click on a feature to shift it. Move the mouse and click where wanted or enter the desired distance in the user input widget. Your changes may then be saved with the saveEdits Save Layer Edits tool.

QGIS options dialog (Digitizing tab then Curve offset tools section) allows you to configure some parameters like Join style, Quadrant segments, Miter limit.

Dividir objetos espaciales

You can split features using the splitFeatures Split Features icon on the toolbar. Just draw a line across the feature you want to split.

Dividir partes

En QGIS ahora es posible dividir las partes de un objeto espacial múlti-parte, de modo que se incrementa el número de partes. Sólo se tiene que dibujar una línea en la parte que se desea dividir utilizando el icono splitParts Dividir partes

Combinar objetos espaciales seleccionados

La herramienta mergeFeatures Combinar objetos espaciales seleccionados le permite combinar objetos espaciales. Un nuevo cuadro de diálogo le permitirá elegir el valor que debe elegir entre cada una de las entidades seleccionadas o seleccionar una función (mínimo, máximo, mediana, Suma, Saltar Atributo) a utilizar para cada columna. Si los objetos espaciales no tienen unas fronteras comunes, se creará un multipolígono.

Combinar atributos de objetos espaciales

La herramienta mergeFeatAttributes Combinar los atributos de los objetos espaciales seleccionados le permite combinar los atributos de los objetos espaciales con límites comunes y atributos sin combinar sus límites. En primer lugar seleccione varios objetos espaciales en uno. A continuación presione el botón mergeFeatAttributes Combinar los atributos de los objetos espaciales seleccionados. Ahora QGIS le pregunta que atributos son los que debe aplicarse a todos los objetos seleccionados. Como resultado, todos los objetos seleccionados tienen las mismas entradas de atributo.

Rotar símbolos de puntos

rotatePointSymbols Rotar símbolos de puntos le permite cambiar la rotación de símbolos de punto en el área del mapa. Primero se debe definir una columna de rotación en la tabla de atributos de la capa de puntos en el menú Avanzado del menú Estilo de la Propiedades de la capa. También se necesitará entrar a ‘Marcador SVG’ y elegir Propiedades definidas por datos .... Activar checkbox Ángulo y elegir ‘rotación’ como campo. Sin estos ajustes, la herramienta esta inactiva.

Figure Edit 5:

../../../_images/rotatepointsymbol.png

Rotar símbolos de puntos

Cambiar la rotación, seleccionar un objeto espacial puntual en el lienzo del mapa y rotarlo, mantener presionado el botón izquierdo del ratón. Una flecha roja con el valor de rotación se visualizará (vea Figure_edit_5). Al soltar el botón izquierdo del ratón una vez más, el valor se actualizará en la tabla de atributos.

Nota

Si se mantiene presionada la tecla Ctrl, la rotación se realiza en pasos de 15 grados.

Rastreo Automático

Usually, when using capturing map tools (add feature, add part, add ring, reshape and split), you need to click each vertex of the feature.

Using the automatic tracing mode you can speed up the digitization process. Enable the tracing Tracing tool by pushing the icon or pressing t key and snap to a vertex or segment of a feature you want to trace along. Move the mouse over another vertex or segment you’d like to snap and instead of an usual straight line, the digitizing rubber band represents a path from the last point you snapped to the current position. QGIS actually uses the underlying features topology to build the shortest path between the two points. Click and QGIS places the intermediate vertices following the path. You no longer need to manually place all the vertices during digitization.

Tracing requires snapping to be activated in traceable layers to build the path. You should also snap to an existing vertex or segment while digitizing and ensure that the two nodes are topologically connectable following existing features, otherwise QGIS is unable to connect them and thus traces a single straight line.

Nota

Adjust map scale or snapping settings for an optimal tracing

If there are too many features in map display, tracing is disabled to avoid potentially long tracing structure preparation and large memory overhead. After zooming in or disabling some layers the tracing is enabled again.

Truco

Quickly enable or disable automatic tracing by pressing t key

By pressing t key, tracing can be enabled/disabled anytime even while digitizing one feature, so it is possible to digitize some parts of the feature with tracing enabled and other parts with tracing disabled. Tools behave as usual when tracing is disabled.

El panel de Digitalización Avanzada

When capturing new geometries or geometry parts you also have the possibility to use the Advanced Digitizing panel. You can digitize lines exactly parallel or at a specific angle or lock lines to specific angles. Furthermore you can enter coordinates directly so that you can make a precise definition for your new geometry.

Figure Advanced Edit 1:

../../../_images/advanced_digitizing.png

El panel de Digitalización Avanzada

Nota

Las herramientas no están habilitadas si la vista del mapa esta en coordenadas geográficas.

Crear nueva capa vectorial

QGIS le permite crear nuevas capas de archivo shape, SpatiaLite, GPX y Nuevas Capas de borrador temporal. La creación de una nueva capa GRASS esta implementada dentro del complemento GRASS. Por favor refierase a la sección Crear una nueva capa vectorial GRASS para obtener más información sobre la creación de capas vectoriales GRASS.

Crear una nueva capa de archivo shape

To create a new shape layer for editing, choose New ‣ newVectorLayer New Shapefile Layer... from the Layer menu. The New Vector Layer dialog will be displayed as shown in Figure_edit_6. Choose the type of layer (point, line or polygon) and the CRS (coordinate reference system).

Note that QGIS does not yet support creation of 2.5D features (i.e., features with X,Y,Z coordinates).

Figure Edit 6:

../../../_images/editNewVector.png

Diálogo Crear un nuevo archivo Shape

To complete the creation of the new shapefile layer, add the desired attributes by clicking on the [Add to attributes list] button and specifying a name and type for the attribute. A first ‘id’ column is added as default but can be removed, if not wanted. Only Type: real selectString, Type: integer selectString, Type: string selectString and Type:date selectString attributes are supported. Additionally and according to the attribute type, you can also define the width and precision of the new attribute column. Once you are happy with the attributes, click [OK] and provide a name for the shapefile. QGIS will automatically add a .shp extension to the name you specify. Once the layer has been created, it will be added to the map, and you can edit it in the same way as described in section Digitalizando una capa existente above.

Crear una nueva capa SpatiaLite

Crear una nueva capa SpatiaLite para editar, seleccione Nuevo‣ newSpatiaLiteLayer Nieva capa SpatiaLite... desde el menú Capa. El diálogo guilabel:Nueva capa SpatiaLite se desplegara como se ve en Figure_edit_7.

Figure Edit 7:

../../../_images/editNewSpatialite.png

Creating a New SpatiaLite layer Dialog

The first step is to select an existing SpatiaLite database or to create a new SpatiaLite database. This can be done with the browse button browseButton to the right of the database field. Then, add a name for the new layer, define the layer type, and specify the coordinate reference system with [Specify CRS]. If desired, you can select checkbox Create an autoincrementing primary key.

Definir una tabla de atributos para la nueva capa SpatiaLite, añadir los nombres de las columnas de atributos que desee crear con el tipo de campo correspondiente, y haga clic en el botón [Añadir a lista de atributos]. Una ves que este feliz con los atributos, haga clic [Aceptar]. QGIS añadirá automáticamente la nueva capa a la leyenda, y se puede editar de la misma manera como se describió en la sección anterior Digitalizando una capa existente.

Además de la gestión de capas SpatiaLite se puede hacer con la DBManager. Ver Complemento administrador de BBDD.

Crear una nueva capa GPX

To create a new GPX file, you need to load the GPS plugin first. Plugins ‣ showPluginManager Plugin Manager... opens the Plugin Manager Dialog. Activate the checkbox GPS Tools checkbox.

When this plugin is loaded, choose New ‣ createGPX Create new GPX Layer... from the Layer menu. In the Save new GPX file as dialog, you can choose where to save the new GPX layer.

Crear una nueva capa temporal

Empty, editable memory layers can be defined using Layer ‣ Create Layer ‣ New Temporary Scratch Layer. Here you can even create radioButtonOffMultipoint, radioButtonOffMultiline and radioButtonOffMultipolygon Layers beneath radioButtonOnPoint, radioButtonOffLine and radioButtonOffPolygon Layers. Temporary Scratch Layers are not saved and will be discarded when QGIS is closed. See also Pegar en nueva capa.