Outdated version of the documentation. Find the latest one here.

Trabajar con la tabla de atributos

Los objetos espaciales mostrados tabla de atributos de una capa seleccionada. Cada fila en la tabla representa un objeto espacial en el mapa, y cada columna contiene una pieza importante de información acerca del objeto espacial. Los objetos espaciales en la tabla se pueden buscar, seleccionar y mover o incluso editar.

To open the attribute table for a vector layer, make the layer active by clicking on it in the map legend area. Then, from the main Layer menu, choose openTable Open Attribute Table. It is also possible to right click on the layer and choose openTable Open Attribute Table from the drop-down menu, and to click on the openTable Open Attribute Table button in the Attributes toolbar.

This will open a new window that displays the feature attributes for the layer (figure_attributes_1). The number of features and the number of selected features are shown in the attribute table title.

Figure Attributes 1:

../../../_images/vectorAttributeTable.png

Attribute Table for regions layer

The buttons at the top of the attribute table window provide the following functionality:

  • toggleEditing Toggle editing mode to enable editing functionalities (also with Ctrl+e)
  • saveEdits Save Edits (also with Ctrl+s)
  • draw Reload the table
  • newTableRow Add feature
  • deleteSelected Delete selected features (also with Ctrl+d)
  • expressionSelect Select features using an Expression
  • selectAll Select all (also with Ctrl+a)
  • invertSelection Invert selection (also with Ctrl+r)
  • unselectAttributes Deseleccionar todo (también con Ctrl+u)

  • selectedToTop Move selected to top (also with Ctrl+t)
  • panToSelected Desplazar el mapa a las filas seleccionadas (también con Ctrl+P)

  • zoomToSelected Zoom map to the selected rows (also with Ctrl+j)
  • copySelected Copy selected rows to clipboard (also with Ctrl+c)
  • editPaste Paste from clipboard to a new row (also with Ctrl+v)
  • deleteAttribute Delete Column for PostGIS layers and for OGR layers with GDAL version >= 1.9 (also with Ctrl+l)
  • newAttribute New Column for PostGIS layers and for OGR layers with GDAL version >= 1.6 (also with Ctrl+w)
  • calculateField Abrir calculadora de campos (también con Ctrl+I)

Below these buttons is the Field Calculator bar (enabled only in editing mode), which allows calculations to be quickly applied to either all or selected features attributes in the table. This bar uses the same expressions as the calculateField Field Calculator (see Calculadora de Campo).

Truco

Omitir geometría WKT

Si desea utilizar los datos de atributos en programas externos (como Excel), utilice el botón copySelected Copiar filas seleccionadas al portapapeles. Se puede copiar la información sin geometrías vectoriales si se desactiva Configuración ‣ Opciones ‣`Fuente de datos checkbox Copiar la geometría en la representación WKT de la tabla de atributos.

Seleccionar elementos en una tabla de atributos

Cada registro seleccionado en la tabla de atributos mostrar los atributos de un objeto espacial seleccionado en la capa. Si el conjunto de objetos espaciales seleccionados en la ventana principal se cambia, la selección también se actualiza en la tabla de atributos. Igualmente, si el conjunto de registros seleccionados en la tabla cambian, el conjunto de objetos espaciales seleccionados en la ventana principal se actualizaran.

Los registros se pueden seleccionar haciendo clic en el número de registros del lado izquierdo del registro. Múltiples registros se pueden marcar al mantener la tecla Ctrl. Una selección continua se puede hacer al mantener la tecla Shift y haciendo clic en varios encabezados de registros del lado izquierdo del registro. Todos los registros entre la posición actual del cursos y el registro donde se hace clic son seleccionados. Mover la posición del cursos en la tabla de atributos, al hacer clic en una celda de la tabla, no cambia el registro seleccionado. Cambiar la selección en el lienzo principal no mueve la posición del cursos en la tabla de atributos.

La tabla se puede ordenar por cualquier columna, al hacer clic en el encabezado de la columna. Una pequeña flecha indica el tipo de orden (que apunta hacia abajo significa descender los valores de la fila de arriba hacia abajo, apuntando hacia arriba significa que los valores ascendentes de la fila de arriba hacia abajo).

Para una búsqueda simple por atributos en una sola columna, elija del menú Filtro de columna ‣ en la esquina inferior izquierda. Seleccione el campo (columna) en la que la búsqueda debe realizarse desde el menú desplegable, y pulse el botón [Aplicar]. entonces sólo los objetos espaciales coincidentes se muestran en la tabla de atributos.

To make a selection, you have to use the expressionSelect Select features using an Expression icon on top of the attribute table. expressionSelect Select features using an Expression allows you to define a subset of a table using a Function List like in the calculateField Field Calculator (see Calculadora de Campo). The query result can then be saved as a new vector layer. For example, if you want to find regions that are boroughs from regions.shp of the QGIS sample data, you have to open the Fields and Values menu and choose the field that you want to query. Double-click the field ‘TYPE_2’ and also [Load all unique values] . From the list, choose and double-click ‘Borough’. In the Expression field, the following query appears:

"TYPE_2"  =  'Borough'

Aquí también se puede utilizar la Lista de funciones ‣ Reciente (Selection) para hacer una selección que utilizo antes. El constructor de expresiones recuerda las últimas 20 expresiones utilizadas.

Las filas coincidentes serán seleccionadas, y el número total de filas coincidentes aparecerán en la barra de título de la tabla de atributos, así como en la barra de estado de la ventana principal. Para búsquedas que muestran sólo objetos espaciales seleccionados en el mapa, utilice el Generador de consultas descrito en la sección Constructor de Consulta.

To show selected records only, use Show Selected Features from the menu at the bottom left. See next section for more information on filter feature.

La barra de calculadora de campos le permite hacer calculos sólo en las filas seleccionadas. Por ejemplo, se puede alterar el número del campo ID del archivo :regions.shp con la expresión

ID+5

como muestra en figure_attributes_1 .

Filtar objetos

At the bottom of the attribute table, you have a dropdown list of different filter:

  • Mostrar todos los objetos espaciales

  • Mostrar objetos espaciales seleccionados;

  • Show Features visible on map;
  • Show Edited and New Features;
  • Filtro de campos;

  • Advanced filter (Expression);

The first four are self explanatory, the two last are expression filters. Field Filter allows user to choose a column name in the list and add a simple form to the right of the drop-down list to filter with a like expression parameter. This filter will create an expression filter as an Advanced filter. The last kind of filter will open an expression window, see Expresiones for more information.

Tab/form mode

By default the attribute window displays a table layout. In some case one should prefer to use a form layout to help edit some features more easily.

You can switch to form layout by clicking in the bottom right, on openForm and switch back to table layout with openTable.

Acercamiento a objeto espacial

To zoom into a feature, without having to select it, right-click on the feature you want to zoom in, within the attribute table, and select Zoom to feature.

Guardar objetos espaciales seleccionados como nueva capa

Los objetos espaciales seleccionados se pueden guardar como algún formato vectorial OGR- reconocido y también transformar en otro sistema de referencia de coordenadas (SRC). Solamente abra con el clic derecho del ratón la capa y haga clic en Guardar como para definir el nombre de salida del archivo, su formato y SRC (vea también Panel de Capas). Para guardar la selección asegúrese que Guardar sólo los objetos espaciales seleccionados este seleccionado. También es posible especificar opciones de creación de OGR dentro del diálogo.

Pegar en nueva capa

Los objetos espaciales que están en el portapapeles se pueden pegar en una nueva capa. Para esto, primero se hace una capa editable. Se seleccionan algunos objetos espaciales, se copian al portapapeles y se pegan en la nueva capa utilizando Edición‣ Pegar objetos espaciales como y elige menuselection:Nueva capa vectorial o Nueva capa borrado temporal.

This applies to features selected and copied within QGIS and also to features from another source defined using well-known text (WKT).

Editando valores de atributo

The calculateField Field Calculator button in the attribute table allows you to perform calculations on the basis of existing attribute values or defined functions, for instance, to calculate length or area of geometry features. The results can be written to a new attribute field, a virtual field, or they can be used to update values in an existing field.

A virtual field is a field based on an expression calculated on the fly, meaning that its value is automatically updated as soon as the underlying parameter changes. The expression is set once; you no longer need to recalculate the field each time underlying values change. For example, you may want to use a virtual field if you need area to be evaluated as you digitize features or to automatically calculate a duration between dates that may change (e.g., using now() function).

Nota

Uso de Campos Virtuales

  • Virtual fields are not permanent in the layer attributes, meaning that they’re only saved and available in the project file they’ve been created.
  • Un campo puede definirse como virtual sólo al momento de su creación y la expresión usado no puede cambiarse luego: necesitará borrar y recrear el campo.

The field calculator is available on any layer that supports edit. When you click on the field calculator icon the dialog opens (see figure_attributes_2). If the layer is not in edit mode, a warning is displayed and using the field calculator will cause the layer to be put in edit mode before the calculation is made.

The quick field calculation bar on top of the attribute table is only visible if the layer is in edit mode.

In quick field calculation bar, you first select the existing field name then open the expression dialog to create your expression or write it directly in the field then click on [Update All], [Update Selected] or [Update Filtered] button according to your need.

Calculadora de Campo

Based on the Expression Builder dialog, the field calculator dialog offers a complete interface to define an expression and apply it to an existing or a newly created field. To use the field calculator dialog, you first must select whether you want to only update selected features, create a new attribute field where the results of the calculation will be added or update an existing field.

Figure Attributes 2:

../../../_images/fieldcalculator.png

Calculadora de Campo

If you choose to add a new field, you need to enter a field name, a field type (integer, real or string), the total field width, and the field precision (see figure_attributes_2). For example, if you choose a field width of 10 and a field precision of 3, it means you have 6 digits before the dot, then the dot and another 3 digits for the precision.

A short example illustrates how field calculator works when using the Expression tab. We want to calculate the length in km of the railroads layer from the QGIS sample dataset:

  1. Load the shapefile railroads.shp in QGIS and press openTable Open Attribute Table.
  2. Click on toggleEditing Toggle editing mode and open the calculateField Field Calculator dialog.
  3. Select the checkbox Create a new field checkbox to save the calculations into a new field.
  4. Add length as Output field name and real as Output field type, and define Output field width to be 10 and Precision, 3.
  5. Now double click on function $length in the Geometry group to add it into the Field calculator expression box.
  6. Complete the expression by typing / 1000 in the Field calculator expression box and click [Ok].
  7. Ahora puede encontrar un nuevo campo length en la tabla de atributos.

Trabajar con tablas de atributos no espaciales

QGIS allows you also to load non-spatial tables. This currently includes tables supported by OGR and delimited text, as well as the PostgreSQL, MSSQL and Oracle provider. The tables can be used for field lookups or just generally browsed and edited using the table view. When you load the table, you will see it in the legend field. It can be opened with the openTable Open Attribute Table tool and is then editable like any other layer attribute table.

As an example, you can use columns of the non-spatial table to define attribute values, or a range of values that are allowed, to be added to a specific vector layer during digitizing. Have a closer look at the edit widget in section Menú de Campos to find out more.

Formateo condicional de Celdas de Tablas

You can enable the conditional formatting panel clicking on rendererAttributeTable at the top right of the attributes window in table view (not available in form view).

The new panel allows user to add new rules for conditional formatting of field or full row in regard of the expression on field. Adding new rule open a form to define:

  • el nombre de la regla,

  • una condición de la ventana de expresión,

  • un formateo preestablecido

  • algunos otros parámetros para mejorar, cambiar o definir el formateo:

    • colores de fondo y texto,

    • uso de ícono,

    • bold, italic underline, or strikeout,
    • campo texto,

    • tipo de letra.

Figure Attributes 3:

../../../_images/attribute_table_conditional_formating.png

Formateo Condicional de una tabla de atributos

Creando relaciones uno a muchos

Las relaciones son una técnica que a menudo se utiliza en base de datos. El concepto es, que los objetos espaciales (filas) de diferentes capas (tablas) pueden pertenecer a uno al otro.

As an example you have a layer with all regions of alaska (polygon) which provides some attributes about its name and region type and a unique id (which acts as primary key).

Llaves foráneas

A continuación, le da otra capa de punto o tabla con información sobre aeropuertos que se encuentran en las regiones y también se desea hacer un seguimiento de los mismos. Si desea agregarlos a la capa de la región, es necesario crear una relación de uno a muchos utilizando una clave foránea, porque hay varios aeropuertos de la mayoría de las regiones.

Figure Relations 1:

../../../_images/relations1.png

Región Alaska con aeropuertos

Además de los atributos ya existentes en la tabla de atributos de aeropuertos, otro campo fk_region que actúa como una clave externa (si tiene una base de datos, es probable que desee definir una restricción en él).

Este campo fk_region siempre contendrá un identificador de una región. Se puede ver como un puntero a la región que pertenece. Y se puede diseñar un formulario de edición personalizada para la edición y QGIS se encarga de la instalación. Se trabaja con diferentes proveedores (por lo que también se puede utilizar con archivos de formas y csv) y todo lo que tiene que hacer es decirle a QGIS las relaciones entre las tablas.

Capas

QGIS no hace diferencia entre una tabla y una capa vectorial. Básicamente, una capa vectorial es una table con una geometría. Por lo que puede añadir su tabla como una capa vectorial. Para demostrar se puede cargar el archivo shape ‘region’ (con geometrías) y la tabla csv ‘airport’ (sin geometrías) y una llave foránea (fk_region) a la capa región. Esto quiere decir, que cada aeropuerto pertenece a exactamente una región, mientras que cada región puede tener cualquier número de aeropuertos (una típica relación uno a muchos).

Definición (Administrador de Relación)

The first thing we are going to do is to let QGIS know about the relations between the layer. This is done in Project ‣ Project Properties. Open the Relations menu and click on Add.

  • nombre va a ser utilizado como un título. Debe ser una cadena legible por humanos, que describe, para lo que la relación se utiliza. Lo llamaremos “Aeropuertos” en este caso.

  • Capa de referencia es la que tiene el campo de llave foránea. En nuestro caso este es la capa de aeropuertos.

  • Campo de referencia dirá que los puntos de campo a la otra capa por lo que este es fk_region en este caso.

  • referenced layer is the one with the primary key, pointed to, so here it is the regions layer
  • Campo referenciado es la llave primaria en la capa referenciada por lo que es ID

  • Id se utilizará para propósitos internos y tiene que ser único. Se puede necesitar para construir formularios personalizados una vez que esto es implementado. Si se deja vacío, uno será generado para que se pueda asignar uno a si mismo para obtener uno que sea más fácil de manejar.

Figure Relations 2:

../../../_images/relations2.png

Administrador de Relaciones

Formularios

Ahora que QGIS conoce acerca de las relaciones, se utilizará para mejorar el formulario generado. Como no hemos cambiado el método de formulario predeterminado (autogenerado) se acaba de añadir un nuevo widget de nuestro formulario. Así que vamos a seleccionar la zona de la capa en la leyenda y utilizar la herramienta de identificación. Dependiendo de la configuración, la forma puede abrir directamente o se tendrá que elegir para abrirlo en el diálogo de identificación dentro de las acciones.

Figure Relations 3:

../../../_images/relations3.png

Identification dialog regions with relation to airports

As you can see, the airports assigned to this particular region are all shown in a table. And there are also some buttons available. Let’s review them shortly

  • The toggleEditing button is for toggling the edit mode. Be aware that it toggles the edit mode of the airport layer, although we are in the feature form of a feature from the region layer. But the table is representing features of the airport layer.
  • The signPlus button will add a new feature to the airport layer. And it will assign the new airport to the current region by default.
  • The remove button will delete the selected airport permanently.
  • The link symbol will open a new dialog where you can select any existing airport which will then be assigned to the current region. This may be handy if you created the airport on the wrong region by accident.
  • The unlink symbol will unlink the selected airport from the current region, leaving them unassigned (the foreign key is set to NULL) effectively.
  • Los dos botones situados a la derecha del interruptor entre la vista de tabla y vista de formulario en el que más tarde le permite ver todos los aeropuertos en su forma respectiva.

If you work on the airport table, a new widget type is available which lets you embed the feature form of the referenced region on the feature form of the airports. It can be used when you open the layer properties of the airports table, switch to the Fields menu and change the widget type of the foreign key field ‘fk_region’ to Relation Reference.

If you look at the feature dialog now, you will see, that the form of the region is embedded inside the airports form and will even have a combobox, which allows you to assign the current airport to another region.

Figure Relations 4:

../../../_images/relations4.png

Identification dialog airport with relation to regions