Outdated version of the documentation. Find the latest one here.

Configuración QGIS

QGIS is highly configurable through the Settings menu. Choose between Project Properties, Options and Customization.

Nota

QGIS follows desktop guidelines for the location of options and project properties item. Consequently related to the OS you are using, location of some of items described below could be in the Project or the Settings menu.

Propiedades del proyecto

In the properties window for the project under nix Settings ‣ Project Properties (kde) or nix osx win Project ‣ Project Properties (Gnome, OS X or Windows), you can set project-specific options.

  • In the General menu, the general settings let you:

    • dé un texto al título del proyecto aparte de la ruta del archivo del proyecto

    • escoge el color a usar para objetos espaciales cuando son seleccionados

    • escoger el color de fondo: el color a usar para la tela de fondo del mapa

    • set whether the path to layers in the project should be saved as absolute (full) or as relative to the project file location. You may prefer relative path when both layers and project files can be moved or shared or if the project is accessed from computers on different platforms.
    • choose to avoid artifacts when project is rendered as map tiles. Note that checking this option can lead to performance degradation.

    Calculating areas and distances is a common need in GIS. However, these values are really tied to the underlying projection settings. The Measurements frame lets you control these parameters. You can indeed choose:

    • the ellipsoid to use: it can be an existing one, a custom one (you’ll need to set values of the semi-major and semi-minor axis) or None/Planimetric.
    • the units for distance measurements for length and perimeter and the units for area measurements. These settings, which default to the units set in QGIS options but then overrides it for the current project, are used in:
      • Attribute table field update bar
      • Cálculos de calculadora de campo

      • Identify tool derived length, perimeter and area values
      • Default unit shown in measure dialog

    The Coordinate display allows you to choose and customize the format of units to use to display the mouse coordinate in the status bar and the derived coordinates shown via the identify tool.

    Finally, you can define a project scale list, which overrides the global predefined scales.

Figure General Menu:

../../../_images/project_general.png

General tab of Project Properties dialog

  • El menú SRC habilitado para elegir el Sistema de Referencia de Coordenadas para este proyecto, y para habilitar la reproyección al vuelo de capas ráster y vector cuando se muestran capas de un diferente SRC.

  • With the Identify layers menu, you set (or disable) which layers will respond to the identify tool. By default, layers are set queryable.
  • El menú Estilos predeterminados le permite controlar cómo las nuevas capas se dibujaran cuando no tienen un estilo existente .qml definido. También puede establecer el nivel de trasparecía por defecto para nuevas capas y si los símbolos deben tener colores al azar para asignarlos. También hay una sección adicional donde puede definir colores específicos para el proyecto en ejecución. Puede encontrar los colores añadidos en el menú desplegable de la ventana de diálogo de color presente en cada representación.

  • The tab OWS Server allows you to define information about the QGIS Server WMS and WFS capabilities, extent and CRS restrictions.
  • El menú Macros es utilizado para editar macros de Python para proyectos. Actualmente, solo tres macros están disponibles: openProject(), saveProject() and closeProject().

Figure Macro Menu:

../../../_images/macro.png

Definición macro en QGIS

  • El menú Relaciones es utilizado para definir relaciones 1:n. Las relaciones están definidas en el diálogo de propiedades del proyecto. Una vez que existen las relaciones de una capa, un nuevo elemento de la interfaz de usuario en la vista del formulario (por ejemplo al identificar un elemento espacial y abrir el formulario) mostrará una lista de las entidades relacionadas. Este proporciona un poderosa forma para expresar, por ejemplo la inspección de la longitud de una tubería o el segmento de carretera. Se puede encontrar más información acerca de relaciones 1:n y soporte en la sección Creando relaciones uno a muchos.

Opciones

options Some basic options for QGIS can be selected using the Options dialog. Select the menu option Settings ‣ options Options. The tabs where you can customize your options are described below.

Menú General

Aplicación

  • Seleccione el Estilo (QGIS requiere reiniciar) selectString y elija entre ‘Oxygen’,’Windows’,’Motif’,’CDE’, ‘Plastique’ and ‘Cleanlooks’ (nix).

  • Define the Icon theme selectString. Currently only ‘default’ is possible.
  • Define the Icon size selectString.
  • Define the Font. Choose between radioButtonOn Qt default and a user-defined font.
  • Cambiar el Límite de tiempo para mensajes o diálogos con tiempo selectString.

  • checkbox Ocultar la pantalla de bienvenida al iniciar la aplicación

  • checkbox Mostrar consejos al iniciar

  • checkbox Títulos de cajas de grupos en negrita

  • checkbox Cajas de grupo al estilo QGIS

  • checkbox Utilizar los diálogos de selección de colores nativos

  • checkbox Usar diálogos de selección de color actualizadas en vivo

  • checkbox Estilo de barra lateral personalizado

  • checkbox Apoyo para rotación del lienzo experimental (requiere reiniciar)

Los archivos de proyecto

  • Open project on launch selectString (choose between ‘New’, ‘Most recent’ and ‘Specific’). When choosing ‘Specific’ use the browseButton to define a project.
  • checkbox Crear nuevo proyecto desde el proyecto predeterminado. Tiene la posibilidad de presionar Establecer el actual proyecto como predeterminado o sobre Restablecer el predeterminado. Puede navegar a través de sus archivos y definir un directorio donde se encuentra las plantillas definidas por el usuario. Esto se añadirá a Proyecto ‣ Nueva plantilla de formulario. Si activa primero checkbox Crear nuevo proyecto desde proyecto predeterminado y entonces guarde un proyecto en l la carpeta de las plantillas de proyecto.

  • checkbox Solicitar guardar proyectos y fuentes de datos modificadas cuando sea necesario

  • checkbox Pedir confirmación cuando se va a eliminar una capa

  • checkbox Avisar cuando se abra un proyecto guardado con una versión anterior de QGIS

  • Enable macros selectString. This option was created to handle macros that are written to perform an action on project events. You can choose between ‘Never’, ‘Ask’, ‘For this session only’ and ‘Always (not recommended)’.

Menú Sistema

Entorno

Variables de entorno del sistema ahora se puede ver, y muchos lo configuran en el grupo Entorno (ver figure_environment_variables). Esto es útil para las plataformas, como Mac, donde una aplicación GUI no heredan necesariamente entorno del casco del usuario. También es útil para configurar y visualizar las variables de entorno para los conjuntos de herramientas externas controladas por la caja de herramientas de procesamiento (por ejemplo, SAGA, GRASS), y para activar la salida de depuración para secciones específicas del código fuente.

  • checkbox Utilizar variables personalizadas (requiere reiniciar - incluir separadores). Puede [Añadir] y [Borrar] variables. Las variables de entorno ya definidas se muestran en Variables de entorno actuales, y es posible filtrarlos activando checkbox Mostrar sólo variables de QGIS específicas.

Figure System Environment:

../../../_images/sys-env-options.png

Variables del ambiente del sistema en QGIS

Rutas de complemento

[Añadir] o [Borrar] Ruta(s) para buscar librerías de componentes en C++ adicionales

Menú Fuente de datos

Atributos de entidades espaciales y tabla

  • checkbox Abrir tabla de atributos en la ventana adosada (requiere reiniciar QGIS)

  • checkbox Copiar geometría en WKT representación de la tabla de atributos. Al utilizar copySelected :sup:` Copiar las filas seleccionadas al portapapeles` desde el diálogo Tabla de atributos, este tiene el resultado que las coordenadas de los puntos o vértices también se copian en el portapapeles.

  • Attribute table behavior selectString. There are three possibilities: ‘Show all features’, ‘Show selected features’ and ‘Show features visible on map’.
  • Attribute table row cache selectNumber. This row cache makes it possible to save the last loaded N attribute rows so that working with the attribute table will be quicker. The cache will be deleted when closing the attribute table.
  • Representación de valores NULOS. Aquí, puede definir un valor para los datos de campos que tienen un valor NULO.

Manejo de fuente de datos

  • Scan for valid items in the browser dock selectString. You can choose between ‘Check extension’ and ‘Check file contents’.
  • Scan for contents of compressed files (.zip) in browser dock selectString. ‘No’, ‘Basic scan’ and ‘Full scan’ are possible.
  • Solicitar subcapas raster al abrir. Algunas subcapas raster soportadas — se les llama subdataset en GDAL. Un ejemplo son los archivos netCDF — si hay muchos variables netCDF, GDAL ve cada variable como un subconjunto de datos. La opción le permite controlar cómo lidiar con subcapas cuando se abre un archivo con subcapas. Dispone de las siguientes opciones:

    • ‘Siempre’: Siempre preguntar (Si hay subcapas existentes)

    • ‘Si es necesario’: Preguntar si la capa no tiene bandas, pero tiene subcapas

    • ‘Nunca’: Nunca preguntar, no se cargará nada

    • ‘Cargar todo’: Nunca preguntar, pero cargar todas las subcapas

  • checkbox Ignore shapefile encoding declaration. If a shapefile has encoding information, this will be ignored by QGIS.
  • checkbox Añadir capas PostGIS con doble clic y seleccionar en modo extendido

  • checkbox Añadir capas de Oracle con doble clic y seleccionar en modo extendido

  • checkbox Ejecutar expresiones en el lado del servidor si es posible

  • checkbox create transaction groups automatically whenever possible (Experimental). When this mode is turned on, all (postgres) layers from the same database are synchronised in their edit state, i.e. when one layer is put into edit state, all are, when one layer is committed or one layer is rolled back, so are the others. Also, instead of buffering edit changes locally, they are directly sent to a transaction in the database which gets committed when the user clicks save layer.

Hidden Browser Path

This widget lists all the folder you chose to hide from the Browser panel. Removing a folder from the list will make it available in the Browser panel.

Menú representación

Comportamiento de presentación

  • checkbox Por defecto las nuevas capas añadidas al mapa se deben mostrar

  • checkbox Utilizar el cacheo de presentación en lo posible a la velocidad de regeneración

  • checkbox Representación de capas en paralelo utilizando muchos núcleos CPU

  • checkbox Máximo de núcleos a utilizar

  • Intervalo de actualización del mapa (por defecto 250 ms)

  • checkbox Habilitar simplificación de objetos espaciales por defecto a las nuevas capas añadidas

  • Simplificación del umbral

  • checkbox Simplifique el lado del proveedor si es posible

  • Escala máxima a la que la capa se debe simplificar

Calidad de representación

  • checkbox Hacer que las líneas se muestren menos quebradas a expensas del rendimiento de la representación

Rásters

  • Con Selección de la banda RGB, puede definir el numero para la banda Roja, Verde y Azul.

Mejora de contraste

  • Single band gray selectString. A single band gray can have ‘No stretch’, ‘Stretch to MinMax’, ‘Stretch and Clip to MinMax’ and also ‘Clip to MinMax’.
  • Multi band color (byte/band) selectString. Options are ‘No stretch’, ‘Stretch to MinMax’, ‘Stretch and Clip to MinMax’ and ‘Clip to MinMax’.
  • Multi band color (>byte/band) selectString. Options are ‘No stretch’, ‘Stretch to MinMax’, ‘Stretch and Clip to MinMax’ and ‘Clip to MinMax’.
  • Límites (mínimo/máximo) selectString. Las opciones son ‘Corte del conteo acumulativo’, ‘Min/Máx’, ‘Media +/- desviación estándar’.

  • Límite para corte del conteo acumulativo de píxeles

  • Multiplicador de la desviación estándar

Depuración

  • checkbox Refrescar lienzo de mapa

Menú de Colores

Este menú le permite añadir algunos colores personalizados que puede encontrar en cada ventana de diálogo de color de la representación. Verá un conjunto de colores predefinidos en la pestaña: se puede eliminar o editar todos ellos. Por otra parte se puede añadir el color que se desea y realizar algunas operaciones de copiar y pegar. Finalmente se puede exportar el conjunto de colores como un archivo gpl o importarlos.

Menú Vista del mapa y leyenda

Apariencia del mapa predeterminado (anulado por las propiedades del proyecto)

  • Definir un Color de selección y un Color de fondo.

Leyenda de capa

  • Double click action in legend selectString. You can either ‘Open layer properties’ or ‘Open attribute table’ with the double click.
  • Lo siguiente es posible Estilos de elementos de la leyenda:

    • checkbox Comenzar el nombre de las capas con mayúsculas

    • checkbox Poner en negrita los nombres de la capa

    • checkbox Poner en negrita los nombres de grupo

    • checkbox Mostrar nombres de atributos de clasificación

    • checkbox Crear iconos de ráster (puede ser lento)

Menú Herramientas de mapa

This menu offers some options regarding the behavior of the Identify tool.

  • Radio de búsqueda para identificar y visualizar avisos en el mapa es un factor de tolerancia expresada como un porcentaje del ancho de mapa. Esto significa que la herramienta de identificación representara los resultados siempre y cuando haga clic dentro de esta tolerancia.

  • Color de realce le permite elegir con que color deben ser identificados los objetos espaciales que están resaltados.

  • Buffer determines a buffer distance to be rendered from the outline of the identify highlight.
  • Minimum width determines how thick should the outline of a highlighted object be.

Herramienta de medición

  • Definir Color de la banda de medida para herramienta de medida

  • Definir Lugares decimales

  • checkbox Keep base unit to not automatically convert large numbers (e.g., meters to kilometers)
  • Preferred distance units radioButtonOn (‘Meters’, ‘Feet’, ‘Nautical Miles’, ‘Degrees’ or ‘Map Units’ )
  • Preferred area units radioButtonOn (‘Square meters’, ‘Square feet’, ‘Square yards’, ‘Hectares’, ‘Map Units’ ...)
  • Preferred angle units radioButtonOn (‘Degrees’, ‘Radians’, ‘Gon/gradians’, ‘Minutes of arc’ ...)

Mover y zum

  • Definir Acción de la rueda del ratón selectString (‘Zum’, ‘Zum y centrar’, ‘Zoom al cursor del ratón’, ‘Nada’)

  • Definir Factor de zum para la rueda del ratón

Escalas predefinidas

Here, you find a list of predefined scales. With the signPlus and signMinus buttons you can add or remove your personal scales. You can also import or export scales from/to a .XML file. Note that you still have the possibility to remove your changes and reset to the predefined list.

Menú Diseñador

Predeterminados de la composición

Se puede definir el Tipo de letra predeterminado aquí.

Apariencia de la cuadrícula

  • Definir el Estilo de cuadrícula selectString (‘Sólido, ‘Puntos’, ‘Cruces’)

  • Definir el Color de la cuadrícula

Valores predeterminados de la cuadrícula y guía

  • Define the Grid spacing selectNumber
  • Definir el Desplazamiento de cuadrícula selectNumber para x y y

  • Define the Snap tolerance selectNumber

Menú Digitalización

Creación de entidades espaciales

  • checkbox Suprimir formulario emergente de atributos después de crear objetos espaciales

  • checkbox Reutilizar últimos valores de atributos introducidos

  • Validar geometrías. Editar lineas y polígonos complejos con muchos nodos puede resultar a una representación muy lenta. Esto se debe a los procesos de validación por defecto en QGIS puede tomar mucho tiempo. Para acelerar la representación, es posible seleccionar la validación de geometría GEOS (a partir de GEOS 3.3) o a pagarlo. La validación de geometría GEOS es mucho más rápido, pero la desventaja es que sólo el primer problema de geometría será reportado.

Banda de medición

  • Definir banda elástica Ancho de línea y Color de línea

Autoensamblado

  • checkbox Abrir opciones de autoensamblado en una ventana adosada(requiere reiniciar QGIS)

  • Define Default snap mode selectString (‘To vertex’, ‘To segment’, ‘To vertex and segment’, ‘Off’)
  • Definir Tolerancia de autoensamblado predeterminado en unidades de mapa o píxeles

  • Definir el Radio de búsqueda para edición de vértices en unidades de mapa o píxeles

Marcar vértices

  • checkbox Mostrar marcadores sólo para los objetos espaciales seleccionados

  • Definir vértice Estilo de marcador selectString (‘Cruz’ (predeterminado), ‘Círculo semitransparente’ o ‘Nada’)

  • Definir vértice Tamaño de marcador

Herramienta de desplazamiento de curva

The next 3 options refer to the offsetCurve Offset Curve tool in Digitalización avanzada. Through the various settings, it is possible to influence the shape of the line offset. These options are possible starting from GEOS 3.3.

  • Estilo de la unión

  • Segmentos del cuadrante

  • Límite Miter

Menú GDAL

GDAL es una biblioteca de intercambio de datos para archivos ráster. Es esta pestaña, puede Editar opciones de creación y Editar opciones de pirámides de los formatos ráster. Definir que controlador GDAL se va a utilizar para un formato ráster, como en algunos casos más de un controlador está disponible.

Menú SRC

SRC predeterminado para nuevos proyectos

  • radioButtonOff Don’t enable ‘on the fly’ reprojection
  • radioButtonOn Automatically enable ‘on the fly’ reprojection if layers have different CRS
  • radioButtonOff Enable ‘on the fly’ reprojection by default
  • Seleccionar un SRC y Empezar siempre nuevos proyectos con este SRC

SRC para nuevas capas

Esta área permite definir la acción a realizar cuando una nueva capa es creada, o cuando una capa sin SRC es cargada.

  • radioButtonOn Prompt for CRS
  • radioButtonOff Use project CRS
  • radioButtonOff Use default CRS

Por defecto transformación de datum

  • checkbox Preguntar por la trasformación del datum cuando el predeterminado no este definido

  • Si ha trabajado con la trasformación de SRC ‘al vuelo’ puede ver el resultado de la transformación en la ventana de abajo. Puede encontrar información acerca de ‘Origen SRC’ y ‘Destino SRC’ así como también ‘Transformación de datum de origen’ y ‘Trasformación de datum destino’.

Menú Idioma

  • checkbox Ignorar el idioma del sistema y Idioma a usar en su lugar

  • Información acerca del idioma del sistema

Autenticación

In the Authentication tab you can set authentication configurations and manage PKI certificates. See Sistema de autenticación for more details.

Menú Red

General

  • Definir Dirección de búsqueda de WMS, por omisión es http://geopole.org/wms/search?search=\%1\&type=rss

  • Definir Expiró el tiempo para solicitudes de red - por omisión 60000

  • Definir Periodo de expiración predeterminada para teselas WMS-C/WMTS (en horas) - por omisión 24

  • Definir Reintentar al máximo en caso de errores en la solicitud de tile

  • Definir Agente- Usuario

Figure Network Tab:

../../../_images/proxy-settings.png

Configurar proxy en QGIS

Configuración de caché

Definir la configuración del caché Directorio y un Tamaño.

  • checkbox Usar proxy para acceso web y definir ‘Servidor’, ‘Puerto’, ‘Usuario’, y ‘Contraseña’.

  • Set the Proxy type selectString according to your needs.
    • Default Proxy: Proxy se determina con base en el proxy de aplicación que establece el uso

    • Socks5Proxy: Proxy genérico para cualquier tipo de conexión. Soporta TCP, UDP, unión a un puerto (conexiones entrantes) y autenticación.

    • HttpProxy: Implementado con el comando “CONNECT”, sólo admite conexiones TCP salientes; admite la autenticación.

    • HttpCachingProxy: Implementando el uso de comandos HTTP normales, es útil sólo en el contexto de peticiones HTTP.

    • FtpCachingProxy: Implementar el uso de un proxy FTP, es útil sólo en el contexto de las peticiones FTP.

Excluir algunas URLs se puede agregar a la caja de texto debajo los valores del proxy (ver Figure_Network_Tab).

Si necesita más información detallada acerca de las diferentes configuraciones de proxy, consulte el manual de documentación de la biblioteca QT en http://doc.trolltech.com/4.5/qnetworkproxy.html#ProxyType-enum.

Truco

Utilizar proxies

El uso de proxies a veces puede ser complicado. Es útil para proceder por ‘prueba y error’ con los tipos de proxies anteriores, comprobar para ver si en su caso tiene éxito.

You can modify the options according to your needs. Some of the changes may require a restart of QGIS before they will be effective.

  • nix La configuración se guarda en un archivo de texto: $HOME/.config/QGIS/QGIS2.conf

  • osx Puede encontrar sus ajustes en: $HOME/Library/Preferences/org.qgis.qgis.plist

  • win Los ajustes se almacenan bajo el registro: HKEY\CURRENT_USER\Software\QGIS\qgis

Personalización

The customization dialog lets you (de)activate almost every element in the QGIS user interface. This can be very useful if you want to provide your end-users with a ‘light’ version of QGIS, containing only the icons, menus or panels they need.

Nota

Antes de aplicar los cambios, debe reiniciar QGIS.

Figure Customization 1:

../../../_images/customization.png

El diálogo de Personalización

Ticking the checkbox Enable customization checkbox is the first step on the way to QGIS customization. This enables the toolbar and the widget panel from which you can uncheck and thus disable some GUI items.

The configurable item can be:

With select Switch to catching widgets in main application, you can click on an item in QGIS interface that you want to be hidden and QGIS automatically unchecks the corresponding entry in the Customization dialog.

Once you setup your configuration, click [Apply] or [Ok] to validate your changes. This configuration becomes the one used by default by QGIS at the next startup.

The modifications can also be saved in a .ini file using fileSave Save To File button. This is a handy way to share a common QGIS interface among multiple users. Just click on fileOpen Load from File from the destination computer in order to import the .ini file. You can also run command line tools and save various setups for different use cases as well.

Truco

Easily restore predefined QGIS

The initial QGIS GUI configuration can be restored by one of the methods below:

  • unchecking checkbox Enable customization option in the Customization dialog or click the selectAllTree Check All button
  • pressing the [Reset] button in the QSettings frame under Settings ‣ Options menu, System tab
  • launching QGIS at a command prompt with the following command line qgis --nocustomization
  • setting to false the value of UI ‣ Customization ‣ Enabled variable under Settings ‣ Options menu, Advanced tab.

In most cases, you need to restart QGIS in order to have the change applied.