Outdated version of the documentation. Find the latest one here.

Allgemeine Werkzeuge

Tastenkürzel

QGIS bietet Standard Tastenkürzel für zahlreiche Funktionen. Sie können im Kapitel Menüleiste nachgelesen werden. Zusätzlich ist es aber auch möglich, eigene Tastenkürzel zu definieren und bestehende zu ändern. Öffnen Sie dazu das Menü Einstellungen ‣ Tastenkürzel festlegen.

Figure Shortcuts 1:

../../../_images/shortcuts.png

Define shortcut options nix (KDE)

Die Konfiguration ist sehr einfach. Wählen Sie einfach eine Aktion aus und drücken dann auf [Ändern], [Keins setzen] oder [Voreinstellung]. Wenn Sie ihre Einstellung gefunden haben, kann diese als XML-Datei abgespeichert und somit auch für eine andere QGIS Installation genutzt werden.

Hilfe

Wenn Sie Hilfe zu bestimmten Themen brauchen erreichen Sie die Kontext-Hilfe über den Hilfe Knopf der Ihnen in den meisten Dialogen zur Verfügung steht. Bitte beachten Sie daß Erweiterungen von Drittanbietern zu dementsprechend gewidmeten Internetseiten verweisen.

Layeranzeige kontrollieren

QGIS rendert standardmäßig alle sichtbaren Layer wenn das Kartenfenster aktualisirt werden muss. Die Abläufe, die eine ‘Erneuerung’ der Wiedergabe verursachen sind:

  • Einen Layer hinzufügen

  • Karten verschieben, hinein- oder herauszoomen

  • Größe des QGIS-Fensters verändern

  • Layer ein- oder ausblenden

QGIS ermöglicht es, den Wiedergabeprozess auf verschiedene Arten zu kontrollieren.

Maßstabsabhängige Layeranzeige

Die maßstabsabhängige Wiedergabe erlaubt es, einen mini- und maximalen Maßstab, in dessen Rahmen ein Layer angezeigt wird, anzugeben. Um die maßstabsabhängige Wiedergabe einzustellen öffnen Sie den Eigenschaften Dialog eines Layers, indem Sie diesen in der Legende doppelt anklicken, im Reiter Allgemein die entsprechenden Einstellungen vornehmen und das Kontrollkästchen checkboxMaßstabsabhängig zeichnen aktivieren.

Sie können es einstellen, in dem Sie erst mit der Maus im Kartenfenster den gewünschten Maßstab wählen und dann die Werte aus der Statusleiste übernehmen.

Layeranzeige kontrollieren

Die Kartenwiedergabe kann auf folgende Art kontrolliert werden:

Wiedergabe unterdrücken

Um die Wiedergabe einer Karte zu unterdrücken, klicke Sie auf das Kontrollkästchen checkbox Zeichnen auf der rechten Seite der Statusleiste. Wenn das Kontrollkästchen nicht aktiv ist, führt QGIS keine Erneuerung der Wiedergabe des Kartenfensters durch wie in Abschnitt Layeranzeige kontrollieren beschrieben. Beispiele, bei denen das Unterdrücke der Wiedergabe angewendet wird, sind:

  • Viele Layer hinzufügen und ihre Symbologie vor der Visualisierung einstellen

  • Einen oder mehrere große Layer hinzufügen und erst die maßstabsabhängige Wiedergabe einstellen

  • Einen oder mehrere große Layer hinzufügen und erst in ein bestimmtes Gebiet hineinzoomen

  • Eine Kombination aus den oben genannten Punkten

Wenn Sie die checkbox Zeichnen aktivieren, findet automatisch eine Erneuerung der Wiedergabe des Kartenfensters statt.

Option für Layer hinzufügen

Sie können für das Hinzuladen neuer Layer eine Einstellung vornehmen, die bewirkt, dass diese beim Laden erst einmal nicht angezeigt werden. Um diese Option zu nutzen deaktivieren Sie in der Menuleiste unter Einstellungen ‣Optionen ‣ im Reiter Darstellung das Kontrollkästchen checkbox Normalerweise werden alle neuen Layer im Kartenfenster angezeigt. Dadurch werden alle neu geladenen Layer erstmal nicht angezeigt.

Zeichnen stoppen

Um die Wiedergabe einer Karte zu stoppen drücken Sie die ESC Taste. Dies stoppt die Erneuerung der Wiedergabe und die Karte wird nur zum Teil angezeigt. Es kann sein dass etwas Zeit zwischen dem Drücken der Esc Taste und dem Stoppen der Kartenwiedergabe vergeht.

Bemerkung

Es ist derzeit nicht möglich das Zeichnen zu stoppen - diese Funktion wurde mit der Version qt4 ausgeschaltet da es zu Problemen und Abstürzen der Benutzeroberfläche kam.

Anpassen des Kartenfensters bei der Wiedergabe

Normalerweise werden in QGIS Inhalte von Layern erst visualisiert wenn sämtliche Daten geladen sind. Um zu bewirken, dass die Inhalte von Layern direkt beim Lesen angezeigt werden, verändern Sie in der Menüleiste unter Einstellungen ‣Optionen im Reiter Darstellung die Anzahl von Objekten, nach deren Zeichnung die Anzeige aktualisiert werden soll. Der Wert 0 (Standard) verhindert die Aktualisierung während des Zeichnens. Bei zu niedrigem Wert leidet die Leistung, das ständig ein Update der Wiedergabe stattfindet. Zu Beginn ist oftmals ein Wert von 500 sinnvoll.

Die Qualität der Wiedergabe beeinflussen

Um die Wiedergabequalität der Layer zu beeinflussen gibt es drei Möglichkeiten. Öffnen Sie den Reiter Darstellung im Menü Einstellungen ‣Optionen ‣ und aktivieren bzw. deaktivieren Sie folgende Kontrollkästchen.

  • checkbox Linien auf Kosten der Zeichengeschwindigkeit weniger gezackt zeichnen

  • checkbox Problem mit falsch gefüllten Polygonen beheben

Messen

Das Messen funktioniert mit Projektionen (z.B. UTM) und auch mit nicht projizierten Daten. Wenn die geladene Karte als Geografisches Koordinatensystem abgebildet wird (z.B. Latitude/Longitude) sind die Messergebnisse falsch. Sie müssen dann ein passendes KBS mit einer Projektion verwenden (siehe Abschnitt Arbeiten mit Projektionen). Alle Meßwerkzeuge verwenden auch die eingestellte Fangtoleranz der Digitalisierung. Dies ist zum Beispiel dann sinnvoll, wenn Sie entlang von Linien oder Polygongrenzen geladener Vektorlayer messen wollen.

Um ein Meßwerkzeug auszuwählen klicken Sie auf mActionMeasure und suchen das Werkzeug das sie benutzen wollen aus.

Strecken, Flächen und Winkel messen

mActionMeasure QGIS kann reale Distanzen ziwschen Punkten auf Basis eines vorgegebenen Ellipsoiden messen. Dazu wählen Sie im Menü Einstellungen ‣Optionen im Reiter Kartenwerkzeuge einen Ellipsoiden aus. Es kann außerdem die Gummibandfarbe und die bevorzugte Maßeinheit eingestellt werden. Das Werkzeug ermöglicht es, Punkte im Kartenfenster auszuwählen. Jedes Längensegment wird in einem Popup angezeigt und zusätzlich auch die Gesamtlänge aller Längensegmente. Um das Messen von Strecken zu beenden, klicken Sie auf die rechte Maustaste.

Figure Measure 1:

../../../_images/measure_line.png

Measure Distance nix (KDE)

mActionMeasureArea Auch Flächengrößen können gemessen werden. Das Popup zeigt dabei die akkumulierte Flächengröße. Zusätzlich schnappt das Meßwerkzeug auf den gerade ausgewählten Layer wenn für den entsprechenden Layer ein Fangmodus eingestellt wurde (siehe Abschnitt Einstellen der Fangtoleranz und des Suchradius). Wenn Sie also exakt entlang einer Linie oder Polygonumrandung messen möchten, setzen Sie erst eine Fangtoleranz und selektieren dann den Layer. Wenn Sie jetzt das Meßwerkzeug benutzen schnappt man mit jedem Mausklick (innerhalb der eingestellten Toleranz) auf den Layer.

Figure Measure 2:

../../../_images/measure_area.png

Measure Area nix (KDE)

mActionMeasureAngle Auch Winkel können mit dem Winkel messen- Werkzeug gemessen werden. Der Mauszeiger wird zum Kreuz. Drücken Sie die linke Maustaste und zeichnen Sie das erste Segment des Winkels, klicken nochmals auf die linke Maustaste und messen sie den Winkel, der im Dialogfenster angezeigt wird.

Figure Measure 3:

../../../_images/measure_angle.png

Measure Angle nix (KDE)

Objekte auswählen und Auswahl aufheben

Die Werkzeugleiste bietet mehrere Werkzeuge, um Objekte im Kartenfenster auszuwählen. Um ein oder mehrere Objekte auszuwählen, klicken Sie auf mActionSelect und wählen Sie dann das entsprechende Werkzeug:

  • mActionSelect Einzelnes Objekt wählen

  • mActionSelectRectangle Objekte durch Rechteck wählen

  • mActionSelectPolygon Objekte durch Polygon wählen

  • mActionSelectFreehand Objekte freihändig wählen

  • mActionSelectRadius Objekte durch Radius wählen

Um die Auswahl von Objekten wieder aufzuheben, klicken Sie auf den Knopf mActionDeselectAll.

Dekorationen

Die Dekorationen von QGIS beinhalten einen Urheberrechtshinweis, einen Nordpfeil und einen Maßstab. Sie werden dazu verwendet die Karte durch Hinzufügen von kartographischen Elementen zu Dekorieren.

Bemerkung

Vor QGIS 1.8. wurde die gleiche Funktionaliät durch die Dekorationen Plugins zur Verfügung gestellt.

Nordpfeil

north_arrow Nordpfeil platziert einen einfachen Nordpfeil im Kartenfenster. Bislang steht hierfür lediglich eine Pfeilform zur Verfügung. Sie können die Richtung des Nordpfeiles entweder selbst anpassen oder dies automatisch von QGIS bewerkstellingen lassen. Wenn Sie es QGIS überlassen die Richtung zu bestimmen, entscheided das Programm, in welche Richtung der Nordpfeil idealerweise zeigen sollte.

Figure Decorations 2:

../../../_images/north_arrow_dialog.png

The North Arrow Dialog nix

Maßstab

scale_bar Maßstab fügt dem Kartenausschnitt einen einfachen Maßstabsbalken hinzu. Dabei können Sie sowohl das Aussehen, die Platzierung , als auch die Beschriftung festlegen.

Figure Decorations 3:

../../../_images/scale_bar_dialog.png

The Scale Bar Dialog nix

QGIS unterstützt hierbei jedoch lediglich die Darstellung des Balkens in denjenigen Einheiten, die auch in Ihren entsprechenden Karten verwendet werden. Dies bedeutet, dass Sie einer Karte deren Layer der Einheit Meter entsprechen, keinen Maßstabsbalken in den Einheiten Fuß oder Zoll hinzufügen können.

Das Hinzufügen eines Maßstabbalkens geht folgendermaßen:

  1. Klicken Sie auf Ansicht ‣Dekorationen ‣ Maßstab. Der Dialog startet (siehe figure_decorations_3)

  2. Wählen Sie aus dem Drop-Down Menü Platzierung ‘Unten Links’ aus

  3. Wählen Sie aus dem Drop-Down Menü Maßstabsstil ‘Strich unten’ aus

  4. Wählen Sie aus Balkenfarbe‘schwarz’ aus oder verwenden Sie die Standardfarbe schwarz

  5. Legen Sie die Größe des Balkens und seine Beschriftung unter Größe des Maßstabs mit ‘30 Grad’ fest

  6. Vergewissern Sie sich, dass das Kontrollkästchen checkbox Aktiviere Maßstab aktiv ist

  7. Optional können Sie noch auswählen. dass die Maßstabszahl bei Größenänderungen immer auf eine Ganze Zahl gerundet werden soll mit dem Kontrollkästchen checkbox Bei Größenänderungen automatisch runde Zahlen einstellen

  8. Klicken Sie auf OK

Tipp

Einstellungen von Dekorationen

Wenn Sie ein .qgs-Projekt speichern werden alle bezüglich Nordpfeil, Maßstab und Urheberrechtshinweis gemachten Änderungen im Projekt gespeichert und das nächste mal wenn das Projekt geladen wird wiederhergestellt.

Beschriftungstools

Das mActionTextAnnotation Beschriftungstext-Werkzeug in der Atrribut-Werkzeugleiste bietet die Möglichkeit formatierten Text in einer Sprechblase im QGIS Kartenfenster zu platzieren. Aktivieren Sie dazu einfach das Beschriftungstext-Werkzeug und klicken Sie in das Kartenfenster.

Figure annotation 1:

../../../_images/annotation.png

Annotation text dialog nix

Ein Doppelklick auf das Element öffnet den Dialog mit verschiedenen Optionen. im Texteditor können Sie den formatierten Text eingeben und einige Einstellungen vornehmen. Z.B. kann das Objekt an einer bestimmten Stelle positioniert werden, was dann durch ein Markersymbol angezeigt wird. Oder das es unabhängig von dem Objekt im Kartenfenster angezeigt wird. Der Text kann entweder durch Verschieben der Markierung oder der Sprechblase im Kartenfenster verschoben werden.

Das mActionAnnotation Beschriftung verschieben Werkzeug ermöglicht es, den Beschriftungstext im Kartenfenster mit der Maus zu verschieben.

Beschriftungsformular

Zusätzlich können Sie eigene Beschriftungsformulare erstellen. Das mActionFormAnnotation Beschriftungsformular Tool ist nützlich um Attribute eines Vektorlayers in einem maßgeschneiderten QT-Designer Beschriftungsformular anzuzeigen. (siehe figure_custom_annotation). Es ist ähnlich wie die Designer-Formulare für das Identifizierungswerkzeug, wird aber als Beschriftungstext angezeigt. Siehe auch den QGIS-Blog Eintrag unter der URL http://blog.qgis.org/node/143 für weitere Informationen.

Figure annotation 2:

../../../_images/custom_annotation.png

Customized qt designer annotation form nix

Bemerkung

Wenn Sie das Tastenkürzel Ctrl+T drücken während ein Beschriftungswerkzeug aktiv ist ändert sich deren Anzeigestatus zwischen an und aus.

Räumliche Lesezeichen

Räumliche Lesezeichen ermöglichen es, geografische Orte zu markieren und als Lesezeichen abzuspeichern, um dorthin später zurückzufinden.

Ein Lesezeichen erstellen

Um ein Lesezeichen zu erstellen:

  1. Zoomen oder verschieben Sie das Kartenfenster in einen Ausschnitt Ihrer Wahl.

  2. Wählen Sie in der Menüleiste Ansicht ‣ Neues Lesezeichen oder drücken Sie kbd:Ctrl-B.

  3. Geben Sie eine Beschreibung für das Lesezeichen ein (bis zu 255 Zeichen).

  4. Klicken Sie auf Enter um das Lesezeichen hinzuzufügen oder auf [Löschen] um das Lesezeichen zu entfernen.

Sie können mehrere Lesezeichen mit demselben Namen erstellen.

Arbeiten mit Lesezeichen

Um ein bestehendes Lesezeichen zu editieren, wählen Sie in der Menüleiste Ansicht ‣ Zeige Lesezeichen. Das Dialogfenster erlaubt es, auf ein Lesezeichen zu zoomen oder es zu löschen. Sie können die Koordinaten oder den Namen des Lesezeichens nicht verändern.

Auf ein Lesezeichen zoomen

Im Dialogfenster Räumliches Lesezeichen klicken Sie auf das gewünschte Lesezeichen und wählen dann den Knopf [Zoomen auf]. Sie können auch auf ein Lesezeichen zoomen, indem Sie es mit einem Doppelklick auswählen.

Ein Lesezeichen löschen

Um ein Lesezeichen aus dem Dialogfenster Räumliches Lesezeichen zu löschen, klicken Sie auf das gewünschte Lesezeichen, dann auf den Knopf [Löschen] und bestätigen Sie es mit [Ja] oder [Nein].

Layer/Gruppen einbinden

Wenn Sie Inhalte von anderen Projekten in Ihr Projekt einbinden wollen wählen Sie Layer ‣ Eingebettete Layer und Gruppen.

Layer einbetten

Der folgende Dialog ermöglicht Ihnen das Einbetten von Layern aus anderen Projekten:

  1. Drückekn Sie browsebutton um nach einem anderen Projekt des Alaskadatensatzes zu suchen.

  2. Drücken Sie die Projektdatei grassland. Sie können den Inhalt des Projektes sehen (siehe figure_embed_dialog).

  3. Drücken Sie Ctrl und klicken Sie auf die Layer grassland und regions. Die Layer sind jetzt in der Kartenlegende und im Kartenfenster eingebettet.

Figure Nesting 1:

../../../_images/embed_dialog.png

Select layers and groups to embed nix

Die eingebetteten Layer sind editierbar sie können jedoch Eigenschaften wie Stil und Beschriftung nicht ändern.

Eingebettete Layer entfernen

Klicken Sie mit der rechten Maustaste auf den eingebetteten Layer und wählen Sie mActionRemoveLayer Entfernen.