Algemene opties items Lay-out

QGIS verschaft een groot aantal items om een kaart op te maken. Zij kunnen zijn van het type kaart, legenda, schaalbalk, afbeelding, tabel, noordpijl… Zij delen echter enkele algemene opties en gedrag dat hieronder wordt uitgelegd.

Een item voor lay-out maken

Items kunnen worden gemaakt met verschillende gereedschappen, ofwel vanaf niets of gebaseerd op bestaande items.

Een item voor lay-out maken vanaf niets:

  1. Selecteer het overeenkomende gereedschap ofwel uit het menu Item toevoegen of de werkbalk Toolbox.

  2. Dan:

    • Klik op de pagina en vul de grootte en informatie voor de plaatsing in in het dialoogvenster Nieuw item eigenschappen dat opent (voor details, bekijk Positie en grootte);

      ../../../../_images/new_item_properties.png

      Dialoogvenster Nieuw item Eigenschappen

    • Of klik-en-sleep om de initiële grootte en plaatsing van het item te definiëren. U kunt vertrouwen op snappen aan rasters en hulplijnen voor een betere positie.

Notitie

Omdat zij bijzondere vormen kunnen hebben werken de methoden met één klik, noch klikken-en-slepen voor het tekenen van items knoop en pijl; u dient te klikken en elke knoop van het item te plaatsen. Bekijk De op knopen gebaseerde vormen voor meer details.

U kunt ook:

  1. Een bestaand item selecteren met de knop select Item selecteren/verplaatsen op de werkbalk Toolbox

  2. Het contextmenu of de gereedschappen van het menu Bewerken gebruiken om het item te kopiëren/knippen en het op de muispositie plakken als een nieuw item.

    U kunt ook de opdracht In plaats plakken (Ctrl+Shift+V) gebruiken om een item te dupliceren van de ene pagina naar een andere en het op de nieuwe pagina plakken op dezelfde coördinaten als het origineel.

Meer nog, u kunt items maken met een sjabloon voor afdruklay-out (voor details, bekijk Lay-out beheren) met de opdracht Lay-out ‣ Items uit sjabloon toevoegen….

Tip

Items voor lay-out toevoegen met de bestandsverkenner

Vanuit uw bestandsverkenner of met het paneel Browser sleep-en-laat vallen een sjabloon voor een afdruk-lay-out (bestand .qpt) op een dialoogvenster voor een afdruklay-out en QGIS voegt automatisch alle items uit dat sjabloon toe aan de lay-out.

Werken met items voor lay-out

Elk item in de afdruklay-out kan worden verplaatst en op grootte worden gebracht om een perfecte lay-out te maken. Voor beide bewerkingen is de eerste stap om het gereedschap select Item selecteren/verplaatsen en te klikken op het item.

U kunt meerdere items kiezen met de knop select Item selecteren/verplaatsen: klik en sleep over de items of houdt de toets Shift ingedrukt en klik op alle items die u nodig heeft. Klik erop met ingedrukte Shift-toets om een item te deselecteren.

Elke keer als er een selectie is wordt het aantal items weergegeven op de statusbalk. In het menu Bewerken vind u acties om alle items te selecteren, alle selecties op te heffen, de huidige selectie om te keren en meer…

Items verplaatsen en grootte wijzigen

Tenzij de optie Beeld ‣ Begrenzingsvakken weergeven niet is geselecteerd zal een geselecteerd item vierkantjes rondom zijn randen weergeven ; verplaatsen van een daarvan met de muis zal de grootte van het item in de overeenkomende richting wijzigen. Ingedrukt houden van de Shift-toets tijdens het wijzigen van de grootte zal de verhoudingen behouden. Ingedrukt houden van de Alt-toets zal de grootte wijzigen vanuit het midden van het item.

Selecteer, om een item voor de lay-out te verplaatsen, het met de muis en verplaatst het met ingedrukte linker muisknop. Als u de verplaatsing wilt beperken tot de horizontale of verticale as, houd dan de Shift-toets op het toetsenbord ingedrukt tijden het verplaatsen van de muis. U kunt ook ene geselecteerd item verplaatsen met de pijltoetsen op het toetsenbord; als de verplaatsing te langzaam gaat kunt u die versnellen door Shift ingedrukt te houden. Als u een betere precisie nodig hebt, gebruik dan de eigenschappen Positie en grootte, of snappen aan rasters/hulplijnen zoals hierboven uitgelegd voor het maken van items.

Wijzigen van de grootten of verplaatsen van verscheidene items in één keer gaat op dezelfde manier als voor een enkel item. QGIS verschaft echter enkele gevorderde gereedschappen om automatisch de grootte van een selectie items te wijzigen door verschillende regels te volgen:

  • de hoogte van elk item komt overeen met het resizeTallest grootste of het resizeShortest kleinste geselecteerde item;

  • de breedte van elk item komt overeen met resizeWidest breedste of het resizeNarrowest smalste geselecteerde item;

  • grootten van items wijzigen naar resizeSquare vierkanten: elk item wordt vergroot om een vierkant te vormen.

Op dezelfde wijze zijn geautomatiseerde gereedschappen beschikbaar om de positie van meerdere items te beheren door ze gelijkmatig te verdelen:

  • randen (links, rechts, boven of onder) van items;

  • midden van items ofwel horizontaal of verticaal.

Items groeperen

Groeperen van items stelt u in staat een set items te bewerken zoals één enkel: u kunt eenvoudig grootte wijzigen, verplaatsen, verwijderen, kopiëren van de items als één geheel.

Selecteer, om een groep items te maken, er meer dan één en druk op de knop groupItems Groeperen in het menu Beeld of de werkbalk Acties of vanuit het menu met rechts klikken. Een rij genaamd Groep is toegevoegd aan aan het paneel Items en kan worden vastgezet of verborgen, net als elk ander object van het paneel Items. Gegroepeerde items zijn niet individueel te selecteren in het kaartvenster; gebruik het paneel Items om direct te selecteren en toegang te krijgen tot het paneel Item-eigenschappen.

Items vastzetten

Once you have found the correct position for an item, you can lock it by using the locked Lock selected items button in the Items menu or the Actions toolbar or ticking the box next to the item in the Items panel. Locked items are not selectable on the canvas.

Vastgezette items kunnen worden losgemaakt door het item te selecteren op het paneel Items en het keuzevak te deselecteren, of u kunt de pictogrammen op de werkbalk gebruiken.

Uitlijning

De visuele hiërarchie verhogen of verlagen van items staan in het keuzemenu raiseItems Geselecteerde items verhogen. Kies een item uit het kaartvenster van de afdruklay-out en selecteer de overeenkomende functionaliteit om het geselecteerde item te verhogen of te verlagen vergeleken met de andere items. Deze volgorde wordt weergegeven in het paneel Items. U kunt ook objecten verhogen of verlagen op het paneel Items door een label van een object aan te klikken en te verslepen in deze lijst.

../../../../_images/alignment_lines.png

Hulplijnen voor uitlijnen in de afdruklay-out

Er zijn verscheidene opties voor uitlijning beschikbaar binnen het menu alignLeft Geselecteerde items uitlijnen (zie figure_layout_common_align). U selecteert eerst enkele items en klikt dan op één van de pictogrammen voor uitlijning.

  • alignLeft Links uitlijnen of alignRight Rechts uitlijnen;

  • alignTop Bovenkant uitlijnen of alignBottom Onderkant uitlijnen;

  • alignHCenter Midden uitlijnen horizontaal of alignVCenter Midden verticaal uitlijnen.

Alle geselecteerde items zullen dan worden uitgelijnd op hun gemeenschappelijk begrenzingsvak. Bij het verplaatsen van items in het kaartvenster verschijnen hulplijnen voor uitlijnen als randen, midden of hoeken worden uitgelijnd.

Items Algemene eigenschappen

Items van afdruklay-out hebben een verzameling algemene eigenschappen die u vindt aan de onderzijde van het paneel Item-eigenschappen: Positie en grootte, Rotatie, Frame, Achtergrond, Item ID, Variabelen en Rendering (Zie figure_layout_common).

../../../../_images/common_properties.png

Algemene groepen Item-eigenschappen

Notitie

Het pictogram dataDefined Data bepaalde ‘override’ naast de meeste opties betekent dat u die eigenschap kunt associëren met een laag, attributen van objecten, geometrie of met enig andere eigenschap van lay-outitems met expressies of variabelen. Deze zijn in het bijzonder handig bij het genereren van een atlas (Bekijk voor meer informatie Knoppen Data-bepaalde ‘override’ verkennen met atlas).

  • De groep Positie en grootte laat u de grootte en de positie definiëren van het frame dat het item bevat (zie Positie en grootte voor meer informatie).

  • De Rotatie stelt de rotatie van het item in (in graden).

  • The checkbox Frame shows or hides the frame around the item. Use the Color, Thickness and Join style widgets to adjust those properties.

  • Gebruik het menu Achtergrondkleur voor het instellen van een achtergrondkleur. Klik op de knop [Kleur…] om een dialoogvenster weer te geven waar u een kleur of een aangepaste instelling kunt kiezen. Transparantie kan worden aangepast door de instellingen voor het veld Alfa te wijzigen.

  • Gebruik Item ID om een relatie te maken naar andere items van afdruklay-out. Dit wordt gebruikt met de server van QGIS en andere potentiële webcliënten. U kunt een ID instellen voor een item (bijvoorbeeld een kaart en een label), en dan kan de webcliënt gegevens verzenden om een eigenschap in te stellen (bijv. tekst voor een label) voor dat specifieke item. De opdracht GetProjectSettings zal de items en ID’s vermelden die beschikbaar zijn in een lay-out.

  • Modus Rendering helpt u in te stellen of en hoe het item moet worden weergegeven: u kunt, bijvoorbeeld, Meng-modus toepassen, de doorzichtbaarheid van het item aanpassen of Item uitsluiten voor exporteren.

Positie en grootte

Uitbreiden van de mogelijkheden van het dialoogvenster Nieuw Item eigenschappen met data-bepaalde mogelijkheden, deze groep stelt u in staat de items nauwkeurig te plaatsen.

../../../../_images/position_size.png

Position and size

  • het feitelijke nummer van de page waar het item op geplaatst moet worden;

  • het verwijzingspunt van het item;

  • de coördinaten X en Y van het Referentiepunt van het item op de geselecteerde pagina. De verhouding tussen deze waarden kan worden vergrendeld door te klikken op de knop lockedGray. Wijzigen van een waarde met het widget of met het gereedschap select Item selecteren/verplaatsen zal in beide zichtbaar zijn;

  • de Breedte en Hoogte van het begrenzingsvak van het item. Net als met coördinaten kan de verhouding tussen breedte en hoogte worden vergrendeld.

Modus Rendering

QGIS staat nu geavanceerde rendering toe voor items van afdruklay-out net zoals voor vector- en rasterlagen.

../../../../_images/rendering_mode.png

Modus Rendering

  • Meng-modus: U kunt met dit gereedschap speciale effecten bereiken die anders mogelijk pas konden worden bereikt met grafische programma’s. De pixels van uw bovenliggende en onderliggende items worden gemengd via de overeenkomstig de ingestelde modus (bekijk Meng-modi voor een beschrijving van elk effect).

  • Transparantie slider: U kunt met dit gereedschap het onderliggende item in afdruklay-out zichtbaar maken. Gebruik de schuifbalk om de zichtbaarheid van uw item aan uw behoeften aan te passen. U kunt ook een precieze definitie van het percentage zichtbaarheid instellen in het menu naast de schuifbalk.

  • checkbox Item uitsluiten voor exporteren: U kunt besluiten om een item onzichtbaar te maken in alle acties voor exporteren. Na het activeren van het keuzevak, zal het item niet worden opgenomen in PDF’s, afdrukken etc..

Variabelen

Variabelen vermeldt alle beschikbare variabelen op het niveau van het item voor afdruklay-out (inclusief alle globale, project en lay-out variabelen). Kaartitems bevatten ook variabelen voor Kaartinstellingen die eenvoudige toegang verlenen tot waarden zoals het schaalbereik van de kaart, enzovoort.

In Variabelen is het ook mogelijk om variabelen op het niveau van het item te beheren. Klik op de knop signPlus om een nieuwe aangepaste variabele toe te voegen. Selecteer op dezelfde wijze een aangepaste variabele uit de lijst en klik op de knop signMinus om hem te verwijderen.

Meer informatie over het gebruiken van variabelen in het gedeelte Waarden opslaan in Variabelen.