Opzioni comuni degli Oggetti del Layout

QGIS fornisce un’ampia gamma di oggetti per il layout di una mappa. Possono essere di mappa, legenda, barra di scala, immagine, tabella, freccia nord, tipo immagine….. Tuttavia, condividono alcune opzioni e comportamenti comuni che vengono di seguito trattati.

Creare un oggetto nel Layout

Gli oggetti possono essere creati utilizzando diversi strumenti, sia da zero o sulla base di oggetti esistenti.

Per creare un oggetto di layout da zero:

  1. Seleziona lo strumento corrispondente o dal menu Aggiungi Oggetto o dalla barra Strumenti.

  2. Poi:

    • Clicca sulla pagina e immetti la dimensione e le informazioni di posizionamento richieste nella finestra di dialogo Proprietà nuovo oggetto che compare (per i dettagli, vedi Posizione e Dimensione);

      ../../../../_images/new_item_properties.png

      Finestra di dialogo Proprietà nuovo oggetto

    • Oppure tieni premuto il clic sinistro e trascina per definire la dimensione iniziale e il posizionamento dell’oggetto. Puoi contare sull’aggancio di griglie e guide per un posizionamento migliore.

Nota

Poiché possono avere forme particolari, il disegno di oggetti nodi o frecce non funziona con i metodi con un solo clic né con clic e trascina; devi fare clic e posizionare ogni nodo dell’oggetto. Vedi layout_node_node_based_shape_item per maggiori dettagli.

Puoi anche:

  1. Selezionare un oggetto esistente con il pulsante select Seleziona/Sposta oggetto dalla barra Strumenti

  2. Usare il menu contestuale o gli strumenti del menu Modifica per copiare/tagliare l’oggetto e incollarlo nella posizione del mouse come nuovo oggetto.

    Puoi anche utilizzare il comando Incolla sul posto (Ctrl+Shift+V) per duplicare un oggetto da una pagina all’altra e posizionarlo nella nuova pagina alle stesse coordinate dell’originale.

Inoltre, puoi creare oggetti utilizzando un modello di layout di stampa (per i dettagli, vedi Il Gestore del Layout) tramite il comando Layout ‣ Aggiungi Oggetti da modello….

Suggerimento

Aggiungere elementi di layout utilizzando il file browser

Dal tuo file browser o usando il pannello Browser, trascina e rilascia un modello di layout di stampa (.qpt file) in una finestra di dialogo di layout di stampa e QGIS aggiunge automaticamente tutti gli elementi di quel modello al layout.

Interagire con gli oggetti del layout

Ogni oggetto all’interno del layout di stampa può essere spostato e ridimensionato per creare un layout perfetto. Per entrambe le operazioni il primo passo è quello di attivare lo strumento select Seleziona/Sposta oggetto e cliccare sull’oggetto.

Puoi selezionare più oggetti con il pulsante select Seleziona/Sposta oggetto: fai clic e trascina gli oggetti o tieni premuto il pulsante Shift e fai clic su ciascuno degli oggetti desiderati. Per deselezionare un oggetto, clicca su di esso tenendo premuto il pulsante Shift.

Ogni volta che c’è una selezione, il conteggio degli oggetti selezionati viene visualizzato sulla barra di stato. All’interno del menu Modifica menu, è possibile trovare azioni per selezionare tutti gli oggetti, cancellare tutte le selezioni, invertire la selezione corrente e altro ancora…..

Spostamento e ridimensionamento degli oggetti

A meno che l’opzione Visualizza ‣ Mostra i Perimetri di Delimitazione non sia deselezionata, un oggetto selezionato mostrerà dei quadrati sui suoi confini; spostando uno di essi con il mouse ridimensionerà l’oggetto nella direzione corrispondente. Durante il ridimensionamento, tenendo premuto Shift manterrà il rapporto di aspetto. Tenendo premuto Alt si ridimensiona dal centro dell’oggetto.

Per spostare un oggetto del layout, selezionarlo con il mouse e muoverlo tenendo premuto il tasto sinistro. Se è necessario limitare i movimenti all’asse orizzontale o verticale, basta tenere premuto il tasto Shift sulla tastiera mentre si muove il mouse. Puoi anche spostare un oggetto selezionato usando il tasto Arrow keys sulla tastiera; se il movimento è troppo lento, puoi accelerarlo tenendo premuto Shift. Se hai bisogno di maggiore precisione, usa le proprietà Posizione e Dimensione, o aggancio al reticolo/guide come spiegato sopra per la creazione dell’oggetto.

Il ridimensionamento o lo spostamento di più oggetti contemporaneamente è fatto allo stesso modo come per un singolo oggetto. QGIS fornisce tuttavia alcuni strumenti avanzati per ridimensionare automaticamente una selezione di oggetti seguendo regole diverse:

  • l’altezza di ogni oggetto corrisponde al resizeTallest più alto o a quella resizeShortest più corto oggetto selezionato;

  • la larghezza di ogni oggetto corrisponde al resizeWidest più largo o resizeNarrowest più stretto oggetto selezionato;

  • ridimensiona gli oggetti in resizeSquare quadrati: ogni oggetto viene ridimensionato in forma quadrata.

Allo stesso modo, sono disponibili strumenti automatici per organizzare la posizione di più oggetti i distribuendoli in modo equidistante:

  • al bordo (sinistro, destro, superiore o inferiore) degli oggetti;

  • centrando gli oggetti sia orizzontalmente che verticalmente.

Raggruppamento degli oggetti

Raggruppare gli oggetti ti permette di manipolare un insieme di oggetti come un unico oggetto: si possono facilmente ridimensionare, spostare, eliminare, copiare gli oggetti nel loro insieme.

Per creare un gruppo di oggetti, selezionane più di uno e premi il pulsante groupItems Raggruppa nel menu Oggetti o nella barra delle Azioni o dal menu tasto destro del mouse. Una riga denominata Group viene aggiunta al pannello Oggetti e può essere bloccata o nascosta come qualsiasi altro Items panel’s object. Gli oggetti raggruppati sono non selezionabili singolarmente sulla mappa; utilizza il pannello Oggetti per la selezione diretta e accedi al pannello delle proprietà dell’oggetto.

Bloccare gli oggetti

Quando hai trovato la posizione corretta per un oggetto, puoi bloccarlo utilizzando il pulsante locked Blocca gli oggetti selezionati nel menù Oggetti o nella Barra delle Azioni o selezionando la casella accanto all’oggetto nel pannello Oggetti. Gli elementi bloccati sono non selezionabili sull’area di stampa.

Gli oggetti bloccati possono essere sbloccati selezionando l’oggetto nel pannello Oggetti e deselezionando la casella di spunta oppure puoi utilizzare le icone sulla barra degli strumenti.

Allineamento

Lo spostamento in alto o in basso nella gerarchia visiva degli oggetti si trova all’interno del menu a discesa raiseItems Muovi in alto. Scegli un oggetto nell’area di stampa del layout e seleziona la funzione corrispondente per alzare o abbassare l’oggetto selezionato rispetto agli altri oggetti. Questo ordine è mostrato nel pannello Oggetti. Puoi anche alzare o abbassare gli oggetti nel pannello Oggetti cliccando e trascinando l’etichetta di un oggetto in questa lista.

../../../../_images/alignment_lines.png

Allineamento alle linee di aiuto nel layout di stampa

Ci sono diverse opzioni di allineamento disponibili nel menu a tendina alignLeft Allinea a sinistra (vedi figure_layout_common_align). Per usare una funzione di allineamento, si selezionano prima gli oggetti e poi si clicca su una delle icone di allineamento:

  • alignLeft Allinea a sinistra o alignRight Allinea a destra;

  • alignTop Allinea in alto o alignBottom Allinea in fondo;

  • alignHCenter Allinea al centro orizzontale o alignVCenter Allinea al centro Verticale.

Tutti gli oggetti selezionati saranno quindi allineati al loro comune rettangolo di delimitazione. Quando si spostano oggetti sull’area di disegno, le linee di aiuto all’allineamento appaiono quando i bordi, i centri o gli angoli sono allineati.

Proprietà comuni Oggetti

Gli oggetti del layout hanno un insieme di proprietà comuni che si trovano in fondo al pannello Proprietà dell’oggetto: Posizione e dimensione, Rotazione, Cornice, Sfondo, ID oggetto, Variabili e Visualizzazione (vedi figure_layout_common).

../../../../_images/common_properties.png

Gruppi di Proprietà comuni in Proprietà dell’Oggetto

Nota

L’icona dataDefined Sovrascrittura definita dai dati accanto alla maggior parte delle opzioni significa che puoi associare quella proprietà ad un layer, agli attributi degli oggetto, alla geometria o a qualsiasi altra proprietà di layout, usando expressions o variables. Per ulteriori informazioni vedi data_definita.

  • Il gruppo Posizione e Dimensione ti permette di definire la dimensione e la posizione del riquadro che contiene l’oggetto (vedi Posizione e Dimensione per maggiori informazioni).

  • La Rotazione imposta la rotazione dell’oggetto (in gradi).

  • La checkbox Cornice mostra o nasconde la cornice intorno all’oggetto. Clicca su Colore e Spessore e il widget Stile unione per regolare queste proprietà.

  • Utilizza il menu Sfondo per impostare un colore di sfondo. Fai clic sul pulsante [Colore] per visualizzare una finestra di dialogo in cui puoi scegliere un colore o un’impostazione personalizzata. La trasparenza può essere regolata modificando le impostazioni del campo alfa.

  • Utilizza il pulsante ID oggetto per creare una relazione con altri oggetti del layout di stampa. Questo viene utilizzato con il server QGIS e altri potenziali client web. Puoi impostare un ID su un oggetto (ad esempio, una mappa o un’etichetta), e poi il client web può inviare dati per impostare una proprietà (ad esempio, il testo dell’etichetta) per quell’oggetto specifico. Il comando GetProjectSettings elenca gli oggetti e gli ID disponibili in un layout.

  • Visualizzazione ti aiuta ad impostare se e come l’oggetto può essere visualizzato: puoi, per esempio, applicare modo di miscelazione, regolare l’opacità dell’oggetto o Escludi oggetto dalle esportazioni.

Posizione e Dimensione

Estendendo le opzioni della finestra di dialogo New Item Properties con funzionalità definite dai dati, questo gruppo permette di posizionare gli oggetti con precisione.

../../../../_images/position_size.png

Finestra di dialogo Proprietà nuovo oggetto

  • il numero specifico della pagina su cui posizionare l’oggetto;

  • il punto di riferimento dell’oggetto;

  • le coordinate X e Y del Punto di riferimento dell’oggetto nella pagina scelta. Il rapporto tra questi valori può essere bloccato cliccando sul pulsante lockedGray. Le modifiche apportate a un valore utilizzando il widget o lo strumento select Seziona/Sposta oggetto si rifletteranno in entrambi;

  • il Larghezza e Altezza del perimetro di delimitazione dell’oggetto. Per quanto riguarda le coordinate, il rapporto tra larghezza e altezza può essere bloccato.

Visualizzazione

QGIS permette di effettuare visualizzazioni avanzate per gli oggetti del layout, proprio come per i layer vettoriali e raster.

../../../../_images/rendering_mode.png

Visualizzazione

  • Modalità fusione: con questo strumento puoi ottenere effetti che altrimenti sarebbero possibili solo usando software specializzati per la manipolazione grafica. I pixel degli elementi di sovrapposizione e di sottofondo possono essere mescolati in base alla modalità impostata (vedi Metodi di fusione per la descrizione di ciascun effetto).

  • Trasparenza slider: Con questo strumento Puoi rendere visibile l’oggetto sottostante nel layout. Usa il cursore per adattare la visibilità del tuo oggetto alle tue esigenze. Puoi anche definire con precisione la percentuale di visibilità nel menu accanto al cursore.

  • checkbox Escludi oggetto dalle esportazioni: puoi decidere di rendere invisibile un oggetto in tutte le esportazioni. Dopo aver attivato questa casella di controllo, l’oggetto non sarà incluso nell’esportazione in PDF, stampa ecc.

Variabili

Variabili elenca tutte le variabili disponibili a livello di layout (che include tutte le variabili globali, di progetto e di composizione). Gli oggetti mappa mappa includono anche le variabili delle impostazioni della mappa che forniscono un facile accesso a valori come la scala della mappa, l’estensione e così via.

In Variabili, è anche possibile gestire variabili a livello di oggetto. Fai click sul pulsante signPlus per aggiungere una nuova variabile personalizzata. Allo stesso modo, seleziona qualsiasi variabile a livello di elemento personalizzato dall’elenco e fai click sul pulsante signMinus per rimuoverlo.

Maggiori informazioni sull’utilizzo delle variabili nella sezione Memorizzazione valori nelle Variabili.