Outdated version of the documentation. Find the latest one here.

.

QGIS Configuration

QGIS is highly configurable through the Settings menu. Choose between Panels, Toolbars, Project Properties, Options and Customization.

Bemerkung

QGIS follows desktop guidelines for the location of options and project properties item. Consequently related to the OS you are using, location of some of items described above could be located in the View menu (Panels and Toolbars) or in Project for Options.

Panels and Toolbars

In the Panels‣ menu, you can switch on and off QGIS widgets. The Toolbars‣ menu provides the possibility to switch on and off icon groups in the QGIS toolbar (see figure_panels_toolbars).

Figure Panels and Toolbars:

../../../_images/panels_and_toolbars.png

The Panels and Toolbars menu nix

Tipp

Activating the QGIS Overview

In QGIS, you can use an overview panel that provides a full extent view of layers added to it. It can be selected under the menu nix Settings ‣ Panels or win View ‣ Panels. Within the view is a rectangle showing the current map extent. This allows you to quickly determine which area of the map you are currently viewing. Note that labels are not rendered to the map overview even if the layers in the map overview have been set up for labeling. If you click and drag the red rectangle in the overview that shows your current extent, the main map view will update accordingly.

Tipp

Show Log Messages

It’s possible to track the QGIS messages. You can activate checkbox Log Messages in the menu nix Settings ‣ Panels or win View ‣ Panels and follow the messages that appear in the different tabs during loading and operation.

Projekteigenschaften

In the properties window for the project under nix Settings ‣ Project Properties (kde) or nix win Project ‣ Project Properties (Gnome), you can set project-specific options. These include:

  • In the General menu, the project title, selection and background color, layer units, precision, and the option to save relative paths to layers can be defined. If the CRS transformation is on, you can choose an ellipsoid for distance calculations. You can define the canvas units (only used when CRS transformation is disabled) and the precision of decimal places to use. You can also define a project scale list, which overrides the global predefined scales.
  • Im KBS Menü können Sie das Koordinatenbezugssystem für dieses Projekt auswählen und Spontan-Reprojektion für das Darstellen von Vektor- und Rasterlayern mit verschiedenen KBS einschalten.

  • With the third Identify layers menu, you set (or disable) which layers will respond to the identify tool (see the “Map tools” paragraph from the Optionen section to enable identifying of multiple layers).
  • The Default Styles menu lets you control how new layers will be drawn when they do not have an existing .qml style defined. You can also set the default transparency level for new layers and whether symbols should have random colours assigned to them. There is also an additional section where you can define specific colors for the running project. You can find the added colors in the drop down menu of the color dialog window present in each renderer.
  • The tab OWS Server allows you to define information about the QGIS Server WMS and WFS capabilities, extent and CRS restrictions.
  • Das Menü Macros wird verwendet um Python-Makros für Projekte zu bearbeiten. Zur Zeit sind nur drei Makros möglich:openProject(), saveProject() und closeProject().

Figure Macro Menu:

../../../_images/macro.png

Macro settings in QGIS

  • Das Menü Beziehungen wird verwendet um 1:n-Beziehungen zu definieren. Die Beziehungen werden im Dialog Projekteigenschaften definiert. Sind einmal Beziehungen für einen Layer erstellt erscheint ein neues Schnittstellenelement im Objektformular (z.B. wenn Sie ein Objekt abfragen und sein Formular öffnen) das die damit verknüpften Elemente auflistet. Dies ist eine leistungsfähige Methode um z.B. die Inspektionsgeschichte eines Pipelineabschnittes oder Straßenabsschnittes auszudrücken. Sie können mehr über die Unterstützung von 1:n Beziehungen im Abschnitt Creating one to many relations finden.

Optionen

mActionOptions Some basic options for QGIS can be selected using the Options dialog. Select the menu option Settings ‣ mActionOptions Options. The tabs where you can customize your options are described below.

Menü Allgemein

Anwendung

  • Select the Style (QGIS restart required) selectstring and choose between ‘Oxygen’,’Windows’,’Motif’,’CDE’, ‘Plastique’ and ‘Cleanlooks’ (nix).
  • Define the Icon theme selectstring. Currently only ‘default’ is possible.
  • Define the Icon size selectstring.
  • Define the Font. Choose between radiobuttonon Qt default and a user-defined font.
  • Change the Timeout for timed messages or dialogs selectstring.
  • checkbox Splashscreen beim Start nicht anzeigen

  • checkbox Tipps beim Starten anzeigen

  • checkbox Gruppenrahmentitel fett

  • checkbox Gruppenrahmen im QGIS-Stil

  • checkbox Use native color chooser dialogs
  • checkbox Use live-updating color chooser dialogs
  • checkbox Custom side bar style
  • checkbox Experimental canvas rotation support (restart required)

Projektdateien

  • Open project on launch selectstring (choose between ‘New’, ‘Most recent’ and ‘Specific’). When choosing ‘Specific’ use the browsebutton to define a project.
  • checkbox Neues Projekt aus Vorgabeprojekt erstellen. Sie haben die Möglichkeit auf Aktuelles Projekt als Vorgabe speichern oder Vorgabe zurücksetzen zu drücken. Sie können durch Ihre Dateien gehen und ein Verzeichnis definieren in dem Sie ihre benutzerdefinierten Projektvorlagen festlegen. Diese werden dann dem Menü Projekt ‣ Neu aus Vorlage hinzugefügt wenn Sie erst checkbox Neues Projekt aus Vorgabeprojekt erstellen aktivieren und dann ein Projekt in den Projektvorlagenordner speichern.

  • checkbox Bei Bedarf nachfragen, ob geänderte Projekt und Datenquellen gespeichert werden sollen

  • checkbox Prompt for confirmation when a layer is to be removed
  • checkbox Warnung ausgeben wenn QGIS-Projekt einer früheren Version geöffnet wird

  • Enable macros selectstring. This option was created to handle macros that are written to perform an action on project events. You can choose between ‘Never’, ‘Ask’, ‘For this session only’ and ‘Always (not recommended)’.

Menü System

Umgebung

Systemumgebungsvariablen können nun eingesehen werden und viele von ihnen konfiguriert in der Umgebung Gruppe (siehe figure_environment_variables). Dies ist für Betriebssysteme wie Mac nützlich da dort eine GUI Anwendung nicht notwendigerweise die Shellumgebung des Benutzers übernimmt. Sie ist auch nützlich um Umgebungsvariablen für externe Werkzeuge die von der Verarbeitungs-Toolbox (z.B. SAGA, GRASS) kontrolliert werden zu setzen und zu visualisieren und um die Debug-Ausgabe für bestimmte Abschnitte des Quellcodes anzuschalten.

  • checkbox Benutzerdefinierte Umgebungsvariablen verwenden (Neustart erforderlich - Trennzeichen einschließen). Sie können Variablen [Hinzufügen] und [Entfernen]. Bereits definierte Umgebungsvariablen sind unter Aktuelle Umgebungsvariablen dargestellt und es ist möglich sie zu filtern indem Sie checkbox Nur QGIS-spezifische Variablen anzeigen aktivieren.

Figure System Environment:

../../../_images/sys-env-options.png

System environment variables in QGIS

Erweiterungspfade

[Hinzufügen] und [Entfernen] von Nach zusätzlichen C++ Erweiterungsbibliotheken zu durchsuchende Pfad(e)

Menü Datenquellen

Objektattribute und -tabelle

  • checkbox Attributtabelle gedockt öffnen (QGIS-Neustart erforderlich)

  • checkbox Copy geometry in WKT representation from attribute table. When using mActionCopySelected Copy selected rows to clipboard from the Attribute table dialog, this has the result that the coordinates of points or vertices are also copied to the clipboard.
  • Attribute table behaviour selectstring. There are three possibilities: ‘Show all features’, ‘Show selected features’ and ‘Show features visible on map’.
  • Attribute table row cache selectnumber. This row cache makes it possible to save the last loaded N attribute rows so that working with the attribute table will be quicker. The cache will be deleted when closing the attribute table.
  • Repräsentation für NULL-Werte. Hier können Sie einen Wert für Datenfelder die einen NULL-Wert enthalten festlegen.

Datenquellenbehandlung

  • Scan for valid items in the browser dock selectstring. You can choose between ‘Check extension’ and ‘Check file contents’.
  • Scan for contents of compressed files (.zip) in browser dock selectstring. ‘No’, ‘Basic scan’ and ‘Full scan’ are possible.
  • Beim Öffnen nach Rasterunterlayern fragen. Einige Rasterformate unterstützen Unterlayer - sie werden Subdataset in GDAL genannt. Ein Beispiel sind netCDF-Dateien - wenn es viele netCDF-Variablen gibt interpretiert GDAL jede Variable als Subdataset. Die Option ermöglicht es Ihnen zu steuern wie mit Unterlayern umgegangen wird wenn eine Datei mit Unterlayern geöffnet wird. Sie haben die folgenden Wahlmöglichkeiten:

    • ‘Immer’: Immer fragen (ob es Unterlayer gibt)

    • ‘Wenn nötig’: Fragen ob Layer keine Bänder aber Unterlayer hat

    • ‘Nie’: Nie fragen, lädt dann nichts

    • ‘Alle laden’: Nie auffordern aber alle Unterlayer laden

  • checkbox Ignore shapefile encoding declaration. If a shapefile has encoding information, this will be ignored by QGIS.
  • checkbox Add PostGIS layers with double click and select in extended mode
  • checkbox Oracle-Layer mit Doppelklick hinzufügen und zur Auswahl den erweiterten Modus verwenden

Menü Darstellung

Rendering behaviour

  • checkbox Normalerweise werden alle neuen Layer im Kartenfenster angezeigt

  • checkbox Wo möglich den Darstellungscache benutzen, um das Neuzeichnen zu beschleunigen

  • checkbox Layer mit vielen CPU-Kernen parallel zeichnen

  • checkbox Max. zu benutzende Kerne

  • Kartenaktualisierungsintervall

  • checkbox Enable feature simplication by default for newly added layers
  • Vereinfachungsschwelle

  • checkbox Auf Datenlieferantenebene vereinfachen, wenn möglich

  • Größter Maßstab bis zu dem der Layer vereinfacht werden soll

Zeichenqualität

  • checkbox Linie auf Kosten der Zeichengeschwindigkeit weniger gezackt zeichnen

Raster

  • Mit RGB Kanalauswahl können Sie Nummer für den Roten Kanal, Grünen Kanal und Blauen Kanal festlegen.

Kontrasverbesserung

  • Single band gray selectstring. A single band gray can have ‘No stretch’, ‘Stretch to MinMax’, ‘Stretch and Clip to MinMax’ and also ‘Clip to MinMax’.
  • Multi band color (byte/band) selectstring. Options are ‘No stretch’, ‘Stretch to MinMax’, ‘Stretch and Clip to MinMax’ and ‘Clip to MinMax’.
  • Multi band color (>byte/band) selectstring. Options are ‘No stretch’, ‘Stretch to MinMax’, ‘Stretch and Clip to MinMax’ and ‘Clip to MinMax’.
  • Limits (minimum/maximum) selectstring. Options are ‘Cumulative pixel count cut’, ‘Minimum/Maximum’, ‘Mean +/- standard deviation’.
  • Kommulative Pixelanzahl-Schnittgrenzen

  • Standardabweichungsfaktor

Fehlersuche

  • checkbox Kartenaktualisierung

Menü Farben

This menu allows you to add some custom color that you can find in each color dialog window of the renderers. You will see a set of predefined colors in the tab: you can delete or edit all of them. Moreover you can add the color you want and perform some copy and paste operations. Finally you can export the color set as a gpl file or import them.

Menü Karte und Legende

Voreingestelltes Kartenaussehen (Projekteigenschaften überschreiben)

  • Definieren Sie eine Farbe für Auswahlen und eine Hintergrundfarbe

Layerlegende

  • Double click action in legend selectstring. You can either ‘Open layer properties’ or ‘Open attribute table’ with the double click.
  • Die folgenden Legendenelementstile sind möglich:

    • checkbox Layernamen groß schreiben

    • checkbox Layernamen fett

    • checkbox Gruppennamen fett

    • checkbox Klassifikationsattributnamen anzeigen

    • checkbox Rastericons erzeugen (kann langsam sein)

Menü Kartenwerkzeuge

This menu offers some options regarding the behaviour of the Identify tool.

  • Suchradius für die Objektidentifikation und zur Maptipanzeige ist ein Toleranzfaktor ausgedrückt als Prozentsatz der Kartenbreite. Das heißt dass das Objekte abfragen Werkzeug so lange Ergebnisse anzeigt wie sie innerhalb dieser Toleranz klicken.

  • Mit Hervorhebungsfarbe können Sie wählen mit welcher Farbe abgefragte Objekte hervorgehoben werden solllen.

  • Buffer expressed as a percentage of the map width, determines a buffer distance to be rendered from the outline of the identify highlight.
  • Minimum width expressed as a percentage of the map width, determines how thick should the outline of a highlighted object be.

Messwerkzeug

  • Definieren Sie Gummibandfarbe für das Meßwerkzeug

  • Definieren Sie Dezimalstellen

  • checkbox Keep base unit
  • Preferred measurements units radiobuttonon (‘Meters’, ‘Feet’, ‘Nautical Miles’ or ‘Degrees’)`
  • Preferred angle units radiobuttonon (‘Degrees’, ‘Radians’ or ‘Gon’)

Verschieben und Zoomen

  • Define Mouse wheel action selectstring (‘Zoom’, ‘Zoom and recenter’, ‘Zoom to mouse cursor’, ‘Nothing’)
  • Definieren Sie Zoomfaktor für das Mausrad

Vordefinierte Maßstäbe

Here, you find a list of predefined scales. With the [+] and [-] buttons you can add or remove your individual scales.

Menü Zusammenstellung

Zusammenstellungsvoreinstellungen

You can define the Default font here.

Gitterdarstellung

  • Define the Grid style selectstring (‘Solid’, ‘Dots’, ‘Crosses’)
  • Define the Grid color

Grid and guide defaults

  • Define the Grid spacing selectnumber
  • Define the Grid offset selectnumber for x and y
  • Define the Snap tolerance selectnumber

Menü Kartenwerkzeuge

Objekterzeugung

  • checkbox Eingabe der Attributwerte bei der Erstellung neuer Objekte unterdrücken

  • checkbox Letzte Attributwerteingaben wiederverwenden

  • Validate geometries. Editing complex lines and polygons with many nodes can result in very slow rendering. This is because the default validation procedures in QGIS can take a lot of time. To speed up rendering, it is possible to select GEOS geometry validation (starting from GEOS 3.3) or to switch it off. GEOS geometry validation is much faster, but the disadvantage is that only the first geometry problem will be reported.

Gummiband

  • Definieren Sie für das Gummiband die Linienbreite und Linienfarbe

Objektfang

  • checkbox Fangoptionsdialog in einem Dockfenster anzeigen (QGIS-Neustart erforderlich)

  • Define Default snap mode selectstring (‘To vertex’, ‘To segment’, ‘To vertex and segment’, ‘Off’)
  • Definieren Sie die Voreingestellte Fangtoleranz in Karteneinheiten oder Pixeln

  • Definieren Sie den Suchradius für die Stützpunktbearbeitung in Karteneinheiten oder Pixeln.

Stützpunktmarken

  • checkbox Markierungen nur für gewählte Objekte anzeigen

  • Define vertex Marker style selectstring (‘Cross’ (default), ‘Semi transparent circle’ or ‘None’)
  • Definieren Sie die Markierungsgröße für die Stützpunktmarken

Werkzeug zum Linien versetzen

The next 3 options refer to the mActionOffsetCurve Offset Curve tool in Erweiterte Digitalisierung. Through the various settings, it is possible to influence the shape of the line offset. These options are possible starting from GEOS 3.3.

  • Verbindungsstil

  • Quadrantensegmente

  • Eckengrenze

Menü GDAL

GDAL ist eine Datenaustauschbibliothek für Rasterdateien. In diesem Menü können Sie Erzeugungsoptionen bearbeiten und Pyramidenoptionen bearbeiten . Definieren Sie welcher GDAL-Treiber für ein Rasterformat benutzt wird, da in einigen Fällen mehr als ein Treiber zur Verfügung gestellt wird.

Menü KBS

Vorgabe-KBS für neue Projekte

  • radiobuttonoff Don’t enable ‘on the fly’ reprojection
  • radiobuttonon Automatically enable ‘on the fly’ reprojection if layers have different CRS
  • radiobuttonoff Enable ‘on the fly’ reprojection by default
  • Wählen Sie ein KBS aus und Neue Projekte immer in diesem KBS beginnen

KBS für neue Layer

Der zweite Bereich ermöglicht es, Voreinstellungen vorzunehmen, wenn ein neuer Layer erzeugt wird oder ein Layer geladen wird, der keine KBS Information besitzt.

  • radiobuttonon Prompt for CRS
  • radiobuttonoff Use project CRS
  • radiobuttonoff Use default CRS

Datumtransformationsvorgaben

  • checkbox Datumtransformation erfragen wenn keine Vorgabe definiert ist

  • Wenn Sie mit der ‘Spontan’ KBS Transformation gearbeitet haben können sie das Ergebnis der Transformation im Fenster unten sehen. Sie können Informationen über das ‘Quell-KBS’ und das ‘Ziel-KBS’ genauso wie über ‘Quell-Datumstransformation’ und ‘Ziel-Datumstransformation’ finden.

Menü Sprache

  • checkbox System-Locale überschreiben und Stattdessen folgende Spracheinstellungen benutzen

  • Informationen über die aktive System-Locale

Menü Netzwerk

Allgemein

  • WMS Suchadresse - Standard ist http://geopole.org/wms/search?search=%1&type=rss

  • Definieren Sie Zeitüberschreitung für Netzwerkanfragen (ms) - Standard ist 60000

  • Definieren Sie Verfallszeitraumvorgabe für WMS-C/WMTS Kacheln (Stunden) - Standard ist 24

  • Legen Sie Maximale Wiederholungen bei Kachelabfragefehlern fest.

  • Definieren Sie User-Agent

Figure Network Tab:

../../../_images/proxy-settings.png

Proxy-settings in QGIS

Cache-Einstellungen

Definieren Sie das Verzeichnis und eine Größe für den Cache.

  • checkbox Proxy für Web-Zugriff benutzen und entsprechend ‘Host’, ‘Port’, ‘Benutzer’ und ‘Passwort’ definieren.

  • Set the Proxy type selectstring according to your needs.
    • DefaultProxy ‣: Proxy wird auf Grundlage des Proxy der Anwendung festgelegt

    • Socks5Proxy ‣: Proxy für jede Art von Verbindung. Unterstützt TCP, UDP, Bindung an einen Port (eingehende Verbindungen) und Authentifizierung.

    • HttpProxy ‣: Umgesetzt mit dem “CONNECT”-Befehl, unterstützt nur ausgehende TCP-Verbindungen und Authentifizierung.

    • HttpCachingProxy:Umgesetzt mit normalen HTTP Befehlen ist dies nur im Zusammenhang mit HTTP Befehlen sinnvoll einzusetzen.

    • FtpCachingProxy: Mit einem FTP-Proxy umgesetzt ist dies nur sinnvoll im Zusammenhang mit FTP-Anforderungen anzuwenden

Das Ausschließen von URLs kann in das Textfenster unter den Proxyeinstellungen eingetragen werden (siehe Figure_Network_Tab).

Wenn Sie weitere Informationen über die verschiedenen Proxyeinstellungen benötigen, schauen Sie bitte im Handbuch der QT-Bibliothek nach unter der http://doc.trolltech.com/4.5/qnetworkproxy.html#ProxyType-enum.

Tipp

Proxy richtig anwenden

Das Verwenden von Proxys kann manchmal schwierig sein. Es ist sinnvoll die oben angesprochenen Proxytypen auszuprobieren, um zu sehen, welcher in dem jeweiligen Fall am besten funktioniert.

You can modify the options according to your needs. Some of the changes may require a restart of QGIS before they will be effective.

  • nix Einstellungen sind gespeichert in einer Textdatei: $HOME/.config/QGIS/QGIS2.conf

  • osx Alle Einstellungen sind gespeichert in: $HOME/Library/Preferences/org.qgis.qgis.plist

  • win Einstellungen sind gespeichert in der Registry unter: HKEYCURRENT_USERSoftwareQGISqgis

Anpassung

The customization tool lets you (de)activate almost every element in the QGIS user interface. This can be very useful if you have a lot of plugins installed that you never use and that are filling your screen.

Figure Customization 1:

../../../_images/customization.png

The Customization dialog nix

QGIS Customization is divided into five groups. In checkbox Menus, you can hide entries in the Menu bar. In checkbox Panels, you find the panel windows. Panel windows are applications that can be started and used as a floating, top-level window or embedded to the QGIS main window as a docked widget (see also Panels and Toolbars). In the checkbox Status Bar, features like the coordinate information can be deactivated. In checkbox Toolbars, you can (de)activate the toolbar icons of QGIS, and in checkbox Widgets, you can (de)activate dialogs as well as their buttons.

With mActionSelect Switch to catching widgets in main application, you can click on elements in QGIS that you want to be hidden and find the corresponding entry in Customization (see figure_customization). You can also save your various setups for different use cases as well. Before your changes are applied, you need to restart QGIS.