Outdated version of the documentation. Find the latest one here.

.

Configuración QGIS

QGIS es altamente configurable a través del menú Configuración. Elegir entre Paneles, Barras de herramientas, Propiedades del proyecto, Opciones y Personalización.

Paneles y Barras de Herramientas

En el menú Paneles‣, puede encender o apagar los widgets de QGIS. El menú Barra de herramientas‣ proporciona la posibilidad para encender y apagar grupos de iconos en la barra de herramientas (ver figure_panels_toolbars).

Figure Panels and Toolbars:

../../../_images/panels_and_toolbars.png

El menú de paneles y barras de herramientas nix

Truco

Activar la información general de QGIS

En QGIS, puede usar un panel de vista general que proporciona una vista completa de las capas añadidas. Se puede seleccionar en el menú nix Configuración ‣ Paneles o win Ver ‣ Paneles. Dentro de la vista un rectangulo mostrará la vista del mapa actual. Esto le permite determinar rápidamente que área del mapa se ve actualmente. Tenga en cuenta que las etiquetas no son representadas en la vista general del mapa incluso si las capas en la vista general del mapa se ha establecido el etiquetado. Al hacer clic y arrastrar el rectángulo rojo en la vista general se muestra la extensión actual, la vista principal del mapa se actualizará en consecuencia.

Truco

Mostrar el registro de mensajes

Es posible seguir los mensajes de QGIS. Puede activar checkbox Registro de mensajes en el menú nix Configuración‣ Paneles o win Ver ‣ Paneles y seguir los mensajes que aparecen en las diferentes pestañas durante la carga y funcionamiento.

Propiedades del proyecto

In the properties window for the project under nix Settings ‣ Project Properties or win Project ‣ Project Properties, you can set project-specific options. These include:

  • En le menú General, el título del proyecto, color de selección y fondo, unidades de la capa, la precisión y la opción de guardar rutas relativas a las capas se pueden definir. Si la trasformación SRC esta activada, se puede elegir un elipsoide para cálculos de distancia. Se pueden definir las unidades del lienzo(sólo se utiliza cuando la transformación SRC está desactivada) y la precisión de decimales se utiliza. También puede definir una lista de la escala del proyecto, que anula las escalas predefinidas globales.

  • El menú SRC habilitado para elegir el Sistema de Referencia de Coordenadas para este proyecto, y para habilitar la reproyección al vuelo de capas ráster y vector cuando se muestran capas de un diferente SRC.

  • Con el tercer menú Identificar capas, se establece (o deshabilitar) las capas que responderán a la herramienta de identificar objetos espaciales (ver el párrafo de “Herramientas del mapa” de la sección Opciones para permitir la identificación de múltiples capas)

  • The Default Styles menu lets you control how new layers will be drawn when they do not have an existing .qml style defined. You can also set the default transparency level for new layers and whether symbols should have random colours assigned to them.
  • La pestaña de Servidor OWS le permite definir información acerca del QGIS servidor WMS y capacidades WFS, extensión y restricciones SRC.

  • El menú Macros es utilizado para editar macros de Python para proyectos. Actualmente, solo tres macros están disponibles: openProject(), saveProject() and closeProject().

Figure Macro Menu:

../../../_images/macro.png

Ajustes de la Macro en QGIS

  • El menú Relaciones es utilizado para definir relaciones 1:n. Las relaciones están definidas en el diálogo de propiedades del proyecto. Una vez que existen las relaciones de una capa, un nuevo elemento de la interfaz de usuario en la vista del formulario (por ejemplo al identificar un elemento espacial y abrir el formulario) mostrará una lista de las entidades relacionadas. Este proporciona un poderosa forma para expresar, por ejemplo la inspección de la longitud de una tubería o el segmento de carretera. Se puede encontrar más información acerca de relaciones 1:n y soporte en la sección Creating one to many relations.

Opciones

mActionOptions Algunas opciones básicas de QGIS se pueden seleccionar utilizando el diálogo Opciones. Seleccione la opción del menú Configuración ‣ mActionOptions Opciones. Las pestañas donde puede personalizar las opciones están descritas a continuación.

Menú General

Aplicación

  • Seleccione el Estilo (QGIS requiere reiniciar) selectstring y elija entre ‘Oxygen’,’Windows’,’Motif’,’CDE’, ‘Plastique’ and ‘Cleanlooks’ (nix).

  • Definir el Tema de icono selectstring. Actualmente solo ‘predeterminado’ es posible.

  • Definir el Tamaño del icono selectstring.

  • Definir la Fuente. Elegir entre radiobuttonon Qt default y una fuente definida por el usuario.

  • Cambiar el Límite de tiempo para mensajes o diálogos con tiempo selectstring.

  • checkbox Ocultar la pantalla de bienvenida al iniciar la aplicación

  • checkbox Mostrar consejos al iniciar

  • checkbox Títulos de cajas de grupos en negrita

  • checkbox Cajas de grupo al estilo QGIS

  • checkbox Usar diálogos de selección de color actualizados en vivo

Los archivos de proyecto

  • Abrir proyecto on launch selectstring (elegir entre ‘Nuevo’, Más reciente’ y ‘Específico’). Al elegir ‘Específico’ utilice el browsebutton para definir un proyecto.

  • checkbox Crear nuevo proyecto desde el proyecto predeterminado. Tiene la posibilidad de presionar Establecer el actual proyecto como predeterminado o sobre Restablecer el predeterminado. Puede navegar a través de sus archivos y definir un directorio donde se encuentra las plantillas definidas por el usuario. Esto se añadirá a Proyecto ‣ Nueva plantilla de formulario. Si activa primero checkbox Crear nuevo proyecto desde proyecto predeterminado y entonces guarde un proyecto en l la carpeta de las plantillas de proyecto.

  • checkbox Solicitar guardar proyectos y fuentes de datos modificadas cuando sea necesario

  • checkbox Avisar cuando se abra un proyecto guardado con una versión anterior de QGIS

  • Habilitar macros selectstring. Esta opción fue creada para manejar macros que estén escritos para llevar una acción en los eventos del proyecto. Puede elegir entre ‘Nunca’, ‘Preguntar’, ‘Sólo para esta sesión’ y ‘Siempre (no recomendado)’.

Menú Sistema

Entorno

Variables de entorno del sistema ahora se puede ver, y muchos lo configuran en el grupo Entorno (ver figure_environment_variables). Esto es útil para las plataformas, como Mac, donde una aplicación GUI no heredan necesariamente entorno del casco del usuario. También es útil para configurar y visualizar las variables de entorno para los conjuntos de herramientas externas controladas por la caja de herramientas de procesamiento (por ejemplo, SAGA, GRASS), y para activar la salida de depuración para secciones específicas del código fuente.

  • checkbox Utilizar variables personalizadas (requiere reiniciar - incluir separadores). Puede [Añadir] y [Borrar] variables. Las variables de entorno ya definidas se muestran en Variables de entorno actuales, y es posible filtrarlos activando checkbox Mostrar sólo variables de QGIS específicas.

Figure System Environment:

../../../_images/sys-env-options.png

Variables de entorno del sistema en QGIS

Rutas de complemento

[Añadir] o [Borrar] Ruta(s) para buscar librerías de componentes en C++ adicionales

Menú Fuente de datos

Atributos de entidades espaciales y tabla

  • checkbox Abrir tabla de atributos en la ventana adosada (requiere reiniciar QGIS)

  • checkbox Copiar geometría en WKT representación de la tabla de atributos. Al utilizar mActionCopySelected :sup:` Copiar las filas seleccionadas al portapapeles` desde el diálogo Tabla de atributos, este tiene el resultado que las coordenadas de los puntos o vértices también se copian en el portapapeles.

  • Funcionamiento de la tabla de atributos selectstring. Hay tres posibilidades: ‘Mostrar todos los objetos espaciales’, ‘Mostrar objetos seleccionados’ y ‘Mostrar objetos espaciales visibles en el mapa’.

  • Caché de registro de tabla de atributos selectnumber. Esta fila en caché hace posible guardar la última carga de N filas de atributos de modo que el trabajo con la tabla de atributos será más rápido. El caché se borrará cuando cierre la tabla de atributos.

  • Representación de valores NULOS. Aquí, puede definir un valor para los datos de campos que tienen un valor NULO.

Manejo de fuente de datos

  • Buscar elementos válidos en el dock del explorador selectstring. Puede elegir entre ‘Comprobar extensión’ y ‘Comprobar contenido de archivo’.

  • Analizar en busca de contenido de archivos comprimidos (zip) en navegador base selectstring. ‘No’, ‘Exploración básica’ y ‘Exploración completa’ son posibles.

  • Solicitar subcapas raster al abrir. Algunas subcapas raster soportadas — se les llama subdataset en GDAL. Un ejemplo son los archivos netCDF — si hay muchos variables netCDF, GDAL ve cada variable como un subconjunto de datos. La opción le permite controlar cómo lidiar con subcapas cuando se abre un archivo con subcapas. Dispone de las siguientes opciones:

    • ‘Siempre’: Siempre preguntar (Si hay subcapas existentes)

    • ‘Si es necesario’: Preguntar si la capa no tiene bandas, pero tiene subcapas

    • ‘Nunca’: Nunca preguntar, no se cargará nada

    • ‘Cargar todo’: Nunca preguntar, pero cargar todas las subcapas

  • checkbox Ignorar la declaración de codificación del archivo shape. Si el archivo shape tiene información de codificación, Este será ignorado por QGIS.

  • checkbox Añadir capas PostGIS con doble clic y seleccionar en modo extendido

  • checkbox Añadir capas de Oracle con doble clic y seleccionar en modo extendido

Menú representación

Comportamiento de presentación

  • checkbox Por defecto las nuevas capas añadidas al mapa se deben mostrar

  • checkbox Enable back buffer
  • checkbox Utilizar el cacheo de presentación en lo posible a la velocidad de regeneración

  • checkbox Habilitar simplificación de objetos espaciales por defecto a las nuevas capas añadidas

  • checkbox Simplifique el lado del proveedor si es posible

Calidad de representación

  • checkbox Hacer que las líneas se muestren menos quebradas a expensas del rendimiento de la representación

  • checkbox Fix problems with incorrectly filled polygons

Rásters

  • Con Selección de la banda RGB, puede definir el numero para la banda Roja, Verde y Azul.

Contrast enhancement

  • Unibanda gris selectstring. Una sola banda de gris puede tener ‘Sin realce’, ‘Estirar a MinMax’, ‘Estirar y cortar a MinMax’ y también ‘Cortar a MinMax’.

  • Color de multibanda (byte/band) selectstring. Las opciones son ‘Sin realce’, ‘Estirar a MinMax’, ‘Estirar y cortar a MinMax’ y ‘Cortar a MinMax’.

  • Color de multibanda (>byte/band) selectstring. Las opciones son ‘No realce’, ‘Estirar a MinMax’, ‘Estirar y cortar a MinMax’ y ‘Cortar a MinMax’.

  • Límites (mínimo/máximo) selectstring. Las opciones son ‘Corte del conteo acumulativo’, ‘Min/Máx’, ‘Media +/- desviación estándar’.

  • Límite para corte del conteo acumulativo de píxeles

  • Multiplicador de la desviación estándar

Depuración

  • checkbox Refrescar lienzo de mapa

Menú Vista del mapa y leyenda

Apariencia del mapa predeterminado (anulado por las propiedades del proyecto)

  • Definir un Color de selección y un Color de fondo.

Leyenda de capa

  • Acción doble clic en la leyenda selectstring. Puede ‘Abrir las propiedades de la capa’ o ‘Abrir la tabla de atributos’ con el doble clic.

  • Lo siguiente es posible Estilos de elementos de la leyenda:

    • checkbox Comenzar el nombre de las capas con mayúsculas

    • checkbox Poner en negrita los nombres de la capa

    • checkbox Poner en negrita los nombres de grupo

    • checkbox Mostrar nombres de atributos de clasificación

    • checkbox Crear iconos de ráster (puede ser lento)

    • checkbox Añadir nuevas capas al grupo seleccionado o al actual

Menú Herramientas de mapa

Identify

  • checkbox Open identify results in a dock window (QGIS restart required)
  • The Mode setting determines which layers will be shown by the Identify tool. By switching to ‘Top down’ or ‘Top down, stop at first’ instead of ‘Current layer’, attributes for all identifiable layers will be shown with the Identify tool. In QGIS 2.2. you can now use a ‘Layer selection’ option so that you can choose with the left-mouse menu which layer you want to identify (see the “Project properties” section under Proyectos to set which layers are identifiable).
  • checkbox Open feature form, if a single feature is identified
  • Define Search radius for identifying and displaying map tips as a percentage of the map width

Herramienta de medición

  • Definir Color de la banda de medida para herramienta de medida

  • Definir Lugares decimales

  • Mantener unidad base

  • Unidades de medida preferidas radiobuttonon (‘Metros’, ‘Pies’, ‘Millas náuticas’ o ‘Grados’)`

  • Unidades de ángulos preferidas radiobuttonon (‘Grados’, ‘Radianes’ o ‘Grados centecimales’)

Mover y zum

  • Definir Acción de la rueda del ratón selectstring (‘Zum’, ‘Zum y centrar’, ‘Zoom al cursor del ratón’, ‘Nada’)

  • Definir Factor de zum para la rueda del ratón

Escalas predefinidas

Aquí, encontrará una liste de escalas predefinidas. Con los botones [+] y [-] puede añadir o eliminar las escalas individuales.

Menú Diseñador

Predeterminados de la composición

Puede definir la fuente Predeterminado aquí.

Apariencia de la cuadrícula

  • Definir el Estilo de cuadrícula selectstring (‘Sólido, ‘Puntos’, ‘Cruces’)

  • Definir el Color...

Cuadrícula predeterminada

  • Definir la Separación selectnumber

  • Definir el Desplazamiento de cuadrícula selectnumber para x y y

  • Definir la Tolerancia de Ajuste selectnumber

Guía predeterminada

  • Definir la Tolerancia de Ajuste selectnumber

Menú Digitalización

Creación de entidades espaciales

  • checkbox Suprimir formulario emergente de atributos después de crear objetos espaciales

  • checkbox Reutilizar últimos valores de atributos introducidos

  • Validar geometrías. Editar lineas y polígonos complejos con muchos nodos puede resultar a una representación muy lenta. Esto se debe a los procesos de validación por defecto en QGIS puede tomar mucho tiempo. Para acelerar la representación, es posible seleccionar la validación de geometría GEOS (a partir de GEOS 3.3) o a pagarlo. La validación de geometría GEOS es mucho más rápido, pero la desventaja es que sólo el primer problema de geometría será reportado.

Banda de medición

  • Definir banda elástica Ancho de línea y Color de línea

Autoensamblado

  • checkbox Abrir opciones de autoensamblado en una ventana adosada(requiere reiniciar QGIS)

  • Definir Modo de autoensamblado por omisión selectstring (‘A vértice’, ‘A segmento’, ‘A vértice y segmento’, ‘Desconectado’)

  • Definir Tolerancia de autoensamblado predeterminado en unidades de mapa o píxeles

  • Definir el Radio de búsqueda para edición de vértices en unidades de mapa o píxeles

Marcar vértices

  • checkbox Mostrar marcadores sólo para los objetos espaciales seleccionados

  • Definir vértice Estilo de marcador selectstring (‘Cruz’ (predeterminado), ‘Círculo semitransparente’ o ‘Nada’)

  • Definir vértice Tamaño de marcador

Herramienta de desplazamiento de curva

Las siguientes 3 opciones se refieren a la herramienta mActionOffsetCurve Desplazar curva en Advanced digitizing. A través de las diversas configuraciones, es posible influir en la forma del desplazamiento de la línea. Estas opciones son posibles a partir de GEOS 3.3.

  • Estilo de la unión

  • Segmentos del cuadrante

  • Límite Miter

Menú GDAL

GDAL es una biblioteca de intercambio de datos para archivos ráster. Es esta pestaña, puede Editar opciones de creación y Editar opciones de pirámides de los formatos ráster. Definir que controlador GDAL se va a utilizar para un formato ráster, como en algunos casos más de un controlador está disponible.

Menú SRC

SRC predeterminado para nuevos proyectos

  • radiobuttonoff No habilitar la reproyección ‘al vuelo’

  • radiobuttonon Habilitar automáticamente la reproyección al vuelo si las capas tienen un SRC diferente

  • radiobuttonoff Activar reproyección al vuelo por defecto

  • Seleccionar un SRC y Empezar siempre nuevos proyectos con este SRC

SRC para nuevas capas

Esta área permite definir la acción a realizar cuando una nueva capa es creada, o cuando una capa sin SRC es cargada.

  • radiobuttonon Solicitar SRC

  • radiobuttonoff Usar SRC del proyecto

  • radiobuttonoff Usar SRC por omisión mostrado abajo

Por defecto transformación de datum

  • checkbox Preguntar por la trasformación del datum cuando el predeterminado no este definido

  • Si ha trabajado con la trasformación de SRC ‘al vuelo’ puede ver el resultado de la transformación en la ventana de abajo. Puede encontrar información acerca de ‘Origen SRC’ y ‘Destino SRC’ así como también ‘Transformación de datum de origen’ y ‘Trasformación de datum destino’.

Menú Idioma

  • checkbox Ignorar el idioma del sistema y Idioma a usar en su lugar

  • Información acerca del idioma del sistema

Menú Red

General

  • Definir Dirección de búsqueda de WMS, por omisión es http://geopole.org/wms/search?search=\%1\&type=rss

  • Definir Expiró el tiempo para solicitudes de red - por omisión 60000

  • Definir Periodo de expiración predeterminada para teselas WMS-C/WMTS (en horas) - por omisión 24

  • Definir Reintentar al máximo en caso de errores en la solicitud de tile

  • Definir Agente- Usuario

Figure Network Tab:

../../../_images/proxy-settings.png

Configurar proxy en QGIS

Configuración de caché

Definir la configuración del caché Directorio y un Tamaño.

  • checkbox Usar proxy para acceso web y definir ‘Servidor’, ‘Puerto’, ‘Usuario’, y ‘Contraseña’.

  • Establecer el Tipo de proxy selectstring de acuerdo a sus necesidades.

    • Default Proxy: Proxy se determina con base en el proxy de aplicación que establece el uso

    • Socks5Proxy: Proxy genérico para cualquier tipo de conexión. Soporta TCP, UDP, unión a un puerto (conexiones entrantes) y autenticación.

    • HttpProxy: Implementado con el comando “CONNECT”, sólo admite conexiones TCP salientes; admite la autenticación.

    • HttpCachingProxy: Implementando el uso de comandos HTTP normales, es útil sólo en el contexto de peticiones HTTP.

    • FtpCachingProxy: Implementar el uso de un proxy FTP, es útil sólo en el contexto de las peticiones FTP.

Excluir algunas URLs se puede agregar a la caja de texto debajo los valores del proxy (ver Figure_Network_Tab).

Si necesita más información detallada acerca de las diferentes configuraciones de proxy, consulte el manual de documentación de la biblioteca QT en http://doc.trolltech.com/4.5/qnetworkproxy.html#ProxyType-enum.

Truco

Utilizar proxies

El uso de proxies a veces puede ser complicado. Es útil para proceder por ‘prueba y error’ con los tipos de proxies anteriores, comprobar para ver si en su caso tiene éxito.

Puede modificar las opciones de acuerdo a sus necesidades. Alguno de los cambios puede requerir un reinicio de QGIS antes de hacerse efectivos.

  • nix Settings are saved in a text file: $HOME/.config/QGIS/qgis.conf
  • osx Puede encontrar sus ajustes en: $HOME/Library/Preferences/org.qgis.qgis.plist

  • win Los ajustes se almacenan bajo el registro: HKEY\CURRENT_USER\Software\QGIS\qgis

Personalización

Las herramientas personalizadas permite que (des)active casi todos los elementos en la interfaz de usuario de QGIS. Esto puede ser muy útil si se tienen muchos complementos instalados que nunca se utilizan y que esta llenando su pantalla.

Figure Customization 1:

../../../_images/customization.png

El diálogo de Personalización nix

La personalización de QGIS se divide en cinco grupos. En los checkbox Menús, puede ocultar las entradas en la barra de menú. En checkbox Panel, encontrar el panel de ventanas. Ventanas del panel son aplicaciones que se pueden iniciar y usar como una ventana flotante, de nivel superior o incrustados a la ventana principal de QGIS como se acopló el widget (ver también Paneles y Barras de Herramientas). En el checkbox Barra de Estado, las funciones como la información de coordenadas se puede desactivar. En checkbox Barra de Herramientas, puede (des)activar los iconos de la barra de QGIS, y en checkbox Widgets, puede (des)activar diálogos, así como sus botones.

Con mActionSelect Cambiar a la captura de widgets en la aplicación principal, puede hacer clic en los elementos en QGIS que desee que se oculte y busque las entradas correspondientes en la personalización (ver figure_customization). También puede guardar sus diferentes configuraciones para diferentes casos de uso. Antes de aplicar los cambios es necesario reiniciar QGIS.