Outdated version of the documentation. Find the latest one here.

QGIS GUI

All’avvio di QGIS la GUI si presenta come mostrato di sotto (i numeri da 1 a 5 cerchiati di giallo si riferiscono alle 5 aree principali dell’interfaccia come verrà in seguito discusso):

Figure QGIS GUI 1:

../../../_images/startup.png

QGIS GUI con i dati campione Alaska nix

Nota

L’aspetto delle finestre (barra del titolo, ecc.) può apparire diverso a seconda del sistema operativo e del gestore di finestre utilizzato.

L’interfaccia di QGIS è divisa in cinque aree:

  1. Barra dei Menu

  2. Barra degli Strumenti

  3. Legenda

  4. Vista Mappa

  5. Barra di Stato

Le cinque componenti dell’interfaccia di QGIS sono descritte con maggior dettaglio nelle sezioni seguenti. Due ulteriori sezioni descriveranno le scorciatoie da tastiera e la guida contestuale.

Barra degli Strumenti

Le barre degli strumenti forniscono accesso alla maggior parte delle medesime funzioni presenti nei menu, oltre a funzioni addizionali per interagire con la mappa. Ogni oggetto della barra degli strumenti ha un aiuto a comparsa (popup). Lasciando il cursore del mouse sopra l’icona verrà visualizzata una breve descrizione della funzione fornita da quello strumento.

Ogni barra può essere spostata secondo le preferenze personali. Inoltre ognuna di esse può essere disattivata dal menu contestuale cliccando con il tasto destro del mouse sulla barra degli strumenti (leggi Pannelli e Barre degli strumenti).

Suggerimento

Ripristinare le barre degli strumenti

Se avete accidentalmente disattivato tutte le barre strumenti, potete ripristinarle dalla voce di menu Visualizza ‣ Barre degli strumenti ‣. Se una barra degli strumenti scompare in Windows, il che sembra succedere di tanto in tanto, è necessario rimuovere \HKEY_CURRENT_USER\Software\QGIS\qgis\UI\state dal registro. Al riavvio di QGIS viene ripristinato lo stato di default e le barre degli strumenti sono nuovamente visibili.

Legenda

L’area di legenda è usata per impostare la visibilità e l’ordine di sovrapposizione dei layer. La casella di controllo in ogni legenda può essere usata per attivare/disattivare la visibilità di un layer.

Un layer può essere selezionato e trascinato in modo da modificarne la visibilità (z-ordering). Z-ordering significa che i layer in cima alla legenda coprono nella mappa quelli sottostanti.

Nota

Questo comportamento può essere disabilitato dal pannello ‘Ordine dei layer’

I layer presenti nella legenda possono essere organizzaati in gruppi. Ci sono due modi per farlo:

  1. Cliccare con il tasto destro del mouse nell’area di legenda e selezionare Aggiungi gruppo ‣, quindi assegnare un nome al gruppo e premere il tasto Invio. Ora è possibile cliccare e trascinare layer esistenti all’interno del gruppo.

  2. Selezionare alcuni layer, cliccare con il tasto destro e selezionare Gruppo selezionato. I layer selezionati saranno automaticamenti spostati in un nuovo gruppo.

Per rimuovere un layer da un gruppo è possibile cliccare e trascinare il layer al di fuori dello stesso o in alternativa cliccare con il tasto destro del mouse sul layer e selezionare Muovi fuori dal gruppo ‣. I gruppi possono essere nidificati all’interno di altri gruppi.

La casella di controllo di un gruppo può essere usata per mostrare/nascondere tutti i layer del gruppo con un singolo clic.

Il contenuto del menu contestuale varia a seconda che si faccia click col tasto destro del mouse su un layer raster o vettoriale. Per i layer vettoriali di GRASS la voce di menu mActionToggleEditing Modifica non è abilitata. Si veda la sezione Digitalizzare e modificare layer vettoriali GRASS per informazioni su come modificare layer vettoriali GRASS.

Menu contestuale per i raster

  • Zoom all’estensione del layer ‣

  • Zoom alla scala migliore (100%)

  • Stira usando l’estensione attuale

  • Aggiungi alla panoramica ‣

  • Rimuovi ‣

  • Duplica

  • Imposta il SR del layer ‣

  • Imposta SR progetto dal layer

  • Salva come ...

  • Proprietà

  • Rinomina ‣

  • Copia stile

  • Aggiungi nuovo gruppo ‣

  • Espandi tutto ‣

  • Racchiudi tutto ‣

  • Aggiorna l’ordine del disegno

Inoltre, a seconda della posizione e della selezione del layer

  • Crea un elemento al livello più alto

  • Gruppo selezionato

Menu contestuale per i vettori

  • Zoom all’estensione del layer

  • Aggiungi alla panoramica

  • Rimuovi ‣

  • Duplica

  • Imposta il SR del layer ‣

  • Imposta SR progetto dal layer

  • Apri tabella attributi

  • Modifica (non disponibile per i layer GRASS)

  • Salva come ...

  • Salva la selezione con nome...

  • Filtro

  • Mostra totale elementi

  • Proprietà

  • Rinomina ‣

  • Copia stile

  • Aggiungi nuovo gruppo ‣

  • Espandi tutto ‣

  • Racchiudi tutto ‣

  • Aggiorna l’ordine del disegno

Inoltre, a seconda della posizione e della selezione del layer

  • Crea un elemento al livello più alto

  • Gruppo selezionato

Menu contestuale per i gruppi di layer

  • Zoom al gruppo

  • Rimuovi ‣

  • Imposta il SR del gruppo

  • Rinomina ‣

  • Aggiungi nuovo gruppo ‣

  • Espandi tutto ‣

  • Racchiudi tutto ‣

  • Aggiorna l’ordine del disegno

È possibile selezionare più di un layer o gruppo allo stesso tempo tenendo premuto il tasto Ctrl e selezionando con il tasto sinistro del mouse. Tutti i layer così selezionati possono essere spostati contemporaneamente in un nuovo gruppo.

Puoi anche rimuovere più layer o gruppi contemporaneamente selezionando i diversi layer tenendo premuto il tasto Ctrl e premendo poi Ctrl+D. In questo modo tutto ciò che è stato selezionato verrà rimosso dalla lista dei layer.

Lavorare con la Legenda indipendentemente dall’ordine dei layer

Esiste un widget con cui è possibile impostare una legenda indipendentemente dall’ordine di visualizzazione. Si può attivare questa opzione dal menu Visualizza ‣ Pannelli ‣ Ordine dei layer e determinare l’ordine di visualizzazione dei layer nella vista mappa. Cosi facendo si possono ordinare i layer in base ad un determinato criterio, pur mantenendo l’ordine di visualizzazione iniziale corretto (vedi figure_layer_order). Spuntando la casella checkbox control rendering order collocata sotto l’elenco dei layer è possibile ritornare al comportamento iniziale.

Figure Layer Order:

../../../_images/layer_order.png

Lavora con una legenda indipendente dall’ordine dei layer nix

Vista Mappa

Questa è l’area in cui le mappe vengono visualizzate. La mappa visualizzata in questa finestra sarà il risultato dei layer vettoriali e/o raster che si è scelto di caricare (vedere le sezioni che seguono per ulteriori informazioni su come caricare i layer). La zona di visualizzazione della mappa può essere modificata (spostando la messa a fuoco dell’esposizione della mappa ad un’altra regione) ed è possibile effettuare operazioni di zoom in ed out. Varie altre operazioni sono descritte nella sezione relativa alla barra dei menu. La vista nell’area di mappa e la legenda sono strettamente legate l’un l’altra: le mappe che vengono visualizzate riflettono i cambiamenti fatti nella area della legenda.

Suggerimento

ZOOM IN E ZOOM OUT CON LA ROTELLA DEL MOUSE

Per le operazioni di zoom è anche possibile utilizzare la rotella del mouse. Posizionando il puntatore del mouse nell’area di visualizzazione delle mappe si aumenta lo zoom girando la rotella verso lo schermo, lo si riduce girandola nel verso contrario. La posizione del puntatore costituisce il centro per l’ingrandimento. Il comportamento della funzione di zoom con la rotella del mouse può essere regolata dalla scheda Strumenti mappa presente nel menu Impostazioni ‣ Opzioni .

Suggerimento

MUOVERE LA MAPPA CON I TASTI FRECCIA E LA BARRA SPAZIATRICE

È possibile spostare la vista mappa anche con i tasti freccia della tastiera. Posizionare il mouse nella vista mappa e cliccare la freccia destra per spostarsi verso est, la freccia sinistra per spostarsi verso ovest, la freccia in su per spostarsi verso nord e la freccia in giù per spostarsi verso sud. Puoi anche spostare la mappa con la barra spaziatrice o premendo la rotellina del mouse: nel primo caso tieni premuta la barra spaziatrice e muovi il mouse, mentre nel secondo caso tieni premuto il tasto della rotellina mentre muovi il mouse.

Barra di Stato

La barra di stato mostra le coordinate di mappa (es. metri o gradi decimali) alla posizione del mouse. Nella barra di stato a sinistra del visore delle coordinate è presente un piccolo pulsante che consente di passare dalla visione delle coordinate al movimento del mouse alla visione delle coordinate dell’estensione della vista mappa.

Accanto al display di visualizzazione delle coordinate si trova il display della scala. Questo mostra la scala della vista mappa. Sia ingrandendo che rimpicciolendo la scala, QGIS mostrerà la scala corrente. È presente un selettore che permette di scegliere fra scale predefinite da 1:500 a 1:1000000.

Una barra di avanzamento nella barra di stato mostra il progredire della visualizzazione di ogni layer nella vista mappa. In alcuni casi, come quando vengono raccolte informazioni statistiche su layer raster, questa barra è utilizzata per mostrare lo stato di tali processi, in genere molto lunghi.

Se è disponibile un nuovo plugin o un aggiornamento ad un plugin installato, nella barra di stato apparirà un avviso. L’icona mIconStopRendering disattiva temporaneamente la visualizzazione dei layer nella vista mappa (sezione Visualizzazione). Nella parte destra della barra di stato è presente una casella di controllo che, se attivata, può essere usata per impedire temporaneamente la visualizzazione dei layer.

All’estrema destra della barra di stato appare il codice EPSG del SR del progetto corrente; cliccando sull’icona a forma di proiettore subito a destra del codice EPSG è possibile accedere alle proprietà del SR stesso.

Suggerimento

IMPOSTARE CORRETTAMENTE LA SCALA DELLA MAPPA

I gradi sono l’unità di misura predefinita di QGIS, quindi le coordinate di ciascun layer verranno visualizzate in gradi decimali. Per ottenere valori di scala corretti, è possibile cambiarli manualmente in unità metriche nella scheda Generale sotto il menu Impostazioni ‣ Proprietà progetto oppure è possibile scegliere un Sistema di riferimento (SR) cliccando sull’icona mIconProjectionDisabled Stato SR nell’angolo in basso a destra della barra di stato. In quest’ultimo caso le unità di misura sono impostate secondo le caratteristiche delle proprietà del progetto, ad esempio ‘+units=m’.