Outdated version of the documentation. Find the latest one here.

Modifica

QGIS supports various capabilities for editing OGR, SpatiaLite, PostGIS, MSSQL Spatial and Oracle Spatial vector layers and tables.

Nota

The procedure for editing GRASS layers is different - see Section Digitalizzare e modificare layer vettoriali GRASS for details.

Suggerimento

Modifiche concorrenti

Questa versione di QGIS non effettua alcuna verifica sulla possibilità che più utenti stiano effettuando contemporaneamente modifiche sullo stesso layer, è quindi l’ultimo utente che effettua il salvataggio ad apportare le modifiche definitive.

Settare la tolleranza dello snapping e il raggio di ricerca degli elementi

Prima di editare vertici, è molto importante sia impostare il livello di snapping che il valore del raggio di ricerca al fine di gestire in maniera ottimale la modifica delle geometrie di un layer vettoriale.

Tolleranza di snapping

La tolleranza di snapping è la distanza entro la quale QGIS cerca il vertice e/o segmento più vicino al quale si cerca di agganciarsi quando si crea un nuovo vertice o si sposta un vertice esistente. Se non si è entro la tolleranza di snapping, QGIS lascerà il vertice creato o spostato nella posizione in cui si rilascia il pulsante del mouse invece di agganciarlo ad un vertice e/o segmento esistente. La tolleranza di snapping influenza tutti gli strumenti che lavorano con una tolleranza.

  1. A general, project wide snapping tolerance can be defined choosing Settings ‣ mActionOptions Options. On Mac: go to QIS ‣ mActionOptions Preferences..., on Linux: Edit ‣ mActionOptions Options. In the Digitizing tab you can select between to vertex, to segment or to vertex and segment as default snap mode. You can also define a default snapping tolerance and a search radius for vertex edits. The tolerance can be set either in map units or in pixels. The advantage of choosing pixels, is that the snapping tolerance doesn’t have to be changed after zoom operations. In our small digitizing project (working with the Alaska dataset), we define the snapping units in feet. Your results may vary, but something on the order of 300ft should be fine at a scale of 1:10 000 should be a reasonable setting.
  2. È anche possibile impostare una tolleranza di snapping per singolo layer scegliendo la voce di menu Impostazioni ‣ (oppure File ‣) Opzioni si snap... (figura figure_edit_1 ).

Da notare che la tolleranza di snap per un singolo layer sovrascrive la tolleranza globale impostata nella scheda Digitalizzazione. Se è necessario modificare un layer ed impostare lo snap per i suoi vertici, allora abilitare la tolleranza di snap solamente sul layer richiesto. Diminuire la tolleranza di snap globale a un livello più basso ed assicurarsi che sia selezionatala casella di controllo per il layer.

Figure Edit 1:

../../../_images/editProjectSnapping.png

Edit snapping options on a layer basis nix

Raggio di ricerca

Il raggio di ricerca è la distanza che QGIS usa per cercare il vertice più vicino che si sta provando a spostare quando si clicca nella mappa. Se non si è entro il raggio di ricerca, QGIS non troverà né selezionerà alcun vertice e mostrerà un avvertimento in una finestra pop-up. La tolleranza di snapping e il raggio di ricerca sono impostati in unità di mappa o in pixel e potrebbe essere necessario fare diversi tentativi prima di trovare l’impostazione migliore. Se si specifica una tolleranza troppo alta, QGIS potrebbe agganciare il vertice sbagliato, specialmente se si ha a che fare con molti vertici vicini all’area in cui si sta effettuando la modifica. Impostando invece un raggio di ricerca troppo piccolo impedirà a QGIS di trovare alcuna geometria da spostare.

Il raggio di ricerca per la modifica di vertici può essere definito in unità del layer dalla scheda Digitalizzazione sotto il menu Impostazioni ‣ mActionOptions Opzioni, sotto lo stesso percorso dal quale è possibile impostare la tolleranza di snapping a livello di progetto.

Zoom e spostamento

Prima di editare un layer sarebbe opportuno ingrandire la vista mappa su un’area di interesse, al fine di evitare una lunga attesa per la visualizzazione di tutti i vertici della mappa.

Oltre ad utilizzare le icone mActionPan Sposta mappa e mActionZoomIn Ingrandisci / mActionZoomOut Rimpicciolisci è possibile interagire con la mappa con la rotellina del mouse, la barra spaziatrice e i tasti freccia della tastiera.

Zoom e spostamento con la rotella del mouse

Per spostarsi nella mappa cliccare sulla rotella del mouse e trascinare, mentre per lo zoom basta ruotare la stessa. Posizionare il cursore nell’area di mappa e ruotare la rotellina verso di sé per ridurre e verso lo schermo per ingrandire. La posizione del puntatore del mouse determinerà il centro dell’area da ingrandire. È possibile personalizzare il comportamento della rotella del mouse nella scheda Strumenti mappa alla voce di menu Impostazioni ‣ mActionOptions Opzioni.

Spostamento con i tasti freccia

È possibile spostare la vista mappa anche con i tasti freccia della tastiera. Posizionare il mouse nella vista mappa e cliccare la freccia destra per spostarsi verso est, la freccia sinistra per spostarsi verso ovest, la freccia in su per spostarsi verso nord e la freccia in giù per spostarsi verso sud.

È anche possibile tenere premuta la barra spaziatrice mentre si sposta il mouse per spostare la vista mappa e usare i tasti PgUp e PgDown per aumentare o ridurre l’ingrandimento senza interrompere la sessione di digitalizzazione.

Modifiche topologiche

Oltre alle opzioni di snap a livello di singolo layer, la finestra di dialogo Opzioni di snap... permette di impostare altre funzionalità topologiche. È possibile selezionare le opzioni checkbox Abilita la modifica topologica e/o checkbox Evita inters.: quest’ultima evita l’intersezione di nuovi poligoni.

Abilitare la modifica topologica

The option checkbox Enable topological editing is for editing and maintaining common boundaries in polygon mosaics. QGIS ‘detects’ a shared boundary in a polygon mosaic and you only have to move the vertex once and QGIS will take care about updating the other boundary.

Evitare le intersezioni per i nuovi poligoni

The second topological option in the checkbox Avoid Int. column, called Avoid intersections of new polygons avoids overlaps in polygon mosaics. It is for quicker digitizing of adjacent polygons. If you already have one polygon, it is possible with this option to digitize the second one such that both intersect and QGIS then cuts the second polygon to the common boundary. The advantage is that users don’t have to digitize all vertices of the common boundary.

Enable snapping on intersections

Another option is to use checkbox Enable snapping on intersection. It allows to snap on an intersection of background layers, even if there’s no vertex on the intersection.

Modifica di un layer esistente

By default, QGIS loads layers read-only: This is a safeguard to avoid accidentally editing a layer if there is a slip of the mouse. However, you can choose to edit any layer as long as the data provider supports it, and the underlying data source is writable (i.e. its files are not read-only).

In QGIS sono presenti due barre strumenti distinte per la modifica dei vettori, una di base e l’altra avanzata, quest’ultima descritta nella Sezione Digitalizzazione avanzata. Entrambe le barre possono essere attivate/disattivate sotto Visualizza ‣ Barra degli strumenti ‣. Gli strumenti di base offrono le seguenti funzionalità:

Icona

Azione

Icona

Azione

mActionAllEdits Current edits mActionToggleEditing

Attiva modifica

mActionCapturePoint

Aggiunge elementi: Inserisci punto

mActionCaptureLine

Aggiunge elementi: Inserisci linea

mActionCapturePolygon

Aggiunge elementi: Inserisci poligono

mActionMoveFeature

Muove elementi

mActionNodeTool

Strumento vertici

mActionDeleteSelected

Elimina elementi selezionati

mActionEditCut

Taglia elementi

mActionEditCopy

Copia elementi

mActionEditPaste

Incolla elementi

mActionSaveEdits Save layer edits

Strumenti di base per la modifica di layer vettoriali

Ogni sessione di modifica è inizializzata dall’opzione mActionToggleEditing Modifica, che può essere attivata e disattivata nel menù contestuale che si apre cliccando con il tasto destro del mouse sul nome del layer nella legenda.

In alternativa, è possibile usare il pulsante Modifica mActionToggleEditing Modifica. Quando il layer è in modalità modifica, i vertici In alternativa, è possibile usare il pulsante sono contrassegnati da indicatori (croci o cerchi semitrasparenti) e altri strumenti sono attivati nella barra degli strumenti di modifica.

Suggerimento

Salvataggio ad intervalli regolari

Remember to mActionSaveEdits Save Layer Edits regularly. This will also check that your data source can accept all the changes.

Aggiungere elementi

È possibile usare gli strumenti mActionCapturePoint Inserisci punto, mActionCaptureLine Inserisci linea o mActionCapturePolygon Inserisci poligono per porre il puntatore di QGIS in modalità digitalizzazione.

Per ogni elemento, bisogna dapprima digitalizzare la geometria e successivamente inserire gli attributi. Per digitalizzare la geometria, cliccare con il tasto sinistro del mouse nella vista mappa per creare il primo punto del nuovo elemento.

Per linee e poligoni, continuare a cliccare con il tasto sinistro per ogni ulteriore vertice che si desidera inserire. Quando è terminato l’inserimento dei vertici o dei punti, cliccare con il tasto destro in qualunque punto della mappa per confermare di aver terminato l’inserimento della geometria dell’elemento.

The attribute window will appear, allowing you to enter the information for the new feature. Figure_edit_2 shows setting attributes for a fictitious new river in Alaska. In the Digitizing menu under the Settings ‣ Options menu, you can also activate checkbox Suppress attributes pop-up windows after each created feature checkbox Reuse last entered attribute values.

Figure Edit 2:

../../../_images/editDigitizing.png

Enter Attribute Values Dialog after digitizing a new vector feature nix

Per spostare degli elementi utilizzare lo strumento mActionMoveFeature Muovi elemento/i.

Suggerimento

Tipologie di attributo

Relativamente agli shapefile, la modifica del tipo di attributo è validata durante l’inserimento, per cui non è ovviamente possibile inserire un numero in una colonna testuale quando compare la finestra di dialogo Attributi e viceversa. Qualora si avesse tale necessità, è necessario modificare gli attributi in un secondo momento per mezzo della finestra di dialogo Tabella degli attributi.

Current Edits

This new feature allows the digitization of multiple layers. Choose mActionFileSaveAs Save for Selected Layers to save all changes you made in multiple layers. You also have the opportunity to mActionRollbackEdits Rollback for Selected Layers so that the digitization is then withdrawn for all selected layers. If you want to stop editing the selected layers the mActionCancelEdits Cancel for Selected Layer(s) is an easy way.

The same functions for editing all layers of the project are available.

Strumento vertici

For shapefile-based layers as well as SpatialLite,PostgreSQL/PostGIS, MSSQL Spatial and Oracle Spatial tables the mActionNodeTool Node Tool provides manipulation capabilites of feature vertices similar to CAD programs. It is possible to simply select multiple vertices at once and to move, add or delete them alltogether. The node tool also works with ‘on the fly’ projection turned on and supports the topological editing feature. This tool is, unlike other tools in QGIS, persistent, so when some operation is done, selection stays active for this feature and tool. If the node tool couldn’t find any features, a warning will be displayed.

Pertanto, è importante impostare Impostazioni ‣ mActionOptions Opzioni ‣ Digitalizzazione ‣ Raggio di ricerca: selectnumber ad un valore superiore a zero (per esempio 10). Altrimenti QGIS non è in grado di gestire adeguatemente la modifica dei vertici.

Suggerimento

Indicatori dei vertici

The current version of QGIS supports three kinds of vertex-markers: Semi transparent circle, Cross and None. To change the marker style, choose mActionOptions Options from the Settings menu and click on the Digitizing tab and select the appropriate entry.

Operazioni di base

Attivare lo strumento mActionNodeTool Strumento vertici e selezionare un elemento cliccandoci sopra: un riquadro rosso apparirà su ogni vertice dell’elemento.

  • Selecting vertices: You can select vertices by clicking on them one at a time, by clicking on an edge to select the vertices at both ends, or by clicking and dragging a rectangle around some vertices. When a vertex is selected its color changes to blue. To add more vertices to the current selection, hold down the Ctrl key while clicking. Hold down Ctrl or Shift when clicking to toggle the selection state of vertices (vertices that are currently unselected will be selected as usual, but also vertices that are already selected will become unselected).
  • Aggiungere vertici: per aggiungere un vertice fare doppio click nei pressi di un bordo. Si noti che il vertice apparirà sul bordo e non alla posizione del cursore del mouse.

  • Eliminare vertici: per eliminare un vertice selezionato basta premere il tasto Delete. Si noti che non è possibile eliminare un intero elemento tramite lo strumento mActionNodeTool Strumento vertici; QGIS manterrà un numero minimo di vertici per il tipo di elemento su cui si sta lavorando. Per eliminare completamente un elemento, usare lo strumento mActionDeleteSelected Elimina il selezionato.

  • Spostare vertici: selezionare i vertici di interesse, quindi cliccare e trascinare nella direzione verso la quale si intende spostare i vertici; i vertici saranno spostati tutti insieme. Se lo snap è attivo, l’intera selezionare può essere agganciata al vertice e/o linea più vicina.

Ogni cambiamento operato con lo strumento vertici è memorizzato nel dialogo Annulla. Tutte le operazioni supportano le modifiche topologiche (se attivate) ed è possibile operare con la proiezione a volo attiva. Lo strumento vertici offre, inoltre, la possibilità di ottenere informazioni su un vertice lasciando semplicemente il cursore del mouse sul vertice di interesse.

Tagliare, copiare ed incollare elementi

Gli elementi selezionati possono essere tagliati, copiati ed incollati tra layer dello stesso progetto di QGIS a patto che anche per il layer di destinazione sia stata abilitata la modalità di modifica tramite l’opzione mActionToggleEditing Modifica.

Gli elementi possono essere anche incollati in applicazioni esterne in formato testo: gli elementi verranno rappresentati nel formato CSV con le informazioni della geometria espresse nel formato testo OGC Well Known Text (WKT).

Le funzioni di copia/incolla sono utili quando si devono modificare più layer copiando le modifiche effettuate in uno di questi negli altri. Supponendo, ad esempio, di voler lavorare su un layer contenente solo alcuni laghi, diventa molto più agevole creare un nuovo layer vuoto nel quale incollare gli elementi dei quali necessitiamo invece di lavorare sul layer big_lakes contenente 5000 elementi.

Dovremo quindi effettuare le seguenti operazioni:

  1. Caricare il layer dal quale vogliamo copiare gli elementi (layer sorgente)

  2. Caricare o creare il layer nel quale vogliamo incollare gli elementi copiati (layer di destinazione)

  3. Impostare entrambi i layer in modalità modifica

  4. Rendere attivo il layer sorgente cliccando sul relativo nome nella legenda

  5. Attivare lo strumento mActionSelect Seleziona il singolo elemento per selezionare gli elementi dal layer sorgente

  6. Cliccare sullo stumento mActionEditCopy Copia elementi

  7. Rendere attivo il layer di destinazione cliccando sul relativo nome nella legenda

  8. Attivare lo strumento mActionEditPaste Incolla elementi

  9. Terminare le modifiche e salvare

Se il layer sorgente e quello di destinazione hanno un diverso schema (nomi e tipi dei campi) QGIS popola, se presenti, i campi comuni e ignora il resto. Se non è importante che vengano copiati anche gli attributi nel layer di destinazione, si può non prestare attenzione a come viene definito lo schema della tabella attributi, altrimenti è necessario definirlo in modo che lo schema del layer sorgente e quello del layer di destinazione combacino.

Suggerimento

Congruenza degli elementi incollati

Se il layer sorgente e quello di destinazione usano lo stesso sistema di proiezione, gli elementi incollati saranno assolutamente identici a quelli del layer di origine. Nel caso in cui invece la proiezione del layer di destinazione sia differente QGIS non garantisce che la geometria sia identica a causa del pur ridotto errore di arrotondamento introdotto nel passaggio da un sistema di proiezione all’altro.

Cancellare elementi selezionati

Se si vuole eliminare un intero poligono, è possibile farlo selezionando dapprima l’elemento che intendiamo cancellare con lo strumento mActionSelect Seleziona il singolo elemento: è possibile anche selezionare più poligoni contemporaneamente. Una volta definita la selezione, usare lo strumento mActionDeleteSelected Elimina il selezionato per cancellare la selezione.

Anche lo strumento mActionEditCut Taglia geometrie può essere usato per eliminare elementi: tali elementi vengono spostati in un blocco appunti spaziale. In questo modo è possibile annullare l’operazione incollando nuovamente gli elementi tagliati con lo strumento mActionEditPaste Incolla elementi, fornendo in ultima analisi almeno un livello di annullamento. Gli strumenti taglia, copia e incolla lavorano sugli elementi selezionati, consentendo quindi di lavorare su più di un elemento alla volta.

Salvare i layer modificati

When a layer is in editing mode, any changes remain in the memory of QGIS. Therefore they are not committed/saved immediately to the data source or disk. If you want to save edits to the current layer but want to continue editing without leaving the editing mode, you can click the mActionSaveEdits Save Layer Edits button. When you turn editing mode off with the mActionToggleEditing Toggle editing (or quit QGIS for that matter), you are also asked if you want to save your changes or discard them.

Se le modifiche non possono essere salvate (ad es. perché il disco di destinazione è pieno o gli attributi contengono valori esterni agli estremi ammissibili), lo stato della memoria di QGIS è preservato, consentendo dunque di correggere gli errori e riprovare il salvataggio.

Suggerimento

Integrità dei dati

È buona norma fare un back-up del dato originale prima di procedere alla modifica. Per quando siano stati fatti molti sforzi da parte dei programmatori di QGIS per preservare l’integrità del dato, non vi è alcuna garanzia che ciò avvenga.

Digitalizzazione avanzata

Icona

Azione

Icona

Azione

mActionUndo

Annulla

mActionRedo

Ripristina

mActionRotateFeature Rotate Feature(s) mActionSimplify

Semplifica geometrie

mActionAddRing

Aggiungi buco

mActionAddPart

Aggiungi una parte

mActionDeleteRing

Elimina buco

mActionDeletePart

Elimina parte

mActionReshape

Modifica la forma

mActionOffsetCurve

Curva di offset

mActionSplitFeatures

Spezza elemento

mActionMergeFeatures

Unisci le geometrie selezionate

mActionRotatePointSymbols

Ruota i simboli per i punti

mActionMergeFeatureAttributes

Unisci gli sttributi delle geometrie selezionate

Barra degli strumenti di digitalizzazione avanzata

Annullare e rispristinare

Gli strumeti mActionUndo Annulla e mActionRedo Ripristina permettono di annullare/ripristinare le modifiche ad un layer vettoriale. Inoltre, è disponibile un widget che memorizza e mostra tutte le operazioni annulla/ripristina (Figura Figure_edit_3). Per attivare il widget cliccare con il tasto destro del mouse sulla barra degli strumenti ed attivare la casella di controllo Annulla/Ripristina. Annulla/Ripristina è comunque attivo, anche se il widget non è visibile.

Figure Edit 3:

../../../_images/redo_undo.png

Redo and Undo digitizing steps nix

Cliccando su Annulla, tutti gli elementi e gli attributi vengono riportati al loro stato precedente. Le modifiche effettuate con strumenti diversi da quelli per la digitalizzazione (es. un plugin), potrebbero non essere annullabili.

Se nel widget Annulla/Ripristina si clicca su una determinata operazione, tutti gli elementi saranno riportati allo stato successivo all’operazione selezionata.

Rotate Feature(s)

Use the mActionRotateFeatureRotate Feature(s) to rotate one or multiple selected features in the map canvas. You first need to select the features and then press the mActionRotateFeatureRotate Feature(s) Icon. Then the centroid of the feature appears and will be the rotation anchor point. If you selected multiple features the rotation anchor point will be the common center of the features. Press and drag the left mouse button in the desired direction to rotate the selected features.

It’s also possible to create a user-defined rotation anchor point by which the selected feature will rotate. Select the features to rotate and activate the mActionRotateFeatureRotate Feature(s) Tool. Press and hold the Ctrl button and move the mouse pointer (without pressing the mouse button) to the place where you want the rotation anchor to be moved. Release the Ctrl button when the desired rotation anchor point is reached. Now press and drag the left mouse button in the desired direction to rotate the selected feature(s).

Semplifica geometrie

Lo strumento mActionSimplify Semplifica geometrie permette di ridurre il numero di vertici di un elemento, preservandone la geometria: un elemento selezionato con lo strumento sarà evidenziato da una linea di semplificazione rossa, inoltre verrà mostrato a schermo un cursore (Tolleranza linea di semplificazione). Muovendo il cursore, la linea di semplificazione cambia e mostra la forma che assumerà l’elemento che si sta semplificando. Per memorizzare la geometria semplificata, cliccare su [OK] . Se una geometria non può essere semplificata (come nel caso di un multi-poligono), verrà mostrato un messaggio di errore.

Aggiungi buco

Si possono digitalizzare nuovi poligoni all’interno di poligoni esistenti, al fine di creare un buco all’interno di questi ultimi, scegliendo lo strumento mActionAddRing Aggiungi buco. In questo modo solo l’area compresa tra i bordi del poligono interno e di quello esterno verrà evidenziata come poligono ad anello.

Aggiungi una parte

You can mActionAddPart add part polygons to a selected multipolygon. The new part polygon has to be digitized outside the selected multipolygon.

Elimina buco

Lo strumento mActionDeleteRing Elimina buco permette di eliminare un buco all’interno di un poligono. Lo strumento funziona esclusivamente con layer di poligoni. Nessuna azione viene effettuata se lo strumento viene usato sul bordo esterno di un poligono. Prima di selezionare i vertici di un buco, impostare adeguatamente la tolleranza.

Elimina parte

Lo strumento mActionDeletePart Elimina parte permette di eliminare parti da geometrie multi-parte (multi-punto, multilinea, multi-poligono); lo strumento non ha effetto sull’ultima parte aggiunta. Prima di selezionare i vertici di una parte, impostare adeguatamente la tolleranza.

Modifica la forma

Lo strumento mActionReshape Modifica forma permette di modificare la forma di elementi a geometria lineare e poligonale tracciando una nuova linea: la porzione di elemento tra i due punti di intersezione con la nuova linea sarà rimpiazzata dalla forma di quest’ultima. Prestare particolare attenzione ad utilizzare lo strumento con i poligoni: limitarsi a piccole porzioni di poligono. La nuova forma non può intersecare più buchi, altrimenti si generano poligoni non validi.

Per modificare, ad esempio, il bordo di un poligono basta cliccare un primo punto all’interno del poligono, cliccare un secondo punto all’esterno del poligono, tracciare il profilo della nuova forma, rientrare nel poligono e cliccare con il tasto destro del mouse per terminare l’operazione. Lo strumento aggiungerà automaticamente nuovi nodi laddove la nuova linea interseca il bordo del poligono. È, inoltre, possibile rimuovere parte di un poligono iniziando la nuova linea all’esterno del poligono, aggiungendo vertici all’interno e terminando la linea all’esterno con il tasto destro del mouse.

Nota

Lo strumento potrebbe alterare la posizione iniziale di un poligono o di una linea chiusa, per cui nodo iniziale e nodo finale potrebbero non coincidere. Per molte applicazioni tale fatto non è un problema rilevante, ma è opportuno tenerne conto.

Dividere elementi

The mActionOffsetCurve Offset Curve tool creates parallel shifts of line layers. The tool can be applied to the edited layer (the geometries are modified) or also to background layers (creates copies of the lines / rings and adds it to the the edited layer). It is thus ideally suited for the creation of distance line layers. The displacement is shown at the bottom left of the taskbar. To create a shift of a line layer you have to go into editing mode and then select the feature. You can make the mActionOffsetCurve Offset Curve tool active and drag the cross to the desired distance. Your changes then can be saved with the mActionSaveEditsSave Layer Edits tool.

Spezza elemento

È possibile dividere degli elementi tramite lo strumento mActionSplitFeatures Spezza elemento e tracciando una linea attraverso l’elemento di interesse.

Unire elementi

Lo strumento mActionMergeFeatures Unisci le geometri selezionate permette di unire elementi con bordi condivisi e stessi attributi.

Unire attributi di elementi

The mActionMergeFeatureAttributes Merge Attributes of Selected Features tool allows to merge attributes of features with common boundaries and attributes without merging their boundaries. You can merge the attributes when selecting several features at once. Then press the mActionMergeFeatureAttributes Merge Attributes of Selected Features button. Now QGIS offers you which attributes are to be applied to all selected objects. As a result, all objects have the same attribute entries.

Ruota i simboli per i punti

The mActionRotatePointSymbols Rotate Point Symbols allows to change the rotation of point symbols in the map canvas. You have to define a rotation column from the attribute table of the point layer in the Advanced menu of the Style menu of the Layer Properties. Also you have to go into the ‘SVG marker’ and choose Data defined properties .... Activate checkbox Angle and choose ‘rotation’ as field. Without these settings the tool is inactive.

Figure Edit 4:

../../../_images/rotatepointsymbol.png

Rotate Point Symbols nix

Per modificare la rotazione, selezionare un elemento puntuale nella vista mappa e ruotarlo tenendo premuto il tasto sinistro del mouse; apparirà una freccia rossa ed il valore di rotazione (Figura Figure_edit_4). Al termine dell’operazione, il valore di rotazione nella tabella degli attributi sarà aggiornato di conseguenza.

Nota

Se si tiene premuto il tasto Ctrl, la rotazione avverrà per step di 15 gradi.

Creating new Vector layers

QGIS allows to create new Shapefile layers, new SpatiaLite layers, and new GPX Layers. Creation of a new GRASS layer is supported within the GRASS-plugin. Please refer to section Creare un nuovo layer vettoriale GRASS for more information on creating GRASS vector layers.

Creare un nuovo Shapefile

Per creare un nuovo layer shapefile selezionare Nuovo ‣ mActionNewVectorLayer Nuovo layer shapefile... dal menu Layer. Apparirà la finestra di dialoto Nuovo vettore mostrata in figura Figure_edit_5. Scegliere il tipo di geometria (Punto, Linea o Poligono) ed il sistema di riferimento (SR).

Si noti che QGIS non supporta la creazione di elementi 2.5D (ad es. elementi con coordinate XYZ) o il conteggio degli elementi.

Figure Edit 5:

../../../_images/editNewVector.png

Creating a new Shapefile layer Dialog nix

To complete the creation of the new Shapefile layer, add the desired attributes by clicking on the [Add to attributes list] button and specifying a name and type for the attribute. A first ‘id’ column is added as default but can be removed, if not wanted. Only Type: real selectstring, Type: integer selectstring, Type: string selectstring and Type:date selectstring attributes are supported. Additionally and according to the attribute type you can also define the width and precision of the new attribute column. Once you are happy with the attributes, click [OK] and provide a name for the shapefile. QGIS will automatically add a .shp extension to the name you specify. Once the layer has been created, it will be added to the map and you can edit it in the same way as described in Section Modifica di un layer esistente above.

Creare un nuovo layer SpatiaLite

To create a new SpatiaLite layer for editing, choose New ‣ mActionNewSpatiaLiteLayer New SpatiaLite Layer... from the Layer menu. The New SpatiaLite Layer dialog will be displayed as shown in Figure_edit_6.

Figure Edit 6:

../../../_images/editNewSpatialite.png

Creating a New SpatiaLite layer Dialog nix

First step is to select an existing SpatiaLite database or to create a new SpatiaLite database. This can be done with the browse button browsebutton to the right of the database field. Then add a name for the new layer and define the layer type and specify the Coordinate Reference System with [Specify CRS]. If desired you can select to checkbox Create an autoincrementing primary key.

Per definire la tabella degli attributi del nuovo layer, indicare nome e tipo dell’attributo desiderato e cliccare su [Aggiungi alla tabella degli attributi] quindi cliccare su [OK]. Una volta creato il layer, lo stesso sarà aggiunto alla vista mappa e potrà essere modificato come descritto alla precedente sezione Modifica di un layer esistente.

I layer Spatialite possono essere gestiti attraverso DB Manager, vedi sezione Plugin DB Manager.

Creating a new GPX layer

To create a new GPX file you need to load the GPS plugin first. Plugins ‣ mActionShowPluginManager Plugin Manager... opens the Plugin Manager Dialog. Activate the checkbox GPS Tools checkbox.

When this plugin is loaded choose New ‣ icon_newgpx Create new GPX Layer... from the Layer. In the Save new GPX file as dialog you can choose where to save the new GPX layer.

Lavorare con la tabella degli attributi

La tabella degli attributi mostra gli elementi di un layer. Ogni riga nella tabella rappresenta un elemento ed ogni colonna un attributo. Gli elementi possono essere cercati, selezionati, spostati e modificati.

To open the attribute table for a vector layer, make the layer active by clicking on it in the map legend area. Then from the main menu Layer choose mActionOpenTable Open Attribute Table. It is also possible to rightclick on the layer and choose mActionOpenTable Open Attribute Table from the dropdown menu and to click on the mActionOpenTable Open Attribute Table button in the Attributes toolbar.

Si aprirà la finestra di dialogo mostrata in Figura figure_attributes_1: il titolo della finestra, inoltre, mostra il numero di elementi selezionati sul totale degli elementi del layer.

Figure Attributes 1:

../../../_images/vectorAttributeTable.png

Attribute Table for regions layer nix

Selezionare elementi nella tabella degli attributi

Ogni riga selezionata nella tabella degli attributi mostra gli attributi di un elemento selezionato nel layer. Se l’insieme di elementi selezionati nella vista mappa viene modificato, la selezione viene aggiornata anche nella tabella e viceversa. Allo stesso modo, se cambia l’insieme delle righe selezionate nella tabella degli attributi, cambierà anche la visualizzazione degli elementi nella vista mappa.

Le righe possono essere selezionate cliccando sul numero alla loro sinistra. Si possono selezionare righe multiple tenendo premuto il tasto Ctrl. È possibile selezionare un sottoinsieme di righe tenendo premuto Shift e cliccando sulle due righe che delimitano il sottoinsieme di interesse. Spostare il cursore del mouse e cliccare nelle celle della tabella non modifica la selezione. Cambiare la selezione della vista mappa non modifica la posizione del cursore nella tabella.

Le righe della tabella possono essere ordinate in funzione degli attributi. Cliccare sull’intestazione dell’attributo rispetto al quale si intende ordinare la tabella: una piccola freccia a destra del nome dell’attributo indicherà il verso dell’ordinamento (freccia in su per ordinamento crescente, freccia in giù per ordinamento decrescente).

For a simple search by attributes on only one column choose the Column filter ‣ from the menu in the bottom left corner. Select the field (column) from which the search should be performed from the dropdown menu and hit the [Apply] button. Then only the matching features are shown in the Attribute table.

To make a selection you have to use the mIconExpressionSelect Select features using an Expression icon on top of the Attribute table. The mIconExpressionSelect Select features using an Expression allows you to define a subset of a table using a Function List like in the mActionCalculateField Field Calculator (see Calcolatore di campi). The query result then can be saved as a new vector layer. For example if you want to find regions that are boroughs from the regions.shp of the QGIS sample data you have to open the >Fields and Values menu and choose the field that you want to query. Double-klick the field ‘TYPE_2’ and also [Load all unique values] . From list choose and double-klick ‘Borough’. In the Expression field the following query appears:

"TYPE_2"  =  'Borough'

The matching rows will be selected and the total number of matching rows will appear in the title bar of the attribute table, and in the status bar of the main window. For searches that display only selected features on the map use the Query Builder described in Section Costruttore di interrogazioni.

To show selected records only, use Show Selected Features from the menu at the bottom left.

The other buttons at the top of the attribute table window provide following functionality:

  • mActionToggleEditing Modalità modifica per modificare singoli valori della tabella e per abilitare le funzionalità di seguito descritte. Anche con Ctrl+E

  • mActionSaveEdits Save Edits also with Ctrl+S
  • mActionUnselectAttributes Unselect all also with Ctrl+U
  • mActionSelectedToTop Muovi selezione in alto anche con Ctrl+T

  • mActionInvertSelection Invert selection also with Ctrl+R
  • mActionCopySelected Copia le righe selezionate nel blocco appunti anche con Ctrl+C

  • mActionZoomToSelected Zoom mappa alle righe selezionate anche con Ctrl+J

  • mActionZoomToSelected Zoom mappa alle righe selezionate anche con Ctrl+P

  • mActionDeleteSelected Elimina gli elementi selezionati anche con Ctrl+D

  • mActionNewAttribute Nuova colonna per layer PostGIS ed OGR con GDAL versione >= 1.6. Anche con Ctrl+W

  • mActionDeleteAttribute Elimina colonna per layer PostGIS ed OGR con GDAL versione >= 1.9. Anche con Ctrl+L

  • mActionCalculateField Apri il calcolatore di campi anche con Ctrl+I

Suggerimento

Geometrie WKT

If you want to use attribute data in external programs (such as Excel) use the mActionCopySelected Copy selected rows to clipboard button. You can copy the information without vector geometries if you deactivate Settings ‣ Options ‣ Data sources menu checkbox Copy geometry in WKT representation from attribute table.

Salvare elementi selezionati come nuovo layer

Gli elementi selezionati possono essere salvati in uno dei formati vettoriali supportati da OGR, anche con sistema di riferimento diverso da quello del layer di origine. Cliccare con il tasto destro del mouse sul layer in legenda e selezionare Salva selezione con nome ‣ dal menu contestuale: quindi definire il nome, il formato ed il sistema di riferimento del file di output (Sezione Legenda). È anche possibile specificare le opzioni di creazione OGR.

Lavorare con tabelle di attributi non spaziali

QGIS allows also to load non spatial tables. This includes currently tables supported by OGR, delimited text as well as the PostgreSQL, MSSQL and Oracle provider. The tables can be used for field lookups or just generally browsed and edited using the table view. When you load the table you will see it in the legend field. It can be opened e.g. with the mActionOpenTable Open Attribute Table tool and is then editable like any other layer attribute table.

As an example you can use columns of the non spatial table to define attribute values or a range of values that are allowed to be added to a specific vector layer during digitizing. Have a closer look at the edit widget in section Fields Menu to find out more.