Outdated version of the documentation. Find the latest one here.

Configurazione di QGIS

QGIS è altamente configurabile attraverso il menu Impostazioni ‣ attraverso i menu Opzioni e Personalizzazione. Altre opzioni di configurazione sono possibili attraverso i menu Pannelli e Barre degli strumenti presenti nel menu Visualizza ‣.

Pannelli e Barre degli strumenti

Nel menu Pannelli ‣ è possibile attivare e disattivare i widgets di QGIS. Il menu Barre degli strumenti ‣ offre la possibilità di attivare e disattivare gruppi di icone nella barra degli strumenti di QGIS (vedi figure_panels_toolbars).

Figure Panels and Toolbars:

../../../_images/panels_and_toolbars.png

Pannelli e Barre degli strumenti nix

Suggerimento

Panoramica

In QGIS you can use an overview panel that provides a full extent view of layers added to it. It can be selected under the menu View ‣ Panels. Within the view is a rectangle showing the current map extent. This allows you to quickly determine which area of the map you are currently viewing. Note that labels are not rendered to the map overview even if the layers in the map overview have been set up for labeling. If you click and drag the red rectangle in the overview that shows your current extent, the main map view will update accordingly.

Suggerimento

Messaggi di log

Puoi facilmente tenere traccia dei messaggi di QGIS. Attiva la casella di controllo checkboxMessaggi di log nel menu Visualizza ‣ Pannelli e segui cosi i messaggi relativi alle varie operazioni nella scheda Generale e Plugin.

Proprietà progetto

In the properties window for the project under nix Project ‣ Project Properties or win Project ‣ Project Properties you set project specific options. These include:

  • Nel menu Generale puoi impostare: il titolo del progetto, il colore della selezione e dello sfondo, l’unità di misura della mappa, la precisione e l’opzione di salvare il percorso ai layer come relativo o assoluto. Se hai attivato la trasformazione del SR puoi specificare un ellissoide per il calcolo delle distanze. Puoi scegliere le unità della mappa (solo se la trasformazione del SR è disattivata) e la precisione del numero (cifre decimali). Infine puoi anche inserire una lista di scale che sovrascriveranno le scale preimpostate.

  • La scheda SR permette di scegliere il sistema di riferimento e di abilitare la riproiezione al volo di raster e vettori quando questi hanno un SR diverso.

  • Il terzo menu Informazioni vettore permette di attivare/disattivare i vettori che possono essere interrogati. (Vedi anche il paragrafo relativo agli strumenti mappa nella sezione Opzioni dell’interfaccia grafica (GUI) per maggiori informazioni sull’interrogabilità di layer multipli).

  • Il menu Stili predefiniti permette di scegliere il modo in cui i nuovi layer caricati verranno visualizzati quando non hanno un file di stile .qml definito. Puoi anche impostare un livello di trasparenza e puoi scegliere se a un simbolo deve essere assegnato un colore casuale oppure uno predefinito.

  • La scheda Server OWS permette di impostare le informazioni sulle funzionalità dei server WMS e WFS, l’estensione e le restrizioni dei SR.

  • Il menu Macro serve per creare un modulo Python, salvarlo in file di progetto .qgs in modo che quando questo viene caricato, verranno eseguite specifiche funzioni come: openProject(), saveProject() and closeProject().

Figure Macro Menu:

../../../_images/macro.png

Impostazioni macro in QGIS

Opzioni dell’interfaccia grafica (GUI)

mActionOptions Alcune opzioni di base per QGIS possono essere impostate nella finestra Opzioni. Seleziona la voce Impostazioni ‣ mActionOptions Opzioni. Le schede nelle quali possono essere regolate le opzioni sono:

Menu Generale

Applicazione

  • Seleziona Stile (Necessario il riavvio di QGIS) selectstring e scegli fra ‘Windows’, ‘Motif’, ‘CDE’, ‘Plastique’ e ‘Cleanlux’ (nix).

  • Definisci il Tema delle icone selectstring. Attualmente è disponibile solo ‘default’.

  • Definisci la Dimensione delle icone selectstring.

  • Definisci il Carattere. Scegli fra radiobuttonon QT predefinito o un carattere di tua scelta.

  • Cambia il Timeout per messaggi o dialoghi a tempo selectstring.

  • checkbox Nascondi lo splash screen all’avvio

  • checkbox Mostra suggerimenti all’avvio

  • checkbox Titoli del gruppo box in grassetto

  • checkbox Box gruppi secondo stile QGIS

  • checkbox Usa pannelli scelta colore per aggiornare

File di progetto

  • Apri un progetto all’apertura di QGIS selectstring (scegli fra ‘Nuovo’, ‘Più recente’ e ‘Specifico’. Se hai scelto ‘Specifico’ usa browsebutton per stabilire qual è il progetto da aprire)

  • checkbox Crea un nuovo progetto dal progetto predefinito. Puoi premere su Definisce il progetto attuale come predefinito oppure su Ripristina il predefinito. Sfoglia fra i tuoi file e definisci la cartella in cui sono presenti i progetti da usare come modello. Se hai attivato|checkbox| Crea un nuovo progetto dal progetto predefinito e hai salvato un progetto nella cartella dei modelli, comparirà la nuova voce Progetto ‣ Nuovo da modello.

  • checkbox Chiedi di salvare il progetto e cambia sorgente dati quando richiesto

  • checkbox Avvisa quando viene aperto un file di progetto salvato con una vecchia versione di |qg|

  • Abilita macro selectstring. Questa opzione è stata creata per gestire al meglio le macro scritte per effettuare un’azione

su di un progetto. Puoi scegliere fra ‘Mai’, ‘Chiedi’, ‘Solo per questa sessione’ e ‘Sempre (sconsigliato)’.

Menu Sistema

Ambiente

Il menu Ambiente mostra le variabili di ambiente e permette di configurarle (vedi figure_environment_variables). Questa opzione è particolarmente utile per piattaforme stile Mac, dove le applicazioni GUI non ereditano necessariamente l’ambiente shell dell’utente. È utile anche per impostare/visualizzare le variabili di ambiente usate da strumenti esterni, gestiti da Processing come, SAGA e GRASS. Infine è utile anche per abilitare gli output del debug per specifiche sezione del codice sorgente.

  • checkbox Usa variabili utente (necessario il riavvio - includere i separatori). Aggiungi e Rimuovi le variabili. Il Variabili di ambiente attuali ‣ mostra le variabili di ambiente e puoi scegliere di checkbox Mostrare le sole variabili specifiche di QGIS.

Figure System Environment:

../../../_images/sys-env-options.png

Variabili di ambiente in QGIS

Percorsi verso i plugin

  • Aggiungi o Rimuovi Percorsi per cercare ulteriori librerie plugin C++

Menu Sorgente dati

Attributi delle geometrie e tabelle

  • checkbox Apri la tabella degli attributi in una finestra agganciata (richiede il riavvio di QGIS)

  • checkbox Copia la geometria in formato WTK dalla tabella degli attributi. Cliccando su mActionCopySelectedCopia le righe selezionate nel blocco appunti dal menu della Tabella degli attributi verranno copiate, oltre agli attributi, anche le coordinate dei vertici della geometria.

  • Comportamento della tabella di attributi selectstring. Ci sono tre possibilità: ‘Mostra tutti gli elementi’, ‘Mostra gli elementi selezionati’ e ‘Mostra gli elementi visibili nella mappa’

  • Cache riga attributi tabella selectstring. La cache permette di salvare le ultime x righe degli attributi caricate: in questo modo il lavoro con la tabella degli attributi risulterà essere molto più veloce. La cache verrà cancellata alla chiusura della tabella degli attributi.

  • Mostra i valori NULL come. Puoi definire un attributi con cui verranno visualizzati i valori NULL (nessun valore).

Trattamento delle sorgenti dati

  • Ricerca elementi validi nella finestra del browser selectstring. Puoi scegliere fra ‘Controlla estensione’ e ‘Controlla il contenuto del file’.

  • Ricerca contenuto dei file compressi (.zip) nella finestra del browser selectstring. Puoi scegliere fra ‘No’, ‘Scansione base’ e ‘Scansione completa’ .

  • Richiedi i sublayer raster al caricamento. Alcuni raster supportano i sublayer, chiamati subdataset in GDAL. Un esempio sono i file netcdf: se sono presenti diverse variabili netcdf, GDAL riconosce ogni variabile come un subdataset. L’opzione permette di gestire i sublayer quando uno di questi viene aperto. Sono possibili le seguenti scelte:

    • ‘Sempre’: chiede sempre (se sono presenti sublayer)

    • ‘Se necessario’: chiede se il layer non ha bande, ma ha sublayer

    • ‘Mai’: non chiede mai e non carica niente

    • ‘Carica tutto’: non chiede, ma carica tutti i sublayer

  • checkbox Ignora la dichiarazione di codifica per lo shapefile. Se lo shapefile ha informazioni sulla sua codifica, queste verranno ignorate.

  • checkbox Aggiungi un layer PostGIS con un doppio click e seleziona la modalità estesa

  • checkbox Aggiungi layer Oracle con un doppio click e seleziona modalità estesa

Menu Visualizzazione

Impostazioni di visualizzazione

  • checkbox Rendi le linee meno irregolari a spese delle prestazioni

  • checkbox Risolvi problemi con i poligoni riempiti non correttamente

Raster

  • con Selezione banda RGB puoi scegliere il numero di bande rosse, verdi e blu.

Miglioramento contrasto

  • Banda singola grigia selectstring. Una singola banda grigia può avere: ‘Nessuno stiramento’, ‘Stira a MinMax’, ‘Stira e taglia a MinMax’ e anche ‘Taglia a MinMax’

  • Colore multibanda (byte/band) selectstring. ‘Nessuno stiramento’, ‘Stira a MinMax’, ‘Stira e taglia a MinMax’ e ‘Taglia a MinMax’.

  • Colore multibanda (>byte/band) selectstring. ‘Nessuno stiramento’, ‘Stira a MinMax’, ‘Stira e taglia a MinMax’ e ‘Taglia a MinMax’.

  • Limiti (minimo/massimo) selectstring. ‘Taglio del conteggio cumulativo pixel’, ‘Minimo/Massimo’, ‘Media +/- deviazione standard’

  • Limiti di taglio del conteggio cumulativo pixel

  • Moltiplicatore deviazione standard

Debugging

  • Mostra questi eventi nel pannello dei messaggi di log (nella scheda di visualizzazione checkbox Aggiornamento della visualizzazione della mappa

Menu Mappa & Legenda

Aspetto della mappa (modificato dalle proprietà del progetto)

  • Scegli un Colore della selezione e un Colore di sfondo

Legenda dei layer

  • Azione eseguita in legenda sul comando doppio click selectstring. Puoi scegliere fra ‘Apri proprietà layer’ oppure ‘Apri tabella degli attributi’ facendo doppio click sul layer.

  • è possibile scegliere diverse opzioni per gli Stili elementi legenda

    • checkbox Nomi dei layer in maiuscolo

    • checkbox Nomi dei layer in grassetto

    • checkbox Nomi gruppo in grassetto

    • checkbox Visualizza nomi di classificazione degli attributi

    • checkbox Crea le icone raster (potrebbe essere lento)

    • checkbox Aggiungi nuovi layer al gruppo selezionato

Menu Strumenti mappa

Informazioni

  • checkbox Apri i risultati di un’interrogazione in una finestra agganciata (richiede il riavvio di QGIS)

  • L’impostazione Modalità determina quali layer saranno mostrati attraverso lo strumento ’Informazioni elementi’. Passando a “Top down” o “Il primo attivo” invece di “Layer in uso” gli attributi di tutti i layer selezionabili (Si veda la Sezione Proprietà progetto in: Progetti sulle modalità di impostazione dei layer selezionabili) saranno visibili tramite lo strumento Informazioni elementi.

  • checkbox Apri il modulo degli elementi se viene identificato un un singolo elemento

  • Specificare il raggio di ricerca come percentuale della larghezze della mappa

Strumenti di misura

  • Colore elastico

  • Posizioni decimali

  • checkbox Mantieni le unità di base

  • Unità di misura preferita radiobuttonon (‘metri’ o ‘piedi’)`

  • Unità preferite per gli angoli radiobuttonon (‘Gradi’, ‘Radianti’ o ‘Gradi decimali’)

Spostamento e zoom

  • Define Mouse wheel action selectstring (‘Zoom’, ‘Zoom and recenter’, ‘Zoom to mouse cursor’, ‘Nothing’)
  • Fattore di zoom

Scale preimpostate

Qui trovi un elenco di scale preimpostate. Con i pulsanti ‘+’ e ‘-‘ puoi aggiungere ed eliminare altre scale.

Menu Digitalizzazione

Creazione di geometrie

  • checkbox Non aprire la finestra degli attributi dopo la creazione di ogni geometria

  • checkbox Ripeti i valori degli attributi usati per ultimi

  • Verifica le geometrie. Modificare linee/poligoni con molti nodi può portare a una visualizzazione molto lenta: questo succede perché le procedura di verifica delle geometrie in QGIS richiede molto tempo. Per velocizzare la visualizzazione è possibile selezionare GEOS (GEOS 3.3) dal menu a tendina oppure disattivare del tutto la verifica. La verifica effettuata da GEOS è molto più rapida, ma ha lo svantaggio di comunicare solamente il primo problema geometrico rilevato.

Elastico

  • Definisci le proprietà dell’elastico, Spessore della linea e Colore della linea

Snapping

  • checkbox Apri le opzioni di snap in una finestra agganciata (richiede il riavvio di QGIS)

  • Imposta la Modalità di snap predefinita selectstring (‘Al vertice’, ‘Al segmento’, ‘Al vertice e al segmento’, ‘Spento’)

  • Imposta la Tolleranza di snapping predefinita in unità di mappa o pixel

  • Imposta il Raggio di ricerca per le modifiche dei vertici in unità di mappa o in pixel

Indicatori di vertice

  • checkbox Utilizza indicatori solo per le geometrie selezionate

  • Imposta lo Stile indicatore selectstring (‘Croce’ (predefinito), ‘Cerchio semi trasparente’ o ‘Nessuno’)

  • Specifica le Dimensioni indicatore

Strumento per la curva di offset

Le 3 opzioni successive si riferiscono allo strumento mActionOffsetCurve Curva di offset in Digitalizzazione avanzata. Attraverso i vari settaggi è possibile influenzare la forma della linea di offset. Queste opzioni sono possibili da GEOS 3.3.

  • Stile di unione per l’offset

  • Segmenti di quadrante

  • Limite di smussatura per l’offset

Menu GDAL

GDAL è una libreria di lettura e scrittura per file raster. In questa scheda puoi Modificare le opzioni di creazione e Modificare le opzioni per le piramidi

Menu SR

SR predefinito per nuovi progetti

  • checkbox Abilita automaticamente la riproiezione al volo se i layer hanno SR differente

  • checkbox Effettua sempre la riproiezione al volo

  • Seleziona un SR e Inizia un nuovo progetto sempre con questo SR

SR per i nuovi layer

Questa sezione permette di specificare il comportamento di QGIS quando viene creato un nuovo layer oppure quando viene caricato un layer privo di SR.

  • radiobuttonon Richiedi SR

  • radiobuttonoff Usa il SR del progetto

  • radiobuttonoff Utilizza come predefinito SR visualizzato sotto

Lingua

  • checkbox Sovrascrivi lingua in uso

  • Informazioni sulla lingua correntemente impostata nel sistema

Rete

Generale

  • Indirizzo di ricerca WMS (Quello predefinito è “http://geopole.org/wms/search?search=%1&type=rss”)

  • Imposta il Timeout per le richieste di rete (ms) - il valore predefinito è 60000

  • Imposta il Periodo di scadenza predefinito per piastrelle WMSC/WMTS (ore) - valore standard è 24

Figure Network Tab:

../../../_images/proxy-settings.png

Impostazioni dei proxy in QGIS

Impostazioni della cache

Specifica la Cartella e la Dimensione per la cache.

  • checkbox Utilizza un proxy per l’accesso web, definizione di host, porta, utente e password.

  • Definizione del Tipo proxy selectstring.

    • Default Proxy:Il proxy è determinato sulla base delle impostazioni in uso del proxy dell’applicazione

    • Socks5Proxy: Proxy generico per ogni tipo di connessione. Supporta TCP, UDP, associazione a una porta (connessione in entrata) e autenticazione.

    • HttpProxy: Realizzato usando il comando “CONNECT”, supporta solamente connessioni TCP in uscita; supporta l’autenticatione.

    • HttpCachingProxy: Realizzato usando normali comandi HTTP, è utile solamente nel contesto di richieste HTTP

    • FtpCachingProxy: Realizzato usando un proxy FTP, è utile solamente nel contesto di richieste FTP

È possibile escludere alcuni URL aggiungendo il testo nella sezione dedicata (vedi Figure_Network_Tab).

Per informazioni più dettagliate sulle diverse impostazioni del proxy, si prega di fare riferimento al manuale della documentazione delle librerie QT suhttp://doc.trolltech.com/4.5/qnetworkproxy.html#ProxyType-enum.

Suggerimento

UTILIZZO DEI PROXY

L’utilizzo dei proxy può a volte essere complicato. E’ utile testare i tipi di proxy succitati e controllare il loro funzionamento nel vostro caso specifico.

Queste opzioni possono essere modificate in funzione delle proprie esigenze. Alcuni cambiamenti potrebbero richiedere il riavvio di QGIS prima di essere attivi.

  • nix, le impostazioni sono salvate in un file di testo:

  • |osx|puoi trovare le impostazioni in: $HOME/Library/Preferences/org.qgis.qgis.plist

  • win le impostazioni sono salvate nel resistro: HKEY\CURRENT_USER\Software\QGIS\qgis

Personalizzazione

Lo strumento di personalizzazione permette di attivare/disattivare praticamente qualunque elemento dell’interfaccia di QGIS. Questa possibilità è molto utile se sono stati installati molti plugin che vengono usati raramente e che riempiono lo schermo.

Figure Customization 1:

../../../_images/customization.png

Finestra di dialogo Personalizzazione nix

Il menu Personalizzazione di QGIS è diviso in cinque gruppi. In checkbox Menu è possibile nascondere funzioni all’interno della Barra dei Menu. In checkbox Panelli puoi trovare tutti i pannelli presenti in QGIS. I pannelli sono applicazioni che possono essare avviate e usate come finestre mobili, fisse oppure possono essere incorporate nella finestra principale di QGIS come se fossero dei widget (see also Pannelli e Barre degli strumenti). In checkbox Barra di stato è possibile disattivare caratteristiche come le informazioni sulle coordinate. In checkbox Barra degli strumenti è possibile attivare/disattivare le icone della barra degli strumenti di QGIS e in checkbox Widgets si possono attivare/disattivare i diversi pannelli presenti in QGIS.

Con mActionSelect Passa ai widget per la cattura nell’applicazione principale è possibile cliccare sugli elementi di QGIS che si intendono nascondere dall’interfaccia e trovarli nel menu Personalizzazione (vedi figure_customization). È possibile anche salvare le diverse impostazioni a seconda dei diversi utilizzi. Prima che i cambiamenti diventino effettivi è necessario riavviare QGIS.