7. QGIS GUI

The QGIS graphical user interface (GUI) is shown in the figure below (the numbers 1 through 5 in yellow circles indicate important elements of the QGIS GUI, and are discussed below).

../../../_images/startup.png

Fig. 7.1 QGIS GUI con i dati di esempio Alaska

Nota

L’aspetto delle finestre (barra del titolo, ecc.) potrà apparire diverso a seconda del sistema operativo e dell’ambiente desktop.

The main QGIS GUI (Fig. 7.1) consists of five components / component types:

  1. Menu Bar

  2. Toolbars

  3. Panels

  4. Map View

  5. Status Bar

Scroll down for detailed explanations of these.

7.2. Pannelli e Barre degli strumenti

From the View menu (or kde Settings), you can switch QGIS widgets (Panels ‣) and toolbars (Toolbars ‣) on and off. To (de)activate any of them, right-click the menu bar or toolbar and choose the item you want. Panels and toolbars can be moved and placed wherever you like within the QGIS interface. The list can also be extended with the activation of Core or external plugins.

7.2.1. Barre degli strumenti

The toolbars provide access to most of the functions in the menus, plus additional tools for interacting with the map. Each toolbar item has pop-up help available. Hover your mouse over the item and a short description of the tool’s purpose will be displayed.

Puoi spostare a piacimento ogni barra in funzione delle tue esigenze. Inoltre puoi disattivare ogni barra cliccando con il tasto destro sulla barra degli strumenti disattivando la voce relativa nel menu.

../../../_images/toolbars1.png

Fig. 7.2 Il menu Barra degli strumenti

Suggerimento

Ripristinare le barre degli strumenti

If you have accidentally hidden a toolbar, you can get it back using View ‣ Toolbars ‣ (or kde Settings ‣ Toolbars ‣). If, for some reason, a toolbar (or any other widget) totally disappears from the interface, you’ll find tips to get it back at restoring initial GUI.

7.2.2. Pannelli

QGIS provides many panels. Panels are special widgets that you can interact with (selecting options, checking boxes, filling values…) to perform more complex tasks.

../../../_images/panels.png

Fig. 7.3 Il menu Pannelli

Below is a list of the default panels provided by QGIS:

7.3. Mappa

7.3.1. Exploring the map view

The map view (also called Map canvas) is the «business end» of QGIS — maps are displayed in this area. The map displayed in this window will reflect the rendering (symbology, labeling, visibilities…) you applied to the layers you have loaded. It also depends on the layers and the project’s Coordinate Reference System (CRS).

When you add a layer (see e.g. Accedere ai dati), QGIS automatically looks for its CRS. If a different CRS is set by default for the project (see Sistemi di Riferimento delle coordinate e Progetti) then the layer extent is «on-the-fly» translated to that CRS, and the map view is zoomed to that extent if you start with a blank QGIS project. If there are already layers in the project, no map canvas resize is performed, so only features falling within the current map canvas extent will be visible.

While the focus is over the map view:

  • it can be panned, shifting the display to another region of the map: this is performed using the pan Pan Map tool, the arrow keys, moving the mouse while any of the Space key, the middle mouse button or the mouse wheel is held down.

  • it can be zoomed in and out, with the dedicated zoomIn Zoom In and zoomIn Zoom Out tools. This is also performed by rolling the wheel forward to zoom in and backwards to zoom out. The zoom is centered on the mouse cursor position.

    You can customize the Zoom factor under the Settings ‣ Options ‣ Map tools menu.

  • it can be zoomed to the full extent of loaded layers (zoomFullExtent Zoom Full), to a layer extent (zoomToLayer Zoom to Layer) or to the extent of selected features (zoomToSelected Zoom to Selection)

  • you can navigate back/forward through canvas view history with the zoomLastZoom Last and zoomNextZoom Next buttons or using the back/forward mouse buttons.

By default, QGIS opens a single map view (so called «main map»), which is tightly bound to the Layers panel; the main map automatically reflects the changes you make in the Layers panel area. But it’s possible to have additional map views to preview different renderings of your dataset, side by side; while still relying on the layers properties as set in the Layers panel, each map view can display a different set of layers at different scale and extent.

7.3.2. Setting additional map views

To add a new map view, go to View ‣ newMap New Map View. A new floating widget displaying the layers rendering is added to QGIS. You can add as many map views as you need. They can be kept floating, placed side by side or stacked on top of each other.

../../../_images/map_views.png

Fig. 7.4 Multiple map views with different settings

At the top of an additional map canvas, there’s a toolbar with following capabilities:

  • zoomFullExtent Zoom Full, zoomToSelected Zoom to Selection and zoomToLayer Zoom to Layer to navigate within the view

  • showMapTheme Set View Theme to select the map theme to display in the map view. If set to (none), the view will follow the Layers panel changes.

  • options View settings to configure the map view:

    • radioButtonOn Synchronize view center with main map: syncs the center of the map views without changing the scale. This allows you to have an overview style or magnified map which follows the main canvas center.

    • radioButtonOff Synchronize view to selection: same as zoom to selection

    • Scale

    • Rotation

    • Magnification

    • unchecked Synchronize scale with the main map scale. A Scale factor can then be applied, allowing you to have a view which is e.g. always 2x the scale of the main canvas.

    • checkbox Show annotations

    • checkbox Show cursor position

    • unchecked Show main canvas extent

    • checkbox Show labels: allows to hide labels regardless they are set in the displayed layers” properties

    • Change map CRS…

    • Rename view…

7.3.3. Exporting the map view

Maps you make can be layout and exported to various formats using the advanced capabilities of the print layout or report. It’s also possible to directly export the current rendering, without a layout. This quick «screenshot» of the map view has some convenient features.

To export the map canvas with the current rendering:

  1. Go to Project ‣ Import/Export

  2. Depending on your output format, select either

    • saveMapAsImage Esporta Mappa come Immagine…

    • or saveAsPDF Export Map to PDF…

The two tools provide you with a common set of options. In the dialog that opens:

../../../_images/saveMapAsImage.png

Fig. 7.5 The Save Map as Image dialog

  1. Choose the Extent to export: it can be the current view extent (the default), the extent of a layer or a custom extent drawn over the map canvas. Coordinates of the selected area are displayed and manually editable.

  2. Enter the Scale of the map or select it from the predefined scales: changing the scale will resize the extent to export (from the center).

  3. Set the Resolution of the output

  4. Control the Output width and Output height in pixels of the image: based by default on the current resolution and extent, they can be customized and will resize the map extent (from the center). The size ratio can be locked, which may be particularly convenient when drawing the extent on the canvas.

  5. checkbox Draw active decorations: in use decorations (scale bar, title, grid, north arrow…) are exported with the map

  6. checkbox Draw annotations to export any annotation

  7. checkbox Append georeference information (embedded or via world file): depending on the output format, a world file of the same name (with extension PNGW for PNG images, JPGW for JPG, …) is saved in the same folder as your image. The PDF format embeds the information in the PDF file.

  8. When exporting to PDF, more options are available in the Save map as PDF… dialog:

    ../../../_images/saveMapAsPDF.png

    Fig. 7.6 The Save Map as PDF dialog

    • checkbox Export RDF metadata of the document such as the title, author, date, description…

    • unchecked Create Geospatial PDF (GeoPDF): Generate a georeferenced PDF file (requires GDAL version 3 or later). You can:

      • Choose the GeoPDF Format

      • checkbox Include vector feature information in the GeoPDF file: will include all the geometry and attribute information from features visible within the map in the output GeoPDF file.

      Nota

      Since QGIS 3.10, with GDAL 3 a GeoPDF file can also be used as a data source. For more on GeoPDF support in QGIS, see https://north-road.com/2019/09/03/qgis-3-10-loves-geopdf/.

    • Rasterize map

    • checkbox Simplify geometries to reduce output file size: Geometries will be simplified while exporting the map by removing vertices that are not discernably different at the export resolution (e.g. if the export resolution is 300 dpi, vertices that are less than 1/600 inch apart will be removed). This can reduce the size and complexity of the export file (very large files can fail to load in other applications).

    • Set the Text export: controls whether text labels are exported as proper text objects (Always export texts as text objects) or as paths only (Always export texts as paths). If they are exported as text objects then they can be edited in external applications (e.g. Inkscape) as normal text. BUT the side effect is that the rendering quality is decreased, AND there are issues with rendering when certain text settings like buffers are in place. That’s why exporting as paths is recommended.

  9. Click Save to select file location, name and format.

    When exporting to image, it’s also possible to Copy to clipboard the expected result of the above settings and paste the map in another application such as LibreOffice, GIMP…

7.4. Visualizzazione Mappa 3D

3D visualization support is offered through the 3D map view. You create and open a 3D map view via View ‣ new3DMap New 3D Map View. A floating QGIS panel will appear. The panel can be docked.

To begin with, the 3D map view has the same extent and view as the 2D main map canvas. A set of navigation tools are available to turn the view into 3D.

../../../_images/3dmapview.png

Fig. 7.7 The 3D Map View dialog

The following tools are provided at the top of the 3D map view panel:

  • pan Camera control: moves the view, keeping the same angle and direction of the camera

  • zoomFullExtent Zoom Full: resizes the view to the whole layers” extent

  • 3dNavigation Toggle on-screen notification: shows/hides the navigation widget (that is meant to ease controlling of the map view)

  • identify Identify: returns information on the clicked point of the terrain or the clicked 3D feature(s) – More details at Informazione Elementi

  • measure Measurement line: measures the horizontal distance between points

  • play Animations: shows/hides the animation player widget

  • saveMapAsImage Save as image…: exports the current view to an image file format

  • options Configure the map view settings

7.4.2. Creating an animation

An animation is based on a set of keyframes - camera positions at particular times. To create an animation:

  1. Toggle on the play Animations tool, displaying the animation player widget

  2. Click the signPlus Add keyframe button and enter a Keyframe time in seconds. The Keyframe combo box now displays the time set.

  3. Using the navigation tools, move the camera to the position to associate with the current keyframe time.

  4. Repeat the previous steps to add as many keyframes (with time and position) as necessary.

  5. Click the play button to preview the animation. QGIS will generate scenes using the camera positions/rotations at set times, and interpolating them in between these keyframes. Various Interpolation modes for animations are available (eg, linear, inQuad, outQuad, inCirc… – more details at https://doc.qt.io/qt-5/qeasingcurve.html#EasingFunction-typedef).

    The animation can also be previewed by moving the time slider. Keeping the refresh Repeat button pressed will repeatedly run the animation while clicking play stops a running animation.

It is possible to browse the different views of the camera, using the Keyframe list. Whenever a time is active, changing the map view will automatically update the associated position. You can also symbologyEdit Edit keyframe (time only) or signMinus Remove keyframe.

Click fileSave Export animation frames to generate a series of images representing the scene. Other than the filename Template and the Output directory, you can set the number of Frames per second, the Output width and Output height.

7.4.3. Scene Configuration

The 3D map view opens with some default settings you can customize. To do so, click the options Configure… button at the top of the 3D canvas panel to open the 3D configuration window.

../../../_images/3dmapconfiguration.png

Fig. 7.8 The 3D Map Configuration dialog

In the 3D Configuration window there are various options to fine-tune the 3D scene:

  • Camera’s Field of view: allowing to create panoramic scenes. Default value is 45°.

  • Terrain: Before diving into the details, it is worth noting that terrain in a 3D view is represented by a hierarchy of terrain tiles and as the camera moves closer to the terrain, existing tiles that do not have sufficient details are replaced by smaller tiles with more details. Each tile has mesh geometry derived from the elevation raster layer and texture from 2D map layers.

    • The elevation terrain Type can be:

    • Elevation: Raster layer to be used for generation of the terrain. This layer must contain a band that represents elevation.

    • Vertical scale: Scale factor for vertical axis. Increasing the scale will exaggerate the height of the landforms.

    • Tile resolution: How many samples from the terrain raster layer to use for each tile. A value of 16px means that the geometry of each tile will consist of 16x16 elevation samples. Higher numbers create more detailed terrain tiles at the expense of increased rendering complexity.

    • Altezza bordo: A volte è possibile vedere piccole crepe tra le mattonelle del terreno. Aumentando questo valore si aggiungono pareti verticali («bordi») intorno alle mattonelle del terreno per nascondere le crepe.

    • Map theme: Allows you to select the set of layers to display in the map view from predefined map themes.

  • unchecked Terrain shading: Allows you to choose how the terrain should be rendered:

    • Shading disabled - terrain color is determined only from map texture

    • Shading enabled - terrain color is determined using Phong’s shading model, taking into account map texture, the terrain normal vector, scene light(s) and the terrain material’s Ambient and Specular colors and Shininess

  • Lights: You can add up to eight point lights, each with a particular position (in X, Y and Z), Color, Intensity and Attenuation.

    ../../../_images/3dmapconfiguration_lights.png

    Fig. 7.9 The 3D Map Lights Configuration dialog

  • Risoluzione mattonelle Mappa: Larghezza e altezza delle immagini della mappa 2D usate come suddivisione in mattonelle del terreno. 256px significa che ogni mattonella sarà visualizzata in un’immagine di 256x256 pixel. Un numero più alto crea mattonelle di terreno più dettagliate a scapito di una maggiore complessità di visualizzazione.

  • Max. errore di schermo: Determina la soglia per sostituire le mattonelle del terreno con altre più dettagliate (e viceversa) - cioè quanto tempo la vista 3D utilizzerà mattonelle di qualità superiore. Un numero inferiore significa maggiori dettagli della scena a scapito di una maggiore complessità di visualizzazione.

  • Max. errore al suolo: La risoluzione delle mattonelle del terreno in cui si interrompe la divisione delle mattonelle in mattonelle più dettagliate (dividerle non introdurrebbe comunque alcun dettaglio in più). Questo valore limita la profondità della gerarchia delle mattonelle: valori più bassi rendono la gerarchia profonda, aumentando la complessità di visualizzazione.

  • Zoom labels: Mostra il numero di livelli di zoom (dipende dalla risoluzione delle mattonelle della mappa e dall’errore massimo al suolo).

  • unchecked Mostra etichette: Attiva/disattiva le etichette della mappa

  • unchecked Mostra le info sulle mattonelle della mappa: Include i numeri delle mattonelle di confine e delle mattonelle del terreno (utile per la soluzione delle tematizzazioni del terreno).

  • unchecked Mostra i perimetri di delimitazione: Mostra i perimetri di delimitazione 3D delle mattonelle del terreno (utile per la soluzione delle tematizzazioni del terreno)

  • unchecked Mostra il centro di ripresa della fotocamera

7.4.4. Layer vettoriali 3D

Un layer vettoriale con valori di elevazione può essere mostrato nella mappa 3D controllando Configura nella scheda Nuova mappa 3D delle proprietà del layer vettoriale. Sono disponibili diverse opzioni per controllare la visualizzazione del layer vettoriale 3D.

7.5. Barra di Stato

La barra di stato ti fornisce informazioni generali sulla visualizzazione della mappa e sulle azioni elaborate o disponibili e ti offre strumenti per gestire la visualizzazione della mappa.

Sul lato sinistro della barra di stato, la barra di localizzazione, un widget di ricerca rapida, ti aiuta a trovare ed eseguire qualsiasi funzione o opzione in QGIS. Basta digitare il testo associato all’elemento che stai cercando (nome, tag, parola chiave….) e ottieni una lista che si aggiorna mentre scrivi. Puoi anche limitare la portata della ricerca usando locator filters. Fai clic sul pulsante search per selezionare uno qualsiasi di essi e premi la voce Configura per le impostazioni globali.

Nell’area accanto alla barra di localizzazione, quando necessario ti verrà mostrato un riepilogo delle azioni eseguite (come la selezione di elementi in un layer, la rimozione del layer) o una completa descrizione dello strumento su cui si passa sopra (non disponibile per tutti gli strumenti).

In caso di lunghe operazioni, come l’acquisizione di statistiche in layer raster, l’esecuzione di algoritmi di elaborazione o la visualizzazione di più layer nella mappa, nella barra di stato viene visualizzata una barra dello stato di avanzamento.

L’opzione tracking Coordinate mostra la posizione corrente del mouse, seguendolo durante lo spostamento sulla mappa. Puoi impostare le unità di misura (e la precisione) nella scheda Progetto ‣ Proprietà… ‣ Generale. Clicca sul piccolo pulsante a sinistra della casella di testo per passare dall’opzione Coordinate all’opzione extents Estensioni che mostra le coordinate in unità mappa degli attuali angoli in basso a sinistra e in alto a destra della mappa.

Accanto al display delle coordinate si trova il display Scala. Mostra la scala della visualizzazione della mappa. C’è un selettore di scala, che permette di scegliere tra predefined and custom scales.

Sul lato destro del display della scala, premi il pulsante lockedGray per bloccare la scala e utilizza la lente di ingrandimento per ingrandire o ridurre lo zoom. La lente d’ingrandimento consente di ingrandire una mappa senza alterare la scala della mappa, rendendo più facile modificare con precisione la posizione delle etichette e dei simboli. Il livello di ingrandimento è espresso in percentuale. Se Livello di ingrandimento ha un livello del 100%, allora la mappa corrente non viene ingrandita. Inoltre, un valore di ingrandimento predefinito può essere impostato all’interno di Impostazioni ‣ Opzioni… ‣ Visualizzazione ‣ Livello ingrandimento, che è molto utile per schermi ad alta risoluzione per ingrandire simboli piccoli.

A destra della scala puoi definire la rotazione corrente in gradi in senso orario della mappa.

Sul lato destro della barra di stato, c’è una piccola casella di controllo che può essere usata temporaneamente per impedire che i layeri vengano aggiornati nella visualizzazione mappa (vedi la sezione Visualizzazione).

A destra delle funzioni di visualizzazione, trovi il pulsante projectionEnabled EPSG:code che mostra il SR del progetto corrente. Cliccando su questo pulsante si apre la finestra di dialogo Proprietà progetto e ti consente di applicare un altro SR alla visualizzazione della mappa.

Il pulsante messageLog Messages accanto ad esso apre il pannello Messaggi di Log che contiene informazioni sui processi in corso (attivazione di QGIS, caricamento di plugin, strumenti di processing….).

A seconda di Plugin Manager settings, la barra di stato può a volte mostrare icone a destra per informarti sulla disponibilità di plugin pluginNew nuovi o pluginUpgrade aggiornabili. Clicca sull’icona per aprire la finestra di dialogo Plugin.

Suggerimento

Calcolare la scala corretta della mappa

Quando avvii QGIS, il SR predefinito è WGS 84 (EPSG 4326) e le unità di misura sono i gradi. Ciò significa che QGIS interpreterà qualsiasi coordinata del layer come specificato in gradi. Per ottenere valori di scala corretti, è possibile modificare manualmente questa impostazione nella scheda Generale sotto Progetto ‣ Proprietà… (ad es. ai metri), oppure è possibile utilizzare l’icona projectionEnabled EPSG:code vista sopra. In quest’ultimo caso, le unità sono impostate a quanto specificato dalla proiezione del progetto (ad esempio, +units=us-ft).

Da notare che la scelta del sistema SR di partenza può essere fatta in Impostazioni ‣ Opzioni ‣ SR.