24.2.3. Plugin eVis

(This section is derived from Horning, N., K. Koy, P. Ersts. 2009. eVis (v1.1.0) User’s Guide. American Museum of Natural History, Center for Biodiversity and Conservation. Available from https://www.amnh.org/research/center-for-biodiversity-conservation/capacity-development/biodiversity-informatics, and released under the GNU FDL.)

Il Centro per la Biodiversità e la Conservazione (Center for Biodiversity and Conservation - CBC) presso il Museo Americano di Storia Naturale (American Museum of Natural History’s - AMNH) ha sviluppato lo strumento Event Visualization Tool (eVis), un altro strumento software aggiunto alla suite di strumenti di monitoraggio e di supporto decisionale per la conservazione e guida dell’area protetta e del piano paesaggistico. Questo plugin consente agli utenti di collegare facilmente dati geocodificati (ad esempio, con latitudine e longitudine o X e Y Coordinate) quali fotografie e altri documenti di supporto ai dati vettoriali in QGIS.

eVis è ora automaticamente installato e abilitato nelle nuove versioni di QGIS, e come tutti i plugin, può essere disattivato e abilitato utilizzando il Plugin Manager (vedi La finestra di dialogo Plugins).

Il plugin consta di tre moduli: “Connessione Database”, “ID evento”, “Browser evento”. Questi funzionano insieme per consentire la visualizzazione di fotografie geocodificate e altri documenti collegati a oggetti memorizzati file vettoriali, database o fogli di calcolo.

24.2.3.1. Browser evento

Il modulo “Sfoglia Evento” fornisce la funzionalità per visualizzare le fotografie geocodificate collegate alle geometrie vettoriali visualizzate nella finestra della mappa di QGIS. I dati dei punti, ad esempio, possono provenire da un file vettoriale che può essere inserito utilizzando QGIS o può derivare dal risultato di una query al database. La geometria vettoriale deve contenere le informazioni sugli attributi ad essa associati per descrivere la posizione e il nome del file contenente la fotografia e, facoltativamente, la direzione della bussola a cui è stata puntata la fotocamera quando è stata acquisita l’immagine. Il tuo layer vettoriale deve essere caricato in QGIS prima di eseguire Sfoglia Evento.

24.2.3.1.1. Aprire il modulo Browser evento

Per avviare il modulo Sfoglia Evento, fai click su Database ‣ eVis ‣ Sfoglia evento eVis. Si aprirà la finestra Browser Evento

La finestra Browser evento ha tre schede visualizzate nella parte superiore della finestra. La scheda Visualizza è usata per visualizzare la fotografia e i suoi dati di attributo associati. La scheda Opzioni fornisce un numero di impostazioni che possono essere regolate per controllare il comportamento del plugin eVis. Infine, la scheda Configura Applicazioni Esterne serve per mantenere una tabella delle estensioni dei file e le loro associate applicazioni per consentire a eVis di visualizzare documenti diversi dalle immagini.

24.2.3.1.2. Finestra Visualizza

Per visualizzare la finestra Visualizza, fai click sulla scheda Visualizza nella finestra Browser Evento. La finestra Visualizza è usata per visualizzare le fotografie geocodificate e i relativi dati attributo.

../../../../_images/evisdisplay.png

Fig. 24.11 La finestra di dialogo eVis

  1. Area di visualizzazione dell’immagine: un riquadro in cui sarà mostrata l’immagine.

  2. Pulsante Zoom in: Ingrandisce per mostrare maggiori dettagli. Se l’intera immagine non può essere visualizzata nella finestra di visualizzazione, appariranno barre di scorrimento sul lato sinistro e inferiore della finestra per consentire di far scorrere l’immagine.

  3. Rimpicciolisci: rimpicciolisce per vedere più parti dell’immagine.

  4. Zoom completo: visualizza tutta l’immagine.

  5. Finestra degli attributi: qui vengono visualizzate tutte le informazioni sugli attributi per il punto associato alla fotografia visualizzata. Se il tipo di file a cui si fa riferimento nel record visualizzato non è un’immagine ma è di un tipo di file definito in Configura applicazioni esterne, facendo doppio clic sul valore del campo contenente il percorso del file, verrà avviata l’applicazione per aprire il file da visualizzare o ascoltare il contenuto del file. Se l’estensione del file viene riconosciuta, i dati dell’attributo verranno visualizzati in verde.

  6. Pulsanti per la navigazione: utilizzare i pulsanti Precedente e Successivo per caricare l’oggetto precedente o successivo quando è selezionato più di un oggetto.

24.2.3.1.3. Finestra Opzioni

../../../../_images/evisoptions.png

Fig. 24.12 Opzioni della finestra di dialogo eVis

  1. Percorso file: elenco a discesa per specificare l’attributo campo contenente il percorso o l’URL della directory per le fotografie o altri documenti visualizzati. Se la posizione è un percorso relativo, la casella di controllo deve essere attivata. Il percorso di base per un percorso relativo può essere immesso nella casella di testo Percorso base sottostante. Informazioni sulle diverse opzioni per specificare la posizione del file sono indicate in basso nella sezione Specificare la localizzazione ed il nome di una foto

  2. Orientamento bussola: un elenco a discesa per specificare il campo dell’attributo che contiene l’orientamento della bussola associato alla fotografia visualizzata. Se sono disponibili informazioni sulla bussola, è necessario fare clic sulla casella di controllo sotto il titolo del menu a discesa.

  3. Offset bussola: gi offset della bussola possono essere utilizzati per compensare la declinazione (per regolare l’orientamento magnetico all’orientamento del nord effettivo). Fai click sul pulsante radio radioButtonOn Manuale per immettere l’offset nella casella di testo o fai click sul pulsante radio radioButtonOn Da Attributo per selezionare il campo attributo contenente gli offset. Per entrambe queste opzioni, le declinazioni est devono essere immesse usando valori positivi e le declinazioni ovest dovrebbero utilizzare valori negativi.

  4. Percorso base della cartella: il percorso base su cui verrà associato il percorso relativo definito in Figure_eVis_options (A).

  5. Sostituisci percorso: se è selezionata questa casella di controllo, solo il nome di file in A verrà aggiunto al percorso base.

  6. Applica regola a tutti i documenti: se selezionato, le stesse regole di percorso definite per le fotografie verranno utilizzate per documenti non di immagine, ad esempio filmati, documenti di testo e file audio. Se non è selezionato, le regole del percorso si applicano solo alle fotografie e gli altri documenti ignoreranno il parametro del percorso base.

  7. Ricorda le impostazioni: Se la casella di controllo è selezionata, i valori dei parametri associati saranno salvati per la sessione successiva quando la finestra viene chiusa o quando viene premuto il pulsante Salva in basso.

  8. Ripristina: Ripristina i valori di questa riga all’impostazione predefinita.

  9. Ripristina le impostazioni predefinite: Tutti i campi verranno ripristinati alle impostazioni predefinite. Ha lo stesso effetto di fare clic su tutti i pulsanti Ripristina.

  10. Salva: salva le impostazioni senza chiudere la scheda Opzioni.

24.2.3.1.4. Configurazione applicazioni esterne

../../../../_images/evisexternal.png

Fig. 24.13 La finestra Applicazioni Esterne di eVis

  1. Tabella riferimento file: una tabella contenente i vari tipi di file utilizzati da eVis. Ogni tipo file necessita di un’estensione e di un percorso all’applicazione in grado di gestirlo. Ciò permette di aprire diversi tipi di file come filmati, suoni e documenti testuali, oltre che solo immagini.

  2. Aggiungi nuovo tipo file: aggiunge un nuovo tipo di file con una univoca estensione e il percorso dell’applicazione che può aprire il file.

  3. Elimina riga corrente: elimina il tipo di file selezionato in tabellae definito da un’estensione di file e da un percorso ad un’applicazione associata.

24.2.3.2. Specificare la localizzazione ed il nome di una foto

La posizione e il nome della fotografia possono essere memorizzati utilizzando un percorso assoluto o relativo, o un URL se la fotografia è disponibile su un server web. Esempi dei diversi approcci sono elencati nella tabella evis_examples.

X        Y        FILE                                                BEARING
780596   1784017  C:\Workshop\eVis_Data\groundphotos\DSC_0168.JPG     275
780596   1784017  /groundphotos/DSC_0169.JPG                          80
780819   1784015  https://biodiversityinformatics.amnh.org/\
                  evis_testdata/DSC_0170.JPG                          10
780596   1784017  pdf:https://www.testsite.com/attachments.php?\
                  attachment_id-12                                    76

24.2.3.3. Specificare la localizzazione ed il nome di altri documenti

Anche i documenti di supporto come documenti di testo, video e clip audio possono essere visualizzati o riprodotti da eVis. Per fare ciò, è necessario aggiungere una voce nella tabella di riferimento dei file a cui è possibile accedere dalla finestra Configura applicazioni esterne in Browser eventi generici che corrisponde all’estensione del file a un’applicazione che può essere usato per aprire il file. È inoltre necessario avere il percorso o l’URL del file nella tabella degli attributi per il layer vettoriale. Una regola aggiuntiva che può essere utilizzata per gli URL che non contengono un’estensione di file per il documento che si desidera aprire è specificare l’estensione del file prima dell’URL. Il formato è — file extension:URL. L’URL è preceduto dall’estensione del file e da due punti; questo è particolarmente utile per accedere ai documenti da wiki e altri siti Web che utilizzano un database per gestire le pagine Web (vedi Tabella evis_examples).

24.2.3.4. Usare Browser evento

Quando si apre la finestra Browser eventi”, una fotografia apparirà nella finestra di visualizzazione se il documento a cui si fa riferimento nella tabella degli attributi del file vettoriale è un’immagine e se le informazioni sulla posizione del file nella finestra :guilabel:`Opzioni sono correttamente impostate. Se è prevista una fotografia e non appare, sarà necessario regolare i parametri nella finestra Opzioni.

Se nella tabella degli attributi viene fatto riferimento a un documento (o a un’immagine che non ha un’estensione di file riconosciuta da eVis), il campo contenente il percorso del file sarà evidenziato in verde nella finestra delle informazioni sugli attributi se tale estensione di file è definita nel tabella di riferimento dei file situata nella finestra Configura le applicazioni esterne. Per aprire il documento, fare doppio clic sulla linea evidenziata in verde nella finestra delle informazioni sugli attributi. Se viene fatto riferimento a un documento nella finestra delle informazioni sugli attributi e il percorso del file non è evidenziato in verde, sarà necessario aggiungere una voce per l’estensione del file nel file Configura le applicazioni esterne. Se il percorso del file è evidenziato in verde ma non si apre quando si fa doppio clic, sarà necessario regolare i parametri nella finestra Opzioni in modo che il file possa essere localizzato da eVis.

Se non si è specificato l’orientamento della fotocamera nella finestra Opzioni, compare un asterisco rosso sul vettore associato alla fotografia. Se l’orientamento è specificato, allora comparirà una freccia che punterà nella direzione indicata nella finestra Browser evento. La freccia sarà centrata sul punto associato con la fotografia o con un altro documento.

Per chiudere la finestra Browser evento, clicca sul pulsante Chiudi nella finestra Visualizza.

24.2.3.5. Strumento ID evento

Il modulo “ID evento” ti permette di visualizzare una foto cliccando su un elemento nella vista mappa di QGIS. L’elemento vettoriale deve avere associati le informazioni di attributo contenenti la localizzazione ed il nome del file della foto e, eventualmente, la direzione della bussola della fotocamera quando l’immagine è stata acquisita. Questo layer deve essere caricato in QGIS prima di aprire lo strumento “ID evento”.

24.2.3.5.1. Aprire il modulo Browser evento

Per avviare il modulo “ID evento”, fai click sull’icona eventId ID evento o fai click su Database -> eVis -> Strumento ID evento. Ciò farà sì che il cursore si trasformi in una freccia con una “i” sopra di esso a significare che lo strumento ID è attivo.

Per visualizzare le fotografie collegate alle geometrie vettoriali presenti nel livello vettoriale attivo visualizzato nella finestra della mappa QGIS, sposta il cursore ID evento sulla geometria e quindi fai click con il mouse. Dopo aver cliccato sulla funzione, si apre la finestra Browser evento e le fotografie sulla località cliccata o nelle vicinanze sono disponibili per la visualizzazione nel browser. Se è disponibile più di una fotografia, puoi scorrere i diversi elementi utilizzando i pulsanti Precedente e Successivo. Altre opzioni di controllo sono presenti nella sezione Browser evento di questa guida.

24.2.3.6. Connessione database

Il modulo “Connessione Database” permette di connettersi ed interrogare un database o altre risorse ODBC, es. un foglio di calcolo.

eVis può connettersi direttamente alle seguenti tipologie di database: PostgreSQL, MySQL, SQLITE; può leggere dati da connessioni ODBC (ad esempio MS Access): in tal caso è necessario configurare il driver ODBC (come ad esempio un foglio Excel) per il sistema operativo che stai usando.

24.2.3.6.1. Aprire il modulo Connessione Database

Per avviare il modulo “Connessione Database”, fai click sull’apposita icona evisConnect Connessione a database eVis o fai clic su Database -> eVis -> Connessione database. Questo lancerà la finestra Connessione Database. La finestra ha tre schede: Query predefinite, Connessione Database e SQL Query. La finestra Console di output nella parte inferiore della finestra mostra lo stato delle azioni avviate dalle diverse sezioni di questo modulo.

24.2.3.6.2. Connessione Database

Fai click sulla scheda Connessione Database per aprire l’interfaccia di connessione al database. Quindi, utilizza Tipo database selectString casella combinata per selezionare il tipo di database a cui ti vuoi connettere. Se è richiesta una password o un nome utente, tali informazioni possono essere inserite nelle caselle di testo Nome utente e Password.

Inserire il server del database in Host Database. Questa opzione non è disponibile se hai scelto “MSAccess” come tipo di database. Se il database si trova sul tuo desktop, allora dovrai inserire «localhost».

Immetti il nome del database nella casella di testo Nome database. Se hai selezionato “ODBC” come tipo di database, devi specificare il nome dell’origine dati.

Quando tutti i parametri sono stati compilati, fai clic sul pulsante Connetti. Se la connessione ha successo, nella finestra Output Console verrà scritto un messaggio che indica che la connessione è stata stabilita. Se non è stata stabilita una connessione, è necessario verificare che siano stati inseriti parametri corretti.

../../../../_images/evisdatabase.png

Fig. 24.14 La finestra connessione Database di eVis

  1. Tipo di Database: una lista a discesa per specificare il tipo di database che sarà utilizzato.

  2. Host Database: nome host del database.

  3. Porta: il numero di porta se il tipo di database selezionato è MYSQL o PostgreSQL.

  4. Nome Database: il nome del database.

  5. Connetti: un pulsante per connettersi al database utilizzando i parametri sopra definiti.

  6. Console di Output: la finestra console dove vengono visualizzati i messaggi relativi alla connessione.

  7. Nome utente: nome utente in caso di database protetto.

  8. Password: password in caso di database protetto.

  9. Query Predefinite: scheda “Query Predefinite”.

  10. Connessione Database: scheda “Connessione Database”.

  11. Query SQL: scheda “Query SQL”.

  12. Help: mostra la guida in linea.

  13. OK: chiude Connessione Database .

24.2.3.6.3. Eseguire query SQL

Le query SQL sono utilizzate per estrarre informazioni da un database o da una risorsa ODBC. In eVis, l’output di queste query è un layer vettoriale aggiunto alla finestra della mappa QGIS. Fai clic sulla scheda Query SQL per visualizzare l’interfaccia delle query SQL. I comandi SQL possono essere inseriti in questa finestra di testo. Un utile tutorial sui comandi SQL è disponibile all’indirizzo https://www.w3schools.com/sql. Per esempio, per estrarre tutti i dati da un foglio di lavoro in un file Excel, select * from [sheet1$] dove sheet1 è il nome del foglio di lavoro.

Fai clic sul pulsante Esegui Query per eseguire il comando. Se la query ha esito positivo, viene visualizzata la finestra Scegli file database. Se la query non ha esito positivo, nella finestra Console di output apparirà un messaggio di errore.

Nella finestra Scegli file Database assegnare un nome al nuovo layer che verrà creato dai risultati della query nella casella di testo Nome del nuovo layer.

../../../../_images/evissql_query.png

Fig. 24.15 La scheda query SQL di eVis

  1. Query SQL: è il riquadro per inserire le query SQL.

  2. Esegui Query: pulsante per mandare in esecuzione la query inserita in Query SQL.

  3. Console di Output: la finestra della console dove vengono visualizzati i messaggi relativi alla connessione.

  4. Help: mostra la guida in linea.

  5. OK: chiude Connessione Database.

Usa le caselle combinate X Coordinate selectString e Y Coordinate selectString per selezionare i campi del database che memorizza le coordinate X (o longitudine) e Y` (o latitudine). Cliccando sul pulsante OK il layer vettoriale creato dalla query SQL viene visualizzato nella finestra della mappa QGIS.

Per salvare questo file vettoriale per uso futuro, puoi utilizzare il comando “Salva come …” di QGIS a cui si accede facendo click con il tasto destro del mouse sul nome del layer nella legenda della mappa QGIS e quindi selezionando “Salva come …”

Suggerimento

Creare un layer vettoriale da un foglio di lavoro Microsoft Excel

Quando crei un layer vettoriale da un foglio di lavoro di Microsoft Excel, puoi vedere che sono stati inseriti zeri indesiderati («0») nelle righe della tabella degli attributi al di sotto dei dati validi. Ciò può essere causato dall’eliminazione dei valori per queste celle in Excel utilizzando la chiave Backspace. Per correggere questo problema, devi aprire il file Excel (devi chiudere QGIS se sei connesso al file, per permetterti di modificare il file) e quindi usare Modifica -> Elimina per rimuovere le righe vuote dal file. Per evitare questo problema, puoi semplicemente cancellare diverse righe nel foglio di lavoro di Excel usando Modifica -> Elimina prima di salvare il file.

24.2.3.6.4. Eseguire query predefinite

Con le query predefinite, puoi selezionare query scritte in precedenza memorizzate in formato XML in un file. Ciò è particolarmente utile se non hai familiarità con i comandi SQL. Fai clic sulla scheda Query predefinite per visualizzare l’interfaccia di query predefinita.

To load a set of predefined queries, click on the folder Open File icon. This opens the Open File window, which is used to locate the file containing the SQL queries. When the queries are loaded, their titles as defined in the XML file will appear in the drop-down menu located just below the folder Open File icon. The full description of the query is displayed in the text window under the drop-down menu.

Seleziona la query che vuoi eseguire dal menu a discesa e quindi fai click sulla scheda Query SQL per verificare che la query sia stata caricata nella finestra della query. Se è la prima volta che sta eseguendo una query predefinita o sta cambiando database, devi assicurarti di essere connesso al database.

Fai clic sul pulsante Esegui Query nella scheda Query SQL per eseguire il comando. Se la query ha esito positivo, viene visualizzata la finestra Selezione file database. Se la query non ha esito positivo, nella finestra Console di Output apparirà un messaggio di errore.

../../../../_images/evispredefined.png

Fig. 24.16 Scheda Query predefinite eVis

  1. Apri file: avvia il browser file «Apri file» per cercare il file XML che contiene le query predefinite.

  2. Query predefinite: un elenco a discesa con tutte le query definite dal file XML delle query predefinite.

  3. Descrizione query: una breve descrizione della query. Questa descrizione proviene dal file XML delle query predefinite.

  4. Console di Output: la finestra della console dove vengono visualizzati i messaggi relativi alla connessione.

  5. Help: mostra la guida in linea.

  6. OK: chiude Connessione Database .

24.2.3.6.5. Formato XML per le query predefinite di eVis

Tag XML letti da eVis

Tag

Descrizione

query

Definisce l’inizio e la fine di una istruzione di query.

shortdescription

Una breve descrizione della query visualizzata nel menu a discesa eVis.

Descrizione

Descrizione più dettagliata che viene mostrata nella casella ’Descrizione query’ di eVis.

databasetype

Il tipo di database, definito nel menu a discesa Tipo database nella scheda Connessione database.

databaseport

La porta di connessione come definita nella casella di teso Porta nella scheda Connessione Database.

databasename

Il nome del database come definito nella casella di testo Nome nella scheda Connessione Database.

databaseusername

Il nome utente del database definito nella casella di testo Nome utente nella scheda Connessione database.

databasepassword

La password del database come definita nella casella di testo Password nella scheda Connessione database.

sqlstatement

Il comando SQL.

autoconnect

A flag («true» or «false») to specify if the above tags should be used to automatically connect to the database without running the database connection routine in the Database Connection tab.

Segue un esempio completo di file XML contenente tre query:

<?xml version="1.0"?>
<doc>
 <query>
   <shortdescription>Import all photograph points</shortdescription>
   <description>This command will import all of the data in the SQLite database to QGIS
      </description>
   <databasetype>SQLITE</databasetype>
   <databasehost />
   <databaseport />
   <databasename>C:\textbackslash Workshop/textbackslash
eVis\_Data\textbackslash PhotoPoints.db</databasename>
   <databaseusername />
   <databasepassword />
   <sqlstatement>SELECT Attributes.*, Points.x, Points.y FROM Attributes LEFT JOIN
      Points ON Points.rec_id=Attributes.point_ID</sqlstatement>
   <autoconnect>false</autoconnect>
 </query>
  <query>
   <shortdescription>Import photograph points "looking across Valley"</shortdescription>
   <description>This command will import only points that have photographs "looking across
      a valley" to QGIS</description>
   <databasetype>SQLITE</databasetype>
   <databasehost />
   <databaseport />
   <databasename>C:\Workshop\eVis_Data\PhotoPoints.db</databasename>
   <databaseusername />
   <databasepassword />
   <sqlstatement>SELECT Attributes.*, Points.x, Points.y FROM Attributes LEFT JOIN
      Points ON Points.rec_id=Attributes.point_ID where COMMENTS='Looking across
      valley'</sqlstatement>
   <autoconnect>false</autoconnect>
 </query>
 <query>
   <shortdescription>Import photograph points that mention "limestone"</shortdescription>
   <description>This command will import only points that have photographs that mention
      "limestone" to QGIS</description>
   <databasetype>SQLITE</databasetype>
   <databasehost />
   <databaseport />
   <databasename>C:\Workshop\eVis_Data\PhotoPoints.db</databasename>
   <databaseusername />
   <databasepassword />
   <sqlstatement>SELECT Attributes.*, Points.x, Points.y FROM Attributes LEFT JOIN
      Points ON Points.rec_id=Attributes.point_ID where COMMENTS like '%limestone%'
      </sqlstatement>
   <autoconnect>false</autoconnect>
 </query>
</doc>