10. Lavorare con le proiezioni

Un Sistema di Riferimento delle Coordinate, o SR, è un metodo per associare coordinate numeriche ad una posizione sulla superficie terrestre. QGIS supporta circa 7.000 SR standard, ognuno con diversi casi d’uso, pro e contro! Scegliere un sistema di riferimento appropriato per i tuoi progetti e dati QGIS può essere un compito complesso, ma fortunatamente QGIS ti aiuta ad orientarti in questa scelta e rende il lavoro con i diversi SR il più trasparente e accurato possibile.

10.1. Panoramica sul supporto alle proiezioni

QGIS supporta circa 7.000 SR noti. Questi SR standard si basano su quelli definiti dall’European Petroleum Search Group (EPSG) e dall’Institut Geographique National de France (IGNF) e sono disponibili in QGIS attraverso la sottostante libreria di proiezione «Proj». Comunemente, queste proiezioni standard sono identificate attraverso l’uso di una combinazione di autorità:codice, dove l’autorità è un nome dell’organizzazione come «EPSG» o «IGNF», e il codice è un numero unico associato a uno specifico SR. Ad esempio, il comune SR WGS 84 latitudine/longitudine è noto con l’identificatore EPSG:4326 e lo standard di mappatura web SR è EPSG:3857.

I SR personalizzati creati dall’utente sono memorizzati in un database SR utente. Vedi la sezione Sistemi di riferimento personalizzati per informazioni sulla gestione dei tuoi Sistemi di Riferimento delle coordinate personalizzate.

10.2. Sistemi di Riferimento delle coordinate e layer

In order to correctly project data into a specific target CRS, either your data must contain information about its coordinate reference system or you will need to manually assign the correct CRS to the layer. For PostGIS layers, QGIS uses the spatial reference identifier that was specified when that PostGIS layer was created. For data supported by OGR or GDAL, QGIS relies on the presence of a recognized means of specifying the CRS. For instance, for the Shapefile format this is a file containing an ESRI Well-Known Text (WKT) representation of the layer’s CRS. This projection file has the same base name as the .shp file and a .prj extension. For example, alaska.shp would have a corresponding projection file named alaska.prj.

Whenever a layer is loaded into QGIS, QGIS attempts to automatically determine the correct CRS for that layer. In some cases this is not possible, e.g. when a layer has been provided without retaining this information. You can configure QGIS behavior whenever it cannot automatically determine the correct CRS for a layer:

  1. Apri Impostazioni ▶ options Opzioni… ▶ SR

    ../../../_images/options_crs1.png

    Fig. 10.1 Scheda SR nella finestra di dialogo opzioni QGIS

  2. Nel gruppo SR per i layer, imposta l’azione da realizzare quando si crea un nuovo layer, o quando si carica un layer privo di SR. Uno tra:

    • radioButtonOn Lascia come SR sconosciuto (nessuna azione): non esegue nessuna richiesta di selezione del SR quando viene caricato un layer senza SR, rimandando la scelta del SR ad un secondo momento. Utile quando si caricano molti layer in una volta sola. Questi layer saranno identificabili nel pannello Layers con l’icona indicatorNoCRS vicina. Saranno anche non georeferenziati, con le coordinate del layer trattate come puramente numeriche, non come valori coerenti con coordinate terrestri, i.e. lo stesso comportamento di tutti i livelli quando un progetto è impostato per non avere SR. <project_crs>`.

    • radioButtonOff Richiedi SR: richiede di selezionare manualmente il SR. Selezionare la scelta corretta è cruciale, poiché una scelta errata posizionerà il tuo layer nel punto sbagliato sulla Terra! Talvolta, i medadata associati descrivono il corretto SR di un layer, in altri casi avrai bisogno di contattare l’autore del data per determinare il corretto SR da associare.

    • radioButtonOff Usa il SR del Progetto

    • radioButtonOff Usa SR del layer predefinito, come impostato nel menu a tendina SR predefinito per i layer sopra.

Suggerimento

To assign the same CRS to multiple layers that have no crs or have a wrong one in one operation:

  1. Select the layers in the Layers panel

  2. Press Ctrl+Shift+C. You could also right-click over one of the selected layers or go to Layer ▶ Set CRS of layer(s)

  3. Find and select the right CRS to use

  4. And press OK. You can confirm that it has been set correctly in the Source tab of the layers” properties dialog.

Note that changing the CRS in this setting does not alter the underlying data source in any way, rather it just changes how QGIS interprets the raw coordinates from the layer in the current QGIS project.

10.3. Sistemi di Riferimento delle coordinate e Progetti

Every project in QGIS also has an associated Coordinate Reference System. The project CRS determines how data is projected from its underlying raw coordinates to the flat map rendered within your QGIS map canvas.

QGIS supports «on the fly» CRS transformation for both raster and vector data. This means that regardless of the underlying CRS of particular map layers in your project, they will always be automatically transformed into the common CRS defined for your project. Behind the scenes, QGIS transparently reprojects all layers contained within your project into the project’s CRS, so that they will all be rendered in the correct position with respect to each other!

È importante fare una scelta appropriata di SR per i tuoi progetti QGIS. La scelta di un SR inappropriato può causare distorsioni delle mappe e riflettere in modo inadeguato le dimensioni e le posizioni degli oggetti rispetto al mondo reale. Di solito, mentre si lavora in aree geografiche più piccole, ci sarà un certo numero di SR standard utilizzati all’interno di un particolare paese o area amministrativa. È importante cercare quali SR sono scelte appropriate o standard per l’area che si sta mappando e assicurarsi che il progetto QGIS segua questi standard.

By default, QGIS starts each new project using a global default projection. This default CRS is EPSG:4326 (also known as «WGS 84»), and it is a global latitude/longitude based reference system. This default CRS can be changed via the CRS for New Projects setting in the CRS tab under Settings ▶ options Options… (see figure_projection_options). There is an option to automatically set the project’s CRS to match the CRS of the first layer loaded into a new project, or alternatively you can select a different default CRS to use for all newly created projects. This choice will be saved for use in subsequent QGIS sessions.

The project CRS can also be set through the CRS tab of the Project ▶ Properties… dialog. It will also be shown in the lower-right of the QGIS status bar.

../../../_images/projectionDialog.png

Fig. 10.2 Finestra di dialogo Proprietà del progetto

Sono disponibili le opzioni:

  • unchecked No projection (or unknown/non-Earth projection): Checking this setting will disable ALL projection handling within the QGIS project, causing all layers and map coordinates to be treated as simple 2D Cartesian coordinates, with no relation to positions on the Earth’s surface. It can be used to guess a layer CRS (based on its raw coordinates or when using QGIS for non earth uses like role-playing game maps, building mapping or microscopic stuff. In this case:

    • No reprojection is done while rendering the layers: features are just drawn using their raw coordinates.

    • The ellipsoid is locked out and forced to None/Planimetric.

    • The distance and area units, and the coordinate display are locked out and forced to «unknown units»; all measurements are done in unknown map units, and no conversion is possible.

  • or an existing coordinate reference system that can be geographic, projected or user-defined. A preview of the CRS extent on earth is displayed to help you select the appropriate one. Layers added to the project are translated on-the-fly to this CRS in order to overlay them regardless their original CRS. Use of units and ellipsoid setting are available and make sense and you can perform calculations accordingly.

Ogni volta che selezioni un nuovo SR per il progetto QGIS, le unità di misura verranno automaticamente modificate nella scheda Generale della finestra di dialogo delle Proprietà progetto (Project ▶ Properties…) per corrispondere al SR selezionato. Ad esempio, alcuni SR definiscono le loro coordinate in piedi invece che in metri, pertanto, impostando il progetto QGIS su uno di questi SR, il tuo progetto verrà anche impostato per utilizzare i piedi come default per le misure.

Suggerimento

Setting the project CRS from a layer

You can assign a CRS to the project using a layer CRS:

  1. In the Layers panel, right-click on the layer you want to pick the CRS

  2. Select Set project CRS from Layer.

The project’s CRS is redefined using the layer’s CRS. Map canvas extent, coordinates display are updated accordingly and all the layers in the project are on-the-fly translated to the new project CRS.

10.4. Scelta del sistema di riferimento delle coordinate

Questa finestra di dialogo consente di assegnare un sistema di riferimento di coordinate a un progetto o a un layer, a condizione che siano disponibili database di sistemi di proiezione. Gli elementi nella finestra di dialogo sono:

  • Filtro: se conosci il codice EPSG, l’identificatore o il nome del SR che vuoi impostare, puoi utilizzare questa area di ricerca per trovarlo nell’elenco. Inserisci il codice EPSG, l’identificatore o il nome.

  • Sistemi di riferimento usati di recente: se hai certi SR che usi frequentemente nel tuo lavoro GIS quotidiano, questi verranno visualizzati in questa sezione della finestra di dialogo. Clicca su una di queste voci per impostare il SR associato.

  • Sistemi di riferimento mondiali: questa è una lista di tutti i SR supportati da QGIS, compresi quelli geografici, proiettati e personalizzati. Per specificare un SR, selezionalo dalla lista espandendo la lista dallo specifico raggruppamento. Il SR attivo è preselezionato.

  • PROJ in formato testo: Questa è la stringa SR usata dal motore di proiezione PROJ. Questo testo è di sola lettura ed è dato a scopo informativo.

Il selettore del SR mostra anche un’anteprima approssimativa dell’area geografica per la quale un SR selezionato è valido per l’uso. Molti SR sono progettati solo per l’uso in piccole aree geografiche e non devono essere utilizzati al di fuori dell’area per cui sono stati progettati. L’anteprima della mappa ombreggia un’area di utilizzo approssimativa ogni volta che si seleziona un SR dall’elenco. Inoltre, questa mappa di anteprima mostra anche una indicazione dell’estensione della mappa principale corrente.

10.5. Sistemi di riferimento personalizzati

Se QGIS non ha le informazioni sul sistema di riferimento di cui hai bisogno, puoi crearne uno personalizzato. Per farlo, seleziona customProjection SR personalizzato… dal menu Impostazioni. I SR personalizzati vengono salvati nel tuo database utente di QGIS. Oltre ai SR personalizzati, questo database contiene anche i segnalibri geospaziali e altri dati utente.

../../../_images/customProjectionDialog.png

Fig. 10.3 Finestra di dialogo SR personalizzato

Defining a custom CRS in QGIS requires a good understanding of the PROJ projection library. To begin, refer to «Cartographic Projection Procedures for the UNIX Environment - A User’s Manual» by Gerald I. Evenden, U.S. Geological Survey Open-File Report 90-284, 1990 (available at https://pubs.usgs.gov/of/1990/of90-284/ofr90-284.pdf).

Questo manuale descrive l’uso di proj e delle relative utilità da riga di comando. I parametri cartografici usati da proj sono descritti nel manuale e sono identici a quelli usati da QGIS.

La finestra di dialogo Definizione Sistema Riferimento Spaziale Personalizzato richiede solamente due parametri per definire un SR personalizzato:

  1. Il nome

  2. The cartographic parameters in PROJ or WKT format

To create a new CRS, click the signPlus Add new CRS button, enter a descriptive name, select the format, and the CRS parameters.

Click Validate to test whether the CRS definition is an acceptable projection definition.

Puoi testare i parametri del SR per vedere se danno risultati corretti. Per fare questo, inserisci i valori noti di latitudine e longitudine WGS 84 rispettivamente nei campi North e East. Fai clic su Calculate, e confronta i risultati con i valori noti nel tuo sistema di riferimento delle coordinate.

10.5.1. Inserire una trasformazione NTv2 in QGIS

Per inserire un file di trasformazione NTv2 in QGIS devi fare un ulteriore passo:

  1. Mettere il file NTv2 (.gsb) nella cartella SR/Proj che utilizza QGIS (ad esempio. C:\OSGeo4W64\share\proj per gli utenti Windows)

  2. Aggiungere nadgrids (+nadgrids=nameofthefile.gsb) alla definizione Proj nel campo Parametri del Definizione Sistema Riferimento Personalizzato delle coordinate (Impostazioni ▶ Proiezioni personalizzate…).

    ../../../_images/nadgrids_example.png

    Fig. 10.4 Impostazione di una trasformazione Ntv2

10.6. Trasformazioni Datum

In QGIS, “on-the-fly” CRS transformation is enabled by default, meaning that whenever you use layers with different coordinate systems QGIS transparently reprojects them to the project CRS. For some CRS, there are a number of possible transforms available to reproject to the project’s CRS!

By default, QGIS will attempt to use the most accurate transformation available. However, in some cases this may not be possible, e.g. whenever additional support files are required to use a transformation. Whenever a more accurate transformation is available, but is not currently usable, QGIS will show an informative warning message advising you of the more accurate transformation and how to enable it on your system. Usually, this requires download of an external package of transformation support files, and extracting these to the proj folder under your QGIS user profile folder.

If desired, QGIS can also prompt you whenever multiple possible transformations can be made between two CRSs, and allow you to make an informed selection of which is the most appropriate transformation to use for your data.

This customization is done in the Settings ▶ options Options ▶ CRS tab menu under the Default datum transformations group:

  • using checkbox Ask for datum transformation if several are available: when more than one appropriate datum transformation exists for a source/destination CRS combination, a dialog will automatically be opened prompting users to choose which of these datum transformations to use for the project. If the Make default checkbox is ticked when selecting a transformation from this dialog, then the choice is remembered and automatically applied to any newly created QGIS projects.

  • or defining a list of appropriate datum transformations to use as defaults when loading a layer to a project or reprojecting a layer.

    Usa il pulsante signPlus per aprire la finestra di dialogo Seleziona le trasformazioni del datum. Poi:

    1. Choose the Source CRS of the layer, using the drop-down menu or the setProjection Select CRS widget.

    2. Provide the Destination CRS in the same way.

    3. A list of available transformations from source to destination will be shown in the table. Clicking a row shows details on the settings applied and the corresponding accuracy of the transformation.

      In some cases a transformation may not be available for use on your system. In this case, the transformation will still be shown in this list but will not be selectable.

    4. Trova la trasformazione che preferisci, selezionala e clicca su OK.

      A row is added to the table under Default Datum Transformations with information about Source CRS and Destination CRS as well as the datum transformations (Source Datum Transformation and Destination Datum Transformation) to be used to transform between the CRSs.

    From now, QGIS automatically uses the selected datum transformations for further transformation between these two CRSs until you remove it (signMinus) from the list or change the entry (toggleEditing) in the list.

../../../_images/datumTransformation.png

Fig. 10.5 Seleziona una trasformazione di default di datum

Datum transformations set in the Settings ▶ options Options ▶ CRS tab will be inherited by all new QGIS projects created on the system. Additionally, a particular project may have its own specific set of transformations specified via the CRS tab of the Project properties dialog (Project ▶ Properties…). These settings apply to the current project only.