.

Bewerken

QGIS ondersteund verschillende mogelijkheden om OGR, SpatiaLite, PostGIS, MSSQL Spatial en Oracle Spatial vectorlagen en tabellen te bewerken.

Notitie

Het bewerken van GRASS vectorlagen gaat anders - zie Digitaliseren en bewerken van een GRASS vectorlaag for details.

Tip

Tegelijk bewerken

Deze versie van QGIS houdt niet bij of er iemand toevallig hetzelfde object bewerkt. De laatste die zijn wijzigingen opslaat wint.

Het instellen van de Snapping Toleranties en Zoek Radius

Voordat we de hoekpunten gaan bewerken doen we er goed aan eerst de snapping toleranties en de zoek radius in te stellen zodat het bewerken van vector laag geometrieën beter zal gaan.

Snapping toleranties

De Snapping tolerantie is de afstand die QGIS gebruikt om te zoeken naar het dichtsbijzijnde hoekpunt en/of lijnsegment waar een nieuw hoekpunt geplaatst of een bestaand hoekpunt naar verplaatst moet worden. Wanneer de muiscursor verder dan die afstand van een bestaand hoekpunt bevindt dan zal het hoekpunt daar geplaatst worden waar de muiscursor zich bevindt. Binnen die afstand zal deze naar een bestaand hoekpunt ‘snappen’! De instellingen van de snapping tolerantie heeft effect op al het gereedschap dat toleranties gebruikt.

  1. Een standaard tolerantie voor snappen in een project kan worden ingesteld via het menu Extra ‣ mActionOptions Opties. Ga, op een Mac: naar QGIS ‣ mActionOptions Extra..., onder Linux: Bewerken ‣ mActionOptions Opties. Op de tab Digitaliseren kunt u bij de standaard modus Snappen kiezen tussen ‘Naar hoekpunt’, ‘Naar segment’ en ‘Naar hoekpunt en segment’. U kunt ook een standaard tolerantie voor snappen en een zoekradius voor hoekpunt bewerkingen instellen. De toleranties kunnen ingesteld worden in kaarteenheden of in pixels. Het nadeel van het gebruik van kaarteenheden is dat u dan telkens na in- en uitzoomen de toleranties moet aanpassen. Bij het gebruik van pixels heeft u daar weinig last van. In ons kleine project voor digitaliseren (workend met de gegevensset Alaska), definiëren we de eenheden voor snappen in feet. Uw resultaten kunnen variëren, maar bij een kaartschaal van 1:10.000 is een tolerantie voor snappen in kaarteenheden van ongeveer 100 meter een werkbare instelling.

  2. Een op laag gebaseerde tolerantie voor ‘snappen’ kan worden ingesteld door te kiezen voor Extra ‣ (of Bestand ‣) ‘Snapping’-opties... om de modus ‘snappen’ en tolerantie voor elke laag in te stellen (zie figure_edit_1 ).

Onthoud dat deze op laag-gebasseerde instellingen zullen worden gebruikt in plaats van de standaard instellingen. Wanneer je één laag moet bewerken waarbij de hoekpunten moeten snappen naar de hoekpunten van een andere laag, activeer dan snappen voor die andere laag en maak de standaard toleranties voor ‘snappen’ een stuk kleiner. Daarnaast zal snappen niet plaatsvinden naar lagen die niet aanstaan in de snappen opties voor lagen, ook niet na het instellen van de standaard toleranties voor ‘snappen’ . Dus zorg ervoor dat deze lagen, waar je wel naar toe wilt snappen, aangevinkt zijn.

Figure Edit 1:

../../../_images/editProjectSnapping.png

Bewerk de snapping opties op laagniveau nix

Zoekradius

De zoekradius is de afstand die QGIS gebruikt om het dichtsbijzijnde hoekpunt te vinden wanneer je op de kaart klikt. Wanneer er zich binnen die afstand geen hoekpunt aangetroffen wordt, dan zal er een melding verschijnen dat er geen hoekpunt gevonden is om te bewerken. Zowel snap tolerantie als zoek radius kunnen in pixels en kaarteenheden gegeven worden en het vereist wat uitzoekwerk om de goede instellingen te vinden. Wanneer je een te grote snap tolerantie instelt, dan heb je een grote kans dat deze naar het verkeerde hoekpunt snapt. Wanneer de zoek radius te klein is zal deze niets vinden om te verplaatsen.

De zoekradius voor het bewerken van hoekpunten in laageenheden kan worden ingesteld in het tabblad :guilabel`Digitaliseren` onder Extra ‣ mActionOptions Opties. Dezelfde plaats waar je de standaard snapping tolerantie instelt.

Zoomen en Kaart verschuiven

Voordat je een laag gaat bewerken, moet je inzoomen op het betreffende gebied. Dit voorkomt dat alle hoekpunten die je kunt bewerken getekend moeten worden voor de hele laag, dat kost meer tijd.

Naast het gebruik van de knoppen mActionPan Kaart verschuiven en de mActionZoomIn Inzoomen / mActionZoomOut Uitzoomen op de werkbalk kun je ook het muiswieltje, de spatiebalk en de pijltjestoetsen gebruiken.

Zoomen en de kaart verplaatsen met het muiswiel

Tijdens het digitaliseren kun je met het ingedrukte muiswieltje binnen de kaart, het kaartbeeld verplaatsen. Wanneer je het muiswieltje naar je toe rolt zal het kaartbeeld uitzoomen en wanneer je het muiswieltje van je af rolt inzoomen. De plaats van de muiscursor zal het centrum van het gebied zijn waar je op in of uitzoomt. Je kunt het gedrag voor het in- en uitzoomen met het muiswieltje aanpassen onder het tabblad Kaart gereedschap onder het menu Extra ‣ mActionOptions Opties.

De kaart verplaatsen met de pijltjestoetsen

Tijdens het digitaliseren kun je het kaartbeeld verplaatsen met behulp van de pijltjestoetsen. Plaats de muiscursor in het kaartbeeld en druk op de rechter- of de linkerpijltjestoets om het kaartbeeld naar het oosten of het westen te verplaatsen. Met de pijltjestoets omhoog of omlaag kun je het kaartbeeld naar het noorden of naar het zuiden verplaatsen.

Met ingedrukte spatiebalk, kun je met de muiscursor het kaartbeeld verplaatsen in de richting waar je de muiscursor naar toe beweegt. Met de toetsen PgUp en PgDown van je toetsenbord kun je in- en uitzoomen op de kaart zonder je digitaliseer sessie te onderbreken.

Topologische bewerkingen

Vanuit het menu Snapping opties kun je ook instellen of er bij bewerkingen rekening moet worden gehouden met topologische relaties tussen lagen onderling. Deze dialoog kan worden opgestart vanuit het hoofdmenu via Extra ‣ Snapping opties.... Hier kun je het aanvinkvakje checkbox Topologisch bewerken aanzetten activeren en/of kun je voor polygoonlagen de kolom checkbox Voorkom kruisingen aanvinken waarmee voorkomen wordt dat polygoonvlakken elkaar overlappen.

Topologisch bewerken aanzetten

De optie checkbox Topologisch bewerken aanzetten is voor het bewerken en onderhouden van polygoon-objecten met gedeelde grenzen. QGIS herkent gedeelde grenzen tussen vlakken en wanneer je een hoekpunt van een grens verplaatst, dan zal QGIS ook direct de geometrie van (het) andere vlakobject(en), waar deze grens een onderdeel van vormt, aanpassen. Wanneer deze optie aanstaat dan zal tijdens het inbrengen van nieuwe polygoonobjecten het ‘overbodig’ overlappende gedeelte van het nieuwe vlak worden verwijderd en de grens exact aansluitend worden gemaakt. Zorg er bij het opvoeren van het nieuwe vlak er dan wel voor dat het beginpunt en het eindpunt van de grens waar de overlapping begint gelijk zijn. Op deze manier kun je veel sneller een gedeelde grens opvoeren die vaak bestaat uit meerdere punten.

Kruisingen voorkomen

De tweede topologische instelling die je kunt instellen is het aanvinkvak in de kolom Voorkom kruisingen, waarbij het aanvinkvak alleen aanwezig is voor polygonen. Wanneer deze aanwezig is en je voert een polygoon op waarbij de grens zichzelf snijd waardoor er meer dan 1 aaneengesloten vlak ontstaat, dan zal er direkt een melding volgen die de gebruiker daarop attendeert, maar die het aanmaken van het object niet voorkomt! Staat het aanvinkvak ‘Voorkom kruisingen’ niet aangevinkt, dan blijft die melding achterwege. In de praktijk blijkt dat deze controle er ook voor zorgt dat binnen een bestaande polygoon, voor een laag waar deze controle voor aanstaat, niet een andere polygoon kan worden opgevoerd die daar geheel binnen valt. In de engelse handleiding staat bovendien dat de optie Voorkom kruisingen indien aangezet helpt bij het digitaliseren van aansluitende grenzen, maar het is de optie Topologisch bewerken aanzetten die daarvoor zorgt.

Snappen op snijpunten aanzetten

Een andere optie is het aanvinkvak checkbox Snappen op snijpunten aanzetten. Dit geeft de mogelijkheid te ‘snappen’ naar snijpunten van achtergrondlagen zelfs wanneer er geen hoekpunt aanwezig is op het snijpunt.

Het digitaliseren van een bestaande kaartlaag

Standaard staan kaartlagen in QGIS, na het laden, op alleen lezen. Dit voorkomt dat je per ongeluk een kaartlaag gaat wijzigen. Maar je kunt elke kaartlaag wijzigen, tenminste voor kaartlagen waarvoor het wijzigen van kaartlagen ondersteund wordt en wanneer je, op bestandsniveau, schrijfrechten hebt voor die bestanden.

Over het algemeen zijn gereedschappen voor het bewerken van vectorlagen verdeeld in een werkbalk Digitaliseren en een werkbalk Geavanceerd digitaliseren die beschreven worden in Geavanceerd digitaliseren. U kunt beide werkbalken aan-/uitzetten onder Extra ‣ Werkbalken ‣. De werkbalk Digitaliseren biedt het volgende:

Icoon

Doel

Icoon

Doel

mActionAllEdits

Huidige wijzigingen

mActionToggleEditing

Bewerken aan/uitzetten

mActionCapturePoint

Toevoegen objecten: Punten

mActionCaptureLine

Toevoegen objecten: Lijnen

mActionCapturePolygon

Toevoegen objecten: Polygonen

mActionMoveFeature

Verplaatsen Object

mActionNodeTool

Bewerken van knooppunten

mActionDeleteSelected

Geselecteerde verwijderen

mActionEditCut

Objecten knippen

mActionEditCopy

Objecten kopiëren

mActionEditPaste

Objecten plakken

mActionSaveEdits

Wijzigingen in laag opslaan

De functies van de werkbalk ‘Digitaliseren’

Elke sessie waarbij je een kaartlaag gaat bewerken begint met het schrijfbaar maken van de geselecteerde laag met mActionToggleEditing Bewerken aan/uitzetten. Deze bestaat als menu-optie in het snelmenu, die je opent met de rechtermuisknop na het selecteren van een laag in de legenda.

Maar je kunt ook het icoon mActionToggleEditing Bewerken aan/uitzetten kiezen van de werkbalk Digitaliseren om met bewerken te beginnen of te stoppen. Wanneer het bewerken van een laag aanstaat, zullen er markingen verschijnen voor de hoekpunten en meer knoppen op de werkbalk zullen actief en beschikbaar worden.

Tip

Regelmatig opslaan

Vergeet niet om de knop mActionSaveEdits Wijzigingen Laag Opslaan regelmatig te gebruiken. Deze zal ook controleren of je je gegevens nog kunt schrijven naar de databron.

Objecten toevoegen

U kunt de knoppen mActionCapturePoint Object toevoegen, mActionCaptureLine Object toevoegen of mActionCapturePolygon Object toevoegen van de werkbalk Digitaliseren gebruiken om QGIS te wijzigen naar de modus Digitaliseren waarbij ook de muisaanwijzer veranderd. Welke knop op de werkbalk aanwezig is, is afhankelijk van de actieve soort vectorlaag.

Voor elk object begin je eerst met het digitaliseren van de geometrie en vervolgens geef je de attribuutwaarden in. Door met de linkerknop in het kaartbeeld te klikken digitaliseer je een punt voor de nieuwe geometrie.

Voor lijnen en polygonen, voegt u volgende punten toe door met de linkermuis door te klikken in het kaartbeeld. Voor het laatste punt, klikt u ergens in het kaartvenster met de rechtermuisknop. Voor osx Mac moet u bij het ingeven van het laatste punt de control-toets ingedrukt houden.

Vervolgens opent het venster waarmee je de attribuutwaarden voor het nieuwe object kunt inbrengen. Figure_edit_2 toont het venster voor het inbrengen voor een nieuwe fictieve rivier. In het tabblad Digitaliseren in het menu Extra ‣ Opties, kun je het de aanvinkvakje checkbox Geen attribuut-popups na het aanmaken van elk kaartobject tonen en het aanvinkvak checkbox Laatst ingevoerde attribuutwaarden gebruiken aanzetten.

Figure Edit 2:

../../../_images/editDigitizing.png

Geef attribuutwaarden via het attributenformulier na het digitaliseren van nieuwe geometrie nix

Met de werkbalkknop mActionMoveFeature Object(en) verplaatsen kun je bestaande objecten verplaatsen.

Tip

Soorten attribuutwaarden

Tijdens het bewerken vindt er controle plaats van ingevoerde attribuutwaarden. Het is daarom niet mogelijk om een tekstwaarde in te vullen voor een numeriekveld in het formuliervenster Attributen.Wanneer dat toch nodig is, dan kun je dat naderhand alsnog doen in de dialoog Attribuuttabel.

Huidige wijzigingen

Deze functionaliteit geeft de mogelijkheid om meerdere lagen te digitaliseren. Kies mActionFileSaveAs Opslaan voor geselecteerde laag/lagen om alle wijzigingen voor meerdere lagen op te slaan. Het is ook mogelijk om met mActionRollbackEdits Terugdraaien voor geselecteerde laag/lagen alle wijzigingen voor alle geselecteerde lagen in één keer terug te draaien. Als u wilt stoppen met het bewerken van de geselecteerde lagen is mActionCancelEdits Afbreken voor geselecteerde laag/lagen een eenvoudige manier.

Dezelfde functionaliteit is beschikbaar voor het bewerken van alle lagen.

Bewerken van knooppunten

Voor het bewerken van geometrie kun je werkbalkknop mActionNodeTool Knooppunt-gereedschap gebruiken, Je kunt hiermee meerdere knooppunten van een geometrie selecteren en deze verplaatsen, toevoegen of verwijderen. Het Knooppuntgereedschap werkt ook wanneer ‘gelijktijdige CRS-transformatie’ geactiveerd is. Daarnaast blijft de selectie na een bewerking gewoon nog actief (in tegenstelling tot de meeste andere gereedschap in QGIS waarbij dat niet het geval is). Wanneer het Knooppunt-gereedschap geen objecten kon vinden, zal deze een waarschuwing tonen.

Het is aan te raden om eerst de Zoekradius voor hoekaanpassingen op een waarde groter dan 0 te zetten (bijvoorbeeld 10) anders kun je geen knooppunt in QGIS selecteren en volgt er een melding. Zet de zoekradius via het menu Extra ‣ mActionOptions Opties ‣ Digitaliseren ‣ :guilabel`Zoekradius voor hoekpuntaanpassingen` selectnumber.

Tip

Knooppunt markeringen

De huidige versie van QGIS ondersteund drie soorten markeerstijlen voor het weergevan van de hoekpunten: ‘Semi transparante circel’, ‘Kruis’ en ‘Geen’. Om de markeerstijl te wijzigen open het tabblad Digitaliseren in het menu Opties te openen via menuselection:Extra mActionOptions Options .... Onder het deel Hoekpunten staan de opties Markerstijl en Markergrootte waarmee je de markeerstijl kun aanpassen.

Standaard bewerkingen

Start met het activeren van het mActionNodeTool Kooppunten-gereedschap en selecteer een object door hierop te klikken. Rode vierkantjes verschijnen rond elk knooppunt van dit object.

  • Selecteren van knooppunten: Je kunt een enkele knooppunt selecteren door er precies op te klikken. Wanneer je op de lijn klikt die twee knooppunten verbindt, dan worden beide verbonden knooppunten geselecteerd. Wanneer je een vierkant trekt (met ingehouden linkermuisknop) waarbinnen zich meerdere knooppunten bevinden, worden deze knooppunten allemaal geselecteerd. Wanneer een knooppunt geselecteerd is zal de kleur hiervan blauw worden. Je kunt meer knooppunten aan de bestaande selectie toevoegen door met ingehouden Ctrl toets, voor osx command toets, knooppunten te selecteren. Wordt met de Ctrl toets op een reeds geselecteerd knooppunt geklikt dan wordt deze verwijderd uit de selectie .

  • Toevoegen van knooppunten: Om een knooppunt toe te voegen kun je dichtbij of op een lijnstuk klikken. Het nieuwe knooppunt zal overigens altijd toegevoegd worden op de bestaande lijn en niet op de plaats waar je met de muis hebt geklikt. Het nieuwe knooppunt kun je daarna verplaatsen indien nodig.

  • Verwijderen van knooppunten: Je kunt knooppunten verwijderen door deze eerst te selecteren en daarna op de Delete toets te drukken. Voor osx fn + Delete toets. Je kunt met het mActionNodeTool Knooppunten-gereedschap geen volledig object verwijderen, zodra je dreigt onder het minimaal aantal benodigde punten voor het type vectorobject komt, dat je aan het bewerken bent (1 voor punt, 2 voor lijn, 3 voor polygoon) zal het verwijderen niet doorgaan. Om een volledig object te verwijderen gebruik mActionDeleteSelected Geselecteerd(e) object(en) verwijderen.

  • Verplaatsen van knooppunten Selecteer eerst alle knooppunten die je wilt verplaatsen. Klik op een geselecteerd knooppunt of een lijnstuk en sleep deze naar de plek waar je alle geselecteerde knooppunten naar toe wilt verplaatsen. Wanneer snapping is geactiveerd zal de hele selectie zich verplaatsen (‘snappen’) naar het dichtsbijzijnde knooppunt of lijn.

Elke wijziging die gedaan is met het knooppunten-gereedschap wordt opgeslagen in de dialoog Ongedaan maken. Daarnaast wordt topologisch bewerken ondersteund voor alle handelingen wanneer dit is geactiveerd. Gelijktijdige CRS transformatie wordt eveneens ondersteund en er verschijnt informatie in het scherm over het knooppunt wanneer je de muisaanwijzer even boven een knooppunt houdt.

Objecten knippen, kopiëren en plakken

Geselecteerde objecten kunnen geknipt, gekopiëerd en geplakt worden tussen vectorlagen in hetzelfde QGIS project, maar dan moet de doellaag ook eerst bewerkbaar zijn gemaakt met mActionToggleEditing Bewerken aan/uitzetten.

Objecten kunnen ook geplakt worden in externe applicatie als tekst: De objecten worden daarbij gepresenteerd in CSV formaat (comma gescheiden waarden) waarbij de geometrie waarden zijn opgeslagen in WKT-formaat (Well-Known Text formaat, een OGC standaard) waarbij geometrie wordt weergeven in tekst.

In deze versie van QGIS kunnen objecten in tekst formaat niet in een laag van QGIS worden geplakt. Wanneer komt de kopieer en plakfunctionaliteit van pas? Je kunt meerdere lagen tegelijk bewerkbaar zetten en dan bijvoorbeeld in een laag met duizenden meren alleen die twee meren kopiëren die je nodig hebt en deze plakken in een nieuwe lege laag plakken.

Als voorbeeld zullen we enkele lagen van de laag met meren kopiëren naar een nieuwe laag:

  1. Laad de laag van waaruit u objecten wilt kopiëren (de bronlaag)

  2. Laad of maak de laag aan waar je naartoe wilt kopiëren (de doellaag)

  3. Zet het bewerken aan voor de doellaag

  4. Maak de bronlaag de actieve laag door deze te selecteren in de legenda

  5. Gebruik het selectiegereedschap mActionSelect Eén object selecteren om object(en) te selecteren in de bronlaag

  6. Klik op mActionEditCopy Kaartobjecten kopiëren

  7. Maak nu de doellaag de actieve laag door er op te klikken in de legenda

  8. Klik op mActionEditPaste Kaartobjecten Plakken

  9. Zet bewerken voor de laag uit en sla de wijzigingen op

Wat gebeurt er wanneer inhoudelijk de attribuutvelden niet overeenkomen? QGIS zal dan alleen die velden kopiëren die inhoudelijk overeenkomen en de rest negeren. Wanneer je zeker wilt weten dat de attributen en de geometrie goed overgezet worden, dan moeten de tabellen inhoudelijk overeenkomen.

Tip

Behoud van eigenschappen geplakte objecten

Wanneer de bronlaag en de doellaag dezelfde kaartprojectie hebben, zal na het plakken de geometrie goed behouden zijn. Echter wanneer de kaartprojectie van de bron- en de doellaag verschillen dan kan het zijn dat de geometrie niet exact behouden blijft. Dit komt omdat tijdens de reprojectie er kleine afrondingsverschillen zullen optreden voor het berekenen van de nieuwe coördinaten.

Geselecteerde objecten verwijderen

Wanneer we een polygoon willen verwijderen, kunnen we dat doen door eerst de polygoon te selecteren met het selectiegereedschap mActionSelect Eén object selecteren. Je kunt ook meerdere objecten selecteren. De geselecteerde objecten kun je verwijderen met mActionDeleteSelected Geselecteerd Object(en) Verwijderen.

Met mActionEditCut Kaartobjecten knippen van de werkbalk :guilabel`Digitaliseren` kun je ook objecten verwijderen. Daarbij worden niet alleen de objecten uit de laag gehaald maar ook tijdelijk in het geheugen bewaard in he “ruimtelijke clipboard”. Vervolgens kan het object met mActionEditPaste Kaartobjecten Plakken weer ingebracht worden. Knippen, kopiëren en plakken werkt op de geselecteerde objecten, wat betekent dat die er meerdere tegelijkertijd mogen zijn.

Bewerkte lagen opslaan

Wanneer een laag bewerkbaar is, zullen de wijzigingen in het geheugen van QGIS zijn opgeslagen. Deze zijn dan nog niet opgeslagen op schijf. Wanneer je tijdens het bewerken de wijzigingen tussendoor wilt opslaan gebruik dan mActionSaveEdits Wijzigingen opslaan. Wanneer je wisselt naar bewerken uitzetten met mActionToggleEditing Bewerken aan-/uitzetten en er zijn wijzigingen gedaan (of QGIS wilt afsluiten), dan zal er de vraag komen of je huidige aanpassingen wilt opslaan.

Wanneer de wijzigingen niet opgeslagen kunnen worden (bijv. geen schijfruimte meer beschikbaar), dan blijven de wijzigingen nog bewaard in QGIS. Je kunt dan eerst het probleem oplossen (bijv. schijfruimte beschikbaar maken) en vervolgens alsnog de wijzigingen bewaren.

Tip

Integriteit van gegevens

Het is altijd een goed idee om een backup te maken van je gegevens voordat je begint met het wijzigen ervan. Alhoewel de ontwikkelaars van QGIS veel aandacht hebben gegeven aan het behouden van de integriteit van de gegevens, zijn er geen garantie afgegeven.

Geavanceerd digitaliseren

Icoon

Doel

Icoon

Doel

mActionUndo

Ongedaan maken

mActionRedo

Opnieuw

mActionRotateFeature

Object(en) roteren

mActionSimplify

Object vereenvoudigen

mActionAddRing

Ring toevoegen

mActionAddPart

Onderdeel toevoegen

mActionFillRing

Ring Vullen

mActionDeleteRing

Verwijder ring

mActionDeletePart

Verwijder onderdeel

mActionReshape

Object vervormen

mActionOffsetCurve

Verspring curve

mActionSplitFeatures

Kaartobjecten splitsen

mActionSplitParts

Delen Splitsen

mActionMergeFeatures

Geselecteerde objecten samenvoegen

|mActionMergeFeaturesAttributes|

Attributen van geselecteerde objecten samenvoegen

mActionRotatePointSymbols

Puntsymbolen roteren

Tabel Geavanceerd bewerken: De werkbalk Geavanceerd digitaliseren voor vectorlagen

Ongedaan maken en Opnieuw

mActionUndo Ongedaan maken en mActionRedo Opnieuw geven de gebruiker de mogelijkheid om bewerkingen op vectorlagen in stappen ongedaan te maken of nogmaals uit te voeren. Er is ook een paneel aanwezig waarmee je een historie krijgt te zien van alle bewerkingen (zie Figure_edit_3). Dit paneel is standaard niet zichtbaar maar je kunt dit zichtbaar maken door met de rechtermuis op de toolbar klikken en vervolgens de keuze “Ongedaan maken/Opnieuw” te selecteren waarna dit paneel zichtbaar wordt. Dit kan ook via menuopties Beeld ‣ Panelen ‣ Ongedaan maken/Opnieuw. De functie Ongedaan maken/ Opnieuw is actief ook wanneer het paneel niet zichtbaar is.

Figure Edit 3:

../../../_images/redo_undo.png

Ongedaan maken en Opnieuw uitvoer van gedigitaliseerde stappen nix

Wanneer Ongedaan maken wordt gebruikt, zal de status van de objecten weer zijn als voor de laatste bewerking. Wanneer bewerkingen buiten de normale vectorbewerkingen om worden gedaan, bijvoorbeeld vanuit een plugin, dan kan het zijn dat deze bewerkingen niet uitgevoerd kunnen worden (dat ligt eraan hoe deze bewerkingen geprogrammeerd zijn).

Met het panel Ongedaan maken/Opnieuw kun je door te klikken op een bewerking in de lijst direct naar de situatie terugspringen van voor de bewerking.

Object(en) roteren

Gebruik mActionRotateFeaturePuntsymbolen roteren om een of meerdere geselecteerde objecten te roteren in het kaartbeeld. Eerst moeten er enkele objecten worden geselecteerd en selecteer vervolgens de knop mActionRotateFeaturePuntsymbolen roteren. Vervolgens zal het zwaartepunt (de centroïde) van het object worden getoond wat zal dienen als rotatiepunt. Wanneer er meerdere objecten worden geselecteerd zal het rotatiepunt het gezamenlijke zwaartepunt van die objecten zijn. Met een ingehouden linkermuisknop kunnen de geselecteerde objecten gedraaid worden om het rotatiepunt in de gewenste richting.

Het is mogelijk om zelf een rotatiepunt aan te maken waar geselecteerde objecten om geroteerd zullen worden. Selecteer eerst de objecten geroteerd moeten worden selecteer vervolgens de knop mActionRotateFeaturePuntsymbolen roteren. Hou nu de Ctrl toets ingedrukt en verplaats de muisaanwijzer (zonder indrukken) naar de plaats waar het rotatiepunt moet komen te liggen. Laat nu de Ctrl toets los om het rotatiepunt vast te leggen. Met een ingehouden linkermuisknop kunnen de geselecteerde objecten gedraaid worden om het rotatiepunt in de gewenste richting.

Object vereenvoudigen

Het gereedschap mActionSimplify Object vereenvoudigen stelt u in staat het aantal punten waaruit de geometrie van een object bestaat te verkleinen, zolang het object tussentijds niet wijzigt en het object geen multi-geometrie is. Selecteer eerst een object, dit zal worden geaccentueerd door een rood ‘elastiek’ en een schuifbalk zal verschijnen. Door de schuifbalk te verplaatsen zal de vorm van het elastiek veranderen om het verminderen van het aantal punten weer te geven. Klik op [OK] om de nieuwe vereenvoudigde geometrie vast te leggen. Wanneer een object niet kan worden vereenvoudigd (bijv. Multipolygonen), zal een bericht verschijnen.

Ring toevoegen

Je kunt aan een polygon ‘gaten’ toevoegen door gebruik te maken van het icoon mActionAddRing Ring Toevoegen. Dit betekent dat je binnen een bestaande polygoon polygonen kunt toevoegen die fungeren als ‘gaten’. Dus de ruimte tussen de buitenste polygoon en de binnenste polygonen blijft over als polygoon.

Onderdeel toevoegen

Met mActionAddPart onderdeel toevoegen kun je eiland polygonen toevoegen aan een bestaande polygoon. Het nieuwe eiland polygoon moet buiten de grens van geselecteerde (multi-)polygoon liggen.

Ring Vullen

U kunt de functie mActionFillRing Ring vullen gebruiken om een ring aan een polygoon toe te voegen en tegelijkertijd een nieuw object aan de laag toe te voegen. U hoeft dus niet meer eerst het pictogram mActionAddRing Ring toevoegen te gerbuiken en dan de functie mActionCapturePolygon Onderdeel toevoegen.

Verwijder ring

Met mActionDeleteRing Ring Verwijderen kun je een binnenste polygoon ‘gat’ verwijderen binnen een bestaande polygoon. Deze tool werkt alleen met polygoon lagen. Het zal ook niets veranderen wanneer deze wordt gebruikt voor een eiland polygoon. Deze tool werkt voor polygoon en multi-polygoon objecten. Voordat je de hoekpunten van een ring selecteert, wijzig de zoekradius voor hoekpuntaanpassingen.

Verwijder onderdeel

Met mActionDeletePart Verwijder Onderdeel kun je delen van een multi-geometrie object verwijderen. Je kunt met dit gereedschap niet de laatst overblijvende polygoon verwijderen. Dit gereedschap werkt voor alle multi-geometrie objecten voor punten, lijnen en polygonen. Voordat je de hoekpunten van een deel selecteert, wijzig de zoekradius voor hoekpuntaanpassingen.

Object vervormen

Je kunt lijn- en polygoonobjecten vervormen gebruik makende van mActionReshape Objecten vervormen. Hiermee kun je een deel van een lijn of polygoon vervangen door een nieuw lijnstuk van het eerste tot de laatste snijpunt met de oorspronkelijke lijn. Bij polygonen leidt dit soms tot ongewenste resultaten. Het is vooral handig om kleinere lijnstukken van een polygoon aan te passen, en niet om grote wijzigingen uit te voeren. Het is ook niet toegestaan om meerdere polygoonringen te doorsnijden aangezien dit een invalide polygoon oplevert.

Je kunt, bijvoorbeeld de grens van een polygoon bewerken met deze tool. Klik eerst aan de binnenkant van de polygoon vlak bij het punt waar de nieuwe grens moet beginnen, steek daar de grens van de polygoon over en begin dan met het tekenen van de nieuwe grens buiten de huidige grens van de polygoon. Eindig het toevoegen van nieuwe grenspunten door het laatste punt aan de binnenkant van de huidige grens te plaatsen met de rechtermuisknop. Op de snijpunten van de nieuwe met de oude grens zullen door deze functie automatisch nieuwe punten worden toegevoegd. De polygoon kan ook kleiner worden gemaakt door buiten de huidige grens te beginnen en binnen de huidige polygoongrens de nieuwe grens te tekenen en met de rechtermuisklik het tekenen te stoppen buiten de huidige grens.

Notitie

De tool Objecten vervormen kan het startpunt van een polygoon of een gesloten lijn wijzigen. Dus het punt dat twee keer voorkomt kan een ander punt zijn. Dit zal geen probleem zijn voor de meeste applicaties, maar hier dient wel rekening mee worden gehouden.

Verspring curve

Het gereedschap mActionOffsetCurve Verspring curve maakt parallelle lijnen en polygonen voor lijnlagen. De functie werkt voor de laag die bewerkt wordt (de geometrieën worden gewijzigd) of op achtergrondlagen (in welk geval het kopieën maakt van de lijnen / ringen en ze toevoegt aan de laag die bewerkt wordt). Het is dus ideaal geschikt voor het maken van op afstand lijnlagen. De afstand wordt getoond onderin de taakbalk.

U moet eerst naar de modus Bewerken en dan het object selecteren om een lijn te verschuiven. U kunt het gereedschap mActionOffsetCurve Verspring curve activeren en de cursor verslepen naar de gewenste afstand. Uw wijzigingen kunnen dan worden opgeslagen met het gereedschap mActionSaveEditsWijzigingen laag opslaan.

QGIS‘s dialoogvenster Opties (tab Digitaliseren dan gedeelte Lijnverspring-gereedschap ) stelt u in staat enkele parameters, zoals Verbindingsstijl, Segmenten per kwadrant, Maximale puntlengte bij hoekpunten, te configureren.

Kaartobjecten splitsen

U kunt objecten opdelen, gebruik makend van mActionSplitFeatures Kaartobjecten splitsen. Je kunt een lijn tekenen over het kaartobject dat u wilt splitsen.

Delen splitsen

In QGIS 2.0 is het nu mogelijk om de delen van een meerdelige object te splitsen zodat het aantal delen wordt vergroot. Teken een lijn over het deel dat u wilt splitsen met behulp van het pictogram mActionSplitParts Kaartobjectensplitsen.

Geselecteerde objecten samenvoegen

Het gereedschap mActionMergeFeatures Geselecteerde objecten samenvoegen stelt u in staat aan elkaar grenzende objecten samenvoegen die gemeenschappelijke grenzen hebben. Een nieuw dialoogvenster zal u in staat stellen te kiezen welke waarde te kiezen voor alle geselecteerde features of selecteer een functie (Minimum, Maximum, Mediaan, Som, Attribuut overslaan) om voor elke kolom te gebruiken.

Samenvoegen attribuutwaarden van geselecteerde objecten

Met de functie mActionMergeFeatureAttributes Attributen van geselecteerde objecten samenvoegen is het samenvoegen van attributen van objecten mogelijk van aangrenzende objecten zonder de grenzen samen te voegen. Men kan ook de attributen van meerdere geselecteerde objecten samenvoegen. selecteer de knop mActionMergeFeatureAttributes Attributen van geselecteerde objecten samenvoegen. QGIS geeft nu de keuze welke attribuutwaarden voor alle geselecteerde objecten zullen worden toegekend. Het resultaat is dat alle objecten dezelfde attribuutwaarden zullen krijgen.

Puntsymbolen roteren

De tool mActionRotatePointSymbols Puntsymbolen Roteren`geeft de mogelijkheid om puntsymbolen in de kaart laten roteren. Daarvoor moet er voor het object een attribuutveld aanwezig zijn in de attributentabel waarmee je de rotatie kunt vastleggen en daarnaast moet aangegeven zijn dat dit veld gebruikt moet worden voor rotatie voor deze puntenlaag, via de :guilabel:`Geavanceerd in het tabblad Style van Laag Eigenschappen. Je moet ook ‘SVG marker’ openen en kiezen voor Data gedefinieerde eigenschappen .... Activeer vervolgens het aanvinkvak checkbox Hoek en kies ‘rotation’ als veld. Zonder deze instellingen zal deze tool niet geactiveerd zijn.

Figure Edit 4:

../../../_images/rotatepointsymbol.png

Puntsymbolen roteren nix

Om de rotatie van een puntobject te wijzigen, selecteer een puntobject in de kaart en roteer deze door de linkermuis in houden. Een rode pijl met de rotatiewaarde zal getoond worden (zie Figure_edit_4). Wanneer je de linkermuis loslaat, zal de rotatiewaarde worden bijgewerkt in de attributentabel.

Notitie

Wanneer de Ctrl toets wordt ingehouden, zal de rotatie worden uitgevoerd in stappen van 15 graden.

Nieuwe vectorlagen maken

QGIS ondersteund het aanmaken van nieuwe Shapefile, nieuwe SpatiaLite vectorlagen en nieuwe GPX lagen. Het aanmaken van nieuwe GRASS vectorlagen wordt ondersteund binnen de GRASS-plugin. Zie Maken van een nieuwe GRASS vectorlaag voor meer informatie over het aanmaken van GRASS vectorlagen.

Nieuwe Shapefile-laag maken

Om een nieuwe Shape vectorlaag te maken om te bewerken, kies Kaartlagen ‣ Nieuw ‣ mActionNewVectorLayer Nieuw Shape Laag.... De dialoog Nieuwe Vectorlaag zal worden getoond zoals in Figure_edit_5. Kies het type vectorlaag (punt, lijn of polygoon) en de CRS (Coördinaten Referentie Systeem).

QGIS ondersteund nog niet het aanmaken van 2.5D objecten (bijvoorbeeld objecten met X,Y en Z coördinaten).

Figure Edit 5:

../../../_images/editNewVector.png

Dialoogvenster Nieuwe Shapefile-laag maken nix

Voeg de gewenste attributen toe door te klikken op de knop [Toevoegen aan attributenlijst] en een naam en type voor het attribuut te specificeren om het maken van een nieuwe laag voor een shapefile te voltooien, Een eerste kolom ‘id’ wordt standaard toegevoegd maar kan worden verwijderd indien niet gewenst. Alleen attibuten Type: real selectstring, Type: integer selectstring, Type: string selectstring en Type:date selectstring worden ondersteund. Aanvullend en overeenkomstig het type attribuut, kunt u ook de breedte en precisie van de nieuwe kolom voor het attribuut definiëren. Als de attributen naar wens zijn, klik dan op [OK] en geef een naam op voor het shapefile. QGIS zal automatisch de extensie .shp aan de naam die u specificeert toevoegen. Als de laag eenmaal is gemaakt zal die worden toegevoegd aan de kaart en kunt u die op dezelfde manier bewerken als is beschreven in het gedeelte Het digitaliseren van een bestaande kaartlaag hierboven.

Nieuwe Spatialite-laag maken

Voor het aanmaken van een nieuwe Spatialite laag, kies Kaartlagen ‣ Nieuw ‣ mActionNewSpatiaLiteLayer Nieuwe Spatialite Laag.... De dialoog Nieuw SpatiaLite Laag wordt geopend zoals getoond in Figure_edit_6.

Figure Edit 6:

../../../_images/editNewSpatialite.png

Dialoogvenster Nieuwe Spatialite-laag maken nix

De eerste stap is om een bestaande SpatiaLite database te selecteren of om een nieuwe SpatiaLite database aan te maken. Dit kan gedaan worden met de browse functie browsebutton aan de rechterkant van het veld database. Geef een naam voor die nieuwe laag en het Coördinaten Referentie Systeem met [Geef het CRS]. Indien gewenst kun men ook het aanvinkvak checkbox Maak een automatisch ophogen primair sleutelveld aan activeren.

Om de attribuutvelden voor de nieuwe SpatiaLite laag toe te voegen, geef de naam en de attribuuttype en klik op de knop [Toevoegen aan attributenlijst]. Wanneer tevreden druk dan op [OK]. QGIS zal automatsche de nieuwe laag toevoegen aan de kaart en je kunt deze bewerken op dezelfde manier als beschreven in Het digitaliseren van een bestaande kaartlaag.

De DB Manager kan gebruikt worden voor overig beheer van SpatiaLite lagen, zie Plug-in DB Manager.

Een nieuwe GPX-laag maken

Om een nieuwe GPX bestand aan te maken laad eerst de GPS plugin. menuselection:Plugins –> mActionShowPluginManager Beheer en Installeer Plugins... opent de dialoog Plugin Manager. Activeer het aanvinkvak checkbox GPS-gereedschap.

Wanneer deze plugin is geladen kies Nieuw ‣ icon_newgpx Aanmaken nieuwe GPX Laag... in het menu Kaartlagen. In de dialoog Nieuw GPX bestand opslaan als kun je kiezen waar de nieuwe GPX laag wordt opgeslagen.

Werken met de Attributentabel

De attributentabel toont de objecten van een geselecteerde laag. Elke regel in de tabel representeert één kaartobject en elke kolom bevat een attribuutwaarde die een stukje informatie bevat over het object. Objecten in de tabel kunnen worden opgezocht, geselecteerd, verplaatst en zelfs bewerkt.

Om de attributentabel voor een vector laag te openen, maak de laag actief door deze te selecteren in de legenda. Open de attributentabel via het menu Kaartlagen ‣ `|mActionOpenTable| :menuselection:`Open Attributentabel. Het is ook mogelijk om door met de rechtermuis op een laag in de legenda te klikken het snelmenu te openen en hierin mActionOpenTable Open Attributentabel te kiezen. Je kunt deze ook ook openen met de knop mActionOpenTable| Open Attributentabel in de werkbalk Attributen.

Dit zal een nieuw venster openen die de object attributen van de laag toont (figure_attributes_1). Het aantal objecten en het aantal geselecteerde objecten wordt getoond in de titel van de attributentabel.

Figure Attributes 1:

../../../_images/vectorAttributeTable.png

Attributentabel voor de laag regions nix

Het selecteren van objecten in een attributentabel

Elke geselecteerde regel in de attributen tabel toont de attributen van een geselecteerd object in de laag. Wanneer het aantal geselecteerde objecten in de kaart veranderd, zal dit direct worden bijgewerkt in de attributentabel. Ook wanneer in de attributentabel de selectie wijzigt zal de selectie in de kaart worden bijgewerkt.

Regels kunnen worden geselecteerd door te klikken op het regelnummer aan de linkerkant. Meerdere rijen kunnen worden geselecteerd met de ingehouden Ctrl toets. Een Opvolgende selectie kan worden gemaakt door de Shift toets in te drukken en een regelnummer aan de linkerkant. Alle regels tussen de regel waarin zich de cursor bevindt en de aangeklikte regel worden geselecteerd. Het veranderen van de cursor positie door in een andere cel van de tabel te klikken, zal de selectie niet aanpassen. Het wijzigen van de selectie in het kaartbeeld, zal niet de cursorpositie in de attributentabel wijzigen.

De tabel kan gesorteerd worden per kolom, door een kolomhoofd te selecteren. Een kleine pijl wijst de sorteervolgorde aan (een pijltje omhoog betekent, de waarden zijn oplopend gesorteerd van boven naar beneden, pijltje omlaag betekent, de waarden zijn aflopend gesorteerd van boven naar beneden).

Voor een simpele zoekactie op attribuutwaarden op één kolom, selecteer de Kolomfilter ‣ van het keuzemenu linksonderin. Selecteer vervolgens het veld (kolom) waarin gezocht moet worden met de inhoud van het veld zoek naar en selecteer de knop [Zoek]. Vervolgens worden alleen overeenkomende objecten getoond in de attributentabel.

U moet het pictogram mIconExpressionSelect Selecteer objecten m.b.v. reguliere expressie boven in de attributentabel gebruiken om een selectie te maken. mIconExpressionSelect Selecteer objecten m.b.v. reguliere expressie stelt u in staat een subset van een tabel te definiëren met behulp van een Functielijst zoals in mActionCalculateField Veldberekening (bekijk Veldberekening). Het resultaat van de query kan dan worden opgeslagen als een nieuwe vectorlaag. Als u bijvoorbeeld regio’s wilt vinden die gemeenten zijn in het bestand regions.shp van de voorbeeldgegevens van QGIS, moet u het menu Velden en waarden openen en het veld kiezen dat u wilt bevragen. Dubbelklik op het veld ‘TYPE_2’ en ook op [All unieke waarden laden] . Kies, uit de lijst, en dubbelklik op ‘Borough’. In het veld Expressie verschijnt de volgende query:

"TYPE_2"  =  'Borough'

Hier kunt u ook gebruiken Functielijst ‣ Recent (Selectie) om een selectie te maken die u eerder hebt gebruikt. De expressiebouwer onthoudt de laaste 20 gebruikte expressies.

De overeenkomstige rijen worden geselecteerd en het aantal zal weergegeven worden in de titel van de attributentabel en in de statusbalk van het hoofdscherm. Voor zoekopdrachten die alleen geselecteerde objecten op de kaart toont, gebruik de Zoekopdrachtbouwer die beschreven is in Querybouwer.

Om alleen geselecteerde regels te tonen, selecteer Toon Geselecteerde Objecten in het menu linksonder.

De overige knoppen bovenin het menu van de attributentabel biedt de volgende functionaliteit:

  • mActionToggleEditing Bewerken aan/uitzetten om een veldwaarde te bewerken en ook de functies te activeren die hieronder beschreven wordt (ook met Ctrl+E)

  • mActionSaveEdits Wijzigingen opslaan (ook met Ctrl+S)

  • mActionUnselectAttributes Deselecteer alles (ook met Ctrl+U)

  • mActionSelectedToTop Verplaats selectie naar boven (ook met Ctrl+T)

  • mActionInvertSelection Selectie omdraaien (ook met Ctrl+R)

  • mActionCopySelected Kopieer geselecteerde rijen naar klembord (ook met Ctrl+C)

  • mActionZoomToSelected Zoom kaart naar de geselecteerde rijen (ook met Ctrl+J)

  • PanToSelected Verschuif de kaart naar de geselecteerde rijen (ook met Ctrl+P)

  • mActionDeleteSelected Geselecteerde objecten verwijderen (ook met Ctrl+D)

  • mActionNewAttribute Nieuwe kolom voor PostGIS lagen en voor OGR lagen (ook met Ctrl+W)

  • mActionDeleteAttribute Verwijder kolom voor PostGIS lagen en voor OGR lagen geopende met GDAL driver versie >= 1.9 (ook met Ctrl+L)

  • mActionCalculateField Open veldberekening (ook met Ctrl+I)

Onder deze knoppen staat de werkbalk Veldberekening, die het mogelijk maakt berekeningen snel toe te passen op de in de tabel zichtbare attributen. Deze werkbalk gebruikt dezelfde expressies als mActionCalculateField Veldberekening (zie Veldberekening).

Tip

Overslaan WKT geometry

Wanneer je attribuutgegevens in externe programma’s wilt gebruiken (zoals excel) gebruik de knop mActionCopySelected Kopieer geselecteerde rijen naar klembord. De gegevens kunnen gekopieerd worden zonder geometrie informatie wanneer in Extra ‣ Opties ‣ tabblad Databronnen het aanvinkvak checkbox Kopieer geometrie in WKT representatie van attributentabel is gedeactiveerd.

Opslaan van geselecteerde objecten als nieuwe laag

De geselecteerde objecten kunnen worden opgeslagen in alle door OGR ondersteunde vectorindelingen en ook worden omgezet naar een ander Coördinaten Referentie Systeem (CRS). Open het menu voor de rechter muisknop van de laag en selecteer Opslaan als om vervolgens een naam voor het uitvoerbestand op te geven, het gewenste indeling en het CRS (zie Legenda). Zorg er voor dat het checkbox Alleen geselecteerde objecten opslaan is geselecteerd om de selectie op te slaan. Het is ook mogelijk om opties voor het maken van OGR op te geven in het dialoogvenster.

Plakken in een nieuwe kaartlaag

Objecten die op het klembord staan kunnen worden geplakt in een nieuwe laag. maak de laag eerst bewerkbaar om dit te kunnen doen. Selecteer enkele objecten, kopieer ze naar het klembord, en plak ze dan in de nieuwe laag met behulp van Bewerken ‣ Objecten plakken en kies Nieuwe vectorlaag of Nieuwe geheugenlaag.

Dit is van toepassing op geselecteerde en gekopieerde objecten binnen QGIS en ook voor objecten uit andere bronnen die zijn gedefinieerd met behulp van bekende tekst (WKT).

Werken met niet spatiale tabellen

QGIS staat ook toe om niet spatiale tabellen te openen. Dit betreffen door OGR ondersteunde tabellen, tekengescheiden tekst en de PostgreSQL, MSSQL en Oracle databasetabellen. De tabellen kunnen worden gebruikt voor mogelijke veldwaarden of alleen voor het bekijken en bewerken gebruik makende van de tabellenweergave. Wanneer de tabel wordt geladen kun je dit zien in de legenda. Wanneer deze tabel wordt geopend met de mActionOpenTable Open Attributentabel kan deze bewerkt worden als elke ander laag in de attributentabel.

Als een voorbeeld kun je kolommen van een niet spatiale tabel gebruiken om tijdens het digitaliseren de in te geven waarde voor een veld te beperken tot een set mogelijke attribuutwaarden of een waardenbereik. Voor meer informatie zie ook Menu Velden.

Een tot veel-relaties maken

Relaties zijn een techniek die veel gebruikt wordt in databases. Het concept is, dat objecten (rijen) van verschillende lagen (tabellen) aan elkaar kunnen behoren.

Als voorbeeld heeft u een laag met alle regio’s van Alaska (polygoon) die verschillende attributen verschaft over de naam ervan en het regiotype en een unieke id (die dient als primaire sleutel).

Secundaire sleutels

Dan krijgt u een andere laag met punten of tabel met informatie over vliegvelden die in de regio’s liggen en u wilt ook deze bijhouden. Als u ze wilt toevoegen aan de laag van de regio’s, dient u een één tot veel-relatie te maken met behulp van secundaire sleutels, omdat er meerdere vliegvelden in de meeste regio’s liggen.

Figure Relations 1:

../../../_images/relations1.png

Regio Alaska met vliegvelden nix

Maak in aanvulling op de reeds bestaande attributen in de attributentabel van de vliegvelden een ander veld fk_region dat optreedt als een secundaire sleutel (als u een database heeft, wilt u er waarschijnlijk een voorwaarde aan verbinden).

Dit veld fk_region zal altijd een id van een regio bevatten. Het kan worden gezien als een verwijzing naar de regio waartoe het behoort. En u kunt een aangepaste vorm voor het bewerken ontwerpen en QGIS zorgt dan voor de instellingen. Het werkt voor verschillende providers (dus u kunt het ook gebruiken met shape- en csvbestanden) en alles wat u hoeft te doen is QGIS de relaties tussen uw tabellen te vertellen.

Lagen

QGIS maakt geen verschil tussen een tabel en een vectorlaag. In feite is een vectorlaag een tabel met een geometrie. Dus kunt u uw laag tabel als een vectorlaag toevoegen. U kunt, om het te demonstreren, het shapefile ‘region’ laden (met geometrieën) en de csv-tabel ‘airport’ (zonder geometrieën) en een secundaire sleutel (fk_region) aan de laag region. Dit betekent dat elk vliegveld tot precies één regio behoort terwijl elke regio een onbepaald aantal vliegvelden kan hebben (een typische een tot veel-relatie).

Definitie (Relatiebeheer)

Het eerste dat gaan we doen is om QGIS in kennis te stellen van de relaties tussen de lagen. Dit wordt gedaan in Project ‣ Projectinstellingen. Open het menu Relaties en klik op Relatie toevoegen.

  • Naam zal worden gebruikt als de titel. Het zou een door mensen te lezen tekenreeks moeten zijn, die beschrijft waar de relatie voor wordt gebruikt. We zullen het in dit geval eenvoudigweg “Vliegvelden” noemen.

  • Referentielaag (Child) is die met het veld voor de secundaire sleutel erin. In ons geval is dat de laag airports

  • Referentieveld wil zeggen welk veld naar de andere laag verwijst dus dat is in dit geval fk_region

  • Referentielaag (Parent) is die waarnaar de primaire sleutel verwijst, dus hier is het de laag regions

  • Referentieveld is de primaire sleutel van de laag waarnaar verwezen wordt, dus dit is ID

  • id zal worden gebruikt voor interne doeleinden en moet uniek zijn. U zou mogelijk een aangepaste formulier willen maken als het eenmaal ondersteund wordt. Als u het leeg laat zal er een voor u worden gegenereerd maar u kunt er zelf een toewijzen als dat voor u eenvoudiger is.

Figure Relations 2:

../../../_images/relations2.png

Relatiebeheer nix

Formulieren

Nu QGIS van de relatie weet zal het worden gebruikt om de formulieren te verbeteren die het genereert. Als we de standaardmethode voor het formulier niet wijzigden (autogenerated) zal het eenvoudigweg een nieuw widget in ons formulier maken. Dus laten we de laag regions selecteren in de legenda en het gereedschap Identificeren gebruiken. Afhankelijk van uw instellingen zou het formulier direct kunnen openen of u moet het kiezen om het openen in het dialoogvenster Identificatieresultaten onder Acties.

Figure Relations 3:

../../../_images/relations3.png

Dialoogvenster Identificatieresultaten regions met relatie naar vliegvelden nix

Zoals u kunt zien worden de vliegvelden die tot deze bepaalde regio zijn toegewezen weergegeven in een tabel. En er zijn ook enkele knoppen beschikbaar. Laten we die even kort bekijken

  • De knop mActionToggleEditing is voor het aan of uitzetten van het bewerken. Onthoud dat het de modus Bewerken voor de laag airports schakelt, hoewel we in het objectformulier van een object uit de laag regions staan. maar de tabel geeft objecten weer uit de laag airports.

  • De knop mActionSignPlus zal een nieuw object aan de laag airports toevoegen. En het zal standaard het nieuwe vliegveld toevoegen aan de huidige regio.

  • De knop mActionRemove zal het geselecteerde vliegveld permanent verwijderen.

  • Het symbool mActionLink zal een nieuw dialoogvenster openen waar u een bestaand vliegveld kunt selecteren dta dan zal worden toegvoegd aan de huidige regio. Dit kan handig zijn als u per ongeluk eerder het vliegveld in de verkeerde regio maakte.

  • Het symbool mActionUnlink zal het geselecteerde vliegveld loskoppelen van de huidige regio en het daarnna als niet-toegewezen beschouwen (de secundaire sleutel wordt op NULL gezet).

  • De twee knoppen aan de rechterkant schakelen tussen de tabelweergave en de formulierweergave waarbij de laatste u de vliegvelden laat zien in hun respectievelijke formulier.

Als u werkt aan de tabel airports, wordt een nieuw type widget beschikbaar dat u het objectfomulier van de regio waarnaar verwezen wordt laat inbedden in het objectformulier van de vliegvelden. Het kan worden gebruikt als u de laageigenschappen van de tabel airports opent, schakelt naar het menu Velden en het type widget van het veld van de secundaire sleutel ‘fk_region’ wijzigt naar Relatie referentie.

Als u nu kijkt naar het dialoogvenster van het object, zult u zien dat het formulier van regio nu is ingebed in het formulier van de vliegvelden en zelfs een combinatievak zal hebben, wat u in staat stelt het huidige vliegveld aan een andere regio toe te wijzen.

Figure Relations 4:

../../../_images/relations4.png

Dialoogvenster Identificatieresultaten airports met relatie naar regio’s nix