6. Trabajando con Archivos de Proyecto

6.1. Introduciendo proyectos QGIS

El estado de su sesión QGIS se llama proyecto. QGIS trabaja solo en un proyecto a la vez. Una configuración puede ser específica del proyecto o un valor predeterminado de toda la aplicación para nuevos proyectos (consulte la sección Opciones). QGIS puede guardar el estado de su espacio de trabajo en un QGIS project file usando las opciones del menú Project ‣ fileSave Save o Project ‣ fileSaveAs Save As….

Nota

If the project has been modified the * symbol will appear in the title bar and QGIS will, by default, ask you if you would like to save the changes. This behavior is controlled by the checkbox Prompt to save project and data source changes when required setting under Settings ‣ Options ‣ General.

Puede cargar proyectos existentes en QGIS desde el panel del navegador o mediante Project ‣ fileOpen Open…, Project ‣ New from template o Project ‣ Open Recent ‣.

Al inicio, una lista de Project Templates y Recent Projects son mostradas, incluyendo pantallazos, nombres y rutas de archivo (hasta para 10 proyectos). La lista Recent Projects es útil para acceder a proyectos usados recientemente. Haga doble click en una entrada para abrir el proyecto o la plantilla del proyecto. También puede agregar una capa para crear un nuevo proyecto automáticamente. Las listas desaparecerán, dando paso al lienzo del mapa.

Si desea borrar su sesión y comenzar de nuevo, vaya a Project ‣ fileNew New. Esto le pedirá que guarde el proyecto existente si se han realizado cambios desde que se abrió o se guardó por última vez.

When you open a fresh project, the title bar will show Untitled Project until you save it.

../../../_images/new_project.png

Figura 6.1 Empezando un nuevo Proyecto en QGIS

La información guardada en un archivo de proyecto incluye:

  • Capas añadidas

  • Que capas pueden ser consultadas

  • Propiedades de capa, incluyendo simbología y estilos

  • Proyección para la vista de mapa

  • Última extensión vista

  • Diseños de impresión

  • Elementos del diseño de impresión con ajustes

  • Ajustes del diseño de impresión del atlas

  • Ajustes de digitalización

  • Relaciones de tabla

  • Macros del proyecto

  • Estilos predeterminados del proyecto

  • Ajustes de complementos

  • Ajustes del servidor QGIS desde la pestaña de ajustes de OWS en las propiedades del proyecto

  • Consultas almacenadas en el Administrador de BBDD

El archivo del proyecto se guarda en formato XML (consulte QGS/QGZ - The QGIS Project File Format). Esto significa que es posible editar el archivo fuera de QGIS si sabe lo que está haciendo. El formato del archivo del proyecto se ha actualizado varias veces. Los archivos de proyecto de versiones anteriores de QGIS puede que no funcionen correctamente.

Nota

Por defecto, QGIS le advertirá sobre las diferencias de versión. Este comportamiento se controla en la pestaña General tab of Settings ‣ Options (checkbox Warn when opening a project file saved with an older version of QGIS).

Cada vez que guardas un archivo de proyecto .qgs en QGIS, se crea una copia de seguridad del archivo en el mismo directorio que el archivo de proyecto, con la extensión .qgs~.

La extensión para proyectos QGIS es .qgs pero al guardar desde QGIS, el valor predeterminado es guardar usando un formato comprimido con la extensión .qgz. El archivo .qgs está incrustado en el archivo .qgz (un archivo zip), junto con su base de datos sqlite asociada (.qgd) para auxiliary data. Puede acceder a estos archivos descomprimiendo el archivo .qgz.

Nota

El mecanismo Propiedades de almacenamiento auxiliar hace que un proyecto comprimido sea particularmente útil, ya que incorpora datos auxiliares.

Los proyectos también se pueden guardar/cargar en/desde una base de datos PostgreSQL utilizando los siguientes elementos del menú Proyecto:

  • Project ‣ Open from

  • Project ‣ Save to

Ambos elementos de menú tienen un submenú con una lista de implementaciones adicionales de almacenamiento de proyectos (PostgreSQL y GeoPackage). Al hacer click en la acción, se abrirá un cuadro de diálogo para elegir una conexión y proyecto GeoPackage o una conexión, esquema y proyecto PostgreSQL.

Los proyectos almacenados en Geopackage o PostgreSQL también se pueden cargar a través del panel del navegador QGIS, ya sea haciendo doble click en ellos o arrastrándolos al lienzo del mapa.

6.2. Generando la salida

Hay varias formas de generar resultados de su sesión QGIS. Ya hemos discutido guardar como un archivo de proyecto en Introduciendo proyectos QGIS. Otras formas de producir archivos de salida son:

  • Creando imágenes: Project ‣ Import/Export ‣ saveMapAsImage Export Map to Image… da salida a la representación del lienzo del mapa en un formato de imagen (PNG, JPG, TIFF …) a escala, resolución, tamaño, … Es posible georreferenciar la imagen. Ver Exportando la vista de mapa para mas detalles.

  • Exportar a archivos PDF: Project ‣ Import/Export ‣ Export Map to PDF… genera la representación del lienzo del mapa en PDF a escala personalizada, resolución y con algunas configuraciones avanzadas (simplificación, georreferenciación, …). Ver Exportando la vista de mapa para mas detalles.

  • Exportando a archivos DXF: Project ‣ Import/Export ‣ Export Project to DXF… abre un diálogo donde puede definir “Symbology mode”, La “Symbology scale” y capas vectoriales que quiera exportar a DXF. Mediante el “Symbology mode”, Los símbolos de la simbología QGIS original se pueden exportar con alta fidelidad (consulte la sección Creating new DXF files).

  • Diseñando mapas: Project ‣ newLayout New Print Layout… abre un cuadro de diálogo donde puede diseñar e imprimir el lienzo del mapa actual (consulte la sección Diseñando los mapas).