5. Comenzando

Este capítulo proporciona un rápido resumen para instalar QGIS, descargar los datos de muestra QGIS, y ejecutar una primera sesión visualizando datos ráster y vectoriales.

5.1. Instalando QGIS

EL proyecto QGIS proporciona diferentes modos para instalar QGIS dependiendo de tu plataforma.

5.1.1. Instalación para binarios

Los instaladores estándar están disponibles para win MS Windows y osx macOS. Se proporcionan paquetes binarios (rpm y deb) o repositorios de software para muchos tipos de GNU/Linux nix.

Para obtener más información e instrucciones para su sistema operativo, consulte https://download.qgis.org.

5.1.2. Instalando desde la fuente

If you need to build QGIS from source, please refer to the installation instructions. They are distributed with the QGIS source code in a file called INSTALL. You can also find them online at https://github.com/qgis/QGIS/blob/master/INSTALL.md.

Si desea crear una versión particular y no la versión en desarrollo, debe reemplazar master con la rama de lanzamiento (comúnmente en la forma release-X_Y) en el enlace mencionado anteriormente (las instrucciones de instalación pueden diferir).

5.1.3. Instalación en medios externos

Es posible instalar QGIS (con todos los complementos y configuraciones) en una unidad flash. Esto se logra definiendo una opción –profiles-path que sobreescriba la ruta predeterminada user profile y fuerce QSettings para usar este directorio, también. Mira la sección Ajustes del sistema para información adicional.

5.1.4. Descargando datos de muestra

Esta guía del usuario contiene ejemplos basados en el conjunto de datos de muestra QGIS (también denominado Alaska dataset).

win El instalador de Windows tiene una opción para descargar el conjunto de datos de muestra QGIS. Si está marcado, los datos se descargarán a su carpeta Documents y ubicados en una carpeta llamada GIS Database. Puede usar el Explorador de Windows para mover esta carpeta a cualquier ubicación conveniente. Si no seleccionó la casilla de verificación para instalar el conjunto de datos de muestra durante la instalación inicial de QGIS, puede realizar una de las siguientes acciones:

  • Usar datos SIG que ya tenga

  • Download sample data from https://github.com/qgis/QGIS-Sample-Data/archive/master.zip and unzip the archive on any convenient location on your system.

  • Desinstalar QGIS y volver a instalarlo con la opción de descarga de datos marcada (sólo recomendado si las soluciones anteriores no funcionaron).

nix osx For GNU/Linux and macOS, there are no dataset installation packages available as rpm, deb or dmg. To use the sample dataset, download it from https://github.com/qgis/QGIS-Sample-Data/archive/master.zip and unzip the archive on any convenient location on your system.

El conjunto de datos de Alaska incluye todos los datos SIG que se utilizan para los ejemplos y las capturas de pantalla en esta guía del usuario; También incluye una pequeña base de datos GRASS. La proyección para los conjuntos de datos de muestra QGIS es Alaska Albers Equal Area con unidades de pies. El código EPSG es 2964.

PROJCS["Albers Equal Area",
GEOGCS["NAD27",
DATUM["North_American_Datum_1927",
SPHEROID["Clarke 1866",6378206.4,294.978698213898,
AUTHORITY["EPSG","7008"]],
TOWGS84[-3,142,183,0,0,0,0],
AUTHORITY["EPSG","6267"]],
PRIMEM["Greenwich",0,
AUTHORITY["EPSG","8901"]],
UNIT["degree",0.0174532925199433,
AUTHORITY["EPSG","9108"]],
AUTHORITY["EPSG","4267"]],
PROJECTION["Albers_Conic_Equal_Area"],
PARAMETER["standard_parallel_1",55],
PARAMETER["standard_parallel_2",65],
PARAMETER["latitude_of_center",50],
PARAMETER["longitude_of_center",-154],
PARAMETER["false_easting",0],
PARAMETER["false_northing",0],
UNIT["us_survey_feet",0.3048006096012192]]

Si tiene la intención de utilizar QGIS como interfaz gráfica para GRASS, puede encontrar una selección de ubicaciones de muestra (por ejemplo, Spearfish o Dakota del Sur) en el sitio web oficial de GRASS GIS, https://grass.osgeo.org/download/sample-data/.

5.2. Iniciando y deteniendo QGIS

QGIS se puede iniciar como cualquier otra aplicación en su computadora. Esto significa que puede iniciar QGIS de la siguiente manera:

  • usando nix menu Aplicaciones, win el menú Inicio, o osx el Dock

  • doble clic el ícono en su carpeta de Aplicaciones o atajo de escritorio

  • haciendo doble clic en un archivo de proyecto QGIS existente (con extensión .qgz o .qgs). Tenga en cuenta que esto también abrirá el proyecto.

  • escribiebdo qgis en un símbolo del sistema (suponiendo que QGIS se agregó en su RUTA o que está en su carpeta de instalación)

Para detener QGIS, use:

  • nix win la opción del menú Project ‣ Exit QGIS o use el atajo Ctrl+Q

  • osx QGIS ‣ Quit QGIS, o use el atajo Cmd+Q

  • o use el aspa roja en la esquina superior derecha de la interfaz principal de la aplicación.

5.3. Sesión de muestra: carga de capas ráster y vectoriales

Ahora que ya tiene QGIS installed y un sample dataset disponible, demostraremos una primera sesión de muestra. En este ejemplo, visualizaremos un ráster y una capa vectorial. Usaremos:

  • la capa ráster landcover (qgis_sample_data/raster/landcover.img)

  • y la capa vectorial lakes (qgis_sample_data/gml/lakes.gml)

Donde qgis_sample_data representa la ruta del conjunto de datos descomprimido.

  1. Inicie QGIS como vió en Iniciando y deteniendo QGIS.

  2. Para cargar los archivos en QGIS:

    1. Click en el icono dataSourceManager Open Data Source Manager. EL Administrador de la Fuente de Datos debería abrirse en modo Navegador.

    2. Navegue al directorio qgis_sample_data/raster/

    3. Seleccione el archivo ERDAS IMG landcover.img y haga doble-click en él. La capa de cobertura terrestre se agrega en segundo plano mientras la ventana del Administrador de origen de datos permanece abierta.

      ../../../_images/add_raster1.png

      Figura 5.1 Añadiendo datos a un nuevo proyecto en QGIS

    4. Para cargar los datos de los lagos, navege a la carpeta qgis_sample_data/gml/, y haga doble-click en el archivo lakes.gml para abrirlo.

    5. Un diálogo Coordinate Reference System Selector se abre. En el menú Filter, escriba 2964, filtrando la lista de sistemas de coordenadas de referencia a continuación.

      ../../../_images/selectCRS.png

      Figura 5.2 Seleccione el Sistema de Coordenadas de Referencia de los datos

    6. Seleccione la entrada NAD27 / Alaska Alberts

    7. Haz clic en Aceptar.

    8. Cierre la ventana del Administrador de Fuente de Datos

Ahora tiene las dos capas disponibles en su proyecto en algunos colores aleatorios. Haga alguna personalización en la capa lagos.

  1. Seleccione la herramienta zoomIn Zoom In en la barra de herramientas Navigation

  2. Amplíe un área con algunos lagos

  3. Doble-click en la capa lakes en la leyenda del mapa para abrir el diálogo Properties

  4. Para cambiar el color de los lagos:

    1. Click en la pestaña symbology Symbology

    2. Seleccione azul como color de relleno.

      ../../../_images/selectFillColor.png

      Figura 5.3 Seleccionando el color de los lagos

    3. Presione OK. Los lagos se muestran ahora en azul en el lienzo del mapa.

  5. Para mostrar el nombre de los lagos:

    1. Reabra el diálogo lakes layer Properties

    2. Click en la pestaña labeling Labels

    3. Seleccione Single labels en el menú desplegable para habilitar el etiquetado.

    4. De la lista Label with, escoja el campo NAMES.

      ../../../_images/showLabels.png

      Figura 5.4 Mostrando los nombres de los lagos

    5. Presione Apply. Los nombres se mostrarán ahora sobre los límites.

  6. Puede mejorar la legibilidad de la etiquetas añadiendo una zona sombreada blanca a su alrededor

    1. Click en la pestaña Buffer en la lista a la izquierda

    2. Marque checkbox Draw text buffer

    3. Elija 3 como tamaño de buffer

    4. Click en Apply

    5. Comprueba si el resultado parece bueno, y actualiza el valor que necesite.

    6. Finalmente haga click OK para cerrar el diálogo the Layer Properties y aplicar los cambios.

Sugiero ahora añadir algunas decoraciones con el fin de dar forma al mapa y exportarlo fuera de QGIS:

  1. Seleccione el menú View ‣ Decorations ‣ Scale Bar

  2. En el diálogo que se abre, marque la opción checkbox Enable Scale Bar

  3. Personalice las opciones del diálogo como quiera

  4. Presione Apply

  5. Del mismo modo, desde el menú de decoración, agregue más elementos (flecha norte, derechos de autor …) al lienzo del mapa con propiedades personalizadas.

  6. Click en Project ‣ Import/Export ‣ saveMapAsImage Export Map to Image…

  7. Presione Save en el diálogo abierto

  8. Seleccione una localización del archivo, un formato y confirme presionando de nuevo Save

  9. Presione Project ‣ fileSave Save… para almacenar sus cambios como un archivo de proyecto .qgz.

¡Eso es! Puede ver lo fácil que es visualizar capas ráster y vectoriales en QGIS, configurarlas y generar su mapa en un formato de imagen que puede usar en otros softwares. Pasemos a aprender más sobre las funcionalidades disponibles, características y configuraciones, y cómo usarlas.

Nota

Para continuar aprendiendo QGIS mediante ejercicios paso a paso, siga las instrucciones Training manual.