Outdated version of the documentation. Find the latest one here.

.

Algemeen gereedschap

Snelkoppelingen toetsenbord

QGIS heeft voor veel functies standaard snelkoppelingen. Deze worden in Menubalk beschreven. Daarnaast geeft de menu optie Extra ‣ Snelkoppelingen configureren... de mogelijkheid om de standaard snelkoppelingen aan te passen en nieuwe toe te voegen voor functies van QGIS die nog geen snelkoppeling hebben.

Figure Shortcuts 1:

../../../_images/shortcuts.png

Optiemenu snelkoppelingen definiëren nix (Gnome)

Configureren van snelkoppelingen is erg eenvoudig. Selecteer een actie uit de lijst, selecteer [Aanpassen], [Niet gebruiken] of [Als standaard zetten]. Wanneer u tevreden bent over uw configuratie, dan kunt u deze opslaan als een XML-bestand en via dit menu laden in een andere installatie van QGIS.

Contextuele help

Wanneer u hulp nodig heeft over een specifiek onderwerp, kunt u in veel dialoogvensters/menu’s op de knop [Help] drukken. De knop Help in plug-ins die door derden zijn ontwikkeld, kunnen verwijzen naar speciaal daarvoor gemaakte webpagina’s.

Renderen

QGIS zal standaard automatisch de zichtbare lagen opnieuw opbouwen, renderen, wanneer nodig. De gebeurtenissen die het verversen van het kaartvenster starten zijn:

  • Toevoegen van een laag

  • Verschuiven of in/uitzoomen

  • Het wijzigen van de grootte van het QGIS programma venster

  • Het wijzigen van de zichtbaarheden van een laag of lagen

QGIS geeft je op een aantal manieren controle op het renderings-proces.

Schaalafhankelijk renderen

Met schaalafhankelijk tonen is het mogelijk om de minimum en maximum schalen in te stellen waarbij een laag zichtbaar zal zijn. Om schaalafhankelijk tonen in te stellen open het dialoogvenster Eigenschappen door te dubbelklikken op een laag in de legenda. Op de tab Algemeen kan men het keuzevak checkbox Gebruik schaalafhankelijk tonen selecteren en vervolgens de minimum en maximum schaalwaarden invullen waarbinnen de laag zichtbaar zal zijn.

U kunt deze waarden achterhalen door het kaartvenster eerst in te zoomen tot u de kaart net niet/wel wilt zien en dan de bijbehorende schaal af te lezen van de statusbalk.

Controle over het renderen van de kaart

Men kan op de volgende manieren meer controle krijgen over het renderen van het kaartvenster:

Uitstellen van het renderen

Om het renderen uit te stellen, vink het keuzevak checkbox (Her)teken uit in de rechter bendenhoek van de statusbalk. Wanneer het keuzevak checkbox (Her)teken niet is geselecteerd, zal QGIS het kaartvenster niet opnieuw opbouwen bij de gebeurtenissen die beschreven zijn in Renderen. Voorbeelden wanneer u het opnieuw opbouwen van de kaart wilt uitstellen zijn:

  • Na het toevoegen van veel kaartbladen wil je deze eerst van symbologie voorzien en de tekenvolgorde instellen

  • Na het toevoegen van een of meer grote lagen wilt u eerst instellen bij welke schalen deze getekend zal worden

  • Na het toevoegen van één of meer grote lagen, wilt u eerst inzoomen op een bepaald gebied voordat dit getekend wordt

  • Een combinatie van bovenstaande redenen

Het weer aanvinken van checkbox Render zal onmiddelijk het opnieuw opbouwen van het kaartvenster starten.

Instellen optie Laag toevoegen

Er is ook de mogelijkheid om het kaartvenster niet opnieuw te tekenen na het toevoegen van nieuwe lagen. Het keuzevak dat de zichtbaarheid weergeeft van de nieuw toegevoegde laag, is dan niet geselecteerd. Kies, om deze optie in te stellen, de menuoptie Extra ‣ Opties ‣ en open de tab Rendering. Deselecteer het keuzevak checkbox Standaard zullen nieuw toegevoegde lagen aan de kaart direct worden afgebeeld. De zichtbaarheid van elke laag die hierna wordt toegevoegd, zal standaard uit staan in de legenda.

Het renderen stoppen

Om het tekenen van de kaart te stoppen druk op de ESC toets. Dit zal het tekenen van de kaart onderbreken waarbij de kaart slechts gedeeltelijk getekend is. Het kan even duren voordat het tekenen stopt na het indrukken van de ESC toets.

Notitie

Het is momenteel niet mogelijk om het renderen te stoppen - dit is tijdelijk uitgeschakeld in de op Qt4 gebouwde versie aangezien dit kon leiden tot problemen als het stoppen van de toepassing.

Bijwerken van het kaartvenster tijdens het Renderen

Men kan gebruik maken van een optie om kaartgegevens al te tekenen tijdens het inlezen en opbouwen van kaartgegevens. Standaard, laat QGIS nog geen objecten van een laag zien totdat het inlezen en opbouwen van de laag is afgerond. Kies, om kaartgegevens te tekenen tijden het lezen ervan, de menuoptie Extra ‣ Opties Open de tab Rendering. Zet het aantal objecten alvorens de kaart te hertekenen op een geschikte waarde om tijdens het inlezen de kaart al te zien opbouwen. Wanneer de waarde op 0 staat zal de laag pas getoond worden wanneer deze volledig is opgebouwd. Het instellen van een te lage waarde zal resulteren in een traag opbouwende kaart omdat de kaart bijna continue moet worden bijgewerkt. Een voorgestelde waarde om mee te beginnen is 500.

Beïnvloeden van de kwaliteit van het renderen

Er zijn twee opties waarmee men de kwaliteit van het renderen kan beïnvloeden. Kies de menuoptie Extra ‣ Opties open de tab Rendering en selecteer of deselecteer de volgende leuzevakken.

  • checkbox Maak de lijnen minder rafelig ten koste van de tijd dat het tekenen kost

  • checkbox Problemen met fout (gevulde) polygonen oplossen

Het renderen versnellen

Er zijn twee opties waarmee men de snelheid van het renderen kan beïnvloeden. Kies de menuoptie Extra ‣ Opties, open de tab Rendering en selecteer of deselecteer de volgende keuzevakken.

  • Een andere optie in het menu Extra ‣ Opties ‣ Rendering is het keuzevak checkbox Back buffer inschakelen. Dit geeft een betere grafische uitvoering maar daaarbij kan men het tekenen niet onderbreken en ook niet incrementeel objecten tekenen. Wanneer dit niet is geselecteerd, kunt u het Aantal objecten alvorens de kaart te hertekenen instellen, anders is deze inactief.

  • checkbox Gebruik de cache voor het tekenen indien mogelijk om het hertekenen te versnellen

Meten

Men kan direct beginnen te meten binnen geprojecteerde coördinatensystemen zoals het UTM of het Nederlandse RijksDriehoek-stelsel. Wanneer de geladen laag echter een geografisch coördinatensysteem betreft, dat gebruik maakt van lengtegraden/breedtegraden, dan zal het resultaat van gemeten lengtes en oppervlaktes in eerste instantie onjuist zijn. Om dit op te lossen moet er eerst een meer toepasselijk coördinatensysteem ingesteld worden (zie Werken met Projecties). Alle onderdelen die gebruikt worden om te meten gebruiken dezelfde opties voor ‘snappen’ van het gereedschap Digitaliseren. Dit is vooral handig wanneer u bestaande lijnen en vlakken van vectorlagen wilt opmeten.

Selecteer, om een meetgereedschap te kiezen, mActionMeasure en kies vervolgens het gereedschap dat u wilt gebruiken.

Het meten van lengte, oppervlakte of hoek

mActionMeasure Lijn Meten QGIS kan de directe afstand meten tussen twee punten of via een gedefiniëerde ellipsoïde oftewel de aardkromming, van gebruikt coördinaten systeem. Om dit in te stellen, kies de menuoptie Extra ‣ Opties. Open het tabblad Kaart gereedschap en kies de juiste ellipsoïde voor afstandsberekeningen. Men kan hier ook de kleur van de rubberband en de voorkeuren voor te gebruiken eenheden voor lengtematen en hoeken instellen. Met de rubberband wordt het flexibele meetlint bedoelt waarmee de afstanden kunnen worden opgemeten. Men kan nu het meetgereedschap gebruiken door te klikken in het kaartvenster. Het menu opmeten verschijnt waarbij zowel de lengtes van de lijnsegmenten als de totale lengte wordt getoond. Gebruik de rechtermuisknop om te stoppen met meten.

Figure Measure 1:

../../../_images/measure_line.png

Afstanden meten nix (Gnome)

mActionMeasureArea Vlak opmeten: U kunt ook oppervlaktes meten. In het menu Opmeten komt dan de totale oppervlakte te staan. Ook in dit geval zal het meetgereedschap naar objecten van de geselecteerde vectorlaag proberen te snappen, tenminste wanneer voor die laag een tolerantie voor ‘snappen’ is ingesteld. (Zie Het instellen van de Snapping Toleranties en Zoek Radius). Stel, wanneer u nauwkeurig een oppervlakte wil opmeten, dan eerst voor een laag de tolerantie voor ‘snappen’ in en selecteer dan vervolgens die laag. Vervolgens kunt u nu precies oppervlaktes inmeten waarbij elke muisklik naar de dichtstbijzijnde hoek of lijn van de geselecteerde laag zal springen, wanneer deze zich binnen de ingestelde tolerantie bevindt.

Figure Measure 2:

../../../_images/measure_area.png

Gebieden meten nix (Gnome)

mActionMeasureAngle Hoek opmeten: U kunt ook hoeken opmeten. De muisaanwijzer verandert in een kruisje. Klik om het eerste segment te tekenen van de hoek die u wilt opmeten, verplaats dan de cursor om de gewenste hoek te tekenen. De meting wordt getoond in een pop-up dialoogvenster.

Figure Measure 3:

../../../_images/measure_angle.png

Hoeken meten nix (Gnome)

Selecteren en deselecteren van objecten

De werkbalk van QGIS bevat verschillende gereedschappen waarmee u objecten kunt selecteren in het kaartvenster. Klik, om één of meerdere objecten te selecteren, op mActionSelect en kies het gewenste gereedschap om te selecteren:

  • mActionSelect 1 object selecteren

  • mActionSelectRectangle Objecten met een rechthoek selecteren

  • mActionSelectPolygon Objecten met een polygoon selecteren

  • mActionSelectFreehand Objecten selecteren door er overheen te tekenen

  • mActionSelectRadius Objecten met cirkel selecteren

Om de huidige selectie van geselecteerde objecten ongedaan te maken klik op mActionDeselectAll Objecten uit alle layers deselecteren.

mIconExpressionSelect Selecteer objecten met een expressie geven de mogelijkheid objecten te selecteren met behulp van een dialoogvenster voor een expressie. Bekijk het hoofdstuk Expressies voor voorbeelden.

Gebruikers kunnen geselecteerde objecten opslaan in een Nieuwe geheugenlaag of een Nieuwe vectorlaag met behulp van Bewerken ‣ Plak objecten als ... waarbij kan worden gekozen uit verschillende methodes.

Objecten identificeren

Met Objecten identificeren kan men zichtbare objecten op de kaart bevragen waarbij de attributen worden getoond in een resultaatvenster. Gebruik Beeld ‣ Objecten identificeren of druk op Ctrl+Shift+I, of klik op het pictogram mActionIdentify Objecten identificeren in de werkbalk om objecten te identificeren.

Wanneer u meerdere objecten selecteert, dan zal Identificatieresultaten een overzicht geven van alle geselecteerde objecten. Het eerste item in de resultaatlijst is het nummer gevolgd door de laagnaam. In een niveau daaronder bevindt zich de naam van het attribuutveld met de attribuutwaarde, vervolgens wordt alle informatie van het object getoond.

Dit venster kan worden aangepast om aangepaste velden te tonen, maar het zal standaard drie soorten informatie weergeven:

  • Acties: acties kunnen worden toegevoegd aan de resultaatlijst van het gereedschap Objecten identificeren. Wanneer u een actie selecteert zal die actie worden gestart. Standaard wordt er slechts één actie toegevoegd, de actie Het object bewerken formulier.

  • Afgeleid: deze bevat attribuutwaarden die zijn berekend of afgeleid van andere informatie. Men kan hier het coördinaat vinden waarmee is gezocht, de X- en Y-coördinaten, de oppervlakte en omtrek in kaarteenheden voor polygonen , de lengte in kaarteenheden voor lijnen en het object-ID’s.

  • Veld attributen: Dit is de lijst van velden met attribuutwaarden van de gegevens.

Figure Identify 1:

../../../_images/identify_features.png

Dialoogvenster Objecten identificeren nix (Gnome)

Aan de onderkant van het venster Identificatieresultaten staan vijf pictogrammen:

  • mActionIdentifyExpand Boom uitklappen

  • mActionIdentifyCollapse Boom inklappen

  • mActionIdentifyDefaultExpand Nieuwe resultaten zullen standaard worden uitgebreid

  • mActionIdentifyCopyAttributes Kopieer attributen

  • mActionIdentifyPrint Geselecteerde HTML antwoord afdrukken

Andere functies kunnen worden gevonden in het contextmenu van het geïdentificeerde item. Vanuit het contextmenu kunt u bijvoorbeeld:

  • Het formulier Object bekijken

  • Naar object inzoomen

  • Kopieer object: Kopieer alle geometrie en attributen van het object

  • Object selecteren aan/uit: voegt geïdentificeerde object toe aan selectie

  • Attribuutwaarde kopiëren: Kopieert alleen de waarde van het attribuut waar u op klikt

  • Kopiëren objectattributen: Kopieert alleen de attributen

  • Wis resultaat: Het scherm Identificatieresultaten wordt leeggemaakt

  • Wis accentueren: Verwijdert objecten die geaccentueerd waren op de kaart

  • Alles accentueren

  • Laag accentueren

  • Activeer laag: Kies een laag die moet worden geactiveerd

  • Laag-eigenschappen: Opent het menu Laag-eigenschappen

  • Alles uitklappen

  • Alles inklappen

Decoraties

De kaartdecoraties van QGIS zijn het Grid, het label Copyright, de Noordpijl en de schaalbalk. Ze worden gebruikt om de kaart te ‘decoreren’ door cartografische elementen toe te voegen.

Grid

transformed Grid geeft de mogelijkheid om een coördinatenraster en annotaties van coördinaten toe te voegen aan het kaartvenster.

Figure Decorations 1:

../../../_images/grid_dialog.png

Dialoogvenster Grid nix

  1. Selecteer via het menu Beeld ‣ Decoraties ‣ Grid. De dialoog opent (zie figure_decorations_1).

  2. Activeer het keuzevak checkbox Grid activeren en stel de definities voor het raster in, overeenkomstig de geladen lagen in het kaartvenster.

  3. Activeer het keuzevak checkbox Teken labels en stel de definities voor annotatie in overeenkomstig de lagen die geladen zijn in het kaartvenster.

  4. Klik op [Apply] om het resultaat direct te zien.

  5. Klik op **[OK] om het dialoogvenster te sluiten.

Noordpijl

north_arrow Noordpijl plaatst een simpele noordpijl op de kaart. Momenteel is er slechts 1 stijl beschikbaar. Je kunt de hoek van de noordpijl instellen of door QGIS de richting automatisch laten instellen. Wanneer er voor gekozen worden om door QGIS zelf de richting te laten bepalen, zal deze de richting zo goed mogelijk bepalen. Voor het plaatsen van de noordpijl zijn er vier opties, die overeenkomen met de vier hoeken van het kaartvenster.

Figure Decorations 3:

../../../_images/north_arrow_dialog.png

Dialoogvenster Noordpijl nix

Schaalbalk

scale_bar Schaalbalk plaatst een eenvoudige schaalbalk op de kaart. De stijl en de plaats kan worden aangepast evenals de labels van de Schaalbalk.

Figure Decorations 4:

../../../_images/scale_bar_dialog.png

Dialoogvenster Schaalbalk nix

QGIS ondersteunt alleen het tonen van de schaalbalk in dezelfde lengteenheid als die van de kaart. Wanneer de eenheid van de lagen in meters zijn kun je niet een schaalbalk maken in feet . Zo kun je ook geen schaalbalk in meters tonen wanneer de gebruikte kaart als eenheid in graden wordt getoond.

Een schaalbalk toevoegen:

  1. Selecteer via het menu Beeld ‣ Decoraties ‣ Schaalbalk The dialoog opent (zie figure_decorations_4).

  2. Kies de plaatsing met de keuzelijst Plaatsing selectstring.

  3. Kies de stijl in de keuzelijst Schaalbalkstijl selectstring .

  4. Kies de kleur van de balk via het kleurenpalet achter Schaalbalkkleur selectcolor of laat deze op zwart staan

  5. Zet de grootte van de schaalbalk en het label Grootte van de balk selectnumber.

  6. Zorg ervoor dat het aanvinkvak checkbox Schaalbalk gebruiken is aangevinkt.

  7. Geef aan of de schaalbalk automatisch naar gehele getallen verspringt wanneer de kaart van grootte wijzigt door het keuzevak checkbox Klik automatisch naar gehele getallen tijdens het aanpassen van de grootte te selecteren

  8. Klik [OK].

Tip

Decoratie-instellingen

Wanneer u een project van QGIS opslaat, zullen de wijzigingen die u heeft gemaakt aan Grid, Noordpijl, Schaalbalk en Copyright mee worden opgeslagen in het projectbestand en teruggezet worden bij het openen van het project.

Gereedschappen voor annotatie

Het gereedschap mActionTextAnnotation Tekst annotatie op de werkbalk Attributen geeft de mogelijkheid om een tekstballon ergens in het kaartvenster te plaatsen. Gebruik het gereedschap Tekst annotatie en klik ergens in het kaartvenster.

Figure annotation 1:

../../../_images/annotation.png

Dialoogvenster Annotatie tekst nix

Wanneer u dubbelklikt op de ballontekst heeft u verschillende mogelijkheden om deze aan te passen. Er is een tekstvak waar u de tekst mee kunt aanpassen. U kunt kiezen of de tekst verbonden is aan een kaartlocatie of dat deze steeds op dezelfde plaats blijft staan ook al verschuift u de kaart. U kunt het tekstitem verplaatsen door de markering op de kaart of de ballontekst naar een andere plek te slepen. De gebruikte pictogrammen zijn onderdeel van het thema GIS, maar worden standaard ook in de andere thema’s gebruikt.

Het gereedschap mActionAnnotation Annotatie verplaatsen wordt gebruikt om de annotatie te verplaatsen in het kaartvenster.

HTML-annotaties

De gereedschappen mActionTextAnnotation HTML-annotatie op de werkbalk Attributen geven de mogelijkheid om de inhoud van een HTML-bestand in een tekstballon ergens in het kaartvenster te plaatsen. Gebruik het gereedschap HTML-annotatie en klik ergens in het kaartvenster en voer in het dialoogvenster een pad in naar het HTML-bestand.

SVG-annotaties

Het gereedschap mActionSaveAsSVG SVG-annotatie op de werkbalk Attributen geeft de mogelijkheid om een SVG-symbool in een ballon ergens in het kaartvenster te plaatsen. Gebruik het gereedschap SVG-annotatie en klik ergens in het kaartvenster en voeg in het dialoogvenster een pad in naar het SVG-bestand.

Formulier-annotaties

Het is mogelijk om uw eigen formulieren voor annotaties te maken en te gebruiken. Het gereedschap mActionFormAnnotation Formulier-annotatie kan gebruikt worden om de attributen van een vectorlaag te tonen in een speciaal daarvoor door uzelf ontworpen formulier in de QT designer (zie figure_custom_annotation). Dit is hetzelfde formulier als dat wat wordt gebruikt voor het gereedschap Objecten identificeren, maar dan gebruikt als annotatie. De volgende video van Tim Sutton https://www.youtube.com/watch?v=0pDBuSbQ02o laat het gebruik ervan zien.

Figure annotation 2:

../../../_images/custom_annotation.png

Maatwerk Qt designer annotatie formulier nix

Notitie

Wanneer u de toetsencombinatie Ctrl+T gebruikt terwijl een gereedschap Annotatie actief is (annotatie verplaatsen, tekst-annotatie, formulier-annotatie), dan wisselt het tekstitem van zichtbaar naar onzichtbaar en andersom.

Favoriete plaatsen

De Engelse term ’Spatial Bookmarks’ is vrij vertaald naar ’Favoriete plaatsen’. U kunt met Favoriete plaatsen aangeven waar u later terug wilt keren.

Favoriete plaats maken

Een favoriete plaats maken:

  1. Zoom in op een gebied naar keuze.

  2. Selecteer de menu optie Beeld ‣ Nieuwe Favoriet ... of gebruik de snelkoppeling Ctrl-B.

  3. Geef een beschrijvende naam waaronder u de Favoriete plaats op wilt slaan (tot 255 tekens).

  4. Klik op Enter om de Favoriete plaats toe te voegen of [Verwijderen] om de Favoriete plaats te verwijderen.

Men kan meerdere favorieten onder dezelfde naam opslaan.

Werken met Favoriete plaatsen

Kies, om een Favoriete plaats te gebruiken of te beheren, de menuoptie Beeld ‣ Favoriete plaatsen tonen. Het dialoogvenster Favoriete plaatsen geeft de mogelijkheid om snel te springen naar die opgeslagen Favoriete plaats of om een Favoriete plaats te verwijderen. U kunt de naam of de positie van een Favoriete plaats niet wijzigen.

Naar Favoriete plaats verplaatsen

Kies, in het dialoogvenster Favoriete plaatsen, de favoriete plaats door deze te selecteren en druk daarna op de knop [Zoom naar]. U kunt ook naar een Favoriete plaats springen door hierop te dubbelklikken.

Favoriete plaats verwijderen

Selecteer, om een favoriete plaats te verwijderen uit het dialoogvenster Favoriete plaatsen ..., de favoriet en druk op [Verwijderen]. Bevestig de gemaakte keuze in het vervolgschermpje door op [OK] te drukken of maak het verwijderen alsnog ongedaan door te drukken op [Cancel] .

Projecten in een project

Wanneer u de inhoud van een ander project wilt opnemen in een project kunt u kiezen voor menuselection:Kaartlagen –> Kaartlagen en groepen inbedden.

Lagen inbedden

Het volgende dialoogvenster maakt het inbedden van lagen vanuit een ander project mogelijk. Hier volgt een voorbeeld:

  1. Gebruik browsebutton om een ander project te selecteren van de gegevensset Alaska.

  2. Selecteer het projectbestand grassland. U kunt de inhoud van het project zien (zie figure_embed_dialog).

  3. Druk op Ctrl en selecteer de lagen grassland en regions. Druk op [OK]. De lagen zijn nu toegevoegd in de legenda en het kaartvenster.

Figure Nesting 1:

../../../_images/embed_dialog.png

Lagen en groepen selecteren om in te bedden nix

Alhoewel je de ingebedde lagen kunt bewerken, kun je eigenschappen als Stijl en Labels van deze lagen niet aanpassen.

Ingebedde lagen verwijderen

Klik met de rechtermuis op de ingebedde lagen en selecteer mActionRemoveLayer Verwijder.