Outdated version of the documentation. Find the latest one here.

.

QGIS GUI

All’avvio di QGIS l’interfaccia grafica si presenta come mostrato in figura (i numeri da 1 a 5 cerchiati di giallo fanno riferimento alle 5 aree principali dell’interfaccia grafica come verrà in seguito discusso):

Figure QGIS GUI 1:

../../../_images/startup.png

QGIS GUI con i dati campione Alaska nix

Nota

L’aspetto delle finestre (barra del titolo, ecc.) potrà apparire diverso a seconda del sistema operativo e dell’ambiente desktop.

L’interfaccia di QGIS è divisa in cinque aree:

  1. Barra dei Menu

  2. Barra degli Strumenti

  3. Legenda

  4. Mappa

  5. Barra di Stato

I cinque componenti dell’interfaccia di QGIS sono descritti con maggior dettaglio nelle sezioni seguenti. Due ulteriori sezioni illustreranno le scorciatoie da tastiera e la guida contestuale.

Barra degli Strumenti

Le barre degli strumenti forniscono accesso alla maggior parte delle funzioni presenti nei menu, oltre a funzioni aggiuntive volte ad interagire con la mappa. Ogni oggetto della barra degli strumenti ha un aiuto a comparsa (pop-up). Lasciando il cursore del mouse sopra l’icona, verrà visualizzata una breve descrizione della funzione di quello strumento.

Puoi spostare a piacimento ogni barra. Inoltre puoi disattivare ogni barra cliccando con il tasto destro sulla barra degli strumenti e disattivando la voce relativa al menu (vedi Pannelli e Barre degli strumenti).

Suggerimento

Ripristinare le barre degli strumenti

Se hai disattivato accidentalmente tutte le barre strumenti, le puoi ripristinarle dalla voce di menu Visualizza ‣ Barre degli strumenti ‣. Se una barra degli strumenti scompare in Windows, il che sembra succedere di tanto in tanto, è necessario rimuovere \HKEY_CURRENT_USER\Software\QGIS\qgis\UI\state dal registro. Al riavvio di QGIS viene ripristinato lo stato predefinito e le barre degli strumenti saranno nuovamente visibili.

Legenda

The map legend area lists all the layers in the project. The checkbox in each legend entry can be used to show or hide the layer.

Puoi selezionare un layer e trascinarlo in modo da modificarne la visibilità (Z-ordering). Z-ordering significa che i layer in cima alla legenda coprono nella mappa quelli sottostanti.

Nota

Puoi disabilitare questo comportamento dal pannello ‘Ordine dei layer’.

Puoi organizzare in gruppi i layer presenti nella legenda. Ci sono due modi per farlo:

  1. Right click in the legend window and choose Add New Group. Type in a name for the group and press Enter. Now click on an existing layer and drag it onto the group.
  2. Seleziona alcuni layer, clicca con il tasto destro e scegli Gruppo selezionato. I layer selezionati saranno automaticamente spostati nel nuovo gruppo.

Per rimuovere un layer da un gruppo puoi selezionare e trascinare il layer al di fuori dello stesso o in alternativa puoi cliccare con il tasto destro del mouse sul layer e selezionare Muovi fuori dal gruppo –>. I gruppi possono essere nidificati all’interno di altri gruppi.

Puoi usare la casella di controllo di un gruppo per mostrare/nascondere tutti i layer del gruppo con un singolo click.

Le voci del menu contestuale (click con il tasto destro sul layer) sono diverse a seconda se il file è un raster un vettore. Per i vettori di GRASS la voce di menu mActionToggleEditing Modifica non è abilitata. Vedi la sezione Digitalizzare e modificare layer vettoriali GRASS per informazioni su come modificare i vettori di GRASS.

Menu contestuale per i raster

  • Zoom all’estensione del layer ‣

  • Zoom alla scala migliore (100%)

  • Stira usando l’estensione attuale

  • Aggiungi alla panoramica ‣

  • Rimuovi ‣

  • Duplica

  • Imposta il SR del layer ‣

  • Imposta SR progetto dal layer

  • Salva come ...

  • Proprietà

  • Rinomina ‣

  • Copia stile

  • Add New Group
  • Expand all
  • Collapse all
  • Update Drawing Order

Inoltre, a seconda della posizione e della selezione del layer

  • Crea un elemento al livello più alto

  • Gruppo selezionato

Menu contestuale per i vettori

  • Zoom all’estensione del layer

  • Aggiungi alla panoramica

  • Rimuovi ‣

  • Duplica

  • Imposta il SR del layer ‣

  • Imposta SR progetto dal layer

  • Apri tabella attributi

  • Modifica (non disponibile per i layer GRASS)

  • Salva come ...

  • Save Selection As
  • Filtro

  • Mostra totale elementi

  • Proprietà

  • Rinomina ‣

  • Copia stile

  • Add New Group
  • Expand all
  • Collapse all
  • Update Drawing Order

Inoltre, a seconda della posizione e della selezione del layer

  • Crea un elemento al livello più alto

  • Gruppo selezionato

Menu contestuale per i gruppi di layer

  • Zoom al gruppo

  • Rimuovi ‣

  • Imposta il SR del gruppo

  • Rinomina ‣

  • Add New Group
  • Expand all
  • Collapse all
  • Update Drawing Order

Puoi selezionare più di un layer o di un gruppo allo stesso tempo tenendo premuto il tasto Ctrl e cliccando il tasto sinistro del mouse sui vari layer. Potrai cosi spostare contemporaneamente tutti i layer selezionati in un nuovo gruppo.

Puoi anche rimuovere più layer o gruppi contemporaneamente selezionando i diversi layer tenendo premuto il tasto Ctrl e premendo poi Ctrl+D. In questo modo tutto ciò che hai selezionato verrà rimosso dalla lista dei layer.

Lavorare con la legenda indipendentemente dall’ordine dei layer

Hai anche la possibilità di usare un pannello per impostare una legenda indipendentemente dall’ordine di visualizzazione. Puoi attivare questa opzione dal menu Visualizza ‣ Pannelli ‣ Ordine dei layer e determinare così l’ordine di visualizzazione dei layer nella mappa. Cosi facendo puoi ordinare i layer in base ad un determinato criterio, pur mantenendo l’ordine di visualizzazione iniziale corretto (vedi figure_layer_order). Spuntando la casella di controllo checkbox Controllo ordine di visualizzazione collocata sotto l’elenco dei layer, puoi ritornare al comportamento iniziale predefinito.

Figure Layer Order:

../../../_images/layer_order.png

Lavora con una legenda indipendente dall’ordine dei layer nix

Mappa

Questa è l’area in cui le mappe vengono visualizzate. La mappa visualizzata in questa finestra è il risultato dei vettori e/o raster che hai scelto di caricare (vedi le sezioni che seguono per ulteriori informazioni su come caricare i layer). Puoi modificare la zona di visualizzazione della mappa (spostando la messa a fuoco dell’esposizione della mappa ad un’altra regione) puoi effettuare operazioni di zoom in ed out. Varie altre operazioni sono descritte nella sezione relativa alla barra dei menu. La vista nell’area di mappa e la legenda sono strettamente legate l’una all’altra: le mappe che vengono visualizzate riflettono i cambiamenti fatti nella area della legenda.

Suggerimento

ZOOM IN E ZOOM OUT CON LA ROTELLA DEL MOUSE

Per le operazioni di zoom puoi anche utilizzare la rotella del mouse. Posizionando il puntatore del mouse nell’area di visualizzazione delle mappe aumenterai lo zoom girando la rotella verso lo schermo, lo ridurrai girandola nel verso contrario. La posizione del puntatore costituisce il centro per l’ingrandimento. Puoi regolare il comportamento della funzione di zoom con la rotella del mouse nella scheda Strumenti mappa del menu Impostazioni ‣ Opzioni .

Suggerimento

MUOVERE LA MAPPA CON I TASTI FRECCIA E LA BARRA SPAZIATRICE

Puoi spostare la mappa anche con le frecce della tastiera. Posiziona il mouse sulla mappa e clicca la freccia destra per spostarti verso est, la freccia sinistra per spostarti verso ovest, la freccia in su per spostarti verso nord e la freccia in giù per spostarti verso sud. Puoi anche spostare la mappa con la barra spaziatrice oppure premendo la rotellina del mouse: nel primo caso tieni premuta la barra spaziatrice e muovi il mouse, mentre nel secondo caso tieni premuto il tasto della rotellina mentre muovi il mouse.

Barra di Stato

La barra di stato mostra le coordinate di mappa (es. metri o gradi decimali) della posizione del mouse. Nella barra di stato a sinistra delle coordinate è presente un piccolo pulsante che ti consente di passare dalla visualizzazione delle coordinate del movimento del mouse alla visualizzazione delle coordinate dell’estensione della mappa.

Accanto alla finestra delle coordinate c’è la finestra della scala. Questa mostra la scala della mappa attuale. Sia ingrandendo che rimpicciolendo la scala, QGIS mostrerà la scala corrente. Un menu a tendina ti permette di scegliere fra alcune scale predefinite da 1:500 a 1:1000000.

La barra di avanzamento nella barra di stato mostra il progredire della visualizzazione di ogni layer nella mappa. In alcuni casi, come quando vengono raccolte informazioni statistiche su raster, questa barra è usata per mostrare lo stato di avanzamento di questi processi, in genere molto lunghi.

Se è disponibile un nuovo plugin o un aggiornamento di un plugin installato, apparirà un avviso nella barra di stato. Nella parte destra della barra di stato è presente una casella di controllo che, se attivata, può essere usata per impedire temporaneamente la visualizzazione dei layer. L’icona mIconStopRendering disattiva temporaneamente la visualizzazione dei layer nella mappa (vedi sezione Visualizzazione).

All’estrema destra della barra di stato è visibile il codice EPSG del SR del progetto corrente; cliccando sull’icona a forma di proiettore subito a destra del codice EPSG è possibile accedere alle proprietà del SR.

Suggerimento

Calcolare la scala corretta della mappa

I gradi sono l’unità di misura predefinita di QGIS, quindi le coordinate di ciascun layer verranno visualizzate in gradi decimali. Per ottenere valori di scala corretti, puoi cambiarli manualmente in unità metriche nella scheda Generale del menu Progetto ‣ Proprietà progetto oppure puoi scegliere un sistema di riferimento (SR) cliccando sull’icona mIconProjectionDisabled Stato SR nell’angolo in basso a destra della barra di stato. In quest’ultimo caso le unità di misura sono impostate secondo le caratteristiche delle proprietà del progetto, ad esempio ‘+units=m’.