Outdated version of the documentation. Find the latest one here.

Instrumente generale

Combinații de taste

QGIS oferă, pentru multe entități, scurtături implicite de la tastatură. Le puteți găsi în secțiunea Bara de Meniuri. În plus, opțiunea de meniu Setări ‣ Configurare Scurtături... vă permite să modificați combinațiile de taste implicite și să adăugați noi combinații pentru funcționalitățile QGIS.

Figure Shortcuts 1:

../../../_images/shortcuts.png

Definirea opțiunilor pentru scurtături

Configurarea este foarte simplă. Trebuie doar să selectați o funcție din listă și faceți clic pe:

  • [Change] and press the new combination you want to assign as new shortcut
  • [Set none] to clear any assigned shortcut
  • or [Set default] to backup the shortcut to its original and default value.

După ce ați terminat configurarea, o puteți salva su b formă defișier XML, apoi să o încărcați într-o altă instalare QGIS.

Ajutor contextual

Când aveți nevoie de ajutor pe un anumit subiect, puteți accesa ajutorul contextual prin intermediul butonului [Ajutor], disponibil in cele mai multe dialoguri — vă rugăm să rețineți că plugin-urile terțe pot avea pagini web dedicate.

Randare

În mod implicit, QGIS face toate straturile vizibile de fiecare dată când canevasul hărții este actualizat. Între evenimentele care declanșează o actualizare de canevas sunt incluse:

  • Adăugarea unui strat

  • Deplasare și transfocare

  • Redimensionarea ferestrei QGIS

  • Schimbarea vizibilității unuia sau mai multor straturi

QGIS permite controlarea procesului de randare în mai multe moduri.

Randarea Dependentă de Scară

Randarea dependentă de scară vă permite să specificați scările minimă și maximă la care un strat va fi vizibil. Pentru a seta o randare dependentă de scară, deschideți Properties printr-un dublu-clic pe stratul din legendă. În fila General, faceți clic pe caseta checkbox :guilabel:`Scale dependent visibility`pentru a activa funcția, apoi setați valorile pentru scările minimă.și maximă.

Puteți determina valorile scării, transfocând mai întâi la nivelul pe care doriți să-l utilizați, și observând valoarea scării din bara de stare QGIS.

Controarea Randării Hărților

Randarea hărții poate fi controlată în diverse moduri, așa cum este descris mai jos.

Suspendarea Randării

Pentru a suspenda randarea, faceți clic pe caseta checkbox Render din colțul din dreapta jos al barei de stare. În cazul în care caseta checkbox Render nu este bifată, QGIS nu redesenează canevasul ca răspuns la oricare din evenimentele descrise în secțiunea Randare. Exemple de momente când s-ar putea suspenda randarea:

  • Adăugarea mai multor straturi și simbolizarea lor înainte de desenare

  • Adăugarea unuia sau a mai multor straturi mari, și stabilirea dependenței de scară înainte de desenare

  • Adăugarea unuia sau a mai multe straturi mari, și transfocarea la o vizualizare specifică înainte de desenare

  • Orice combinație a celor de mai sus

Bifarea casetei checkbox Randare activează randarea și provoacă o reîmprospătare imediată a canevasului hărții.

Setarea Opțiunilor de Adăugare a Stratului

Puteți seta o opțiune pentru a încărca mereu noi straturi, fără a le desena. Acest lucru înseamnă că stratul va fi adăugat la hartă, dar caseta sa de vizibilitate din legendă va fi debifată din oficiu. Pentru a seta această opțiune, selectați opțiunea de meniu Settings ‣ Options, apoi faceți clic pe fila Rendering. Debifați caseta checkbox În mod implicit, straturile nou adăugate pe hartă ar trebui să fie vizibile. Orice strat adăugat ulterior pe harta va fi stins (invizibil), în mod implicit.

Oprirea Randării

Pentru a opri desenarea hărții, apăsați tasta ESC. Acest lucru va opri reîmprospătarea canevasului, lăsând harta parțial desenată. Este posibil să dureze ceva timp între apăsarea tastei ESC și momentul în care desenarea hărții se oprește.

Note

În acest moment nu este posibilă oprirea randării — acest lucru a fost dezactivat în portarea de Qt4, din cauza problemelor și a defectelor Interfeței cu Utilizatorul (UI).

Influențarea Calității Randării

QGIS are o opțiune de influențare a calității randării hărții. Alegeți opțiunea de meniu Setări ‣ Opțiuni, faceți clic pe fila Randare, apoi selectați sau deselectați caseta care checkbox Face ca liniile să apară mai puțin zimțate, cu prețul unei reduceri a vitezei de desenare.

Accelerează randarea

Există două setări care vă permit să îmbunătăți viteza de randare. Deschideți dialogul opțiunilor QGIS folosind Setări ‣ Opțiuni, fila Randare, apoi bifând sau debifând următoarele casete:

  • checkbox Se folosește memoria tampon, acolo unde este posibil, pentru a se accelera redesenarea

  • checkbox Straturile se randează în paralel, utilizând mai multe nuclee CPU și checkbox Maximum de nuclee utilizate.

  • The map renders in the background onto a separate image and each checkbox Map Update interval, the content from this (off-screen) image will be taken to update the visible screen representation. However, if rendering finishes faster than this duration, it will be shown instantaneously.
  • With checkbox Enable Feature simplification by default for newly added layers, you simplify features’ geometry (less nodes) and as a result, they quickly display. Be aware that you can also face rendering inconsistencies.

Selectorul de Culoare

The select color dialog will appear whenever you push the selectColor icon to choose a color. The features of this dialog depends on the state of the Use native color chooser dialogs parameter checkbox in Settings ‣ Options ‣ General menu. When checked, the color dialog used is the one of the OS being used. Otherwise, QGIS custom color chooser is used.

This dialog has four different tabs which allow you to select colors by colorBox color ramp, colorWheel color wheel, colorSwatches color swatches or colorPicker color picker (not available under osx).

Whatever method you use, the selected color is always described through color sliders for HSV (Hue, Saturation, Value) and RGB (Red, Green, Blue) values. There is also an opacity slider to set transparency level. On the lower left part of the dialog you can see a comparison between the current and the new color you are presently selecting and on the lower right part you have the option to add the color you just tweaked into a color slot button.

Figure color selector 1:

../../../_images/color_selector_ramp.png

Fila de selectare a gamei de culori

Tip

Dynamically change the color with the live-updating option

Check the Use live-updating color chooser dialogs option in the General Settings to have the color applied to your items as you change color parameters in the QGIS custom color chooser dialog.

With colorBox color ramp or with colorWheel color wheel, you can browse to all possible color combinations. There are other possibilities though. By using colorSwatches color swatches you can choose from a preselected list. This selected list is populated with one of three methods:

  • Culori recente,

  • Standard colors, a user-defined list of colors set under Settings ‣ Options ‣ Colors menu
  • or Project colors, a user-defined list of colors set under Project ‣ Project Properties ‣ Default Styles.

Figure color selector 2:

../../../_images/color_selector_recent_colors.png

Color selector switcher tab

Another option is to use the colorPicker color picker which allows you to sample a color from under your mouse pointer at any part of QGIS or even from another application by pressing the space bar. Please note that the color picker is OS dependent and is currently not supported by OSX.

Tip

preluare rapidă a culorii + copiere/lipire culori

You can quickly choose from Recent colors, from Standard colors or simply copy or paste a color by clicking the drop-down arrow that follows the selectColor color box.

Figure color selector 3:

../../../_images/quick_color_selector.png

Meniul rapid al selectorului de culoare

Modurile de Fuziune

QGIS offers different options for special rendering effects with these tools that you may previously only know from graphics programs. Blending modes can be applied on layers, on features but also on print composer items:

  • Normal: This is the standard blend mode, which uses the alpha channel of the top pixel to blend with the pixel beneath it. The colors aren’t mixed.
  • Lighten: This selects the maximum of each component from the foreground and background pixels. Be aware that the results tend to be jagged and harsh.
  • Screen: Light pixels from the source are painted over the destination, while dark pixels are not. This mode is most useful for mixing the texture of one item with another item (e.g., you can use a hillshade to texture another layer).
  • Dodge: Dodge will brighten and saturate underlying pixels based on the lightness of the top pixel. So, brighter top pixels cause the saturation and brightness of the underlying pixels to increase. This works best if the top pixels aren’t too bright; otherwise the effect is too extreme.
  • Addition: This blend mode simply adds pixel values of one item with the other. In case of values above one (in the case of RGB), white is displayed. This mode is suitable for highlighting features.
  • Darken: This creates a resultant pixel that retains the smallest components of the foreground and background pixels. Like lighten, the results tend to be jagged and harsh.
  • Multiply: Here, the numbers for each pixel of the top item are multiplied with the corresponding pixels for the bottom item. The results are darker pictures.
  • Burn: Darker colors in the top item cause the underlying items to darken. Burn can be used to tweak and colorise underlying layers.
  • Overlay: This mode combines the multiply and screen blending modes. In the resulting picture, light parts become lighter and dark parts become darker.
  • Soft light: This is very similar to overlay, but instead of using multiply/screen it uses color burn/dodge. This is supposed to emulate shining a soft light onto an image.
  • Hard light: Hard light is also very similar to the overlay mode. It’s supposed to emulate projecting a very intense light onto an image.
  • Difference: Difference subtracts the top pixel from the bottom pixel, or the other way around, to always get a positive value. Blending with black produces no change, as the difference with all colors is zero.
  • Subtract: This blend mode simply subtracts pixel values of one item from the other. In case of negative values, black is displayed.

Transfocare și Deplasare

QGIS dispune de instrumente de deplasare sau transfocare în zona de interes.

Apart from using the pan pan and zoomIn zoom-in / zoomOut zoom-out icons on the toolbar with the mouse, navigating can also be done with the mouse wheel, spacebar and the arrow keys.

Transfocarea și deplasarea cu ajutorul rotiței mouse-ului

Puteți apăsa rotița mouse-ului pentru deplasare în interiorul ferestrei principale; de asemenea, puteți utiliza rotița mouse-ului pentru a mări sau a micșora harta. Plasați cursorul mouse-ului în interiorul hărții, și mișcați rotița înainte (dinspre dvs.) pentru a mări, și înapoi (înspre dvs.) pentru a micșora. Transfocarea are loc din poziția cursorului mouse-ului. Puteți personaliza comportamentul de transfocare al rotiței mouse-ului folosind meniul filei Instrumentelor hărții de sub Setări ‣ options Opțiuni.

Deplasarea cu ajutorul tastelor cu săgeți

Puteți utiliza tastele cu săgeți pentru a deplasa harta. Plasați cursorul mouse-ului în interiorul hărții și apăsați tasta săgeții din dreapta pentru deplasarea înspre est, tasta săgeții din stânga pentru deplasarea înspre vest, tasta săgeții de sud pentru deplasarea înspre nord și tasta săgeții din jos pentru deplasarea înspre sud.

De asemenea, puteți utiliza bara de spațiu pentru a produce temporar deplasări ale hărții. Tastele PgUp și PgDown vor determina mărirea sau micșorarea hărții.

Măsurarea

QGIS provides four means of measuring geometries:

  • the interactive measurement tools measure,
  • measuring in the calculateField Field Calculator,
  • derived measures in the Identificare entități tool,
  • and a vector analysis tool: Vector ‣ Geometry Tools ‣ Export/Add Geometry Columns

Measuring works within projected coordinate systems (e.g., UTM) and unprojected data. The first three measuring tools behave equally to global project settings:

If “on the fly” CRS transformation is enabled, the default measurement metric is - different from most other GIS - ellipsoidal, using the ellipsoid defined in File ‣ Project properties ‣ General. This is true both when geographic and projected coordinate systems are defined for the project. If you want to calculate the projected / planimetric area or distance using cartesian maths, the measurement ellipsoid has to be set to “None / Planimetric” (File ‣ Project properties ‣ CRS). However, with a geographic (= unprojected) CRS defined for the data and project, area and distance measurement will be ellipsoidal. If “on the fly” CRS transformation is disabled, the measurement metric is planimetric when the project coordinate system is projected and ellipsoidal when the project coordinate system is unprojected / geographic.

However, neither the identify tool nor the field calculator will transform your data to the project CRS before measuring. If you want to achieve this, you have to use the vector analysis tool: Vector ‣ Geometry Tools ‣ Export/Add Geometry Columns. Here, measurement is by default planimetric except if you choose the ellipsoidal measure.

Măsurarea interactivă a lungimii, a ariei și a unghiurilor

Toate modulele de măsurare utilizează setările de acroșare ale modulului de digitizare. Acest lucru este util atunci când se dorește măsurarea de-a lungul liniilor sau a suprafețelor din straturile vectoriale.

Pentru a selecta un instrument de măsurare, faceți clic pe measure, apoi selectați instrumentul pe care doriți să-l utilizați.

În mod implicit, measure Măsurare Linie: QGIS poate măsura distanțele reale dintre punctele date, în conformitate cu un elipsoid definit. Puteți defini o bandă elastică, o culoare, unitățile de măsură preferate (metri sau picioare) și unitățile unghiului (grade, radiani și gon) din alegeți opțiunea de meniu Settings ‣ Options ‣ Map Tools. Instrumentul vă permite apoi să faceți clic pe punctele de pe hartă. Lungimea fiecărei entități, precum și totalul, apare în fereastra de măsură. Pentru a opri măsurarea, faceți clic pe butonul din dreapta al mouse-ului. Rețineți că puteți schimba interactiv unitățile de măsură în dialogul de măsurare. El suprascrie Unitățile de măsurare preferate din opțiuni. Există o secțiune de informații în fereastra de dialog, care arată care dintre setările CRS-ului sunt utilizate în timpul calculelor de măsurare.

Figure Measure 1:

../../../_images/measure_line.png

Măsurarea Distanței

measureArea Measure Area: Zonele pot fi, de asemenea, măsurate. În fereastra de măsură, va apărea dimensiunea zonei acumulate. În plus, instrumentul de măsură se va acroșa la stratul curent selectat, cu condiția ca toleranța de acroșare a stratului să fie setată (a se vedea secțiunea Setarea Toleranței Acroșării și Căutarea Razei). Astfel, dacă vreți să măsurați exact o linie sau un poligon, mai întâi setați-i toleranța, apoi selectați stratul. Apoi, când se vor utiliza instrumentele de măsurare, fiecare clic de mouse (în funcție de toleranță) se va acroșa la acel strat.

Figure Measure 2:

../../../_images/measure_area.png

Măsurarea Ariei

measureAngle Measure Angle: Puteți măsura, de asemenea, unghiurile. Cursorul va lua forma unei cruciulițe. Faceți clic pentru a desena primul segment al unghiului pe care doriți să-l măsurați, apoi deplasați cursorul pentru a desena unghiul dorit. Măsura acestuia va fi afișată într-o fereastră de tip pop-up.

Figure Measure 3:

../../../_images/measure_angle.png

Măsurarea Unghiului

Salvarea și deselectarea entităților

Bara de instrumente a QGIS dispune de mai multe unelte pentru selectarea entităților în canevasul hărții. Pentru a selecta una sau mai multe entități, este suficient să faceți clic pe select și să alegeți instrumentul:

  • selectRectangle Select Features by area or single click to select feature(s) either by simple click or by rectangle
  • selectPolygon Selectare Entități după un Poligon

  • selectFreehand Selectare Entități în Mod Liber

  • selectRadius Selectare Entități după o Rază

Pentru a deselecta toate entitățile faceți clic pe deselectAll Deselectarea Entităților din Toate Straturile.

expressionSelect Selectarea entităților prin utilizarea unei expresii permite utilizatorului să selecteze o entitate cu ajutorul dialogului expresiei. Vedeți capitolul Expresii pentru unele exemple.

Utilizatorii pot salva entitățile selectate într-un Nou Strat Vectorial, din Memorie sau într-un Nou Strat Vectorial, folosind Editare ‣ Copiere Entități și apoi Editare ‣ Lipire Entități ca... în formatul dorit.

Configurarea suprascrierii definită de date

Beside many options in the vector layer properties dialog or settings in the print composer, you can find a dataDefined Data defined override icon. Thanks to expressions based on layer attributes or item settings, prebuild or custom functions and variables, this tool allows you to set dynamic value for the concerned parameter. When enabled, the value returned by this widget is applied to the parameter regardless its normal value (checkbox, textbox, slider...).

Clicking the dataDefined Data defined override icon shows:

  • a Description ... that indicates if it is enabled, which input expected, valid input type and the current definition,
  • an entry to list the Field type available,
  • an entry to list the Variable available,
  • Edit ... button to create or edit the expression to use,
  • butoanele Lipire și Copiere,

  • Clear button to remove the setup.

Tip

When the data-defined override option is setup correctly the icon is yellow dataDefineOn or dataDefineExpressionOn; if it is broken, the icon is red dataDefineError or dataDefineExpressionError.

Parametrii care pot fi utilizați cu instrumentele de definire cu ajutorul datelor sunt:

  • Parametrii pentru stil și simboluri

  • Parametrii etichetelor

  • Parametrii compozitorului

Identificare entități

Instrumentul de Identificare vă permite să interacționați cu canevasul hărții, și să obțineți, într-o fereastră pop-up, informații despre entități. Pentru a identifica entitățile, utilizați Vizualizare ‣ Identificare entități sau Ctrl + Shift + I, sau faceți clic pe pictograma identify Identificare entități din bara de instrumente a Atributelor.

QGIS offers two ways to identify features with the identify Identify features tool:

  • left click will identify features according to the mode set in the Identify results panel
  • right click will fetch all the snapped features from all the visible layers. This will open a context menu, allowing the user to choose more precisely the features to identify.

Dacă faceți clic pe mai multe entit(ăți), dialogul de Identificare rezultate va lista informațiile despre toate entit(ățile) selectate. Vizualizarea implicită constă într-un arbore în care primul element este numele stratului, având în subordine toate entit(ățile) identificate. Fiecare entitate este descrisă de numele unui câmp, alături de valoarea sa. Primul câmp este cel stabilit în Proprietăți ‣ Afișare. Apoi urmează restul informațiilor despre entitate.

Această fereastră poate fi setată pentru a afișa câmpuri personalizate, dar, în mod implicit, ea va afișa trei tipuri de informații:

  • Acțiuni: Acțiunile pot fi adăugate ferestrelor de identificare a entităților. Acțiunea se va lansa atunci când faceți clic pe eticheta acțiunii. În mod implicit, se adaugă doar o acțiune, și anume vizualizarea formularului entității pentru editare.

  • Derived: This information is calculated or derived from other information. This includes the feature id, its length or perimeter and area in map units depending on its geometry, the count of spatial parts and the number of the clicked part in case of multi-geometry, the count of vertices in the feature and the number of the closest one to the point clicked. It also reports the X and Y (and Z/M if available) coordinate values of both clicked point and feature closest vertex.
  • Atributele datelor: Aceasta este lista câmpurilor și valorilor atributelor, pentru entitatea pe care s-a efectuat click.

Figure Identify 1:

../../../_images/identify_features.png

Dialiogul de identificare a entităților

În partea de sus a ferestrei, aveți șapte pictograme:

  • expandTree Expandare arbore

  • collapseTree Restrângere arbore

  • expandNewTree Default behavior to define whether next identified features information should be collapsed or expanded
  • propertyItem Vizualizarea formularului entității

  • deselectAll Clear Results
  • editCopy Copy selected feature to clipboard
  • filePrint Se imprimă răspunsul HTML selectat

În partea de jos a ferestrei, aveți casetele Mod și Vizualizare. Cu ajutorul casetei Mod puteți defini straturile din care se va efectua identificarea:

  • ‘Stratul curent’ : sunt identificate doar entitățile din stratul selectat. Stratul poate să nu fie vizibil pe canevas.

  • ‘Top down, stop at first’: for only features from the upper visible layer.
  • ‘De sus în jos’: pentru toate entitățile din straturile vizibile. Rezultatele sunt afișate în panou.

  • și ‘Selecția stratului’. : deschide un meniu contextual, în care utilizatorul va selecta stratul din care se vor identifica entitățile. Operează similar unui clic-dreapta. Numai entitățile selectate se vor afișate în panoul cu rezultate.

Vizualizarea poate fi setată ca ‘Arbore’, ‘Tabel’ și ‘Graf’. Ultimele două pot fi setate pentru straturile raster.

The identify tool allows you to checkboxauto open a form. If checked, each time a single feature is identified QGIS will open a form showing its attributes. This is a handy way to quickly edit a feature’s attributes.

Alte funcții pot fi găsite în meniul contextual al elementului identificat. De exemplu, din meniul contextual puteți:

  • Vizualiza formularul entității

  • Transfocare pe entitate

  • Copia entități: Copierea tuturor entităților geometrice și a atributelor

  • Activează selecția entităților: Adaugă entitatea identificată la selecție

  • Copia valoarea atributului: Copie doar valoarea atributului pe care faceți clic

  • Copiere atribute entitate: Copiază atributele entității

  • Șterge rezultatele: Elimină rezultatele din fereastră

  • Elimina evidențierea: Anulează evidențierea entităților de pe hartă

  • Evidențiază tot

  • Evidențiere strat

  • Activa stratul: Alegeți un strat pentru a fi activat

  • Afișa proprietățile straturilor: Deschide fereastra de proprietăți a unui strat

  • Expandează tot

  • Restrânge tot

Instrumente de Adnotare

Instrumentul textAnnotation Text Annotation din bara de instrumente a atributelor oferă posibilitatea de a plasa text formatat într-un balon, pe canevasul hărții QGIS. Folosiți instrumentul Adnotare Text, apoi faceți clic pe canevasul hărții.

Figure annotation 1:

../../../_images/annotation.png

Dialogul de adnotare text

Efectuând dublu clic pe element se va deschide un dialog cu diverse opțiuni. Cu ajutorul editorului de text se va introduce textul formatat și alte setări de elemente. De exemplu, apare opțiunea de a poziționa elementul pe hartă (atribuindu-i un simbol de marcare) sau de a-l poziționa pe ecran (neavând legătură cu harta). Elementul poate fi deplasat prin poziționarea pe hartă (prin glisarea marcajului) sau prin deplasarea numai a balonului. Pictogramele sunt parte a temei GIS, ele fiind utilizate, în mod implicit, și în alte teme.

Instrumentul annotation Move Annotation vă permite să deplasați adnotarea pe canevasul hărții.

Adnotări de tip html

formAnnotation Html Annotation din bara de instrumente a atributelor oferă posibilitatea de plasare a conținutului unui fișier html într-un balon, pe canevasul hărții QGIS. Folosind instrumentul de Adnotare Html, faceți clic pe canevasul hărții, și adăugați calea către fișierul HTML în fereastra de dialog.

Adnotări SVG

saveAsSVG Adnotarea SVG din bara de instrumente a atributelor, oferă posibilitatea de plasare a unui simbol SVG într-un balon, pe canevasul hărții QGIS. Folosind instrumentul de Adnotare SVG, faceți clic pe canevasul hărții, și adăugați calea către fișierul SVG în fereastra de dialog.

Adnotări de tip formular

În plus, puteți crea propriile dvs. formulare de adnotare. Instrumentul formAnnotation Formular de Adnotare este util pentru a afișa atributele unui strat vectorial într-un formular personalizat în Qt Designer (a se vedea figure_custom_annotation). Acesta este similar cu formularul proiectat pentru instrumentul Identify features, dar va fi afișat într-un element de adnotare. Vedeți, de asemenea, acest videoclip al lui Tim Sutton, pentru mai multe informații: https://youtu.be/0pDBuSbQ02o?t=2m25s .

Figure annotation 2:

../../../_images/custom_annotation.png

Formulare de adnotare personalizate în qt designer

Note

Dacă apăsați Ctrl+T, atât timp cât instrumentul Annotation este activ (deplasare adnotare, adnotare text, formular de adnotare), starea de vizibilitate a elementelor este inversată.

Semne de Carte Spațiale

Semnele de carte spațiale vă permit să “marcați” o locație geografică și să reveniți la ea mai târziu. Marcajele sunt salvate pe calculator, ceea ce înseamnă că acestea sunt disponibile din orice proiect aflat pe același computer.

Crearea unui Semn de Carte

Pentru a crea un semn de carte:

  1. Deplasare sau transfocare în zona de interes.

  2. Selectați opțiunea de meniu View ‣ New Bookmark sau apăsați Ctrl-B. Marcajul nou creat se va deschide în panoul marcajelor spațiale.

  3. Introduceți un nume descriptiv pentru marcaj (până la 255 de caractere).

  4. Apăsați Enter pentru a adăuga marcajul, sau efectuați clic oriunde.

Rețineți că puteți avea mai multe marcaje cu același nume.

Lucrul cu Marcaje

Pentru a utiliza sau pentru a gestiona marcajele, selectați opțiunea de meniu Vizualizare ‣ Afișare Marcaje. Panoul Marcajelor Geospațiale vă permite să:

  • Transfocare pe Marcaj: selectați marcajul dorit făcând clic pe el, apoi pe Transfocare pe Marcaj. Puteți transfoca, de asemenea, la un marcaj, efectuând un dublu-clic pe el.

  • Ștergerea unui Marcaj: selectați marcajul, apoi faceți clic pe Ștergere Marcaj. Confirmați alegerea dvs.

  • Import or Export a bookmark: To share or transfer your bookmarks between computers you can use the Import/Export Bookmarks pull down menu in the Spatial Bookmarks dialog. All the bookmarks are transferred.

Imbricarea Proiectelor

Dacă doriți să încorporați conținutul din alte fișiere de proiect în proiectul dumneavoastră, puteți alege Layer ‣ Embed Layers and Groups.

Încapsularea straturilor

Urmatorul dialog vă permite să încorporați straturile din alte proiecte. Iată un mic exemplu:

  1. Apăsați browseButton pentru a căuta un alt proiect din setul de date Alaska.

  2. Selectați fișierul de proiect relations.qgs. Puteți vedea conținutul proiectului (v. figure_embed_dialog).

  3. Apăsați Ctrl și faceți clic pe straturile airports și regions. Clic pe [OK]. Straturile selectate sunt încorporate în legendă și în cadrul hărții.

Figure Nesting 1:

../../../_images/embed_dialog.png

Selectați straturile și grupurile pentru încapsulare

Atât timp cât straturile încapsulate sunt editabile, nu le puteți schimba proprietățile, cum ar fi stilul și etichetarea.

Eliminare straturi încapsulate

Faceți clic dreapta pe stratul încorporat, apoi selectați removeLayer Eliminare.

Decorațiuni

Decorațiile din QGIS includ o Grilă, Eticheta Drepturilor de Autor, Săgeata Nordului și Scara Grafică. Adăugarea acestor elemente cartografice reprezintă activitatea de ‘decorare’ a hărții.

Grilă

transformed Grid vă permite să adăugați o rețea de coordonate și să coordonați adnotările din canevasul hărții.

Figure Decorations 1:

../../../_images/grid_dialog.png

Dialogul Grilei

  1. Selectați din meniul View ‣ Decorations ‣ Grid. Se va lansa dialogul (vedeți figure_decorations_1).

  2. Activează caseta checkbox Enable grid și stabiliți definiții de grile în funcție de straturile încărcate în canevasul hărții.

  3. Activați caseta checkbox Draw annotations și stabiliți definițiile adnotărilor în conformitate cu straturile încărcate în canevasul hărții.

  4. Clic pe [Aplicare] pentru a verifica dacă arată așa cum ați dorit, sau pe [OK] dacă totul este în regulă.

Săgeata Nordului

|north_arrow| North Arrow plasează o săgeată a nordului pe canevasul hărții. În prezent, există doar un singur stil disponibil. Puteți regla unghiul săgeții, sau să lăsați aplicației QGIS sarcina de determinare automată a direcției. Dacă optați pentru QGIS, aplicația va face tot posibilul pentru a presupune cel mai bun mod de orientare a săgeții. Pentru plasarea săgeții aveți patru opțiuni, corespunzătoare celor patru colțuri ale canevasului hărții. Puteți rafina plasarea elementului, prin setarea pe Orizontală și/sau Verticală a Marginii față de Conturul (Canevasului). Aceste valori pot reprezenta o distanță în Milimetri, Pixeli sau ca Procentaj din lățimea sau înălțimea canevasului hărții.

Figure Decorations 3:

../../../_images/north_arrow_dialog.png

Dialogul Săgeții Nordului

Scara Grafică

scaleBar Scale Bar adaugă o simplă scară grafică în canevasul hărții. Puteți controla stilul și poziționarea, precum și etichetarea bării.

Figure Decorations 4:

../../../_images/scale_bar_dialog.png

Dialogul Scării Grafice

QGIS acceptă afișarea scării numai în aceleași unități ca și cadrul hărții. Deci, în cazul în care unitățile straturilor dvs. sunt în metri, nu veți putea crea o scară în picioare. În mod similar, dacă utilizați grade zecimale, nu puteți crea o scară care să afișeze distanța în metri.

Pentru a adăuga o scară grafică:

  1. Selectați meniul View ‣ Decorations ‣ Scale Bar. Fereastra de dialog se lansează (vedeți figure_decorations_4).

  2. Asigurați-vă că este bifată caseta checkbox Enable scale bar.

  3. Alegeți stilul din caseta Scale bar style selectString.

  4. Selectați culoarea barei Color of bar selectColor sau folosiți culoarea neagră, implicită.

  5. Setați Dimensiunea barei selectNumber.

  6. Opțional, bifați checkbox Rotunjire numerică automată, în urma redimensionării pentru a afișa valori ușor de citit.

  7. Alegeți poziționarea din caseta combinată Placement selectString.

  8. Puteți rafina plasarea elementului, prin setarea pe Orizontală și/sau Verticală a Marginii față de Conturul (Canevasului). Aceste valori pot reprezenta o distanță în Milimetri, Pixeli sau ca Procentaj din lățimea sau înălțimea canevasului hărții.

  9. Clic pe [Aplicare] pentru a verifica dacă arată așa cum ați dorit, sau pe [OK] dacă totul este în regulă.

Tip

Setările Decorațiunilor

Când salvați un proiect .qgs, orice modificări pe care le-ați adus Grilei, Săgeții Nordului, Scării Grafice și drepturilor de autor, vor fi salvate în cadrul proiectului și vor fi restaurate data viitoare când încărcați proiectul.

Autentificarea

QGIS has facility to store/retrieve authentication credentials in a secure manner. Users can securely save credentials into authentication configurations, which are stored in a portable database, can be applied to server or database connections, and safely referenced by their ID tokens in project or settings files. For more information see Sistem de Autentificare.

A master password needs to be set up when initializing the authentication system and its portable database.

Salvarea stratului într-un fișier

Layers (raster or vector) can be saved in another format with the Save As... feature in the layer contextual menu (by right-clicking in the layer in the layer tree) or in the Layer ‣ Save As... menu.

The Save As dialog shows several parameters to change the behaviour when saving the layer. Common parameters (raster and vector) are:

  • Format
  • Nume de fișier

  • CRS
  • Add save file to map to add the new layer to the canvas
  • Extent (possible values are layer, Map view or custom extent)
  • Create (for raster), Layer or Custom (for vector) Options which allow you to change some advanced options. Advanced user can see the driver documentation in gdal-ogr documentation.

Totuși, unii parametri sunt specifici formatelor raster și vector:

  • Parametrii specifici rasterelor:

    • Rezoluţiea (orizontală și verticală)

    • Crearea piramidei

    • Modul de ieșire (date brute sau imagine randată)

  • Parametrii specifici vectorilor:

    • Codificare

    • Salvare doar a entităților selectate

    • Trecere peste crearea de atribute

    • Symbology export: can be used mainly for DXF export and for all file formats who manage OGR feature styles (see note below) as DXF, KML, tab file formats:
      • No symbology: default style of the application that reads the data
      • Feature symbology: save style with OGR Feature Styles (see note below)
      • Symbol Layer symbology: save with OGR Feature Styles (see note below) but export the same geometry multiple times if there are multiple symbology symbol layers used
    • Geometrie:

      • se forțează utilizarea multi-geometriilor,

      • adaugă dimensiunea z,

      • add or remove a geometry column with the drop-down list. This is not linked with the current geometry type of the layer. You can add an empty geometry column to an attribute table, remove the geometry column of a spatial layer.

Note

OGR Feature Styles are a way to store style directly in the data as a hidden attribute. Only some format can handle this kind of information. KML, DXF and TAB files format are such format. For advanced user, you can read the OGR Feature Styles specification document.

Note

Despre fişierele DXF

Vector layers can be exported to DXF files using another tool, the DXF Export ... in Project. The windows allow the user to choose the layer file, the symbology mode (see the note above), the symbology scale, the encoding, the visibility preset and the layers to include in the DXF file.

As an option, you can checkbox Use the layer title as name if set or Export features intersecting the current map extent.

Use of variables for dynamic content

Puteți defini variabile personalizate pentru utilizarea în expresii. Variabilele pot fi definite la nivelul global al aplicației, la nivel de proiect, la nivelul stratului și la nivelul compoziției. Similar regulilor CSS, variabilele pot fi suprascrise - de exemplu, o variabilă la nivel de proiect va rescrie orice variabilă setată la nivel de aplicație. Puteți folosi aceste variabile pentru a construi șiruri de text sau alte expresii personalizate folosind caracterul @ înainte de numele variabilei. De exemplu, crearea, în compozitor, a unei etichete cu acest conținut:

This map was made using QGIS [% @qgis_version %]. The project file for this
map is: [% @project_path %]

Va produce o etichetă care arată în felul următor:

This map was made using QGIS 2.14. The project file for this map is:
/gis/qgis-user-conference-2015.qgs

You can manage global variables from the Settings ‣ Options menu, and project level variables from Project properties (including adding your own custom variables).

Figure Variables dialog 2:

../../../_images/options_variables.png

Editarea variabilei la nivel de proiect

Note

you can read more information and find examples here Exploring variables in QGIS 2.12, part 1, part 2 and part 3.