Outdated version of the documentation. Find the latest one here.

일반 도구

키보드 단축키

QGIS는 많은 기능에 대해 기본 키보드 단축키를 제공합니다. 메뉴 바 에서 단축키를 찾아볼 수 있습니다. 또한 Settings ‣ Configure Shortcuts... 메뉴 옵션에서 기본 키보드 단축키를 변경하고 QGIS 기능에 새 키보드 단축키를 추가할 수도 있습니다.

Figure Shortcuts 1:

../../../_images/shortcuts.png

단축키 옵션 정의

설정 방법은 아주 간단합니다. 목록에서 기능을 선택하고 다음을 클릭하십시오:

  • [Change] 을 클릭하고 새 단축키로 할당할 키 조합을 입력하십시오.

  • 할당된 단축키를 삭제하려면 [Set none] 을 클릭하십시오.

  • 또는 단축키를 원래의 기본값으로 되돌리려면 [Set default] 을 클릭하십시오.

사용자 설정을 마친 후, 설정을 XML 파일로 저장해서 또다른 QGIS 설치본으로 불러올 수 있습니다.

컨텍스트 도움말

특정 문제에 대해 도움말이 필요한 경우, 대부분의 대화창에 있는 [Help] 버튼을 통해 컨텍스트 도움말을 볼 수 있습니다. 이때 제3자 플러그인의 경우 전용 웹페이지로 이동할 수도 있다는 사실을 알아두십시오.

렌더링 작업

기본적으로 QGIS는 맵 캔버스를 업데이트할 때마다 모든 가시 레이어를 렌더링합니다. 다음과 같은 이벤트가 맵 캔버스 업데이트를 유발합니다:

  • 레이어 추가

  • 맵 이동 또는 확대/축소

  • QGIS 창 크기 변경

  • 레이어(들)의 가시성 변경

사용자는 QGIS 상에서 다양한 방법으로 렌더링 과정을 제어할 수 있습니다.

축척에 따른 렌더링

축척에 의존적인 렌더링을 통해 어떤 레이어가 가시화되는 최소 및 최대 축척을 설정할 수 있습니다. 축척에 의존적인 렌더링을 설정하려면, 범례에 있는 레이어를 더블 클릭해서 Properties 대화창을 여십시오. General 탭에서 checkbox Scale dependent visibility 체크박스를 클릭한 다음, 최소 및 최대 축척값을 설정합니다.

먼저 사용자가 원하는 수준까지 확대/축소한 다음 QGIS 상태 바에서 축척을 확인해서 축척값을 결정할 수 있습니다.

맵 렌더링 제어

다음에서 설명하는 대로, 다양한 방법으로 맵 렌더링을 제어할 수 있습니다.

렌더링 보류

렌더링 작업을 보류하려면, 상태 바 우하단에 있는 checkbox Render 체크박스를 클릭하십시오. checkbox Render 체크박스를 해제하면, QGIS는 렌더링 작업 에서 설명하는 어떤 이벤트에도 대응하지 않은 채 캔버스를 다시 그리지 않습니다. 사용자가 렌더링을 보류하길 원할 수도 있는 경우는 다음과 같습니다:

  • 많은 레이어를 추가하고 렌더링 전에 심볼 작업을 하고자 하는 경우

  • 하나 이상의 대용량 레이어를 추가하고 렌더링 전에 축척 의존성을 설정하고자 하는 경우

  • 하나 이상의 대용량 레이어를 추가하고 렌더링 전에 특정한 뷰로 확대/축소하고자 하는 경우

  • 이런 경우들의 조합

checkbox Render 체크박스를 체크하면 렌더링을 활성화해서 즉시 맵 캔버스를 업데이트하게 됩니다.

레이어 추가 옵션 설정

새 레이어를 불러올 때 항상 그리지 않도록 하는 옵션을 설정할 수 있습니다. 즉 맵에 레이어가 추가되어도, 기본적으로 범례의 가시성 체크박스는 해제된 상태일 것이라는 뜻입니다. 이 옵션을 설정하려면, Settings ‣ Options 메뉴 옵션을 선택한 다음 Rendering 탭을 클릭하십시오. checkbox By default new layers added to the map should be displayed 체크박스를 해제하십시오. 이후 맵에 추가되는 모든 레이어가 기본적으로 꺼져 있게 (보이지 않게) 될 것입니다.

렌더링 중단

맵 렌더링을 중단하려면 ESC 키를 누르십시오. 맵 캔버스 업데이트를 중단하고 맵 일부만 렌더링한 채 남아 있을 겁니다. ESC 키를 눌렀을 때 실제로 맵 렌더링을 중단할 때까지 시간이 조금 걸릴 수도 있습니다.

주석

현재 렌더링을 중단하는 것은 불가능합니다. 사용자 인터페이스 문제 및 소프트웨어 오류 등의 이유 때문에 Qt4 포팅 버전에서는 비활성화된 상태입니다.

렌더링 질 변경

QGIS는 맵의 렌더링 질을 변경할 수 있는 옵션을 보유하고 있습니다. Settings ‣ Options 메뉴 옵션을 선택하고, Rendering 탭을 클릭한 다음 checkbox Make lines appear less jagged at the expense of some drawing performance 체크박스를 체크하거나 해제해보십시오.

렌더링 속도 향상

몇 가지 설정으로 렌더링 속도를 향상시킬 수 있습니다. Settings ‣ Options 메뉴 옵션으로 QGIS 설정 대화창을 열고, Rendering 탭으로 이동해서 다음 체크박스들을 체크하거나 해제해보십시오:

  • checkbox 속도 향상을 위해 가능한 경우 렌더링 캐시 사용 을 체크

  • checkbox 다중 CPU 코어를 사용해 레이어 병렬 렌더링 을 체크한 다음 checkbox 사용할 최대 코어 수 를 설정

  • 백그라운드에서 맵을 별개의 이미지로 렌더링해서 각 checkbox 맵 업데이트 간격 시간마다 이 (오프스크린) 이미지의 내용을 가져다가 맵 캔버스를 업데이트하게 됩니다. 하지만 렌더링 작업이 이 간격보다 빨리 끝나는 경우, 그 즉시 화면에 업데이트됩니다.

  • checkbox 새로 추가한 레이어에 대해 기본적으로 피처 단순화 활성화 를 체크하면, 피처의 도형을 단순화(노드 감소)해서 그 결과 더 빨리 표시합니다. 이때 렌더링 일관성을 해치게 될 수도 있다는 점을 주의하십시오.

색상 선택자

사용자가 색상을 선택하기 위해 |selectColor| 아이콘을 클릭할 때마다 색상 선택 대화창이 열립니다. Settings ‣ Options ‣ General 메뉴에 있는 Use native color chooser dialogs 파라미터 체크박스의 상태에 따라 이 대화창의 기능이 달라집니다. 체크된 상태라면, 사용 중인 OS의 색상 대화창이 열립니다. 해제된 경우엔 QGIS 전용 색상 선택자가 열립니다.

이 대화창은 사용자가 색상을 선택할 수 있도록 colorBox 색상표, colorWheel 색상환, colorSwatches 색상 견본표 또는 (osx 상에서는 사용할 수 없는) colorPicker 색상 추출기 탭 4개를 보유하고 있습니다.

어떤 방법을 이용하든, 항상 HSV(색상hue, 채도saturation, 명도value)와 RGB 값에 대한 슬라이드 바를 통해 선택한 색상을 표현합니다. 투명도 수준을 설정하기 위한 opacity 슬라이드 바도 있습니다. 대화창의 좌하단에서 current 색상과 사용자가 방금 고른 new 색상을 비교해 볼 수 있으며, 우하단에서 사용자가 방금 조정한 색상을 색상 슬롯 버튼으로 추가할 수도 있습니다.

Figure color selector 1:

../../../_images/color_selector_ramp.png

색상 선택자 창의 색상표 탭

참고

실시간 업데이트 옵션으로 동적 색상 변경

Settings ‣ Options ‣ General 메뉴에 있는 Use live-updating color chooser dialogs 옵션을 체크해서 QGIS 전용 색상 선택자 대화창에서 색상 파라미터를 변경하는 대로 색상을 적용시킬 수 있습니다.

colorBox 색상표 또는 colorWheel 색상환 을 통해 가능한 모든 색상 조합을 탐색해볼 수 있습니다. 그런데 다른 가능성도 있습니다. colorSwatches 색상 견본표 를 이용하면 사전 선택된 목록에서 색상을 선택할 수 있습니다. 이 목록의 색상들은 다음 세 가지 방법 가운데 하나로 채워집니다.

  • 최근 색상

  • 표준 색상Settings ‣ Options ‣ Colors 메뉴에서 설정할 수 있는 사용자 정의 색상 목록

  • 프로젝트 색상Project ‣ Project Properties ‣ Default Styles 메뉴에서 설정할 수 있는 사용자 정의 색상 목록

Figure color selector 2:

../../../_images/color_selector_recent_colors.png

색상 선택자 창의 색상 견본표 탭

사용자가 QGIS 창의 어디에서라도 또는 다른 응용 프로그램 상에서라도 스페이스 바를 눌러 색상 표본을 추출할 수 있는 colorPicker 색상 추출기 를 이용하는 옵션도 있습니다. 이 색상 추출기는 OS에 의존하기 때문에, 현재 OS X는 지원하지 않는다는 사실을 알아두십시오.

참고

빠른 색상 추출기 + 색상 복사/붙여넣기

최근 색상, 표준 색상 을 통해서도 빠르게 색상을 선택할 수 있지만, selectColor 색상 상자 뒤에 있는 드롭다운 화살표를 클릭해서 간단하게 색상을 복사 또는 붙여넣기 할 수 있습니다.

Figure color selector 3:

../../../_images/quick_color_selector.png

빠른 색상 선택자 메뉴

혼합 모드

QGIS는 이 도구들을, 사용자가 이전에 그래픽 프로그램으로밖에 몰랐을, 특별한 렌더링 효과를 위한 여러 옵션과 함께 제공합니다. 레이어나 피처에 적용할 수도 있지만, 인쇄 작성자 항목에도 다음 혼합 모드를 적용할 수 있습니다:

  • Normal: 표준 혼합 모드로, 위에 있는 픽셀의 알파 채널을 이용해서 밑에 있는 픽셀과 혼합합니다. 색상은 섞이지 않습니다.

  • Lighten: 위에 있는 픽셀과 밑에 있는 픽셀로부터 각 요소의 최대값을 선택합니다. 이 모드의 산출물은 경계가 도드라져 보기 안 좋은 경향이 있다는 사실을 주의하십시오.

  • Screen: 원본의 밝은 픽셀은 산출물에 렌더링되는 반면, 어두운 픽셀은 렌더링되지 않습니다. 이 모드는 한 항목의 질감을 다른 항목과 섞는 데 가장 유용합니다. (예를 들어 어떤 레이어에 질감을 부여하는 데 음영기복도를 사용할 수 있습니다.)

  • Dodge: 위에 있는 픽셀의 밝기를 바탕으로 밑에 있는 픽셀의 명도와 채도를 올립니다. 따라서 위에 있는 픽셀이 밝을수록 밑에 있는 픽셀의 채도와 명도가 증가합니다. 위에 있는 픽셀이 너무 밝지 않을 때 가장 유용합니다. 너무 밝을 경우 그 효과가 극단적일 것입니다.

  • Addition: 이 혼합 모드는 한 항목의 픽셀값을 다른 항목의 픽셀값에 단순히 더합니다. (RGB 값이) 1 이상의 값이 나올 경우 하얀색이 표시됩니다. 피처를 강조하려 할 때 적당한 모드입니다.

  • Darken: 위에 있는 픽셀과 밑에 있는 픽셀 가운데 가장 적은 요소를 가져와 산출 픽셀을 생성합니다. Lighten 모드와 마찬가지로 보기에 안 좋은 경향이 있습니다.

  • Multiply: 위에 있는 항목의 각 픽셀의 값을 밑에 있는 항목의 대응 픽셀의 값과 곱합니다. 산출물이 아주 어둡게 보이게 됩니다.

  • Burn: 위에 있는 항목의 색상이 어두울수록 밑에 있는 항목도 어두워집니다. 밑에 있는 레이어에 색상을 부여하고 조정하는 데 이 모드를 쓸 수 있습니다.

  • Overlay: 이 모드는 Multiply 와 Screen 혼합 모드를 조합합니다. 밝은 부분은 더 밝고 어두운 부분은 더 어두운 산출물을 생성합니다.

  • Soft light: Overlay 모드와 매우 비슷하지만, Multiply/Screen을 이용하는 대신 Burn/Dodge 모드의 색상을 이용합니다. 이미지 상에 부드러운 빛을 비추는 것 같은 효과를 낸다고 합니다.

  • Hard light: 이 모드도 Overlay 모드와 매우 비슷합니다. 이미지 상에 아주 강렬한 빛을 비추는 것 같은 효과를 낸다고 합니다.

  • Difference: 이 모드는 밑에 있는 픽셀값에서 위에 있는 픽셀값을 빼거나 그 반대로 계산해서 항상 양의 값을 남깁니다. 검정색은 혼합해도 아무 변화가 없습니다. 모든 색상과의 차가 0이기 때문입니다.

  • Subtract: 이 혼합 모드는 한 항목의 픽셀값에서 다른 항목의 픽셀값을 단순히 뺍니다. 음의 값이 나올 경우 검정색이 표시됩니다.

확대/축소 및 이동

QGIS는 사용자의 관심 지역으로 확대/축소하거나 이동할 수 있는 도구를 제공합니다.

마우스로 툴바에 있는 pan 이동zoomIn 확대 / zoomOut 축소 아이콘을 이용하는 것 이외에, 마우스 휠, 스페이스 바 그리고 방향 키로도 맵을 탐색할 수 있습니다.

마우스 휠로 확대/축소 및 이동

마우스 휠을 누른 채로 메인 창 안을 이동할 수 있으며, 마우스 휠을 돌려서 맵을 확대/축소할 수 있습니다. 확대/축소의 경우, 맵 영역 안쪽에 마우스 커서를 가져간 다음 휠을 앞으로 (사용자에게서 멀리) 돌리면 확대되고 뒤로 (사용자쪽으로) 돌리면 축소됩니다. 마우스 커서 위치를 중심으로 관심 영역이 확대/축소됩니다. Settings ‣ options Options 메뉴에 있는 Map tools 탭에서 마우스 휠 확대/축소 습성을 사용자 지정할 수 있습니다.

방향 키로 이동

방향 키를 이용해서 맵을 이동할 수 있습니다. 맵 영역 안쪽에 마우스 커서를 가져간 다음 오른쪽 방향 키를 누르면 동쪽으로, 왼쪽 방향 키를 누르면 서쪽으로, 위쪽 방향 키를 누르면 북쪽으로, 아래쪽 방향 키를 누르면 남쪽으로 이동합니다.

스페이스 바를 누르면 일시적으로 마우스 움직임에 따라 맵을 이동시킬 수 있습니다. 사용자 키보드의 PgUpPgDown 키를 누르면 맵을 확대하거나 축소할 수 있습니다.

측정

QGIS는 도형을 측정하는 네 가지 방법을 제공하고 있습니다:

  • 쌍방향 측정 도구인 measure 과,

  • calculateField 필드 계산기 에서 측정하는 방법,

  • 피처 식별 도구에서 파생된 측정 방법,

  • 그리고 Vector ‣ Geometry Tools ‣ Export/Add Geometry Columns 메뉴의 벡터 분석 도구가 있습니다.

측정 작업은 (UTM 같은) 투영좌표계 및 투영체가 정의되지 않은 데이터 안에서 이루어집니다. 처음 세 가지 측정 도구의 습성은 일반 투영 설정과 동일합니다:

“실시간” 좌표계 변환을 활성화한 경우, 기본 미터 측정법으로 ─ 대부분의 다른 GIS와는 달리 ─ File ‣ Project properties ‣ General 에서 정의한 타원체를 사용합니다. 프로젝트에 지리좌표계 또는 투영좌표계를 정의한 경우 둘 다 그렇습니다. 만일 사용자가 데카르트 평면에서 투영/평면 면적 또는 거리를 계산하고자 할 경우, (File ‣ Project properties ‣ CRS 에서) 측정 타원체를 None / Planimetric 으로 설정해야 합니다. 하지만, 데이터와 프로젝트에 (투영체가 정의되지 않은) 지리좌표계를 정의한 경우, 타원체 상에서 면적 및 거리를 측정할 것입니다. “실시간” 좌표계 변환을 비활성화했다면, 프로젝트의 좌표계에 투영체를 정의한 경우 미터 측정법이 평면을 이용하고, 투영체를 정의하지 않았거나 지리좌표계인 경우 타원체를 이용합니다.

그러나 식별 도구 또는 필드 계산기 둘 다 측정 작업 전에 사용자 데이터를 프로젝트의 좌표계로 변환하지 않을 겁니다. 측정 전에 좌표계를 변환하도록 하고 싶다면, Vector ‣ Geometry Tools ‣ Export/Add Geometry Columns 벡터 분석 도구를 이용해야만 합니다. 이때 사용자가 타원체 측정법을 선택한 경우를 제외하면 기본적으로 평면 상에서 측정하게 됩니다.

쌍방향으로 길이, 면적 및 각도 측정

모든 측정 모듈은 디지타이즈 작업 모듈의 스냅(snap) 설정을 이용합니다. 사용자가 벡터 레이어의 라인 또는 면을 따라 측정하고자 할 때 유용합니다.

측정 도구를 선택하려면, measure 를 클릭한 다음 사용하고자 하는 도구를 선택하십시오.

measure Measure Line 은 기본 측정 도구로, QGIS는 정의된 타원체에 따라 설정한 포인트들 사이의 실제 거리를 측정합니다. Settings ‣ Options ‣ Map Tools 메뉴 옵션에서 고무줄 색상과 선호하는 측정 단위(미터, 피트) 및 각도 단위(도, 라디안, 그레이드)를 정의할 수 있습니다. 사용자는 이 도구를 이용해서 맵 상에 포인트들을 클릭할 수 있습니다. 각 선분의 길이가, 총계와 함께, 측정 창에 표시됩니다. 측정을 마치려면 오른쪽 클릭하십시오. 측정 대화창에서 측정 단위를 쌍방향으로 변경할 수 있다는 사실을 기억하십시오. 옵션에서 정의한 Preferred measurement units 를 무시합니다. 대화창의 정보란은 측정값을 계산하는 데 어떤 좌표계 설정을 사용하고 있는지 보여줍니다.

Figure Measure 1:

../../../_images/measure_line.png

거리 측정

measureArea Measure Area 도구로 면적도 측정할 수 있습니다. 측정 창에 누적 면적을 표시합니다. 또, 현재 선택한 레이어에 스냅 허용 오차(Setting the Snapping Tolerance and Search Radius 참조)를 설정했을 경우, 측정 도구가 레이어에 스냅할 것입니다. 따라서 라인 피처를 따라서든 폴리곤 피처를 돌아서든, 정확히 측정하려면 먼저 스냅 허용 오차를 설정한 다음 레이어를 선택해야 합니다. 그러면 측정 도구 사용 시 (허용 오차 설정 범위 내의) 각 마우스 클릭이 해당 레이어에 스냅할 것입니다.

Figure Measure 2:

../../../_images/measure_area.png

면적 측정

measureAngle Measure Angle: 도구로 각도도 측정할 수 있습니다. 커서가 십자가 형태로 바뀝니다. 사용자가 측정하려는 각도의 첫 번째 선분을 그린 다음, 커서를 움직여서 원하는 각도를 그리십시오. 측정값이 팝업 대화창에 표시됩니다.

Figure Measure 3:

../../../_images/measure_angle.png

각도 측정

피처 선택 및 선택해제

QGIS 툴바는 맵 캔버스에서 피처를 선택할 수 있는 도구를 몇 가지 제공하고 있습니다. 하나 이상의 피처를 선택하려면, select 를 클릭한 다음 다음 도구 가운데 하나를 선택하십시오:

  • selectRectangle Select Features by area or single click: 단순 클릭 또는 사각형을 그려 피처(들)을 선택

  • selectPolygon Select Features by Polygon
  • selectFreehand Select Features by Freehand
  • selectRadius Select Features by Radius

선택한 모든 피처를 선택해제하려면, deselectAll Deselect Features from All Layers 를 클릭하십시오.

expressionSelect Select features using an expression 을 클릭하면 표현식 대화창을 이용해서 피처를 선택할 수 있습니다. Expressions 에 있는 몇 가지 예시를 참조하십시오.

Edit ‣ Copy FeaturesEdit ‣ Paste Features as 메뉴를 통해 선택한 피처를 각각 원하는 유형의 새 메모리 벡터 레이어새 벡터 레이어 로 저장할 수 있습니다.

데이터 정의 무시 설정

벡터 레이어 속성창 또는 인쇄 작성자의 설정에는 많은 옵션들이 있지만, 그 중에서도 dataDefined Data defined override 아이콘이 있습니다. 레이어 속성 또는 항목 설정, 사전 빌드된/사용자 지정된 함수 그리고 변수 에 기반한 표현식 덕분에, 이 도구로 관심 파라미터에 대해 동적인 값을 설정할 수 있습니다. 이 옵션을 활성화하면, 일반적인 값(체크박스, 텍스트 란, 슬라이드 바 등등)에 상관없이 이 위젯이 반환하는 값을 파라미터에 적용합니다.

dataDefined Data defined override 아이콘을 클릭하면 다음과 같은 내용을 표시합니다:

  • 활성화한 경우, 입력해야 할 유효한 입력 유형 및 현재 정의를 설명하는 Description ...

  • 사용할 수 있는 Field type 을 목록화할 수 있는 항목

  • 사용할 수 있는 Variable 를 목록화할 수 있는 항목

  • 사용할 표현식을 생성하거나 편집할 수 있는 Edit ... 버튼

  • PasteCopy 버튼

  • 설정을 제거할 수 있는 Clear 버튼

참고

데이터로 정의된 무시 옵션을 유효하게 설정한 경우 노란색 dataDefineOn 또는 dataDefineExpressionOn 아이콘을 표시하고, 유효하지 않은 경우 빨간색 dataDefineError 또는 dataDefineExpressionError 아이콘을 표시합니다.

다음 파라미터를 데이터 정의 도구와 함께 쓸 수 있습니다:

  • 스타일 및 심볼 파라미터

  • 라벨 파라미터

  • 작성자 파라미터

피처 식별

식별 도구를 통해 맵 캔버스와 상호작용할 수 있으며 팝업창으로 피처에 대한 정보를 얻을 수 있습니다. 피처를 식별하려면, View ‣ Identify features 메뉴를 클릭하거나 Ctrl + Shift + I 단축키를 누르십시오. 또는 속성 툴바에 있는 identify Identify features 아이콘을 클릭해도 됩니다.

QGIS는 identify Identify features 도구로 피처를 식별할 수 있는 두 가지 방법을 제공합니다:

  • 왼쪽 클릭 하면 Identify results 패널에서 설정한 모드에 따라 피처를 식별합니다.

  • 오른쪽 클릭 하면 가시화된 모든 레이어에서 스냅된 모든 피처를 불러옵니다. 이 방법은 컨텍스트 메뉴를 열어, 사용자가 식별할 피처를 더 정확하게 선택할 수 있도록 해줍니다.

피처(들)을 클릭하면, 클릭한 피처(들)에 대한 정보 목록을 담은 Identify results 대화창이 열립니다. 기본 뷰는 첫 번째 항목이 레이어명이고 그 하위 항목이 식별된 피처(들)인 트리 뷰입니다. 각 피처는 필드명을 그 값과 함께 표시합니다. Properties ‣ Display 메뉴에서 이 필드를 설정합니다. 그 다음 해당 피처에 대한 다른 모든 정보를 나열합니다.

사용자 지정 필드를 표출시키기 위해 이 대화창을 사용자 지정할 수도 있지만, 기본적으로 다음 세 가지 유형의 정보를 표시할 것입니다:

  • Actions: 피처 식별 창에 액션을 추가할 수 있습니다. 액션 라벨을 클릭해서 액션을 수행합니다. 기본적으로, 편집 작업을 위한 view feature form 이라는 액션 하나가 추가돼 있습니다. 레이어의 속성 대화창에서 더 많은 액션을 정의할 수 있습니다.

  • Derived: 다른 정보로부터 계산된 또는 파생된 정보입니다. 피처 ID, 도형 유형에 따라 맵 단위로 계산된 피처의 길이 또는 둘레와 면적, 공간 부분의 개수 및 멀티 도형의 경우 클릭한 부분의 개수, 피처가 보유한 꼭짓점의 개수와 클릭한 포인트에 가장 가까운 꼭짓점 번호 등의 정보를 포함합니다. 또 클릭한 포인트 및 가장 가까운 꼭짓점 모두의 X, Y (가능한 경우 Z/M) 좌표값도 표시합니다.

  • Data attributes: 사용자가 클릭한 피처의 속성 항목 및 값들의 목록입니다.

Figure Identify 1:

../../../_images/identify_features.png

피처 식별 대화창

창 상단에 아이콘이 7개 있습니다:

  • expandTree Expand tree
  • collapseTree Collapse tree
  • expandNewTree Default behavior: 다음에 식별한 피처의 정보를 접어서 표시할지 확장해서 표시할지 정의합니다.

  • propertyItem View the feature form
  • deselectAll Clear Results
  • editCopy Copy selected feature to clipboard
  • filePrint Print selected HTML response

창 하단에는 ModeView 콤보박스가 있습니다. Mode 콤보박스를 통해 어떤 레이어에 있는 피처를 식별해야 하는지 정의할 수 있습니다:

  • ‘Current layer’: 선택한 레이어에 있는 피처만 식별합니다. 레이어가 맵 캔버스에 보이지 않을 수도 있습니다.

  • ‘Top down, stop at first’: 가시화된 레이어 가운데 가장 위에 있는 레이어의 피처만 식별합니다.

  • ‘Top down’: 가시화된 레이어들의 모든 피처를 식별합니다. 식별 결과가 패널에 표시됩니다.

  • ‘Layer selection’: 컨텍스트 메뉴를 열어서 사용자가 피처를 식별할 레이어를 선택할 수 있습니다. 오른쪽 클릭과 동일하게 동작합니다. 선택한 피처만 식별 결과 패널에 표시될 것입니다.

View 를 ‘트리’, ‘테이블’ 또는 ‘그래프’로 설정할 수 있습니다. ‘테이블’과 ‘그래프’는 래스터 레이어에 대해서만 설정할 수 있습니다.

식별 도구에서 checkbox 자동으로 양식 열기 를 이용할 수 있습니다. 이 체크박스를 체크하면, 피처를 하나 식별할 때마다 QGIS가 해당 피처의 속성을 보여주는 양식을 열 것입니다. 빠르게 피처 속성을 편집할 수 있는 편리한 방법입니다.

식별된 항목의 컨텍스트 메뉴에서 다른 기능도 찾아볼 수 있습니다. 예를 들면, 컨텍스트 메뉴를 통해 다음 작업을 할 수 있습니다:

  • 피처 양식 보기

  • 피처로 확대/축소

  • 피처 복사: 모든 피처 도형 및 속성 복사

  • 피처 집합 켜고끄기: 식별한 피처를 집합에 추가

  • 속성값 복사: 사용자가 클릭한 속성값만 복사

  • 피처 속성 복사: 피처의 속성을 복사

  • 결과 삭제: 창에서 식별 결과를 제거

  • 강조 삭제: 맵 상에서 강조된 피처를 제거

  • 모든 피처 강조

  • 레이어 강조

  • 레이어 활성화: 활성화할 레이어를 선택

  • 레이어 속성: 레이어 속성 창 열기

  • 모두 확장

  • 모두 접기

주석 도구

속성 툴바에 있는 textAnnotation Text Annotation 도구를 쓰면 QGIS 맵 캔버스에 말풍선 안에 서식을 적용한 텍스트를 입력할 수 있습니다. Text Annotation 도구를 실행한 다음 맵 캔버스를 클릭해보십시오.

Figure annotation 1:

../../../_images/annotation.png

주석 텍스트 대화창

말풍선을 더블 클릭하면 다양한 옵션을 보유한 대화창이 열립니다. 서식을 적용한 텍스트를 입력할 수 있는 텍스트 편집기와 다른 설정들을 이용할 수 있습니다. 예를 들어, 말풍선을 (마커 심볼로 표시되는) 맵 위치에 놓을지 (맵과는 상관없는) 스크린 위치에 놓을지 선택할 수 있습니다. 맵 위치를 이동시켜서 (맵 마커를 드래그해서) 말풍선을 움직일 수도 있고 그냥 말풍선만 이동시킬 수도 있습니다. 마커 심볼은 GIS 테마의 일부이며, 다른 테마에서도 기본 심볼로 쓰입니다.

annotation Move Annotation 도구를 쓰면 맵 캔버스 상에서 주석을 이동시킬 수 있습니다.

HTML 주석

속성 툴바에 있는 formAnnotation Html Annotation 도구를 쓰면 QGIS 맵 캔버스 상의 말풍선 안에 HTML 파일의 내용을 입력할 수 있습니다. Html Annotation 도구를 사용해서, 맵 캔버스를 클릭한 다음 대화창에 HTML 파일을 가리키는 경로를 추가하십시오.

SVG 주석

속성 툴바에 있는 saveAsSVG SVG Annotation 도구를 쓰면 QGIS 맵 캔버스 상의 말풍선 안에 SVG 심볼을 입력할 수 있습니다. SVG Annotation 도구를 사용해서, 맵 캔버스를 클릭한 다음 대화창에 SVG 파일을 가리키는 경로를 추가하십시오.

양식 주석

이와 별개로, 사용자만의 주석 양식을 생성할 수도 있습니다. formAnnotation Form Annotation 도구는 벡터 레이어의 속성을 사용자 지정 Qt 설계자 양식으로 (다음 그림 참조) 표시하는 데 유용합니다. 피처 식별 도구의 설계자 양식과 비슷하지만, 주석 항목 형태로 표시합니다. 더 자세한 정보를 원한다면 팀 서튼이 게시한 https://youtu.be/0pDBuSbQ02o?t=2m25s 영상을 참조하세요.

Figure annotation 2:

../../../_images/custom_annotation.png

사용자 지정 Qt 설계자 주석 양식

주석

Annotation 도구가 활성화됐을 때 (주석 이동, 텍스트 주석, 양식 주석 등) Ctrl+T 를 누르면 말풍선들의 가시성 상태가 반전됩니다.

공간 북마크

공간 북마크를 통해 지리적 위치에 “책갈피”를 끼워 나중에 다시 돌아올 수 있습니다. 북마크는 컴퓨터에 저장되는데, 동일한 컴퓨터일 경우 어떤 프로젝트에서도 사용할 수 있다는 뜻입니다.

북마크 생성

북마크를 생성하려면:

  1. 관심 지역으로 확대/축소 또는 이동하십시오.

  2. View ‣ New Bookmark 메뉴 옵션을 클릭하거나 Ctrl-B 를 누르십시오. 공간 북마크 패널이 새로 생성된 북마크와 함께 열릴 겁니다.

  3. 북마크를 잘 설명하는 명칭을 (영문자 255개까지 지원합니다) 입력하십시오.

  4. 북마크를 추가하려면 Enter 를 누르거나 패널 외 다른 곳을 클릭하십시오.

북마크 여러 개를 동일한 명칭으로 만들 수 있다는 사실을 기억하십시오.

북마크 관련 작업

북마크를 사용하거나 관리하려면, View ‣ Show Bookmarks 메뉴 옵션을 클릭하십시오. Spatial Bookmarks 패널을 통해 다음과 같은 작업을 할 수 있습니다:

  • 북마크로 확대/축소: 원하는 북마크를 선택한 다음 Zoom To Bookmark 를 클릭하십시오. 북마크를 더블 클릭해도 해당 위치로 확대/축소할 수 있습니다.

  • 북마크 삭제: 북마크를 선택한 다음 Delete Bookmark 를 클릭하십시오. 사용자가 한 번 더 확인해야 합니다.

  • 북마크 내보내기 또는 가져오기: 컴퓨터 사이에서 사용자의 북마크를 공유하거나 전송하려면 Spatial Bookmarks 대화창에 있는 Import/Export Bookmarks 풀다운 메뉴를 쓸 수 있습니다. 모든 북마크가 전송됩니다.

프로젝트 내포 작업

사용자 프로젝트에 다른 프로젝트 파일의 내용을 삽입하고자 할 경우, Layer ‣ Embed Layers and Groups 메뉴 옵션을 선택하면 됩니다.

레이어 삽입

다음 대화창을 통해 다른 프로젝트에 있는 레이어를 삽입할 수 있습니다. 다음은 간단한 예시입니다:

  1. browseButton 버튼을 클릭해서 알래스카 데이터셋을 기반으로 한 프로젝트를 찾으십시오.

  2. relations.qgs 프로젝트 파일을 선택하십시오. 프로젝트의 내용을 (다음 그림 참조) 볼 수 있습니다.

  3. Ctrl 키를 누른 채 airportsregions 레이어를 클릭한 다음, [OK] 를 누르십시오. 선택한 레이어들이 맵 범례와 맵 뷰에 삽입됩니다.

Figure Nesting 1:

../../../_images/embed_dialog.png

삽입할 레이어 및 그룹 선택

삽입한 레이어를 편집할 수 있지만, 스타일 및 라벨 같은 속성을 변경할 수는 없습니다.

삽입 레이어 제거

삽입한 레이어를 오른쪽 클릭한 다음 removeLayer Remove 를 선택하십시오.

지도 장식

QGIS의 지도 장식은 그리드, 저작권 라벨, 방위표 및 축척 막대를 포함하며, 지도 제작 요소를 추가해 맵을 ‘장식’하는 데 쓰입니다.

그리드

transformed Grid 를 통해 맵 캔버스에 좌표 격자 및 좌표 주석을 추가할 수 있습니다.

Figure Decorations 1:

../../../_images/grid_dialog.png

그리드 대화창

  1. 메뉴에서 View ‣ Decorations ‣ Grid 를 선택하십시오. 대화창이 열립니다. (앞의 그림 을 참조하십시오.)

  2. checkbox Enable grid 체크박스를 체크해서 활성화한 다음 맵 캔버스에 불러온 레이어에 맞춰 그리드 정의를 설정하십시오.

  3. checkbox Draw annotations 체크박스를 체크해서 활성화한 다음 맵 캔버스에 불러온 레이어에 맞춰 주석 정의를 설정하십시오.

  4. 기대한 대로 보이는지 확인하려면 [Apply] 를 클릭하고, 만족스러울 경우 [OK] 를 클릭하십시오.

방위표

northArrow North Arrow 도구는 맵 캔버스 상에 간단한 방위표를 삽입합니다. 현재 사용할 수 있는 스타일은 하나뿐입니다. 사용자가 방위표의 각도를 조정하거나, QGIS가 방향을 자동적으로 설정하도록 할 수 있습니다. QGIS가 방향을 결정하도록 선택한 경우, QGIS는 방위표의 방향을 어떻게 잡아야 하는지 최선을 다해 추측합니다. 맵 캔버스의 구석 자리라는 네 가지 옵션 가운데 방위표의 위치를 선택할 수 있습니다. 수평 그리고/또는 수직 Marging from (Canvas) Edge 를 설정해서 방위표의 위치를 미세 조정할 수 있습니다. 이 값들은 밀리미터 또는 픽셀 단위의 거리일 수도 있고, 맵 캔버스의 너비 또는 높이의 백분율 로 설정할 수도 있습니다.

Figure Decorations 3:

../../../_images/north_arrow_dialog.png

방위표 대화창

축척 막대

scaleBar Scale Bar 도구는 맵 캔버스에 단순한 축척 막대를 추가합니다. 사용자가 스타일과 위치는 물론 막대의 라벨도 제어할 수 있습니다.

Figure Decorations 4:

../../../_images/scale_bar_dialog.png

축척 막대 대화창

QGIS에서는 축척을 사용자 맵 프레임과 동일한 단위로만 표시할 수 있습니다. 따라서 사용자 레이어의 단위가 미터라면, 축척 막대를 피트 단위로 생성할 수 없습니다. 마찬가지로, 사용자가 십진수도(decimal degrees)를 사용하고 있다면, 미터 단위로 거리를 표시하는 축척 막대를 생성할 수 없습니다.

축척 막대를 추가하려면:

  1. 메뉴에서 View ‣ Decorations ‣ Scale Bar 를 선택하십시오. 대화창이 열립니다. (앞의 그림 을 참조하십시오.)

  2. checkbox Enable scale bar 체크박스가 체크되어 있는지 확인하십시오.

  3. Scale bar style selectString 콤보박스를 이용해서 축척 막대의 스타일을 선택하십시오.

  4. Color of bar selectColor 에서 막대의 색상을 선택하거나, 기본 색상인 검정색을 사용하십시오.

  5. Size of bar selectNumber 를 설정하십시오.

  6. checkbox Automatically snap to round number on resize 를 체크해서 축척값을 읽기 쉽게 표시할 수도 있습니다.

  7. Placement selectString 콤보박스를 이용해서 막대의 위치를 선택하십시오.

  8. 수평 그리고/또는 수직 Marging from (Canvas) Edge 를 설정해서 라벨의 위치를 미세 조정할 수 있습니다. 이 값들은 밀리미터 또는 픽셀 단위의 거리일 수도 있고, 맵 캔버스의 너비 또는 높이의 백분율 로 설정할 수도 있습니다.

  9. 기대한 대로 보이는지 확인하려면 [Apply] 를 클릭하고, 만족스러울 경우 [OK] 를 클릭하십시오.

참고

지도 장식 설정

사용자가 .qgs 프로젝트 파일을 저장할 때 그리드, 방위표, 축척 막대 그리고 저작권 라벨에 대한 어떤 변경 사항이든 프로젝트에 저장되어 다음에 프로젝트를 불러올 때 함께 복구될 것입니다.

인증

QGIS에는 안전한 방식으로 인증서(authentication credentials)를 저장/검색할 수 있는 기능이 있습니다. 사용자는 인증 환경 설정 안에 인증서를 안전하게 저장할 수 있는데, 인증 환경 설정은 자체 데이터베이스에 저장되어 서버 또는 데이터베이스 연결에 적용할 수 있으며 프로젝트 또는 설정 파일 내부에서 ID 토큰으로 안전하게 참조할 수 있습니다. 더 자세한 정보를 원한다면 Authentication System 을 참조하세요.

인증 시스템 및 그 자체 데이터베이스를 처음 실행할 때 마스터 비밀번호를 설정해줘야 합니다.

레이어를 파일로 저장

레이어 트리에 있는 레이어를 오른쪽 클릭하면 나타나는 레이어 컨텍스트 메뉴에서 Save As... 기능을 선택하거나, Layer ‣ Save As... 메뉴를 선택해서 래스터 또는 벡터 레이어를 또다른 유형으로 저장할 수 있습니다.

Save As 대화창에는 레이어 저장 시의 습성을 변경할 수 있는 파라미터가 몇 가지 있습니다. 래스터 및 벡터 레이어에 공통된 파라미터는 다음과 같습니다:

  • 유형

  • 파일명

  • 좌표계

  • 캔버스에 새 레이어를 추가하기 위해 맵에 저장 파일을 추가

  • 범위(레이어, 맵 뷰 또는 사용자 지정 범위의 값을 사용할 수 있습니다)

  • 몇몇 고급 옵션을 변경할 수 있도록 해주는 레이어 옵션, (래스터 용) 생성 옵션 또는 (벡터 용) 사용자 지정 옵션도 있습니다. 고급 사용자의 경우 GDAL 문서 가운데 드라이버 문서를 살펴볼 수 있습니다.

그런데 다음 몇몇 파라미터는 래스터 및 벡터 유형에 맞춰져 있습니다:

  • 래스터 특화 파라미터:

    • 해상도(수평 및 수직)

    • 피라미드 생성

    • 산출물 모드(가공되지 않은 데이터 또는 렌더링된 이미지)

  • 벡터 특화 파라미터:

    • 인코딩

    • 선택한 피처만 저장

    • 속성 생성 건너뛰기

    • 심볼 내보내기: 주로 DXF 내보내기에 사용되지만, DXF, KML, TAB 파일 유형 같은 OGR 피처 스타일을 관리하는 (다음 주석 참조) 모든 파일 유형을 내보낼 수 있습니다.

      • No symbology: 데이터를 읽는 응용 프로그램의 기본 스타일

      • Feature symbology: OGR 피처 스타일로 스타일을 저장 (다음 주석 참조)

      • Symbol Layer symbology: OGR 피처 스타일로 저장(다음 주석 참조)하지만 심볼 레이어가 반복해서 이용한 심볼이 있을 경우 동일 도형을 반복해서 내보냅니다.

    • 도형:

      • 멀티 도형으로 강제 변환

      • Z 차원 추가

      • 드롭다운 목록을 통해 도형 열을 추가 또는 제거합니다. 레이어의 현재 도형 유형과는 연결되지 않습니다. 속성 테이블에 비어 있는 도형 열을 추가하고, 공간 레이어의 도형 열을 제거할 수 있습니다.

주석

OGR 피처 스타일 은 데이터에 스타일을 숨은 속성으로 직접 저장할 수 있는 방법입니다. 몇몇 유형만이 이런 종류의 정보를 처리할 수 있습니다. KML, DXF 및 TAB 파일이 바로 그런 파일 유형입니다. 고급 사용자인 경우 OGR 피처 스타일 사양 문서를 살펴볼 수 있습니다.

주석

DXF 파일에 대해

벡터 레이어의 경우 또다른 도구인 Project 메뉴의 DXF Export ... 를 사용해서 DXF 파일로 내보낼 수 있습니다. 대화창에서 레이어 파일, 심볼 모드(앞의 내용 참조), 심볼 축척, 인코딩, 가시성 사전 설정 및 DXF 파일에 포함시킬 레이어를 선택할 수 있습니다.

checkbox Use the layer title as name if set 또는 Export features intersecting the current map extent 옵션을 이용할 수 있습니다.

동적 내용을 위한 변수 이용

사용자는 표현식에 이용할 사용자 지정 변수를 정의할 수 있습니다. 응용 프로그램 전체 수준, 프로젝트 수준, 레이어 수준 그리고 작성 수준에서 변수를 정의할 수 있습니다. CSS의 순차적(cascading) 규칙처럼, 변수도 덮어 쓸 수 있습니다 ─ 예를 들어, 프로젝트 수준의 변수는 모든 응용 프로그램 수준의 변수를 덮어 쓸 것입니다. 변수명 앞에 @ 문자를 붙여서 텍스트 문자열 또는 다른 사용자 지정 표현식을 만드는 데 쓸 수 있습니다. 다음은 작성자가 라벨을 생성하는 예시입니다:

This map was made using QGIS [% @qgis_version %]. The project file for this
map is: [% @project_path %]

다음과 같은 라벨로 렌더링될 겁니다:

This map was made using QGIS 2.14. The project file for this map is:
/gis/qgis-user-conference-2015.qgs

Settings ‣ Options 메뉴에서 전체 수준 변수를 관리할 수 있고, 프로젝트 속성에서 (사용자 지정 변수 추가 포함) 프로젝트 수준 변수를 관리할 수 있습니다.

Figure Variables dialog 2:

../../../_images/options_variables.png

Edit variable at the project level

주석

QGIS 2.12에서 변수 탐구, 1부, 2부 그리고 3부 에서 더 자세한 정보와 예시들을 찾아볼 수 있습니다.