Outdated version of the documentation. Find the latest one here.

QGIS 환경 설정

Settings 메뉴를 통해 QGIS 환경을 매우 자세하게 설정할 수 있습니다. 프로젝트 속성, 옵션 및 사용자 지정 가운데 선택하세요.

주석

QGIS는 옵션 및 프로젝트 속성 항목의 위치에 대해 데스크탑 지침을 따릅니다. 그 결과 사용자의 OS에 따라, 이 문서에서 설명하는 몇 가지 항목들의 위치가 Project 메뉴에 있거나 또는 Settings 메뉴에 있을 수 있습니다.

프로젝트 속성

nix Settings ‣ Project Properties (KDE) 또는 nix osx win Project ‣ Project Properties (Gnome, OS X 또는 윈도우) 메뉴의 프로젝트 속성창에서 프로젝트 특화 옵션들을 설정할 수 있습니다.

  • General 탭의 일반 설정 을 통해:

    • 프로젝트 파일 경로 아래에 프로젝트 명을 부여할 수 있고

    • 피처 선택 시 피처에 적용할 색상을 선택할 수 있고

    • 배경색 ─ 맵 캔버스에 적용할 색상 ─ 을 선택할 수 있으며

    • 프로젝트 내부의 레이어를 가리키는 경로를 절대 경로(전체 경로)로 저장할지 프로젝트 파일 위치에 상대적인 상대 경로로 저장할지 설정할 수 있습니다. 레이어 및 프로젝트 파일이 이동 또는 공유될 가능성이 있거나, 다른 플랫폼을 이용하는 컴퓨터에서 프로젝트에 접근하는 경우, 상대 경로가 더 적당할 수도 있습니다.

    • 프로젝트를 맵 타일로 렌더링할 때 인공물(artifact)을 제외하도록 선택할 수 있습니다. 이 옵션을 체크하면 성능이 저하될 수도 있다는 점을 주의하십시오.

    GIS에서 면적 및 거리를 계산해야 하는 일은 매우 흔합니다. 하지만, 이런 계산값은 기저 투영체 설정과 관련이 깊습니다. 측정 프레임을 통해 이런 파라미터들을 제어할 수 있습니다. 사용자는 다음과 같은 옵션을 선택할 수 있습니다:

    • 사용할 타원체: 기존 타원체, 사용자 지정 타원체(사용자가 반장축semi-major axis 및 반단축semi-minor axis 값을 설정해야 합니다) 또는 None/Planimetric 가운데 선택할 수 있습니다.

    • 길이 및 둘레에 대한 units for distance measurementsunits for area measurements 옵션. 현재 프로젝트에서 QGIS 옵션에 설정된 기본 단위를 무시하게 만드는 이 설정은 다음에 사용됩니다:

      • 속성 테이블 항목 업데이트 바

      • 필드 계산기 계산

      • 식별 도구에서 파생되는 길이, 둘레 및 면적 값

      • 측정 대화창에 표시되는 기본 단위

    좌표 표시 옵션으로 상태 바에 표시되는 마우스 좌표 및 식별 도구에 표시되는 파생 좌표에 쓰이는 단위의 유형을 선택하고 사용자 지정할 수 있습니다.

    마지막으로, 전체 수준의 사전 정의된 축척을 무시하는 프로젝트 축척 을 정의할 수 있습니다.

Figure General Menu:

../../../_images/project_general.png

프로젝트 속성 대화창의 일반 탭

  • CRS 탭에서 현재 프로젝트에 적용할 좌표계를 선택할 수 있고, 서로 다른 좌표계에 기반한 레이어를 표출할 때 래스터 및 벡터 레이어의 실시간 재투영을 활성화할 수 있습니다.

  • Identify layers 탭에서 어떤 레이어가 식별 도구 에 응답할지 설정(또는 해제)할 수 있습니다. 기본적으로 레이어는 쿼리 가능하게 설정돼 있습니다.

  • Default Styles 탭에서 사전 정의된 .qml 스타일이 없는 새 레이어를 어떻게 렌더링할지 제어할 수 있습니다. 또 새 레이어의 기본 투명도 수준 및 심볼에 랜덤한 색상을 할당할지 여부도 설정할 수 있습니다. 현재 실행 중인 프로젝트를 위한 지정 색상들을 정의할 수 있는 옵션도 있습니다. 각 렌더링 작업자(renderer)에 있는 색상 대화창의 드롭다운 메뉴에서 추가한 색상을 찾아볼 수 있습니다.

  • OWS Server 탭에서 QGIS 서버의 WMS 및 WFS 능력, 범위 및 좌표계 제한 조건에 대한 정보를 정의할 수 있습니다.

  • Macros 탭은 프로젝트를 위한 파이썬 매크로를 편집하는 데 쓰입니다. 현재, openProject(), saveProject() 그리고 closeProject() 세 가지 매크로만 사용할 수 있습니다.

Figure Macro Menu:

../../../_images/macro.png

QGIS의 매크로 설정

  • Relations 탭은 일대다(1:n) 관계를 정의하는 데 쓰입니다. 프로젝트 속성 대화창에서 관계를 정의합니다. 어떤 레이어에 대해 관계가 존재하는 경우, 양식 뷰에 있는 새 사용자 인터페이스 요소가 (예를 들어 피처를 식별하고 그 양식을 열 때) 관련 요소들의 목록을 표출할 것입니다. 이렇게 되면, 예를 들어 어떤 파이프라인 또는 도로 구간의 점검 이력을 보여줄 수 있는 강력한 방법이 생기는 겁니다. Creating one to many relations 에서 일대다 관계에 대한 더 자세한 내용을 찾아볼 수 있습니다.

옵션

options Options 대화창을 통해 QGIS에 대한 몇몇 기본 옵션을 선택할 수 있습니다. Settings ‣ options Options 메뉴 옵션을 선택합니다. 사용자 고유 옵션을 사용자 지정할 수 있는 탭들에 대해 다음에서 설명하고 있습니다.

일반 메뉴

응용 프로그램

  • Style (QGIS restart required) selectString 을 선택한 다음 ‘Oxygen’, ‘Windows’, ‘Motif’, ‘CDE’, ‘Plastique’ 그리고 ‘Cleanlooks’ (nix) 가운데 하나를 선택합니다.

  • Icon theme selectString 를 정의합니다. 지금은 ‘default’만 사용할 수 있습니다.

  • Icon size selectString 를 정의합니다.

  • Font 를 정의합니다. radioButtonOn Qt default 와 사용자 정의 폰트 가운데 선택하세요.

  • Timeout for timed messages or dialogs selectString 을 변경합니다.

  • checkbox Hide splash screen at startup
  • checkbox Show tips at startup
  • checkbox Bold group box titles
  • checkbox QGIS-styled group boxes
  • checkbox Use native color chooser dialogs
  • checkbox Use live-updating color chooser dialogs
  • checkbox Custom side bar style
  • checkbox Experimental canvas rotation support (restart required)

프로젝트 파일

  • Open project on launch selectString 을 선택한 다음 ‘New’, ‘Most recent’ 그리고 ‘Specific’ 가운데 하나를 선택합니다. ‘Specific’을 선택한 경우 |browseButton| 버튼을 이용해서 프로젝트를 정의합니다.

  • checkbox Create new project from default project 을 선택한 다음 Set current project as default 또는 Reset default 가운데 하나를 클릭할 수 있습니다. 사용자 파일을 탐색하고 사용자가 직접 정의한 프로젝트 템플릿이 있는 디렉터리를 정의할 수 있습니다. 이 템플릿을 Project ‣ New From Template 메뉴에 추가할 것입니다. 먼저 checkbox Create new project from default project 을 활성화한 경우, 프로젝트 템플릿 폴더에 프로젝트를 저장하십시오.

  • checkbox Prompt to save project and data source changes when required
  • checkbox Prompt for confirmation when a layer is to be removed
  • checkbox Warn when opening a project file saved with an older version of QGIS
  • Enable macros selectString 옵션은 프로젝트 이벤트에 대한 액션을 수행하기 위해 작성된 매크로를 처리하기 위해 생성됐습니다. ‘Never’, ‘Ask’, ‘For this session only’ 그리고 ‘Always (not recommended)’ 가운데 선택할 수 있습니다.

시스템 메뉴

환경

이제 Environment 그룹에서 (다음 그림 참조) 시스템 환경 변수를 살펴볼 수 있고, 많은 변수를 설정할 수 있습니다. 이 옵션은 맥 OS X처럼 GUI 응용 프로그램이 사용자의 셸 환경을 반드시 상속하지는 않는 플랫폼에서 유용합니다. SAGA, GRASS 같은 공간 처리 도구 상자가 제어하는 외부 도구 모음 용 환경 변수들을 설정하고 살펴보는 데에도, 그리고 소스 코드의 특정 부분에 대해 산출물을 디버그하는 작업을 활성화시키는 데에도 유용합니다.

  • checkbox Use custom variables (restart required - include separators) 을 활성화하면 변수들을 [추가] 하고 [삭제] 할 수 있습니다. Current environment variables 에 사전 정의한 환경 변수를 표시하며, checkbox Show only QGIS-specific variables 를 활성화해서 환경변수를 필터링할 수도 있습니다.

Figure System Environment:

../../../_images/sys-env-options.png

QGIS의 시스템 환경 변수

플러그인 경로

Path(s) to search for additional C++ plugin libraries[추가] 또는 [삭제] 합니다.

데이터소스 메뉴

피처 속성 및 테이블

  • checkbox Open attribute table in a dock window (QGIS restart required)
  • checkbox Copy geometry in WKT representation from attribute table 를 활성화하면 Attribute table 에서 copySelected Copy selected rows to clipboard 를 사용할 때, 포인트 또는 꼭짓점의 좌표도 함께 클립보드로 복사합니다.

  • Attribute table behavior selectString 에서 ‘Show all features’, ‘Show selected features’ 및 ‘Show features visible on map’ 세 가지 습성 가운데 하나를 선택할 수 있습니다.

  • Attribute table row cache selectNumber 에서 속성 테이블 관련 작업을 빠르게 처리할 수 있도록 최근 속성 행을 몇 개나 행 캐시에 저장할지 설정할 수 있습니다. 속성 테이블을 닫으면 캐시를 삭제합니다.

  • Representation for NULL values 을 통해 NULL 값을 포함하는 데이터 항목을 위한 값을 정의할 수 있습니다.

데이터소스 처리

  • Scan for valid items in the browser dock selectString 을 통해 ‘Check extension’ 과 ‘Check file contents’ 가운데 하나를 선택할 수 있습니다.

  • Scan for contents of compressed files (.zip) in browser dock selectString 을 통해 ‘No’, ‘Basic scan’ 과 ‘Full scan’ 가운데 하나를 선택할 수 있습니다.

  • Prompt for raster sublayers when opening. 일부 래스터는 하위 레이어 ─ GDAL에서 하위 데이터셋이라고 부르는 ─ 를 지원합니다. netCDF 파일이 한 예입니다. netCDF 변수가 여러 개 있을 경우, GDAL은 모든 변수를 하위 데이터셋으로 간주합니다. 이 옵션은 하위 레이어를 보유한 파일을 열었을 때 하위 레이어를 어떻게 처리할지를 제어할 수 있게 해줍니다. 다음 가운데 하나를 선택할 수 있습니다:

    • ‘Always’: (하위 레이어가 존재할 경우) 항상 물어봅니다.

    • ‘If needed’: 레이어에 밴드는 없지만 하위 레이어는 있을 경우 물어봅니다.

    • ‘Never’: 물어보지 않고, 아무것도 불러오지 않습니다.

    • ‘Load all’: 물어보지 않지만, 모든 하위 레이어를 불러옵니다.

  • checkbox Ignore shapefile encoding declaration 를 체크하면 shapefile에 인코딩 정보가 있더라도 QGIS가 무시할 것입니다.

  • checkbox Add PostGIS layers with double click and select in extended mode
  • checkbox Add Oracle layers with double click and select in extended mode
  • checkbox Execute expressions on server-side if possible
  • checkbox create transaction groups automatically whenever possible (Experimental) 모드를 활성화한 경우, 동일 데이터베이스로부터 나온 모든 (PostgreSQL) 레이어의 편집 상태를 동기화합니다. 예를 들어, 레이어 하나를 편집 상태로 만들면 모든 레이어가 편집 상태로 바뀝니다. 레이어 하나를 커밋하거나 롤백하면, 다른 레이어들도 그렇게 됩니다. 또한 편집 변경 사항을 로컬에서 버퍼링하는 대신, 사용자가 레이어 저장을 클릭할 경우 커밋되는 데이터베이스로 직접 전송합니다.

숨겨진 탐색 경로

이 위젯은 사용자가 탐색 패널에서 숨기기로 선택한 모든 폴더 목록을 표시합니다. 이 목록에서 폴더를 제거하면 탐색 패널에 표시될 것입니다.

렌더링 메뉴

렌더링 습성

  • checkbox By default new layers added to the map should be displayed
  • checkbox Use render caching where possible to speed up redraws
  • checkbox Render layers in parallel using many CPU cores
  • checkbox Max cores to use
  • Map update interval (default to 250 ms)
  • checkbox Enable feature simplification by default for newly added layers
  • Simplification threshold
  • checkbox Simplify on provider side if possible
  • Maximum scale at which the layer should be simplified

렌더링 질

  • checkbox Make lines appear less jagged at the expense of some drawing performance

래스터

  • RGB band selection 을 이용해서 적색, 녹색, 청색 밴드의 번호를 정의할 수 있습니다.

Contrast enhancement

  • Single band gray selectString. 단일 회색조 밴드를 렌더링할 때 ‘No stretch’, ‘Stretch to MinMax’, ‘Stretch and Clip to MinMax’ 그리고 ‘Clip to MinMax’ 네 가지 옵션이 있습니다.

  • Multi band color (byte/band) selectString. ‘No stretch’, ‘Stretch to MinMax’, ‘Stretch and Clip to MinMax’ 그리고 ‘Clip to MinMax’ 네 가지 옵션이 있습니다.

  • Multi band color (>byte/band) selectString. ‘No stretch’, ‘Stretch to MinMax’, ‘Stretch and Clip to MinMax’ 그리고 ‘Clip to MinMax’ 네 가지 옵션이 있습니다.

  • Limits (minimum/maximum) selectString. ‘Cumulative pixel count cut’, ‘Minimum/Maximum’, ‘Mean +/- standard deviation’ 세 가지 옵션이 있습니다.

  • Cumulative pixel count cut limits
  • Standard deviation multiplier

디버그

  • checkbox Map canvas refresh

색상 메뉴

이 메뉴를 통해 렌더링 작업자의 각 색상 대화창에 몇몇 사용자 지정 색상을 추가할 수 있습니다. 탭에 사전 정의 색상 집합이 있는데, 사용자가 전부 삭제하거나 편집할 수 있습니다. 거기에 원하는 색상을 추가할 수도 있고, 복사 및 붙여넣기 같은 작업을 수행할 수도 있습니다. 마지막으로 색상 집합을 gpl 파일로 내보내거나 불러올 수 있습니다.

캔버스 및 범례 메뉴

(프로젝트 속성으로 무시되는) 기본 맵 모양

  • Selection colorBackground color 을 정의합니다.

레이어 범례

  • Double click action in legend selectString. 더블 클릭을 하면 ‘레이어 속성창 열기’를 할지 ‘속성 테이블 열기’를 할지 선택할 수 있습니다.

  • Legend item styles 에서 다음 스타일을 사용할 수 있습니다:

    • checkbox Capitalise layer names
    • checkbox Bold layer names
    • checkbox Bold group names
    • checkbox Display classification attribute names
    • checkbox Create raster icons (may be slow)

맵 도구 메뉴

이 메뉴는 Identify tool 의 습성과 관련된 몇 가지 옵션을 제공합니다.

  • Search radius for identifying and displaying map tips 은 맵 너비의 백분율로 표현하는 허용 오차 인수입니다. 즉 사용자가 이 허용 오차 안에서 클릭하는 한 식별 도구가 결과를 표시할 것이란 뜻입니다.

  • Highlight color 에서 식별된 피처를 어떤 색상으로 강조할지 선택할 수 있습니다.

  • Buffer 에서 식별 강조 윤곽선을 어느 정도의 버퍼 거리로 렌더링할지 설정합니다.

  • Minimum width 에서 강조된 객체의 윤곽선을 얼마나 굵게 할지 설정합니다.

측정 도구

  • 측정 도구 용 Rubberband color 를 정의합니다.

  • Decimal places 를 정의합니다.

  • checkbox Keep base unit 을 체크하면 자동적으로 큰 숫자로 (예를 들어 미터를 킬로미터로) 변환하는 걸 막아줍니다.

  • Preferred distance units radioButtonOn (‘Meters’, ‘Feet’, ‘Nautical Miles’, ‘Degrees’ or ‘Map Units’ )
  • Preferred area units radioButtonOn (‘Square meters’, ‘Square feet’, ‘Square yards’, ‘Hectares’, ‘Map Units’ ...)
  • Preferred angle units radioButtonOn (‘Degrees’, ‘Radians’, ‘Gon/gradians’, ‘Minutes of arc’ ...)

이동 및 확대/축소

  • Mouse wheel action selectString 에서 ‘Zoom’, ‘Zoom and recenter’, ‘Zoom to mouse cursor’, ‘Nothing’ 가운데 하나를 선택합니다.

  • 마우스 휠 용 Zoom factor 를 정의합니다.

사전 정의 축척

여기에서 사전 정의된 축척 목록을 볼 수 있습니다. signPlus|signMinus| 버튼으로 사용자 지정 축척을 추가하거나 제거할 수 있습니다. 또 축척을 .XML 파일 유형으로 내보내거나 불러올 수 있습니다. 사용자 변경 사항을 제거하고 사전 정의 목록으로 리셋할 수 있다는 사실을 기억하십시오.

작성자 메뉴

작성 기본값

여기에서 Default font 를 정의할 수 있습니다.

그리드 모양

  • Grid style selectString 에서 ‘Solid’, ‘Dots’, ‘Crosses’ 가운데 하나를 선택합니다.

  • Grid color 를 정의합니다.

그리드 및 가이드 기본값

  • Grid spacing selectNumber 을 정의합니다.

  • Grid offset selectNumber 의 x 및 y를 정의합니다.

  • Snap tolerance selectNumber 를 정의합니다.

디지타이즈 메뉴

피처 생성

  • checkbox Suppress attributes pop-up windows after each created feature
  • checkbox Reuse last entered attribute values
  • Validate geometries. 많은 노드를 보유한 복잡한 라인 및 폴리곤을 편집하는 작업은 렌더링이 아주 느려질 수 있습니다. QGIS의 기본 유효성 확인 과정에 시간이 오래 걸릴 수 있기 때문입니다. GEOS 도형 유효성 확인을 (GEOS 3.3 버전부터 사용할 수 있습니다) 활성화하거나, 도형 유효성 확인 과정을 비활성화해서 렌더링 속도를 높일 수 있습니다. GEOS 도형 유효성 확인은 훨씬 빠르지만, 첫 도형 문제만 표시한다는 단점이 있습니다.

고무줄

  • 고무줄의 Line widthLine color 을 정의합니다.

스냅

  • checkbox Open snapping options in a dock window (QGIS restart required)
  • Default snap mode selectString 를 정의합니다. ‘To vertex’, ‘To segment’, ‘To vertex and segment’, ‘Off’ 가운데 하나를 선택할 수 있습니다.

  • Default snapping tolerance 를 정의합니다. 맵 단위 또는 픽셀 개수로 설정할 수 있습니다.

  • Search radius for vertex edits 을 정의합니다. 맵 단위 또는 픽셀 개수로 설정할 수 있습니다.

꼭짓점 마커

  • checkbox Show markers only for selected features
  • 꼭짓점 Marker style selectString 을 정의합니다. ‘Cross’ (default), ‘Semi transparent circle’ 또는 ‘None’ 가운데 하나를 선택할 수 있습니다.

  • 꼭짓점 Marker size 를 정의합니다.

곡선 오프셋 도구

다음 세 가지 옵션은 Advanced digitizingoffsetCurve Offset Curve 에서 쓰입니다. 다양한 설정을 통해, 라인 오프셋의 형태를 변경할 수 있습니다. GEOS 3.3 버전부터 이 옵션들을 사용할 수 있습니다.

  • Join style
  • Quadrant segments
  • Miter limit

GDAL 메뉴

GDAL은 래스터 파일 용 데이터 교환 라이브러리입니다. 이 탭에서 래스터 유형의 Edit create optionsEdit Pyramids Options 을 정의할 수 있습니다. 래스터 유형에 대해 어떤 GDAL 드라이버를 사용할지 정의합니다. 몇몇 경우 GDAL 드라이버를 하나 이상 사용할 수 있습니다.

좌표계 메뉴

새 프로젝트를 위한 기본 좌표계

  • radioButtonOff Don’t enable ‘on the fly’ reprojection
  • radioButtonOn Automatically enable ‘on the fly’ reprojection if layers have different CRS
  • radioButtonOff Enable ‘on the fly’ reprojection by default
  • 좌표계와 Always start new projects with this CRS 을 선택합니다.

새 레이어를 위한 좌표계

새 레이어를 생성하거나 좌표계가 정의되지 않은 레이어를 불러올 때 수행할 액션을 이 옵션으로 정의할 수 있습니다.

  • radioButtonOn Prompt for CRS
  • radioButtonOff Use project CRS
  • radioButtonOff Use default CRS

기본 데이터 변환

  • checkbox Ask for datum transformation when no default is defined
  • 사용자가 ‘실시간’ 좌표계 변환을 활성화한 채 작업했다면 변환 결과를 아래 창에서 확인할 수 있습니다. ‘Source CRS’ 및 ‘Destination CRS’ 는 물론 ‘Source datum transform’ 및 ‘Destination datum transform’ 에 대한 정보를 찾아볼 수 있습니다.

로케일 메뉴

  • checkbox Overwrite system localeLocale to use instead

  • 활성화된 시스템 로케일에 대한 정보

인증

Authentication 탭에서 인증 환경을 설정하고 PKI 인증서를 관리할 수 있습니다. 더 자세한 내용은 Authentication System 을 참조하세요.

네트워크 메뉴

일반

  • WMS search address 를 정의합니다. 기본값은 http://geopole.org/wms/search?search=\%1\&type=rss 입니다.

  • Timeout for network requests (ms) 을 정의합니다. 기본값은 60,000입니다.

  • Default expiration period for WMSC/WMTS tiles (hours) 을 정의합니다. 기본값은 24입니다.

  • Max retry in case of tile request errors 를 정의합니다.

  • User-Agent 를 정의합니다.

Figure Network Tab:

../../../_images/proxy-settings.png

QGIS의 프록시 설정

캐시 설정

Directory 와 캐시 용 Size 을 정의합니다.

  • checkbox Use proxy for web access 를 체크하고 ‘Host’, ‘Port’, ‘User’ 그리고 ‘Password’를 정의합니다.

  • 사용자의 필요에 따라 Proxy type selectString 을 설정합니다.

    • Default Proxy: 응용 프로그램이 사용하는 프록시 설정을 바탕으로 프록시를 결정합니다.

    • Socks5Proxy: 모든 종류의 연결에 쓸 수 있는 일반 프록시입니다. TCP, UDP, 지정 포트(들어오는 연결) 그리고 인증을 지원합니다.

    • HttpProxy: “CONNECT” 명령어로 시행되며, 나가는 TCP 연결만 지원하고, 인증을 지원합니다.

    • HttpCachingProxy: 통상적인 HTTP 명령어로 시행되며, HTTP 요청이라는 맥락 안에서만 유용합니다.

    • FtpCachingProxy: FTP 프록시를 이용해서 시행되며, FTP 요청이라는 맥락 안에서만 유용합니다.

프록시 설정 아래에 있는 텍스트 상자에 제외시킬 URL을 추가할 수 있습니다. (앞의 그림 참조)

서로 다른 프록시 설정에 대한 자세한 정보가 필요한 경우, http://doc.trolltech.com/4.5/qnetworkproxy.html#ProxyType-enum 에 있는 기저 Qt 라이브러리 문서를 참조하십시오.

참고

프록시 사용

프록시를 사용한다는 건 때로 까다로울 수 있습니다. 앞에서 설명한 프록시 유형들을 ‘시행착오’를 거쳐 가며 사용자의 환경에서 어떤 유형이 작동하는지 확인해 나가는 편이 좋습니다.

사용자의 필요에 따라 옵션들을 조정할 수 있습니다. 일부 변경 사항들은 적용되기 전에 QGIS를 재시작해야 할 수도 있습니다.

  • nix $HOME/.config/QGIS/QGIS2.conf 텍스트 파일에 설정을 저장합니다.

  • osx $HOME/Library/Preferences/org.qgis.qgis.plist 파일에 설정을 저장합니다.

  • win HKEY\CURRENT_USER\Software\QGIS\qgis 레지스트리에 설정을 저장합니다.

사용자 지정

사용자 지정 작업 대화창을 통해 QGIS 사용자 인터페이스의 거의 모든 요소를 (비)활성화할 수 있습니다. 최종 사용자가 필요로 하는 아이콘, 메뉴 또는 패널만 있는 ‘가벼운’ QGIS 버전을 제공하고자 할 때 매우 유용합니다.

주석

사용자 변경 사항을 적용하려면 QGIS를 재시작해야 합니다.

Figure Customization 1:

../../../_images/customization.png

사용자 지정 작업 대화창

checkbox Enable customization 체크박스를 체크하는 일이 QGIS 사용자 지정 작업의 첫 번째 단계입니다. 툴바 및 위젯 패널을 활성화하는데, 이 패널에서 몇몇 GUI 항목을 체크 해제해서 쓸 수 없게 만들 수 있습니다.

환경을 설정할 수 있는 항목은 다음과 같습니다:

  • 메뉴 또는 메뉴 바 에 있는 몇몇 하위 메뉴

  • 패널 전체 (패널 및 툴바 참조)

  • 상태 바 에서 설명한 상태 바 또는 상태 바의 몇몇 항목들

  • 툴바 전체 또는 툴바의 몇몇 아이콘들

  • 라벨, 버튼, 콤보박스 등 QGIS의 모든 대화창의 모든 위젯

select Switch to catching widgets in main application 을 쓰면, QGIS 인터페이스에서 사용자가 숨기고 싶은 항목을 클릭할 수 있습니다. 그러면 QGIS가 사용자 지정 작업 대화창에서 대응 항목을 자동적으로 체크 해제할 것입니다.

사용자 환경 설정을 마친 다음, 사용자가 변경한 사항을 확인하려면 [적용] 또는 [확인] 을 클릭하십시오. 다음번에 QGIS를 시작할 때 이 환경 설정을 기본값으로 이용할 것입니다.

fileSave Save To File 버튼을 클릭하면 변경 사항들을 .ini 파일로도 저장할 수 있습니다. 사용자 여러 명이 QGIS 인터페이스를 공유할 수 있는 간편한 방법입니다. 다른 컴퓨터에서 이 .ini 파일을 불러오려면 fileOpen Load from File 만 클릭하면 됩니다. 또 명령어 도구 를 실행해서 서로 다른 사용 목적을 위해 다양한 설정을 저장할 수도 있습니다.

참고

사전 정의된 QGIS를 손쉽게 복구

다음 방법들 가운데 하나를 통해 초기 QGIS GUI 환경 설정을 복수할 수 있습니다:

  • 사용자 지정 작업 대화창에서 checkbox Enable customization 을 체크 해제하거나 selectAllTree Check All 버튼을 클릭합니다.

  • Settings ‣ Options 메뉴의 System 탭의 QSettings 프레임에 있는 [Reset] 버튼을 클릭합니다.

  • 명령어 프롬프트에서 QGIS를 다음 명령어 qgis --nocustomization 로 실행합니다.

  • setting to false the value of UI ‣ Customization ‣ Enabled variable under Settings ‣ Options menu, Advanced tab.

대부분의 경우, 이 변경 사항을 적용하려면 QGIS를 재시작해야 합니다.