Outdated version of the documentation. Find the latest one here.

QGIS GUI

QGIS를 실행하면, 다음 그림에 나온 GUI를 만나게 됩니다. (노란색 원 안의 1번부터 5번까지를 설명하겠습니다.)

Figure QGIS GUI 1:

../../../_images/startup.png

알래스카 예시 데이터를 불러온 QGIS GUI

주석

사용자의 운영체제 및 창 관리자에 따라 창 양식(제목 바 등등)이 다르게 나타날 수도 있습니다.

QGIS GUI는 다음 5개 영역으로 나뉩니다:

  1. 메뉴 바

  2. 툴바

  3. 패널

  4. 맵 뷰

  5. 상태 바

다음 단락에서 QGIS 인터페이스의 이 5개 구성요소들을 더 자세히 설명합니다. 다른 단락 2개는 키보드 단축키와 컨텍스트 도움말을 다룹니다.

패널 및 툴바

View 메뉴에서 (KDE인 경우 Settings 에서) QGIS 위젯(Panels ‣) 또는 툴바(Toolbars ‣)를 켜고 끌 수 있습니다. 사용자가 메뉴 바 또는 툴바를 오른쪽 클릭해서 어떤 항목이라도 (비)활성화시킬 수 있고, 원하는 항목을 선택할 수도 있습니다. QGIS 인터페이스 안이라면, 각 패널 또는 툴바를 사용자가 편리하게 사용할 수 있는 어떤 위치로든 이동할 수 있습니다. 또한 핵심 또는 외부 플러그인 을 활성화하면 목록을 확장할 수도 있습니다.

툴바

메뉴와 동일한 기능들을 대부분 툴바를 통해서 접근할 수 있으며, 더불어 맵과 상호 작용할 수 있는 추가적인 도구들도 제공합니다. 툴바의 각 항목은 팝업 도움말을 보유하고 있습니다. 항목 위에 사용자의 마우스를 가져 가면 해당 도구의 목적을 설명하는 짧은 텍스트를 표출할 것입니다.

사용자의 필요에 따라 모든 툴바를 이동할 수 있습니다. 또, 오른쪽 클릭으로 컨텍스트 메뉴를 불러오거나 툴바 위에 마우스를 가져 가서 툴바를 꺼버릴 수도 있습니다.

Figure Toolbars:

../../../_images/toolbars1.png

툴바 메뉴

참고

툴바를 복구하기

사용자가 실수로 툴바를 꺼버렸을 경우, View ‣ Toolbars ‣ 메뉴 옵션을 (리눅스 KDE에서는 Settings ‣ Toolbars ‣ 를) 선택해서 다시 불러올 수 있습니다. 어떤 이유로 인터페이스에서 툴바가 (또는 다른 위젯이) 완전히 사라졌을 경우, 초기 GUI 복구 에서 다시 불러올 수 있는 도움말을 찾아볼 수 있습니다.

패널

QGIS는 작업할 수 있는 많은 패널들을 기본적으로 제공합니다.

Figure Panels:

../../../_images/panels.png

패널 메뉴

이 패널들 가운데 일부는 이 단락에서 설명하고 있으며, 이 문서의 서로 다른 부분들에서 다음과 같은 다른 패널들을 찾아볼 수 있습니다:

레이어 패널

레이어 패널은 프로젝트 내부의 모든 레이어 목록을 담고 있습니다. 각 범례 항목의 체크박스를 통해 레이어를 보이도록 하거나 숨길 수 있습니다. 레이어 패널에 있는 툴바를 통해 다음 작업을 할 수 있습니다:

  • addGroup: 새 그룹을 추가합니다.

  • showPresets Manage Visibility: 레이어의 가시성 및 사전 설정 레이어 조합을 제어합니다.

  • filterMap Filter Legend by Map Content: 보이도록 설정된 레이어 및 레이어의 피처가 현재 맵 캔버스와 교차하는 레이어만 레이어 패널에 레이어 스타일을 렌더링합니다. 해당 사항이 없을 경우, 일반적인 NULL 심볼이 레이어에 적용됩니다. 레이어 심볼을 바탕으로 하는 이 방식으로 어떤 레이어의 어떤 피처 유형이 사용자의 관심 지역을 커버하고 있는지 손쉽게 식별할 수 있습니다.

  • expressionFilter Filter Legend by Expression: 선택된 레이어 트리에서 조건을 만족하지 않는 피처를 보유한 스타일을 제거하는 표현식을 적용하도록 도와줍니다. 예를 들어 기준으로 설정한 다른 레이어의 영역/피처 내부에 있는 피처만 강조하도록 할 수도 있습니다. 드롭다운 목록으로부터, 표현식 모음을 편집하고 정리할 수 있습니다.

  • expandTree Expand All 또는 collapseTree Collapse All: 레이어 패널에 있는 모든 레이어 및 그룹을 펼치거나 접을 수 있습니다.

  • removeLayer Remove Layer/Group: 현재 선택한 레이어 및 그룹을 제거합니다.

Figure Layer tools Bar:

../../../_images/layer_toolbar.png

Layer Toolbar in Layers Panel

showPresets 버튼으로 범례에 사전 설정 뷰를 추가할 수 있습니다. 사전 설정은 레이어 조합을 현재 스타일과 함께 저장해서 쉽게 복구할 수 있는 방법입니다. 사전 설정 뷰를 추가하려면, 원하는 레이어들을 원하는 심볼과 함께 보이도록 설정한 다음, showPresets 버튼을 클릭하십시오. 드롭다운 메뉴에서 Add Preset... 을 선택해서 사전 설정에 명칭을 부여하십시오. 추가한 사전 설정이 드롭다운 메뉴의 목록 하단에 추가되어, 해당 항목을 클릭하면 다시 불러올 겁니다.

Replace Preset ‣ 옵션은 사전 설정의 내용을 현재 맵 뷰로 덮어쓰도록 도와줍니다. 반면 Remove Current Preset 버튼을 클릭하면 활성화된 사전 설정을 삭제합니다.

사용자의 특정 뷰를 바탕으로 한 맵 배치를 생성할 수 있도록, 추가한 모든 사전 설정은 맵 작성자에도 표시됩니다. (Main properties 을 참조하십시오.)

주석

레이어 패널을 관리하는 도구들은 인쇄 작성자의 맵과 범례 항목을 배치하는 데에도 쓰일 수 있습니다.

Z 순서를 변경하기 위해 범례 안에서 레이어를 선택, 위아래로 드래그할 수 있습니다. Z 순서란 범례 목록 상위에 위치한 레이어가 범례 목록 하위에 있는 레이어를 덮는다는 뜻입니다.

주석

레이어 정렬 패널을 통해 이 습성을 무시하게 할 수 있습니다.

범례 창에 있는 레이어들을 그룹화할 수도 있습니다. 그룹화하는 데에는 다음 두 가지 방법이 있습니다:

  1. folder 아이콘을 클릭해서 새 그룹을 추가합니다. 그룹의 명칭을 입력한 다음 Enter 를 누르십시오. 이제 기존 레이어를 클릭한 채로 그룹으로 드래그하십시오.

  2. 레이어 몇 개를 선택하고, 범례 창을 오른쪽 클릭한 다음 Group Selected 를 선택하십시오. 선택한 레이어들이 새 그룹으로 자동적으로 이동할 것입니다.

레이어를 그룹에서 꺼내려면, 레이어를 밖으로 드래그하거나 또는 오른쪽 클릭한 다음 Make to toplevel item 을 선택하면 됩니다. 또, 그룹을 다른 그룹 안에 넣을 수도 있습니다.

그룹의 체크박스를 한 번 클릭하는 것으로 그룹 안의 모든 레이어를 한꺼번에 보이게 하거나 숨길 수 있습니다.

선택한 범례 항목이 래스터 레이어인지 또는 벡터 레이어인지에 따라 오른쪽 클릭으로 나타나는 컨텍스트 메뉴의 내용이 달라집니다. GRASS 벡터 레이어의 경우, toggleEditing Toggle editing 을 사용할 수 없습니다. GRASS 벡터 레이어 편집에 대한 정보는 Digitizing and editing a GRASS vector layer 을 참조하십시오.

다음은 선택한 항목에 따라 사용할 수 있는 컨텍스트 메뉴 옵션 목록입니다.

옵션

벡터 레이어

래스터 레이어

그룹화

zoomToLayer Zoom to Layer/Group checkbox checkbox checkbox
unchecked Show in Overview checkbox checkbox
zoomActual Zoom to Native Resolution (100%) checkbox
Stretch Using Current Extent checkbox
removeLayer Remove checkbox checkbox checkbox
duplicateLayer Duplicate checkbox checkbox
Set Layer Scale Visibility checkbox checkbox
Set Layer/Group CRS checkbox checkbox checkbox
Set Project CRS from Layer checkbox checkbox
Styles ‣ checkbox checkbox
Copy Style checkbox checkbox
Paste Style checkbox checkbox checkbox
openTable Open Attribute Table checkbox
toggleEditing Toggle Editing checkbox
allEdits Current Edits ‣

checkbox (편집 모드에서)

Save As... checkbox checkbox
Save As Layer Definition File... checkbox checkbox checkbox
Filter checkbox
unchecked Show Feature Count checkbox
Properties checkbox checkbox
Move to Top-level checkbox checkbox
Rename checkbox checkbox checkbox
Group Selected checkbox checkbox
Properties checkbox checkbox
Set Group WMS Data checkbox
unchecked Mutually Exclusive Group checkbox
addGroup Add Group checkbox

상호 배타적 그룹 옵션을 활성화하면 한 번에 한 레이어만 보이는 그룹을 생성할 수 있습니다. 그룹 내부의 어떤 레이어를 보이도록 설정할 때마다 다른 레이어들은 보이지 않도록 꺼질 것입니다.

왼쪽 마우스 버튼으로 레이어를 선택할 때 Ctrl 키를 누르고 있으면 하나 이상의 레이어 또는 그룹을 동시에 선택할 수 있습니다. 그 다음 선택한 모든 레이어를 동시에 새 그룹으로 이동시킬 수 있습니다.

Ctrl 키로 항목 몇 개를 선택한 다음 Ctrl+D 를 누르면 하나 이상의 레이어 또는 그룹을 한 번에 삭제할 수도 있습니다. 이렇게 하면, 선택한 모든 레이어 또는 그룹이 레이어 목록에서 한꺼번에 제거될 것입니다.

벡터 레이어 스타일 편집 작업

레이어 패널에서 레이어 렌더링을 쉽고 빠르게 편집할 수 있는 단축키를 쓸 수 있습니다. 벡터 레이어를 오른쪽 클릭한 다음 목록에서 Styles –> 를 선택하면 다음과 같은 작업을 할 수 있습니다:

  • 레이어에 현재 적용된 스타일 을 확인합니다. 해당 레이어에 많은 스타일을 정의했을 경우, 한 스타일에서 다른 스타일로 바꿔가면 맵 캔버스에서 해당 레이어의 렌더링이 자동적으로 업데이트되는 걸 볼 수 있습니다.

  • 현재 스타일을 복사해서, 적용할 수 있을 경우, 또다른 레이어에 복사한 스타일을 붙여넣을 수 있습니다.

  • 현재 스타일의 명칭을 변경하거나, 새 스타일을 (이때 실제로는 현재 스타일의 복사본입니다) 추가하거나, (스타일이 여러 개 존재할 경우) 현재 스타일을 삭제할 수 있습니다.

주석

이 옵션들은 래스터 레이어에 대해서도 쓸 수 있습니다.

벡터 레이어 내부의 피처들이 모두 유일한 동일 심볼을 보유하고 있든지 또는 피처들이 분류되어 있든지 (이 경우, 트리 구조에 레이어를 하위 항목으로서의 각 클래스와 함께 표출합니다) 간에, 레이어 또는 클래스 층위에서 다음 옵션들을 쓸 수 있습니다:

  • Edit Symbol... 버튼으로 심볼 선택자 대화창을 열어 레이어 또는 피처 심볼의 모든 속성(심볼, 크기, 색상 등등)을 업데이트할 수 있습니다. 또 피처를 더블 클릭해도 Symbol Selector 대화창을 엽니다.

  • 색상 선택자 위젯에 있는 색상환(色相環) 을 클릭해서 색상을 골라 심볼을 채울 색상을 자동적으로 업데이트할 수 있습니다. 사용자 편의를 위해 색상환 하단에서 최근 사용한 색상 을 이용할 수 있습니다.

  • showAllLayers Show All ItemshideAllLayers Hide All Items 버튼을 통해 모든 피처 클래스의 가시성을 켜고 끌 수 있습니다. 이 방법을 쓰면 항목들을 하나하나 체크하거나 해제하는 수고를 피할 수 있습니다.

참고

재빨리 레이어 스타일을 공유

컨텍스트 메뉴에서, 레이어의 스타일을 복사해 그룹 또는 레이어 집합으로 붙여 넣을 수 있습니다. 원본 레이어와 동일한 (벡터 또는 래스터) 유형인 모든 레이어에, 그리고 벡터 레이어인 경우 모든 동일한 도형 유형(포인트, 라인, 폴리곤)에 스타일을 적용합니다.

독자적인 레이어 순서로 범례를 작업

레이어 패널에 대해 독자적인 그리기 순서를 정의할 수 이는 패널이 있습니다. Settings ‣ Panels ‣ Layer Order Panel 메뉴로 이 패널을 활성화할 수 있습니다. 이 기능은, 예를 들어, 사용자 레이어를 중요도에 따라 정렬시키지만 원래 순서로 표시하도록 할 수 있습니다. (다음 figure_layer_order_ 그림을 참조하십시오.) 레이어 목록 하단에 있는 checkbox Control rendering order 를 체크하면 원래 순서로 되돌릴 것입니다.

Figure Layer Order:

../../../_images/layer_order.png

독자적인 레이어 순서로 범례를 정의

통계 요약 패널

이 패널은 특정 벡터 레이어에 대한 몇몇 통계를 표시할 수 있습니다. 사용자는 이 패널에서 다음을 선택할 수 있습니다:

  • 벡터 레이어

  • 열 또는 표현식

  • 통계를 필터링할 피처를 선택

  • 정보를 다시 불러오기

  • 우하단의 버튼으로 표출할 통계 정보를 선택

QGIS 미리보기 패널

QGIS에서, 추가한 레이어들의 전체 범위를 보여주는 미리보기 패널을 이용할 수 있습니다. 이 뷰 안에는 현재 맵 범위를 나타내는 사각형이 있습니다. 이 사각형을 통해 사용자가 현재 맵의 어느 영역을 보고 있는지 빨리 알 수 있습니다. 맵 미리보기가 표시하는 레이어에 라벨이 적용돼 있더라도 맵 미리보기에는 라벨이 렌더링되지 않는다는 사실을 주목하십시오. 미리보기서 현재 범위를 보여주는 빨간색 사각형을 클릭&드래그하면, 그에 따라 맵 뷰도 자동적으로 업데이트됩니다.

로그 메시지 패널

몇몇 작업을 불러오거나 공간 처리할 때, messageLog 로그 메시지 패널을 통해 다른 탭에 나타나는 메시지를 추적하고 지켜볼 수 있습니다. 하단의 상태 바의 가장 오른쪽에 있는 아이콘을 클릭하면 이 패널을 활성화할 수 있습니다.

실행 취소/재실행 패널

이 패널은 편집 중인 각 레이어에 대해 실행된 모든 동작 목록을 표시해서, 위쪽에 정리된 동작을 선택하는 것만으로도 어떤 작업을 빠르게 실행 취소시킬 수 있습니다.

맵 뷰

맵 캔버스 라고도 하는 맵 뷰는 QGIS의 “주 기능의 말단”입니다 ─ 즉 이 영역에 맵이 표출됩니다. 이 창에 표출되는 맵은 사용자가 불러오기로 선택한 벡터 및 래스터 레이어에 따라 달라집니다. (레이어를 불러오는 방법에 대해 자세히 알고 싶다면 이 문서의 다른 부분을 참조하십시오.) 표출된 맵의 중심을 다른 지역으로 옮겨 맵 뷰를 이동할 수도 있고, 확대하거나 축소해서 볼 수도 있습니다. 앞의 툴바 에서 설명한 대로 맵 상에서 수행할 수 있는 작업들은 이 외에도 매우 다양합니다. 맵 뷰와 범례는 서로 강력하게 연관돼 있습니다 ─ 뷰에 표출되는 맵은 사용자가 범례 영역에서 변경한 사항을 반영합니다.

참고

마우스 휠로 맵을 확대/축소

마우스 휠을 이용해서 맵을 확대하거나 축소할 수 있습니다. 맵 영역 안쪽에 마우스 커서를 가져간 다음 휠을 앞으로 (사용자에게서 멀리) 돌리면 확대되고 뒤로 (사용자쪽으로) 돌리면 축소됩니다. 마우스 커서 위치를 중심으로 확대/축소됩니다. Settings ‣ Options 메뉴의 Map tools 탭에서 마우스 휠 확대/축소 습성을 사용자 지정할 수 있습니다.

참고

방향 키와 스페이스 바로 맵을 이동

방향 키를 이용해서 맵을 이동할 수 있습니다. 맵 영역 안쪽에 마우스 커서를 가져간 다음 오른쪽 방향 키를 누르면 동쪽으로, 왼쪽 방향 키를 누르면 서쪽으로, 위쪽 방향 키를 누르면 북쪽으로, 아래쪽 방향 키를 누르면 남쪽으로 이동합니다. 스페이스 바를 누르거나 마우스 휠을 클릭해서도 맵을 이동할 수 있습니다. 그냥 스페이스 바를 누른 채로 또는 마우스 휠을 클릭한 채로 마우스를 움직여보십시오.

상태 바

상태 바는 맵 뷰 및 처리 중이거나 처리할 수 있는 동작에 대한 일반 정보를 제공하며, 맵 뷰를 관리할 수 있는 도구들 또한 보유하고 있습니다.

상태 바의 왼 편에서 사용자가 실행한 (레이어의 피처를 선택했다거나 레이어를 제거했다거나 같은) 동작에 대한 간단한 설명 또는 마우스를 가져간 도구에 대한 (모든 도구가 지원하지는 않습니다) 자세한 설명을 볼 수 있습니다. QGIS 실행 시, 상태 바는 (Plugin Manager settings 에서 체크한 경우) 새 플러그인을 사용할 수 있다거나 플러그인을 업데이트할 수 있다거나 하는 정보도 표시합니다.

래스터 레이어에서 통계를 수집한다거나 맵 뷰에서 레이어 몇 개를 렌더링한다거나 같이 시간이 걸리는 동작의 경우, 상태 바에 진행 막대를 표시해서 해당 작업의 현재 진행 상태를 보여줍니다.

tracking Coordinate 옵션을 클릭하면 맵 뷰 상에서 마우스가 움직이는 것을 따라가며 커서의 현재 위치를 표시합니다. 투영체 속성일반 탭에서 이 기능에 사용할 단위(와 정확도)를 설정할 수 있습니다. 텍스트 란 왼쪽에 있는 작은 버튼을 클릭하면 이 Coordinate 옵션과, 사용자가 맵을 이동하거나 확대/축소할 때 맵 뷰의 현재 좌하단 및 우상단 포인트의 좌표를 표시하는 extents Extents 옵션을 서로 켜고 끌 수 있습니다.

좌표 표시 옆에 Scale 표시가 보입니다. 이 표시는 맵 뷰의 축척을 보여줍니다. 맵을 확대/축소할 때, QGIS가 현재 축척을 표시합니다. 사용자가 맵 뷰에 할당할 사전 정의된/사용자 지정 축척 을 선택할 수 있는 축척 선택자가 존재합니다.

축척 표시 오른쪽에서 사용자의 맵 뷰에 대해 시계 방향 기울기(rotation)를 도(˚) 단위로 정의할 수 있습니다.

상태 바의 오른 편에, 레이어가 맵 뷰에 렌더링되는 것을 일시적으로 막는 데 쓰이는 작은 체크박스가 있습니다. (렌더링 작업 을 참조하십시오.)

렌더링 기능 오른쪽에 projectionDisabled Current CRS: 아이콘을 현재 투영 좌표계의 EPSG 코드와 함께 볼 수 있습니다. 이 아이콘을 클릭하면 현재 프로젝트에 대해 ‘실시간’ 좌표계 변환 활성화 속성을 열어 맵 뷰에 또다른 좌표계를 적용할 수 있습니다.

마지막으로, messageLog Messages 버튼을 클릭하면 기저 프로세스(QGIS 실행, 플러그인 불러오기, 공간 처리 도구 등등)에 대한 정보를 알려주는 로그 메시지 패널 을 엽니다.

참고

사용자 맵 캔버스의 정확한 축척을 계산하기

QGIS를 시작할 때, 기본 좌표계는 WGS 84 (epsg 4326) 이고 단위는 도(˚)입니다. 즉 QGIS는 사용자 레이어의 모든 좌표를 도 단위인 것처럼 해석할 것이란 뜻입니다. 정확한 축척값을 얻으려면 이 설정을, 예를 들어 Project ‣ Project Properties 메뉴의 General 탭에서 미터 단위로 직접 변경하거나, 또는 앞에서 설명한 projectionDisabled Current CRS: 아이콘을 써서 변경할 수도 있습니다. 후자의 경우, 프로젝트의 투영체가 지정하는 대로 (예를 들어 +units=us-ft 처럼) 단위를 설정하게 됩니다.

Settings ‣ Options ‣ CRS 메뉴 옵션에서 실행 시 적용할 좌표계를 설정할 수 있다는 사실을 알아두십시오.