Outdated version of the documentation. Find the latest one here.

Algemeen Gereedschap

Identificeer objecten

Met Objecten Identificeren kan men zichtbare objecten op de kaart bevragen waarbij de attributen worden getoond in een resultaatvenster. Deze functie kan men via het menu selecteren Beeld ‣ Objecten Identificeren of Ctrl+Shift+I, of selecteer het icoon mActionIdentify Objecten Identificeren in de werkbalk.

Wanneer je meerdere objecten selecteert, dan zal er menu verschijnen die een overzicht geeft van de attribuutwaarden van alle geselecteerde objecten. Het eerste item in de resultaatlijst is het nummer gevolgd door de laagnaam. In een niveau daaronder bevindt zich de naam van het attribuutveld met de attribuutwaarde, vervolgens wordt alle informatie van het object getoond.

Dit venster kan via maatwerk (-formulier) worden aangepast om extra informatie te tonen, maar standaard zal deze drie soorten informatie tonen.

  • Acties: acties kunnen worden toegevoegd aan de resultaatlijst van de tool objecten identificeren. Wanneer men een actie selecteert zal die actie worden gestart. Standaard wordt er slechts één actie toegevoegd, de actie Het object bewerken formulier.

  • Afgeleid: deze bevat attribuutwaarden die is berekend of afgeleid van andere informatie. Men kan hier het coördinaat vinden waarmee is gezocht, de X- en Y-coördinaten, de oppervlakte en omtrek in kaarteenheden wanneer het een polygoon (vlak) object betreft, de lengte in kaarteenheden wanneer het een lijn-object betreft en het object-id.

  • Veld attributen: Dit is de lijst van velden met attribuutwaarden.

Figure Identify 1:

../../../_images/identify_features.png

De dialoog Objecten identificeren nix (Gnome)

Aan de onderkant van het venster Indentificatieresultaten bevinden zich vijf knoppen met iconen:

  • mActionIdentifyExpand Boom uitklappen

  • |mActionIdentifyCollapset| Boom inklappen

  • mActionIdentifyDefaultExpand Nieuwe resultaten zullen standaard worden uitgebreid

  • mActionIdentifyCopyAttributes Kopieer attributen

  • mActionIdentifyPrint Geselecteerde HTML antwoord afdrukken

Meer functies kunnen worden gevonden door ergens in de resultaatlijst via de rechtermuisknop een snelmenu te openen.

Dit snelmenu geeft de mogelijkheden om:

  • Object-bekijken formulier

  • Naar object inzoomen

  • Kopieer object: kopieer het hele object, geometrie en attribuutwaarden;

  • Attribuut-waarden kopiëren: Kopieert alleen de via de rechtermuisknop geselecteerde attribuutwaarde;

  • Kopiëren objectattributen: kopieert alleen de attribuutwaarden;

  • Wis resultaat: Het scherm Identificatieresultaten wordt leeggemaakt

  • Wis highlights: De objecten die gehighlight waren op de kaart zijn niet langer gehighlight

  • Alles Highlighten

  • Highlight de laag

  • Laag eigenschappen: opent het menu Laag Eigenschappen

  • Alles uitklappen

  • Alles inklappen

Snelkoppelingen toetsenbord

QGIS heeft voor veel functies standaard snelkoppelingen. Deze worden in Menubalk beschreven. Daarnaast geeft de menu optie Extra ‣ Snelkoppelingen bewerken ... de mogelijkheid om de standaard snelkoppelingen aan te passen en nieuwe toe te voegen, voor QGIS functies die nog geen snelkoppeling hebben.

Figure Shortcuts 1:

../../../_images/shortcuts.png

Optiemenu snelkoppelingen definiëren nix (Gnome)

Configuratie van snelkoppelingen is erg eenvoudig. Selecteer een actie van de lijst, selecteer [Aanpassen], [Niet gebruiken] of [Als standaard zetten]. Wanneer je tevreden bent over je configuratie, dan kun je deze opslaan als een XML file en laden in een andere QGIS installatie via dit menu.

Contextuele help

Wanneer je hulp nodig hebt over een specifiek onderwerp, kun je in veel dialogen/menu’s op de [Help] knop drukken. De help knop in plugins die door derden zijn ontwikkeld, kunnen verwijzen naar speciaal daarvoor gemaakte webpagina’s.

Renderen

QGIS zal standaard automatisch de zichtbare lagen opnieuw opbouwen, renderen, wanneer nodig. De volgende gebeurtenissen zullen het verversen van het kaartbeeld starten:

  • Toevoegen van een kaartlaag

  • Verschuiven of in/uitzoomen

  • Het wijzigen van de grootte van het QGIS programma venster

  • Het wijzigen van de zichtbaarheden van een laag of lagen

QGIS geeft je op een aantal manieren controle op het renderings-proces.

Schaalafhankelijk Tonen

Met schaalafhankelijk tonen is het mogelijk om de minimum en maximum schalen in te stellen waarbij een laag zichtbaar dient te zijn. Om schaalafhankelijk tonen in te stellen open de dialoog Eigenschappen door te dubbelklikken op een kaartlaag in de legenda. In het tabblad Algemeen kan men het aanvinkvakje checkbox Gebruik schaalafhankelijk tonen aanvinken en vervolgens de minimum en maximum schaalwaarden invullen waarbinnen de kaartlaag zichtbaar dient te zijn.

Je kunt deze waarden achterhalen door het kaartbeeld eerst in te zoomen tot je de kaart net niet/wel wilt zien en dan de bijbehorende schaal af te lezen van de statusbalk.

Controle over het renderen van de kaart

Men kan op de volgende manieren meer controle krijgen over het renderen van het kaartbeeld:

Uitstellen van het Renderen

Om het renderen uit te stellen, vink het aanvinkvakje checkbox Render uit in de rechteronderhoek van de statusbalk. Wanneer het aanvinkvakje checkbox Render niet is aangevinkt, zal QGIS het kaartbeeld niet opnieuw opbouwen in de gebeurtenissen die beschreven zijn in Renderen. Voorbeelden wanneer je het opnieuw opbouwen van de kaart wilt uitstellen:

  • Na het toevoegen van veel kaartbladen wil je deze eerst van symbologie voorzien en de tekenvolgorde instellen

  • Na het toevoegen van een of meer grote kaartlagen wil je eerst instellen bij welke schalen deze getekend mag worden

  • Na het toevoegen van een of meer grote kaart lagen wil je eerst in zoom en op een bepaald gebied voordat deze getekend wordt

  • Een combinatie van bovenstaande redenen

Het weer aanvinken van checkbox Render zal onmiddelijk het opnieuw opbouwen van het kaartbeeld starten.

Instelling Toevoegen Laag Optie

Er is ook de mogelijkheid om niet direkt de kaart opnieuw te tekenen na het toevoegen van nieuwe kaartlagen. Dit betekent dat het aanvinkvakje voor de zichtbaarheid van nieuw toegevoegde lagen, standaard niet zal zijn aangevinkt. Om deze optie in te stellen kies de menuoptie Extra ‣ Opties ‣ en open het tabblad Rendering. Ontvink het aanvinkvakje checkbox Standaard zullen nieuw toegevoegde lagen aan de kaart direct worden afgebeeld. Elke laag die hierna wordt toegevoegd, zal standaard uit staan (onzichtbaar) in de legenda.

Een andere optie in het menu Extra ‣ Opties ‣ Rendering is het aanvinkvak checkbox Back buffer inschakelen. Dit geeft een betere grafische performance maar dan kan men het tekenen niet onderbreken en ook niet incrementeel objecten tekenen. Wanneer deze niet is aangevinkt, kun je het Aantal objecten alvorens de kaart te hertekenen instellen, anders is deze inactief.

Ten slotte kan men het aanvinkvak checkbox Gebruik de cache voor het tekenen indien mogelijk om het hertekenen te versnellen activeren.

Het renderen stoppen

Om het tekenen van de kaart te stoppen druk op de ESC toets. Dit zal het tekenen van de kaart onderbreken waarbij de kaart slechts gedeeltelijk getekend is. Het kan even duren voordat het tekenen stopt na het indrukken van de ESC toets.

Notitie

Het is momenteel niet mogelijk om het renderen te stoppen - dit is tijdelijk uitgeschakeld in de op qt4 gebouwde versie aangezien dit kon leiden tot problemen als een vastlopende applicatie.

Bijwerken van het kaartbeeld tijdens het Renderen

Men kan gebruik maken van een optie om kaartgegevens al te tekenen tijdens het inlezen en opbouwen van kaartgegevens. Standaard, laat QGIS nog geen objecten van een laag zien totdat het inlezen en opbouwen van de kaartlaag is afgerond. Om kaartgegevens te tekenen tijden het lezen ervan, kies de menuoptie Extra ‣ Opties Open het tabblad. Rendering. Zet het aantal objecten alvorens de kaart te hertekenen op een geschikte waarde om tijdens het inlezen de kaart al te zien opbouwen. Wanneer de waarde op 0 staat zal de kaartlaag pas getoond worden wanneer deze volledig is opgebouwd. Het instellen van een te lage waarde zal resulteren in een traag opbouwende kaart omdat de kaart bijna continue moet worden bijgewerkt. Een voorgestelde waarde om mee te beginnen is 500.

Beïnvloeden van de kwaliteit van het renderen

Er zijn twee opties waarmee men de kwaliteit van het renderen kan beïnvloeden. Kies de menuoptie Extra ‣ Opties open het tabblad Rendering en vink of ontvink de volgende aanvinkvakjes.

  • checkbox Maak de lijnen minder rafelig ten koste van de tijd dat het tekenen kost

  • checkbox Problemen met fout (gevulde) polygonen oplossen

Meten

Men kan direct beginnen te meten binnen geprojecteerde coördinaten systemen zoals het UTM of het Nederlandse RijksDriekhoek stelsel. Wanneer de geladen kaartlaag echter een geographisch coördinatensysteem betreft, die gebruik maakt van lengtegraden/breedtegraden, dan zal het resultaat van gemeten lengtes en op- pervlaktes in eerste instantie onjuist zijn. Om dit op te lossen moet er eerst een meer toepasselijk coördinaten systeem ingesteld worden (zie Werken met Projecties). Alle onderdelen die gebruikt worden om te meten gebruiken dezelfde snapping opties van het digitaliseer gereedschap. Dit is vooral handig wanneer je bestaande lijnen en vlakken van vectorlagen wilt opmeten.

Om een meetgereedschap te kiezen selecteer mActionMeasure en kies vervolgens het gereedschap dat je wilt gebruiken.

Het meten van lengte, oppervlakte of hoek

mActionMeasure Measure Line QGIS kan de directe afstand meten tussen twee punten of via de gedefiniëerde ellipsoïde oftewel de aardkromming, van gebruikt coördinaten systeem. Om dit in te stellen, kies de menuoptie Extra ‣ Opties. Open het tabblad Kaart gereedschap en kies de juiste ellipsoïde voor afstandsberekeningen. Men kan hier ook de kleur van de rubberband en de voorkeuren voor te gebruiken eenheden voor lengtematen en hoeken instellen. Met de rubberband wordt het flexibele meetlint bedoelt waarmee de afstanden kunnen worden opgemeten. Men kan nu het meetgereedschap gebruiken door te klikken in het kaartbeeld. Het menu opmeten verschijnt waarbij zowel de lengtes van de lijnsegmenten als de totale lengte wordt getoond. Gebruik de rechtermuisknop om te stoppen met meten.

Figure Measure 1:

../../../_images/measure_line.png

Het meten van afstanden nix (Gnome)

mActionMeasureArea Measure Area: Je kunt ook oppervlaktes meten. In het menu opmeten, komt dan de totale oppervlakte te staan. Ook in dit geval zal de meettool naar objecten van de geselecteerde vectorlaag proberen te snappen, tenminste wanneer voor die laag een snapping tolerantie is ingesteld. (Zie Het instellen van de Snapping Toleranties en Zoek Radius). Wanneer men nauwkeurig oppervlakte wilt opmeten, zet dan eerst voor een laag de snapping tolerantie, en selecteer dan vervolgens die laag. Vervolgens kan men nu precies oppervlaktes inmeten waarbij elke muisklik naar de dichtsbijzijnde hoek of lijn van geselecteerde laag zal springen, wanneer deze zich binnen ingestelde tolerantie bevindt.

Figure Measure 2:

../../../_images/measure_area.png

Het meten van oppervlaktes nix (Gnome)

mActionMeasureAngle Measure Angle: Men kan ook hoeken opmeten, selecteer Hoek Opmeten. De muisaanwijzer veranderd in een kruisje. Zet eerst twee punten de basislijn om vervolgens met het derde punt de relatieve hoek t.o.v. de basislijn op te meten. De meting wordt getoond in een popup menu.

Figure Measure 3:

../../../_images/measure_angle.png

Het meten van hoeken nix (Gnome)

Selecteren en deselecteren van objecten

De QGIS werkbalk bevat functionaliteit waarmee men objecten kan selecteren in het kaartbeeld. Om een of meerdere objecten te selecteren klik op mActionSelect en kies de gewenste selectie functie:

  • mActionSelect Selecteer 1 Object

  • mActionSelectRectangle Selecteer Objecten binnen Rechthoek

  • mActionSelectPolygon Selecteer Objecten binnen Polygoon

  • mActionSelectFreehand Selecteer objecten via Vrije Selectie

  • mActionSelectRadius Selecteer Objecten binnen Straal

Om de huidige selectie van geselecteerde objecten ongedaan te maken klik op mActionDeselectAll Objecten uit alle layers deselecteren.

Decoraties

De kaartdecoraties van QGIS zijn het Copyright Label, de Noordpijl en de Schaalbalk. Ze worden gebruikt om de kaart te decoreren door kaartelementen toe te voegen.

Grid

transformed Grid geeft de mogelijkheid om een coördinaten grid met labels te tonen in het kaartbeeld.

Figure Decorations 1:

../../../_images/grid_dialog.png

De Grid Dialoog nix

  1. Selecteer via het menu Beeld ‣ Decoraties ‣ Grid. De dialoog opent (zie figure_decorations_1).

  2. Activeer het aanvinkvak checkbox Grid activeren en zet de grid definities volgens de geladen lagen in het kaartbeeld.

  3. Activeer het aanvinkvak checkbox Teken labels en stel de annotatie definities in volgens de lagen die geladen zijn in het kaartbeeld.

  4. Klik op [Apply] om het resultaat direct te zien.

  5. Klik op **[OK] om de dialoog te sluiten.

Noordpijl

north_arrow Noordpijl plaatst een simpele noordpijl op de kaart. Momenteel is er slechts 1 stijl beschikbaar. Je kunt de hoek van de noordpijl instellen of door QGIS de richting automatisch laten instellen. Voor het plaatsen van de noordpijl zijn er vier opties, die overeenkomen met de vier hoeken van het kaartbeeld.

Figure Decorations 3:

../../../_images/north_arrow_dialog.png

De Noordpijl Dialoog nix

Schaalbalk

scale_bar Schaalbalk plaatst een eenvoudige schaalbalk op de kaart. De stijl en de plaats kan worden aangepast evenals de labels van de Schaalbalk.

Figure Decorations 4:

../../../_images/scale_bar_dialog.png

De Schaalbalk Dialoog nix

QGIS ondersteunt alleen het tonen van de schaal in dezelfde lengteenheid als die van de kaart. Wanneer de eenheid van je lagen in meters zijn kun je niet een schaalbalk maken in feet . Zo kun je ook geen schaalbalk in meters tonen wanneer de gebruikte kaart als eenheid in graden wordt getoond.

Toevoegen van een schaalbalk:

  1. Selecteer via het menu Beeld ‣ Decoraties ‣ Schaalbalk The dialoog opent (zie figure_decorations_4)

  2. Kies de plaatsing met de keuzelijst Plaats ‘RechtsBoven’

  3. Kies de stijl in de keuzelijst Schaalbalkstijl ‘Waardeaanduiding Boven’

  4. Kies de kleur van de balk via het kleurenpalet achter Schaalbalkkleur of laat deze op zwart staan

  5. Zet de grootte van de schaalbalk en het label Grootte van de balk

  6. Zorg ervoor dat het aanvinkvak checkbox Schaalbalk gebruiken is aangevinkt

  7. Geef aan of de schaalbalk automatisch naar gehele getallen verspringt wanneer de kaart van grootte wijzigd door het aanvinkvak checkbox Klik automatisch naar gehele getallen tijdens het aanpassen van de grootte aan te vinken

  8. Klik op [OK]

Tip

Decoratie Instellingen

Wanneer je een QGIS project opslaat, zullen de wijzigingen die je hebt gemaakt aan Noordpijl, Schaalbalk en Copyright mee worden opgeslagen in het projectbestand en teruggezet worden bij het openen van het project.

Annotatie Functies

De mActionTextAnnotation Tekst Annotatie functies in de werkbalk Attributen geven de mogelijkheid om een tekstballon ergens in het kaartbeeld te plaatsen. Gebruik de Annotatie functie en klik ergens in het kaartbeeld.

Figure annotation 1:

../../../_images/annotation.png

Annotatie tekst dialoog nix

Wanneer men dubbelklik op de ballontekst heeft men verschillende mogelijkheden om deze aan te passen. Er is een tekstvak waar men de tekst mee kan aanpassen. Men kan kiezen of het de tekst verbonden is aan een kaartlokatie of dat deze steeds op dezelfde plaats blijft staan ook al verschuifd men de kaart. Men kan het tekst item verplaatsen door de marker of de ballontekst naar een andere plek te slepen. De gebruikte icoontjes zijn onderdeel van het gis thema, maar worden ook in de andere thema’s gebruikt.

De mActionAnnotation Verplaats Annotatie functie wordt gebruikt om de annotatie te verplaatsen in het kaartbeeld.

Html annotatie

De mActionTextAnnotation Html Annotatie functies in de werkbalk Attributen geven de mogelijkheid om de in inhoud van een html bestand in een tekstballon ergens in het kaartbeeld te plaatsen. Gebruik de Html Annotatie functie en klik ergens in het kaartbeeld en voeg een pad toe naar het html bestand in de dialoog.

SVG annotatie

De mActionSaveAsSVG SVG Annotatie functies in de werkbalk Attributen geven de mogelijkheid om een SVG symbool een ballon ergens in het kaartbeeld te plaatsen. Gebruik de SVG Annotatie functie en klik ergens in het kaartbeeld en voeg een pad toe naar het SVG bestand in de dialoog.

Formulier annotatie

Het is mogelijk om je eigen annotatie formulieren te maken en te gebruiken. De functie mActionFormAnnotation Formulier annotatie kan gebruikt worden om de attributen van een vector laag te tonen in een speciaal daarvoor door jezelf ontworpen formulier in de QT designer (zie figure_custom_annotation). Dit is hetzelfde formulier dat wordt gebruikt voor de identiteit tool, maar dan gebruikt als annotatie. Zie ook de QGIS blog http://blog.qgis.org/node/143 voor meer informatie.

Figure annotation 2:

../../../_images/custom_annotation.png

Maatwerk qt designer annotatie formulier nix

Notitie

Wanneer je de toetsencombinatie Ctrl+T gebruikt terwijl een annotatie functie actief is (verplaats annotatie, tekst annotatie, formulier annotatie), dan wisselt het tekstitem van zichtbaar naar onzichtbaar en andersom.

Favoriete Plaatsen

De Engelse term ’Spatial Bookmarks’ is vrij vertaald naar ’Favoriete Plaatsen. Je kunt met Favoriete Plaatsen aangeven waar je later (vaker) terug wilt keren.

Aanmaken van Favoriete Plaats

Hoe je een favoriete plaats aanmaakt:

  1. Zoom in op een gebied naar keuze.

  2. Selecteer de menu optie Beeld ‣ Nieuwe Favoriet ... of gebruik de snelkoppeling Ctrl-B.

  3. Geef een beschrijvende naam waaronder je de Favoriete plaats op wilt slaan (tot 255 tekens).

  4. Klik op Enter om de Favoriete plaats toe te voegen of [Verwijderen] om de Favoriete plaats te verwijderen.

Men kan meerdere favorieten onder dezelfde naam opslaan.

Werken met Favoriete Plaatsen

Om een Favoriet te gebruiken of te beheren, kies de menu optie Beeld ‣ Toon Favorieten. De dialoog Favoriete Plaatsen geeft de mogelijkheid om snel te springen naar die opgeslagen favoriete plaats of om een Favoriete plaats te verwijderen. Je kunt de naam of de positie van een Favoriete plaats niet wijzigen.

Verplaatsen naar een Favoriete Plaats

Vanuit de dialoog Ruimtelijke Favorieten ..., kies de favoriete plaats door deze te selecteren en druk daarna op de knop [Zoom naar]. Je kunt ook naar een Favoriete plaats springen door hierop te dubbelklikken.

Verwijderen van een Favoriete Plaats

Om een favoriete plaats te verwijderen vanuit de dialoog Ruimtelijke Favorieten ... selecteer de favoriet en druk op [Verwijder]. Bevestig gemaakte keuze in het vervolgschermpje door op [Ja] te drukken of maak het verwijderen alsnog ongedaan door te drukken op [Nee] .

Projecten in een project

Wanneer je de inhoud van een ander project wilt opnemen in een project kun je kiezen voor menuselection:Kaartlagen –> Kaartlagen en groepen inbedden.

Inbedden van lagen

De volgende dialoog maakt het inbedden.van lagen van een ander project mogelijk:

  1. Gebruik browsebutton om een ander project te selecteren van de Alaska dataset.

  2. Selecteer het projectbestand grassland. Je kunt de inhoud van het project zien (zie figure_embed_dialog).

  3. Druk op Ctrl en selecteer de lagen grassland en regio’s. De lagen zijn nu toegevoegd in de kaartlegenda en het kaartbeeld.

Figure Nesting 1:

../../../_images/embed_dialog.png

Selecteer lagen en groepen om in te voegen nix

Wanneer de ingebedde kaartlagen bewerkbaar worden gemaakt kun je eigenschappen als Stijl en Labeling van deze lagen niet aanpassen.

Verwijderen van ingebedde lagen

Klik met de rechtermuis op de ingebedde lagen en selecteer mActionRemoveLayer Verwijder.

Tekstgescheiden kaartlaag toevoegen

Deze functie geeft de mogelijkheid om een tekengescheiden tekst bestand als een laag in QGIS te laden. De volgende instellingen moeten worden gegeven:

  1. Het Bestandsformaat is normaalgesproken radiobuttonon CSV (komma gescheiden waarden). Wanneer een ander scheidingsteken is gebruikt, activeer dan het keuzerondje radiobuttonon zelfgekozen scheidingsteken en wanneer elke regel in het bestand gescheiden moet worden met een reguliere expressie, activeer dan het keuzerondje radiobuttonon Reguliere expressie scheidingsteken.

  2. Record opties het tekstbestand bevat meestal een kopregel met veldnamen. Meestal is dit de eerste regel. Wanneer er geen kopregel aanwezig is, deactiveer het aanvinkvak checkbox De eerste regel bevat veldnamen. Wanneer de kopregel niet de eerste regel van het tekstbestand is, geef dan het aantal regels wat eerst moet worden overgeslagen.

  3. Met Veld opties kan men de spaties voor en achter een veld verwijderen door het aanvinkvak checkbox Verwijderen van velden, deze funtie had beter vertaald kunnen worden naar Verwijder spaties voor/na. Men kan checkbox Sla lege velden over voor elk record gebruiken en je kunt aangeven dat het checkbox Decimale scheidingsteken is de comma, anders is het decimale scheidingsteken de punt.

  4. Met Geometrie definitie kan men aangeven hoe de geometrie is opgenomen in het tekstbestand. Wanneer het keuzerondje radiobuttonon Punt coördinaten is geactiveerd, dan dient aangegeven te worden welke velden gebruikt worden als X- en Y-veld die coördinatenwaarden moeten bevatten. Coördinaten zijn getallen maar wanneer het aanvinkvak checkbox DMS coördinaten is geactiveerd, dienen deze degree/minutes/seconds (graden/minuten/seconden) notatie te bevatten. Door het activeren van het keuzerondje radiobuttonon Well known text (WKT) kan men geometriëen als punt- lijn- of polygoon-geometriëen opnemen in tekstvorm in de zogenaamde WKT notatie. Na activeren worden het X- en Y- invoerveld vervangen door het keuzevel Geometrie veld. Als laatste kan men ook een tabel toevoegen zonder geometrie met de optie radiobuttonon Geen geometrieen (alleen attributen tabel).

  5. Als Laag instellingen kun je het aanvinkvak checkbox Gebruik spatiale index activeren om de performance van het tonen en selecteren van objecten te verbeteren. Je daarnaast ook het aanvinkvak checkbox Gebruik Subset index activeren en het aanvinkvak checkbox Bestand in de gaten houden om wijzigingen in het bestand, door andere applicaties, in de gaten te houden, zolang QGIS actief is.

Als voorbeeld importeren wij het valide hoogtepunten tekstbestand elevp.csv die onderdeel is van de QGIS voorbeeld dataset (zie Voorbeeld Data):

X;Y;ELEV
-300120;7689960;13
-654360;7562040;52
1640;7512840;3
[...]

Enkele opmerkingen over het tekstbestand:

  1. Het voorbeeld tekstbestand gebruikt ; (puntkomma) als scheidingsteken. Elk teken kan gebruikt worden als scheidingsteken.

  2. De eerst rij is de kopregel. Deze bevat de velden X, Y en ELEV.

  3. Er zijn geen aanhalingstekens (") gebruikt voor de tekstvelden.

  4. De X coördinaten staan onder het veld X.

  5. De Y coördinaten staan onder het veld Y.

Het gebruik van de functie

Selecteer het icoon delimited_text Tekstgescheiden kaarlaag Toevoegen in de werkbalk Kaartlagen bewerken om de dialoog Creëer een Kaartlaag van een Tekstgescheiden Bestand te openen zoals getoond in figure_delimited_text_1.

Figure Delimited Text 1:

../../../_images/delimited_text_dialog.png

Creëer Tekstgescheiden Kaartlaag Dialoog nix

Selecteer eerst het bestand (bijv. :file:qgis_sample_data/csv/elevp.csv`)  via de knop **[Bladeren...]**. Wanneer het bestand is geselecteerd, zal |qg| proberen om het bestand op te delen in records met velden, met het laatst gebruikte scheidingsteken, in dit geval een puntkomma (;``). Het is belangrijk om eerst het goede scheidingsteken te selecteren om vanuit een tekstbestand de afzonderlijke velden te kunnen bepalen. Om het tab teken te kiezen als scheidingsteken, gebruik \t (dit is de reguliere expressie voor het tabulator karakter).

Wanneer het bestand is ingelezen, activeer het keuzerondje radiobuttononPunt coördinaten bij Geometrie definitie en kies het X en Y veld via de keuzelijst. Geef tenslotte de nieuw laag een naam (bijv., Hoogtepunten) zoals getoond in figure_delimited_text_1 . Na het selecteren van [OK] wordt de laag toegevoegd aan de kaart. Het tekengescheiden tekstbestand gedraagd zich als elke andere kaartlaag in QGIS.