Outdated version of the documentation. Find the latest one here.

Het Vector Eigenschappen Menu

Het menu Laag Eigenschappen voor een vector laag geeft in informatie over de laag, instellingen van de stijlen en de label opties. Wanneer de Vector laag geladen is vanuit een PostgreSQL/PostGIS database, kun je ook de SQL opdracht aanpassen waarmee deze laag is opgehaald door het Query Builder venster te starten onder het tabblad Algemeen. Om toegang te krijgen tot het menu Laag Eigenschappen kun je dubbelklikken op een kaartlaag in de legenda of een laag selecteren en met de rechtermuisklik het snelmenu openen en de menuoptie Eigenschappen selecteren.

Figure Vector Properties 1:

../../../_images/vector_general_menu.png

Het Vector Eigenschappen Menu nix

Stijl Menu

Het Stijl menu geeft toegang tot het toevoegen van symbologie van de vector data en hoe deze moet worden gerenderd. U kunt Laag rendering ‣ gereedschap kiezen die voor alle vectorgegevens gebruikt kunnen worden en speciaal symboolgereedschap dat is ontworpen voor verschillende soorten vectorgegevens.

Renderen van lagen

  • Laag transparantie slider: men kan hiermee onderliggende lagen zichtbaar maken in het kaartbeeld. Gebruik de schuifschaal om de transparantie van geselecteerde vectorlaag aan te passen. Rechts naast de schuifschaal kunt u een exact gewenst transparantie percentage invullen.

  • Laag blending modus: met dit hulpmiddel kunt u speciale effecten op de kaart toepassen die voorheen alleen bekend waren van grafische programma’s. De pixels van de overliggende en onderliggende kaartlagen wordt vermengd volgens de instellingen zoals hieronder beschreven.

    • Normaal: Dit is de standaard blend modus die het alpha kanaal van de bovenliggende pixels mengt met de onderliggende pixel; daarbij worden kleuren niet vermengt

    • Lichter maken: Deze selecteert de maximum waarden van de pixels van de voor en achtergrond. Het resultaat is vaak ruw, grof en kartelig.

    • Screen: Lichte pixels van de bronlaag worden getekend over de doellaag, terwijl dat niet gebeurd met donkere pixels. Deze modus is geschikt voor het mengen van de textuur van de ene laag met die van een andere laag. Je kunt deze bijvoorbeeld gebruiken om schaduwen van heuvels in te brengen in een andere laag.

    • Dodge: Hoe lichter de bovenliggende pixel is des te feller en met meer kleur zullen de onderliggende pixels getoond worden. Dit werkt het beste wanneer de bovenliggende top pixels niet te fel gekleurd zijn anders wordt het resultaat nogal extreem.

    • Toevoegen: Deze blend modus telt de pixelwaarde op van de ene laag bij de andere. Wanneer de waarden boven de 1 uitkomen (in het geval van RGB), zall die pixel wit worden. Deze modus is geschikt om bepaalde objecten op te laten lichten en zo te markeren.

    • Donkerder maken: De resulterende pixel die overblijft is die met de laagste waarde van de voor en achtergrond pixel. Net zoals bij de modus Lichter maken, is het resultaat van ruw, grof en gekarteld

    • Vermenigvuldigen: Deze vermenigvuldigd de waarden voor elke pixel van de toplaag met die van de onderliggende laag. Het resultaat is een donkerder kaartbeeld.

    • Branden: Donker kleuren in de toplaag zorgen ervoor dat onderliggende lagen ook donkerder worden. Dit kan worden gebruikt om de kleuren van onderliggende lagen bij te stellen.

    • Overlay: Combineert de modus vermenigvuldigen en screen. In het resulterend kaartbeeld worden de lichtere delen lichter en donkere delen donkerder.

    • Zacht licht: Lijkt erg op overlay, maar in plaats van de combinatie vermenigvuldigen/screen wordt de combinatie branden/dodge gebruikt. Het effect waar naar gestreefd wordt is dat van het schijnen van een zacht licht op het kaartbeeld.

    • Hard licht: Hard licht lijkt op de modus overlay. Deze moet ervoor zorgen dat het lijkt of er een sterk licht schijnt op het kaartbeeld.

    • Verschil: Verschil haalt de waarde van de top pixel van de onderliggend pixel af of omgekeerd, zodat er altijd een positieve waarde onstaat. Het mixen met zwart levert geen wijziging, omdat waarden voor alle kleuren 0 zijn.

    • Subtract: This blend mode simply subtracts pixel values of one layer with tshe other. In case of negative values, black is displayed.

Since QGIS 2.0 the old symbology is no longer available. In this version the new symbology has been redesigned and revised.

Renderers

De Renderer is verantwoordelijk voor het opbouwen van het kaartbeeld waarbij de objecten met de goede symbologie wordt getekend. Er zijn vier soorten Renderers: Enkel Symbool, Categoriëen (in de oude symbologie werd deze unieke kleuren genoemd), gradueel en Regel-gebaseerd. Er is geen continue kleuren renderer aangezien deze in feite een speciale variant van de Graduele renderer is. De graduele gecategoriseerde renderer kan worden aangemaakt door een combinatie van een symbool en een kleurverloop te kiezen - dit zal de symbolen weergeven met overeenkomende kleuren. Voor puntlagen is er ook een puntverplaatsings renderer beschikbaar. Voor elk data type (punten, lijnen en polygonen) zijn vector symbool laag typen beschikbaar. Afhankelijk van de gekozen renderer, geeft het menu Style menu de volgende verschillende onderdelen. Rechtonder in het symobologie dialoog is er de knop [Symbool] die toegang geeft tot de Stijlen Manager (zie vector_style_manager). De Stijlen Manager geeft de mogelijkheid om bestaande stijlen te bewerken te verwijderen maar ook om nieuwe toe te voegen.

Tip

Selecteer en wijzig meerdere symbolen

Met symbologie kun je meerdere symbolen selecteren en via de rechtermuis kun je de kleur, transparantie, de grootte en de dikte van de buitenlijnen aanpassen.

De Enkel Symbool Renderer

De renderer Enkel Symbool wordt gebruikt om alle objecten van een kaartlaag te presenteren met een enkel door de gebruiker toegekend symbool. De eigenschappen die kunnen worden gewijzigd in het tabblad Stijl is deels afhankelijk van het type kaartlaag, maar voor alle typen geldt de volgende opbouw.Links bovenin het tabblad, kun je de voorvertoning zien van het huidige symbool. Aan de rechterkant van het menu is een lijst van symbolen die reeds aangemaakt zijn voor de huidige stijl, klaar om te gebruiken door deze te selecteren uit de lijst. Het huidige symbool kan worden aangepast gebruik makende van het menu aan de rechterkant.

If you click on the first level in the Symbol layers dialog on the left side it’s possible to define basic parameters like Size, Transparency, Color and Rotation. Here the layers are joined together.

Figure Symbology 1:

../../../_images/singlesymbol_ng_line.png

Eigenschappen van enkele lijnsymbologie nix

Meer gedetailleerde instellingen kan men doen door te klikken op een lijn die zich bevind op het tweede niveau van Symboollagen. Men kan zo een lijn maken bestaande uit meerdere Symboollagen waarbij verschillend lijnsymbologie wordt gecombineerd. De volgende instellingen zijn mogelijk:

  • Symboollaagtypen: Men kan een lijn arceren met symbolen zoals met een Ellipse marker, een lettertype symbool, een standaard symbool, een SVG symbool of een vector veld marker

  • Grootte

  • Hoek

  • Kleuren

  • Randbreedte

  • Verspring X,Y: Men kan het symbool verschuiven in de X- of Y-richting

Let op dat wanneer je de grootte in de lagere levels hebt gezet, dat je de grootte van het hele symbool weer kunt wijzigen met het menu Grootte in het eerste level. De grootte van de lagere levels zal naar rato mee veranderen. Na het symbool te hebben aangepast kan deze worden opgeslagen en worden toegevoegd aan de lijst van huidige stijl symbolen (gebruik makende van de knop [Stijl opslaan...]) zodat deze in de toekomst weer gebruikt kan worden. In het vervolgmenu Sla laageigenschappen op als stijlbestand dat verschijnt na het indrukken van de knop [Stijl opslaan] kun ervoor kiezen om de stijl van de laag op te slaan in een QGIS stijl bestand (.qml) of als SLD bestand (.sld). Een SLD (Styled Layer Descriptor) is een open standaard formaat voorgeschreven door het OGC, die o.a. ook wordt gebruikt door geoserver. Voor de export mogen alle renderstijlen gebruikt worden, maar wanneer een SLD stijl bestand wordt geimporteerd zullen deze worden omgezet naar de simpele symbolen of de regelgebaseerde renderstijl. categoriën of graduele renderstijlen worden daarbij omgezet naar regelgebaseerde renderstijlen. Wanneer je dat wilt voorkomen kun je de stijl het beste opslaan als .qml bestand, maar het is aan de andere kant ook een eenvoudige manier om de renderstijl snel om te zetten.

With the Style manager from the [Symbol] selectstring menu you can administrate your symbols. You can mActionSignPlus add item, editedit item, mActionSignMinus remove item and user share item. ‘Marker’ symbols, ‘Line’ symbols, ‘Fill’ patterns and ‘Color ramps’ can be used to create the symbols (see defining_symbols). The symbols are assigned to ‘All Symbols’, ‘Groups’ or ‘Smart groups’ then.

De Categoriën Renderer

De Categoriën Renderer wordt gebruikt om alle objecten van een laag te tekenen met één symbool met een kleur die afhankelijk is van een attribuutwaarde van diezelfde laag. Het tabblad Stijl geeft je de mogelijkheid om een keuze te maken uit:

  • Een kolom (uit de lijst van attribuutvelden)

  • Het symbool (gebruik makende van het Symbool selectie menu)

  • De kleuren (uit de lijst van de kleurverlopen)

Met de knop [Geavanceerd] die zich rechtsonder in het menu bevindt, kun je instellen welke velden gebruikt kunnen worden voor de rotatie of voor de schaalgrootte van het symbool afhankelijk te maken van de veldwaarde. Daarbij kun je eenvoudig een veld kiezen in een keuzelijstje van velden die je daar eventueel voor kunt gebruiken. De lijst centraal in het menu toont de waarden van de huidig geselecteerde attributen, inclusief de symbolen die zullen worden getekend.

Het voorbeeld in figure_symbology_2 toont de categoriën rendering dialoog gebruikt voor de laag rivers van de QGIS sample dataset.

Figure Symbology 2:

../../../_images/categorysymbol_ng_line.png

Categoriën Symbologie opties nix

Je kunt zelf een nieuwe kleurverloop aanmaken door onderin de lijst van kleurverlopen te kiezen voor Nieuw kleurverloop.... In het venster dat opent kun je vervolgens een kleurverlooptype selecteren uit: Gradiënt, Random, ColorBrewer en cpt-city. Na het drukken op de knop [OK] kun je voor de eerste dire vervolgens ook meerdere ‘stops’ in het kleurverloop opnemen. Zie figure_symbology_3 die een voorbeeld toont van een zelf gemaakte kleurverloop en figure_symbology_3a voor de dialoog cpt-city.

Figure Symbology 3:

../../../_images/customColorRampGradient.png

Voorbeeld van een zelfgemaakte gradiënten kleurenovergang met meerdere stops nix

The cpt-city option opens a new dialog with hundreds of themes included ‘out of the box’.

Figure Symbology 3a:

../../../_images/cpt-cityColorRamps.png

cpt-city dialog with hundreds of color ramps nix

De Graduele Renderer

De Graduele Renderer wordt gebruikt om voor een laag aan de hand van een enkel symbool de classificatie weer te geven aan de hand van de kleuren die afhankelijk is van een attribuutwaarde.

Figure Symbology 4:

../../../_images/graduatesymbol_ng_line.png

Graduele Symbologie opties nix

Net als de Categoriën Renderer, kun je hiervoor de rotatie en de grootte afhankelijk maken van attribuutwaarden.

Net als de categoriën Renderer, heeft het tabblad Stijl de selectiemogelijkheden:

  • Een kolom (uit de lijst van attribuutvelden)

  • Het symbool (Gebruik makende van het Symbool selectie menu)

  • The colors (using the Color Ramp list)

Aanvullend kun je het aantal klassen kiezen en ook welke modus je wilt gebruiken voor de Klassificatie. De beschikbare modus zijn:

  • Gelijke Interval

  • Quantilen

  • Natuurlijke Grenzen (Jenks)

  • Standaard Afwijking

  • Mooie Grenzen

De lijst in het onderste deel van het tabblad Stijl somt de klassen op met hun bereik, labels en symbolen die voor het renderen worden gebruikt.

Het voorbeeld in figure_symbology_4 toont de dialoog van de Renderer Gradueel voor de laag rivers van de QGIS voorbeeld dataset.

De Regel-gebaseerde Renderer

De Regel-gebasseerde Renderer wordt gebruikt om objecten van een laag te tonen waarbij gebruikte kleuren afhankelijk zijn van toegepaste regels. Deze regels zijn gebasseerd op SQL opdrachten. Je kunt ook de Zoekopdrachtbouwer gebruiken om deze te maken. De dialoog geeft de mogelijkheid om met een filter te groeperen of verschalen en je kunt besluiten of je symboollagen wilt gebruiken of dat de eerste regel waaraan voldaan wordt gebruikt wordt.

Het voorbeeld in figure_symbology_5 toont de dialoog van een Regel-gebaseerde renderer voor de laag rivers van de QGIS voorbeeld dataset.

Om een nieuwe regel toe te voegen aan de regelgebaseerde rendering, selecteer een regel in de lijst of druk op ‘+’ en selecteer de nieuwe regel. Druk vervolgens op de knop [Regel bewerken] waarna de dialoog Regel eigenschappen opent waarmee je dat kunt doen. Druk in de dialoog op de knop browsebutton waarmee de Expressie-string bouwer opent waarmee je expressies kunt maken. Dubbelklik eerst op >-Velden en Waarden waarna je de attribuutvelden ziet. Om een attribuutveld toe te voegen, dubbelklik op het veld in de lijst van >-Velden en Waarden.Je kunt de verschillende velden, waarden en functies gebruiken om daarmee een expressie op te bouwen of je kunt dit direct doen door dit in het tekstblok van expressie in te typen (zie Veld berekening).

Figure Symbology 5:

../../../_images/rulesymbol_ng_line.png

Regelgebasseerde Symbologie opties nix

De Punt Verplaatsing Renderer

Deze Punt Verplaatsing Renderer biedt de mogelijkheid om alle objecten te zien ook al staan er meerdere op exact de zelfde positie. Wanneer dat het geval is worden deze op afstand in een circel eromheen geplaatst zodat ze toch zichtbaar zijn.

Figure Symbology 6:

../../../_images/poi_displacement.png

De Punt Verplaatsings dialoog nix

Tip

Export vector symbology

You have the possibility to export vector symbology from QGIS into the Google .kml, *.dxf and MapInfo.tab files. Just open the right mouse menu of the layer and click on Save selection as ‣ to define the name of the output file and its format. Use the Symbology export menu to save the symbology either as Feature symbology ‣ or as Symbol layer symbology ‣. If you have used symbol layers it is recommended to use the second setting.

het Labels menu

Achter de nieuwe knop mActionLabeling Labels zit een geavanceerde manier voor het plaatsen van labels van vector punt-, lijn- en polygoonlagen waarvoor slechts enkele instellingen nodig zijn. Deze ondersteund ook Gelijktijdige CRS Transformatie. In QGIS 2.0 zijn nu een aantal extra functie voor het verbeteren van het labelen. De volgende menu’s zijn gemaakt voor het labelen van vectorlagen:

  • Tekst

  • Opmaak

  • Buffer
  • Achtergrond

  • Schaduw

  • Plaatsing

  • Rendering

Laten we een kijken hoe de nieuwe menu’s gebruikt kunnen worden voor verschillende vectorlagen.

Het labelen van vector puntlagen

Start QGIS en laad een punten vectorlaag. Selecteer deze in de legenda en druk op het mActionLabeling Laag Labelen Opties in de werkbalk Labels van QGIS.

De eeste stap is om het aanvinkvak checkbox Label deze laag met en selecteer een veldattribuut om te gebruiken om te labelen. Selecteer mActionmIconExpressionEditorOpen wanneer je expressie gebaseerde labels wilt maken.

De volgende stappen beschrijven eenvoudige labeling zonder de Data-bepaalde override functies te gebruiken die zich in uitklapbare keuzemenu’s bevinden rechts van de invulbare velden.

You can define the text style in the Text menu (see Figure_labels_1 ). A new function is the Type case option where you can influence the text rendering. You have the possibility to render the text ‘All uppercase’, ‘All lowercase’ or ‘Capitalize first letter’. Also, a new function in QGIS 2.0 is the use of blend modes (see blend_modes).

In het menu Opmaak kun je een tekstkarakter ingeven die gebruikt moet worden als afbrekingsteken waarmee labeltekst worden afgebroken en verdergaat op volgende regel. Activeer de optie checkbox Formatted numbers voor de opmaak van getallen. Het aantal decimale plaatsen wordt hier gegeven. Wanneer je deze optie activeert zullen getallen standaard met drie decimalen worden weergegeven.

To create a buffer just activate checkbox Draw text buffer checkbox in the Buffer menu. The buffer color is variable. Also, a new function in QGIS 2.0 is the use of blend modes (see blend_modes).

If the checkbox Color buffer’s fill checkbox is activated, it will interact with partially transparent text and give mixed color transparency results. Turning off the buffer fill fixes that issue (except where the interior aspect of the buffer’s stroke intersects with the text’s fill) and also allows the user to make outlined text.

In het Achtergrond menu kun je met Grootte X en Grootte Y de vorm van de achtergrond definiëren. Gebruik de grootte velden om een extra ‘buffer’ als achtergrond in te brengen. Standaard wordt hier 1 ingevuld. De achtergrond bestaat dan uit de buffer plus de extra Grootte X en Grootte Y. Men kan met Rotatie de rotatie van het label bepalen waarbij je kunt kiezen tussen ‘Met label synchroniseren’, ‘Op afstand van label’ en ‘Vast’. Met ‘Op afstand van label’ en ‘Vast’ kan de achtergrond worden geroteerd. Geef een Offset X,Y met X en Y waarden en de achtergrond zal verplaatst worden. Wanneer Radius X,Y wordt gebruikt zal de achtergrond afgeronde hoeken krijgen. Het is ook mogelijk de achtergrond met de onderliggende lagen in het kaartbeeld te mengen met Blend mode (zie blend_modes).

Use the Shadow menu for a user-defined Drop shadow. The drawing of the background is very variable. Choose between ‘Lowest label component’, ‘Text’, ‘Buffer’ and ‘Background’. The Offset angle depends on the orientation of the label. If you choose the checkbox Use global shadow checkbox then the zero point of the angle is always oriented to the north and doesn’t depend on the orientation of the label. Influence the appearance of the shadow with the Blur radius. The higher the number, the softer the shadows.

The appearance of the drop shadow can also be altered by choosing a blend mode (see blend_modes).

Kies het menu Plaatsing voor het plaatsen van het label t.o.v. het object en de prioriteit van het plaatsen van labels. Wanneer je gebruik maakt van radiobuttonon Op afstand van punt kun je gebruik maken van Kwadranten om aan te geven waar het label geplaatst moet worden t.o.v. het object. Aanvullend kun je het label ook plaatsen onder een bepaalde hoek met de instelling Rotatie.

In the Rendering menu you can define label and feature options. In the Label options you find the scale-based visibility setting now. You can prevent QGIS from rendering only selected labels with the checkbox Show all labels for this layer (including colliding labels) checkbox. In the Feature options you can define if every part of a multipart feature is to be labeled. In QGIS 2.0 now it’s possible to define if the number of features to be labeled is limited and to checkbox Discourage labels from covering features.

Figure Labels 1:

../../../_images/label_points.png

Slim labelen van punten vector lagen nix

Het labelen van vector lijnlagen

De eerste stap is het activeren van checkbox Deze laag labelen met in het menu Instelling voor het labelen van laag en kies het attribuutveld dat gebruikt moet worden voor het labelen. Selecteer mActionmIconExpressionEditorOpen wanneer je expressie gebaseerde labels wilt gebruiken.

Hierna kun je de tekst tekststijl kiezen in het menu Tekst. Hier kun je dezelfde settings gebruiken als voor punten vector lagen.

Ook in het menu Opmaak kun je dezelfde instellingen gebruiken als voor punten lagen.

Het menu Buffer heeft dezelfde functies als beschreven in labeling_point_layers .

Het Achtergrond menu heeft dezelfde invulvelden als beschreven in labeling_point_layers .

Ook het menu Schaduw heeft dezelfde invulvelden as beschreven in labeling_point_layers .

In the Placement menu you find special settings for line layers. The label can be placed radiobuttonon Parallel, radiobuttonoff Curved or radiobuttonoff Horizontal. With the radiobuttonon Parallel and radiobuttonoff Curved option come the following settings: You can define the position checkbox Above line, checkbox On line and checkbox Below line. It’s possible to select several options at once. QGIS will look for the optimal position of the label then. Remember that here you can also use the line orientation for the position of the label. Additionally you can define a Maximum angle between curved characters when selecting the radiobuttonoff Curved option (see Figure_labels_2 ).

Het menu Rendering heeft bijna dezelfde invulbare velden als die voor punt lagen. Je kunt bij de Label opties aangeven wanneer het labelen niet gedaan mag worden met Onderdruk het labelen van objecten kleiner dan.

Figure Labels 2:

../../../_images/label_line.png

Slim labelen van lijn vectorlagen nix

Het labelen van polygoon vectorlagen

De eeste stap is om het aanvinkvak checkbox Label deze laag met en selecteer een attribuutveld om te gebruiken voor het labelen. Selecteer mActionmIconExpressionEditorOpen wanneer je expressie gebaseerde labels wilt maken.

Definieer de teststijl met het menu Tekst. De invulbare velden zijn gelijk aan die voor punt- en lijnlagen.

Het menu Opmaak geeft de mogelijkheid om meerdere regels op te maken net zoals voor punt- en lijnlagen.

Zoals met punt- en lijnlagen kun je een tekstbuffer creëren met het menu Buffer.

Gebruik het Achtergrond menu om een complexe achtergrond voor de polygoonlaag te maken. Je kunt het menu ook gebruiken voor punt- en lijnlagen.

De invulbare velden in het menu Schaduw zijn dezelfde als voor punt- en lijnlagen.

In het menu Plaatsing zijn er speciale instellingen voor het zetten van labels voor polygoonlagen (zie Figure_labels_3 ). radiobuttonon Op afstand van centroïde, radiobuttonoff Horizontaal (langzaam), radiobuttonoff Rondom centroïde, radiobuttonoff Vrij (langzaam) en radiobuttonoff Gebruik omtrek zijn mogelijk.

Voor de keuze radiobuttonon Op afstand van centroïde kun je aan aangeven of voor bepaling van de centroïde de radiobuttonon zichtbare polygoon in het kaartbeeld of de radiobuttonoff gehele polygoon gebruikt moet worden. Je kunt kwadranten gebruiken en daarbij hoeveel “op afstand” en de rotatie geven van de te plaatsen labels. Met het keuzerondje radiobuttonoff Rondom centroïde is het mogelijk het label te plaatsen rondom de centroïde met een bepaalde afstand. Wederom kun je met de keuze radiobuttonon zichtbare polygoon of radiobuttonoff gehele polygoon de plaats van de centroïde bepalen. Bij de keuze radiobuttonoff Gebruik omtrek kun je de positie en de afstand voor het label geven. Voor de positie zijn de mogelijkheden checkbox Boven lijn, checkbox Op lijn, checkbox Onder lijn and checkbox Positieafhankelijk oriëntatie van lijn.

Het menu Rendering heeft bijna dezelfde invulbare velden als die voor lijnlagen. Je kunt bij de Label opties aangeven wanneer het labelen niet gedaan mag worden met Onderdruk het labelen van objecten kleiner dan.

Figure Labels 3:

../../../_images/label_area.png

Slim labelen van polygoon vectorlagen nix

Gebruik data gedefinieerd labelen

Met de data-bepaalde override functies kunnen de instellingen voor het labelen overschreven worden met veldwaarden uit de attributentabel. Je kunt deze functie activeren/deactiveren met de rechtermuisknop. Hou de muisaanwijzer boven het symbool en je ziet informatie over de data-bepaalde override, inclusief het huidige gebruikte veld voor de definitie. We zullen nu een voorbeeld geven hoe de data-bepaalde override functies gebruikt kunnen worden voor de mActionMoveLabelVerplaats label functionaliteit (zie figure_labels_4 ).

  1. Import the lakes.shp from the QGIS sample dataset.
  2. Dubbelklik op de laag in de legenda om het menu Laag Eigenschappen te openen. Selecteer Labels en Plaatsing. Selecteer de keuze radiobuttonon Op afstand van centroïde.

  3. Ga naar het onderdeel Data gedefinieerd. Klik op het icoon mIconDataDefine om te bepalen welk veld gebruikt moet worden voor Coördinaat. Kies ‘xlabel’ voor X en ‘ylabel’ voor Y. De icoontjes lichten nu geel op.

  4. Zoom in op een meer.

  5. Ga naar de werkbalk Labels en selecteer het icoon mActionMoveLabel. Je kunt nu het label handmatig verschuiven naar een andere plaats (zie figure_labels_5 ). De nieuwe positie van het label is opgeslagen in de velden ‘xlabel’ en ‘ylabel’ veld van de attributentabel.

Figure Labels 4:

../../../_images/label_data_defined.png

Het labelen van polygoon vectorlagen met data-gedefinieerde overrides nix

Figure Labels 5:

../../../_images/move_label.png

Verplaatsen van labels nix

Menu velden

attributes In het tabblad Velden kun je eigenschappen van de velden van de geselecteerde vectorlaag veranderen. De knoppen mActionNewAttribute Nieuwe kolom en mActionDeleteAttribute Verwijder kolom kunnen worden gebruikt wanneer de vectorlaag eerst bewerkbaar gemaakt wordt. Met de knop mActionToggleEditing Bewerken aan/uitzetten kun je wisselen tussen het al dan niet kunnen bewerken van een laag.

Wijzig hulpmiddel

Figure Fields 1:

../../../_images/editwidgetsdialog.png

Dialoog om een wijzig-hulpmiddel te kiezen voor een attribuutveld nix

In het tabblad Velden vind je in de lijst van velden ook de kolom Wijzig-hulpmiddel. Deze kolom bevat knoppen waarmee je zelf meer controle kunt krijgen over welke waarden er in een veld kunnen worden opgevoerd en op welke manier. Wanneer je in een kolom op de knop [Wijzig-hulpmiddel] drukt, start er een dialoog, waarmee je verschillende hulpmiddelen voor een veld kunt instellen. Dit zijn de volgende:

  • Lijn wijzigen: hiermee kun je een regel tekst voor tekstvelden opvoeren of alleen getallen voor numerieke velden.

  • Classificatie: Toont een keuzelijst met waarden die al gebruikt zijn voor dat veld wanneer je dat veld ook hebt gebruikt om daarmee de symbologie te classificeren in het tabblad Stijl. Voor elke ‘unieke waarde’ is het dan mogelijk een andere symbologie te gebruiken.

  • Range: Stel een bereik van waarden in die gebruikt mag worden door een minimum en een maximum waarde in te vullen. Daarnaast kun je ook aangeven of de waarde kan worden ingegeven via een schuifbalk of via een spinbox/draaischijf, waarmee je de waarde kunt instellen door deze naar een waarde te draaien.

  • Unieke waarden: De gebruiker kan alleen al gebruikte waarden kiezen. Daarnaast kan er voor gekozen worden om de waarde ‘aanpasbaar’ te maken, daarbij kan de gebruiker de waarden beginnen te typen en zodra er nog maar 1 mogelijk waarde over blijft zal deze automatisch helemaal worden ingevuld. Kies je niet voor ‘aanpasbaar’ dan krijg je een keuzeveld.

  • Bestandsnaam: Hiermee kun je een bestandsnaam invullen door een bestand te selecteren via de bestandskiezer.

  • Aanwezige waarden: Hiermee kun je in een keuzeveld een Omschrijving kiezen, en daarmee wordt een daaraan gekoppelde waarde ingevuld. Daarbij moet je dus eerst een gekoppelde lijst van waarden en omschrijvingen laden (vanuit een laag of vanuit een csv bestand) of je kunt deze hier opbouwen.

  • Enumeratie: Opent een keuzeveld met waarden die gebruikt kunnen worden. Dit wordt momenteel alleen ondersteund voor de postgres database.

  • Niet aanpasbaar: Wanneer deze is ingesteld is het veld niet aanpasbaar en is deze alleen leesbaar.

  • Verborgen: Een verborgen veld is niet zichtbaar. De gebruiker kan de inhoud van het veld niet zien.

  • Aanvinkvakje: Toont een aanvinkvakje en je kunt zelf invullen welke waarde wordt ingevuld wanneer deze aangevinkt en een niet aangevinkt is.

  • Tekstbewerken: Dit opent een tekstveld waarin je meerdere regels tekst kunt ingeven.

  • Kalender: Opent een kalendercomponent waarmee je een datum kunt kiezen die vervolgens wordt ingevuld. Het veldtype moet een tekstveld zijn.

  • Waarde-relatie: Keuzeveld waarde de waarden zijn ingevuld vanuit een gerelateerde tabel. Je kunt hiervoor een laag, een sleutelveld en het veld met te kiezen waarden instellen.

  • UUID Generator: Genereert een veld waarin automatisch een UUID (Universele Unieke IDentifier), een unieke waarde die automatisch wordt gegenereerd wanneer het veld, door de gebruiker,niet wordt ingevuld.

  • Foto: Het veld bevat de veldnaam van een afbeelding. De breedte en hoogte van het veld kunnen worden gegeven.

  • Webview: Het veld bevat een URL. De breedte en hoogte van het veld zijn variabel.

  • Kleur: Een veld waarmee je kleurcodes kunt invullen. Tijdens het invoeren is er een kleurenbalk aanwezig waarmee de kleur zichtbaar wordt gemaakt.

With the Attribute editor layout you can now define builtin forms for data entry jobs (see figure_fields_2). Choose ‘Drag and drop designer’ and an attribute column. Use the mActionSignPlus Icon to create a category that then will be shown during the digitizing session (see figure_fields_3). Next step will be to assign the relevant fields to the category with the mActionArrowRight Icon. You can create more categories and use the same fields again. When creating a new category QGIS will insert a new tab for the category in the built in form.

Overige opties in het dialoog zijn ‘Automatisch genereren’ en ‘Geef een ui-bestand’. ‘Automatisch genereren’ zal editors aanmaken voor alle velden en deze in de tabel zetten. Met de optie ‘Geef een ui-bestand’ kun je veel complexere formulieren gebruiken gemaakt met de Qt-Designer. Het gebruik van een UI-bestand geeft veel meer vrijheid om een dialoog te maken. Voor gedetailleerde informatie zie http://nathanw.net/2011/09/05/qgis-tips-custom-feature-forms-with-python-logic/ .

QGIS dialogs can have a python function that is called when the dialog is opened. Use this function to add extra logic to your dialogs. An example is (in module MyForms.py):

def open(dialog,layer,feature):
geom = feature.geometry()
control = dialog.findChild(QWidged,"My line edit")

Refereer naar de Python Init Functie als volgt: MyForms.open

MyForms.py must live on PYTHONPATH, .qgis2/python, or inside the project folder

Figure Fields 2:

../../../_images/attribute_editor_layout.png

Dialoog om categorieën aan te maken met de Attribute editor layout

Figure Fields 3:

../../../_images/resulting_feature_form.png

Resultaat formulier tijdens het opvoeren van gegevens

Tabblad Algemeen

general Gebruik het tabblad Algemeen voor algemene instellingen voor een vectorlaag. Je kunt hiermee verschillende zaken instellen:

Laag Info

  • Wijzig de zichtbare naam van de laag in de legenda met Toon als

  • Zet de bron van de vector laag

  • Geef de brondata codering om provider specifieke opties te geven om daarmee het bestand te lezen

Coördinaten Referentie Systeem

  • Specificeer het Coördinaten Referentie Systeem. Hier kun je de projectie bekijken of wijzigen voor de specifieke vectorlaag.

  • Maak een :guilabel: Ruimtelijke Index aan (alleen voor OGR ondersteunde formaten)

  • De knop [Update Extents] zal de kleinste rechthoek bepalen waarbinnen alle geometriëen van deze laag passen

  • Bekijk of wijzig de ruimtelijke projectie van deze specifieke vectorlaag, met de knop [Geef het CRS]

checkbox Schaalafhankelijke zichtbaarheid

  • Je kunt de Maximum (inclusief) en Minimum (exclusief) schaal instellen. De schaal kan ook gezet worden met de knop [Current]

Deelverzameling objecten

Figure General 1:

../../../_images/vector_general_menu.png

Het menu Algemeen in de vectorlaag eigenschappen dialoog nix

Display Menu

mActionMapTips In QGIS 2.0 there is now an own menu for the map tips. It includes a new feature: Map Tip display text in HTML. While you can still choose a radiobuttonoff Field to be displayed when hovering over a feature on the map it is now possible to insert HTML code that creates a complex display when hovering over a feature. To activate Map Tips, select the menu option View ‣ MapTips.Figure Display 1 shows an example of HTML code.

Figure Display 1:

../../../_images/display_html.png

HTML code for map tip nix

Figure Display 2:

../../../_images/map_tip.png

Map tip made with HTML code nix

Tabblad Acties

action QGIS geeft de mogelijkheid om een actie te starten waarbij gebruik wordt gemaakt van attribuutwaarden. Je kunt meerdere acties per vectorlaag aanmaken waarmee je bijvoorbeeld een ander programma kunt aanroepen waarbij attribuutwaarden als argumenten meegeeft.

Figure Actions 1:

../../../_images/action_dialog.png

Het actie menu met enkele voorbeeldacties nix

Acties zijn erg handig wanneer je regelmatig een ander programma wilt starten waarbij je waardes meegeeft van een vectorlaag. Een voorbeeld is een zoekactie op internet waarbij een waarde van een vectorlaag wordt meegegeven. Acties kunnen onderverdeeld worden in 6 typen die als volgt gebruik kunnen worden:

  • Generiek, Mac, Windows en Unix acties starten een extern process (programma),

  • Python acties start de uitvoering van python code,

  • Generieke en Python acties zijn overal zichtbaar,

  • Mac, Windows en Unix acties zijn alleen zichtbaar onder die specifieke besturingssystemen (bijv. je kunt drie ‘Bewerk’ acties maken om een bewerkingsprogramma te openen, maar de gebruiker zullen alleen die ‘Bewerk’actie zien voor hun platform).

Er zijn enkele voorbeelden toegevoegd in de dialoog. Je kunt deze laden door te drukken op [Standaard acties toevoegen]. Een voorbeeld is een zoekactie gebaseerd op een attribuutwaarde. Dit concept is gebruikt in volgende discussie.

Het definiëren van Acties

Open het Laag Eigenschappen menu voor een vectorlaag en open het tabblad Acties. Bovenin zie je een lijst van gedefiniëerde actie (leeg) en onderin kun je onder Actie-eigenschappen een nieuwe actie toevoegen. Geef in het veld ‘Naam’ een beschrijvende naam voor de nieuwe actie. Vul in het veld ‘Actie’ in ieder geval de naam (en het pad) van het te starten programma en als argumenten één of meerdere namen van velden waarvan de waarden worden gebruikt door het programma. Wanneer de actie word gestart dan worden de woorden die beginnen met een % teken gevolgd door een veldnaam vervangen door de waarde van dat veld. De speciale tekens %% zullen vervangen worden door de waarde van een nog te selecteren veld in de het scherm Identificatieresultaten of in de Attributentabel (zie using_actions hieronder). Dubbele aanhalingstekens kunnen worden gebruikt om text samen te voegen tot één enkel mee te geven argument aan een programma, script of opdracht. Dubbele aanhalingstekens zullen worden genegeerd wanneer vooraf gegaan door een backslash.

Wanneer je een veldnaam gebruikt waarvan de naam een deel vormt van een ander veldnaam (bijv. col1 en col10) gebruik dan rechte haken om het veldnaam en het % teken (bijv. [\%col10]). Dit voorkomt dat het veld %col10 wordt gelezen als veld %col1 met daarachter de tekst 0. De rechte haken zullen verwijderd worden door QGIS wanneer deze vervangen worden door de veldwaarde. Wanneer je echter rechte haken mee wilt geven gebruik dan een tweede paar haken, bijvoorbeeld: [[\%col10]].

Het venster Identificatieresultaten heeft een (Afgeleid) deel die gegevens bevat die relevant zijn voor die vectorlaag type. Ook deze afgeleide velden kunnen worden gebruikt in een actie door de van van het afgeleide veld vooraf te laten gaan door (Derived).. Een punt vectorlaag heeft bijvoorbeeld de afgeleide velden X en Y. Je kunt die waarde van die velden als volgt gebruiken in een actie met %(Derived).X en %(Derived).Y. De afgeleide waarden zijn alleen beschikbaar in het venster Identieficatieresultaten niet in het venster van de Attributentabel.

Twee voorbeeld acties worden hier getoond:

  • konqueror http://www.google.com/search?q=%nam
  • konqueror http://www.google.com/search?q=%%

In het eerste voorbeeld, wordt de web browser konqueror gestart en een URL meegegeven als argument. Er wordt gegoogled op de waarde van het veld nam van de vectorlaag. Let op dat de applicatie wel gevonden moet kunnen worden anders moet je het ook het pad meegeven bij het aanroepen van de applicatie. Om er zeker van te zijn dat deze werkt, kunnen we de actie herschrijven waarbij we het hele pad meegeven, het eerste voorbeeld wordt dan: /opt/kde3/bin/konqueror http://www.google.com/search?q=\%nam. Dit zal zeker de web browser applicatie opstarten wanneer deze actie wordt gestart.

Het tweede voorbeeld gebruikt de %% notatie, waarbij we niet uitgaan van een bepaald veld. Wanneer de actie wordt gestart, zal %% worden vervangen door de waarde van het geselecteerde veld in de Identificatieresultaten of van de Attributen tabel.

Gebruik van Acties

Acties kunnen worden gestart vanuit het venster Identificatie Resultaten of vanuit het venster Attributen Tabel. Deze kunnen worden geopend door het icoon mActionIdentify Objecten Identificeren of mActionOpenTable Open attributentabel. Om een actie te starten, selecteer een record en gebruik de rechtermuis om het snelmenu te starten, selecteer daarin de actie. De acties komen erin voor met de gegeven naam.

Wanneer je een actie start die de %% notatie gebruikt, selecteer dan eerst het veld dat je wilt meegeven als argument, in het venster Identificatieresultaten of de dialoog Attribuut tabel zodat de waarde van dat veld wordt meegegeven aan de actie.

Hier volgt nog een voorbeeld dat gegevens uit een vectorlaag met plantensoorten haalt en deze met de lokatie naar een bestand schrijft via een de bash opdracht en de echo opdracht (deze bash opdracht werkt alleen onder nix en misschien ook onder osx). De laag heeft velden met de soortnaam soortnaam, de breedtegraad lat en de lengtegraad long. Hier volgt de gedefinieerde actie:

bash -c "echo \"%taxon_name %lat %long\" >> /tmp/species_localities.txt"

Na het achtereenvolgens selecteren van een aantal objecten (planten) en het aanroepen van de actie ziet de inhoud van het bestand er ongeveer zo uit:

Acacia mearnsii -34.0800000000 150.0800000000
Acacia mearnsii -34.9000000000 150.1200000000
Acacia mearnsii -35.2200000000 149.9300000000
Acacia mearnsii -32.2700000000 150.4100000000

Als oefening kunnen we een actie maken voor de vectorlaag lakes waarbij we gegevens opzoeken in google. Eerst moeten we bepalen wat de URL is waarmee we met een zoekterm kunnen zoeken google. Dat doen we door een simpele zoekopdracht te geven en vervolgens uit de adresregel van de webbrowser de gebruikte URL over te nemen. We zien dat het formaat van de URL als volgt is: http://google.com/search?q=qgis, waarin in dit geval qgis de zoekterm is.

  1. Eerst moet de laag lakes zijn geladen.

  2. Open de dialoog Laag Eigenschappen door in de legenda te dubbelklikken op de vectorlaag of door via de rechtermuisknop het snelmenu te open en daarin Eigenschappen te selecteren.

  3. Open het tabblad Acties.

  4. Geef een naam voor de actie bijvoorbeeld Google Search.

  5. Voor de actie moeten we de opdracht geven waarmee de webbrowser wordt opgestart. In dit geval gebruiken we Firefox. Wanneer het programma niet rechtstreeks kan worden opgestart met alleen het programmanaam dan dient het volledige pad te worden meegegeven.

  6. Geef na de naam van de webbrowser de URL toe waarmee we gaan zoeken in Google zonder zoekterm: http://google.com/search?q=

  7. De tekst in het veld Actie ziet er nu als volgt uit: firefox http://google.com/search?q=

  8. Selecteer de keuzelijst die de vectorlaag lakes bevat. Deze keuzelijst staat links van de knop [Voer veld in].

  9. Selecteer in de keuzelijst met veldnamen het veld Names van de vectorlaag lakes en klik op de knop [Voer veld in].

  10. De tekst van actie ziet er nu als volgt uit:

    firefox http://google.com/search?q=\%NAMES

  11. Als laatste selecteer de knop [Voer actie in] waarna de gemaakte actie wordt toegevoegd aan de lijst van acties.

Hiermee is deze actie aangemaakt en klaar om te gebruiken. De uiteindelijke tekst van de actie ziet er als volgt uit:

firefox http://google.com/search?q=%NAMES

We kunnen deze actie nu gebruiken. Sluit de dialoog Laag Eigenschappen. Zorg ervoor dat de laag lakes geselecteerd is in de legenda en start de functie Objecten Identificeren. Na selectie van een meer zie je dat de actie beschikbaar is in het resultaat:

Figure Actions 2:

../../../_images/action_identifyaction.png

Selecteer een object en kies een actie nix

Wanneer we de actie selecteren, zal deze de webbrowser opstarten met gegeven URL en zoekterm. De zoekterm zou uitgebreid kunnen worden door aan de actie ‘+’ toe te voegen en nog een veld mee te geven. Voor de gebruikte laag heeft dat echter weinig zin.

Je kunt meerdere acties definiëren die getoond worden in het scherm Identificatieresultaten.

Je kunt allerlei toepassingen van acties bedenken. Wanneer je de lokaties van foto’s hebt kun je met een actie die foto’s openen in een viewer applicatie.

We kunnen ook meer geavanceerde akties te maken, door bijvoorbeeld gebruik te maken van Python acties.

Normaal gebruiken we absolute paden wanneer we een actie maken om een bestand met een externe toepassing te openen, of eventueel relatieve paden. In het tweede geval is het pad relatief ten opzichte van de locatie van de externe toepassing. Maar wat wanneer we een relatief pad willen gebruiken ten opzichte van de geopende laag (een vectorbestand, zoals een shapefile of een spatialite databasebestand)? De volgende code geeft een mogelijke oplossing:

command = "firefox";
imagerelpath = "images_test/test_image.jpg";
layer = qgis.utils.iface.activeLayer();
import os.path;
layerpath = layer.source() if layer.providerType() == 'ogr' \
  else (qgis.core.QgsDataSourceURI(layer.source()).database() \
  if layer.providerType() == 'spatialite' else None);
path = os.path.dirname(str(layerpath));
image = os.path.join(path,imagerelpath);
import subprocess;
subprocess.Popen( [command, image ] );

het is goed om te weten dat de actie van het type python is en om de variabelen command en imagerelpath te wijzigen naar gewenste waarden.

Maar wat als we een relatieve pad nodig hebben ten opzichte van het opgeslagen projectbestand? Dat kan met volgende python code:

command="firefox";
imagerelpath="images/test_image.jpg";
projectpath=qgis.core.QgsProject.instance().fileName();
import os.path; path=os.path.dirname(str(projectpath)) if projectpath != '' else None;
image=os.path.join(path, imagerelpath);
import subprocess;
subprocess.Popen( [command, image ] );

Het volgende voorbeeld van een Python actie toont hoe je daarmee nieuwe lagen kunt toevoegen aan het project. Bijvoorbeeld het volgende project zal respectievelijk een vector- en een rasterlaag toevoegen. De namen van de bestanden die toegevoegd zullen worden evenals de namen die gegeven wordt aan de lagen, zijn afkomstig uit een geladen vectorbestand, waarop de actie gedefinieerd is, waarbij filename en layname veldnamen zijn die gebruikt worden door de actie.

qgis.utils.iface.addVectorLayer('/yourpath/[% "filename" %].shp','[% "layername" %]',\
  'ogr')

Om een raster bestand toe te voegen (in dit voorbeeld een tif bestand), wordt dit:

qgis.utils.iface.addRasterLayer('/yourpath/[% "filename" %].tif','[% "layername" %]')

Het tabblad Koppelingen

join The Joins menu allows you to join a loaded attribute table to a loaded vector layer. After clicking mActionSignPlus the Add vector join dialog appears. As key columns you have to define a join layer you want to connect with the target vector layer , a join field that corresponds to an attribute column in the target layer and a target field you find in the attribute table of the target vector layer here. As a result, all information of the join layer and the target layer are displayed in the attribute table of the target layer as joined information.

QGIS currently supports to join non spatial table formats supported by OGR (e.g. CSV, DBF and Excel), delimited text and the PostgreSQL provider (see figure_joins_1).

Figure Joins 1:

../../../_images/join_attributes.png

Join an attribute table to an existing vector layer nix

Daarnaast geeft de dialoog Vectorkoppeling toevoegen de mogelijkheid om:

  • checkbox Koppellaag in virtueel geheugen ‘cachen’

  • checkbox Attribuutindex aanmaken op het koppelveld

Het tabblad Diagrammen

diagram Met het tabblad Diagrammen kun je diagrammen in je vectorlaag plaatsen (zie figure_diagrams_1).

The current core implementation of diagrams provides support for piecharts, text diagrams and histograms.

The menu is divided into four tabs now: Appearance, Size, Postion and Options.

Bij de implementatie van diagrammen ondersteunt taartpunt- en tekstdiagrammen. Daarbij kan de tekst van verschillende veldwaarden onder elkaar getoond worden met een circel of een vierkant en verdelers. De groote van Diagrammen kan overal gelijk zijn of rechtevenredig verschaald worden naar een veldwaarde. Het plaatsen van diagrammen werkt samen met de nieuwe manier van labels plaatsen, dat wil zeggen wanneer er tijdens het renderen (tekenen) een diagram en een label op dezelfde plaats zouden komen te staan, dan kan dat automatisch worden opgelost. Daarnaast kunnen geplaatste diagram later, door de gebruiker, handmatig verplaatst worden.

Figure Diagrams 1:

../../../_images/diagram_tab.png

Vector properties dialog with diagram menu nix

We zullen een voorbeeld geven waarbij we in de alaska boundary laag een aantal diagrammen met temperatuurgegevens plaatsen. Beide te gebruiken vectorlagen zijn onderdeel van de QGIS sample dataset (zie Voorbeeld Data).

  1. Klik eerst het icoon mActionAddOgrLayer Vectorlaag Toevoegen, ga naar de folder waarin zich de QGIS sample dataset bevindt en laad de twee shapefiles alaska.shp en climate.shp.

  2. Dubbelklik op de laag climate in de kaartlegenda waarna het menu Laag Eigenschappen opent.

  3. Selecteer het tabblad Diagrammen, activeer Toon diagrammen en selecteer Tekstdiagram als Diagram type

  4. In the Appearance tab we choose a light blue as Background color and in the Size tab we set a fixed size to 18 mm.
  5. Men kan voor Plaatsing RondomPunt kiezen.

  6. In het diagram willen we de waarden van de eerste drie kolommen tonen. T_F_JAN, T_F_JUL en T_F_MEAN. Selecteer eerst T_F_JAN als Attribuut en klik op de groene knop mActionSignPlus, daarna T_F_JUL en tenslotte T_F_MEAN.

  7. Druk nu op de knop [Apply] om de diagrammen te tonen in het kaartbeeld van QGIS.

  8. You can now adapt the chart size in the Size tab. Deactivate the checkbox Fixed size and set the size of the diagrams on the basis of an Attribute with the [Find maximum value] button and the Size menu. If diagrams appear too small on the screen you can activate the checkbox Increase size of small diagrams checkbox and define the Minimum size of the diagrams.
  9. Wijzig het gebruik van andere kleuren voor de verschillende attribuutvelden met het veld Toegekende attributen. Figure_diagrams_2 geeft een indruk van het resultaat.

  10. Selecteer tenslotte [Ok].

Figure Diagrams 2:

../../../_images/climate_diagram.png

Diagram from temperature data overlayed on a map nix

Remember that in the Position tab a checkbox Data defined position of the diagrams is possible. Here you can use attributes to define the position of the diagram. Also, a scale dependent visibility that you can find in the Appearance tab is possible.

Tabblad Metadata

metadata Het tabblad Metadata bevat de onderdelen Beschrijving, Attributen, MetadataURL en Eingenschappen.

Het onderdeel Eigenschappen kun je algemene informatie over de laag. Opslagtype, bron, type geometrie het aantal objecten. Onder het kopje Extents kun je informatie vinden over het kaartbereik oftewel de grenzen van de kaart en onder het kopje Ruimtelijk Referentie Systeem vind je informatie over welk coördinaten systeem is gebruikt voor deze laag. Dit is een snelle manier om informatie te vinden over een laag.

Additionally you can add/edit a title for the layer and some abstract information in the Description. Also, it’s possible to define a Keyword list here. These keyword lists can be used in a metadata catalogue. If you want to use a title from an XML metadata file you have to fill in a link in the DataUrl field. Use Attribution to get Atrribute data from an XML metadata catalogue. In MetadataUrl you can define the general path to the XML metadata catalogue. These information will be saved in the QGIS project file for following sessions and will be used for QGIS server.

Figure Metadata 1:

../../../_images/vector_metadata_tab.png

Metadata menu in vector layers properties dialog nix