Outdated version of the documentation. Find the latest one here.

QGIS Configureren

QGIS is zeer goed te configuren via het menu Extra. Kies tussen Panelen, Werkbalken, Project instellingen, Opties en Aanpassingen.

Panelen en Werkbalken

Via het menu Panelen‣ kun je QGIS panelen aan of uitzetten. Via het menu Werkbalken‣ kun je werkbalken toevoegen of verwijderen in de ruimte gereserveerd voor werkbalken in QGIS.

Figure Panels and Toolbars:

../../../_images/panels_and_toolbars.png

Het menu Panelen en Werkbalken nix

Tip

Het activeren van Kaartoverzicht in QGIS

In QGIS you can use an overview panel that provides a full extent view of layers added to it. It can be selected under the menu View ‣ Panels. Within the view is a rectangle showing the current map extent. This allows you to quickly determine which area of the map you are currently viewing. Note that labels are not rendered to the map overview even if the layers in the map overview have been set up for labeling. If you click and drag the red rectangle in the overview that shows your current extent, the main map view will update accordingly.

Tip

Toon Logboekmeldingen

Het is mogelijk om gegenereerde logboekmeldingen van QGIS te bekijken. Deze kan geactiveerd worden door het aanvinkvakje checkboxLogboekmeldingen in het menu Extra ‣ Panelen aan te vinken. De meldingen die worden gegeneerd tijdens het opstarten en gebruik van QGIS kunnen bekeken worden onder de tabbladen Algemeen en Plugins.

Projectinstellingen

In the properties window for the project under nix Project ‣ Project Properties or win Project ‣ Project Properties you set project specific options. These include:

  • Onder het tabblad Algemeen kan men het volgende instellen; de projecttitel, de selectie- en achtergrondkleur, de laageenheden, de precisie (aantal decimalen van coördinaten) en of paden relatief of absoluut moeten worden opgeslagen. De te gebruiken eenheden kan alleen worden ingesteld wanneer gelijktijdige CRS transformatie is uitgeschakeld (onder tabblad Ruimtelijk Referentie Systeem). Je kun er ook een lijst van kaartschalen voor het project instellen die de globale ingestelde lijst van kaartschalen overschrijft.

  • In het tabblad Ruimtelijke Referentie Systeem (CRS) kun je de gewenste CRS voor dit project instellen. Daarnaast kun je instellen dat gelijktijdige CRS transformatie moet worden gebruikt wanneer er lagen aanwezig zijn met verschillende CRS.

  • In het derde tabblad Identificeerbare Lagen kun je instellen welke lagen zullen reageren wanneer Objecten Indentificeren wordt gebruikt. (zie de paragraaf Kaartgereedschap van :ref`gui_options` waarin het gebruik hiervan wordt uitgelegd.)

  • Via het menu Standaard stijlen kan men standaard stijlen instellen die worden toegekend aan nieuwe toegevoegde kaartlagen die geen .qml stijlen bestand hebben. Men kan ook de standaard transparantie die moet worden toegekend aan nieuwe lagen instellen en of symbolen Willekleurige kleuren toegekend moeten krijgen.

  • Het tabblad OWS Server geeft de mogelijkheid om informatie in te vullen die meegegeven wordt door de WMS en WFS Capabilities die door QGIS Server terug wordt gegeven plus de extent, het maximale bereik van de kaart en het beperken van mogelijke Coördinaten Referentie Systemen.

  • Het menu Macro’s kan worden gebruikt om python functies te schrijven die als module mee worden opgeslagen in het QGIS projectbestand die worden gestart op de volgende momenten: openProject(), saveProject() en closeProject().

Figure Macro Menu:

../../../_images/macro.png

Macro instellingen in QGIS

Opties

mActionOptions Voor het instellen van globale instellingen van QGIS gebruik de dialoog Opties. Open deze via het menu Extra ‣ mActionOptions Opties. De volgende tabbladen zijn beschikbaar:

Tabblad Algemeen

Applicatie

  • Maak onder Stijl (QGIS herstart nodig) selectstring en kies tussen:

  • Geef het Icoon Thema selectstring. Momenteel is alleen ‘standaard’ beschikbaar.

  • Geef de Icoongrootte selectstring.

  • Geef het Lettertype. Kies tussen het keuzerondje radiobuttonon Qt standaard of maak een keuze uit een systeem lettertype.

  • Wijzig de Zichtbaarheidstijd voor berichten of dialogen selectstring.

  • checkbox Verberg het openingsscherm tijdens opstarten

  • checkbox Tips tonen tijdens het opstarten

  • checkbox Groepsvak titels vet weergeven

  • checkbox Groepsvakken in QGIS stijl

  • checkbox Gebruik direkt bijwerken kleurkeuze dialoog

Projectbestanden

  • Open project bij het opstarten selectstring (kies tussen ‘Nieuw’. ‘Meest recente’ en ‘Specifiek’. Wanneer men kiest voor ‘Specifiek’ gebruik de browsebutton om het project aan te geven waarmee opgestart moet worden)

  • checkbox Maak een nieuw project op basis van het standaardproject. Men heeft de mogelijkheid om het huidige project in te stellen als standaard project met de knop [Huidige project als standaardproject opslaan] of terug te gaan naar het standaardproject met de knop [Standaard terugzetten]. Men kan een folder (Sjabloonmap) instellen waar de project templates komen te staan met de knop [Bladeren]. Er zal een template project gekozen kunnen worden bij de menu optie Project ‣ Nieuw van Template, wanneer eerst het aanvinkvak checkbox Maak een nieuw project op basis van het standaardproject is geactiveerd en vervolgens het project in de folder met templates is opgeslagen.

  • checkbox Geef een waarschuwing om project en gewijzigde databronnen op te slaan indien nodig

  • checkbox Geef een waarschuwing bij het openen van een projectfile uit een oudere versie van |qg|

  • De optie macro’s toestaan selectstring is toegevoegd om meer controle te krijgen over het uivoeren van macro’s, bijvoorbeeld de macro’s voor het uitvoeren van een actie.

Je kunt daarbij kiezen tussen ‘Nooit’, ‘Vragen’, ‘Alleen voor deze sessie’ en ‘Altijd (wordt afgeraden)’.

Systeem Menu

Systeem

De Systeem omgevingsvariabelen kunnen nu worden bekeken en deze kunnen ook worden geconfigureerd via het onderdeel systeemvariabelen (zie figuur figure_environment_variables). Dit is erg handig voor besturingssystemen zoals die op de Mac waarbij voor een grafische applicatie de omgevingsvariabelen zoals men die kan opvragen via de terminal niet dezelfde hoeven te zijn als die door het programma worden gebruikt. Deze kan ook handig zijn om omgevingsvariabelen te zetten die gebruikt worden door externe tools die o.a. gebruikt worden door de processing toolbox, bijv. SAGA, GRASS; en die ook gebruikt kan worden zodat zodat bepaalde onderdelen van de broncode meer output genereren voor het opsporen van fouten (debugging).

  • checkbox Gebruik aangepaste systeemvariabelen (herstart noodzakelijk - voeg scheidingstekens toe). Je kunt nieuwe systeemvariabelen Toevoegen en met Verwijder weer verwijderen. Huidige systeemvariabelen ‣ worden daaronder getoond. Het is mogelijk om alleen de specifieke systeemvariabelen voor QGIS te tonen met het aanvinkvak checkbox Alleen QGIS-specifieke variabelen tonen.

Figure System Environment:

../../../_images/sys-env-options.png

Systeem omgevingsvariabelen in QGIS

Plugin paden

  • Toevoegen of Verwijderen Pad(en) om voor additionele C++ pluginbibliotheken te zoeken

Databronnen Menu

Object-attributen en tabel

  • checkbox Open de attributentabel in een ‘dock-window’ (QGIS herstart vereist)

  • checkbox Kopiëer geometrie in WKT formaat van attributen tabel. Wanneer de functie mActionCopySelectedKopiëer geselecteerde rijen naar klembord in het Attributentabel menu dan zullen ook de coördinaten van de punten en hoekpunten worden gekopieerd naar het klembord.

  • Attributentabel gedrag selectstring. Er zijn drie mogelijkheden: ‘Alle attributen tonen’ (standaard), ‘Geselecteerde objecten tonen’ en ‘Toon objecten in huidig kaartbeeld’

  • Attributentabel rijcache selectstring. Deze instelling zorgt ervoor dat het gegeven aantal rijen in de cache (=geheugenruimte) wordt opgeslagen, zodat deze gegevens sneller beschikbaar zijn en het werken met de attributentabel ook sneller is. De gegevens in de cache worden verwijderen tijdens het sluiten van de dialoog attributentabel.

  • Weergave van NULL waarden Hier kunt een een andere waarde geven om te laten zien, voor velden die een NULL waarde bevatten.

Omgang met databron

  • Zoek naar geldige items in het browser dock selectstring. Je kunt kiezen tussen ‘Extentie controleren’ en ‘Bestandsinhoud controleren’.

  • Zoek naar de inhoud van gecomprimeerde (zip) bestanden in het browser-dock selectstring ‘Nee’, ‘Basic scan’ en ‘Volledige scan’ zijn mogelijk.

  • Suggereer raster sublagen tijdens het openen. Enkele rasterformaten ondersteunen sublagen - deze worden subdatasets in GDAL genoemd. Een voorbeeld is het netcdf bestandsformaat - wanneer er veel netcdf variabelen zijn, dan ziet GDAL elke variabele als een subdataset. De optie wordt gebruikt om controle te krijgen hoe om te gaan, tijdens het laden van, een rasterfile die sublagen bevat. De volgende keuzes zijn mogelijk:

    • ‘Altijd’: altijd vragen (wanneer er sublagen aanwezig zijn)

    • ‘indien nodig’: vraag wanneer de laag geen bandlagen maar wel sublagen heeft

    • ‘Nooit’: geen vragen, laad geen sublagen

    • ‘Laad alles’: geen vragen gewoon alle sublagen laden

  • checkbox Vastgelegde shapefile codering negeren. Wanneer een shapefile informatie over gebruikte karaktercodering bevat, kan men hier aangeven of |qg|die informatie moet negeren.

  • checkbox PostGIS lagen toevoegen door dubbelklikken en selectie in uitgebreide modus

  • checkbox PostGIS lagen toevoegen door dubbelklikken en selectie in uitgebreide modus

Tabblad Rendering

Rendering kwaliteit

  • checkbox Maak de lijnen minder rafelig ten koste van de tijd dat het tekenen kost

  • checkbox Problemen met fout (gevulde) polygonen oplossen

Rasters

  • met RGB-band selectie kan men het nummer voor de Rode, de Groene en de Blauwe band opgeven.

Contrastverhoging

  • Enkelbands grijs selectstring. Een enkelbands grijs kan de waarden hebben ‘Geen Stretch’ ‘Stretch tot MinMax’, ‘Stretch en Clip tot MinMax’ en ‘Clip naar MinMax’

  • Multiband kleur (byte/band) selectstring. ‘Geen Stretch’, ‘Stretch tot MinMax’, ‘Stretch en Clip tot MinMax’ and ‘Clip naar MinMax’.

  • Multiband kleur (>byte/band) selectstring. ‘Geen stretch’, ‘Stretch tot MinMax’, ‘Stretch en Clip tot MinMax’ en ‘Clip naar MinMax’.

  • Bereik (minimum/maximum) selectstring. ‘Cumulatieve telling deel van pixels’, ‘Minimum/Maximum’, ‘Gemiddelde +/- standaardafwijking’

  • Bereik Cumulatieve telling van pixels

  • Vermenigvuldigingsfactor voor standaardafwijking

Debuggen

  • Toon deze acties in het log-berichtenpanel (onder Renderen tab): checkbox Kaartvenster-update

Kaartvenster en Legenda Menu

Standaard waarden kaart (worden door projectwaarden overschreven)

  • Wijzig de Selectiekleur en de Achtergrondkleur.

Legenda lagen

  • Dubbelklik actie in legenda selectstring. Kies tussen ‘Open laag eigenschappen’ of ‘Open attributentabel’ voor de dubbelklik actie.

  • de volgende Legende onderdeel stijlen zijn mogelijk

    • checkbox Laagnamen in hoofdletters

    • checkbox Laagnamen vet

    • checkbox Groepnamen vet

    • checkbox Toon classificatie-attribuutnamen

    • checkbox Raster iconen aanmaken (kan langzaam zijn)

    • checkbox Voeg nieuwe lagen toe aan geselecteerde of huidige groep

Tabblad Kaart gereedschap

Identificeren

  • checkbox Identificeer-resultaten naar een ‘dock-window’ (QGIS herstart vereist)

  • De Modus instelling bepaald mede voor welke lagen ‘Objecten Identificeren’ werkt. Wanneer gekozen wordt voor ‘Van bovenaf’ of ‘Van bovenaf, stop bij eerste’ in plaats van ‘Huidige laag’ zal deze voor meerdere lagen werken (zie ook het onderdeel Projecten in de Project instellingen om in te stellen welke lagen door ‘Objecten Identificeren’ getoond zullen worden bij selectie.

  • checkbox Open object formulier, als er slechts 1 object wordt geprikt

  • Bepaal de Zoekradius voor de indentificatie van objecten en het vertonen van kaarttips als een percentage van de kaart breedte

Meetgereedschap

  • Geef de Rubberband kleur voor het meetgereedschap

  • Zet het aantal te gebruiken Decimale posities

  • checkbox Basis eenheid bewaren

  • Voorkeurs meeteenheden radiobuttonon (‘meters’ of ‘voet’)`

  • Voorkeur hoekeenheden radiobuttonon (‘Graden’, ‘Radialen’ of ‘Gon’)`

Schuiven en zoomen

  • Zet het Muiswielgedrag op selectstring (‘Zoom’, ‘Zoom en recenter’, ‘Zoom naar muis cursor’, ‘Niets’)

  • Stel de Zoom factor in voor het muiswiel

Vooraf ingestelde schalen

Hier tref je de lijst aan met Vooraf ingestelde schalen. Met de ‘+’ en ‘-‘ knop kun je schalen toevoegen en verwijderen.

Tabblad Digitaliseren

Objectcreatie

  • checkbox Geen attribuut-popus na het aanmaken van elk kaartobject tonen

  • checkbox Laatst ingevoerde attribuutwaarden gebruiken

  • Valideer geometriën tijdens het bewerken van complexe lijnen/polygonen bestaande uit veel punten kan dat dit het tekenen vertraagd. Dit komt omdat de standaard validatie ‘QGIS’ veel tijd kan kosten. Om het tekenen te versnellen tijdens het editen kan gekozen worden voor de optie ‘GEOS’ of om de validatie uit te zetten. De validatie met GEOS is veel sneller maar het nadeel is dat deze alleen het eerste geometrie probleem rapporteert.

Rubberband

  • Wijzig de Lijndikte en Lijnkleur van de Rubberband

Snapping

  • checkbox Snapping instellingen openen in een ‘dock-window’ (QGIS herstart vereist)

  • Zet de Standaard ‘snap’-modus selectstring (‘Naar hoekpunt’, Naar segment’, ‘Naar hoekpunt en segment’, ‘Uit’)

  • Zet de Standaard ‘snapping’-tolerantie in kaarteenheden of pixels

  • Zet de zoekradius voor hoekpuntaanpassingen in ‘kaart eenheden’ of ‘pixels’

Hoekpunten

  • checkbox Markers alleen gebruiken voor geselecteerde objecten heeft betrekking op het tonen ervan

  • Wijzig de Markerstijl naar selectstring (‘Kruis’ (standaard), ‘Semi transparente cirkel’ of ‘Niets’)

  • Zet de Markergrootte

Lijnverspring-gereedschap

De volgende 3 opties hebben betrekking op de tool mActionOffsetCurve Verspring Curve, zie Geavanceerd Digitaliseren, waarmee je de vorm van de versprongen lijn kan beïnvloeden.

  • Verbindingsstijl voor de curve offset

  • Kwadrantsegmenten voor curve offset

  • Hoeklimiet voor curve offset

GDAL Menu

GDAL is een functiebibliotheek voor het kunnen inlezen converteren van veel rasterformaten. In dit tabblad kun je Creatie Opties bewerken en Pyramide Opties bewerken voor de raster formaten. Je kunt hier ook instellen welke GDAL functiebibliotheek gebruikt moet worden in het geval er meerdere versies aanwezig zijn.

CRS Menu

Standaard CRS voor nieuwe projecten

  • checkbox Gelijktijdige CRS-transformatie gebruiken wanneer lagen verschillende CRS hebben

  • checkbox Gelijktijdige CRS-transformatie gebruiken

  • Selecteer een CRS voor Altijd dit CRS gebruiken voor nieuwe projecten

CRS voor nieuwe kaartlagen

Het tweede deel geeft de mogelijkheid of er een actie volgt nadat, een nieuwe laag is aangemaakt, of wanneer een laag zonder CRS wordt geladen.

  • radiobuttonoff Vraag om CRS

  • radiobuttonoff Gebruik huidige project CRS

  • radiobuttonoff Gebruik het standaard CRS zoals hieronder getoond

Tabblad Locale

  • checkbox Systeem locale negeren en Te gebruiken locale

  • Informatie over gedetecteerde systeem locale

Tabblad Netwerk

Algemeen

  • Geef een WMS zoekadres, het standaard adres is http://geopole.org/wms/search?search=\%1\&type=rss

  • Geef de Timeout for netwerkaanvraagen (ms) - standaard ingesteld op 60000

  • Define Standaard verlooptijd van WMSC/WMTS tegels (uur) - standaard is 24

Figure Network Tab:

../../../_images/proxy-settings.png

Proxy-instellingen in QGIS

Cache instellingen

Wijzig de Folder en Grootte voor de cache.

  • checkbox Gebruik een proxy voor internettoegang en geef de ‘Host’, ‘Poort’, ‘Gebruiker’ en ‘Wachtwoord’.

  • Geef het Proxy type selectstring naar behoefte.

    • Default Proxy: Proxy wordt bepaald gebasseerd op de huidige applicatie proxy set

    • Socks5Proxy: Een generieke proxy die voor meerdere connectie protocollen. Ondersteund TCP, UDP, directe verbinding op poort (binnenkomende connecties) en autenticatie.

    • HttpProxy: Gebruikt de “CONNECT” opdracht, ondersteund alleen uitgaande TCP connecties; ondersteund autenticatie.

    • HttpCachingProxy: Gebruikt normale HTTP opdrachten, deze is alleen goed bruikbaar bij het gebruik van HTTP requests

    • FtpCachingProxy: Gebruikt een FTP proxy, die alleen goed bruikbaar is in de context van FTP requests

Men kan URL’s uitsluiten door deze toe te voegen aan het tekstinvoervak onder de proxy-instellingen (zie Figure_Network_Tab).

Wanneer je meer gedetailleerde informatie nodig hebt over de verschillende proxy settings, verwijzen we naar de handleiding QT functie bibliotheek documentatie zie http://doc.trolltech.com/4.5/qnetworkproxy.html#ProxyType-enum.

Tip

Het gebruik van Proxies

Het gebruiken van proxies kan soms erg lastig zijn. Gebruik de ‘trial and error’ methode om de verschillende proxy typen te testen en controleer of deze voor jou werken.

Je kunt de opties wijzigen naar behoefte. Enkele aanpassingen hebben echter een herstart van QGIS nodig voordat deze effectief worden.

  • nix instellingen worden opgeslagen in het tekstbestand: file: $HOME/.config/QGIS/qgis.conf

  • osx de instellingen worden opgeslagen in: $HOME/Library/Preferences/org.qgis.qgis.plist

  • win instellingen worden opgeslagen in de windows registry onder: HKEY\CURRENT_USER\Software\QGIS\qgis

Aanpassingen

Met de tool Aanpassingen kun je bijna elke element aan-/uitzetten in de QGIS gebruikersinterface. Dit kan erg handig zijn wanneer veel plugins geinstalleerd zijn die je nooit gebruikt en die veel schermruimte innemen.

Figure Customization 1:

../../../_images/customization.png

Het Aanpassingen dialoog nix

QGIS Aanpassingen is onderverdeeld in vijf groepen. Onder checkbox Menus kun je menu onderdelen verbergen. Onder checkbox Panelen vind je de ‘panelen’. Panelen zijn applicaties die gestart kunnen worden als een losstaand window maar die ook kunnen worden ingebed in het window van de QGIS applicatie zelf.(zie ook Panelen en Werkbalken). Onder checkbox Status Bar kun je onderdelen zoals de coördinaten informatie uitzetten. Onder checkbox Toolbars kun je iconen van de QGIS werkbalken (de)activeren en onder checkbox Hulpmiddelen kun je ook knoppen en bijbehorende dialogen verbergen.

Met mActionSelect Schakel naar widgets in de hoofdapplicatie kun je klikken op elementen in QGIS die je wilt verbergen waarna deze ook direct springt naar de bijbehorende entry in het Aanpassingen dialoog (zie figure_customization). Je kunt ook verschillende sets van instellingen voor verschillende soorten gebruikers opslaan. Om de wijzigen toe te passen is een herstart van QGIS nodig.