Outdated version of the documentation. Find the latest one here.

Editierfunktionen

QGIS supports various capabilities for editing OGR, SpatiaLite, PostGIS, MSSQL Spatial and Oracle Spatial vector layers and tables.

Bemerkung

Die Vorgehensweise zum Editieren von GRASS Layern ist anders - siehe Abschnitt Digitalisieren und Editieren eines GRASS Vektorlayers für Details.

Tipp

Zeitgleiches Editieren

Diese Version von QGIS kontrolliert nicht, ob noch jemand ein Objekt zur gleichen Zeit editiert wie Sie. Die zuletzt schreibende Person gewinnt.

Einstellen der Fangtoleranz und des Suchradius

Bevor wir damit beginnen können Stützpunkte zu editieren ist es sehr wichtig die Fangtoleranz und den Suchradius für Stützpunkte festzulegen um Vektorlayergeometrien optimal editieren zu können.

Fangtoleranz

Die Fangtoleranz ist der Abstand den QGIS verwendet um den nächstgelegenen Stützpunkt bzw. das nächstgelegene Liniensegment zu suchen mit dem sie versuchen sich zu verbinden wenn sie einen neuen Stützpunkt setzen wollen oder einen bestehenden Stützpunkt verschieben wollen. Wenn Sie sich nicht innerhalb der definierten Fangtoleranz befinden wird QGIS den Stützpunkt dort lassen wo sich der Mauszeiger gerade befindet anstatt zu einem bestehenden Stützpunkt oder Liniensegment zu snappen. Die Fangtoleranz Einstellungen betreffen alle Werkzeuge die mit Toleranz arbeiten.

  1. A general, project wide snapping tolerance can be defined choosing Settings ‣ mActionOptions Options. On Mac: go to QIS ‣ mActionOptions Preferences..., on Linux: Edit ‣ mActionOptions Options. In the Digitizing tab you can select between to vertex, to segment or to vertex and segment as default snap mode. You can also define a default snapping tolerance and a search radius for vertex edits. The tolerance can be set either in map units or in pixels. The advantage of choosing pixels, is that the snapping tolerance doesn’t have to be changed after zoom operations. In our small digitizing project (working with the Alaska dataset), we define the snapping units in feet. Your results may vary, but something on the order of 300ft should be fine at a scale of 1:10 000 should be a reasonable setting.
  2. Eine layerbezogene Fangtoleranz kann unter Einstellungen ‣ (oder Datei ‣) Fangoptionen ... um den Fangmodus und die Fangtoleranz auf Layerbasis zu ermöglichen und anzupasssen definiert werden (siehe figure_edit_1 ).

Beachten Sie dass dieses layerbezogene Snapping die globale Snapoption aus dem Reiter Digitalisierung überschreibt. Wenn Sie also einen Layer bearbeiten und seine Stützpunkte zu einem anderen Layer snappen wollen dann stellen Sie das Snappen nur für den zu snappenden Layer ein und verringern die allgemeine Fangtoleranz auf einen kleineren Wert. Darüberhinaus funktioniert das Snappen nicht mit Layern die nicht im Fangoptionen Dialog aktiviert sind, egal wie die allgemeine Fangtoleranz aussieht. Vergewissern Sie sich also dass die Checkbox der Layer auf die Sie snappen müssen markiert ist.

Figure Edit 1:

../../../_images/editProjectSnapping.png

Edit snapping options on a layer basis nix

Suchradius

Der Suchradius ist die Distanz die QGIS benutzt, um den nächstgelegenen Stützpunkt, der verschoben werden soll, zu finden. Wenn Sie sich nicht innerhalb des Suchradius befinden wird QGIS keinen Stützpunkt zum Editieren finden und auswählen und es wird dazu eine störende Warnung erscheinen. Die Fangtoleranz und der Suchradius werden in Karteneinheiten oder Pixeln festgelegt Sie müssen also etwas experimentieren um sie richtig einzustellen. Wenn Sie eine zu große Toleranz festlegen, könnte QGIS zum falschen Stützpunkt snappen, besonders wenn es eine große Anzahl von Stützpunkten in geringer Entfernung gibt. Legen Sie den Suchradius zu klein fest wird es nichts zum verschieben finden.

Der Suchradius für die Stützpunktbearbeitung in Layereinheiten kann im Reiter Digitalisierung unter Einstellungen ‣ mActionOptions Optionen definiert werden. An der gleichen Stellen wo Sie die allgemeine, projektweite Fangtoleranz definieren.

Zoomen und Karte verschieben

Bevor Sie einen Layer editieren sollten Sie in den Bereich hineinzoomen, den Sie bearbeiten wollen. Dadurch vermeiden Sie lange Wartezeiten, bis alle Stützpunkte des Layers visualisiert werden.

Neben den mActionPan Karte verschieben und mActionZoomIn Hineinzoomen / mActionZoomOut Hinauszoomen Icons in der Werkzeugleiste können Sie auch mit dem Mausrad, der Leertaste und den Pfeiltasten navigieren.

Mit dem Mausrad im Kartenfenster zoomen und verschieben

Während des Digitalisierens können Sie das Mausrad zum verschieben innerhalb des Hauptfenster drücken und Sie können das Mausrad zum hinein- und hinauszoomen drehen. Zum Zoomen platzieren Sie den Mauscursor in die Karte und rollen es vorwärts (von Ihnen weg) um hineinzuzoomen und rückwärts (zu Ihnen hin) um herauszuzoomen. Die Position des Mauscursors wird das Zentrum des Sie interessierenden Bereichs sein. Sie können das Verhalten des Mausrad-Zooms anhand des Reiters Kartenwerkzeuge unter Einstellungen ‣ mActionOptions Optionen anpassen.

Den Layer mit den Pfeiltasten verschieben

Das Verschieben des Layers im Kartenfenster während des Digitalisierens ist mit den Pfeiltasten möglich. Platzieren Sie den Mauszeiger in das Kartenfenster und drücken Sie rechte Pfeiltaste, um den Layer nach Osten zu verschieben, die linke Pfeiltaste für Westen, die Pfeiltaste nach unten für Süden und die Pfeiltaste nach oben für das Verschieben nach Norden.

Sie können auch die gedrückte Leertaste dazu verwenden, um den Layer im Kartenfenster zu verschieben. Die PgUp und PgDown Tasten auf Ihrem Keyboard bewirken dann das hineinzoomen und herauszoomen Ihres Kartenfensters ohne das Digitalisieren zu unterbrechen.

Topologisches Editieren

Abgesehen von der Einstellung des layerbasierten Fangmodus können im Menü Einstellungen ‣ Fangoptionen... auch topologische Funktionen aktiviert werden. Hier können sie checkbox Topologisches Editieren an definieren und/oder für Polygonlayer können Sie die Spalte checkbox Überschn.verm. aktivieren die eine Überschneidung neuer Polygone vermeided.

Topologisches Editieren ermöglichen

The option checkbox Enable topological editing is for editing and maintaining common boundaries in polygon mosaics. QGIS ‘detects’ a shared boundary in a polygon mosaic and you only have to move the vertex once and QGIS will take care about updating the other boundary.

Überschneidung neuer Polygone vermeiden

The second topological option in the checkbox Avoid Int. column, called Avoid intersections of new polygons avoids overlaps in polygon mosaics. It is for quicker digitizing of adjacent polygons. If you already have one polygon, it is possible with this option to digitize the second one such that both intersect and QGIS then cuts the second polygon to the common boundary. The advantage is that users don’t have to digitize all vertices of the common boundary.

Enable snapping on intersections

Another option is to use checkbox Enable snapping on intersection. It allows to snap on an intersection of background layers, even if there’s no vertex on the intersection.

Einen vorhandenen Layer editieren

By default, QGIS loads layers read-only: This is a safeguard to avoid accidentally editing a layer if there is a slip of the mouse. However, you can choose to edit any layer as long as the data provider supports it, and the underlying data source is writable (i.e. its files are not read-only).

Das Editieren von Vektorlayern in QGIS ist unterteilt in Digitalisierung und erweiterte Digitalisierung, siehe Abschnitt Erweiterte Digitalisierung. Beide Werkzeugleisten können über das Menü Einstellungen ‣ Werkzeugkästen ‣ aktiviert und deaktiviert werden. Mit der Werkzeugleiste Digitalisierung können folgende Funktionen ausgeführt werden:

Icon

Funktion

Icon

Funktion

mActionAllEdits Current edits mActionToggleEditing

Bearbeitungsstatus umschalten

mActionCapturePoint

Objekt hinzufügen: Punkt hinzufügen

mActionCaptureLine

Objekt hinzufügen: Linie hinzufügen

mActionCapturePolygon

Objekt hinzufügen: Polygon hinzufügen

mActionMoveFeature

Objekt(e) verschieben

mActionNodeTool

Knotenwerkzeug

mActionDeleteSelected

Ausgewähltes Löschen

mActionEditCut

Ausgewählte Objekte ausschneiden

mActionEditCopy

Objekte kopieren

mActionEditPaste

Objekte einfügen

mActionSaveEdits Save layer edits

Tabelle Bearbeiten: Funktionen der Werkzeugleiste Digitalisierung

Alle Bearbeitungssessions beginnen mit dem Aktivieren der Funktion mActionToggleEditing Bearbeitungsstatus umschalten. Diese kann auch im Kontextmenü nach dem Rechtsklick auf den Legendeneintrag für den Layer aktiviert werden.

Alternativ können Sie dazu auch mit der rechten Maustaste auf den Namen des Layers in der Legende klicken und die Option im Kontextmenü auswählen. Sobald der Layer im Bearbeitungsstatus ist, erscheinen die Stützpunkte als das von Ihnen gewählte Stützpunktsymbol und zusätzlich werden die Digitalisier-Tools in der Werkzeugleiste aktiv.

Tipp

Regelmäßiges Sichern der Daten

Remember to mActionSaveEdits Save Layer Edits regularly. This will also check that your data source can accept all the changes.

Objekte digitalisieren

Danach können Sie mit den Icons mActionCapturePoint Objekt hinzufügen, mActionCaptureLine Objekt hinzufügen oder mActionCapturePolygon Objekt hinzufügen in der Werkzeugleiste den Mauszeiger in den Digitalisiermodus bringen.

Für jedes Objekt wird erst die Geometrie digitalisiert und dann das Attribut hinzugefügt. Um eine Geometrie zu digitalisieren, klicken Sie mit der linken Maustaste an eine gewünschte Stelle im Kartenfenster, um den ersten Punkt zu erstellen.

Für Linien und Polygone klicken Sie für jeden weiteren Knotenpunkt wieder die linke Maustaste. Zum Beenden klicken Sie irgendwo im Kartenfenster auf die rechte Maustaste, um anzuzeigen, dass die Geometrie ihres Objektes fertig gestellt ist.

The attribute window will appear, allowing you to enter the information for the new feature. Figure_edit_2 shows setting attributes for a fictitious new river in Alaska. In the Digitizing menu under the Settings ‣ Options menu, you can also activate checkbox Suppress attributes pop-up windows after each created feature checkbox Reuse last entered attribute values.

Figure Edit 2:

../../../_images/editDigitizing.png

Enter Attribute Values Dialog after digitizing a new vector feature nix

Mit dem mActionMoveFeature Objekt(e) verschieben Icon in der Werkzeugleiste können sie komplette Objekte verschieben.

Tipp

Datentyp der Attribute

QGIS kontrolliert beim Editieren, ob die eingetragenen Werte dem Datentyp der Attributspalte entspricht (z.B.: Zahl oder Text). Ansonsten ist es nicht möglich, im Dialog Attribute eine Zahl in eine Textspalte einzutragen, oder umgekehrt. Falls es dennoch notwendig sein sollte, können Sie es nachträglich im Fenster der Attributtabelle ändern.

Current Edits

This new feature allows the digitization of multiple layers. Choose mActionFileSaveAs Save for Selected Layers to save all changes you made in multiple layers. You also have the opportunity to mActionRollbackEdits Rollback for Selected Layers so that the digitization is then withdrawn for all selected layers. If you want to stop editing the selected layers the mActionCancelEdits Cancel for Selected Layer(s) is an easy way.

The same functions for editing all layers of the project are available.

Knotenwerkzeug

For shapefile-based layers as well as SpatialLite,PostgreSQL/PostGIS, MSSQL Spatial and Oracle Spatial tables the mActionNodeTool Node Tool provides manipulation capabilites of feature vertices similar to CAD programs. It is possible to simply select multiple vertices at once and to move, add or delete them alltogether. The node tool also works with ‘on the fly’ projection turned on and supports the topological editing feature. This tool is, unlike other tools in QGIS, persistent, so when some operation is done, selection stays active for this feature and tool. If the node tool couldn’t find any features, a warning will be displayed.

Sie sollten den Suchradius beim Digitalisieren über die Menüleiste unter Einstellungen ‣ mActionOptions Optionen ‣ Digitalisierung größer 0 einstellen. Ansonsten ist QGIS nicht in der Lage, ein Objekt auszuwählen.

Tipp

Stützpunktmarken

Die aktuelle Version von QGIS unterstützt drei Arten von Stützpunktmarken: Teiltransparenter Kreis, Kreuz und Keine. Um den Markierungsstil zu ändern wählen Sie mActionOptions Optionen aus dem Einstellungen Menü, klicken Sie auf den Reiter Digitalisierung und wählen Sie den entsprechenden Eintrag aus.

Eine einfache Übung

Beginnen Sie, indem Sie das mActionNodeTool Knotenwerkzeug aktivieren und dann ein Objekt selektieren. Rote Boxen erscheinen an jedem Stützpunkt des Objektes. Nun sind folgende Funktionen vorhanden.

  • Stützpunkte auswählen: Sie können die Stützpunkte auswählen indem sie einmal darauf klicken, indem Sie auf eine Ecke klicken um beide Enden auszuwählen oder indem Sie ein Rechteck mit der Maus über einige Stützpunkte ziehen. Wenn ein Stützpunkt ausgewählt ist wird er blau. Sie können mehrere Stützpunkte auswählen, indem Sie die Tasten Umschalt gedrückt halten. Mit der Taste Strg oder Shift kann die Auswahl umgekehrt werden (selektierte Stützpunkte werden deselektiert, nicht ausgwählte Stützpunkte werden ausgewählt).

  • Stützpunkte hinzufügen: Dazu klicken Sie doppelt in die Nähe einer Grenzlinie und ein neuer Stützpunkt erscheint. Beachten Sie, dass der Stützpunkt auf der Grenzlinie erscheint, und nicht an der Stelle, wo der Mauspfeil ist.

  • Stützpunkte löschen: Wählen Sie dazu Stützpunkte aus, die gelöscht werden sollen und klicken Sie dann auf die Taste Entfernen. Beachten Sie dass das mActionNodeTool Knotenwerkzeug nicht für das Löschen eines vollständigen Objekts benutzen können, QGIS stellt sicher dass die minimal erforderliche Anzahl von Stützpunkten für das Objekt an dem Sie arbeiten erhalten bleibt. Um ein vollständiges Objekt zu löschen müssen Sie das mActionDeleteSelected Ausgewähltes löschen Werkzeug benutzen.

  • Stützpunkte verschieben:Wählen Sie alle Stützpunkte aus, die verschoben werden sollen. Alle ausgewählten Stützpunkte werden in dieselbe Richtung wie der Mauspfeil verschoben. Wenn eine Fangtolerazt eingestellt ist, können die Stützpunkte zu dem nächstgelegenen Stützpunkt oder Segment snappen.

Jede Veränderung mit dem Knotenwerkzeug wird als einzelner Eintrag im Dialog Rückgängig/Wiederholung abgelegt und unterstütz die topologischen Funktionen. Ausserdem wird On-The-Fly Reprojektion wird unterstützt und Sie können Stützpunkte identifizieren, wenn Sie mit der Maus drüberfahren.

Objekte ausschneiden, kopieren und einfügen

Ausgewählte Objekte können ausgeschnitten, kopiert und an andere Ebenen im aktuellen QGIS-Projekt übergeben (eingefügt) werden, wenn sich der Ziellayer auch im Editiermodus befindet, indem Sie nach Auswahl des Ziellayers auf den Knopf mActionToggleEditing Bearbeitungsstatus umschalten klicken.

Objekte können auch als Text an externe Applikationen übergeben werden: Dabei wird ein Objekt im .csv Format mit ihrer Geometrie im OGC Well-Known Text (WKT) Format erzeugt.

In dieser QGIS Version können Textobjekte außerhalb von QGIS nicht in eine geladene Ebene eingefügt werden. Aber wann macht es Sinn, Objekte zum kopieren, auszuschneiden und einzufügen? Ein Beispiel ist, wenn Sie parallel an mehreren Layern arbeiten und Objekte zwischen den Layern hin- und herkopieren möchten. Ein Szenario könnte sein, dass Sie einen neuen Layer erstellen möchten, in dem aber nur einige Objekte aus einem bereits existierenden Layer verwendet werden sollen, wie etwa 5 Seen aus der Karte lakes.shp , die insgesamt aber tausende Seen enthält.

Wir nutzen diese Idee und machen daraus ein kleines Anwendungsbeispiel:

  1. Laden Sie den Layer, von dem Sie einige Objekte kopieren wollen (Quelle)

  2. Laden oder erstellen Sie einen Layer, in den die kopierten Objekte eingefügt werden sollen (Ziel)

  3. Schalten Sie für den Ziel Layer den Bearbeitungsstatus ein

  4. Stellen Sie die Quelle aktiv, indem Sie es in der Legende anklicken

  5. Benutzen Sie das mActionSelect Einzelnes Objekt auswählen Werkzeug und wählen ein paar Objekte in der Quelle aus

  6. Klicken Sie auf das Icon mActionEditCopy Objekte kopieren

  7. Stellen Sie das ‘Ziel’ aktiv, indem Sie es in der Legende anklicken

  8. Klicken Sie auf das Icon mActionEditPaste Objekte einfügen

  9. Beenden Sie den Bearbeitungsstatus für beide Layer und speichern Sie das Ergebnis ab

Was passiert, wenn der Quell- und Ziellayer ein unterschiedliches Schema enthält (Spaltennamen und -typen unterscheiden sich)? QGIS verwendet die Einträge, die gleich sind und ignoriert den Rest. Wenn es Ihnen egal ist, ob die Attribute korrekt übernommen werden, dann ist es egal, wie Sie die Spaltennamen und -typen der Attributtabelle erstellen. Wenn auch die Attributdaten korrekt übernommen werden sollen, dann stellen Sie sicher, dass auch die Spaltennamen und -typen beider layer zueinander passen.

Tipp

Deckungsgleichheit eingefügter Objekte

Wenn der Quell- und Ziellayer die gleiche Projektion nutzen, hat das übergebene Objekt die identische Geometrie wie in dem Quelllayer. Wenn der Quell- und Ziellayer eine unterschiedliche Projektion nutzen, kann das übergebene Objekt eine andere Geometrie wie in dem Quelllayer besitzen. Der Grund liegt in auftretenden Rundungsabweichungen bei der Konvertierung zwischen Projektionen.

Ausgewählte Objekte löschen

Wenn Sie ein ganzes Polygon löschen möchten, selektieren Sie es erst mit dem mActionSelect Einzelnes Objekt auswählen Werkzeug. Sie können dabei auch mehrere Objekte gleichzeitig auswählen. Wenn Sie die Objekte ausgewählt haben, klicken Sie auf das Icon mActionDeleteSelected Ausgewähltes löschen.

Das Werkzeug mActionEditCut Ausgewählte Objekte ausschneiden kann auch benutzt werden, um Objekte zu löschen. Die Objekte werden gelöscht aber zusätzlich noch im ‘spatial clipboard’ abgelegt. In diesem Fall könnte man dann den letzten Schritt, falls ein Fehler unterlaufen ist, wieder rückgängig machen, indem wir auf das Werkzeug mActionEditPaste Objekte einfügen drücken. Ausschneiden, kopieren und übergeben von Objekten funktioniert mit den gerade ausgewählten Objekten und können nach Bedarf kombiniert verwendet werden.

Änderungen speichern

When a layer is in editing mode, any changes remain in the memory of QGIS. Therefore they are not committed/saved immediately to the data source or disk. If you want to save edits to the current layer but want to continue editing without leaving the editing mode, you can click the mActionSaveEdits Save Layer Edits button. When you turn editing mode off with the mActionToggleEditing Toggle editing (or quit QGIS for that matter), you are also asked if you want to save your changes or discard them.

Wenn die Änderungen nicht gespeichert werden können (z.B. weil die Festplatte voll ist oder Attribute Werte aufweisen, die außerhalb der Wertespanne liegen), bleiben die Änderungen erstmal im Arbeitsspeicher. Dies erlmöglicht es, Änderungen vorzunehmen und dann nochmals die Daten zu speichern.

Tipp

Datenintegrität

Es ist immer gut ein Backup von Ihren Daten zu machen bevor Sie mit dem Bearbeiten starten. Während die Autoren von QGIS sich bemühen die Integrität Ihrer Daten zu bewahren bieten wir keine Garantie in dieser Hinsicht.

Erweiterte Digitalisierung

Icon

Funktion

Icon

Funktion

mActionUndo

Rückgängig

mActionRedo

Wiederholen

mActionRotateFeature Rotate Feature(s) mActionSimplify

Objekt vereinfachen

mActionAddRing

Ring hinzufügen

mActionAddPart

Teil hinzufügen

mActionDeleteRing

Ring löschen

mActionDeletePart

Teil löschen

mActionReshape

Objekte überarbeiten

mActionOffsetCurve

Linie versetzen

mActionSplitFeatures

Objekte trennen

mActionMergeFeatures

Gewählte Objekte verschmelzen

mActionRotatePointSymbols

Punktsymbole drehen

mActionMergeFeatureAttributes

Attribute gewählter Objekte vereinen

Tabelle Erweiterte Digitalisierung: Werkzeugleiste Erweiterte Digitalisierung für Vektorlayer

Rückgängig und Wiederholen

Die Werkzeuge mActionUndo Rückgängig und mActionRedo Wiederholen ermöglichen es, Arbeitsschritte der Vektoreditierung rückgängig zu machen oder zu wiederholen. Im Dialog Rücknahme/Wiederholung werden alle durchgeführten Operationen angezeigt (siehe Abbildung Figure_edit_3). Dieser Dialog wird nicht standardmäßig angezeigt. Klicken Sie dazu in einem freien Bereich der Werkzeugleiste auf die rechte Maustaste und aktivieren dann das Kontrollkästchen Rücknahme/Wiederholung. Die Funktion ist übrigens immer aktiv, auch wenn der Dialog nicht angezeigt wird.

Figure Edit 3:

../../../_images/redo_undo.png

Redo and Undo digitizing steps nix

Wenn Sie auf die Funktion ‘Rückgängig’ klicken, werden alle Geometrien und Attribute auf den Status zurückgestellt, bevor die rückgängig gemachte Operation stattgefunden hat. Veränderung, die an anderer Stelle, z.B. in anderen Plugins durchgeführt wurden, können unspezifisch sein für die unterschiedlichen Operationen - d.h. sie können rückgängig gemacht werden oder aber einfach so bleiben.

Wenn Sie Rücknahme/Wiederholung verwenden wollen klicken Sie einfach auf eine Operation in der history; alle Objekte werden dann auf den Stand vor der ausgewählten Operation zurückgesetzt.

Rotate Feature(s)

Use the mActionRotateFeatureRotate Feature(s) to rotate one or multiple selected features in the map canvas. You first need to select the features and then press the mActionRotateFeatureRotate Feature(s) Icon. Then the centroid of the feature appears and will be the rotation anchor point. If you selected multiple features the rotation anchor point will be the common center of the features. Press and drag the left mouse button in the desired direction to rotate the selected features.

It’s also possible to create a user-defined rotation anchor point by which the selected feature will rotate. Select the features to rotate and activate the mActionRotateFeatureRotate Feature(s) Tool. Press and hold the Ctrl button and move the mouse pointer (without pressing the mouse button) to the place where you want the rotation anchor to be moved. Release the Ctrl button when the desired rotation anchor point is reached. Now press and drag the left mouse button in the desired direction to rotate the selected feature(s).

Objekt vereinfachen

Das Werkzeug mActionSimplify Objekt vereinfachen ermöglicht es, die Anzahl der Stützpunkte eines Objektes zu veringern, solange sich die Geometrie nicht verändert. Sie müssen dazu eines oder mehrere Objekte auswählen. Dadurch werden diese von einem roten Gummiband umrandet und ein Schieber erscheint. Wenn Sie die Stellung des Schiebers verändern, können Sie sehen, wie das Objekt vereinfacht wird. Durch einen Klick auf [OK] wird die neue Geometrie abgespeichert. Wenn ein Objekt nicht vereinfacht werden kann (z.B. bei MultiPolygonen), erscheint ein Fenster mit einer entsprechenden Meldung.

Ring hinzufügen

Sie können Ring-Polygone mit dem Werkzeug mActionAddRing Ring hinzufügen erstellen. Das bedeutet, dass Sie innerhalb eines bestehenden Polygons weitere Polygone digitalisieren können. Diese erscheinen dann als ‘Loch’, so dass nur der Zwischenraum des inneren und des äußeren Polygons als Ring-Polygon übrig bleibt.

Teil hinzufügen

You can mActionAddPart add part polygons to a selected multipolygon. The new part polygon has to be digitized outside the selected multipolygon.

Ring löschen

Das Werkzeug mActionDeleteRing Ring löschen ermöglicht es, Ringpolygone innerhalb eines existierenden Fläche zu löschen. Das Werkzeug funktioniert nur mit Polygonlayern und kann für Polygon- und Multipolygon-Objekte benutzt werden. Es findet keine Veränderung statt, wenn es auf den äußeren Ring eines Polygons angewendet wird. Bevor Sie die Vertices des Ringes selektieren, stellen Sie bitte die Fangtoleranz entsprechend ein.

Teil löschen

Mit dem mActionDeletePart Teil löschen Werkzeug können Teile eines Multi-Feature Objektes gelöscht werden (z.B. ein Polygon von einem Multipolygon Objekt löschen). Dabei wird der letzte Teil des Multi-Feature Objektes nicht gelöscht. Das Werkzeug funktioniert mit alles Multi-Feature Geometrien Punkte, Linien und Polygone. Bevor Sie die Vertices des Teils selektieren, stellen Sie bitte die Fangtoleranz entsprechend ein.

Objekte überarbeiten

Die Geometrien von Linien und Polygonen können mit dem Werkzeug mActionReshape Objekt überarbeiten. Dabei ersetzt die gezogene Linie die originale Linie oder Flächenlinie eines Objektes von der ersten bis zur zweiten Überschneidung. Für Polygone kann dies manchmal zu unerwünschten Resultaten führen und ist vorwiegend sinnvoll, wenn man nur kleinere Teile einer Fläche ersetzen möchte und nicht für eine vollständige Überarbeitung. Dabei ist es für die Vereinfachungslinie auch nicht erlaubt, mehrere Polygongrenzen zu überschneiden.

Als Beispiel können Sie die Grenze eines Polygons mit diesem Tool bearbeiten. Klicken Sie als erstes in die Fläche des Polygons neben den Punkt wo Sie den neuen Stützpunkt hinzufügen wollen. Dann überqueren Sie die Grenze und fügen sie Stützpunkte außerhalb des Polygons ein. Machen Sie einen Rechtsklick in die Fläche des Polygons zum Vervollständigen. Das Werkzeug wird automatisch einen Knoten an der Stelle wo die neue Linie die grenze kreuzt hinzufügen. Es ist auch möglich einen Teil der Polygonfläche zu entfernen indem man außerhalb des Polygons anfängt, Stützpunkte innerhalb des Polygons hinzufügt und außerhalb des Ploygons mit einem Rechtklick aufhört.

Bemerkung

Das Objekte überarbeiten Werkzeug kann die Startposition eines Polygonringes oder einer geschlossenen Linie verändern. Der Punkt, der zweimal abgebildet ist wird also nicht mehr der gleiche sein. Dies mag kein Problem für die meisten Anwendungen sein, sollte aber beachtet werden.

Linie versetzen

The mActionOffsetCurve Offset Curve tool creates parallel shifts of line layers. The tool can be applied to the edited layer (the geometries are modified) or also to background layers (creates copies of the lines / rings and adds it to the the edited layer). It is thus ideally suited for the creation of distance line layers. The displacement is shown at the bottom left of the taskbar. To create a shift of a line layer you have to go into editing mode and then select the feature. You can make the mActionOffsetCurve Offset Curve tool active and drag the cross to the desired distance. Your changes then can be saved with the mActionSaveEditsSave Layer Edits tool.

Objekte trennen

Objekte können mit dem Werkzeug mActionSplitFeatures Objekt teilen geteilt werden. Zeichnen Sie dazu einfach eine Linie durch das Objekt, das Sie teilen wollen.

Gewählte Objekte verschmelzen

Das Werkzeug mActionMergeFeatures Gewählte Objekte verschmelzen erlaubt es, Objekte die eine gemeinsame Grenzlinie und die gleichen Attribute tragen zu verschmelzen.

Attribute gewählter Objekte vereinen

The mActionMergeFeatureAttributes Merge Attributes of Selected Features tool allows to merge attributes of features with common boundaries and attributes without merging their boundaries. You can merge the attributes when selecting several features at once. Then press the mActionMergeFeatureAttributes Merge Attributes of Selected Features button. Now QGIS offers you which attributes are to be applied to all selected objects. As a result, all objects have the same attribute entries.

Punktsymbole drehen

The mActionRotatePointSymbols Rotate Point Symbols allows to change the rotation of point symbols in the map canvas. You have to define a rotation column from the attribute table of the point layer in the Advanced menu of the Style menu of the Layer Properties. Also you have to go into the ‘SVG marker’ and choose Data defined properties .... Activate checkbox Angle and choose ‘rotation’ as field. Without these settings the tool is inactive.

Figure Edit 4:

../../../_images/rotatepointsymbol.png

Rotate Point Symbols nix

Um die Drehung zu ändern, wählen Sie einen Punkt im Kartenfenster aus und drehen diesen, indem Sie die linke Maustaste gedrückt halten. Ein roter Pfeil mit dem Drehwinkel wird dann angezeigt Wenn Sie die linke Maustaste wieder loslassen, wird der neue Wert in der Attributtabelle aktualisiert.

Bemerkung

Wenn Sie zusätzlich die Strg-Taste gedrückt halten, findet die Drehung in 15 Grad Schritten statt.

Creating new Vector layers

QGIS allows to create new Shapefile layers, new SpatiaLite layers, and new GPX Layers. Creation of a new GRASS layer is supported within the GRASS-plugin. Please refer to section Einen neuen GRASS Vektorlayer erstellen for more information on creating GRASS vector layers.

Eine neue Shapedatei erstellen

Um einen neuen Shapelayer zu erstellen, wählen Sie Neu ‣ mActionNewVectorLayer Neuer Shapedatei Layer ... aus dem Menü Layer. Dadurch startet der Dialog Neuer Vektorlayer (vgl. Abb. Figure_edit _5_). Wählen Sie hier den Typ des neuen Layers (Punkt, Linie oder Polygon) und das KBS (Koordinatenbezugsystem).

Beachten Sie dass QGIS derzeit noch keine 2,5D Objekte erstellen kann (z.B. Objekte mit X,Y,Z Koordinaten).

Figure Edit 5:

../../../_images/editNewVector.png

Creating a new Shapefile layer Dialog nix

To complete the creation of the new Shapefile layer, add the desired attributes by clicking on the [Add to attributes list] button and specifying a name and type for the attribute. A first ‘id’ column is added as default but can be removed, if not wanted. Only Type: real selectstring, Type: integer selectstring, Type: string selectstring and Type:date selectstring attributes are supported. Additionally and according to the attribute type you can also define the width and precision of the new attribute column. Once you are happy with the attributes, click [OK] and provide a name for the shapefile. QGIS will automatically add a .shp extension to the name you specify. Once the layer has been created, it will be added to the map and you can edit it in the same way as described in Section Einen vorhandenen Layer editieren above.

Einen neuen SpatiaLite Layer erstellen

To create a new SpatiaLite layer for editing, choose New ‣ mActionNewSpatiaLiteLayer New SpatiaLite Layer... from the Layer menu. The New SpatiaLite Layer dialog will be displayed as shown in Figure_edit_6.

Figure Edit 6:

../../../_images/editNewSpatialite.png

Creating a New SpatiaLite layer Dialog nix

First step is to select an existing SpatiaLite database or to create a new SpatiaLite database. This can be done with the browse button browsebutton to the right of the database field. Then add a name for the new layer and define the layer type and specify the Coordinate Reference System with [Specify CRS]. If desired you can select to checkbox Create an autoincrementing primary key.

Um die Attributtabelle des neuen SpatiaLite Layers festzulegen, geben Sie für die gewünschten Spalten die Namen und den Datentyp an und klicken dann jeweils auf den Knopf [Der Attributliste hinzufügen]. Wenn alles korrekt eingegeben ist, drücken Sie auf [OK]. QGIS zeigt den neuen Layer dann automatisch in der Legende an und Sie können mit dem Editieren beginnen, wie in Kapitel Einen vorhandenen Layer editieren beschrieben.

Das erweitere Managen von SpatiaLite-Layern kann mit dem DB Manager vorgenommen werden (siehe DB Manager Plugin).

Creating a new GPX layer

To create a new GPX file you need to load the GPS plugin first. Plugins ‣ mActionShowPluginManager Plugin Manager... opens the Plugin Manager Dialog. Activate the checkbox GPS Tools checkbox.

When this plugin is loaded choose New ‣ icon_newgpx Create new GPX Layer... from the Layer. In the Save new GPX file as dialog you can choose where to save the new GPX layer.

Mit Attributtabelle arbeiten

Die Attributtabelle zeigt alle Objekte eines ausgewählten Layers. Jede Zeile in der Attributtabelle representiert dabei ein Objekt des Layers mit seinen Attributen, die in einzelne Spalten unterteilt sind. Die Einträge der Attributtabelle können durchsucht, selektiert, verschoben und sogar verändert werden.

To open the attribute table for a vector layer, make the layer active by clicking on it in the map legend area. Then from the main menu Layer choose mActionOpenTable Open Attribute Table. It is also possible to rightclick on the layer and choose mActionOpenTable Open Attribute Table from the dropdown menu and to click on the mActionOpenTable Open Attribute Table button in the Attributes toolbar.

Dieses öffnet ein neues Fenster welches die Attribute der Objekte eines Layers abbildet (figure_attributes_1). Die Anzahl der Objekte und die Anzahl selektierter Objekte werden im Titel der Attributtabelle gezeigt.

Figure Attributes 1:

../../../_images/vectorAttributeTable.png

Attribute Table for regions layer nix

Objekte einer Attributtabelle abfragen

Jede selektierte Zeile in einer Attributtabelle repräsentiert alle Attribute eines Objektes in dem ausgewählten Layer. Die Attributtabelle zeigt alle Veränderungen bei einer Abfrage in der Attributtabelle im Kartenfenster und umgekehrt. Eine neue Abfrage in der Attributtabelle verursacht also eine Veränderung der im Kartenfenster als ausgewählt dargestellten Objekte und eine im Kartenfenster geänderte Auswahl von Objekten spiegelt sich durch eine Veränderung der ausgwählten Zeilen in der Attributtabelle wider.

Zeilen können ausgewählt werden, indem Sie auf die Zeilennummer links neben der Zeile klicken. Mehrere Zeilen können ausgewählt werden, indem die Strg Taste während der Auswahl gedrückt wird.Eine kontinuierliche Auswahl ist möglich, indem Sie bei der Selektion die Umschalt Taste gedrückt halten, während Sie die Zeilennummern auswählen. Alle Zeilen zwischen der aktuell ausgewählten Zeile und der Mauspfeilposition werden dadurch selektiert. Bewegt man den Mauszeiger in der Attributtabelle indem man in eine Zelle in der Tabelle klickt ändert die Zeilenauswahl nicht. Verändert man die Auswahl im Kartenfenster bewegt sich der Mauszeiger in der Attributtabelle nicht.

Jede Spalte kann sortiert werden, indem Sie auf die Kopfzeile klicken. Ein kleiner Pfeil zeigt die Sortierfolge an. Wenn er nach unten zeigt, werden die Werte von oben nach unten absteigend angezeigt. Wenn der Pfeil nach oben zeigt, werden die von oben nach unten aufsteigend angezeigt.

For a simple search by attributes on only one column choose the Column filter ‣ from the menu in the bottom left corner. Select the field (column) from which the search should be performed from the dropdown menu and hit the [Apply] button. Then only the matching features are shown in the Attribute table.

To make a selection you have to use the mIconExpressionSelect Select features using an Expression icon on top of the Attribute table. The mIconExpressionSelect Select features using an Expression allows you to define a subset of a table using a Function List like in the mActionCalculateField Field Calculator (see Feldrechner). The query result then can be saved as a new vector layer. For example if you want to find regions that are boroughs from the regions.shp of the QGIS sample data you have to open the >Fields and Values menu and choose the field that you want to query. Double-klick the field ‘TYPE_2’ and also [Load all unique values] . From list choose and double-klick ‘Borough’. In the Expression field the following query appears:

"TYPE_2"  =  'Borough'

The matching rows will be selected and the total number of matching rows will appear in the title bar of the attribute table, and in the status bar of the main window. For searches that display only selected features on the map use the Query Builder described in Section Abfrageeditor.

To show selected records only, use Show Selected Features from the menu at the bottom left.

The other buttons at the top of the attribute table window provide following functionality:

  • mActionToggleEditing Bearbeitungsmodus umschalten um einen einzelnen Wert zu editieren und weitere Funktionen zu aktivieren auch mit Strg+E

  • mActionSaveEdits Save Edits also with Ctrl+S
  • mActionUnselectAttributes Unselect all also with Ctrl+U
  • mActionSelectedToTop Auswahl nach oben (Strg + T)

  • mActionInvertSelection Invert selection also with Ctrl+R
  • mActionCopySelected Ausgewählte Zeilen in die Zwischenablage kopieren (Strg+C)

  • mActionZoomToSelected Zu den gewählten Zeilen zoomen (Strg+J)

  • PanToSelected Karte zu den gewählten Zeilen verschieben (Strg+P)

  • mActionDeleteSelected Gewählte Objekte löschen (Strg+D)

  • mActionNewAttribute Neue Spalte (Strg+W) für PostGIS und OGR Layer ab GDAL Version >= 1.6

  • mActionDeleteAttribute Spalte löschen (Strg. L) für PostGIS und OGR Layer ab GDAL Version >=1.9

  • mActionCalculateField Feldrechner öffnen (Strg+I)

Tipp

WKT Geometrie überspringen

If you want to use attribute data in external programs (such as Excel) use the mActionCopySelected Copy selected rows to clipboard button. You can copy the information without vector geometries if you deactivate Settings ‣ Options ‣ Data sources menu checkbox Copy geometry in WKT representation from attribute table.

Ausgewählte Objekte als neuer Layer speichern

Ausgewählte Objekte können in jedem von OGR unterstützten Vektor-Format gespeichert werden und auch in ein anderes Koordinatensystem Bezugssystem (KBS) transformiert werden. Öffnen Sie einfach das rechte Maustaste-Menü des Layers und klicken Sie auf Auswahl speichern als ‣. Dann definieren Sie den Namen der Ausgabedatei, das Format und KBS (siehe Abschnitt Map Legend). Sie können zusätzlich auch OGR-Erzeugungsoptionen angeben.

Arbeiten mit nicht räumlichen Attributtabellen

QGIS allows also to load non spatial tables. This includes currently tables supported by OGR, delimited text as well as the PostgreSQL, MSSQL and Oracle provider. The tables can be used for field lookups or just generally browsed and edited using the table view. When you load the table you will see it in the legend field. It can be opened e.g. with the mActionOpenTable Open Attribute Table tool and is then editable like any other layer attribute table.

As an example you can use columns of the non spatial table to define attribute values or a range of values that are allowed to be added to a specific vector layer during digitizing. Have a closer look at the edit widget in section Fields Menu to find out more.