Outdated version of the documentation. Find the latest one here.

Allgemeine Werkzeuge

Identify features

Identify features allow to interact with map canvas to get data attribut on a pop-up windows. To identify feature use View ‣ Identify features or Ctrl+Shift+I, or click on the mActionIdentify Identify features icon in the toolbar.

If you click on several feature, this pop-up will list all data attributes of all features. The first item is the number of the item in the list of result followed by layer name. Then its first child will be the name of a field with its value. Finally all informations of the feature is displayed.

This window can be customized to display custom fields but by default it will display three kind of information:

  • Actions: actions can be added to the identify feature windows. When clicking on the action label, action will be run. By default only one action is added to View feature form for editing.
  • Derived: those informations are calculated or derived from other information. You can find clicked coordinate, X and Y coordinates, area in map unit and perimeter in map unit for polygon, length in map unit for line and feature id.
  • Data attributes: this is the list of attribute fields from data.

Figure Identify 1:

../../../_images/identify_features.png

Identify feaures dialog nix (Gnome)

At the bottom of the windows, you have five icons:

  • mActionIdentifyExpand Expand tree
  • mActionIdentifyCollapse Collapse tree
  • mActionIdentifyDefaultExpand Default behaviour
  • mActionIdentifyCopyAttributes Copy attributes
  • mActionIdentifyPrint Print selected HTML response

More feature can be found in the menu display with a right click of the mouse somewhere in the response tree.

This menu allows to:

  • View Feature form
  • Zoom to feature
  • Copy feature: copy all feature ie geometry and attributes;
  • Copy attribute value: copy only the value of the attribut you click on;
  • Copy feature attributes: copy only attributes;
  • Clear result: result in the window are removed
  • Clear highlights: features highlight on the map are removed
  • Highlight all
  • Highlight layer
  • Layer properties: open layer properties window
  • Expand all
  • Collapse all

Tastenkürzel

QGIS provides default keyboard shortcuts for many features. You find them in Section Menu Bar. Additionally the menu option Settings ‣ Configure Shortcuts allows to change the default keyboard shortcuts and to add new keyboard shortcuts to QGIS features.

Figure Shortcuts 1:

../../../_images/shortcuts.png

Define shortcut options nix (Gnome)

Configuration is very simple. Just select a feature from the list and click on [Change], [Set none] or [Set default]. Once you have found your configuration, you can save it as XML file and load it to another QGIS installation.

Hilfe

Wenn Sie Hilfe zu bestimmten Themen brauchen erreichen Sie die Kontext-Hilfe über den Hilfe Knopf der Ihnen in den meisten Dialogen zur Verfügung steht. Bitte beachten Sie daß Erweiterungen von Drittanbietern zu dementsprechend gewidmeten Internetseiten verweisen.

Layeranzeige kontrollieren

By default, QGIS renders all visible layers whenever the map canvas must be refreshed. The events that trigger a refresh of the map canvas include:

  • Einen Layer hinzufügen

  • Karten verschieben, hinein- oder herauszoomen

  • Resizing the QGIS window
  • Layer ein- oder ausblenden

QGIS allows you to control the rendering process in a number of ways.

Maßstabsabhängige Layeranzeige

Scale dependent rendering allows you to specify the minimum and maximum scales at which a layer will be visible. To set scale dependency rendering, open the Properties dialog by double-clicking on the layer in the legend. On the General tab, click on the checkboxUse scale dependent rendering checkbox to activate the feature then set the minimum and maximum scale values. .

You can determine the scale values by first zooming to the level you want to use and noting the scale value in the QGIS status bar.

Layeranzeige kontrollieren

Die Kartenwiedergabe kann auf folgende Art kontrolliert werden:

Wiedergabe unterdrücken

To suspend rendering, click the checkbox Render checkbox in the lower right corner of the statusbar. When the checkbox Render checkbox is not checked, QGIS does not redraw the canvas in response to any of the events described in Section Layeranzeige kontrollieren. Examples of when you might want to suspend rendering include:

  • Viele Layer hinzufügen und ihre Symbologie vor der Visualisierung einstellen

  • Einen oder mehrere große Layer hinzufügen und erst die maßstabsabhängige Wiedergabe einstellen

  • Einen oder mehrere große Layer hinzufügen und erst in ein bestimmtes Gebiet hineinzoomen

  • Eine Kombination aus den oben genannten Punkten

Wenn Sie die checkbox Zeichnen aktivieren, findet automatisch eine Erneuerung der Wiedergabe des Kartenfensters statt.

Option für Layer hinzufügen

You can set an option to always load new layers without drawing them. This means the layer will be added to the map, but its visibility checkbox in the legend will be unchecked by default. To set this option, choose menu option Settings ‣ Options ‣ and click on the Rendering menu. Uncheck the checkbox By default new layers added to the map should be displayed checkbox. Any layer added to the map will be off (invisible) by default.

Another option in Settings ‣ Options ‣ Rendering menu is the checkbox Enable back buffer checkbox. It provides better graphics performance at the cost of loosing the possibility to cancel rendering and incremental feature drawing. If it is unchecked, you can set the ‘Number of features to draw before updating the display’, otherwise it is inactive.

Finally you can activate the checkbox Use render caching where possible to speed up redraws checkbox.

Zeichnen stoppen

Um die Wiedergabe einer Karte zu stoppen drücken Sie die ESC Taste. Dies stoppt die Erneuerung der Wiedergabe und die Karte wird nur zum Teil angezeigt. Es kann sein dass etwas Zeit zwischen dem Drücken der Esc Taste und dem Stoppen der Kartenwiedergabe vergeht.

Bemerkung

Es ist derzeit nicht möglich das Zeichnen zu stoppen - diese Funktion wurde mit der Version qt4 ausgeschaltet da es zu Problemen und Abstürzen der Benutzeroberfläche kam.

Anpassen des Kartenfensters bei der Wiedergabe

You can set an option to update the map display as features are drawn. By default, QGIS does not display any features for a layer until the entire layer has been rendered. To update the display as features are read from the datastore, choose menu option Settings ‣ Options click on the Rendering menu. Set the feature count to an appropriate value to update the display during rendering. Setting a value of 0 disables update during drawing (this is the default). Setting a value too low will result in poor performance as the map canvas is continually updated during the reading of the features. A suggested value to start with is 500.

Die Qualität der Wiedergabe beeinflussen

To influence the rendering quality of the map you have 2 options. Choose menu option Settings ‣ Options click on the Rendering menu and select or deselect following checkboxes.

  • checkbox Linien auf Kosten der Zeichengeschwindigkeit weniger gezackt zeichnen

  • checkbox Problem mit falsch gefüllten Polygonen beheben

Messen

Das Messen funktioniert mit Projektionen (z.B. UTM) und auch mit nicht projizierten Daten. Wenn die geladene Karte als Geografisches Koordinatensystem abgebildet wird (z.B. Latitude/Longitude) sind die Messergebnisse falsch. Sie müssen dann ein passendes KBS mit einer Projektion verwenden (siehe Abschnitt Arbeiten mit Projektionen). Alle Meßwerkzeuge verwenden auch die eingestellte Fangtoleranz der Digitalisierung. Dies ist zum Beispiel dann sinnvoll, wenn Sie entlang von Linien oder Polygongrenzen geladener Vektorlayer messen wollen.

Um ein Meßwerkzeug auszuwählen klicken Sie auf mActionMeasure und suchen das Werkzeug das sie benutzen wollen aus.

Strecken, Flächen und Winkel messen

mActionMeasure Measure Line: QGIS is able to measure real distances between given points according to a defined ellipsoid. To configure this, choose menu option Settings ‣ Options, click on the Map tools tab and choose the appropriate ellipsoid. There you can also define a rubberband color and your preferred measurement units (meters or feet) and angle units (degrees, radians and gon). The tools then allows you to click points on the map. Each segment-length as well as the total shows up in the measure-window. To stop measuring click your right mouse button.

Figure Measure 1:

../../../_images/measure_line.png

Measure Distance nix (Gnome)

mActionMeasureArea Measure Area: Areas can also be measured. In the measure window the accumulated area size appears. In addition, the measuring tool will snap to the currently selected layer, provided that layer has its snapping tolerance set. (See Section Einstellen der Fangtoleranz und des Suchradius). So if you want to measure exactly along a line feature, or around a polygon feature, first set its snapping tolerance, then select the layer. Now, when using the measuring tools, each mouse click (within the tolerance setting) will snap to that layer.

Figure Measure 2:

../../../_images/measure_area.png

Measure Area nix (Gnome)

mActionMeasureAngle Measure Angle: You can also measure angles. The cursor becomes cross-shaped. Click to draw the first segment of the angle you wish to measure, then move the the cursor to draw the desired angle. The measure is displayed in a popup dialog.

Figure Measure 3:

../../../_images/measure_angle.png

Measure Angle nix (Gnome)

Objekte auswählen und Auswahl aufheben

The QGIS toolbar provides several tools to select features in the map canvas. To select one or several features just click on mActionSelect and select your tool:

  • mActionSelect Select Single Feature
  • mActionSelectRectangle Select Features by Rectangle
  • mActionSelectPolygon Select Features by Polygon
  • mActionSelectFreehand Select Features by Freehand
  • mActionSelectRadius Select Features by Radius

Um die Auswahl von Objekten wieder aufzuheben, klicken Sie auf den Knopf mActionDeselectAll.

Dekorationen

The Decorations of QGIS includes the Grid, Copyright Label, the North Arrow and the Scale Bar. They are used to ‘decorate’ the map by adding cartographic elements.

Grid

transformed Grid allows to add a coordinate grid and coordinate annotations to the map canvas.

Figure Decorations 1:

../../../_images/grid_dialog.png

The Grid Dialog nix

  1. Select from menu View ‣ Decorations ‣ Grid. The dialog starts (see figure_decorations_1).
  2. Activate the checkbox Enable grid checkbox and set grid definitions according to the layers loaded in the map canvas.
  3. Activate the checkbox Draw annotations checkbox and set annotation definitions according to the layers loaded in the map canvas.
  4. Click [Apply] to check, if it looks as expected.
  5. Click [OK] to close the dialog.

Nordpfeil

north_arrow North Arrow places a simple north arrow on the map canvas. At present there is only one style available. You can adjust the angle of the arrow or let QGIS set the direction automatically. If you choose to let QGIS determine the direction, it makes its best guess as to how the arrow should be oriented. For placement of the arrow you have four options, corresponding to the four corners of the map canvas.

Figure Decorations 3:

../../../_images/north_arrow_dialog.png

The North Arrow Dialog nix

Maßstab

scale_bar Scale Bar adds a simple scale bar to the map canvas. You control the style and placement, as well as the labeling of the bar.

Figure Decorations 4:

../../../_images/scale_bar_dialog.png

The Scale Bar Dialog nix

QGIS only supports displaying the scale in the same units as your map frame. So if the units of your layers are in meters, you can’t create a scale bar in feet. Likewise if you are using decimal degrees, you can’t create a scale bar to display distance in meters.

Das Hinzufügen eines Maßstabbalkens geht folgendermaßen:

  1. Select from menu View ‣ Decorations ‣ Scale Bar The dialog starts (see figure_decorations_4)
  2. Wählen Sie aus dem Drop-Down Menü Platzierung ‘Unten Links’ aus

  3. Wählen Sie aus dem Drop-Down Menü Maßstabsstil ‘Strich unten’ aus

  4. Wählen Sie aus Balkenfarbe‘schwarz’ aus oder verwenden Sie die Standardfarbe schwarz

  5. Legen Sie die Größe des Balkens und seine Beschriftung unter Größe des Maßstabs mit ‘30 Grad’ fest

  6. Vergewissern Sie sich, dass das Kontrollkästchen checkbox Aktiviere Maßstab aktiv ist

  7. Optional können Sie noch auswählen. dass die Maßstabszahl bei Größenänderungen immer auf eine Ganze Zahl gerundet werden soll mit dem Kontrollkästchen checkbox Bei Größenänderungen automatisch runde Zahlen einstellen

  8. Klicken Sie auf OK

Tipp

Einstellungen von Dekorationen

When you save a .qgs project, any changes you have made to Grid, NorthArrow, ScaleBar and Copyright will be saved in the project and restored the next time you load the project.

Beschriftungstools

The mActionTextAnnotation Text Annotation tools in the attribute toolbar provides the possibility to place formatted text in a balloon on the QGIS map canvas. Use the Text Annotation tool and click into the map canvas.

Figure annotation 1:

../../../_images/annotation.png

Annotation text dialog nix

Ein Doppelklick auf das Element öffnet den Dialog mit verschiedenen Optionen. im Texteditor können Sie den formatierten Text eingeben und einige Einstellungen vornehmen. Z.B. kann das Objekt an einer bestimmten Stelle positioniert werden, was dann durch ein Markersymbol angezeigt wird. Oder das es unabhängig von dem Objekt im Kartenfenster angezeigt wird. Der Text kann entweder durch Verschieben der Markierung oder der Sprechblase im Kartenfenster verschoben werden.

The mActionAnnotation Move Annotation tool allows to move the annotation on the map canvas.

Html annotations

The mActionFormAnnotation Html Annotation tools in the attribute toolbar provides the possibility to place the content of a html file in a balloon on the QGIS map canvas. Use the Html Annotation tool, click into the map canvas and add the path to the html file into the dialog.

SVG annotations

The mActionSaveAsSVG SVG Annotation tools in the attribute toolbar provides the possibility to place a SVG Symbol in a balloon on the QGIS map canvas. Use the SVG Annotation tool, click into the map canvas and add the path to the SVG file into the dialog.

Beschriftungsformular

Additionally you can also create your own annotation forms. The mActionFormAnnotation Form Annotation tool is useful to display attributes of a vector layer in a customized qt designer form (see figure_custom_annotation). It is similar to the designer forms for the Identify features tool, but displayed in an annotation item. Also see QGIS blog http://blog.qgis.org/node/143 for more information.

Figure annotation 2:

../../../_images/custom_annotation.png

Customized qt designer annotation form nix

Bemerkung

Wenn Sie das Tastenkürzel Ctrl+T drücken während ein Beschriftungswerkzeug aktiv ist ändert sich deren Anzeigestatus zwischen an und aus.

Räumliche Lesezeichen

Räumliche Lesezeichen ermöglichen es, geografische Orte zu markieren und als Lesezeichen abzuspeichern, um dorthin später zurückzufinden.

Ein Lesezeichen erstellen

Um ein Lesezeichen zu erstellen:

  1. Zoomen oder verschieben Sie das Kartenfenster in einen Ausschnitt Ihrer Wahl.

  2. Wählen Sie in der Menüleiste Ansicht ‣ Neues Lesezeichen oder drücken Sie kbd:Ctrl-B.

  3. Geben Sie eine Beschreibung für das Lesezeichen ein (bis zu 255 Zeichen).

  4. Klicken Sie auf Enter um das Lesezeichen hinzuzufügen oder auf [Löschen] um das Lesezeichen zu entfernen.

Sie können mehrere Lesezeichen mit demselben Namen erstellen.

Arbeiten mit Lesezeichen

Um ein bestehendes Lesezeichen zu editieren, wählen Sie in der Menüleiste Ansicht ‣ Zeige Lesezeichen. Das Dialogfenster erlaubt es, auf ein Lesezeichen zu zoomen oder es zu löschen. Sie können die Koordinaten oder den Namen des Lesezeichens nicht verändern.

Auf ein Lesezeichen zoomen

Im Dialogfenster Räumliches Lesezeichen klicken Sie auf das gewünschte Lesezeichen und wählen dann den Knopf [Zoomen auf]. Sie können auch auf ein Lesezeichen zoomen, indem Sie es mit einem Doppelklick auswählen.

Ein Lesezeichen löschen

Um ein Lesezeichen aus dem Dialogfenster Räumliches Lesezeichen zu löschen, klicken Sie auf das gewünschte Lesezeichen, dann auf den Knopf [Löschen] und bestätigen Sie es mit [Ja] oder [Nein].

Layer/Gruppen einbinden

Wenn Sie Inhalte von anderen Projekten in Ihr Projekt einbinden wollen wählen Sie Layer ‣ Eingebettete Layer und Gruppen.

Layer einbetten

Der folgende Dialog ermöglicht Ihnen das Einbetten von Layern aus anderen Projekten:

  1. Drückekn Sie browsebutton um nach einem anderen Projekt des Alaskadatensatzes zu suchen.

  2. Drücken Sie die Projektdatei grassland. Sie können den Inhalt des Projektes sehen (siehe figure_embed_dialog).

  3. Drücken Sie Ctrl und klicken Sie auf die Layer grassland und regions. Die Layer sind jetzt in der Kartenlegende und im Kartenfenster eingebettet.

Figure Nesting 1:

../../../_images/embed_dialog.png

Select layers and groups to embed nix

Die eingebetteten Layer sind editierbar sie können jedoch Eigenschaften wie Stil und Beschriftung nicht ändern.

Eingebettete Layer entfernen

Right-click on the embedded layer and choose mActionRemoveLayer Remove.

Add Delimited Text Layer

This function allows you to load a delimited text file as a layer in QGIS. Following settings need to be defined:

  1. The File format usually is radiobuttonon CSV (comma separated values). If another delimiter is used, activate the radiobuttonon custom delimiter radiobutton and if each line in the file is split using a regular expression, please activate the radiobuttonon Regular expression delimiter radiobutton.
  2. As Record options a text file usually provides a delimited header row of field names. This is usually the first line in the text file. If there is no header row available, deactivate the checkbox first records have field names checkbox. And if the header row isn’t the first line of the text file, define the number of header lines to discard.
  3. As Field options you can trim leading and trailing spaces from fields activating the checkbox Trim fields checkbox. You can checkbox Discard empty fields in each record and you can define that the checkbox Decimal separator is comma. Otherwise it will be point.
  4. As Geometry definitions a typical text file provides radiobuttonon Point coordinates. This means there must be an ‘X’ and ‘Y’ field with coordinate values. If the text file provides a radiobuttonon Well Known Text field, there must be a ‘WKT’ field with geometry information for point, line or polygon objects. These fields can have any name. Otherwise for attribute tables define radiobuttonon no geometry. The x and y coordinates must be specified as a number. The coordinate system is not important. If they are defined in degree/minutes/seconds, activate the checkbox DMS coordinates checkbox.
  5. As Layer settings you can activate checkbox Use spatial index to improve performance of displaying and spatially selecting features. You can define to checkbox Use Subset index and to checkbox Watch file to watch for changes to the file by other applications, while QGIS is running.

As an example of a valid text file we import the elevation point data file elevp.csv coming with the QGIS sample dataset (See Section Beispieldaten):

X;Y;ELEV
-300120;7689960;13
-654360;7562040;52
1640;7512840;3
[...]

Some items of note about the text file are:

  1. The example text file uses ; (semicolon) as delimiter. Any character can be used to delimit the fields.
  2. The first row is the header row. It contains the fields X, Y and ELEV.
  3. No quotes (") are used to delimit text fields.
  4. The x coordinates are contained in the X field.
  5. The y coordinates are contained in the Y field.

Using the function

Click the toolbar icon delimited_text Add Delimited Text Layer in the Manage layers toolbar to open the Create a Layer from a Delimited Text File dialog as shown in figure_delimited_text_1.

Figure Delimited Text 1:

../../../_images/delimited_text_dialog.png

Delimited Text Dialog nix

First select the file (e.g., qgis_sample_data/csv/elevp.csv) to import by clicking on the [Browse] button. Once the file is selected, QGIS attempts to parse the file using the last used delimiter, in this case a semicolon (;). To properly parse the file, it is important to select the correct delimiter. To change the delimiter to tab use \t (this is a regular expression for the tab character).

Once the file is parsed, make a Geometry definition radiobuttononPoint coordinates and choose the X and Y fields from the dropdown lists. Finally enter a Layer name (e.g., elevp) as shown in figure_delimited_text_1 . To add the layer to the map, click [OK]. The delimited text file now behaves as any other map layer in QGIS.